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CONSEQUENTIAL, INDIRECT, EXEMPLARY, SPECIAL, OR INCIDENTAL DAMAGES, INCLUDING ANY LOSS OF
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Included in the PlanAhead™ software source code is source code for the following programs:

Centerpoint XML

The initial developer of the Original Code is CenterPoint - Connective Software Engineering GmbH. Portions created by
CenterPoint - Connective Software Engineering GmbH. Copyright © Copyright IBM Corp. 1998 1998-2000 CenterPoint -
Connective Software Engineering GmbH. All Rights Reserved. Source Code for CenterPoint is available at
http://www.cpointc.com/XML/

NLView Schematic Engine

Copyright © Copyright IBM Corp. 1998 Concept Engineering.

Static Timing Engine by Parallax Software Inc.

Copyright © Copyright IBM Corp. 1998 Parallax Software Inc.

Java Standard Edition

Copyright © Copyright IBM Corp. 1998 1995 - 2006 Sun Microsystems

Includes portions of software from RSA Security, Inc. and some portions licensed from IBM are available at
http://oss.software.ibm.com/icu4j/.

Powered By JIDE - http://www.jidesoft.com

The BSD License for the JGoodies Looks

Copyright © Copyright IBM Corp. 1998 2001-2004 JGoodies Karsten Lentzsch. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following
conditions are met:

- Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer. 

- Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer
in the documentation and/or other materials provided with the distribution. 

- Neither the name of JGoodies Karsten Lentzsch nor the names of its contributors may be used to endorse or promote products
derived from this software without specific prior written permission. 

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND ANY
EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL
THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT
OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR
TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

http://japan.xilinx.com
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このマニュアルについて

このマニュアルには、 PlanAhead™ ソフ ト ウェアのインターフェイスの概要、 デザインやソフ ト

ウェアの機能の使用方法などの詳細な情報が含まれています。 

この章は、 次のセクシ ョ ンから構成されています。

• 「PlanAhead について」

• 「マニュアルの内容」

• 「その他のリ ソース」

• 「表記規則」

メモ : ソフ ト ウェアのインス トール方法およびシステム要件は、 『ISE Design Suite11 : インス トー

ル、 ライセンス、 およびリース  ノート 』 を参照してください。

PlanAhead について

PlanAhead は、 FPGA デバイスの設計に用いられるデザインおよび解析ソフ ト ウェア製品で、

FPGA インプリ メンテーシ ョ ン プロセスに対し、 直感的で統合された環境を提供します。

PlanAhead を使用する と、 デザイン RTL ソース、 合成されたネッ ト リ ス ト 、 およびインプリ メン

テーシ ョ ン結果を解析して回路のパフォーマンスを向上させるこ とができます。 また、 さまざまな

インプリ メンテーシ ョ ン オプシ ョ ンを試し、 タイ ミ ング制約を調整し、物理制約やフロアプランを

利用して、 デザイン結果を改善するこ とができます。 リ ソース数、 インターコネク ト遅延、 および

配線接続を早期に見積もるこ とで、適切なロジッ ク  デバイスの選択とフロアプランが容易になり ま

す。 階層的なデータベースを利用する と、 ブロ ッ ク  ベースのインク リ メンタル手法を使用できるた

め、 ランタイムおよびデザインの配置配線に必要な計算用のリ ソースを削減できます。 

PlanAhead の機能

• I/O ピン割り 当て環境

♦ インタラ クティブな自動 I/O 配置

♦ 関連 I/O をインターフェイスにグループ化

♦ 豊富なデザイン ルール チェッ ク  (DRC)

♦ WASSO 解析

♦ 互換性のあるデバイスへの置き換え

• RTL 開発および解析環境

♦ 合成を必要と しない RTL ソース  (Verilog および VHDL) のインポート およびエラボレー

ショ ン  

♦ 構文チェッ クを含む RTL エラボレーシ ョ ン

http://www.xilinx.com
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このマニュアルについて

♦ ク ロスプローブ可能な RTL エディ タ

♦ リ ソースの予測 

♦ RTL ネッ ト リ ス トおよび階層表示

♦ RTL 回路図

♦ RTL デザイン ルール チェッ ク  (DRC)

• 合成およびインプリ メンテーシ ョ ン環境

♦ 1 つまたは複数の実行の設定および起動

♦ 一般的に使用されるス ト ラテジの定義および適用

♦ 結果の監視および管理

♦ 結果のインポートおよび解析

♦ Linux での複数 CPU 機能

♦ Linux でのリモート  ホス ト

• デザイン解析

♦ インタラ クティブな回路図表示

♦ グラフ ィカルな階層表示

♦ ネッ ト リ ス トの階層表示と展開表示

♦ リ ソース使用率の統計 (配置配線前)

♦ デバイスまたはデザイン オブジェク トの高機能な検索機能

♦ デザイン メ ト リ ッ クの表示

♦ 関連情報を表示するオブジェク トのプロパティ

♦ デザイン ルール チェッ ク機能

♦ 接続の表示

♦ 配置解析およびハイライ ト表示

• スタティ ッ ク  タイ ミ ング予測 (TimeAhead)

• タイ ミ ング制約エディ タ

• 高度なフロアプラン環境

♦ 階層的なフロアプラン

♦ LOC 制約を割り当ておよび固定するための柔軟な機能

• ブロ ッ ク  ペース機能

♦ ブロ ッ ク  レベルのインプ リ メンテーシ ョ ン

♦ IP 作成および再利用

http://japan.xilinx.com
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Project Navigator 環境との統合

Project Navigator 環境との統合

PlanAhead は、 デザイン フローを通してデザイン結果を改善していくための環境を提供します。

Project Navigator と統合された PlanAhead は、4 つのデザイン プロセス  ステップで自動的に起動さ

せるこ とができます。 このステップには、 I/O ピン割り当て (合成前)、 I/O ピン割り当て (合成後)、
エ リ ア/IO/ロジッ クのフロアプラン (合成後)、 およびタイ ミ ング/フロアプラン デザイン解析 (イン

プリ メンテーシ ョ ン後) があ り ます。 スタンドアロンの PlanAhead では、 各ステップに特化した機

能だけを使用するこ とができます。 PlanAhead は、 PACE および Floorplanner に代わり、 FPGA デ
ザインの、 ピン配置、 デザイン表示、 フロアプラン フローのすべてを実行します。

PlanAhead が Project Navigator から起動される と、選択されたタスクに特化した PlanAhead 機能だ

けにアクセスできるインターフェイスが提供されます。このモードは、ISE® 統合モード と呼ばれま

す。 モードは PlanAhead ウ ィンド ウ下部にあるステータス  バーに表示されます。

マニュアルの内容

このマニュアルは、 次の章から構成されています。

• 第 1 章 「PlanAhead デザイン フローの理解」 では、PlanAhead の利点の概要、デザイン フロー

と  PlanAhead の機能の概要、 およびプロジェク トに必要な入出力項目を説明します。

• 第 2 章 「プロジェク トの作成および管理」 では、 PlanAhead のプロジェク トの初期セッ ト アッ

プおよび管理方法を説明します。

• 第 5 章 「Project Navigator からの PlanAhead の使用」 では、 Project Navigator と統合された

PlanAhead フローを説明します。

• 第 3 章 「表示環境の使用」 では、 PlanAhead のユーザー インターフェイスを説明します。

• 第 4 章 「I/O ピンの配置」 では、 ピン割り当てができる  PinAhead 環境を説明します。

• 第 6 章 「RTL デザインの作成および解析」 では、 PlanAhead の RTL 環境を説明します。

• 第 7 章「デザインのインプリ メンテーシ ョ ン」では、PlanAhead の合成およびインプリ メンテー

シ ョ ン環境を説明します。

• 第 8 章 「デザインの解析」 では、 PlanAhead のデザイン解析機能を説明します。

• 第 9 章 「インプリ メンテーシ ョ ン結果の解析」 では、 PlanAhead で使用可能なタイ ミ ングおよ

び配置解析機能を説明します。

• 第 10 章 「デザインのフロアプラン」 では、 フロアプラン制約の作成方法を説明します。

• 第 11 章 「ChipScope を使用したデザインのデバッグ」 では、 PlanAhead に統合された

ChipScope ソフ ト ウェアのデバッグ機能を説明します。

このマニュアルには、 次の付録があ り ます。

• 付録 A 「メニューおよびツールバー コマンド」 では、 メニューコマンドおよびツールバー コマ

ンドについて、 簡単に説明します。

• 付録 B 「XilinxUpdate を使用したインス トール」 では PlanAhead のインク リ メンタル リ リー

ス  ス ト ラテジおよびソフ ト ウェアのアップデート方法を説明します。

• 付録 C 「パスワードなしの SSH の設定」 では、PlanAhead のプロセスを複数のホス トで実行す

るために必要なパスワードなしの SSH の設定方法を説明します。

http://japan.xilinx.com
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その他のリソース

次のリ ソースも参照して ください。 詳細は、 ザイ リ ンクスの Web サイ ト 、 http://japan.xilinx.com/
planahead を参照してください。

ザイリンクスのト レーニング

• Designing with PlanAhead : サンプルデザインを使用して  PlanAhead の機能を学ぶコースです。 

資料

• 『ISE Design Suite11 : インス トール、ライセンス、およびリース  ノート 』 : インス トール手順お

よびシステム要件について説明します。このマニュアルはザイ リ ンクス  Web サイ トから入手で

きます。

• 『PlanAhead リ リース  ノート 』 : このリ リースの新機能に関する情報が提供されています。 ソフ

ト ウェアおよびザイ リ ンクスの Web サイ ト よ り入手できます。

• 『PlanAhead Methodology Guide』 : パフォーマンス向上、結果の再利用性、設計時間の短縮のた

めのさまざまなス ト ラテジが提供されています。 ソフ ト ウェアおよびザイ リ ンクスの Web サ
イ ト よ り入手できます。

• PlanAhead のチュート リ アル : PlanAhead には次のチュート リ アルが用意されています。 ソフ

ト ウェアおよびザイ リ ンクスの Web サイ ト よ り入手できます。

♦ ク イ ッ ク  フロー概要

♦ I/O ピン配置

♦ RTL 開発および解析

♦ デザイン解析およびフロアプラン

♦ PlanAhead および ChipScope を使用したデバッグ

ビデオ デモンスト レーシ ョ ン 
PlanAhead テクニカル ビデオ デモ : PlanAhead ソフ ト ウェアの機能の一部を取り上げたデモの動

画です。 ザイ リ ンクスの Web サイ ト (japan.xilinx.com/design) でのみ視聴できます。

表記規則

このマニュアルでは、 次の表記規則を使用しています。 各規則について、 例を挙げて説明します。

書体

次の規則は、 すべてのマニュアルで使用されています。

表記規則 使用箇所 例

Courier フォン ト
システムが表示する メ ッセージ、
プロンプ ト、プログラム ファ イル
を表示します。

speed grade: - 100

Courier フォン ト  
( 太字 )

構文内で入力するコマンドを示し
ます。

ngdbuild design_name

http://japan.xilinx.com/planahead
http://japan.xilinx.com
http://japan.xilinx.com/design
http://japan.xilinx.com/planahead
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表記規則

オンライン マニュアル

このマニュアルでは、 次の規則が使用されています。

イタ リ ッ ク  フォン ト
ユーザーが値を入力する必要のあ
る構文内の変数に使用します。

ngdbuild design_name

二重 / 一重かぎかっこ
『 』、 「」

『 』 はマニュアル名を、「 」 はセク
シ ョ ン名を示します。

詳細については、 『開発システム
リ ファレンス  ガイ ド』の「PAR」を
参照して ください。

角かっこ  [  ]

オプシ ョ ンの入力またはパラ メー
タを示しますが、 bus[7:0] のよ
う なバス仕様では必ず使用し ま
す。 また、 GUI 表記にも使用しま
す。

ngdbuild [option_name]
design_name

[File] → [Open] をク リ ッ ク し
ます。

中かっこ  {  } 1 つ以上の項目を選択するための
リ ス ト を示します。

lowpwr ={on|off}

縦棒  | 選択する リ ス トの項目を分離しま
す。

lowpwr ={on|off}

縦の省略記号
.
.
.

繰り返し項目が省略されているこ
とを示します。

IOB #1: Name = QOUT’ 
IOB #2: Name = CLKIN’
.
.
.

横の省略記号 . . . 繰り返し項目が省略されているこ
とを示します。

allow block  block_name loc1
loc2 ... locn;

表記規則 使用箇所 例

表記規則 使用箇所 例

青色の文字
マニュアル内の相互参照を示しま
す。

詳細については、「その他のリ ソー
ス」 を参照してください。

詳細については、 第 1 章 「タイ ト
ル フォーマッ ト 」 を参照してくだ
さい。

赤色の文字
ほかのマニュアルへの相互参照を
示します。

詳細については、 『XST ユーザー
ガイ ド』 の図 2-5 を参照してくだ
さい。

青色の下線付き文字
Web サイ ト  (URL) へのハイパー
リ ンクです。

最新のスピード  ファ イルは、
http://japan.xilinx.com から入手
できます。

http://japan.xilinx.com
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第 1 章

PlanAhead デザイン フローの理解

本章は、 次のセクシ ョ ンで構成されています。

• 「PlanAhead デザイン フロー」

• 「入力および出力ファイル」

• 「PlanAhead の用語」

 PlanAhead デザイン フロー

PlanAhead™ は FPGA デザイン フローのさまざまなポイン トでさまざまな方法で使用できます。

RTL 開発からビッ ト ス ト リーム生成まで網羅するフロー管理ツールと して、または I/O ピン割り当

て、 RTL ネッ ト リ ス ト解析、 インプリ メンテーシ ョ ン結果デザイン解析、 フロアプラン、

ChipScope™ ツールを使用したコア挿入とデバッグを目的に使用するこ とができます。 

解析およびフロアプランを通して、 デザインのインプリ メンテーシ ョ ンを制御するために物理制約

が付けられますが、PlanAhead 環境ではさまざまなインプリ メンテーシ ョ ン ス ト ラテジを試すこ と

ができ、 この環境内でインプリ メンテーシ ョ ンの試みとデータすべてを管理できます。 また、 イン

プリ メンテーシ ョ ン後のデザイン パフォーマンス改善のために、 ISE® での配置およびタイ ミ ング

結果の解析にも  PlanAhead が使用されます。 インポート した結果から派生する追加の物理制約は、

後続のインプ リ メ ンテーシ ョ ン中に配置を固定するために使用する こ と もできます。 次のフロー

チャートは、一般的なデザイン フローと  PlanAhead の入力および出力フォーマッ ト を示したもので

す。
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第 1 章 : PlanAhead デザイン フローの理解

PlanAhead 11 では、RTL ソースのインポート、ロジッ クの合成、合成ネッ ト リ ス トのインプリ メン

ト 、 インプ リ メンテーシ ョ ン結果の解析、 フロアプラン、 インプリ メンテーシ ョ ン オプシ ョ ンの設

定、ビッ ト ス ト リーム生成まで、実行できるよ うになっていて、完全なデザイン環境と ソ リ ューシ ョ

ンが提供できるよ うになっています。

PlanAhead では、 複数の合成およびインプ リ メンテーシ ョ ン実行を同時に試行できるよ う、 デザイ

ン フローとデータが管理されます。以前のバージ ョ ンでは、PlanAhead プロジェク トはインポート

されたネッ ト リ ス ト  1 つのみで構成され、 このネッ ト リ ス トから制約を読み込んで複数のフロアプ

ランが作成されていました。 フロアプランの作成が常に必要で、 ネッ ト リ ス トは PlanAhead セッ

シ ョ ン中にメモ リに読み込まれていました。

基本デザイン フロー

基本フローは、簡単に RTL ソースをインポート し、デザインを合成・ インプリ メン ト して、その結

果を確認できるので、 デザインを最初にインプリ メン トする と きによ く使用されます。 さ らにデザ

イン解析およびフロアプランが必要となる場合は、デザイン解析フローを使用する必要があ り ます。

実行試行フロー

異なるス ト ラテジを設定し、 複数の合成やインプ リ メ ンテーシ ョ ン実行を試すこ とができます。

PlanAhead には予め定義されたス ト ラテジのセッ トがあ り ますが、 ユーザーがス ト ラテジを定義す

るこ と もできます。 

PlanAhead の合成およびインプ リ メンテーシ ョ ン環境では、 ザイ リ ンクスの XST 合成ツールを使

用し、 複数の合成実行を設定、 起動、 管理できます。 合成実行に対し再利用可能なス ト ラテジを定

図 1-1 : PlanAhead デザイン フローおよび入力 ・ 出力フォーマッ ト
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入力および出力ファイル

義するこ と もできます。 たとえば、 電力、 パフォーマンス、 エ リ ア最適化のス ト ラテジを作成でき

ます。 こ う したス ト ラテジを個々の実行に設定し、 同時にまたは順々に起動していきます。 合成の

実行結果はインタラ クティブに表示され、 レポート  ファ イルにも簡単にアクセスできます。

複数の合成ス ト ラテジを実行する と  PlanAhead プロジェク ト内に複数のネッ ト リ ス トが作成され

保存されます。 複数あるネッ ト リ ス トはインタラ クティブに解析環境に読み込むこ とができます。

ネッ ト リ ス トのインポート中に、 I/O ピン割り当て、デバイス解析、フロアプランニング、およびイ

ンプリ メンテーシ ョ ン用にフロアプランが作成できます。 

インプリ メンテーシ ョ ン実行は、完了した PlanAhead 合成実行、 フロアプラン、 またはインポート

されたサードパーティの合成ネッ ト リ ス トから作成できます。 フロアプランを作成するこ とで、 さ

まざまな論理制約、物理制約、代替デバイスを設定して試すこ とができます。インプリ メンテーシ ョ

ン実行に対し再利用可能なス ト ラテジを定義するこ と もできます。 たとえば、 マップによるロジッ

ク最適化や配置配線エフォート  レベルのス ト ラテジを作成し、こ う したス ト ラテジを個々の実行に

設定し、 同時にまたは順々に起動していきます。 インプリ メンテーシ ョ ンの実行結果はインタラ ク

ティブに表示され、 コマンド  レポート  ファ イルにも簡単にアクセスできます。

デザイン解析およびフロアプラン フロー

PlanAhead には、デザイン プロセスのさまざまなステージで使用可能な高度なデザイン解析および

フロアプラン機能があ り ます。 RTL は合成前にエラボレートおよび解析できます。合成ネッ ト リ ス

トでさまざまなターゲッ ト  デバイスおよび制約を設定して試行できます。さ らに解析およびフロア

プランを実行するには、 インプ リ メンテーシ ョ ン実行を PlanAhead 環境にインポート します。 コマ

ンド  ライン ツールからのインプリ メンテーシ ョ ン結果もインポートできます。

デザイン解析およびフロアプランのフロー機能は、この資料の該当セクシ ョ ンを参照してください。

入力および出力ファイル

PlanAhead の入力 
このセクシ ョ ンでは、デザイン データをインポートする と きに使用されるフォーマッ トおよび手順

を簡単に説明します。

入力ファイルは次のとおりです。

• 「RTL ソース  ファ イル (Verilog または VHDL、 その他のデザイン テキス ト  ファ イル)」 

• 「ザイ リ ンクス  コア (NGC/NGO)」

• 「XST 制約ファイル (XCF)」

• 「I/O ポート  リ ス ト  (CSV)」

• 「I/O ポート  リ ス ト  (HDL - Verilog または VHDL)」 

• 「最上位ネッ ト リ ス ト  (EDIF)」

• 「モジュール レベルのネッ ト リ ス ト  (EDIF)」

• 「最上位ネッ ト リ ス ト  (NGC)」

• 「制約ファイル (UCF/NCF)」

• 「ザイ リ ンクス  ISE 配置結果 (NCD/XDL)」

• 「ザイ リ ンクス  TRCE タイ ミ ング結果 (TWR)」
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PlanAhead では、 入力ファイルの読み込み中に発生するエラー、 警告、 およびメ ッセージが

planAhead.log ファ イルに書き込まれます。これらのメ ッセージは、PlanAhead の [Console] ウ ィン

ド ウにも表示されます。 

RTL ソース ファイル (Verilog または VHDL、 その他のデザイン テキスト  ファイル)
Verilog や VHDL ファ イルをインポートおよびエラボレート して、 ロジッ クを解析したり、 ソース

を修正するこ とができます。 元のソースファイルはそのままの位置で参照するこ と も、 プロジェク

トにコピーするこ と もできます。検索ディ レク ト リは、RTL ソース  ファ イルのインポート時に指定

します。 ディ レク ト リに含まれた認識可能なファイルおよびファイルタイプはすべてプロジェク ト

にインポート されます。 

ザイリンクス コア (NGC/NGO)
PlanAhead では、ザイ リ ンクス  コア ファ イルや XST 出力ネッ ト リ ス ト などの NGC フォーマッ ト

のネッ ト リ ス ト を使用するデザインがサポート されています。ただし、NGC ファ イルが最上位ネッ

ト リ ス ト なのか、またはモジュール レベルのネッ ト リ ス ト なのかによって、PlanAhead での処理は

異なり ます。PlanAhead でネッ ト リ ス トがインポート される と き、NGC および NGO フォーマッ ト

のコア ファ イルは EDIF に自動的に変換されます。 NGC ファ イルは、ザイ リ ンクス  ngc2edif コマ

ンドを使用して変換されます。NGO ファ イルは、ザイ リ ンクスの ngcbuild および ngc2edif を使用

して変換されます。 

セキュ リティ保護されているコアの場合は、LUT 式が変換された EDIF から削除されます。 この種

類の NGC および NGO コア ファ イルは、 通常パフォーマンスを最大にするために細心の注意を

払って手動で配置されているため、フロアプランでパフォーマンスが向上するこ とはあ り ません。こ

のため、 コア モジュール内のロジッ クはフロアプランしないでください。 ただし、 このコア全体お

よびその周辺ロジッ クのロケーシ ョ ンを効率的にフロアプランするこ とはできます。

[Export Floorplan] および [Save Floorplan] コマンド  (第 10 章 「デザインのフロアプラン」 を参照)
を実行する と、NGC および NGO コア ロジッ クはネッ ト リ ス トから除外され、ブラ ッ クボッ クス  モ
ジュールが作成されます。 元の NGC および NGO コア ファ イルは、 保存ディ レク ト リ またはエク

スポート  ディ レク ト リにコピーされ、 ISE インプリ メンテーシ ョ ンで使用されます。 

メモ : ngc2edif コマンドの出力ログは、PlanAhead を起動したターミナル ウ ィンド ウに表示されま

す。ngc2edif コマンドでは、使用が不可能であったり対応する  NCF 制約と一致しなくなったり した

EDIF ファ イルが生成される場合があ り ます。このよ うな問題が発生した場合は、問題を再現するた

めのデータを電子メールでザイ リ ンクスまで送信して ください。 また、 コアをインポートせずにフ

ロアプランを継続できます。 PlanAhead では、 見つからないロジッ クに対してブラ ッ クボッ クスが

作成されます。 この場合、 NGC コア ファ イルのネッ ト リ ス ト を ISE の実行ディ レク ト リにコピー

します。

XST 制約ファイル (XCF)
PlanAhead では、XST 合成実行を設定するための XST 制約ファイル (XCF) がサポート されていま

す。 

I/O ポート  リス ト  (CSV)
CSV (カンマ区切り ) フォーマッ ト  ファ イルは、インポート して PlanAhead の [I/O Ports] ウ ィンド

ウに表示できます。これらの I/O ポート を物理パッケージ ピンに割り当てて、デバイス  ピンの設定

を定義できます。 CSV ファ イルの内容およびフォーマッ トの詳細は、 第 4 章 「I/O ピンの配置」 を

参照して ください。
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I/O ポート  リス ト  (HDL - Verilog または VHDL)
Verilog または VHDL フォーマッ ト  ファ イルのヘッダにはポートが含まれており、インポート して

PlanAhead の [I/O Ports] ウ ィンド ウに表示できます。これらの I/O ポート を物理パッケージ ピンに

割り当てて、デバイス  ピンの設定を定義できます。HDL ファ イルの内容およびフォーマッ トの詳細

は、 第 4 章 「I/O ピンの配置」 を参照してください。

最上位ネッ ト リス ト  (EDIF)
現バージ ョ ンの PlanAhead では、 EDIF ネッ ト リ ス トのインポートがサポート されています。 この

ネッ ト リ ス トは、 Virtex®-4、 Virtex-5 または Spartan®-3 デバイスの合成に使用されます。 

PlanAhead では、階層デザイン手法をサポートする複数の EDIF ネッ ト リ ス ト を使用してデザイン

を構築できます。最上位ロジッ クを選択する と、下位のモジュールが自動的にインポート されます。

インク リ メンタルなネッ ト リ ス トのインポート機能では、 どのレベルのデザイン階層のネッ ト リ ス

トでも更新できます。 作成中のフロアプラン制約は、 更新されても保持されます。 

モジュール レベルのネッ ト リス ト  (EDIF)
PlanAhead では、階層デザイン手法をサポートする複数の EDIF ネッ ト リ ス ト を使用してデザイン

を構築できます。最上位ロジッ クを選択する と、下位のモジュールが自動的にインポート されます。

デザイン モジュールを検索する検索パスを定義できるため、デザインをアップデートする と き非常

に柔軟に対応できます。PlanAhead には、強力なインク リ メンタル ネッ ト リ ス ト  インポート機能が

あ り、 どのレベルのデザイン階層のネッ ト リ ス トでも更新できます。 

最上位ネッ ト リス ト  (NGC)
最上位に NGC ファ イルを使用する場合、PlanAhead ではインポート  プロセス中に自動的にファイ

ルが EDIF フォーマッ トに変換されます。XST で生成される最上位の NGC フォーマッ ト  ファ イル

は、 ngc2edif コマンドを使用して変換されます。 ISE でインプリ メンテーシ ョ ンするためにデザイ

ンを PlanAhead からエクスポートする と きは、 最上位ロジッ クのネッ ト リ ス トが NGDBuild で使

用される  EDIF フォーマッ トでエクスポート されます。 このプロセスは、 コア レベルの NGC また

は NGO ファ イルをエクスポートするプロセスとは異なり ます。 コアまたはモジュール レベルの

ネッ ト リ ス トの詳細は、 次を参照して ください。

制約ファイル (UCF/NCF)
PlanAhead では、タイ ミ ング制約および物理制約用の UCF および NCF フォーマッ ト  ファ イルのイ

ンポートがサポート されています。 PlanAhead では、 複数の UCF ファ イルをインポートできるの

で、 物理制約、 I/O 制約、 およびタイ ミ ング制約を区別するこ とができます。 

NCF ファ イルなど、コア特有のモジュール レベルの制約もインポートできます。詳細は、「モジュー

ル レベルの制約のインポート 」 を参照してください。

PlanAhead ではザイ リ ンクスでサポート されている  UCF 制約がすべてサポート されています。

UCF 制約およびサポート される構文の詳細は、ザイ リ ンクスの 『制約ガイ ド』 を参照してください。

ザイリンクス ISE 配置結果 (NCD/XDL)
PlanAhead では、XDL フォーマッ ト  データを使用して ISE 配置結果をインポートできます。XDL
データはインプリ メンテーシ ョ ン実行が PlanAhead から起動される と自動的に作成されます。

ISE コマンドが正し く実行されれば、XDL ファ イルは <placed_design_name>.ncd ファ イルから作

成できます。XDL ファ イルを作成したら、個々のブロ ッ クまたはデザイン全体の配置をインポート

できます。
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[Import Placement] コマンドを使用して、<placed_design_name>.ncd ファ イルを指定する と、XDL
コマンドが自動的に実行されます。

手動でこのコマンドを実行するには、 ファ イル構文は次のとおりです。

xdl –ncd2xdl <placed_design_name>.ncd

このコマンドを実行する と、 <placed_design_name>.xdl ファ イルが生成されます。 

XDL コマンドのステータスは、 PlanAhead のターミナル ウ ィンド ウに表示されます。

ザイリンクス TRCE タイ ミ ング結果 (TWR)
PlanAhead では、ザイ リ ンクス  trce コマンドで生成されるタイ ミ ング レポート をインポートできま

す。インポートする と、すべての信号ト レースおよび選択が [Run TimeAhead] ダイアログ ボッ クス

に表示されます。 

レポートの出力 
このセクシ ョ ンでは、通常 PlanAhead デザイン操作で生成されるファ イルについて簡単に説明しま

す。 これらのファイルは、 重要な情報が含まれている可能性があ り ます。 最後の 2 つのレポートは

自動的には生成されないため、 ユーザーが作成する必要があ り ます。

出力ログおよびレポート  ファ イルは次のとおりです。

• 「I/O ピン割り当て (CSV)」

• 「I/O ピン割り当て (HDL - Verilog または VHDL)」 

• 「ログ ファ イル (planAhead.log)」

• 「ジャーナル ファ イル (planAhead.jou)」

• 「エラー ログ ファ イル (planAhead_pidxxxx.debug および hs_err_pidxxxx.log)」

• 「DRC 結果 (results_x_drc.txt)」

• 「TimeAhead の結果 (Excel ファ イル)」

• 「ネッ ト リ ス ト  モジュール、 Pblock、 およびクロ ッ ク領域統計レポート 」

• 「WASSO 解析レポート 」

I/O ピン割り当て (CSV)
この CSV (カンマ区切り ) フォーマッ ト  ファ イルには、 すべての I/O ポートの割り当てと関連する

ピン パッケージ情報が含まれています。 このファ イルは、 RTL ポートのヘッダ定義および PCB 回
路シンボル生成で使用されます。 詳細は、 第 4 章 「I/O ピンの配置」 を参照してください。

I/O ピン割り当て (HDL - Verilog または VHDL)
この Verilog または VHDL フォーマッ ト  ファ イルのファイル ヘッダでは、 すべての I/O ポートの

割り当てがポート と して定義されています。 このファイルは、 RTL ポートのヘッダ定義で使用され

ます。 詳細は、 第 4 章 「I/O ピンの配置」 を参照してください。

ログ ファイル (planAhead.log)
ログ ファ イル planAhead.log には、PlanAhead のコマンドを実行したと きに生成される メ ッセージ

の内容が含まれています。 このファ イルは PlanAhead の起動ディレク ト リ  (Linux) または

C:\Documents and Settings\<user>\Application Data\HDI (Windows) に作成されます。

[Window] → [View Log File] をク リ ッ クする と  PlanAhead でこのファイルを表示できます。
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ジャーナル ファイル (planAhead.jou)
ジャーナル ファ イル planAhead.jou には、起動した PlanAhead セッシ ョ ンの TCL コマンドすべて

が含まれています。 このファ イルは PlanAhead の起動ディレク ト リ  (Linux) または C:\Documents
and Settings\<user>\Application Data\HDI (Windows) に作成されます。ジャーナル ファ イルを再生

する と、 そのセッシ ョ ンで使用したコマンドを再利用できます。 TCL スク リプ トは、 ジャーナル

ファイルからコマンドをコピーする と生成できます。 このファ イルでは、 破損したコマンドまたは

再生する前の複数の PlanAhead セッシ ョ ンのコマンドを削除する必要がある場合があ り ます。

メモ : PlanAhead の操作には、 ジャーナル ファ イルに TCL コマンド と して書き込まれないものも

あ り ます。 

エラー ログ ファイル (planAhead_pidxxxx.debug および hs_err_pidxxxx.log)
これらのエラー ログ ファ イルには、PlanAhead 開発チームがエラーをデバッグする と きに役立つ重

要な情報が含まれています。PlanAhead で内部例外エラーの警告ダイアログ ボッ クスが表示される

と、これらのファイルが PlanAhead の起動ディ レク ト リ  (Linux) または C:\Documents and Settings
\<user>\Application Data\HDI (Windows) に保存されます。 これらのエラーを解決するために、

PlanAhead ジャーナル ファ イル （planAhead.jou) およびエラー ログ ファ イル  (planAhead.log) を
ザイ リ ンクス  PlanAhead 開発チーム planahead_errors@xilinx.com まで電子メールで送信してく

ださい。 これらのファイルにはデザイン データは含まれていません。

DRC 結果 (results_x_drc.txt)
デザインルール チェッ ク  (DRC) の結果は results_x_drc.txt に書き込まれ、PlanAhead 起動ディ レク

ト リ  (Linux)、 または C:\Documents and Settings\<user>\Application Data\HDI (Windows) に保存

されます。DRC が実行されるたびに、PlanAhead の DRC ダイアログ ボッ クスに表示される結果を

反映する内容の新しいファイルが生成されます。

TimeAhead の結果 (Excel ファイル) 
TimeAhead タイ ミ ング解析の結果は、テキス ト  ファ イルにエクスポートできます。データをエクス

ポートするには、 [Timing Results] ウ ィンド ウで [Export to Text File] アイコンをク リ ッ ク します。

ネッ ト リス ト  モジュール、 Pblock、 およびクロック領域統計レポート

[Instance Properties]、 [Clock Regions Properties]、 および [Pblock Properties] ウ ィンド ウに表示さ

れる リ ソース統計はマイクロソフ トの Excel 形式のファイルにエクスポートできます。 このファ イ

ルには、 リ ソース使用率、RPM、 キャ リー チェーンのサイズ、 ク ロ ッ クおよびクロ ッ クが供給され

るインスタンス、 およびその他のリ ソースのデータなどの情報が含まれます。

データをエクスポートするには、これらのウ ィンド ウの [Statistics] タブで [Save statistics to file] ボ
タンをク リ ッ ク します。ダイアログ ボッ クスが表示され、 レポートに含める情報や階層のレベル数

を定義でき、 ファ イル名および保存場所を指定できます。

WASSO 解析レポート

PlanAhead WASSO 解析の結果は、[Run WASSO Analysis] ダイアログ ボッ クスでファイル名およ

びファイルを保存する位置を指定して、 レポート  ファ イルにエクスポートできます。

デフォルト環境の出力

このセクシ ョ ンでは、通常 PlanAhead デザイン操作で生成されるファ イルについて簡単に説明しま

す。 これらのファイルは、 重要な情報が含まれている可能性があ り ます。 最後の 2 つのレポートは

自動的には生成されないため、 ユーザーが作成する必要があ り ます。
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出力ファイルは次のとおりです。

• 「ウ ィ ンド ウ表示オプシ ョ ン ファ イル (planAhead.ini と  <theme_names>.patheme)」

• 「ウ ィ ンド ウ  レイアウ ト  ファ イル (<layoutname>.layout)」

• 「シ ョート カッ ト  (default.xml)」

• 「ス ト ラテジ ファ イル (<strategyname>.psg)」

ウィンドウ表示オプシ ョ ン ファイル (planAhead.ini と  <theme_names>.patheme)
初期化ファイル planAhead.ini には、表示色など  PlanAhead 環境での表示オプシ ョ ンをはじめとす

る現時点でのツールのオプシ ョ ン設定がすべて含まれています。 PlanAhead を閉じる と きに、 カス

タム設定が次の PlanAhead セッシ ョ ンで使用できるよ うに保存されます。 このファ イルは、自動的

にホーム ディ レク ト リに書き込まれます。 

Windows では通常、 このファイルは C:\Documents and Settings\<Username>\Application Data
\HDI\<version_number>\planAhead.ini に保存されます。PlanAhead を起動する と、まず最初にこの

ファイルが自動的に PlanAhead のインス トール ディ レク ト リからインポート されます。 その後、

C:\Documents and Settings\<Username>\Application Data\HDI\<version_number>\ ディ レク ト リ

にこのファ イルがある場合はそこからインポート されます。

Linux では、通常 ~/.HDI/planAhead.ini が初期化ファイルです。PlanAhead を起動する と、このファ

イルが PlanAhead のインス トール ディ レク ト リから自動的にインポート され、続けて  ~/.HDI ディ

レク ト リにこのファ イルがある場合は、 インポート されます。

カスタムのテーマ ファ イルを今後のセッシ ョ ンで使用できるよ うにするには [PlanAhead Options]
ダイアログ ボッ クスの [Themes] ページで [Save As] をク リ ッ ク し、 保存します。 このページは、

[Tools] → [Options] → [Themes] をク リ ッ クする と表示されます。プルダウン メニューで、作業中

の PlanAhead セッシ ョ ンに使用するテーマ ファ イルを選択できます。詳細は、「カスタム テーマの

作成および使用」 を参照して ください。

[Themes] ページに含まれる  [PlanAhead Light Theme] または [PlanAhead Dark Theme] を選択する

と、 あらかじめ設定されているデフォルト設定で C:\Documents and Settings\<Username>
\Application Data\HDI\<version_number>\planAhead.ini (Windows) および ~/.HDI/planAhead.ini
(Linux) が上書きされます。カスタム設定が失われないよ うに、カスタム設定ファイルのバッ クアッ

プを保存しておいてください。

ウィンドウ レイアウト  ファイル (<layoutname>.layout)
ウ ィンド ウ  レイアウ ト  ファ イルは、 [Save Layout As] または [Save as Default Layout] コマンドを

使用して生成されます。 このファ イルには、現在の PlanAhead のデスク ト ップ表示設定が再び使用

できるよ うに保存されます。 フロアプランおよびプロジェク ト表示環境の両方の設定が、 次のサブ

ディ レク ト リに保存されます。 

Windows では通常、 このファイルは C:\Documents and Settings\<Username>\Application Data
\HDI\<version_number>\layouts\floorplan_layout または project_layout に保存されます。

PlanAhead ウ ィンド ウ全体のサイズおよびロケーシ ョ ンは、 C:\Documents and Settings
\<Username>\Application Data\HDI\<version_number>\layouts\application_layout ディ レク ト リに

保存されます。 

Linux では、 データは ~/.HDI ディ レク ト リに作成および保存されます。

シ ョート カッ ト  (default.xml)
アクセラレータ  キー定義 (シ ョート カッ ト  スキーマ) は、 [Tools] → [Options] で表示される

[PlanAhead Options] ダイアログ ボッ クスを使用して作成します。 これは PlanAhead コマンドへの
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キーワード  シ ョート カッ トのマップを定義します。 たとえば、 Ctrl + F はデフォルトで [Edit] →
[Find] コマンドにマップされています。 スキーマは複数定義するこ とができ、 default.xml ファ イル

に保存されます。 

Windows では通常、 このファイルは C:\Documents and Settings\<Username>\Application Data
\HDI\<version_number>\shortcuts に保存されます。 

Linux では、 ~/.HDI/shortcuts ディ レク ト リに作成および保存されます。

スト ラテジ ファイル (<strategyname>.psg)
ス ト ラテジ ファ イルには、ISE インプリ メンテーシ ョ ン コマンドすべてに対するユーザー指定のデ

フォルトのコマンド  ライン オプシ ョ ンが含まれています。ス ト ラテジは、PlanAhead を使用したど

の ISE インプリ メンテーシ ョ ン実行にも適用でき、最初から作成したり、 または提供されているス

ト ラテジをコピーするこ とができます。ユーザー定義のス ト ラテジは、 ホーム  ディ レク ト リに保存

されます。 

Windows では通常、 このファイルは C:\Documents and Settings\<Username>\Application Data
\HDI\<version_number>\strategies に保存されます。

Linux では、 ~/.HDI/ strategies ディ レク ト リに作成および保存されます。

プロジェク ト  データの出力

このセクシ ョ ンでは、 PlanAhead プロジェク トおよびフロアプランで生成されるファ イルについて

簡単に説明します。 これらのファイルは、 PlanAhead で管理されるので、 手動で変更しないでくだ

さい。 プロジェク トの出力ファイルは次のとおりです。

• 「プロジェク ト  ディ レク ト リ  (<projectname>)」

• 「プロジェク ト  ファ イル (<projectname>.ppr)」

• 「プロジェク ト  データ  ディ レク ト リ  (<projectname>.data)」

• 「プロジェク ト  データ  - ネッ ト リ ス ト  サブディレク ト リ  (ネッ ト リ ス ト )」

• 「プロジェク ト  データ  - フロアプラン サブディレク ト リおよびファイル (<floorplan_name>)」

• 「プロジェク ト  RTL ディレク ト リ  (<projectname>.srcs)」

プロジェク ト  ディ レク ト リ  (<projectname>) 
新しいプロジェク トが作成される と、PlanAhead ではプロジェク ト  ファ イル、プロジェク ト  データ

ディ レク ト リ 、および ISE インプリ メンテーシ ョ ン結果を含めるプロジェク ト  ディ レク ト リが作成

されます。このディ レク ト リには、New Project ウ ィザードで入力したプロジェク ト名と同じ名前が

付けられます。 

プロジェク ト  ファイル (<projectname>.ppr)
プロジェク トの PPR ファ イルには、 プロジェク トのステートが保存されます。 このファイルには、

プロジェク トに含まれるネッ ト リ ス ト と複数のフロアプランに関する情報が含まれます。 このファ

イルは、 PlanAhead を起動している間継続して管理されるので、 保存する必要はあ り ません。 この

ファ イルは、 手動で変更しないでください。 

PPR ファ イルは、既存のプロジェク ト を開く と きに PlanAhead ブラウザで選択するファイルです。
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プロジェク ト  データ  ディ レク ト リ  (<projectname>.data)
プロジェク ト  データ  ディ レク ト リには、プロジェク ト内のすべてのフロアプランとネッ ト リ ス ト関

連データが含まれます。 これらのフォルダは、 PlanAhead で管理されるため、 ユーザーが管理する

必要はあ り ません。 

注意 : これらのファイルを変更する と、 プロジェク ト  データが破損する可能性があ り ます。

プロジェク ト  データ  - ネッ ト リス ト  サブディ レク ト リ  (ネッ ト リス ト )
Netlist というサブディレク ト リには、 デザイン全体のネッ ト リ ス トのコピーが保存されます。 

RTL ベースのプロジェク トの場合、 各合成実行に対しサブディレク ト リが作成され、 生成された

ネッ ト リ ス トが保存されます。 このディ レク ト リは合成実行がリセッ ト されるたびにリ フレッシュ

されます。

ネッ ト リ ス ト  ベースのプロジェク トの場合、インポート されたネッ ト リ ス ト を含む 1 つのネッ ト リ

ス ト  ディ レク ト リが作成され、デザインで使用された NGC コア ファ イルのすべてのコピーも こ こ

に保存されます。 [File] → [Update Netlist] コマンドを使用する と、 このサブディ レク ト リの内容を

アップデートできます。

プロジェク ト  データ  - フロアプラン サブディ レク ト リおよびファイル 
(<floorplan_name>)

フロアプランが作成される と、それに対応したサブディ レク ト リが <projectname>.data ディ レク ト

リに作成されます。

このディ レク ト リに含まれるファ イルは、 次のとおりです。

• *.ucf  : インポート された UCF ファ イルすべて。入力ファイルによって異なる場合があ り ます。

• fp.ucf : フロアプランの PlanAhead 制約が含まれます。

• iseloc.xml : PlanAhead で固定されている配置制約と  ISE からインポート された固定されてい

ない配置制約を区別するのに使用します。 

• pfi.xml : フロアプランのターゲッ ト  デバイスが含まれています。

• pfp.xml : フロアプランに対する現時点での PlanAhead の実行情報が含まれています。

• expX サブディ レク ト リ  : PlanAhead の各実行情報が含まれています。

プロジェク ト  RTL ディ レク ト リ  (<projectname>.srcs)
プロジェク ト  ソース  ディ レク ト リには、プロジェク トにインポート された HDL ソース  ファ イルが

すべて格納されます。 これらのフォルダは、 PlanAhead で管理されるため、 ユーザーが管理する必

要はあ り ません。 

注意 : これらのファイルを変更する と、 プロジェク ト  データが破損する可能性があ り ます。
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ISE インプリ メンテーシ ョ ンの出力

このセクシ ョ ンでは、PlanAhead の ISE インプリ メンテーシ ョ ン デザイン操作で生成されるファ イ

ルについて簡単に説明します。 これらのファイルは、 PlanAhead で管理されるので、 手動で変更し

ないでください。 

ISE インプ リ メンテーシ ョ ンの出力ファイルは次のとおりです。

• 「実行ディ レク ト リ  (<projectname>.runs)」

• 「EDIF ネッ ト リ ス ト  (.edf)」

• 「ザイ リ ンクス  コア (.ngc/.ngo)」

• 「ChipScope コア ネッ ト リ ス ト  (.ngc)」

• 「制約ファイル (.ucf)」

• 「ISE 起動スク リプ ト  (jobx.bat/sh、 runme.bat/sh および .<ISE_command>.rst)」

実行ディレク ト リ  (<projectname>.runs)
PlanAhead では、 複数の ISE インプリ メンテーシ ョ ンの実行をキューに含めて順番に実行できま

す。 このと き、実行ディ レク ト リの場所を指定するダイアログ ボッ クスが表示されます。デフォル

トでは、 保存先にプロジェク ト  ディ レク ト リが表示されます。

各実行ディ レク ト リには完全な EDIF ネッ ト リ ス トおよび UCF 制約ファイルが含まれています。

ISE コマンドを指定のオプシ ョ ンで起動する実行スク リプ ト も各 PlanAhead 実行ディ レク ト リに

作成されます。

各実行ディ レク ト リには、 ネッ ト リ ス トおよび制約ファイルを含むすべてのインプリ メンテーシ ョ

ン デザイン データが保存されています。 要件を満たしたインプリ メンテーシ ョ ンが達成される と、

実行ディ レク ト リ全体をアーカイブするこ とができます。 

EDIF ネッ ト リス ト  (.edf)
PlanAhead は ASCII 形式のネッ ト リ ス ト をエクスポート します。このファ イルは、次のコマンドを

実行する と生成されます。

• [Run Implementation] および [Launch Runs] (PlanAhead)

• [File] → [Export Netlist]

• [File] → [Export Pblocks]

• [File] → [Export IP]

インプリ メンテーシ ョ ンの実行および実行の起動

このコマンドを実行する と、 PlanAhead の実行に必要なファイルが自動的にエクスポート され、 こ

の実行に適用するス ト ラテジで指定したオプシ ョ ンを使用して ISE コマンドが実行されます。

このコマンドが使用される と、EDIF および UCF データが自動的にエクスポート されます。実行を

起動する と、最上位デザインの EDIF フォーマッ トのネッ ト リ ス トおよび UCF フォーマッ トの制約

ファイルを含む実行ディ レク ト リが作成されます。 ファ イル名は、 インポート された EDIF ファ イ

ルの元の最上位ネッ ト リ ス ト名と同じです。 

NGC/NGO フォーマッ トのモジュールのネッ ト リ ス ト  ファ イルが使用されている場合は、 各実行

ディ レク ト リにこれらがコピーされます。

実行ディ レク ト リの場所は、 PlanAhead の [Run Properties] ウ ィンド ウで確認できます。
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エクスポート されたネッ ト リス ト

ネッ ト リ ス トは、PlanAhead 環境外の ISE インプリ メンテーシ ョ ン用にデザインの EDIF ファ イル

を提供するためにエクスポート します。 出力ネッ ト リ ス トには元の論理ネッ ト リ ス トの階層が含ま

れています。 出力ファイル名は [Export Netlist] ダイアログ ボッ クスで指定できます。

エクスポート された Pblock

特定の Pblock の EDIF および UCF ファ イルを PlanAhead 環境外の ISE インプリ メンテーシ ョ ン

で使用するには、 Pblock をエクスポート します。

Pblock がエクスポート される と、 PlanAhead で Pblock のロジッ ク割り当てに基づいてネッ ト リ ス

トが作成されます。EDIF およびモジュール ポート  リ ス トが生成され、PlanAhead の物理階層構造

が使用されます。EDIF ネッ ト リ ス トが 1 つ生成され、 こ こに Pblock に割り当てられたロジッ クが

すべて含まれます。このため、ブロ ッ ク  ベースのインプリ メンテーシ ョ ン ス ト ラテジを使用する と

きに非常に柔軟に対応できるよ うにな り ます。 

エクスポート される  Pblock ファ イルは、選択した各 Pblock に対しネッ ト リ ス ト  1 つ、制約ファイ

ル 1 つです。ブロッ ク  レベルのディレク ト リ構造が自動的に作成、管理されるので、ブロ ッ ク  ベー

スの ISE アプローチが簡単になり ます。 選択した Pblock をエクスポートする と、

<pblockname>_CV.edn および <pblockname>_CV.ucf ファ イルを含む <pblockname>_CV サブ

ディ レク ト リが作成されます。 

エクスポート された IP

再利用可能な IP ブロ ッ クの作成に使用する指定のネッ ト リ ス ト  モジュールの EDIF および UCF
ファ イルを書き出すために IP をエクスポート します。 

[Export IP] コマンドはデザインで選択したネッ ト リ ス ト階層で実行します。RPM も  IP モジュール

の出力と して作成できます。エクスポート  ファ イルには、元のネッ ト リ ス ト  フォーマッ トの EDIF
ネッ ト リ ス トおよび UCF 物理制約が含まれます。インターフェイスをそのまま保持するこ とで、次

のデザインのインプリ メンテーシ ョ ンが簡単に実行できます。 エクスポート された EDIF ファ イル

を使用して、ブラ ッ ク  ボッ クスの RTL モジュールを新しいデザインに含めるこ とができます。XST
を使用している場合、エクスポート された EDIF ファ イルはタイ ミ ング データを得るために使用す

るこ とができます。エクスポート された UCF ファ イルは Pblock の配置制約の再生成に使用できま

す。 モジュールのインポート後にモジュールを移動させる と、 複数のモジュールに同じ配置を複製

できます。 

ザイリンクス コア (.ngc/.ngo)
[Export Floorplan] および [Save Floorplan] コマンド  (第 10 章 「デザインのフロアプラン」 を参照)
を実行する と、NGC および NGO コア ロジッ クはネッ ト リ ス トから除外され、ブラ ッ クボッ クス  モ
ジュールが作成されます。 元の NGC および NGO コア ファ イルは、 保存ディ レク ト リ またはエク

スポート  ディ レク ト リにコピーされ、 ISE インプリ メンテーシ ョ ンで使用されます。 

メモ : ngc2edif コマンドの出力ログは、PlanAhead を起動したターミナル ウ ィンド ウに表示されま

す。ngc2edif コマンドでは、使用が不可能であったり対応する  NCF 制約と一致しなくなったり した

EDIF ファ イルが生成される場合があ り ます。このよ うな問題が発生した場合は、問題を再現するた

めのデータを電子メールでザイ リ ンクスまで送信して ください。 また、 コアをインポートせずにフ

ロアプランを継続できます。 PlanAhead では、 見つからないロジッ クに対してブラ ッ クボッ クスが

作成されます。 この場合、 NGC コア ファ イルのネッ ト リ ス ト を ISE の実行ディ レク ト リにコピー

します。
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ChipScope コア ネッ ト リス ト  (.ngc)
PlanAhead は ChipScope と統合しているため、ILA コアをインサートおよびコンフ ィギュレーシ ョ

ンするこ とができます。 このコアがインプリ メン ト される と  NGC フォーマッ トのネッ ト リ ス トが

コンパイルされ、プロジェク ト  ネッ ト リ ス ト  ディ レク ト リに保存され、各インプリ メンテーシ ョ ン

実行ディ レク ト リに実行ごとにコピーされます。詳細は、第 11 章 「ChipScope を使用したデザイン

のデバッグ」 を参照して ください。 

制約ファイル (.ucf)
現バージ ョ ンの PlanAhead では、 ISE で使用されるタイ ミ ング制約および物理制約を含む UCF
フォーマッ トの ASCII ファ イルが書き出されます。 このファ イルは、次のコマンドを実行する と生

成されます。

• [Run Implementation] および [Launch Runs] (PlanAhead)

• [File] → [Export Constraints]

• [File] → [Export Pblocks]

• [File] → [Export IP]

インプリ メンテーシ ョ ンの実行および PlanAhead 実行の起動

EDIF および UCF データのエクスポートは、[Launch Runs] コマンドを使用する と自動的に実行で

きます。 実行を起動する と、 出力ネッ ト リ ス トに元の論理階層を含む実行ディ レク ト リが作成され

ます。実行に対しエクスポート されるファイルは、最上位デザイン全体の EDIF フォーマッ トのネッ

ト リ ス ト と  UCF フォーマッ トの制約ファイルです。ファイル名はインポート された EDIF ファ イル

の元の最上位ネッ ト リ ス ト名と同じです。 

エクスポート された制約

制約をエクスポートする と、 元の UCF ファ イルの内容と構造 (コ メン ト も含む) が保持されます。

出力ファイル名は [Export Constraints] ダイアログ ボッ クスで指定できます。 

エクスポート された Pblock

Pblock をエクスポートする と、 PlanAhead で Pblock の論理割り当てに基づいてネッ ト リ ス ト階層

が作成されます。 この UCF は、 エクスポート された EDIF ネッ ト リ ス ト名と一致するよ う、

PlanAhead の物理階層構造を参照します。このため、ブロ ッ ク  ベースのインプリ メンテーシ ョ ン ス
ト ラテジを使用する と きに非常に柔軟に対応できるよ うにな り ます。 

エクスポート される  Pblock ファ イルは、 ネッ ト リ ス ト  1 つと制約ファイル 1 つです。 ブロ ッ ク  レ
ベルのディ レク ト リ構造が自動的に作成、管理されるので、ブロ ッ ク  ベースの ISE アプローチが簡

単になり ます。 選択した Pblock をエクスポートする と、 <pblockname>_CV.edn および

<pblockname>_CV.ucf ファ イルを含む <pblockname>_CV サブディ レク ト リが作成されます。 

エクスポート された IP

デザインでモジュール インスタンスを選択して [Export IP] コマンドを実行する と、 Pblock ロジッ

クおよび配置制約がエクスポート されます。 エクスポート されたファイルには、 元のネッ ト リ ス ト

フォーマッ トの EDIF ネッ ト リ ス トおよび UCF 物理制約が含まれます。インターフェイスをそのま

ま保持するこ とで、 次のデザインのインプリ メンテーシ ョ ンが簡単に実行できます。 エクスポート

された UCF ファ イルは Pblock の配置制約の再生成に使用できます。モジュールのインポート後に

モジュールを移動させる と、 複数のモジュールに同じ配置を複製できます。 
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ISE 起動スクリプ ト  (jobx.bat/sh、 runme.bat/sh および .<ISE_command>.rst)
ISE 起動スク リプ トは、 PlanAhead の [Run Design] コマンドを使用する と自動的に生成されます。

スク リプ トには、PlanAhead のス ト ラテジで指定されたコマンドおよびコマンド  ライン オプシ ョ ン

が含まれています。 jobx.bat/sh スク リプ トは .jobs サブディ レク ト リにあるプロジェク ト実行ディ

レ ク ト リ に保存され、 選択された各実行を順番に起動し ます。 このス ク リ プ ト によ り各実行の

runme.bat/sh スク リプ トが呼び出されます。 これらのスク リプ トは、 個別に実行するこ と もできま

す。

<ISE_command>.rst ファ イルは、PlanAhead で実行のステータスを記録するために、実行ディ レク

ト リに保存されます。 PlanAhead でプロジェク ト を開く と これらのファイルが読み込まれ、 実行の

ステータスが表示されます。

http://www.xilinx.com


PlanAhead ユーザー ガイド japan.xilinx.com 33
UG632 (v 11.1.0)

PlanAhead の用語

PlanAhead の用語

プロジェク ト  
PlanAhead™ ではセッシ ョ ンごとにアクティブなプロジェク トが 1 つ開きます。 プロジェク トは、

使用しているデザイン フローごとにさまざまな入力フォーマッ トで作成できます。 

• RTL ソース  ファ イルは、 RTL からビッ ト ス ト リーム生成までのフローに適したプロジェク ト

を作成するためにインポート します。 

• 合成ネッ ト リ ス トは、 ネッ ト リ ス トからビッ ト ス ト リームまでのフローに使用するためにイン

ポート します。

• 空のプロジェク トは、第 4 章 「I/O ピンの配置」 で説明しているよ うに、デバイスのリ ソースを

試したり、 I/O ピン割り当てを開始するために作成します、

• 以前のコマンド  ライン インプリ メンテーシ ョ ンからの結果をインポート してプロジェク ト を

作成する方法もあ り ます。

作成するプロジェク ト  タイプによ り、プロジェク トには複数のネッ ト リ ス トが含まれるこ とがあ り

ます。 それぞれのプロジェク トに任意数のフロアプランを作成し、 複数のインプリ メンテーシ ョ ン

実行を起動するこ とができます。 詳細は、 「プロジェク トの管理」 を参照してください。

プロジェク ト情報はプロジェク ト  ファ イル (例 : project_1.ppr)、プロジェク ト  データ  ディ レク ト リ

(例 : project_1.data)、プロジェク ト  ソース  ディレク ト リ  (例 : project_1.srcs)、プロジェク ト実行ディ

レク ト リ (例 : project_1.runs) に保存されます。ソース  ディ レク ト リには、プロジェク トにインポー

ト されたすべての RTL 関連ソース  ファ イルが含まれます。 データ  ディ レク ト リには、 プロジェク

ト  ネッ ト リ ス ト を含むネッ ト リ ス ト  ディ レク ト リ 、およびプロジェク ト内の各フロアプランのディ

レク ト リが含まれています。 実行ディ レク ト リには、 PlanAhead で作成された ISE インプリ メン

テーシ ョ ン実行のデータが保存されています。

プロジェク ト  データは、 PlanAhead で自動的に管理されます。 PlanAhead では、前回ツールを終了

した時点のデータでプロジェク トが開くため、 手動でこれらのファイルに変更を加えないよ うにし

ます。

PlanAhead では、 ファ イルを開いたと きに自動的にプロジェク トの状態が復元されます。 作業した

フロアプランおよび関連実行といったプロジェクのステータスが更新され、 プロジェク トが開きま

す。

ソース

プロジェ ク ト はさ まざまなフォーマッ ト の入力フ ァ イルを使用して作成でき ます。 た と えば、

Verilog や VHDL の RTL ソース  ファ イルをインポート してプロジェク ト を作成できます。 こ う し

たファ イルはソース  ファ イルと呼ばれます。ソースは、RTL ファ イルをインポート して作成したプ

ロジェ ク ト のみに存在し、 合成ネッ ト リ ス ト をインポー ト して作成したプロジェ ク トや空のプロ

ジェク トにはソースはあ り ません。

フロアプラン

フロアプランは選択されたネッ ト リ ス トおよびデバイスに関連した制約のセッ トのこ とです。 フロ

アプランの作成に PlanAhead を使用する必要はあ り ません。 インプリ メンテーシ ョ ン実行は外部

ユーザー制約ファイル (UCF) を使用して起動できます。PlanAhead 内で制約を変更したり適用する

には、 フロアプランをまず作成する必要があ り ます。 各フロアプランで、 選択したネッ ト リ ス ト と

特定の配置およびタイ ミ ング制約が関連付けられます。 各プロジェク トのネッ ト リ ス トで、 異なる

制約やデバイスを使用した複数のフロアプランをサポートできます。 フロアプランは、 保存、 閉じ

る、 復元、 コピー、 名前変更、 削除できます。 閉じたフロアプランは、 プロジェク トに含まれたま
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まにな り ますが、プロジェク ト を開き直したと きにシステム メモ リの節約のためデフォルトでは開

きません。

ネッ ト リス ト  
ネッ ト リ ス トはデザインの論理記述です。 ネッ ト リ ス トは、 最上位ネッ ト リ ス ト とその下位ネッ ト

リ ス ト  (モジュール) から構成される階層構造である必要があ り ます。PlanAhead の RTL ベース  プ
ロジェク トには、複数の合成実行を使用できるため、複数のネッ ト リ ス ト を含めるこ とができます。 

制約

制約は、論理タイ ミ ング、ビヘイビア要件、または物理的な配置要件の記述です。 I/O ポートの割り

当ても、 制約で定義されます。

物理ブロック  (Pblock) 
デザインのパーティシ ョ ンは、物理ブロ ッ クまたは Pblock と呼ばれます。従来の方法では、 1 つの

Pblock に 1 つのロジッ ク  インスタンスまたはロジッ ク  インスタンスのグループが割り当てられま

す。 Pblock では、 FPGA デバイス上に長方形のエリ アを定義して、そのロジッ クに制約を付けるこ

とができます。 Pblock は、 長方形がなくても定義可能で、 ISE では配置実行中にロジッ クのグルー

プ化が試みられます。 Pblock 内に配置されたネッ ト リ ス ト  ロジッ クには、 ISE で AREA_GROUP
制約が付けられます。 Pblock は、特定の RANGE タイプを使用して、 SLICE、 RAM/MULT、 DSP
など特定のロジッ クのみを含めるよ うに指定できます。また Pblock は、複数の長方形を使用して L
形 および T 形などの長方形以外の形を作成できるよ うに定義するこ と もできます。

インスタンス

ネッ ト リ ス トに含まれるインスタンス と呼ばれるエレ メン トには、下位ロジッ ク  プリ ミ ティブと階

層モジュールのコンポーネン トが含まれます。 このマニュアルでは、モジュール コンポーネン トは

モジュールと呼びます。

モジュール

ネッ ト リ ス トに含まれる階層モジュールのインスタンシエーシ ョ ンを表すエレ メン ト をモジュール

またはコンポーネン ト と呼びます。下位プリ ミ ティブ ロジッ クは、 インスタンスまたはプリ ミ ティ

ブと呼びます。

プリ ミテ ィブ

ネッ ト リ ス トに含まれる  LUT、 フ リ ップフロ ップなどの下位ロジッ ク  オブジェク ト を表すエレ メ

ン トは、 プ リ ミ ティブと呼びます。 

実行

各合成またはインプリ メンテーシ ョ ンの試みを 「実行」 と呼びます。 各実行は特定のス ト ラテジに

関連付けられています。 複数の実行を複数のプロセッサを使用して同時に実行したり、 または 1 つ
ずつ実行できます。 実行は順次に起動し、 PlanAhead にそのステータスが表示されます。

スト ラテジ

ス ト ラテジは、 ツールのコマンド  オプシ ョ ンの定義済みセッ トです。 ツールで提供されるス ト ラテ

ジを適用したり、ユーザー ス ト ラテジを作成したりできます。 ス ト ラテジは個々の実行に適用でき

ます。
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サイ ト

PlanAhead では、 デザイン ネッ ト リ ス ト をインプリ メン トする と きに使用される特定 FPGA デバ

イス  リ ソースがタイルで表示されます。プリ ミ ティブ ロジッ クのサイ トには、ネッ ト リ ス トのイン

スタンスを配置できます。これらのサイ トは、オブジェク トの種類 (RAM、MULT、CLB、DSP、PPC、

MGT など) を区別するために、 それぞれ形と色が異なり ます。下位ロジッ クは、配置制約を使用し

て特定のスライスに割り当てるか、BEL 制約を使用してスライス内のゲートに割り当てるこ とがで

きます。

サイ ト配置制約 (LOC)
ロケーシ ョ ン制約 (LOC) は、特定のスライス座標に割り当てられた固定配置サイ トがある下位イン

スタンスに割り当てられます。この制約はロジッ クをスライス内の特定のロジッ ク  ゲートに固定し

ないので、BEL 制約とは異なり ます。LOC 制約を割り当てる と、そのインスタンスに対してエクス

ポート された UCF ファ イルに LOC 制約が書き込まれます。 LOC 制約は、 [Device] ウ ィンド ウで

ズーム レベルに応じて、 この制約が付けられているサイ ト内で長方形と して、 またはサイ ト内のロ

ジッ ク  ファンクシ ョ ン シンボルと して表示されます。

BEL 配置制約 (BEL)
BEL (Basic Element of Logic) 制約は、特定のロジッ ク  デバイス  ゲートに割り当てられた配置サイ

トがある下位インスタンスに割り当てられます。BEL 制約を割り当てる と、そのインスタンスに対

してエクスポート された UCF ファ イルに BEL 制約が書き込まれます。 この制約は、 [Device] ウ ィ

ンド ウでズーム レベルに応じて、 この制約が付けられているサイ ト内で長方形と して、 またはサイ

ト内のロジッ ク  ファンクシ ョ ン シンボルと して表示されます。

I/O ポート

I/O ポートは物理パッケージ ピンに割り当てるユーザー I/O です。 各 I/O 信号はポート と して定義

されます。 

パッケージ ピン

パッケージ ピンは、 I/O ポートが割り当てられるパッケージの物理ピンです。 パッケージ ピンは、

I/O バンクにグループ化されます。 パッケージ ピンおよび I/O バンクの詳細は、 デバイスの仕様を

参照して ください。
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本章は、 次のセクシ ョ ンで構成されています。

• 「PlanAhead の起動」

• 「Getting Started ページの使用」

• 「PlanAhead プロジェク トの種類」

• 「New Project ウ ィザードを使用した新規プロジェク トの作成」

• 「プロジェク トの管理」

• 「フロアプランを使用した作業」

PlanAhead の起動

メモ : インス トール方法は『ISE Design Suite リ リース ノートおよびインス トールガイ ド』を参照し

て ください。 

このソフ ト ウェアはどのディ レク ト リから も起動できますが、プロジェク ト  ディ レク ト リから起動

する と、 プロジェク ト固有のログ ファ イルが簡単に検索できるので便利です。

Linux
PlanAhead を起動するには、 次のコマンドをコマンド  プロンプ トに入力します。

# planAhead

Windows
ザイ リ ンクス  PlanAhead 11.1 のシ ョート カッ ト  アイコンをダブル ク リ ッ ク します。 

PlanAhead のログ ファ イルを書き込むディ レク ト リは、デスク ト ップ アイコンのプロパティに含ま

れている  [作業フォルダ] で設定します。

図 2-1 : ザイリンクス PlanAhead 11.1 のアイコン
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PlanAhead 環境が表示されます。 

これで PlanAhead で新規または既存のプロジェク ト を開く こ とができます。 PlanAhead の Getting
Started ページからは、 プロジェク ト を作成したり、 指定プロジェク ト を開くだけではなく、

PlanAhead のマニュアルも表示できます。 

メモ : [Getting Started] ページは、 [Help] → [Getting Started] をク リ ッ クする と開きます。

PlanAhead コマンド  ライン オプシ ョ ン

PlanAhead にはコマンド  ライン オプシ ョ ンがいくつかあ り ます。PlanAhead のコマンド  ライン オ
プシ ョ ンを表示するには、 次のコマンドをコマンド  プロンプ トに入力します。

# planAhead -help 

図 2-2 : [PlanAhead: Getting Started] ウィンドウ 
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ヘルプ メニューがシェル ウ ィンド ウに表示されます。

PlanAhead の Tcl スタートアップ スクリプ トの使用

PlanAhead の [Tools] → [Run Tcl Script] コマンドを使用する と、スタート アップ スク リプ ト を実行

できます。 planAhead.jou ファ イルからコピーされた PlanAhead の Tcl コマンドは、 スタート

アップ スク リプ トの作成に使用するこ とができます。 PlanAhead のジャーナル ファ イルの詳細は、

「レポートの出力」 を参照して ください。

図 2-3 : PlanAhead のコマンド引数

図 2-4 : PlanAhead の Tcl スクリプ ト例
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Getting Started ページの使用

PlanAhead を起動する と ウ ィンド ウに Getting Started ページが表示されます。青色の下線が付いて

いるコマンド  リ ンクをク リ ッ クする と、特定のコマンドを実行したり、マニュアルを表示できます。 

デフォルトでは、最近開いた 10 個のプロジェク トへのリ ンクが表示され、ク リ ッ クする と開く こ と

ができるよ うになっていますが、プロジェク ト表示前に、そのプロジェク ト  データが使用可能かが

確認されます。 [Tools] → [Options] → [General] をク リ ッ ク して [General] ダイアログ ボッ クスを

開き、 このページにリ ス トするプロジェク トの数を設定できます。

PlanAhead のマニュアルのリ ンクをク リ ッ クする と、PDF ビューアが起動してマニュアルを表示で

きます。 PDF フォーマッ トのマニュアルは、 <InstallDir>/doc ディ レク ト リから も表示できます。

PlanAhead プロジェク トの種類

PlanAhead は FPGA デザイン フローのさまざまなポイン トで使用するこ とができます。 このため、

PlanAhead プロジェク トにはいろいろな種類があ り、 プロジェク ト作成に使用された入力ソースの

タイプによって区別されています。[Create New Project] プロセスで必要なプロジェク トのタイプを

選択するこ とができます。

プロジェク トの種類を一度選択したら、 後で別の種類に変換するこ とはできません。 

メモ : PlanAhead ではパーシャル リ コンフ ィギュレーシ ョ ン デザインをサポートするため派生タ

イプのプロジェク ト も使用されます。この機能は、v11.1 では限定されたユーザーにのみ利用できる

よ うになっており、 詳細は 『Partial Reconfiguration User Guide』 に記載されています。

I/O ピン配置の空プロジェク ト

I/O ピン配置は、 空のプロジェク ト を作成してデザイン サイクルの早期に完成させるこ とができま

す。 I/O ポートは、 PlanAhead 内で作成するか、 CSV、 UCF、 または RTL 入力ファイルを使用しイ

ンポートするこ とができます。 I/O ピン割り当ての後、 PlanAhead で CSV、 UCF、 および RTL 出
力ファイルが作成できます。 このファイルは、 RTL ソースまたはネッ ト リ ス トが使用可能になった

と きにデザイン フローの後段階で使用します。この出力ファイルは、PCB デザインで使用する回路

図シンボルの作成に使用するこ と もできます。

空プロジェク トはそれぞれのデバイス  アーキテクチャで使用可能なロジッ ク  リ ソースを知るため

にも作成できます。

RTL ソースをベースにしたプロジェク ト

PlanAhead は、 RTL 生成からビッ ト ス ト リーム生成まで FPGA デザイン フロー全体の管理に使用

できます。 プロジェク トは RTL ソース  ファ イルおよびプリ コンパイルされた NGC/NGO フォー

マッ トのザイ リ ンクス  コアをインポート して作成できます。RTL に手を加え解析し、コンス ト ラ ク

トが正しいこ とを確認し、 さまざまな合成やインプリ メンテーシ ョ ン実行を起動 ・管理し、 デザイ

ンと実行結果を解析するこ とができます。 また、 フロアプランを作成してさまざまな制約やデバイ

ス  ス ト ラテジを試すこ と もできます。

合成ネッ ト リス ト をベースにしたプロジェク ト

XST やサポート されているサードパーティの合成ツールを使用し  PlanAhead 外で合成されたデザ

インからプロジェク ト を作成するこ と もできます。PlanAhead には EDIF または NGC/NGO フォー

マッ トのネッ ト リ ス ト をインポート します。ネッ ト リ ス トは 1 つのファイルにまとめられていて、複

数のモジュール レベルのネッ ト リ ス トから構成される階層構造になっています。ロジッ ク  ネッ ト リ
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ス ト を解析し、 さまざまなインプリ メンテーシ ョ ン実行を起動 ・管理し、 デザインと実行結果を解

析できます。 また、 フロアプランを作成してさまざまな制約やデバイス  ス ト ラテジを試すこ と もで

きます。

インプリ メン ト されたデザイン結果をベースにしたプロジェク ト

ザイ リ ンクスのコマンド  ライン ツールを使用し  PlanAhead 外で作成されたインプリ メンテーシ ョ

ン結果の解析をするためにプロジェク ト を作成するこ と もできます。デザイン ネッ ト リ ス ト 、 イン

プリ メンテーシ ョ ン、 タイ ミ ング結果を、 タイ ミ ングまたは配置関連の問題を確認するためにイン

ポートできます。 

New Project ウィザードを使用した新規プロジェク トの作成

New Project ウ ィザードでは、プロジェク ト名およびディ レク ト リの定義、ネッ ト リ ス トのインポー

ト、 およびデバイスの選択と制約のインポート を含む初期フロアプランの作成をウ ィザードに従っ

て実行できます。 

プロジェク ト を新規作成するには、 次の手順に従ってください。

1. 次のコマンドのいずれかを選択します。

♦ ツールバーの [New Project] をク リ ッ ク します。 

♦ Getting Started ページの [Create a New Project] とい う リ ンクをク リ ッ ク します。 

♦ [File] → [New Project] をク リ ッ ク します。

ウ ィザードの最初のページではウ ィザードの概要が表示されます。

2. [Next] をク リ ッ ク します。

図 2-5 : [New Project] ボタン
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[Project Name] ページが表示されます。 

プロジェク ト名およびプロジェク ト  ディ レク ト リの入力

次のよ うに、 プロジェク ト名およびプロジェク ト を保存するディ レク ト リ を入力します。

3. [Project Name] ページで、 [Project name] および [Project location] を指定します。

♦ [Project name] : project_2 など、プロジェク ト  ディ レク ト リ を識別する名前を入力します。 

♦ [Project location] : プロジェク ト  ディ レク ト リ を作成するディ レク ト リ を入力します。 

4. 入力後、 [Next] をク リ ッ ク します。

図 2-6 : New Project ウィザード  : [Project Name] ページ

http://www.xilinx.com


PlanAhead ユーザー ガイド japan.xilinx.com 43
UG632 (v 11.1.0)

New Project ウィザードを使用した新規プロジェク トの作成

デザイン ソース データ  タイプの選択

こ こでは、 RTL ソースまたは合成済みのネッ ト リ ス ト  (EDIF または NGC) を PlanAhead にイン

ポートするか、 I/O ピン配置用に空のプロジェク ト を作成するかを指定します。 

5. オプシ ョ ンの選択後、 [Next] をク リ ッ ク します。

6. 選択したデザイン入力に応じて、 次のいずれかのセクシ ョ ンを参照してください。

♦ 「I/O ピンを配置する空のプロジェク トの作成」

♦ 「RTL ソースをインポート したプロジェク トの作成」

♦ 「EDIF または NGC 形式の合成ネッ ト リ ス ト を使用したプロジェク トの作成」

♦ 「ISE 配置およびタイ ミ ング結果を使用したプロジェク トの作成」

メモ : [Do not import sources at this time] を選択してネッ ト リ ス ト をインポート しない場合、 新規

プロジェク ト を定義し終えたらピン レイアウ ト用の PinAhead が起動します。

I/O ピンを配置する空のプロジェク トの作成

I/O ピンを配置するには、作成済みの HDL または合成済みの EDIF を使用する前に空のプロジェク

ト を作成します。 I/O ピン配置の詳細は、 第 5 章 「I/O ピンの配置」 を参照してください。

1. [Design Source] ページで [Do not import sources at this time] をオンにします。

図 2-7 : New Project ウィザード  : [Design Source] ページ
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2. [Next] をク リ ッ ク します。

製品ファ ミ リ とデフォルト  パーツの選択

次に、 製品ファ ミ リおよびデフォルト  パーツを選択します。

図 2-8 : 空のプロジェク トの作成

図 2-9 : New Project ウィザード  : [Choose a Part and a Floorplan Name] ページ
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3. ターゲッ トの製品ファ ミ リ  アーキテクチャ とデフォルト  パーツを選択します。

4. [Next] をク リ ッ ク します。

メモ : プロジェク トに製品ファ ミ リ を一度選択したら変更するこ とはできません。 別のアーキテク

チャをターゲッ トにするには新規プロジェク ト を作成する必要があ り ます。 デフォルト  パーツは、

合成およびインプリ メンテーシ ョ ン実行とフロアプラン作成中に変更できます。

フロアプラン名の指定とターゲッ ト  デバイスの選択

[Floorplan Name] ページが表示されます。

5. [Floorplan Name] ページでは、 フロアプラン名を入力し、 使用するデバイスを選択します。

♦ [Floorplan name] : フロアプランの名前を入力します。

♦ [Choose Part] : 参照ボタンをク リ ッ ク してデバイスを選択するか、 デフォルトのデバイス

を選択します。

6. [Next] をク リ ッ ク します。

[New Project Summary] ページが表示されます。

7. [Finish] をク リ ッ ク して、 プロジェク ト を開始します。

PlanAhead の I/O ピン配置関連のウ ィンド ウでプロジェク トが開きます。 

RTL ソースをインポート したプロジェク トの作成

RTL ソース  ファ イルをインポート してプロジェク ト を作成するこ とができます。これは、RTL コー

ド開発と解析、合成と インプリ メンテーシ ョ ンを目的とする場合に使用します。 RTL 開発および解

析の詳細は、 第 6 章 「RTL デザインの作成および解析」 を参照してください。

1. [Design Source] ページで [Import RTL source] をオンにします。

図 2-10 : New Project ウィザード  : [Floorplan Name] ページ
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2. [Next] をク リ ッ ク します。

製品ファ ミ リ とデフォルト  パーツの選択

次に、 製品ファ ミ リおよびデフォルト  パーツを選択します。

図 2-11 : RTL ソースを使用したプロジェク トの作成

図 2-12 : New Project ウィザード  : [Choose a Part and a Floorplan Name] ページ

http://www.xilinx.com


PlanAhead ユーザー ガイド japan.xilinx.com 47
UG632 (v 11.1.0)

New Project ウィザードを使用した新規プロジェク トの作成

3. ターゲッ トの製品ファ ミ リ  アーキテクチャ とデフォルト  パーツを選択します。

4. [Next] をク リ ッ ク します。

メモ : プロジェク トに製品ファ ミ リ を一度選択したら変更するこ とはできません。 別のアーキテク

チャをターゲッ トにするには新規プロジェク ト を作成する必要があ り ます。 デフォルト  パーツは、

合成およびインプリ メンテーシ ョ ン実行とフロアプラン作成中に変更できます。

ソース ファイルまたはディ レク ト リの追加

次に、 HDL ソース  ファ イルまたは HDL ソース  ファ イルを含むディ レク ト リ を選択します。

♦ [Add Files] : ファ イルを個別にプロジェク トに追加するには、 [Add Files] ボタンをク リ ッ

ク し、 ファ イルを選択します。

♦ [Add Directories] : ディ レク ト リ内のファイルおよびサブディ レク ト リ をすべてプロジェ

ク トに追加するには、[Add Directories] ボタンをク リ ッ ク し、ディ レク ト リ を選択します。

ディ レク ト リにある認識された拡張子を持つソース  ファ イルがすべてインポート されま

す。

♦ [Import Sources into Project] : 元のロケーシ ョ ンではなく、 PlanAhead のプロジェク ト

ディ レク ト リにソース  ファ イルをコピーします。

5. ファ イルまたはディ レク ト リ を選択したら、 [Next] をク リ ッ ク します。

HDL ソース  ファ イルが PlanAhead にインポート されます。 

[New Project Summary] ページが表示されます。

6. [Finish] をク リ ッ ク して、 プロジェク ト を開始します。

RTL 関連のウ ィンド ウが使用可能な PlanAhead のプロジェク ト環境が表示されます。 

図 2-13 : New Project ウィザード  : [Add Sources] ページ
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メモ : PlanAhead の [Console] ウ ィンド ウに警告メ ッセージが表示された場合は、 メ ッセージまた

は PlanAhead ログ ファ イルを確認し、 デザインのエラーやインプリ メンテーシ ョ ン エラーの原因

となる問題がないか確認して ください。

図 2-14 : PlanAhead の RTL 環境
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EDIF または NGC 形式の合成ネッ ト リス ト を使用したプロジェク トの作成

PlanAhead では、合成済みのネッ ト リ ス ト と対応する制約をインポート してプロジェク ト を作成で

きます。 この方法は、 フロアプラン環境およびインプリ メンテーシ ョ ン環境を使用してデザインを

解析、 フロアプラン、 およびインプリ メン トする場合に使用します。 

1. [Design Source] ページで [Import synthesized (EDIF or NGC) netlist] をオンにします。

最上位ネッ ト リス トおよびモジュール検索パスの指定

[Import Netlist] ページでは、 最上位のネッ ト リ ス ト  ファ イルおよびモジュール レベルのネッ ト リ

ス ト を検索する検索パスを入力できます。

2. このページでは、 次を指定します。

♦ [Netlist file] : このプロジェク トの最上位ネッ ト リ ス ト名を入力します。 参照ボタンをク

リ ッ クする と、 最上位ネッ ト リ ス ト  ファ イルを指定できます。

♦ [Netlist directories] : [Add] ボタンをク リ ッ ク して、ネッ ト リ ス トのインポート中に検索す

る下位のモジュールおよびコアを含むディ レ ク ト リ を選択し ます。 デフォル ト では、

PlanAhead の起動ディ レク ト リ と最上位ネッ ト リ ス ト を選択したディ レク ト リが検索パ

スに含まれています。 これらのディ レク ト リの検索順は、 [Up] ボタンおよび [Down] ボタ

ンを使用して変更できます。[Remove] ボタンを使用する と、検索パスからディ レク ト リ を

削除できます。

図 2-15 : 合成済みの EDIF または NGC ネッ ト リス ト を使用したプロジェク トの作成
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3. [Next] をク リ ッ ク してウ ィザードを進めます。

ネッ ト リ ス トが PlanAhead にインポート されます。多少時間がかかるこ とがあ り ます。ネッ ト

リ ス ト ごとにステータス  バーが表示されます。警告およびエラーに関する情報は、 コンソール

ウ ィンド ウに表示され、 また planAhead.log ファ イルに書き込まれます。 正常に終了する と、

メ ッセージが表示されます。

メモ : PlanAhead では、 フロアプランにおいてロジッ ク階層に依存しているため、 インポート

するネッ ト リ ス トには、 ロジッ ク階層が含まれている必要があ り ます。 フラ ッ ト化されたネッ

ト リ ス ト を使用する と、 フロアプランが困難になり ます。 デザインが RTL で記述されており、

階層構造で合成されているこ とを確認して ください。

メモ : 最上位またはモジュール レベルの NGC または NGO フォーマッ ト  ファ イルをインポー

トする と きは、 ngc2edif コマンドを使用して、 PlanAhead 用の EDIF を作成する必要があ り ま

す。 ngc2edif コマンドのステータスは、 コマンド実行時に PlanAhead のターミナル ウ ィンド

ウに表示されます。 

図 2-16 : New Project ウィザード  : [Import Netlist] ページ
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次に、 製品ファ ミ リおよびデフォルト  パーツを選択します。

4. このページで表示 ・ 編集できるオプシ ョ ンは次のとおりです。

♦ [Product Family] : 使用するデバイスを表示します。互換性のあるデバイスのみがこ こに表

示されます。

♦ [Choose Part] : 参照ボタンをク リ ッ ク してデバイスを指定するか、 デフォルト値を使用し

て最上位 EDIF ネッ ト リ ス ト  ファ イルで定義されているデバイスを使用します。

♦ [Floorplan name] : フロアプランの名前を入力します。

5. [Next] をク リ ッ ク します。

メモ : プロジェク トに製品ファ ミ リ を一度選択したら変更するこ とはできません。 別のアーキテク

チャをターゲッ トにするには新規プロジェク ト を作成する必要があ り ます。 デフォルト  パーツは、

合成およびインプリ メンテーシ ョ ン実行とフロアプラン作成中に変更できます。

図 2-17 : New Project ウィザード  : [Choose a Part and a Floorplan Name] ページ
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制約のインポート

[Import Constraints] ページが表示されます。

6. [Add] ボタンをク リ ッ ク して、インポートする最上位の UCF または NCF 制約ファイルを選択

します。 これらのファイルのインポート順は、 [Up] ボタンおよび [Down] ボタンを使用して変

更できます。 [Remove] ボタンを使用する と、 リ ス トからファ イルを削除できます。

モジュール レベルの NCF または UCF 制約を使用する場合は、このリ ス トに含めないでくださ

い。 モジュール レベルの制約のインポートの詳細は、 「制約のインポート 」 70 ページを参照し

て ください。

7. [Next] をク リ ッ ク してウ ィザードを進めます。

UCF ファ イルが PlanAhead にインポート されます。 この動作には多少時間がかかる場合があ

り ます。 

[New Project Summary] ページが表示されます。

8. [Finish] をク リ ッ ク して、 フロアプランを開始します。

フロアプランが開始され、 PlanAhead のフロアプラン環境が起動します。

図 2-18 : New Project ウィザード  : [Import Constraints] ページ
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メモ : PlanAhead の [Console] ウ ィンド ウに警告メ ッセージが表示された場合は、 メ ッセージまた

は PlanAhead ログ ファ イルを確認し、 デザインのエラーやインプリ メンテーシ ョ ン エラーの原因

となる問題がないか確認して ください。

ISE 配置およびタイ ミング結果を使用したプロジェク トの作成

PlanAhead では ISE® インプリ メンテーシ ョ ン結果が含まれたネッ ト リ ス ト と対応する制約をイン

ポート してプロジェク ト を作成できます。 これは、 インプリ メンテーシ ョ ン環境を使用し配置配線

結果を解析するのに使用します。 

[Design Source] ページで [Import ISE Place & Route results] をオンにします。

図 2-19 : PlanAhead のフロアプラン環境
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最上位ネッ ト リス トおよびモジュール検索パスの指定

[Import Netlist] ページでは、 最上位のネッ ト リ ス ト  ファ イルおよびモジュール レベルのネッ ト リ

ス ト を検索する検索パスを入力できます。

2. このページでは、 次を指定します。

♦ [Netlist file] : このプロジェク トの最上位ネッ ト リ ス ト名を入力します。 参照ボタンをク

リ ッ クする と、 最上位ネッ ト リ ス ト  ファ イルを指定できます。

♦ [Netlist directories] : [Add] ボタンをク リ ッ ク して、ネッ ト リ ス トのインポート中に検索す

る下位のモジュールおよびコアを含むディ レ ク ト リ を選択し ます。 デフォル ト では、

PlanAhead の起動ディ レク ト リ と最上位ネッ ト リ ス ト を選択したディ レク ト リが検索パ

スに含まれています。 [Up] ボタンおよび [Down] ボタンで、 これらのディ レク ト リの検索

順序を変更できます。[Remove] ボタンを使用する と、検索パスからディ レク ト リ を削除で

きます。

図 2-20 : ISE の配置配線結果を使用したプロジェク トの作成
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3. [Next] をク リ ッ ク してウ ィザードを進めます。

ネッ ト リ ス トが PlanAhead にインポート されます。多少時間がかかるこ とがあ り ます。ネッ ト

リ ス ト ごとにステータス  バーが表示されます。警告およびエラーに関する情報は、 コンソール

ウ ィンド ウに表示され、 また planAhead.log ファ イルに書き込まれます。 正常に終了する と、

メ ッセージが表示されます。

図 2-21 : New Project ウィザード  : [Import Netlist] ページ
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製品ファ ミ リ とデフォルト  パーツの選択

次に、 製品ファ ミ リおよびデフォルト  パーツを選択します。

4. ターゲッ トの製品ファ ミ リ  アーキテクチャ とデフォルト  パーツを選択します。

5. [Next] をク リ ッ ク します。

メモ : プロジェク トに製品ファ ミ リ を一度選択したら変更するこ とはできません。 別のアーキテク

チャをターゲッ トにするには新規プロジェク ト を作成する必要があ り ます。 デフォルト  パーツは、

合成およびインプリ メンテーシ ョ ン実行とフロアプラン作成中に変更できます。

フロアプラン名の指定とターゲッ ト  デバイスの選択

[Floorplan Name] ページが表示されます。

図 2-22 : New Project ウィザード  : [Choose a Part and a Floorplan Name] ページ
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6. [Floorplan Name] ページでは、 フロアプラン名を入力し、 使用するデバイスを選択します。

♦ [Floorplan name] : フロアプランの名前を入力します。

♦ [Choose Part] : 参照ボタンをク リ ッ ク してデバイスを指定するか、 デフォルト値を使用し

て最上位 EDIF ネッ ト リ ス ト  ファ イルで定義されているデバイスを使用します。

7. フロアプラン名を指定し、 ターゲッ ト  デバイスを選択します。

8. [Next] をク リ ッ ク します。

図 2-23 : New Project ウィザード  :[Floorplan Name] ページ
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制約のインポート

[Import Constraints] ページが表示されます。

9. [Add] ボタンをク リ ッ ク して、インポートする最上位の UCF または NCF 制約ファイルを選択

します。 これらのファイルのインポート順は、 [Up] ボタンおよび [Down] ボタンを使用して変

更できます。 [Remove] ボタンを使用する と、 リ ス トからファ イルを削除できます。

モジュール レベルの NCF または UCF 制約を使用する場合は、このリ ス トに含めないでくださ

い。 モジュール レベルの制約のインポートの詳細は、 「制約のインポート 」 70 ページを参照し

て ください。

10. [Next] をク リ ッ ク してウ ィザードを進めます。

UCF ファ イルが PlanAhead にインポート されます。 この動作には多少時間がかかる場合があ

り ます。 

図 2-24 : New Project ウィザード  :[Import Constraints] ページ
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New Project ウィザードを使用した新規プロジェク トの作成

配置およびタイ ミング結果のインポート

[Import ISE Implementation Results] ページが開きます。ISE で生成された配置配線結果をインポー

ト し、 PlanAhead で表示および解析するためのフロアプランを作成するこ とができます。

11. このページでは、 次を指定します。

♦ [Import Placement] : XDL、GZ、NCD など、 ISE インプリ メンテーシ ョ ンからの配置結果

ファイルのディ レク ト リ を指定します。

♦ [Import Timing] : TWX など  ISE インプリ メンテーシ ョ ンのタイ ミ ング結果ファイルの

ディ レク ト リ を指定します。

♦ [Results Name] : フロアプラン名を入力します。

[New Project Summary] ページが表示されます。

12. [Finish] をク リ ッ ク して、 フロアプランを開始します。

フロアプランが開始され、 PlanAhead のフロアプラン環境が起動します。

図 2-25 : New Project ウィザード  : [Import ISE Implementation Results] ページ
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メモ : PlanAhead の [Console] ウ ィンド ウに警告メ ッセージが表示された場合は、 メ ッセージまた

は PlanAhead ログ ファ イルを確認し、 デザインのエラーやインプリ メンテーシ ョ ン エラーの原因

となる問題がないか確認して ください。

プロジェク トの管理

次のコマンドは、 合成済みネッ ト リ ス ト をインポート してプロジェク トが作成されている場合に使

用します。PinAhead プロジェク ト または HDL ソースを使用して作成されたプロジェク トでは使用

できないコマンドが含まれています。 

既存プロジェク ト を開く方法

PlanAhead で既存のプロジェク ト を開くには、 [Open Project] コマンドを使用するか、Windows の
場合は PlanAhead プロジェク ト  (PPR) ファイルをダブルク リ ッ クする と、PlanAhead が起動しファ

イルが開きます。 プロジェク トは、 前回プロジェク ト を閉じた時点の状態で開きます。 前回のイン

プリ メンテーシ ョ ン実行がすべて回復され、 開いていたフロアプランも再度開き、 修正できます。 

図 2-26 : PlanAhead のフロアプラン環境
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プロジェク トは、 HDL ソースや合成済みネッ ト リ ス ト を使用して PlanAhead で作成された場合な

ど、 プロジェク トのタイプに応じたウ ィンド ウ  レイアウ トで表示されます。

プロジェク ト を開くには、 次の方法のいずれかを実行します。

• [File] → [Open Project] をク リ ッ ク します。

• [Open Project] ボタンをク リ ッ ク します。

• Getting Started ページで [Open a Previously Created Project] リ ンクをク リ ッ ク します。

[Open Project] ダイアログ ボッ クスが表示されます。PPR プロジェク ト ファ イルを選択して開きま

す。

複数のプロジェク ト を開く

1 つの PlanAhead セッシ ョ ンで複数のプロジェク ト を同時に開くには、 この章の 「既存プロジェク

ト を開 く 方法」 で説明した方法のいずれかを実行し ます。 開いたプロジェ ク ト ご と に別個の

PlanAhead メ イン ウ ィンド ウが開きます。複数のプロジェク ト を同時に開いた場合、 ウ ィンド ウに

よってはフォーカスに問題が生じるこ とがあ り ます。 

複数のプロジェク ト を開いた場合、システム メモ リの要件によ り、パフォーマンスが低下するこ と

があ り ます。 [PlanAhead environment] ウ ィンド ウの右下にある  Java のメモリ使用状況ステータス

バーを確認して ください。 PlanAhead では Java のメモ リ制限が Windows で 512MB、 64 ビッ ト

Linux で 1GB に設定されています。この制限に近づいてきた場合は、プロジェク トやフロアプラン

を閉じ、 メモ リ を解放して ください。

図 2-27 : [Open Project] ボタン

図 2-28 : [Open Project] ダイアログ ボックス
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プロジェク ト を閉じる

プロジェク ト を閉じるには [File] → [Close Project] をク リ ッ ク します。プロジェク ト を閉じる と、保

存されていないフロアプランを保存するよ うにという メ ッセージが表示されます。 データを保存し

てからプロジェク ト を閉じるかど うかの選択肢があ り ます。 ネッ ト リ ス トのアップデートは、 実行

時にプロジェク トに自動的に保存されます。

合成ネッ ト リス ト  ベースのプロジェク トのネッ ト リス トのアップデート

最上位ネッ ト リス トのアップデート

新し く合成されたネッ ト リ ス ト を使用してデザイン全体をアップデートするには、 次の手順に従っ

てください。

1. [File] → [Update Netlist] をク リ ッ ク します。

Update Netlist ウ ィザードが表示されます。 

2. デザイン ネッ ト リ ス ト全体をアップデートするには、[Replace the entire design] をオンにしま

す。 

3. [Next] をク リ ッ ク し次に進みます。

[Import Netlist] ページが表示されます。

4. 次の 2 つのオプシ ョ ンを設定してください。

♦ [Netlist file] : このプロジェク トの最上位ネッ ト リ ス ト名を入力します。 参照ボタンをク

リ ッ ク し、 デザインの最上位ネッ ト リ ス ト  ファ イルを選択します。

♦ [Netlist directories] : ネッ ト リ ス トのインポート中に最下位のモジュールおよびコアを検

索するディ レク ト リ を、[Add] ボタンを使用して選択します。デフォルトでは、PlanAhead
の起動ディ レク ト リ と最上位ネッ ト リ ス ト を選択したディ レク ト リが検索パスに含まれて

図 2-29 : Update Netlist ウィザード
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います。 [Up] ボタンおよび [Down] ボタンで、 これらのディ レク ト リの検索順序を変更で

きます。 [Remove] ボタンをク リ ッ クする と、ディ レク ト リが検索パスから削除されます。

5. [Next] をク リ ッ ク します。

6. [Update Netlist Summary] ページで [Finish] をク リ ッ ク します。

ネッ ト リ ス トが PlanAhead にインポート されます。多少時間がかかるこ とがあ り ます。ネッ ト リ ス

ト ごとにステータス  バーが表示されます。警告およびエラーに関する情報は、コンソール ウ ィンド

ウに表示され、 また planAhead.log ファ イルに書き込まれます。 正常に終了する と、 メ ッセージが

表示されます。

モジュール レベルのネッ ト リス トのアップデート

[Update Netlist] コマンドを使用し、新規モジュール レベルまたは最上位のネッ ト リ ス ト をインポー

ト し、 モジュールを置き換えるこ とができます。 新し く インポート したネッ ト リ ス トに含まれるモ

ジュールを選択して、 既存のプロジェク トのモジュールと置き換えるこ とができます。 ただし、 モ

ジュール ポート  インターフェイスはそのままなので、 ロジッ クが階層ロジッ ク  モジュールの境界

を越えて最適化されていないこ とを確認するための合成パラ メータが必要な場合があ り ます。 階層

保持に関する詳細は、 使用している合成ツールのマニュアルを参照して ください。

PlanAhead では、モジュール レベルのインク リ メンタル ネッ ト リ ス ト を合成よ り インポートできま

す。 この機能を使用して、 インク リ メンタル合成のス ト ラテジをインプリ メン トできます。 

メモ : デザインを再合成する と、 下位のネッ ト名と インスタンス名が変わってしま う こ とがよ くあ

り ます。 フロアプランに LOC のよ うなインスタンス  レベルの制約が含まれている と、 名前の不一

致が生じます。 PlanAhead では、 ネッ ト リ ス ト をアップデートする前にモジュール制約が読み込ま

れないので、 アップデート中の潜在的な問題を回避できます。 制約はアップデート後にインポート

し直すこ とができ、 名前が一致した制約が割り当てられます。 通常は、 配置制約がデザインで定義

されている と きにのみこのよ うな問題が発生します。 ネッ ト リ ス トのアップデート前にモジュール

制約を削除して ください。

図 2-30 : Update Netlist ウィザード  : [Import Netlist] ページ
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[Update Netlist] コマンドでデザインのモジュールを個別にインポートする と、 ネッ ト リ ス トはモ

ジュールごとにアップデート されます。 この方法は次のとおりです。

1. [File] → [Update Netlist] をク リ ッ ク します。

Update Netlist ウ ィザードが表示されます。

2. [Replace a specific module] オプシ ョ ンをオンにし、デザイン内の選択したモジュールがアップ

デート されるよ うにします。 

3. [Next] をク リ ッ ク し次に進みます。

図 2-31 : Update Netlist ウィザード
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[Import Netlist] ページが表示されます。 

図 2-32 : Update Netlist ウィザード  :[Import Netlist] ページ
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[Import Netlist] ページには次のオプシ ョ ンがあ り ます。

♦ [Netlist file] : プロジェク ト をアップデートするモジュールを含むネッ ト リ ス トの名前を

入力します。参照ボタンをク リ ッ ク し、モジュールのネッ ト リ ス ト  ファ イルを選択します。

♦ [Netlist directories] : ネッ ト リ ス トのインポート中に最下位のモジュールおよびコアを検

索するディ レク ト リ を、[Add] ボタンを使用して選択します。デフォルトでは、PlanAhead
の起動ディ レク ト リ と最上位ネッ ト リ ス ト を選択したディ レク ト リが検索パスに含まれて

います。 [Up] ボタンおよび [Down] ボタンで、 これらのディ レク ト リの検索順序を変更で

きます。 [Remove] ボタンをク リ ッ クする と、ディ レク ト リが検索パスから削除されます。

4. [Next] をク リ ッ ク し次に進みます。

[Specify Replacement Module] ダイアログ ボッ クスが表示されます。

5. リ ス トから、 アップデート中に置き換えるモジュールを選択します。 デフォルトでは、 置き換

えるネッ ト リ ス トの最上位モジュールが自動的に選択されます。列のヘッダをク リ ッ クする と、

リ ス トが並べ替えられます。 

6. [Next] をク リ ッ ク し次に進みます。

[Specify Module to be Replaced] ページが表示されます。

7. アップデートする元のネッ ト リ ス トでモジュールを選択します。 置き換えるモジュールの名前

に基づいて、 置き換えられるモジュールの名前が自動的に選択されます。 正しいモジュールが

選択されていない場合は、 手動で選択し直して ください。 

8. [Next] をク リ ッ ク し次に進みます。

[Update Netlist Summary] ページが表示されます。

9. 置き換えるモジュールのサマリ を確認して ください。 

10. [Finish] をク リ ッ クする と、新しいモジュール レベル ネッ ト リ ス トでデザインがアップデート

されます。

図 2-33 : Update Netlist ウィザード  : [Specify Replacement Module] ページ
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フロアプランを使用した作業

フロアプランとは

PlanAhead には、代替デバイス、 タイ ミ ング制約や物理制約、 インプリ メンテーシ ョ ン オプシ ョ ン

などのデザイン パラ メータをいろいろ試し解析できるフロアプラン環境があ り ます。このフロアプ

ランは、 特定ネッ ト リ ス トおよびデバイスをターゲッ トにしたデザイン制約のスナップシ ョ ッ ト と

い うふうに考えてください。フロアプランは PlanAhead で作成され、デバイスや制約を変更して試

すこ とができます。 

フロアプラン作成中に最上位 UCF ファ イルを任意数設定するこ と もできます。 モジュール レベル

の UCF ファ イルも、 [Import Constraints] コマンドを使用してインポートできます。 インポート さ

れたら、フロアプラン内の制約がすべて PlanAhead で管理されます。最初にインポート された UCF
ファ イルは、 PlanAhead またはインプリ メンテーシ ョ ン ツールでは参照されなくな り ます。 イン

ポート された制約および新し く割り当てられた制約はすべて 1 つの UCF ファ イルにまとめられ、

インプリ メンテーシ ョ ン ツールに渡されます。

ネッ ト リ ス ト  ベースのプロジェク トや、RTL ベースのプロジェク トの合成実行用に、複数のフロア

プランを作成するこ とができます。

フロアプランの作成

合成ネッ ト リス ト  プロジェク トおよび空のプロジェク ト

合成ネッ ト リ ス ト  ベースのプロジェク ト または空のピン割り当て用プロジェク トで作業している

場合、初期フロアプランはプロジェク ト作成プロセスで作成されます。 New Project ウ ィザードで、

フロアプラン名、 ターゲッ ト  デバイス、 最上位 UCF ファ イルを指定します。 モジュール レベルの

UCF ファ イルも、 [Import Constraints] コマンドを使用してインポートできます。

既存のプロジェク トでフロアプランを作成するには、 次の手順に従います。

1. 次のいずれかの方法で New Floorplan ウ ィザードを起動します。

♦ [File] → [New Floorplan] をク リ ッ ク します。

♦ [New Floorplan] ボタンをク リ ッ ク します。

New Floorplan ウ ィザードが表示されます。

2. [Next] をク リ ッ ク し次に進みます。

図 2-34 : [New Floorplan] ボタン
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フロアプラン名の指定とターゲッ ト  デバイスの選択

[Choose a Part and a Floorplan Name] ページが表示されます。 

3. このページでは次のオプシ ョ ンを設定します。

♦ [Floorplan name] : フロアプランの名前を入力します。

♦ 使用するデバイス :

- [From Netlist] : 最上位 EDIF ネッ ト リ ス ト  ファ イルに定義されているデバイスを使

用します。

- [Choose Part] : 参照ボタンをク リ ッ ク してデバイスを選択します。

4. [Next] をク リ ッ ク し次に進みます。

制約のインポート

[Import Constraints] ページが表示されます。

図 2-35 : New Floorplan ウィザード  : [Choose a Part and a Floorplan Name] ページ
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1. [Add] ボタンをク リ ッ ク して、 インポートする、最上位の UCF または NCF 制約ファイルを選

択します。 これらのファイルのインポート順は、 [Up] ボタンおよび [Down] ボタンを使用して

変更できます。 [Remove] ボタンをク リ ッ クする と、 ファ イルがリ ス トから削除されます。

モジュール レベルの制約ファイルが使用されている場合は、 こ こに含めないでください。 モ

ジュール レベルの制約のインポートの詳細は、 「モジュール レベルの制約のインポート 」 を参

照して ください。

2. [Next] をク リ ッ ク し次に進みます。

UCF ファ イルが PlanAhead にインポート されます。 この動作には多少時間がかかる場合があ

り ます。 

[New Floorplan Summary] ページが表示されます。

3. [Finish] をク リ ッ クする と、 フロアプランが作成されます。

新規のフロアプランが開き、 PlanAhead 環境でアクティブになり ます。

追加フロアプランは [New Floorplan] または [Copy Floorplan] コマンドを使用して作成します。

RTL プロジェク ト

RTL プロジェク トでは、合成およびインプリ メンテーシ ョ ン実行用にフロアプランを作成する必要

はあ り ません。インプリ メンテーシ ョ ン実行が起動する と、ターゲッ ト  デバイスおよび最上位 UCF
ファ イルが 1 つ定義されます。 さまざまなデバイス、制約、 インプリ メンテーシ ョ ン オプシ ョ ンを

設定して試すこ とができます。ただし、各実行に 1 つの UCF ファ イルしか割り当てるこ とができな

いため、制約は PlanAhead では変更されません。制約の変更やインプリ メンテーシ ョ ン結果の解析

には、 フロアプランが作成されます。 

[Select] → [Import Run] をク リ ッ ク し、 解析結果をインポートおよび解析する場合、 フロアプラン

を定義するよ うプロンプ トが表示されます。これで、フロアプランが作成され結果が表示されます。

実行を起動するための UCF ファ イルはこのフロアプランに読み込まれます。

図 2-36 : New Floorplan ウィザード  : [Import Constraints] ページ
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また、 フロアプランをインプリ メンテーシ ョ ン前に作成してデザインの解析や制約の変更ができま

す。[Select] → [Import Run] をク リ ッ ク しフロアプラン用の合成実行をインポート します。インポー

トが終了したら、[New Floorplan] コマンドを使用しフロアプランを作成します。 詳細は、「複数のフ

ロアプランの作成」 を参照して ください。

追加フロアプランは [New Floorplan] または [Copy Floorplan] コマンドを使用して作成します。

制約のインポート

UCF および NCF 形式の制約ファイルは、合成ソフ ト ウェア ツール、設計者、ザイ リ ンクス  ISE ソ
フ ト ウェア ツール、または PlanAhead の前のセッシ ョ ンによ り作成されますが、フロアプランにイ

ンポートできます。制約には、さまざまなインスタンスに対するタイ ミ ング制約、I/O の配置と規格、

および物理的なロケーシ ョ ン制約があ り ます。 UCF 形式ファイルの詳細は、ザイ リ ンクスの 『制約

ガイ ド』 を参照して ください。

物理制約をインポートする場合は、フロアプランを初期化する必要があ り ます。物理制約のインポー

トは次の手順に従います。

1. [File] → [Import Constraints] をク リ ッ ク します。

[Import Constraints] ダイアログ ボッ クスが表示されます。 

2. [Import Constraints] ダイアログ ボッ クスで、 次のオプシ ョ ンを設定してください。

♦ [Import physical constraints for] : 制約を割り当てるレベルを選択します。

- [Netlist <netlist name>] : 最上位の制約がインポート されます。

図 2-37 : [Import Constraints] ダイアログ ボックス
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- [Instance] :選択されたインスタンスに制約がインポート されます。ダイアログ ボッ ク

スには、 コマンドの実行前に選択したインスタンスが表示されます。 このオプシ ョ ン

は、 コアレベルの NCF ファ イルのよ うなモジュール レベルの制約をインポートする

と きに使用します。

♦ [Constraints files] : インポートする制約ファイルが表示されます。 

3. [Add] ボタンをク リ ッ ク し、 インポートする制約ファイルを選択します。 

4. [OK] をク リ ッ ク し、 制約をインポート します。

インポート実行中の警告やエラーに関する情報は、[Console] ウ ィンド ウに表示され、planAhead.log
に書き込まれます。

I/O ポートの割り当てと タイ ミ ング制約のよ うな、異なるタイプの制約を区別できるよ うに、複数の

制約ファイルをインポートするこ とができます。 

メモ : タイ ミ ング制約は、 2 回以上インポートする と重複します。 重複したタイ ミ ング制約は、

[Constraints] ウ ィンド ウで削除できます。

モジュール レベルの制約のインポート

PlanAhead では、 モジュール レベルの制約を選択して割り当てるこ とができます。 

制約をモジュール インスタンスに割り当てるには、 次の手順に従ってください。

1. [Netlist] ウ ィンド ウでインスタンスを選択します。

2. [File] → [Import Constraints] をク リ ッ ク します。
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[Import Constraints] ダイアログ ボッ クスが表示されます。

3. [Instance] をオンにし、[Instance] フ ィールドにモジュール レベルの制約をインポートするネッ

ト リ ス ト  インスタンスが指定されているこ とを確認します。

4. [Constraints files] で [Add] ボタンをク リ ッ ク し、 インポートする制約ファイルを選択します。 

5. [OK] をク リ ッ ク し、 制約をインポート します。

インポート実行中の警告やエラーに関する情報は、[Console] ウ ィンド ウに表示され、planAhead.log
に書き込まれます。

フロアプランでのデザイン制約のアップデート

PlanAhead では、フロアプランごとに UCF 制約ファイルが管理・保存されます。現在の PlanAhead
での UCF への変更は、 作業中のフロアプランにのみ適用されます。 

メモ : 新しい UCF ファ イルをインポート しても既存の UCF 設定は自動的にはアップデート されま

せん。 アップデートする制約は新しいファイルのインポート前にプロジェク トから削除し、 制約が

重複しないよ うにする必要があ り ます。重複した制約は [Constraints] ウ ィンド ウに表示され、後で

削除できます。

タイ ミング制約の削除

タイ ミ ング制約を削除するには、定義されたタイ ミ ング制約が [Constraints] ウ ィンド ウにすべて表

示されるよ うに設定します。 削除する制約を選択し、 [Delete] コマンドを実行しで削除します。

図 2-38 : [Import Constraints] ダイアログ ボックス
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1. [Constraints] ウ ィンド ウの [Group by type] アイコンをク リ ッ ク します。

2. Ctrl キーを押しながら制約を選択するか、 Ctrl + A を押すと、 複数またはすべての制約を選択

できます。

3. 右ク リ ッ ク し、 [Delete] をク リ ッ ク します。

4. [OK] をク リ ッ ク して削除を実行します。 

配置制約の削除

配置制約の割り当ては、新しい制約をインポートする とアップデート されます。既存の LOC 制約の

割り当ては、新しい割り当てで置き換えられます。インポート されるファ イルに LOC 制約が存在し

ない場合、 制約が削除されるこ とはあ り ません。 

インポート前に、選択した配置制約を削除できます。詳細は、 「選択した配置制約の削除」 を参照し

て ください。

新しい UCF 制約ファイルのインポート

最上位またはモジュール レベルの UCF または NCF 形式の新しい制約ファイルをインポートでき

ます。 

1. [File] → [Import Constraints] をク リ ッ ク します。

[Import physical constraints for] のオプシ ョ ンは次のとおりです。

♦ [Netlist 'netlist name'] : デザインの最上位の制約をインポート します。

♦ [Instance] : インポートする制約のロジッ ク  モジュール インスタンスを選択します。 ダイ

アログ ボッ クスが開いた時点では、コマンドの実行前に選択されたロジッ ク  インスタンス

が表示されます。

[Constraints files] には、 フロアプランへのインポートに選択されたファイルがすべて表示されま

す。[Add] ボタンをク リ ッ ク してインポートする  UCF ファ イルを追加できます。ファ イルはリ ス ト

に表示された順序でインポート されます。インポートする制約ファイルの順番を変更するには [Up]

図 2-39 : タイ ミング制約の削除
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または [Down] ボタンをク リ ッ ク します。[Remove] ボタンをク リ ッ クする と、ファ イルがリ ス トか

ら削除されます。 

2. 最上位の制約をインポートする場合は [Netlist]、モジュール レベルの制約をインポートする場

合は [Instance] をオンにします。

3. インポートするファ イルを選択するには、 [Add] ボタンをク リ ッ ク します。

4. ファ イルの選択が終了したら、 [OK] をク リ ッ ク します。

5. planAhead.log ファ イルまたは [Console] ウ ィンド ウのメ ッセージで、インポート中に問題が発

生していないか確認します。 

モジュール レベルの制約はプロジェク トに最上位の制約と して含められ、インプリ メンテーシ ョ ン

で使用されます。

インポートが正常に終了する と、 新しい配置制約のロケーシ ョ ンが [Device] ウ ィンド ウおよび

[Package] ウ ィンド ウに表示されます。タイ ミ ング制約は、[Constraints] ウ ィンド ウで表示および変

更できます。 PlanAhead では物理制約やタイ ミ ング制約の編集ができます。

複数のフロアプランの作成

既存プロジェク トでフロアプランを追加作成できます。「フロアプランの作成」 にある手順に従って

ください。

図 2-40 : 新しい UCF 制約ファイルのインポート
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複数のフロアプランの管理

[Floorplans] ウインド ウでプロジェク トのフロアプランを管理できます。[Floorplans] ウ ィンド ウの

右ク リ ッ ク  メニューから、 フロアプランをコピーまたは削除したり、 閉じた りできます。 また、 フ

ロアプランの [Properties] ウ ィンド ウにフロアプランに関する情報を表示するこ と もできます。

[Floorplans] ウ ィンド ウを開くには [Windows] → [Floorplans] をク リ ッ ク します。

フロアプランは複数を同時に作成または開いて、異なるデザイン、デバイス、制約の使用を確認する

こ とができます。 作成したフロアプランはそれぞれ作業中のインポート されたネッ ト リ ス ト を参照

します。 タブをク リ ッ クする と、 アクティブなフロアプランが切り替わり ます。 

フロアプランを複数開く とシステム メモ リの使用量が増加するのでご注意ください。

フロアプラン プロパテ ィの表示および編集

PlanAhead でオブジェク ト をク リ ッ クする と、[Properties] ウ ィンド ウに情報が表示され、確認でき

ます。 

フロアプランのプロパティを表示し、 編集するには次の手順に従います。

1. [Physical Hierarchy] ウ ィンド ウでフロアプランをどれか (fp1_16ns など) 選択します。

[Floorplan Properties] ウ ィンド ウが表示されます。

図 2-41 : 複数のフロアプランの管理

図 2-42 : 表示するフロアプランの選択
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2. [Floorplan Properties] ウ ィンド ウの [Name] フ ィールドに、 このプロジェク トのフロアプラン

の名前 (floorplan_2 など) を入力します。 

3. [Apply] をク リ ッ クする と、 入力した内容が有効になり ます。

メモ : [Cancel] ボタンをク リ ッ クする と、 変更内容は破棄されます。

4. [Part Compatibility] タブをク リ ッ ク します。 このタブには I/O ピン割り当ての互換性がある

パーツが表示されます。 ダイアログ ボッ クスのアイコンを使用し、 リ ス トからパーツを追加 ・

削除できます。 詳細については、 「互換性のあるパーツの選択」 を参照してください。

図 2-43 : [Floorplan Properties] ウィンドウ :[General] タブ

図 2-44 : [Floorplan Properties] ウィンドウ : [Part Compatibility] タブ
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5. [Constraints Files] タブをク リ ッ ク します。 インポート された UCF 制約ファイルのリ ス トが表

示されます (編集不可)。

6. [Attributes] タブをク リ ッ ク します。 このタブでは、 [Define new attribute] ボタンを使用して、

属性をフロアプランに割り当てられます。 

 フロアプランを閉じる

フロアプランを閉じるには、 [File] → [Close Floorplan] をク リ ッ クするか、 [Floorplan] タブの右側

の X マークをク リ ッ ク します。

確認のダイアログ ボッ クスが表示されたら、 [OK] をク リ ッ ク します。

閉じよ う とするフロアプランに保存されていない変更があれば、 変更を保存するかど うかを確認す

るボッ クスが表示されます。 [OK] をク リ ッ ク して変更を保存します。 

図 2-45 : [Floorplan Properties] ウィンドウ : [Constraint Files] タブ

図 2-46 : [Floorplan Properties] ウィンドウの [Define new attribute] ボタン

図 2-47 : [Floorplan] タブ
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フロアプランは閉じた後もプロジェク トで使用可能で、 いつでも開く こ とができます。 プロジェク

トのフロアプランはすべて [Floorplans] ウ ィンド ウに表示されます。 

この [Floorplans] ウ ィンド ウでフロアプランは開く、 閉じる、 コピーおよび削除するこ とができま

す。

フロアプランの削除

フロアプランをプロジェク トから削除し、 データをディ スクから削除するには、 [File] → [Delete
Floorplan] をク リ ッ ク します。ディ スクからファ イルが削除されるこ とを確認するダイアログ ボッ

クスが表示されます。

メモ : 作業中の PlanAhead セッシ ョ ンで加えた変更を保存するかど うかの確認メ ッセージが表示

されます。

フロアプランの保存

[Save Floorplan] コマンドの使用

フロアプランが保存される と、 そのフロアプランの project.data ディ レク ト リのファ イルもアップ

デート されます。 ファ イル保存の詳細は、 「プロジェク ト  データの出力」 を参照してください。

フロアプランを保存するには、[File] → [Save Floorplan] または [Save Floorplan] ボタンをク リ ッ ク

します。 

[Save Floorplan As] コマンドの使用

既存のフロアプランは、 変更し、 新しい名前で保存するこ とができます。 プロジェク トには、 元の

フロアプランと新しいフロアプランが含まれます。フロアプランに新しい名前を付けるには、「フロ

アプランを使用した作業」 参照して ください。

新しい名前でフロアプランを保存するには、 次の手順に従ってください。

図 2-48 : [Floorplans] ウィンドウ

図 2-49 : [Save Floorplan] ボタン
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1. [File] → [Save Floorplan As] をク リ ッ ク します。

[Save Floorplan As] ダイアログ ボッ クスが表示されます。

2. このダイアログ ボッ クスの [New Name] フ ィールドで新しい名前を指定します。 

3. [OK] をク リ ッ クする と、 フロアプランが新しい名前で保存されます。

フロアプランで定義された実行も保存されたフロアプランにコピーされます。 実行ディ レク ト リに

は実行の結果データは存在せず、 [Status] には [Not started] が表示されます。

フロアプランのコピー

フロアプランをコピーする主な目的は、 作業中のフロアプラン制約を保持したまま別のデバイスま

たはデバイス  アーキテクチャを選択するためです。 

フロアプランをコピーするには、 次の手順に従ってください。

1. コピーするフロアプランの [Floorplan] タブをク リ ッ ク します。

2. [File] → [Copy Floorplan] をク リ ッ ク します。 

[Copy Floorplan] ダイアログ ボッ クスが表示されます。

3. このダイアログ ボッ クスで、 次のオプシ ョ ンを設定します。

♦ [Name] : フロアプランの新しい名前を指定します。ダイアログ ボッ クスが表示された時点

ではデフォルト名が表示されます。

♦ [Part] : 新しいターゲッ ト  デバイスをオプシ ョ ンで指定できます。

♦ [Copy Pblock Rectangles] : 新しいデバイスで同じ座標が使用可能な場合に、 Pblock の長

方形をコピーするには、 このオプシ ョ ンをオンにします。

♦ [Copy Instance and Port Placement] : 新しいデバイスで同じ座標が使用可能な場合に、 配

置制約をコピーするには、 このオプシ ョ ンをオンにします。

4. [OK] をク リ ッ クする と、 コピーが実行されます。

フロアプランの名前の変更

フロアプランはデザイン プロジェク ト内で名前を変更できます。 この方法は次のとおりです。

1. [Physical Hierarchy] または [Floorplans] ウ ィンド ウでフロアプランを選択します。

フロアプランのプロパティが [Floorplan Properties] ウ ィンド ウに表示されます。

図 2-50 : [Copy Floorplan] ダイアログ ボックス
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2. [Floorplan Properties] が表示されない場合は、 フロアプラン上で右ク リ ッ ク し、 ポップアップ

メニューで [Floorplan Properties] をク リ ッ ク します。 

[Floorplan Properties] ウ ィンド ウは、 次のよ うに表示されます。 

3. [General] タブをク リ ッ ク し、 新しいフロアプランの名前を [Name] フ ィールドに入力します。

4. [Apply] をク リ ッ クする と、 フロアプランの名前が変更されます。

図 2-51 : ポップアップ メニューの [Floorplan Properties]

図 2-52 : [Floorplan Properties] ウィンドウ
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表示環境の使用 
本章は、 次のセクシ ョ ンで構成されています。

• 「表示環境」

• 「ウ ィ ンド ウの操作」

• 「ワークスペース  ウ ィンド ウの使用」

• 「共通のウ ィンド ウの使用」

• 「オブジェク トの選択」

• 「ウ ィ ンド ウの環境設定」

表示環境

PlanAhead™ ソフ ト ウェアでは、デザイン情報およびデバイス情報が、作業内容に応じたさまざま

なウ ィンド ウ  レイアウ トにダイナミ ッ クに表示されます。 

PlanAhead はスタンドアロン ソフ ト ウェア ツールと して、または ISE® ソフ ト ウェアから起動でき

ます。 スタンドアロンで起動する と  PlanAhead の機能はすべて使用できますが、 Project Navigator
から起動する場合は、 特定機能のみが使用できるよ うになっています。 Project Navigator との統合

についての詳細は、 第 5 章 「Project Navigator からの PlanAhead の使用」 を参照してください。

PlanAhead は、 RTL 開発および解析、 論理合成、 物理的デザイン解析、 フロアプラン、 ISE を使用

したインプリ メンテーシ ョ ンなど、FPGA デザイン プロセスの主要ステップをぞれぞれ制御するた

めに使用するこ とができます。 

PlanAhead では、表示レイアウ ト設定を定義してカスタマイズできるよ うになっています。I/O ピン

割り当て、 RTL 開発および解析、デザイン解析およびフロアプランを目的と した表示レイアウ トが

デフォルトで提供されています。PinAhead 環境、プロジェク ト環境、フロアプラン環境に対応した

ウ ィンド ウがそれぞれ開く よ うになっています。

PlanAhead では、入力フォーマッ トに応じてさまざまなタイプのプロジェク ト を作成できるよ うに

なっています。入力フォーマッ トには、 RTL ソース  ファ イル、合成ネッ ト リ ス ト 、 I/O ポート  リ ス

ト 、 およびインプリ メンテーシ ョ ン結果などがあ り ます。 表示レイアウ トは作成されたプロジェク

ト  タイプによって決ま り ます。PlanAhead のプロジェク ト  タイプについての詳細は、第 2 章 「プロ

ジェク トの作成および管理」 を参照して ください。 

プロジェク ト またはフロアプラン環境を表示するには、ツールバー ボタンの下にあるタブを選択し

ます。 

図 3-1 : プロジェク ト環境の選択
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PinAhead は [Tools] → [OpenPinAhead] をク リ ッ クする と起動します。

PinAhead のウィンドウ レイアウト

PlanAhead には I/O ピン配置機能もあ り、ピンの割り当てと ク ロ ッ クのプランニングができます。作

業中のフロアプランから  PinAhead 環境が起動し、 I/O ピン配置に必要な情報が表示されます。 I/O
ピン配置の詳細は、 第 4 章 「I/O ピンの配置」 を参照してください。 

[Tools] → [Open PinAhead] コマンドをク リ ッ クする と、 PinAhead 環境レイアウ トが表示されま

す。

表示環境のエリ アは次のよ うに定義されています。

1. オブジェク トのプロパティ、 ネッ ト リ ス ト 、 ソース

2. ク ロ ッ ク領域、 選択されたオブジェク ト、 制約

3. I/O ポート  リ ス ト

4. パッケージ ピン、 コンソール、 結果表示 (タイ ミ ング、 検索、 デザイン ルール チェッ ク )

図 3-2 : デフォルトの PinAhead 表示レイアウト
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5. ワークスペース  : [Device]、[Package]、[Schematic]、[Hierarchy] ウ ィンド ウ、レポート、WASSO
結果

PinAhead 環境では、 特定デバイス  パッケージおよびデザインの I/O 情報に関する情報が表示され

ます。PinAhead を起動する と この表示レイアウ トが読み込まれます。[Layout] → [Load Layout] →
[PlanAhead Default] をク リ ッ クする と、 デフォルトの PlanAhead 環境に戻り ます。 

プロジェク ト環境ウィンドウ レイアウト

RTL 開発および解析、合成やインプリ メンテーシ ョ ンの実行起動、 プロジェク ト全体の管理に、 プ

ロジェク ト環境を使用します。 詳細は、 第 2 章 「プロジェク トの作成および管理」 を参照してくだ

さい。

PlanAhead で RTL ベース  プロジェク ト を開く と、またはプロジェク ト環境のタブが選択される と、

プロジェ ク ト環境のレイアウ ト が表示されます。 表示されるレイアウ トはデザインのステート に

よって異なり ます。 

表示環境のエリ アは次のよ うに定義されています。

1. フロアプラン、 RTL ソースのウ ィンド ウ

2. プロパティや選択のウ ィンド ウ

3. コンソール、 RTL エラボレート、 デザイン実行、 I/O ポート、 DRC、 検索結果のウ ィンド ウ

図 3-3 : PlanAhead プロジェク ト環境
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4. RTL ネッ ト リ ス トのウ ィンド ウ

5. ワークスペース  : RTL 編集エディ タ、 回路図、 階層、 レポートの表示

フロアプラン環境ウィンドウ レイアウト

ネッ ト リ ス ト  ベースのプロジェク トや空のプロジェク トが開いている場合、またはフロアプランが

選択されている場合、フロアプラン環境のレイアウ トが表示されます。フロアプラン環境の詳細は、

第 10 章 「デザインのフロアプラン」 を参照してください。

表示環境のエリ アは次のよ うに定義されています。

1. 物理階層、 メ ト リ ッ ク、 RTL ソースのウ ィンド ウ

2. プロパティ、 選択、 フロアプランのウ ィンド ウ

3. コンソール、I/O ポート、パッケージ ピン、デザイン実行、結果表示 (タイ ミ ング、検索、DRC、

メ ト リ ッ ク ) のウ ィンド ウ

4. ネッ ト リ ス ト 、 制約のウ ィンド ウ

5. ワークスペース  : [Device]、[Package]、[Schematic]、[Hierarchy] ウ ィンド ウ、レポート、WASSO
結果

図 3-4 : PlanAhead のフロアプラン環境
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ウィンドウの操作

6. [World] ウ ィンド ウ

ウィンドウの操作

表示ウィンドウの切り替え

各ウ ィンド ウの表示エリ アにはタブが表示され、 タブをク リ ッ クする と、 ウ ィンド ウがアクティブ

になり ます。ウ ィ ンド ウのタイプによっては、タブを複数使用できます。ツールに慣れるために、次

の説明を読み、 実際にウ ィンド ウを操作してみてください。

1 つのウ ィンド ウでオブジェク ト を選択する と、 同じオブジェク トが別の該当ウ ィンド ウでも選択

されます。この相互選択機能によ り、ロジッ クの検索およびフロアプランが容易になり ます。デフォ

ルトのレイアウ トは、 さまざまなオブジェク トが選択されたと きに、 情報が最大限に表示できるよ

うになっています。 

表示エリ アのサイズは表示枠を動かすと変更できます。枠にカーソルを置く と スライ ド  シンボルに

変わり、 これを動かすと拡張または縮小できます。 

表示エリ アのアクティブ ウ ィンド ウは、その下部にあるタブをク リ ッ クする と切り替えるこ とがで

き、 ク リ ッ ク したタブがアクティブになり表示されます。

タブをダブルク リ ッ クする と全画面に表示されます。 ワークスペースでそのタブを再度ダブルク

リ ッ クする と元のタブ表示に戻り ます。 ワークスペース以外のウ ィンド ウは、 ウ ィンド ウのバーに

表示されている  [最大化/元のサイズに戻す] ボタンをク リ ッ クする と元に戻すこ とができます。詳細

は、 「ウ ィンド ウ  バナーのコマンドを使用したウ ィンド ウの操作」 を参照してください。

表示エリ アは、 複数のウ ィンド ウを一度に表示するために、 垂直方向または水平方向に分割できま

す。 分割エリ アには、 それぞれ複数のウ ィンド ウを含めるこ とができます。 分割は多様に設定でき

ます。 

各ウ ィンド ウのバナーには、 ウ ィンド ウ表示を変更するコマンドがあ り、 フロート させたり、 非表

示にしたり、最大化したり、閉じた りできます。ウ ィンド ウまたは表示エリ アを閉じる と、他のウ ィ

ンド ウのサイズが変更され、そのスペースに表示されます。ウ ィンド ウ  バナーのコマンドの詳細は、

次の章で説明します。

ワークスペースは、他のド ッキング エリ アとは異なる動作をします。 このエリ アに表示可能なタイ

プは決まっており、 [Device]、 [Schematic]、 [Hierarchy]、 [Package] ウ ィンド ウ と タイ ミ ング パス

レポート、RTL エディ タ  、WASSO 解析結果、 ISE ソフ ト ウェア レポート、および Getting Started
ページが含まれます。各ウ ィンド ウ  タイプに対して複数のウ ィンド ウを開く こ とが可能で、 ワーク

スペースで連動します。 ワークスペースは、 任意の数で垂直方向または水平方向に分割できます。

ウ ィンド ウのタブに表示されている  [閉じる] ボタンをク リ ッ クする と、ウ ィンド ウを閉じるこ とが

できます。ワークスペースのウ ィンド ウは、タブを右ク リ ッ ク して表示されるコマンドを使用して、

フロート または非表示にできます。 

ウィンドウを開く

メ イン メニューから  [Window] メニューを選択する と、ほとんどのタイプのウ ィンド ウを開く こ と

ができます。 既に開いているウ ィ ン ド ウを選択する と、 そのウ ィ ンド ウがアクティブにな り ます。

[Window] メニュー コマンドの一覧と説明は、付録 A の「[Window] メニュー」を参照してください。

図 3-5 : [Netlist] タブの選択
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[Schematic] ウ ィンド ウを表示するには、 オブジェク ト を少なく と も  1 つ選択し、 ポップアップ メ
ニューの [Schematic] コマンドまたは [Schematic] ツールバー ボタンをク リ ッ ク します。 

[Properties] ウ ィンド ウを表示するには、 オブジェク ト を少なく と も  1 つ選択し、 ポップアップ メ
ニューの [<Object type> Properties] をク リ ッ ク します。

[Window] メニューの [New Device View] または [New Package View] ボタンをク リ ッ クする と、

ワークスペースにウ ィンド ウが新し く開きます。

ウィンドウ バナーのコマンドを使用したウィンドウの操作

各表示エリ アは、 ウ ィンド ウ間で共通のコマンドで操作できます。

ウ ィンド ウのバナーで右ク リ ッ クする と、これらのコマンドすべてがポップアップ メニューに表示

されます。

自動非表示の使用

表示エリ アを自動非表示モードにして、 ウ ィンド ウの表示を制御できます。 自動非表示モードにす

るには、 ウ ィンド ウ  バナーで自動非表示の切り替えのボタンをク リ ッ クするか、 ポップアップ メ
ニューで [Auto-hid] をク リ ッ ク します。

表 3-1 : ウィンドウ バナーのコマンド

ツールバー ボタン コマンド 説明

最大化/元のサイズ

に戻す

ワーク スペース以外のウ ィ ン ド ウを最大化または元

のサイズで表示します。 

フローティングの

切り替え

ワーク スペース以外のウ ィ ン ド ウをフロー ト表示ま

たはド ッキングします。PlanAhead デスク ト ップの外

にフロート表示される場合があ り ます。

自動非表示の切り

替え

ウ ィンド ウの表示/非表示を切り替えます。非表示にす

る と、 ド ッキング エリ ア全体が PlanAhead デスク

ト ップの周囲にタブと して表示され、 ワークスペース

にはほかのド ッキング エリ アが表示されます。タブ上

のアイコンをク リ ッ クする と、 ウ ィンド ウが再表示さ

れます。 

閉じる

ウ ィンド ウを閉じます。 ワークスペースにはほかのタ

ブまたはド ッキング エリ アが表示されます。

閉じたウ ィ ン ド ウまたはタブを開くには、 [Window]
メニュー コマンドを使用します。

図 3-6 : [Netlist] ウィンドウで自動非表示切り替えのボタンをクリ ック
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非表示にされたド ッキング エリ アが PlanAhead デスク ト ップの左上端にタブと して表示されます。

ワークスペースにはほかのド ッキング エリアが表示されます。 

自動非表示タブにはアイコンがあ り、これをク リ ッ ク してウ ィンド ウを元の位置に表示できます。タ

ブ上にカーソルを動かすと、 そのウ ィンド ウが一時的に表示されます。 自動非表示されたウ ィンド

ウを再ド ッキングするには、 自動非表示の切り替えのボタンをク リ ッ クするか、 ポップアップ メ

ニューで [Auto-hide] コマンドをク リ ッ ク します。

自動非表示モードを解除するには、[Layout] → [Undo Toggle Autohidden/Docking Mode] をク リ ッ

ク します。

ウィンドウのフロート

ウ ィ ン ド ウは、 ド ッキングを解除してフロート表示し、 個別に移動およびサイズ変更ができます。

ウ ィンド ウをフロート表示するには、ウ ィンド ウのタブまたはバナーをク リ ッ ク して選択し、フロー

ティングの切り替えのボタンをク リ ッ クするか、ポップアップ メニューで [Floating] をク リ ッ ク し

ます。

ウ ィンド ウは新しいフロート  ウ ィンド ウに表示されます。フロート表示されたウ ィンド ウは重なっ

て表示されます。 

ウ ィンド ウ  バナーをド ラ ッグする と、 フロート  ウ ィンド ウを移動できます。 PlanAhead のメ イン

ウ ィンド ウの外にも移動できます。

すべてのフロート  ウ ィンド ウ  タイプのデフォルトの表示位置とサイズは、保存されたレイアウ トに

含まれています。 

ワークスペースのウ ィンド ウは、 タブを右ク リ ッ ク してポップアップ メニューで [Float Window]
をク リ ッ クする と、 フロート表示できます。

表示エリアのサイズの定義

メ イン ド ッキング エリ ア間のウ ィンド ウ枠をド ラ ッグする と、 PlanAhead のド ッキング エリ アの

ウ ィンド ウのサイズを変更できます。 カーソルがスライ ド  コン ト ロールに変わる と、 ウ ィンド ウの

枠をド ラ ッグできます。 表示エリ アを削除するか非表示にして、 ほかのウ ィンド ウの表示場所を広

くするこ と もできます。 ウ ィンド ウを閉じる と、開いた場所にほかのド ッキング エリ アが表示され

ます。 

図 3-7 : 自動非表示モードの [Netlist] ウィンドウ
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ウィ ンドウ特定のツールバー コマンドの使用

多くのウ ィンド ウには、ウ ィンド ウ内に表示されるツールバーがあ り ます。次に、最も一般的なウ ィ

ンド ウ  ツールバー コマンドを示します。 

その他にも、ウ ィ ンド ウ  バナーに表示されるツールバー ボタンがあ り ます。これらの詳細は、「ウ ィ

ンド ウ  バナーのコマンドを使用したウ ィンド ウの操作」 を参照してください。

ワークスペース ウィンドウの使用

ワークスペース ウィンドウとは

PlanAhead のワークスペースでは、 デザインがグラフ ィカルに表示され、 レポートやログも表示さ

れます。 

ワークスペースには次のものが表示されます。

• RTL エディ タ

• [Device] ウ ィンド ウ

• [Package] ウ ィンド ウ

表 3-2 : 共通のウィンドウ ツールバー コマンド

ツールバー ボタ

ン
コマンド 説明

[Collapse All] 展開表示したツ リー全体を非展開します。

[Expand All] ツ リー全体を展開します。

[Automatical ly
scroll to selected
objects]

特定のウ ィ ン ド ウで、 新し く選択したオブジェ ク ト ま

で自動的にツ リーを展開してツ リーをスク ロールする

か、 しないかを切り替えます。 すべてのウ ィンド ウで、

このコマンドがデフォルトでオンになっています。

[Automatically 
update the 
contents of this 
window when 
new objects are 
selected]

ほかのウ ィ ン ド ウでオブジェ ク ト を新し く選択したと

きに、 [Properties] ウ ィンド ウを自動的に更新してその

プロパティ を表示するか、 更新しないかを切り替えま

す。 デフォル ト ではこのコマンドがオンになっていま

す。

[Previous object] 選択したオブジェク トの リ ス ト を古い方へ戻り ます。 

ワークスペース  ウ ィンド ウでは、 以前に使用したズー

ム レベルが反映されます。

[Next object] 選択したオブジェ ク ト の リ ス ト を新しい方へ戻 り ま

す。このボタンは、[Previous Object] ボタンを使用する

と使用できるよ うになり ます。

ワークスペースは、 その時点で使用していたズーム レ
ベルで表示されます。

http://www.xilinx.com


PlanAhead ユーザー ガイド japan.xilinx.com 89
UG632 (v 11.1.0)
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• [Schematic] ウ ィンド ウ

• [Hierarchy] ウ ィンド ウ

• Getting Started ページ

• レポートおよびログ ファ イル

• WASSO の結果

ワークスペース ウィンドウを開く

[Device] ウ ィンド ウおよび [Package] ウ ィンド ウは、メ イン メニューの [Window] コマンドを使用

する と ワークスペースに開く こ とができます。ワークスペース  エリ アには同じタイプのウ ィンド ウ

を複数開く こ とができます。 たとえばデバイスの異なる部分を表示するために、 [Device] ウ ィンド

ウを 2 つ開く こ とができます。 新しい [Device] ウ ィンド ウまたは [Package] ウ ィンド ウを開くに

は、[Window] → [New Device View] または [Window] → [New Package View] をク リ ッ ク します。

[Schematic] ウ ィンド ウを開く方法は少し異なり ます。 [Schematic] ウ ィンド ウを開くには次の手順

に従います。

1. 回路図形式で開くオブジェク ト を少な く と も  1 つ選択します。

2. ポップアップ メニューで [Schematic] コマンドをク リ ッ クするか、 F4 キーを押すか、 または

[Schematic] ボタンをク リ ッ ク します。 

ワークスペースに [Schematic] ウ ィンド ウが表示されます。 [Schematic] コマンドを実行するたび

に、 ワークスペースに [Schematic] ウ ィンド ウが追加されます。

Getting Started ページは、 [Help] → [Getting Started] をク リ ッ クする と開きます。

ワークスペースの全画面表示

ワークスペースのタブをダブルク リ ッ クする と、 全画面表示されます。 ワークスペースでそのタブ

を再度ダブルク リ ッ クする と元のタブ表示に戻り ます。 

タブを右ク リ ッ クする と、 ワークスペースのタブのポップアップ メニューが表示されます。 ワーク

スペースの状況に応じて、 ポップアップ メニューで [Maximize Workspace] または [Restore
Workspace] を選択します。

ワークスペースのフロート表示

ワークスペースをフロート表示するには、 タブを右ク リ ッ ク してポップアップ メニューで [Float
Window] をク リ ッ ク します。

ワークスペースの印刷

[Device]、[Package]、[Schematic]、[Hierarchy] ウ ィンド ウのワークスペースで表示されている箇所

を印刷するこ とができます。[File] → [Print] をク リ ッ ク し、現在表示されている箇所を印刷します。

図 3-8 : [Schematic] ボタン

http://japan.xilinx.com


90 japan.xilinx.com PlanAhead ユーザー ガイド
UG632 (v 11.1.0)

第 3 章 : 表示環境の使用

ワークスペース ウィンドウを閉じる

ワークスペース内のウ ィンド ウは、 ウ ィンド ウ  タブの X マークをク リ ッ クする と閉じます。 

ワークスペースの分割 
ワークスペース  ウ ィンド ウ  エリ アを水平または垂直に分割して、複数のウ ィンド ウを同時に表示で

きます。 図にあるよ うにウ ィンド ウのポップアップ メニューを使用します。

図 3-9 : [Device] ウィンドウ タブと  X マーク

図 3-10 : 垂直に分割
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各ウ ィンド ウを個別に操作でき、 複数のウ ィンド ウをド ッキング表示できます。 

同じタイプのウ ィンド ウを複数開く こ と もできます。 たとえば、 [Device] ウ ィンド ウを 2 つ開いて

デバイスの異なる部分を表示したり、 異なる倍率で表示したりできます。

共通のウィンドウの使用

[Console] ウィンドウおよび Tcl コマンド  ライン

[Console] ウ ィンド ウには、実行した Tcl コマンドのメ ッセージが表示されます。これら メ ッセージ

はすべて、planAhead.log ファ イルにも書き込まれます。 コマンドのエラー、警告、および完了に関

する メ ッセージがこのウ ィンド ウに表示されます。

[Console] ウ ィンド ウを表示するには、 [Window] → [Console] をク リ ッ ク します。

図 3-11 : 垂直に並んだ 2 つのワークスペース ウィンドウ

図 3-12 : [Console] ウィンドウ
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 Tcl コマンド  ラインの使用 
上の図に示されているコマンド  ラインを使用する と、Tcl 形式の PlanAhead コマンドを使用して手

動でコマンドを入力できます。 コマンドは、 [Command] ボッ クスにコマンドを入力する と、実行で

きます。 メニュー操作やド ラ ッグ アンド  ド ロ ップなどの操作が実行可能な編集コマンドには、同等

の Tcl コマンドがあ り ます。インターフェイスを使用してコマンドを実行する と、対応する  Tcl コマ

ンドが実行され、 [Console] ウ ィンド ウに表示されます。 この内容は、 planAhead.jou ファ イルに書

き込まれます。 

コマンドの履歴は、 [Console] ウ ィンド ウで上方向キーまたは下方向キーを押すこ とで確認できま

す。 

Tcl ヘルプの使用

次の構文をコマンド  ラインに入力する と、 すべてのコマンドに対するヘルプが表示されます。

Command> hdi::?

または

Command> help

コマンドの詳細は、 次のよ うにヘルプのクエリーを拡張する と表示できます。

Command> hdi::pblock ?

正確なコマンド構文を確認するには、 コマンドを一度実行し、 PlanAhead の起動ディ レク ト リに含

まれている  planAhead.jou ファ イルを確認します。

[World] ウィンドウの使用

[World] ウ ィンド ウは、右下端に表示され、アクティブなワークスペースで表示されている情報の概

要が表示されます。 [World] ウ ィンド ウを表示するには、 [Window] → [World] をク リ ッ ク します。 

[World] ウ ィンド ウでは、 [Schematic]、 [Device]、 [Package]、 および [Hierarchy] ウ ィンド ウで拡

大表示されたエリ アや選択されたオブジェク トが反映されます。

アクティブ ウ ィンド ウで表示されているエリアは長方形で表示されます。この長方形をド ラ ッグす

る と表示エリ アを変更できます。 また、 この長方形のサイズはカーソルをド ラ ッグする と変更でき

ます。変更する と、アクティブ ウ ィンド ウの拡大/縮小率がこの長方形で定義された新しい表示エリ

アに一致するよ うに調整されます。

選択された Pblock、インスタンス、および I/O ポートは、[World] ウ ィンド ウでハイライ ト されます。

図 3-13 : [World] ウィンドウ
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ステータス バーの使用

PlanAhead の下部に表示されるバーにはステータスが表示されます。 

次に、 ステータス  バーの各フ ィールドの定義および説明を示します。

現在のモード  フ ィールド

ステータス  バーの左端には、現在のモードを示すアイコンが表示されます。デフォルトのモードは

[Select Mode] で、黄色の矢印マークが表示されています。ほかには、[Zoom Area]、[Draw Pblock]、
および PlanAhead がユーザーによる入力を待機しているこ とを示す砂時計が示されます。

情報メ ッセージ フ ィールド

ステータス  バーの 2 番目のフ ィールドには、文脈依存の情報が表示されます。 たとえば、 カーソル

が [Device] ウ ィンド ウまたは [Schematic] ウ ィンド ウ上にある場合、このフ ィールドにはカーソル

がポイン ト しているインスタンス名が表示されます。 また、 ツールバーまたはメニューの上にカー

ソルを置いた場合は、 PlanAhead コマンドの詳細も表示されます。 

座標フ ィールド

情報メ ッセージ フ ィールドの右は座標フ ィールドです。[Device] ウ ィンド ウでカーソルを BRAM、

DSP48 などに動かすと、 こ こにその名前と座標が表示されます。

モード

どのタイプのプロジェク トが使用されているかを示します。PlanAhead が ISE Project Navigator か
ら起動されている場合、 ISE 統合モードが表示されます。 

Java メモリ使用率ゲージ

PlanAhead のグラフ ィカル ユーザー インターフェイスでの Java メモ リ制限は、 Windows の場合

512MB 、 64 ビッ トの Linux の場合 1GB となっています。 左下端にメモ リ  ゲージがあ り、 メモ リ

使用率が表示されます。このゲージが制限値の 10% 内のうちに作業を保存し、ツールを再起動する

必要があ り ます。このゲージは Java のメモリ使用率のみを表示します。タスク  マネージャやト ップ

では Java および C のメモ リ使用率が表示され、 その制限値は高く表示されています。

図 3-14 : ステータス バー
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オブジェク トの選択

PlanAhead では、 オブジェク ト を選択、 ハイライ ト 、 またはマークできます。

オブジェク トの選択

オブジェク トの選択

PlanAhead では、 いくつかの方法でオブジェク ト を選択できます。 現在のウ ィンド ウでオブジェク

ト を選択するには、そのオブジェク ト をク リ ッ ク します。オブジェク トは、1 つのウ ィンド ウで選択

される と、 ほかのウ ィンド ウでも選択されます。

オブジェク ト を移動するには、マウスを使って移動先にド ラ ッグ アンド ド ロ ップします。移動でき

るオブジェク ト を選択する と、 カーソルが手の形に変化します。

オブジェ ク ト が重なる場合は、 優先スキームによ り小さい方のオブジェ ク ト が選択されます。

[Device] ウ ィンド ウでオブジェク トが選択しにくい場合は、[Physical Hierarchy] ウ ィンド ウまたは

[Netlist] ウ ィンド ウで選択してください。オブジェク トは、[PlanAhead Options] ダイアログ ボッ ク

スの [Selection Rules] ページの設定内容にかかわらず、この 2 つのウ ィンド ウからであればいつで

も選択できます。 

オブジェク トがいくつも重なっている場合は、ポップアップ メニューで [Select] コマンドを使用す

る と、 正しいオブジェク ト を選択できます。

複数のオブジェク トの選択

オブジェク ト を選択できるウ ィンド ウや、ダイアログボッ クスの リ ス トでは通常、Shift キーを使用

してツ リーや表の中のオブジェク トの範囲を指定できます。 Ctrl キーを使用する と、 複数の要素を

個別に指定できます。 

[Select Area] コマンドの使用

どのワークスペース  ウ ィンド ウでも、オブジェク ト を長方形で囲んで選択できます。 この方法は次

のとおりです。

1. [Select] → [Select Area] をク リ ッ クするか、 [Select Area] ボタンをク リ ッ ク します。

オブジェ ク ト を長方形で囲みます。 長方形に囲まれるか接触しているオブジェ ク ト はすべて

[Select Area] ダイアログ ボッ クスに表示され、 タイプ別にフ ィルタできます。 

2. チェッ クボッ クスをオフにする と、 そのタイプのオブジェク トは選択から除外されます。 

図 3-15 : [Select Area] ボタン 

図 3-16 : [Select Area] ダイアログ ボックス
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3. [OK] をク リ ッ クする と、 指定したオブジェク トがすべて選択されます。

プリ ミテ ィブの親モジュールの選択

選択されたプリ ミ ティブ ロジッ クすべての親モジュールを選択するには、[Select Primitive Parents]
を使用します。 このコマンドはポップアップ メニューで選択でき、ほとんどのウ ィンド ウで使用可

能です。

フロアプランの管理は、ロジッ ク  モジュールが Pblock に割り当てられている方が、プリ ミ ティブ ロ
ジッ ク  インスタンスに割り当てられている場合よ り も簡単です。タイ ミ ング パスのグループは簡単

に選択でき、 選択する とパス上のプリ ミ ティブ ロジッ ク  インスタンスがすべて選択されます。

[Select Primitive Parents] コマンドを実行する と、 選択されたプリ ミ ティブ ロジッ クすべての親モ

ジュールが自動的に選択されます。 

最初に選択されたプリ ミ ティブ ロジッ クの選択は解除され、 最初に選択されたロジッ クが ROOT
レベルのロジッ クでない限り、 親モジュールのみが選択されます。

モジュールが選択されている場合は、 コマン ド を実行しても親モジュールは選択されず、 そのモ

ジュールが選択されたままになり ます。 そのモジュールが選択されたままになり ます。

[Select] メニュー コマンドの使用

[Select] メニューでは、選択、選択解除、ハイライ ト 、およびマークを実行できます。[Select] メニュー

のコマンドの詳細は、 付録 A の 「[Select] メニュー」 を参照してください。

選択したオブジェク トすべての表示

ワークスペースのウ ィンド ウのズーム オプシ ョ ンを使用する と、選択されたオブジェク ト をすべて

表示できます。 次の方法のいずれかを実行する と、 拡大率が変更され、 選択したオブジェク トがす

べて表示されます。

• [View] → [Fit Selection] をク リ ッ ク します。 

• F9 キーを押します。

• [Fit Selection] ボタンをク リ ッ ク します。

図 3-17 : [Fit Selection] ボタン
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[Selection] ウィンドウの使用

次に示すよ うに、 [Selection] ウ ィンド ウには、 現在選択されているオブジェク トの リ ス トが表示さ

れます。 オブジェク トは、 並び替えたり、 選択を解除したり、 マークを付けたりするこ とができま

す。 このリ ス トは、 フロアプランのオブジェク トが変更される と動的に更新されます。 このウ ィン

ド ウを表示するには、 [Window] → [Selection] をク リ ッ ク します。 

エレ メン トは、 列のヘッダをク リ ッ クする と、 アルファベッ ト順に並び替わり ます。 オブジェク ト

は、並べ替える列のヘッダをク リ ッ クする と、名前、 ID 番号、 または種類で並べ替えるこ とができ

ます。 選択したアイテムは、 [Unselect]、 [Unselect All]、 または [Unselect All Except] コマンドを

使用して リ ス トから削除できます。 

Ctrl キーおよび Shift キーを使用して、オブジェク トのグループを選択するこ と もできます。選択し

たオブジェク トの合計数は、 ウ ィンド ウのタイ トル バーに表示されます。

選択したオブジェク トのハイライ ト

オブジェク ト を指定した色でハイライ ト表示できます。 ハイライ ト表示は、 フロアプランのハイラ

イ ト表示をすべて解除するまで保持されます。 ハイライ トの詳細は、 次を参照してください。

• 「選択したオブジェク トのハイライ ト 」

• 「[Select Primitives] コマンドおよび [Highlight Primitives] コマンドの使用」

図 3-18 : [Selection] ウィンドウ

図 3-19 : [Selection] ウィンドウのポップアップ メニュー コマンド
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選択したオブジェク トのマーク

選択したオブジェク トすべてにマーク  シンボルを付けるこ とができます。 詳細は、 「選択したオブ

ジェク トのマーク」 を参照して ください。

選択ルールの設定

オブジェ ク ト を選択する と、 ほかのオブジェ ク ト も同時に選択される こ とがあ り ます。 たとえば

Pblock を選択する と、割り当てられたネッ ト リ ス トのインスタンスも選択されます。選択のビヘイ

ビアは、 [Tools] → [Options] → [Selection Rules] で選択規則を設定して制御できます。

次に、 [Selection Rules] ページを示します。

[Set] 列のチェッ クボッ クスで、 自動選択のオン/オフを切り替えるこ とができます。 オンにして

[From] 列でオブジェク ト  タイプを指定する と、 [To] 列でのオブジェク ト  タイプの指定が必須にな

り ます。 オフにする と、 [From] 列のみの指定になり ます。

デフォルトの選択規則を使用する と、 PlanAhead を最も効果的に使用できます。 このソフ ト ウェア

に慣れるまではデフォルトの使用を推奨します。

ワークスペース ウィンドウのオブジェク トの選択機能の設定

[Tools] → [Options] → [Themes] をク リ ッ クする と、 [PlanAhead Options] ダイアログ ボッ クスの

[Themes] ページで、 オブジェク トの選択ができます。

オブジェク ト選択の設定の詳細は、「PlanAhead の表示オプシ ョ ンのカスタマイズ」 を参照してくだ

さい。

図 3-20 : [PlanAhead Options] ダイアログ ボックス : [Selection Rules] ページ
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文脈依存カーソルについて

次のコマンド  モードではカーソルの形が変わり ます。

• カーソルが水平、垂直、 または斜めの両方向矢印に変化した場合は、 Pblock の枠およびウ ィン

ド ウの枠を伸縮できます。

• カーソルが手の形に変化した場合は、 Pblock やインスタンスを移動できます。

• カーソルが十字型に変化する と、長方形を描画した拡大範囲指定、ピン割り当てエリ アの定義、

または Pblock の長方形の描画を実行できます。 

• オブジェク ト を移動できない場所にド ラ ッグする と、 カーソルは斜線が入った円になり ます。

• オブジェク ト を移動できる場所にド ラ ッグする と、 カーソルは、 十字型に交差した両方向の矢

印になり ます。

ウィンドウの環境設定

PlanAhead には、 ユーザー設定可能な表示オプシ ョ ンが多くあ り ます。 このツールはデフォルトの

設定で提供されていますが、 これはカスタマイズできます。詳細は、「PlanAhead の表示オプシ ョ ン

のカスタマイズ」 を参照して ください。

表示レイアウ トの設定を保存して、後で PlanAhead を使用する と きに使用できます。PinAhead、プ

ロジェク ト 、 およびフロアプランのレイアウ トは個別に保存されます。 PlanAhead 全体のウ ィンド

ウサイズおよび位置は、 レイアウ ト  ファ イルに保存され、次回の使用時に復元されます。 この表示

設定は、PlanAhead を閉じる と きにホーム ディレク ト リに保存されます。設定ファイルのレイアウ

トの詳細は、 「デフォルト環境の出力」 を参照して ください。

PlanAhead ではフロアプラン環境レイアウ トにいくつかのオプシ ョ ンが用意されています。 これら

のレイアウ トでは、最も効率よ く適切な情報が表示されます。次回 PlanAhead を使用する と きの表

示 「テーマ」 を保存できます。 詳細は、 「カスタム テーマの作成および使用」 を参照してください。

PlanAhead の表示オプシ ョ ンのカスタマイズ

ウ ィンド ウの表示オプシ ョ ンを変更する と、 環境の表示やビヘイビアを制御できます。

表示オプシ ョ ンを確認または編集するには、 [Tools] → [Options] をク リ ッ ク します。 [PlanAhead
Options] ダイアログ ボッ クスが表示されます。変更は、[OK] ボタンまたは [Apply] ボタンをク リ ッ

クする と有効になり ます。 [Cancel] をク リ ッ クする と、 変更は反映されません。

[Themes] ページでは全般的な環境を制御する設定を確認および変更できます。インターフェイスの

さまざまなエリ アのオプシ ョ ンを確認または変更できます。 [Themes] ページの、 [General]、
[Device]、 [I/Os]、 および [Bundle Nets] タブをク リ ッ ク して、 表示設定を変更できます。

http://www.xilinx.com


PlanAhead ユーザー ガイド japan.xilinx.com 99
UG632 (v 11.1.0)

ウィンドウの環境設定

ウィンドウの全般的な表示オプシ ョ ンの設定

[General] タブでは、PlanAhead ウ ィンド ウの全般的な色や外観のオプシ ョ ンをカスタマイズできま

す。 

[Color] 列をク リ ッ クする とプルダウン メニューに切り替わり ます。 プルダウンの矢印をク リ ッ ク

する とポップアップ メニューが表示され、 色を選択できます。

図 3-21 : [General] タブ
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[Device] ウィンドウの表示オプシ ョ ンの設定

[Device] タブを使用する と、[Device] ウ ィンド ウのオブジェク ト  タイプごとに色、表示/非表示、選

択可/不可のデフォルト設定を設定できます。 

チェッ ク  ボッ クスで、オン/オフを切り替えます。[Display] 列のチェッ ク  ボッ クスをオフにする と、

[Device] ウ ィンド ウでそのオブジェク ト  タイプが非表示になり ます。[Select] 列のチェッ ク  ボッ ク

スをオフにする と、 [Device] ウ ィンド ウでそのオブジェク ト  タイプが選択できな くな り ます。

[Display] がオンであれば、 オブジェク トは表示されます。

メモ : オブジェク トの種類によっては、 [Frame Color] オプシ ョ ンおよび [Fill Color] オプシ ョ ンが

設定できないものがあ り ます。

メモ : オブジェク トにはデバイス特定のものがあ り、 それ以外のデバイスでは無効です。

図 3-22 : [Themes] ページ : [Device] タブ 
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[Package] ウィンドウの表示オプシ ョ ンの設定

[I/O] タブではオブジェク ト  タイプごとに、 [Package] ウ ィンド ウでの色、 表示/非表示、 選択可/不
可を設定するこ とができます。 

チェッ クボッ クスで、オン/オフを切り替えます。[Display] 列のチェッ ク  ボッ クスをオフにする と、

[Device] ウ ィンド ウでそのオブジェク ト  タイプが非表示になり ます。 [Select] 列のチェッ クボッ ク

スをオフにする と、 [Device] ウ ィンド ウでそのオブジェク ト  タイプが選択できな くな り ます。

[Display] がオンであれば、 オブジェク トは表示されます。

メモ : オブジェク トの種類によっては、 [Frame Color] オプシ ョ ンおよび [Fill Color] オプシ ョ ンが

設定できないものがあ り ます。

メモ : オブジェク トにはデバイス特定のものがあ り、 それ以外のデバイスでは無効です。

[Device] ウィンドウのバンドル ネッ ト表示オプシ ョ ンの設定

[Device] ウ ィンド ウのバンドル ネッ トの表示は、 [Bundle Nets] タブで設定します。

バンドルの信号カウン ト範囲は、 [From] 列と  [To] 列で指定します。 各列でバンドル ネッ トの範囲

を個別に設定します。

チェッ クボッ クスで、オン/オフを切り替えます。 [Display] 列のチェッ クボッ クスをオフにする と、

[Device] ウ ィンド ウでそのバンドル ネッ ト範囲が非表示になり ます。 [Select] 列のチェッ クボッ ク

図 3-23 : [Themes] ページ :[Device] タブ 
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スをオフにする と、 [Device] ウ ィンド ウでそのオブジェク ト  タイプが選択できな くな り ます。

[Display] がオンであれば、 オブジェク トは表示されます。

[Device] ウ ィンド ウに表示されるバンドルの線の幅は、 [Width] 列を変更してバンドル ネッ ト ごと

に設定できます。

[Schematic] ウィンドウでのスラックおよびファンアウトの表示オプシ ョ ンの設定

[Schematic] ページでは、 ソース  ピンにファンアウ ト値を、 デスティネーシ ョ ン ピンにスラ ッ ク値

を表示するよ うに設定できます。詳細は、「回路図ピンのスラ ッ ク、ファンアウ ト、値のアノテーシ ョ

ン」 を参照して ください。

ツールバー コマンドを使用した表示の調整

[Device] ウ ィンド ウまたはメ イン ツールバーのツールバー ボタンを使用して、 表示を変更するこ

と もできます。 ボタンの中には、 特定のタイプのオブジェク トが表示されている場合しか有効でな

いものがあ り ます。 ツールバー コマンドの説明は、 「ツールバー コマンド」 を参照してください。 

カーソルをボタンの上に移動する と、 機能を説明するツール ヒ ン トが表示されます。 

図 3-24 : [Themes] ページ :バンドル ネッ トの設定

図 3-25 : 表示を制御するツールバーのボタン
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カスタム表示設定の保存

テーマの選択

PlanAhead には、淡色と濃色両方のデフォルトの背景設定があ り ます。[Themes] ページのプルダウ

ン メニューで [PlanAhead Light Theme] または [PlanAhead Dark Theme] のいずれかを選択しま

す。

これらのデフォルト  オプシ ョ ンは、planahead.ini ファ イルで定義されます。詳細は、「ウ ィンド ウ表

示オプシ ョ ン ファ イル (planAhead.ini と  <theme_names>.patheme)」 を参照してください。

カスタム テーマの作成および使用

カスタムのウ ィンド ウ設定を保存して PlanAhead の初期化ファイルを作成し、以後のセッシ ョ ンで

使用できます。 これは [Themes] ページのプルダウン メニューの横にある  [Save As] ボタンをク

リ ッ クする と保存されます。

ユーザー定義のテーマを作成する場合は、 カスタムの設定が保存されている初期化ファイルのバッ

クアップを取っておく こ とをお勧めします。 デフォルトおよびカスタムの初期化ファイルについて

の詳細は、「ウ ィンド ウ表示オプシ ョ ン ファ イル (planAhead.ini と  <theme_names>.patheme)」を参

照して ください。

図 3-26 : カスタム テーマの作成
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PlanAhead の動作オプシ ョ ンの設定

選択ルール オプシ ョ ンの設定

[Selection Rules] ページでは、 すべてのウ ィンド ウのオブジェク ト選択設定を制御できます。 オブ

ジェク ト を選択する と、ほかのオブジェク ト も同時に選択されるこ とがあ り ます。たとえば Pblock
を選択する と、割り当てられたネッ ト リ ス トのインスタンスも選択されます。詳細は、「オブジェク

トの選択」 を参照して ください。

シ ョート カッ ト  キーワードの設定

頻繁に使用されるコマンドには、 キーボードのキーを組み合わせたシ ョート カッ トが定義されてい

ます。 シ ョート カッ トは、 ポップアップ メニューのコマンドの横に表示されます。 たとえば、 [Fit
Selection] コマンドのシ ョート カッ ト キーは、 F9 です。

[PlanAhead Options] ダイアログ ボッ クスの [Shortcuts] ページで、デフォルトのシ ョート カッ ト を

変更できます。 

[Shortcuts] ページで、カスタムのシ ョート カッ ト設定を含むシ ョート カッ トのスキーマを新規に作

成できます。

ページの上部では使用可能なシ ョート カッ ト  スキーマを管理できるよ うになっています。 [Copy]
ボタンをク リ ッ クする と、新規スキーマ作成用に [PlanAhead Default] スキーマがコピーされます。

図 3-27 : [Shortcuts] ページ
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プルダウン メニューから選択する と リ ス トにあるスキーマをアクティベートできます。スキーマを

変更するには、 まずPlanAhead のデフォルト  スキーマをコピーする必要があ り ます。

スキーマのシ ョート カッ トの変更には、ダイアログ ボッ クスの下の部分を使用します。 リ ス ト内を

検索し新しいシ ョート カッ ト を入力するためのコマンドを選択します。 [Add Shortcut] ボタンをク

リ ッ ク し、 新しいシ ョート カッ ト を [Add Shortcut] ダイアログ ボッ クスに入力します。 [OK] をク

リ ッ クする と、 新しいシ ョート カッ トが追加されます。

シ ョート カッ ト を割り当てるためにコマンドのリ ス トは、[Filter] フ ィールドを使用してフ ィルタで

きます。 このフ ィールドに文字列を入力してコマンドをフ ィルタします。

同じコマンドにウ ィンド ウ別に異なるシ ョート カッ ト を割り当てるこ とができます。

ユーザー定義のシ ョート カッ ト  スキーマはすべて次の場所に保存されます。 

• C:\Documents and Settings\<Username>\Application Data\HDI\shortcuts (Windows の場合)

• ~/.HDI/shortcuts (Linux の場合)

シ ョート カッ ト を削除するには、 [Remove] ボタンをク リ ッ ク します。
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PlanAhead の全般的なオプシ ョ ンの設定

[Tools] → [Options] をク リ ッ ク し  [PlanAhead Options] ダイアログ ボッ クスを開き、 [General] タ
ブを選択します。

メモ : [Office 2003] のオプシ ョ ンは、 Linux では使用できません。 

[Genera] ページにあるオプシ ョ ンは次の通りです。

• [Look and Feel] : 一般的なスタイルや色を設定できます。 

メ モ : Windows 版の PlanAhead のテス ト および開発のほと んどが、 デフォル ト の [Office
2003] の設定で実施されています。 表示の問題が発生した場合は、 [Look and Feel] の [Style]
を [Office 2003] に戻してください。

図 3-28 : [General] ページ
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• [Warning Dialog] : 警告ダイアログ ボッ クスの表示方法を設定します。 

• [I/O Placement] : インタラ クティブな I/O 配置 DRC のオン/オフを切り替えます。

• [Connectivity Display] : [Device] ウ ィンド ウで表示される接続を表示方法を設定します。

• [Miscellaneous] : ザイ リ ンクス  Web サイ トでのソフ ト ウェア アップデート を自動確認するた

めのオプシ ョ ンを設定し、 [Getting Started] ページで表示する最近開いたプロジェク トの数を

定義します。

表示エリア内でのウィンドウの移動

複数のウ ィンド ウを同じ表示エリ ア内に垂直または水平に並べて表示できます。 ウ ィンド ウのタブ

をク リ ッ ク してほかの表示エリ アにド ラ ッグする と、 表示エリ アを分割できます。 アウ ト ラ インが

表示され、 どこが表示されているのかがわかり ます。 ド ラ ッグしてアウ ト ラ インを移動しながら、

ウ ィンド ウの移動先を決定できます。 

ウ ィンド ウを移動して表示エリ アを共有するには、 次の手順に従います。

1. タブをク リ ッ ク します。 図 3-29 の例では、 [Constraints] タブをク リ ッ ク しています。

2. タブを移動先にド ラ ッグします。 グレーのアウ ト ラインで移動場所が確認できます。

3. 移動先でド ロ ップします。
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ウ ィンド ウを元の場所に戻すには、 [Layout] → [Undo Dragging] をク リ ッ ク します。上記の手順で

元の位置にド ラ ッグするこ と もできます。

[Constraints] ウ ィンド ウを [Properties] ウ ィンド ウに移動する という よ うに、 ウ ィンド ウをまった

く別のド ッキング エリ アに移動するには、移動するウ ィンド ウのタブを移動先のド ッキング エリア

のバナーにド ラ ッグします。

1. タブをク リ ッ ク します。

2. 移動先のド ッキング エリアのバナーにド ラ ッグします。

3. ド ロ ップしてウ ィンド ウ と タブを配置します。

カスタム ウィンドウ レイアウトの作成

[Layout] メニューにあるコマンドを選択し、デフォルトやカスタムの表示設定を保存したり復元し

たりするこ とができます。 [Layout] メニュー コマンドの一覧と説明は、 付録 A の 「[Layout] メ
ニュー」 を参照して ください。

図 3-29 : [Constraints] ウィンドウをド ラ ッグしウィンドウと並べて表示
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ウィ ンドウ レイアウトの復元

PlanAhead のレイアウ ト を元に戻すためのコマンドには、 多くの種類があ り ます。

選択していたオプシ ョ ンをオフに切り替える と、 ウ ィ ンド ウが元の場所に戻り ます。 ウ ィンド ウ  バ
ナーのコマンドを使用しても切り替えるこ とができ、 前の設定に戻すこ とができます。

デフォルトのウィンドウ レイアウトの復元

変更した後で [Layout] → [Load Layout] → [PlanAhead Default] をク リ ッ クする と、 PlanAhead の
デフォルトのレイアウ トに戻り ます。 

[Undo]/[Redo] コマンドの使用

[Layout] メニューの [Undo] コマンドを使用し、ウ ィ ンド ウ操作を取り消すこ とができます。[Redo]
コマンドを使用する と、 操作を繰り返すこ とができます。
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I/O ピンの配置

本章は、 次のセクシ ョ ンで構成されています。

• 「PinAhead の概要」

• 「PinAhead 環境の使用」

• 「デバイス  リ ソースの表示」

• 「互換性のあるパーツの選択」

• 「I/O ポートのインポート 」

• 「I/O ポートの定義および設定」

• 「I/O ポートの配置」

• 「I/O 関連のクロ ッ ク  ロジッ クの配置」

• 「I/O 配置制約の削除」

• 「I/O ポートおよびクロ ッ ク  ロジッ ク関連の DRC の実行」

• 「WASSO 解析の実行」

• 「パッケージ ピンの情報のエクスポート 」

• 「I/O ポート  リ ス トのエクスポート 」

PinAhead の概要

PinAhead 環境では、デザインおよびデバイスの I/O 要件を解析し、 I/O ピン配置設定または、 PCB
デザインと  FPGA デザイン両方の要件を満たすピン配置を定義できます。 PlanAhead™ では、 I/O
ポート信号の作成および CSV、 UCF、 HDL 形式の I/O ポート  リ ス トのインポートができるため、

ピン配置を設計初期に無駄なく決定でき、 ダウンス ト リームでのピン配置に関連する変更を大幅に

削減できます。 また、 パフォーマンスも大き く向上します。 ピン配置が最適化されていないと遅延

が増加し、 タイ ミ ング要件を満たす障害とな り ます。 PCB から  FPGA ダイへのデータ  フローを考

慮する と、 最適化されたピン配置を迅速に定義でき、 内部および外部のト レース長および配線密集

を緩和できます。

PinAhead 環境の使用

PinAhead 環境で使用されるウ ィンド ウの多くはフロアプラン環境でも使用されています。 フロア

プラン環境の詳細は、 「フロアプラン環境ウ ィンド ウ  レイアウ ト 」 を参照してください。

PinAhead 環境のワークスペースは分割されており、[Package] ウ ィンド ウ と  [Device] ウ ィンド ウの

両方が表示されます。 [ Clock Region]、 [Package Pins]、 [I/O Ports] のウ ィンド ウもあ り、 I/O 情報

が更に詳細に表示されます。
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PinAhead のウ ィンド ウ  レイアウ ト を開くには、 次の 2 つの方法があ り ます。

• [Tools] → [Open PinAhead] をク リ ッ ク します。

• New Project ウ ィザードを使用して空の新規プロジェク ト を作成します。
 

[Package Pins] ウ ィンド ウに、 ザイ リ ンクスで提供されるデバイスのデータシートに含まれるデバ

イス  パッケージの仕様が表示されます。 [Package Pins] ウ ィンド ウの表は I/O バンク別に分類され

ており、 [Device] ウインド ウ と  [Package] ウインド ウの両方で、 異なる  I/O バンクのピンを選択し

てハイライ ト表示できます。 デバイス上の物理的なピンのロケーシ ョ ンと  I/O パッ ドのロケーシ ョ

ンの関係がはっき り と表示されるため、最適な I/O バンクを簡単に選択できます。I/O バンクの各ピ

ンの情報は、 [Package Pins] ウ ィンド ウに表示されます。 詳細は、 「[Package Pins] ウ ィンド ウの使

用」 を参照して ください。

[I/O Ports] ウ ィンド ウには、デザインで定義されているすべての I/O 信号のポートが表示されます。

バスはすべてグループ化され、 バスのフォルダに表示されます。 差動ペア信号とバスもグループ化

されます。 

信号とバスの両方またはどちらかのグループを選択して [Create I/O Port Interface] コマンドを実行

する と、 カスタムのインターフェイスを作成できます。 既存のインターフェイスを変更するコマン

ドはほかにもあ り ます。 詳細は 「I/O ポート  インターフェイスの作成」 を参照してください。

図 4-1 : PinAhead 環境
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個別のピン、 バス、 またはインターフェイスは、 [Device] ウ ィンド ウまたは [Package] ウ ィンド ウ

にド ラ ッグする と、 I/O ピンに割り当てられます。 ピン グループは、 さまざまな配置コマンドを使

用して、 I/O ピンに割り当てるこ とができます。 このコマンドは、 [Place I/O Ports in an I/O Bank]、
[Place I/O Ports in Area]、および [Place I/O Ports Sequentially] コマンドです。それぞれのコマンド

で、 I/O ポートのピンへの割り当て方が異なり ます。 配置されるポート数の情報は、 ツール ヒ ン ト

に表示されます。モードは、選択された I/O ポート を配置するか、Esc キーを押すまでアクティブで

す。 詳細は、 「I/O ポートの配置」 を参照して ください。

割当て規則は割り当てが正し く実行されるよ うに設定されており、 差動ペアのポートは正しいピン

のペアに割り当てられます。 また、 オンライン DRC も  I/O 配置に活用できます。 バッチの

PlanAhead I/O 関連 DRC は改良されており、 このよ う な I/O の問題を発見できます。 

[Tools] → [Autoplace I/O Ports] コマンドを実行する と、デバイス全体または選択されたデバイスの

一部が自動的に配置されます。 コマンドでは I/O バンク規則、差動ペアの規則、 グローバル ク ロ ッ

ク  ピンの規則が遵守され、最大限の I/O ポートが配置されます。 また、 インターフェイスも最大限

にグループ化されます。

個別の I/O ピンまたは I/O バンクに PROHIBIT を設定する と、 I/O が割り当てられません。

どのポート またはインターフェイスも、 [Configure I/O Ports] コマンドを使用して選択および設定

できます。 このコマンドでは、 I/O 規格、駆動強度、およびスルー レートのタイプを設定できます。

PinAhead では、CSV 形式のファイルを出力して PCB 回路図シンボルの作成または HDL ポート  リ
ス トで使用できます。 
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[I/O Ports] ウィンドウの使用

[I/O Ports] ウ ィンド ウでは、デザインで定義されているすべての I/O 信号のポートが表示されます。

これらのポートは、EDIF ネッ ト リ ス ト または CSV形式の I/O ポート  リ ス ト をインポートするこ と

で PlanAhead 内で定義できます。 このウ ィンド ウを表示するには、 [Window] → [I/O Ports] をク

リ ッ ク します。

このウ ィンド ウは、 [Group by Interface and Bus] ボタンをク リ ッ クする と、 インターフェイスごと

またはアルファベッ ト順にピンを並べ替えるこ とができます。 

ポートの信号名、 方向、 パッケージ ピン、 I/O 規格、 駆動電流、 差動ペア、 スルー タイプ、 および

その他の信号情報が、 各 I/O ポートに対して示されます。 表の値はデフォルト値の場合は黒色、 デ

フォルト値でない場合はアスタ リ スク  (*) の付いた黒色、 無効な値や未定義の値は赤色で表示され

ます。 

ポート を複数選択して、 [Create I/O Port Interface] ポップアップ メニュー コマンドを使用する と、

これら を インターフェ イ スにま とめる こ とができ ます。 これらのインターフェ イ スを選択し、

PinAhead 環境内に 1 つのオブジェク ト と して配置できます。 

バスはフォルダと して表示され、 各フォルダにはバス信号のグループが含まれます。

図 4-2 : I/O ポート  インターフェイスを表示した [I/O Ports] ウィンドウ

図 4-3 : [Group by Interface and Bus] ボタン
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PinAhead 環境の使用

ポートおよびインターフェイスを [I/O Ports] ウ ィンド ウから選択し、 PinAhead 環境を使用して割

り当てるこ とができます。

[Package Pins] ウィンドウの使用

[Package Pins] ウ ィンド ウでは、デバイスのパッケージ ピン情報が表示されます。デバイス  ピンの

情報が、表形式で表示されます。このウ ィンド ウを表示するには、[Window] → [Package Pins] をク

リ ッ ク します。

このウ ィンド ウでは [Group by IO Bank] ボタンをク リ ッ ク し、 I/O バンク別またはアルファベッ ト

順にピンを並べ替えて表示するこ とができます。 

I/O バンク番号、 タイプ、差動ペア、サイ ト  タイプ、最小/最大パッケージ遅延などのデバイス  ピン

情報は、パッケージ ピンごとに リ ス ト されます。表の値は、デフォルト値の場合はグレー色、デフォ

ルト値以外の場合は黒色、 不正な値の場合は赤色で表示されます。

メモ : [Package Pins] ウ ィンド ウでの最小/最大パッケージ遅延の計測単位はピコ秒 (ps) です。

[Package Pins] ウ ィンド ウに表示される情報は、列のヘッダをク リ ッ クする と並べ替えられます。列

をも う一度ク リ ッ クする と、逆の順番に並べ替えられます。最初に並べ替えた後で Ctrl キーを押し

て別の列ヘッダをク リ ッ クする と、 次にその列で並べ替えられます。 リ ス トの表示順を整えるため

に、 さまざまな並び替え条件を選択できます。

図 4-4 : [Package Pins] ウィンドウ

図 4-5 : [Group by IO Bank] ボタン
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[Package] ウィンドウの使用

[Package] ウ ィンド ウには、デザインで使用されるデバイスの物理特性が表示されます。さまざまな

種類のピンが、 さまざまな色と形を使用して表示されます。

このウ ィンド ウは、 ワークスペースの [Package] タブをク リ ッ クするか、 [Window] → [New
Package View] をク リ ッ クする と表示されます。[Package] ウ ィンド ウは、複数同時に開く こ とがで

きます。

カーソルを [Package] ウ ィンド ウ上に置く と、 ピン情報が表示されます。 

ポートおよび I/O バッファのインスタンスは、 このウ ィンド ウにド ラ ッグして割り当てるこ とがで

きます。 また、 このウ ィンド ウ内のほかの I/O ピンに割り当て直すこ と もできます。

VCC ピンは赤色の正方形ピン、GND ピンは緑色の正方形ピンと して表示されます。ク ロ ッ ク  ピン

は、 ピンク色の六角形ピンと して表示されます。

ピン間の色が付いたエリ アには、I/O バンクが表示されています。ピンまたはバンクは、ク リ ッ クす

る と選択できます。I/O ピンまたはバンクを選択する と、[Device] ウ ィンド ウでも同じバンクがハイ

ライ ト されます。 [Device] ウ ィンド ウでピンまたは I/O バンクを選択しても  [Package] ウ ィンド ウ

でハイライ ト されます。

[Show Differential I/O pairs] ボタンをク リ ッ クする と、 [Package] ウ ィンド ウ内の差動ピン ペアを

表示できます。 

図 4-6 : [Package] タブ

図 4-7 : [Show Differential I/O pairs] ボタン

http://www.xilinx.com


PlanAhead ユーザー ガイド japan.xilinx.com 117
UG632 (v 11.1.0)

デバイス リソースの表示

[Package] ウ ィンド ウでは、[Show Bottom/Top View] ボタンまたは [Show Bottom/Top View] ポッ

プアップ メニューをク リ ッ クする と、パッケージの上面または下面の表示に切り替えるこ とができ

ます。

[Package] ウ ィンド ウの左上端には、 アイコンが数個あ り ます。 これらのコマンドは、 「共通のポッ

プアップ メニュー コマンドの使用」 で説明されています。

[Package] ウィンドウの印刷

[File] → [Print] をク リ ッ クする と、[Package] ウ ィンド ウを印刷できます。表示されている部分のみ

が印刷されます。[Package] ウ ィンド ウ全体を印刷するには、拡大率を変更して全体を表示してから

印刷します。

[Device] ウィンドウの使用

I/O パッ ド、バンク、およびクロ ッ クに関連する リ ソースは、 [Device] ウ ィンド ウに表示されます。

I/O リ ソースは PinAhead のどのウ ィンド ウでも選択でき、 物理的なパッケージ ピンと内部デバイ

ス  リ ソースの関連性が表示されます。詳細は、第 8 章 の 「[Device] ウ ィンド ウの使用」 を参照して

ください。

デバイス リソースの表示

パッケージ ピンのプロパティの表示

ピンまたは I/O バンクを [Package] ウ ィンド ウで選択して、その詳細を [Properties] ウ ィンド ウに表

示できます。[Package] ウ ィンド ウでオブジェク ト を 1 つ選択し、その詳細を [Properties] ウ ィンド

ウで確認します。

図 4-8 : [Show Bottom/Top View] ボタン

図 4-9 : パッケージ ピン プロパティ
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I/O バンク  リソースの表示

I/O リ ソースはどの PinAhead ウ ィンド ウでも選択できます。選択したデータはほかのすべてのウ ィ

ンド ウでハイライ ト表示されるため、物理パッケージと内部チップの関係が容易に確認できます。さ

まざまなタイプのデバイスおよびデザイン情報が、 適切なウ ィンド ウに示されます。 次に使用例を

示します。

1. [Package Pins] ウ ィンド ウで、 I/O バンクをどれか 1 つク リ ッ ク します。

2. [I/O Bank Properties] ウ ィンド ウで [General] タブをク リ ッ ク します。

図 4-10 : I/O バンクのロケーシ ョ ンおよびリソースが表示されます。
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互換性のあるパーツの選択

クロック領域リソースの表示

ク ロ ッ ク領域は、 [Device] ウ ィンド ウにグラフ ィ ッ ク表示されます。 デフォルトでは青の長方形で

示されますが、 [Tools] → [Options] → [Themes] → [Device] をク リ ッ ク して、表示されたダイアロ

グ ボッ クスで色を変更できます。 

[Clock Regions] ウ ィンド ウでは、ク ロ ッ ク領域を容易に選択できます。ク ロ ッ ク領域を選択する と、

関連した I/O バンクおよびリージ ョナル ク ロ ッ ク  リ ソースがハイライ ト表示されます。 [Clock
Region Properties] ウ ィンド ウには、選択したクロ ッ ク領域のリ ソースの統計およびロジッ クの内容

が表示されます。

互換性のあるパーツの選択

PlanAhead では、 代替パーツを選択し、 有効な I/O ピン割り当てが定義され、 選択したデバイスす

べてに対しそれが有効であるよ う確認できます。 

1. [Package] ウ ィンド ウで [Make Part Compatible] ポップアップ メニューをク リ ッ ク します。 

図 4-11 : クロック領域リソースの表示
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同じパッケージの使用可能な互換性のあるパーツの リ ス ト が表示されます。 この機能は代替

パーツがある場合にのみサポート されています。

2. 代替パーツは任意数選択できますが、 多くのパーツを選択する と配置に使用可能なパッケージ

ピンの数が減っていく場合があ り ます。

PROHIBIT が選択された代替パーツのボンディングされていないピンに自動的に設定されます。使

用禁止になっているパッケージ ピン数を示すダイアログ ボッ クスが表示されます。 PROHIBIT の
設定は選択された代替パーツによって異なり ます。

PROHIBIT は [Package]、[Package Pins]、[Device] ウ ィンド ウでも表示できます。 定義された代替

パーツは [Part Compatible] タブにある  [Floorplan Properties] でも表示 ・管理できます。 

メモ : [Make Part Compatible] コマンドは現在 Virtex®-5 のパーツに対してのみサポート されてい

ます。

フロアプランで定義した代替パーツは、[Floorplan Properties] にある  [Add Compatible Part] ボタン

をク リ ッ ク して表示 ・ 変更できます。

図 4-12 : 代替パーツの選択

図 4-13 : [Add Compatible Part] ボタン
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I/O ポートのインポート

PlanAhead では、 I/O ピン配置を開始するため、 UCF、 CSV、 または HDL ヘッダ フォーマッ ト を

空の PlanAhead プロジェク トへインポートできます。 

RTL ベースまたは合成ネッ ト リ ス ト  ベースのプロジェク ト作成する と、[I/O Ports] ウ ィンド ウに定

義された I/O ポートが自動的にインポート されます。

CSV 形式のファイル

I/O ポートのリ ス ト を CSV ファ イルからインポートするには、 次の手順に従います。

1. フロアプランを選択します。

2. [File] → [Import I/O Ports] → [From CSV] をク リ ッ ク します。

3. インポートする  CSV ファ イルを選択します。

CSV ファ イルの内容は、次のとおりです。ファ イルには最低限 [Signal Name] 列が含まれている必

要があ り ます。 

CSV の列

CSV は、FPGA やボード設計にあたり、デバイス  ピンおよびピン配置のデータを交換する と きに使

用される標準ファイル形式です。

• [IO Bank] : ピンが配置される  I/O バンク。 デバイスのすべてのピンに対しこのフ ィールドに

データがソフ ト ウェアで自動入力されます。値は数値または空白です。入力 CSV ファ イルでは

必須のフ ィールドではあ り ません。

• [Pin Number] : パッケージ ピンの名前またはロケーシ ョ ン。デバイスのすべてのピンに対しこ

のフ ィールドにデータがソフ ト ウェアで自動入力されます。 入力ファイルで必須のフ ィールド

ではあ り ません。 配置定義に使用されます。 値はデバイスの有効なピンです。

• [IOB Alias] : パッケージ ピンの代替パーツ名。 このフ ィールドはソフ ト ウェアで指定され、入

力 CSV ファ イルで指定されていない場合は使用されません。 

• [Site Type] : デバイス  データシートからのピン名。このフ ィールドはソフ ト ウェアで指定され、

入力 CSV ファ イルで指定されていない場合は使用されません。

• [Min/Max Trace Delay] : デバイスのパッ ド  サイ ト とパッケージのボールの間の距離で、 単位

はピコ秒 (ps) です。 このフ ィールドはソフ ト ウェアで入力され、ボード設計時にト レース遅延

を一致させるために使用します。 ト レース遅延のフ ィールドは出力ファイルのみで、 入力ファ

イルには含まれません。

図 4-14 : CSV 形式の I/O ポート  リス ト

http://japan.xilinx.com


122 japan.xilinx.com PlanAhead ユーザー ガイド
UG632 (v 11.1.0)

第 4 章 : I/O ピンの配置

• [Prohibit] : ユーザー I/O がサイ トに追加されないよ う、 さまざまな理由でサイ トは使用禁止さ

れます。PROHIBIT を設定するこ とで、ボード  レイアウ ト問題の抑制、信号間クロス トークの

低減、 同じパッケージの複数の FPGA 間でピン配置が有効であるかど うかの確認に役立ちま

す。UCF ファ イルでは、これは CONFIG PROHIBIT 制約と して記述されています。値は TRUE
または空白です。 [Pin Number] が空白の場合、 このフ ィールド も空白である必要があ り ます。

• [Interface] : ユーザー I/O のセッ ト をユーザーが指定してグループ化します。 たとえば、 この

フ ィールドは、 メモ リ  インターフェイスのデータ、 アドレス、およびイネーブル信号の関係を

指定するのに使用できます。 値は文字列または空白です。 このフ ィールドはオプシ ョ ンです。 

• [Signal Name] : FPGA デザインのユーザー I/O 名。値は文字列、または割り当てられていない

パッケージ ピンの場合は空白です。

• [Direction] : 信号の方向。値は IN、OUT、 INOUT、またはユーザー I/O がサイ トに割り当てら

れていない場合は空白です。

• [DiffPair Type] : 差動ペアのピンが N 側、 P 側のどちらにあるかが記述されます。 これは差動

信号に対してのみ使用されます。 ソフ ト ウェアは、 ピン名ではなく、 この列を使用してどのピ

ンが N 側か P 側かを判断します。 値は P、 N、 またはユーザー I/O がサイ トに割り当てられて

いない場合は空白です。

• [DiffPair Signal] : 差動ペアのも う  1 つのピン名を指定するのに使用します。値はユーザー I/O
名、 または未使用の場合は空白です。

• [IO Standard] : 特定ユーザー I/O の I/O 規格。 このフ ィールドがユーザー I/O に対し空白の場

合、 該当するデフォルト値が使用されます。 値は有効な I/O 規格、 または空白です。

• [Drive] : 特定ユーザー I/O の I/O 規格の駆動強度。すべての I/O 規格が駆動強度を必要とする

わけではあ り ません。 このフ ィールドが空白の場合、 デフォルト値が使用されます。 値は数値

または空白です。

• [Slew Rate] : 特定ユーザー I/O の I/O 規格のスルー レート。すべての I/O 規格がスルー レート

を必要とするわけではあ り ません。 このフ ィールドが空白の場合、 デフォルト値が使用されま

す。 値は FAST および SLOW です。

またほかの情報を追加するこ と もできます。 ユーザー定義の値が入力されているフ ィールドはユー

ザー定義列に自動追加されます。 ユーザーはパッケージ ピンの表に列を追加できます。

CSV でのユーザー定義 I/O ポート  プロパティの使用

PlanAhead には I/O ピン関連データをインポートするための規定フォーマッ トがあ り ます。 通常

CSV ファ イルが使用されます。 インポート された CSV ファ イルにデータを含んだ追加列がある場

合、PlanAhead で [Package Pins] ウ ィンド ウに新しい列が作成され、値を表示・変更できます。[Set
User Column Values] ポップアップ メニュー コマンドを使用し、 カスタム CSV フ ィールドで値を

変更または定義します。[File] → [Export I/Os] → [CSV] をク リ ッ クする と、列と新しい値が保存さ

れ CSV ファ イルにエクスポート されます。

HDL 形式のファイル

PlanAhead では、 HDL 形式のヘッダをインポート して、 [I/O Ports] ウ ィンド ウに表示できます。

HDL ファ イルから  I/O ポートの定義をインポートするには、 [File] → [Import I/O Ports] → [From
HDL] をク リ ッ ク します。 ウ ィザードで VHDL および Verilog のいずれかまたは両方を指定し、最

上位モジュール名と、 HDL ファ イルおよびライブラ リの検索パスを指定して、 HDL ファ イルから

の I/O ポートのインポート を実行します。

http://www.xilinx.com


PlanAhead ユーザー ガイド japan.xilinx.com 123
UG632 (v 11.1.0)

I/O ポートの定義および設定

UCF フォーマッ ト  ファイル

PlanAhead では、 UCF 形式のファイルをインポート して、 [I/O Ports] ウ ィンド ウに表示できます。

HDL ファ イルから  I/O ポートの定義をインポートするには、 [File] → [Import I/O Ports] → [From
UCF] をク リ ッ ク します。 

UCF ではポートの方向が定義されていないので、 [Direction] フ ィールドは 「undefined」 と表示さ

れます。[I/O Ports] ウ ィンド ウの [Set Direction] ポップアップ メニュー コマンドを実行し、I/O ポー

トの方向を定義します。 詳細は、 「I/O ポート方向の設定」 を参照して ください。 

I/O ポートの定義および設定

PinAhead では I/O ポート を作成および設定できます。空のプロジェク ト を作成し、 I/O ポートの リ

ス ト を容易に生成できます。

I/O ポートの作成

I/O ポート を作成するには、 次の手順に従います。

1. [I/O Ports] ウ ィンド ウのポップアップ メニューで、 [Create I/O Ports] をク リ ッ ク します。

[Create I/O Ports] ダイアログ ボッ クスが表示されます。

2. オプシ ョ ンを確認し、 必要があれば編集します。

♦ [Name] : 作成するポート またはバスの名前を指定します。

♦ [Direction] : ポートの方向を選択します。

♦ [Diff Pair] : 信号またはバスに差動ペアを定義する場合はオンにします。

♦ [Create Bus] : バスを作成する場合はオンにし、 バス範囲を指定します。

♦ [Configure]

- [I/O Standard] : I/O 規格を選択します。

- [Drive Strength] : 駆動電流の値を選択します。

図 4-15 : 
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- [Slew Type] : スルー レート を選択します。

- [Pull Type] : 抵抗のタイプを選択します。

デバイスの電圧の情報については、 ザイ リ ンクスのデバイスのマニュアルを参照してください。

I/O ポートの設定

ポート またはポートのグループを設定するには、 次の手順に従います。 

1. [I/O Ports] ウ ィンド ウで、 ポート を選択します。

2. ポップアップ メニューで [Configure I/O Ports] をク リ ッ ク します。

[Configure Ports] ダイアログ ボッ クスが表示されます。

3. 編集可能なオプシ ョ ンを確認し、 必要があれば編集します。

♦ [I/O Standard] : I/O 規格を選択します。

♦ [Drive Strength] : 駆動電流の値を選択します。

♦ [Slew Type] : スルー レート を選択します。

♦ [Pull Type] : 抵抗のタイプを選択します。

デバイスの電圧の情報については、 ザイ リ ンクスのデバイスのマニュアルを参照してください。

I/O ポート方向の設定

設定する必要のある  I/O ポート、 バス、 またはインターフェイスを選択し、 [I/O Ports] ウ ィンド ウ

の [Set Direction] ポップアップ メニュー コマンドをク リ ッ ク します。

図 4-16 : [Configure Ports] ダイアログ ボックス
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差動ペアの定義

差動ピン ペアを定義するには任意の 2 つの I/O ポート を選択し、 [I/O Ports] ウ ィンド ウの [Make
Diff Pair] ポップアップ メニュー コマンドをク リ ッ ク します。

2 つの I/O ポートが、 正側と負側にそれぞれ指定されてダイアログ ボッ クスに表示されます。

[Swap] ボタンをク リ ッ クする と、 正と負を入れ替えるこ とができます。

[Split Diff Pair] ポップアップ メニュー コマンドをク リ ッ クする と、差動ペア定義を削除できます。

I/O ピンおよび I/O バンクの使用禁止

PinAhead では、I/O ピン、I/O ピンのグループ、または I/O バンクの使用を個別に禁止できます。ピ

ンは、[Package Pins] ウ ィンド ウまたは [Package] ウ ィンド ウで選択して使用禁止に設定できます。

I/O ピンまたは I/O バンクを使用禁止にするには、 次の手順に従います。

1. [Package Pins] ウ ィンド ウまたは [Package] ウ ィンド ウで、I/O ピンまたは I/O バンクを選択し

ます。

2. ポップアップ メニューで [Set Prohibit] をク リ ッ ク します。 

[Package] ウ ィンド ウで、赤い X マークが使用禁止になったピンに表示され、[Package Pins] ウ ィン

ド ウの [Prohibit] 列にはチェッ クマークが表示されます。

図 4-17 : [Make I/O Diff Pair] ダイアログ ボックス
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I/O ポート  インターフェイスの作成

複数のポート またはバスはインターフェイスを作成しグループ化できます。インターフェイス  ポー

トがすべて 1 つのグループにまとめられるため、 ピンの割り当てに役立ちます。 ピンをすべて同時

に割り当てる と、 ク ロ ッ ク領域または PCB 配線関連のインターフェイスをま とめたり隔離しやす

くな り ます。特定のロジッ ク  インターフェイスに関連付けられた信号すべての表示および管理も容

易になり ます。

インターフェイスを作成するには、 次の手順に従います。

1. [I/O Ports] ウ ィンド ウで、 信号を選択します。

2. ポップアップ メニューで [Create I/O Port Interface] をク リ ッ ク します。

図 4-18 : 使用禁止のパッケージ ピン
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3. インターフェイス名を指定し、 選択されたバス数およびポート数を確認します。

4. [OK] をク リ ッ ク します。

インターフェイスが展開可能なフォルダと して [I/O Ports] ウ ィンド ウに表示されます。 [I/O Ports]
ウ ィンド ウで I/O ポート を選択して、 インターフェイス  フォルダにド ラ ッグする と、 I/O ポート を

新し く追加できます。

追加 I/O ポート をインターフェイスに追加するには、 次の手順に従います。

1. ポート またはバスを選択します。

2. ポップアップ メニューで [Assign to Interface] をク リ ッ ク します。

3. I/O ポート を追加するインターフェイスを選択します。

I/O ポートおよびインターフェイスを削除するには、 次の手順に従います。

1. ポート またはインターフェイスを選択します。

2. ポップアップ メニューで [Unassign from Interface] をク リ ッ ク します。

インターフェイスを削除するには、削除するインターフェイスを選択し、ポップアップ メニューで

[Delete] をク リ ッ クするか、 Delete キーを押します。

図 4-19 : [Create I/O Ports Interface] ダイアログ ボックス

図 4-20 : I/O ポート  インターフェイスの管理
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I/O ポートの配置

PinAhead では、 さまざまな方法で I/O ポート をパッケージ ピンに割り当てるこ とができます。 個

別の I/O ポート、 I/O ポートのグループ、 またはインターフェイスを [I/O Ports] ウ ィンド ウで選択

し、 [Package] ウ ィンド ウでパッケージ ピンに、 または [Device] ウ ィンド ウで I/O パッ ドに、図で

確認しながら割り当てられます。 インタラ クティブな配置の実行中は、 オンライン DRC のオン/オ
フを切り替えるこ とができます。

I/O ポートの割り当てには、 次の 3 つの配置コマンドを使用します。 詳細は、 次に説明します。

• [Place I/O Ports in an I/O Bank] コマンド

• [Place I/O Ports in Area] コマンド

• [Place I/O Ports Sequentially] コマンド  

自動 I/O ポート割り当ての詳細は、 「I/O ポートの自動割り当て」 を参照して ください。

インタラクテ ィブなデザイン ルール チェ ックの使用

PlanAhead は最終的なピン割り当てを行う ツールではあ り ませんが、 ピン配置が有効であるこ とを

確認します。 インタラ クティブ I/O 配置ルーチンは多くの共通エラーをチェッ ク します。 この機能

は、 [Tools] → [Options] → [General] で表示されるダイアログ ボッ クスの [I/O Placement] で、 オ

ン/オフを切り替えられます。オンにする と、問題を引き起こすピンに I/O ポート を配置できなくな

り ます。 I/O ポート を順次に割り当てる場合、問題のあるピンに I/O ポート を配置しよ う とする と、

I/O ポート を配置できない理由がツールに表示されます。オンライン DRC はデフォルトではオンに

なっています。 チェッ クの多くは最終デザインを表すネッ ト リ ス トが読み込まれている場合のみに

実行されます。

インタラ クティブな I/O 配置ルールには、 次のものが含まれます。

• ギガビッ ト  ト ランシーバ (GT) に関連する、ノ イズの影響を受けやすいピンへの配置の禁止。現

在、 ノ イズの影響を受けやすい I/O パッケージ ピンがすべて禁止されています。

• I/O 規格に違反する配置の禁止。

• バンクでサポート されていない I/O 規格が使用されないよ うに確認。

• バンクに互換性のない VCC ポートが割り当てられていないこ とを確認。 

• VREF ポートが必要なバンクに使用可能な VREF ピンあるこ とを確認。

• グローバル ク ロ ッ クおよびリージ ョナル ク ロ ッ クが適切に割り当てられているこ と  (EDIF
/NGC ネッ ト リ ス トおよび UCF がインポート されている場合のみ) を確認。

• 入力および High 駆動の出力が適切なピンにのみ送信されるこ とを確認 (Spartan®-3 デバイス

の場合)。

• 差動 I/O ポートが正しい極性ピンに割り当てられているこ とを確認。

• 出力ピンが入力のみのピンに配置されていないこ とを確認。

I/O ポートの  I/O バンクへの配置

I/O ポート を I/O バンクに配置するには、 次の手順に従います。

1. [I/O Ports] ウ ィンド ウで、個別の I/O ポート、I/O ポートのグループ、またはインターフェイス

を選択します。 

2. 次の方法のいずれかを選択します。
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♦ [I/O Ports] ウ ィンド ウのポップアップ メニューで、 [Place I/O Ports in an I/O Bank] をク

リ ッ ク します。

♦ [Package] ウ ィンド ウまたは [Device] ウ ィンド ウで、[Place I/O Ports in an I/O Bank] ボタ

ンをク リ ッ ク します。

カーソルをパッケージ ピンまたは I/O パッ ド上に移動する と、 I/O ポートのグループがカーソ

ルと共に移動します。 ツール ヒ ン トには、 カーソルを移動した I/O に配置されるピンの数が表

示されます。 

3. ピンまたはパッ ドをク リ ッ クする と、 選択された I/O ポートが割り当てられます。

4. 選択した I/O ポートすべてを配置できない場合はコマンドが継続し、 次に選択した I/O バンク

に残りの I/O ポートが配置されます。I/O ポートがすべて配置されるか、Esc キーを押すまでコ

マンドが継続します。

ポートは、 [I/O Ports] ウ ィンド ウに表示されている順序で割り当てられます。 割り当ての前に [I/O
Ports] ウ ィンド ウで並べ替えをする と、並べ替えられた順序で割り当てられます。また、 I/O バンク

の割り当てで最初に選択したピンから順に割り当てられます。 I/O バンクの端にあるピンを選択す

る と、 バスが I/O バンク全体に割り当てられます。

バスに関連する  PCB 配線も考慮されます。ピンは、割り当て領域内でバス  ビッ トのベクタが保持さ

れるよ うな順序で割り当てられます。 割り当てパターンをバス配線関連に対応するよ うにカスタマ

イズできます。 

図 4-21 : [Place I/O Ports in an I/O Bank] ボタン

図 4-22 : I/O ポートの I/O バンクへの配置
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I/O ポートの定義された領域への配置

I/O ポート を定義された領域に配置するには、 次の手順に従います。

1. [I/O Ports] ウ ィンド ウで、個別の I/O ポート、I/O ポートのグループ、またはインターフェイス

を選択します。

2. 次の方法のいずれかを選択します。

♦ [I/O Ports] ウ ィンド ウのポップアップ メニューで、[Place I/O Ports in Area] をク リ ッ ク し

ます。

♦ [Package] ウ ィンド ウまたは [Device] ウ ィンド ウで、[Place I/O Ports in Area] ボタンをク

リ ッ ク します。

カーソルが十字型に変化し、 ポートの配置場所の長方形を定義できるよ うになり ます。 

3. [Package] ウ ィンド ウまたは [Device] ウ ィンド ウに長方形を描画し、 割り当て領域を定義しま

す。

4. 選択した I/O ポートすべてが定義した領域に収まらない場合は、 コマンドは継続します。 カー

ソルは十字型のままで、 残りの I/O ポートがすべて配置されるまで、 長方形を続けて描画でき

ます。 Esc キーを押すと、 I/O ポート を配置し終わる前にコマンドが終了します。

ポートは、 [I/O Ports] ウ ィンド ウに表示されている順序で割り当てられます。 割り当ての前に [I/O
Ports] ウ ィンド ウで並べ替えをする と、 並べ替えられた順序で割り当てられます。 

また、長方形の描画方向によって割り当て順序が変わり ます。I/O ポートは最初に選択された長方形

の座標の内側のピンから順に割り当てられます。領域の長方形定義の情報を使用する と、PCB 配線

の観点で見たピン配置設定に役立ちます。

図 4-23 : [Place I/O Ports in Area] ボタン

図 4-24 : I/O ポートの領域への配置
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I/O ポートの順次配置

I/O ポート を順次に配置するには、 次の手順に従います。

1. [I/O Ports] ウ ィンド ウで、個別の I/O ポート、I/O ポートのグループ、またはインターフェイス

を選択します。

2. 次の方法のいずれかを選択します。

♦ [I/O Ports] ウ ィンド ウのポップアップ メニューで、 [Place I/O Ports Sequentially] をク

リ ッ ク します。

♦ [Package] ウ ィンド ウまたは [Device] ウ ィンド ウで、[Place I/O Ports Sequentially] ボタン

をク リ ッ ク します。

カーソルをパッケージ ピンまたは I/O パッ ド上に移動する と、グループの最初の I/O ポートが

カーソルと共に移動します。 ツール ヒ ン トには、 I/O ポート名およびパッケージ ピン名が表示

されます。 

3. ピンまたはパッ ドをク リ ッ クする と、 I/O ポートが割り当てられます。

4. 配置されなかった I/O ポートがある と、コマンドは継続して実行されます。I/O ポートがすべて

割り当てられるまでこの操作を継続するか、 または Esc キーを押します。

ポートは、 [I/O Ports] ウ ィンド ウに表示されている順序で割り当てられます。 割り当ての前に [I/O
Ports] ウ ィンド ウで並べ替えをする と、 並べ替えられた順序で割り当てられます。 

図 4-25 : [Place I/O Ports Sequentially] ボタン

図 4-26 : I/O ポートの順次配置
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I/O ポートの自動割り当て

PinAhead には、I/O ポートのすべてまたは一部をパッケージ ピンに自動的に割り当てる機能があ り

ます。自動配置ではすべての I/O 規格および差動ペアの規則が遵守され、グローバル ク ロ ッ ク  ピン

が正し く配置されます。 

割り当てられていない I/O ポートのサブセッ トに I/O ポート を自動的に割り当てるには、 次の手順

に従います。

1. [I/O Ports] ウ ィンド ウで、 割り当てられていない I/O ポート を選択します。 

2. [Tools] → [Autoplace I/O Ports] または [I/O Ports] ウ ィンド ウのポップアップ メニューで

[Autoplace I/O Ports] をク リ ッ ク します。

Autoplace I/O Ports ウ ィザードが表示されます。

3. 配置する  I/O ポートのグループを選択し、 [Next] をク リ ッ ク します。

図 4-27 : Autoplace I/O Ports ウィザード
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既にパッケージ ピンに割り当てられている  I/O ポート を選択する と、次のページが表示されま

す。

4. 配置する  I/O ポート を選択し、 [Next] をク リ ッ ク します。

5. サマリ  ページで [Finish] をク リ ッ クする と、 選択された I/O ポートが配置されます。

ギガビッ ト  ト ランシーバ I/O ポートの配置

ギガビッ ト  ト ランシーバ (GT) をよ り う ま く管理するため、 PinAhead では、選択、配置、移動の実

行時に、 I/O 差動ペアと  GT ロジッ ク  オブジェク トが自動的にグループ化されます。 複数の GT オ
ブジェク トは 1 つのオブジェク ト と して選択され、GT リ ソースに無効に割り当てられないよ う、ま

とめて移動できます。

インタラ クティブ DRC がオンの場合、ポート配置中に、GT の周囲のノ イズの影響を受けやすい I/O
ピンが自動的に配置禁止になり ます。 詳細は、 「インタラ クティブなデザイン ルール チェッ クの使

用」 を参照して ください。

 I/O 関連のクロック  ロジックの配置

BUFG、DCM、BUFR、DelayCtrls などの、グローバルおよびリージ ョナル ク ロ ッ ク関連のロジッ

クは、 [Device] ウ ィンド ウで手動で配置できます。 デバイス特有のリ ソースすべてに対する適切な

ロジッ ク  サイ トが表示されます。[Edit ] → [Find] コマンドを使用する と、 [Device] ウ ィンド ウで使

用できるサイ ト  タイプを検索できます。検索結果を [Find Results] ウ ィンド ウでク リ ッ クする と、そ

のサイ トがハイライ ト表示されます。

PlanAhead では、 [Find] コマンド、 [Schematic] ウ ィンド ウ、 [Netlist] ウ ィンド ウなど、 さまざまな

方法で、 デザイン ク ロ ッ ク関連のロジッ クを選択できます。 

ク ロ ッ ク  ロジッ クを手動で配置するには、 次の手順に従います。

1. [Device] ウ ィンド ウを拡大表示し、 ロジッ クを配置するデバイス  サイ ト を表示します。

図 4-28 : Autoplace I/O Ports ウィザード
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2. [Create Site Constraint Mode] ツールバー ボタンをオンにします。

3. 配置するロジッ クを [Find Results]、 [Schematic]、 または [Netlist] ウ ィンド ウでク リ ッ ク し、

[Device] ウ ィンド ウのサイ トにド ラ ッグします。 

I/O 配置制約の削除

配置制約を削除するには、 削除する制約を右ク リ ッ ク し、 [Unplace] をク リ ッ ク します。 

選択した I/O 関連の配置制約の削除については、 「配置 LOC 制約」 を参照してください。

I/O ポートおよびクロック  ロジック関連の DRC の実行

DRC の実行

このセクシ ョ ンでは、I/O ポートおよびクロ ッ ク関連の DRC の実行について説明します。ネッ ト リ

ス トおよびフロアプラン関連の DRC の実行については、 「DRC の実行」 を参照してください。 

各ルールは、 次のよ うに選択および実行されます。

1. [Tools] → [Run DRC] をク リ ッ ク します。

図 4-29 : クロック  ロジックの手動配置
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[Run DRC] ダイアログ ボッ クスが表示されます。 

図 4-30 : [Run DRC] ダイアログ ボックス :I/O ピンおよびクロック  DRC ルール
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2. [Results Name] フ ィールドを表示または編集します。 こ こで指定した名前が [DRC Results]
ウ ィンド ウに表示されるので、デバッグ時に区別しやすい名前を付けます。この名前は出力ファ

イル名と しても使用されます。

3. [Rules to Check] グループ ボッ クスの各デザイン オブジェク トで、 チェッ クするルールの

チェッ ク  ボッ クスをオンにします。 各ルールの詳細は、 「I/O ポートおよびクロ ッ ク  ロジッ ク

DRC の実行」 を参照して ください。

♦ [Expand All] ボタンをク リ ッ クするか、各カテゴ リ またはデザイン オブジェク トの横のプ

ラス記号 (+) をク リ ッ クする と、 階層が展開します。

♦ デザイン オブジェク ト全体に DRC を実行する場合は、 デザイン オブジェク トの横の

チェッ クボッ クスをオンにします。 個別のルールを選択する場合は、 その横のチェッ ク

ボッ クスをオンにします。 すべてのデザイン オブジェク トのすべてのルールをチェッ クす

る場合は、 [All Rules] の横のチェッ ク  ボッ クスをオンにします。

4. [OK] をク リ ッ クする と、 選択した項目がチェッ ク されます。

DRC エラーの表示

DRC が完了する と、 結果が表示されます。 

違反は、 [DRC Results] で個別に展開表示されます。エラーは赤色、警告は茶色、情報メ ッセージは

黄色のアイコンで表示されます。

[DRC Results] のリ ス トでエラーをどれか選択する と、そのエラーの情報が [Properties] に表示され

ます。 [Properties] のリ ンクをク リ ッ クする と、 [Device]、 [Netlist]、および [Schematic] で、違反が

発生したデザイン エレ メン トがハイライ ト表示されます。

エラーは、 修正する と  [DRC Results] ウ ィンド ウに表示されなくな り、 DRC が再実行されます。

図 4-31 : DRC Results
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[Run DRC] コマンドを実行し、 エラーが検出されるたびに、 新しい結果のタブが [DRC Results]
ウ ィンド ウに追加されます。結果のファイルも個別に PlanAhead の起動ディ レク ト リに出力されま

す。

I/O ポートおよびクロック  ロジック  DRC の実行

次の表に、 デザイン オブジェク ト ごとの DRC ルール、 目的、 重大度を示します。 

メモ : その他の DRC の詳細は、 第 8 章 の 「DRC ルールについて」 を参照してください。

• 「グローバル ク ロ ッ クのルール」

• 「IOB のルール」

• 「バンク  IO 規格のルール」

メモ : PlanAhead で使用可能な I/O ポートおよびクロ ッ ク  ロジッ ク  DRC は、I/O 関連 DRC のほん

の一部です。I/O ポートおよびクロ ッ ク領域の仕様に関しては、使用しているデバイスの資料を参照

して ください。

グローバル クロックのルール

表 4-1 : グローバル クロックのルール

ルール名 ルールの略称 説明 重要性

Clock Region 
Primary 
Secondary

CRPS プライマ リ /セカンダ リ  ペアのクロ ッ クのうち

の 1 つだけが、 4 分割された区画のうちの 1 つ
にグローバル ク ロ ッ ク配線リ ソ－スを介して

アクセスできます。 これらの 2 つのクロ ッ クが

同じ  4 分割の区画で駆動する場合、ネッ トはグ

ローバル ク ロ ッ ク配線リ ソ－スを使用して配

線できません。 

(Spartan-3 デバイス)

メモ : Pblock が複数のクロ ッ ク領域にまた

がっていてエラーがレポート される場合でも、

ISE® で問題なく  Pblock を使用して正しいク

ロ ッ ク領域にロジッ クを配置でき る場合があ

り ます。

エラー

IBUFG to DCM
connectivity

IDCM IBUFG には、 デバイスの同じエッジ (上、 下、

左、 右) にある  DCM への専用配線のみがあ り

ます。

警告

DCM to BUFG
connectivity

DCMB DCM には最大 4 つの BUFG を接続できます。

専用配線 リ ソースを共有するバッ フ ァのペア

が同じ  DCM で駆動される場合、いずれかが非

専用配線 リ ソースを使用して駆動される必要

があるため、 これが原因でデザインでエラーが

発生します。バッファに左から順に 1 ～ 8 の番

号を付ける と、 1 と  5、 2 と  6、 3 と  7、 4 と  8
という  4 組の排他的ペアができます。1:5、2:6、
3:7、4:8 バッファがサイ ト  1 に配置されている

場合は、同 DCM で駆動されるも う一方のバッ

ファはサイ ト  5 に配置できません。 

エラー
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IOB のルール

Number of 
BUFGs allowed 
for DCM

DCMN DCM は最大 4 つの BUFG に接続できます。こ

れは、 DCMB に関連しています。 
エラー

DCM and 
BUFG 
connectivity

DCME BUFG にはデバイスの同じ側 (上、 下、 左、

右) にある  DCM への専用配線のみが存在しま

す。

警告

表 4-2 : IOB のルール

ルール名 ルールの略称 説明 重要性

IOB clock 
sharing

IOCS IOB サイ トはペアに分けられ、 ク ロ ッ ク

配線 リ ソースが共有でき る よ う になっ

ています。 これらのペアは、 通常 LVDS
ペアにな り ます。 フ リ ップフ ロ ップが

IOB にパッ ク されている方法によって

は、 配線で問題が発生するこ とがあ り ま

す。 この問題を解決するには、 フ リ ップ

フロ ップを特定の BEL に割り当てる必

要があ り ます。

警告

IOB set reset 
sharing

IOSR IOB サイ トには入力、 出力、 ト ラ イス

テート  レジスタがあ り、それぞれが同じ

セッ ト / リセッ ト信号を共有しています

が、 異なる リセッ ト信号では、 レジスタ

をパッ クできません。

エラー

Differential IO 
pads

IODI 差動 I/O の P 信号および N 信号は、専用

の差動ペアでは LOC 制約を付ける必要

があ り ます。

エラー

IO Standard 
Type

IOSTDTYPE 差動ペア I/O 規格が、 差動ピンのペアに

のみ割り当てられている こ と を確認し

ます。

警告

Number of IOs IOCNT ターゲッ ト  デバイスにあるピンの数よ

り も多くの I/O ポートが定義されている

かど うかを示します。

警告

IOs placed on 
prohibited sites

IOPR ノ イズの影響を受けやすい GT ピンに関

連するピンのよ うな、 割り当てが禁止さ

れたピンに割 り当てられたポー ト を識

別します。

エラー

Non inputs 
placed on input 
only pins

IOIP 入力専用ピンが入力のみに使用されて

いるこ とを確認します。

エラー

表 4-1 : グローバル クロックのルール

ルール名 ルールの略称 説明 重要性
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Diff term loced 
to low 
capacitance IOB 
Site

IOLVDSCC 差動出力規格が、 この規格をサポート し

ない低キャパシタンス  サイ トで使用さ

れていないこ とを確認します。

エラー

Prohibit not 
specified for part 
compatibility

IOPCPR1 互換性のあるパーツを使用するデザイ

ンに対し、パッケージ ピンが互換パーツ

にないこ と、 「prohibit」 とマーク されて

いるこ とを確認します。

エラー

Pin should be 
prohibit for part 
compatibility

IOPCPR2 互換性のあるパーツを使用するデザイ

ンに対し、パッケージ ピンが互換パーツ

にないこ と、 ポートに割り当てられてい

ないこ とを確認します。

エラー

MGT not 
allowed for part 
compatibility

IOPCMGT 異なる  MGT 供給電圧を持つパーツが 1
つ互換性のあるパーツ と してが使用さ

れているかど うかを確認し、 使用されて

いる場合は、 MGT の使用を無効にしま

す。

警告

Regional Clock 
Term has no 
BUFR site

IOBUFR0 使用可能な BUFIO 以外のロケーシ ョ ン

に リージ ョナル ク ロ ッ ク  ポートが配置

されていないこ とを確認します。

エラー

Regional Clock 
Buffer Placed in 
Unroutable 
location

IOBUFR1 リージ ョナル ク ロ ッ ク  ポートが配置さ

れる場合、 対応する  BUFIO が互換性の

ないロケーシ ョ ンに配置されていない

こ とを確認します。

エラー

Regional Clock 
Buffer Placed in 
Unroutable 
location

IOBUFR2 リージ ョナル ク ロ ッ ク  ポートが配置さ

れる場合、 対応する  BUFIO がほかのエ

レ メ ン ト が使用されていないこ と を確

認します。

エラー

Regional Clock 
Term has no 
BUFR site

IOBUFR3 使用可能な BUFIO のないバンクにリー

ジ ョナル ク ロ ッ ク  ポートが制約されて

いないこ とを確認します。

エラー

Regional Clock 
Buffer Placed in 
Unroutable 
location

IOBUFR4 リージ ョナル ク ロ ッ ク  ポートがバンク

に制約される場合、 対応する  BUFIO が
互換性のないロケーシ ョ ンに配置され

ていないこ とを確認します。

エラー

Regional Clock 
Buffer Placed in 
Unroutable 
location

IOBUFR5 リージ ョナル ク ロ ッ ク  ポートがバンク

に制約される場合、 対応する  BUFIO が
ほかのエレ メ ン ト が使用されていない

こ とを確認します。

エラー

Regional Clock 
Term has no 
BUFIO site

IOBUFIO0 配置された リージ ョナル ク ロ ッ ク  ター

ミナルのサイ トが BUFIO サイ トに配線

可能であるこ とを確認します。

エラー

表 4-2 : IOB のルール

ルール名 ルールの略称 説明 重要性
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バンク  I/O 規格のルール

Regional Clock 
Buffer Placed in 
Unroutable 
location

IOBUFIO1 リージ ョナル ク ロ ッ ク  ターミナルおよ

び接続されている  BUFIO インスタンス

が両方正し く配置されている こ と を確

認します。

エラー

BUFIO Placed in 
Unroutable 
location

IOBUFIO2 配置された リージ ョナル ク ロ ッ ク  ター

ミナルの関連 BUFIO サイ トが使用され

ていないこ とを確認します。

エラー

Regional Clock 
Term has no 
BUFIO site

IOBUFIO3 リージ ョナル ク ロ ッ ク  ターミナルがバ

ンクに割り当てられている場合、 このバ

ンクから配線可能な BUFIO サイ トがあ

るこ とを確認します。

エラー

BUFIO Placed in 
Unroutable 
location

IOBUFIO4 リージ ョナル ク ロ ッ ク  ターミナルがバ

ンクに割り当てられている場合、BUFIO
サイ ト が正し く配置されている こ と を

確認します。

エラー

BUFIO Placed in 
Unroutable 
location

IOBUFIO5 リージ ョナル ク ロ ッ ク  ターミナルがバ

ンクに割り当てられている場合、BUFIO
サイ ト が使用されていないこ と を確認

します。

エラー

表 4-3 : バンク  I/O 規格のルール 

ルール名 ルールの略称 説明 重要性

Bank IO Standard 
Vcc

BIVC バンク内の I/O に対する、IOSTANDARD
ベースの VOUT の電圧互換性を確認しま

す。

エラー

Bank IO Standard 
Support

BIVB I/O 規格が I/O バンクでサポート されてい

るこ とを確認します。

エラー

Bank IO standard 
Termination

BIVT バンク内の I/O に対する、IOSTANDARD
ベースの DCI 終端の電圧互換性を確認し

ます。

エラー

Bank IO Standard 
VREF

BIVR バンク内の I/O で、 IOSTANDARD ベー

スの VREF の電圧互換性を確認します。

エラー

Bank IO Standard 
VREF Occupied

BIVRU バンク内の I/O で、 IOSTANDARD ベー

スの VREF の電圧互換性を確認します。

エラー

表 4-2 : IOB のルール

ルール名 ルールの略称 説明 重要性
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WASSO 解析の実行

WASSO 解析の実行

PlanAhead には WASSO チェッ クのセッ トが含まれており、 デバイスのシグナル インテグ リ ティ

を、 デザインでの I/O ピンおよびバンクの割り当てに基づいて検証します。

解析を実行するには、 [Tools] → [Run WASSO Analysis] をク リ ッ ク します。

Bank IO Standard 
VR Occupied

DCIP I/O バンクには専用の VRP サイ トおよび

VRN I/O サイ トがあ り、 これらは通常の

I/O と しても使用できます。 このバンクで

DCI I/O 規格が使用される場合は、これら

の I/O を未使用にしておく必要があ り ま

す。

エラー

Bank IO standard 
limits

BISLIM 同じバンクに同時にいくつの規格グルー

プを指定できるか、パーツごとの制限を確

認します。

エラー

Inconsistent Diff 
pair IO Standards

DIFFISTD 差動ペアのターミナルに同じ  I/O 規格が

設定されているかを確認します。

エラー

Inconsistent Diff 
pair IO Standards

DIFFISTDDrv 差動ペアのターミナルに同じ駆動が設定

されているかを確認します。

エラー

Inconsistent Diff 
pair IO Standards

DIFFISTDSle
w

差動ペアのターミナルに同じスルーが設

定されているかを確認します。

エラー

表 4-3 : バンク  I/O 規格のルール 

ルール名 ルールの略称 説明 重要性
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[Run Wasso Analysis] ダイアログ ボッ クスが表示されます。 

[Output File] フ ィールドでは、 レポート  ファ イル名および保存場所を指定できます。

カーソルをフ ィールド上に置く と、そのフ ィールドに入力する値の説明を示したツール ヒ ン トが表

示されます。

WASSO 解析レポートの確認

[Device Parameters] および [Board Parameters] の値は、デザインに合わせて変更できます。まずデ

ザイン全体が解析され、 次に、 関連した隣接の I/O バンクが次々に解析されます。 WASSO の結果

のウ ィンド ウはワークスペースに表示されます。

図 4-32 : [Run Wasso Analysis] ダイアログ ボックス
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パッケージ ピンの情報のエクスポート

レポートには、 I/O バンク と隣接するペアの 最大負荷、 使用率、 およびステータスがすべて表示さ

れます。

パッケージ ピンの情報のエクスポート

デバイス  パッケージ ピンの情報は、 PlanAhead から  CSV 形式のファイルにエクスポートできま

す。 エクスポート内容には、 デバイスのパッケージ ピンすべての情報およびデザインごとの I/O
ポートの割り当てと設定が含まれます。 

エクスポート された リ ス トのパッケージ ピン セクシ ョ ンを基に、I/O ポート をスプレッ ドシートで

定義できます。 

エクスポート された CSV 形式のファイルの情報は、 この章の 「I/O ポートのインポート 」 を参照し

て ください。

図 4-33 : WASSO Results
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I/O ポート  リス トのエクスポート  
I/O ポート  リ ス トは、PlanAhead から  HDL、UCF、または CSV 形式のファイルにエクスポート し、

RTL のコーディングや PCB 回路図シンボルの作成に使用できます。 I/O ポート  リ ス トの情報をエ

クスポートするには、 [File] → [Export I/O Ports] コマンドをク リ ッ ク します。

図 4-34 : I/O ポート  リス トのエクスポート
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第 5 章

Project Navigator からの PlanAhead の
使用

本章は、 次のセクシ ョ ンで構成されています。

• 「統合の概要」

• 「ISE および PlanAhead の統合プロセス」

• 「PlanAhead の表示環境」

• 「PACE / Floorplan Editor から  PlanAhead への移行」

• 「Floorplanner から  PlanAhead への移行」

統合の概要

PlanAhead™ ソフ ト ウェアは特定のデザイン作業を行うため ISE® ソフ ト ウェアと統合していま

す。PlanAhead が ISE Project Navigator から起動する と、PlanAhead は ISE 統合モードで起動しま

す。 このモードでは、 PlanAhead の機能は I/O ピン割り当て、 フロアプラン、 タイ ミ ング解析など、

特定のデザイン作業にのみ適用されます。 PlanAhead プロジェク トは、 Project Navigator 環境で自

動的に作成 ・ 管理されます。

PlanAhead を起動させる  Project Navigator の [Processes] ウ ィンド ウには次の 4 つのプロセスがあ

り ます。

• I/O ピン割り当て (合成前)

• I/O ピン割り当て (合成後)

• エリア/IO/ロジックのフロアプラン (合成後)

• タイ ミング解析/デザインのフロアプラン (インプリ メンテーシ ョ ン後)

この 2 つのツール間で渡されるデータや、PlanAhead で表示されるウ ィンド ウ  レイアウ トは、どの

よ うにツールが起動されたかによって変わり ます。統合に関する詳細は、「ISE および PlanAhead の
統合プロセス」 を参照して ください。

PlanAhead には 2 つのデフォルト  ウ ィンド ウ  レイアウ トがあ り ます。1 つは PinAhead と呼ばれる

I/O ピン割り当て環境で、I/O ピン割り当てに関連した表示機能を含みます。も う  1 つは PlanAhead
フロアプラン環境で、 デザイン解析およびフロアプランに関連しています。 作業内容に合った正し

いウ ィンド ウ  レイアウ ト を使用するこ とが重要です。 

PlanAhead 表示環境の詳細は、 第 3 章 「表示環境の使用」 を参照してください。

ウ ィンド ウ  レイアウ トの設定や読み込みの詳細は、 「ウ ィンド ウの環境設定」 を参照してください。
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ISE および PlanAhead の統合プロセス

Project Navigator と  PlanAhead は、それぞれ独立した環境で、別のシステム プロセスの下で動作し

ています。2 のプロセスを可能な限り統合し、ツール間でのデータ渡しを確実にするため、さまざま

な作業が行われてきました。1 つのツールでデザイン データに変更が加えられても、 リ アル タイム

にはも う  1 つのツールで自動認識はされません。 ですから、 両方のツールで同時にロジッ クや制約

の編集はしないでください。PlanAhead は目的に合わせて起動し、Project Navigator デザイン デー

タを更新する前に閉じて ください。Project Navigator のプロセスは、PlanAhead で変更された UCF
ファ イルを認識するため、 データが保存される と同期します。 次のセクシ ョ ンでは、 ツールの起動

ステップおよび統合を可能にするデータ  ト ランザクシ ョ ンについて説明します。

ロジックおよび制約の渡し  
ISE 統合モードでの PlanAhead では、I/O ピン、論理 LOC および AREA_GROUP 制約に対する物

理的な制約のみを変更するこ とができます。次のすべてのケースにおいて、 RTL ソースや合成ネッ

ト リ ス トでの論理接続は PlanAhead に解析目的のためのみ渡され、Project Navigator には戻されま

せん。ロジッ クやタイ ミ ング制約を変更する  PlanAhead の機能はべて ISE 統合モードでは使用でき

ないよ うになっています。 ロジッ クの変更はすべて Project Navigator または外部 RTL や合成ツー

ルで行う必要があ り ます。 Project Navigator に戻されるファイルは UCF 制約ファイルのみです。

PlanAhead では UCF ファ イルの元の内容とフォーマッ トが保持されます。コ メン ト、不完全な制約

などがそ うです。 デザインで制約が有効であるかど うかは、 PlanAhead を開いたり閉じた りする と

きにはチェッ ク されません。 これは Project Navigator の変換プロセスでチェッ ク されます。

PlanAhead が起動する と、Project Navigator プロジェク トの UCF ソース  ファ イルが PlanAhead に
渡され、 物理制約を追加したり変更したりできます。 PlanAhead で [Save Project] コマンドを使用

する と、変更された UCF ファ イルが元の Project Navigator のソースの保存場所に書き込まれます。

PlanAhead で制約を変更し  [Exit] コマンドを使用する と、ツールを閉じる前に Project Navigator プ
ロジェク トに変更を保存するかど うかを確認する メ ッセージが表示されます。

PlanAhead を起動し  Project Navigator プロジェク トに UCF ファ イルがない場合、UCF を作成する

かど うかを確認するプロンプ トが表示されます。 この空の UCF ファ イルは PlanAhead に渡されま

す。

複数の UCF ファ イルを持つ Project Navigator プロジェク トがサポート されています。 PlanAhead
を起動する前に複数ある  UCF ファ イルの 1 つを選択するよ うプロンプ トが表示されます。

PlanAhead で定義された新しい制約はすべて選択した UCF ファ イルに書き込まれます。 選択され

なかった UCF ファ イルに存在する物理制約は、 PlanAhead でその制約の値が変更されても、 同じ

ファ イルの中に残り ます。

Project Navigator デザイン フローで使用されるコア レベル の NCF ファ イルは PlanAhead には渡

されません。 PlanAhead でこれらのファイルにある物理制約を使用・表示するには、 PlanAhead を
起動する前に最上位 UCF ファ イルに手動でまとめておく必要があ り ます。

一時的な PlanAhead プロジェク トは ISE プロジェク ト  ディ レク ト リに作成され、 PlanAhead が
Project Navigator から起動されるたびに削除および置換されます。

I/O ピン割り当て (合成前)
合成ネッ ト リ ス ト を作成する前に I/O ピン割り当てを早期に実行するこ とができます。 PlanAhead
をスタンドアロンで起動するか、 または Project Navigator のこのプロセスを実行して、 この作業を

行う こ とができます。 
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メモ : デザイン プロセスのこの段階では、 論理合成はまだ実行されていません。 ク ロ ッ ク  ポート、

ク ロ ッ ク関連ロジッ ク、差動ペア、GT などのコンセプ トはツールには認識されていません。 このよ

うなタイプのポートはインプリ メンテーシ ョ ン エラーを避けるために正し く配置されているこ と

を必ず確認する必要があ り ます。できる限り  I/O ピン割り当ては論理合成の後に実行してください。

ネッ ト リ ス トがある場合はクロ ッ ク、 ク ロ ッ ク  ロジッ ク、 差動ペア、 GT などは、 PlanAhead での

ピン割り当て中に自動的に認識されます。 PlanAhead には、 インプリ メンテーシ ョ ン前に配置の有

効性を確認するための、論理接続およびクロ ッ クに基づき実行されるデザイン ルール チェッ ク も多

数備わっています。

合成実行前に Project Navigator でI/O ピン割り当てを実行するには、 [Processes] ウ ィンド ウで

[User Constraints] を展開し  [IO Pin Planning (PlanAhead) - Pre-Synthesis] をダブルク リ ッ クする

か、 または [Tools] → [PlanAhead] → [Pre-Synthesis - IO Pin Planning] をク リ ッ ク します。

PlanAhead が起動する と、 Project Navigator からすべての RTL ソース  ファ イル、 最上位モジュー

ル名、 UCF ファ イルが PlanAhead に渡されます。 デフォルトの I/O ピン割り当て環境 (PinAhead)
のウ ィンド ウ  レイアウ トで PlanAhead が起動します。 RTL エラボレートが実行され、 最上位 I/O
ポートが抽出され PlanAhead の [I/O Ports] ウ ィンド ウに表示されます。

PlanAhead プロジェク ト を保存したり閉じた りする と、元の Project Navigator ソース  UCF ファ イ

ルがアップデート されます。Project Navigator デザイン プロセスのステートはこれでリセッ ト され

ます。

Project Navigator との統合およびプロセスについての詳細は、「ロジッ クおよび制約の渡し」 を参照

して ください。

PlanAhead I/O 環境割り当て (PinAhead) の使用方法については、第 4 章 「I/O ピンの配置」 を参照

して ください。

I/O ピン割り当て (合成後)
メモ : できる限り  I/O ピン割り当ては論理合成の後に実行して ください。 ネッ ト リ ス トがある場合

はクロ ッ ク、 ク ロ ッ ク  ロジッ ク、 差動ペア、 GT などは、 PlanAhead でのピン割り当て中に自動的

に認識されます。 インプリ メンテーシ ョ ン前に配置の有効性を確認するための、 論理接続およびク

ロ ッ クに基づき実行されるデザイン ルール チェッ ク  (DRC) も多数備わっています。

合成実行後に Project Navigator でI/O ピン割り当てを実行するには、 [Processes] ウ ィンド ウで

[User Constraints] を展開し  [IO Pin Planning (PlanAhead) - Post-Synthesis] をダブルク リ ッ クする

か、 または [Tools] → [PlanAhead] → [Post-Synthesis - IO Pin Planning] をク リ ッ ク します。

PlanAhead が起動する と、 Project Navigator から合成された NGC または EDIF フォーマッ トの

ネッ ト リ ス トおよび UCF ファ イルが PlanAhead に渡されます。 デフォルトの I/O ピン割り当て環

境 (PinAhead) のウ ィンド ウ  レイアウ トで PlanAhead が起動します。[I/O Ports] ウ ィンド ウが表示

されます。 

PlanAhead プロジェク ト を保存したり閉じた りする と、元の Project Navigator ソース  UCF ファ イ

ルがアップデート されます。Project Navigator デザイン プロセスのステートはこれでリセッ ト され

ます。

Project Navigator との統合およびプロセスについての詳細は、「ロジッ クおよび制約の渡し」 を参照

して ください。

PlanAhead I/O 環境割り当て (PinAhead) の使用方法については、第 4 章 「I/O ピンの配置」 を参照

して ください。
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エリア/IO/ロジックのフロアプラン (合成後)
PlanAhead にはインプリ メンテーシ ョ ンの前後に使用できるデザイン解析およびフロアプラン環

境があ り ます。論理合成実行後およびインプリ メンテーシ ョ ン前に Project Navigator でデザイン解

析またはフロアプランを実行するには、 [User Constraints] を展開し、 [Floorplan Area/IO/Logic
(PlanAhead) - Post-Synthesis] を実行するか、 または [Tools] → [PlanAhead] → [Post-Synthesis -
Floorplan Area/IO/Logic] をク リ ッ ク します。

PlanAhead が起動する と、 Project Navigator から合成された NGC または EDIF フォーマッ トの

ネッ ト リ ス トおよび UCF ファ イルが PlanAhead に渡されます。 PlanAhead がデフォルトのデザイ

ン解析およびフロアプラン環境で起動します。 

メモ : 下位 NGC コア ファ イルがデザインで使用されソースと して追加されていない場合、Project
Navigator で、変換プロセスのプロパティであるマクロ検索パス  (-sd) を該当ディ レク ト リに設定し

ます。

PlanAhead プロジェク ト を保存したり閉じた りする と、元の Project Navigator ソース  UCF ファ イ

ルがアップデート されます。Project Navigator デザイン プロセスのステートはこれでリセッ ト され

ます。

Project Navigator との統合およびプロセスについての詳細は、「ロジッ クおよび制約の渡し」 を参照

して ください。

インプリ メンテーシ ョ ン前に PlanAhead を使用する方法については、 「デザイン解析およびフロア

プランのウ ィンド ウ  レイアウ ト 」 を参照してください。

インプリ メンテーシ ョ ン後に PlanAhead を使用する方法については、 第 9 章 「インプリ メンテー

シ ョ ン結果の解析」 および第 10 章 「デザインのフロアプラン」 を参照してください。 

タイ ミ ング解析/デザインのフロアプラン (インプリ メンテーシ ョ ン後)
PlanAhead にはインプリ メンテーシ ョ ンの前後に使用できるデザイン解析およびフロアプラン環

境があ り ます。 インプリ メンテーシ ョ ン後のデザイン解析では、 潜在的なデザインの問題を理解す

るために配置を配置結果を確認するこ とができます。物理的な LOC または AREA_GROUP フロア

プラン制約を設定し、インプ リ メンテーシ ョ ン ツールでよ り よ く、安定した結果が得られるよ う、ま

た、 インプリ メンテーシ ョ ン ランタイムを短縮できるよ うにするこ とができます。 

インプリ メンテーシ ョ ン後に Project Navigator からデザイン解析またはフロアプランを実行する

には、 [Implement Design] および [Place & Route] を展開し、 [Analyze Timing/Floorplan Design
(PlanAhead) - Post-Synthesis] をダブルク リ ッ クするか、 または [Tools] → [PlanAhead] → [ Post-
Implementation - Analyze Timing/Floorplan Design] をク リ ッ ク します。

PlanAhead が起動する と、 Project Navigator から合成された NGC または EDIF フォーマッ トの

ネッ ト リ ス ト 、UCF ファ イル、ISE 配置データ、およびタイ ミ ング結果が PlanAhead に渡されます。

PlanAhead がデフォルトのデザイン解析およびフロアプラン環境で起動します。 PlanAhead で ISE
配置データを抽出するには、 xdl という コマンドをまず実行する必要があ り ます。 拡張子が .xdl の
ファイルが生成されますが、 実行に少々時間がかかるこ とがあ り ます。 このコマンドの実行進捗状

況を示すバーが PlanAhead に表示されます。PlanAhead の再起動をスピードアップさせるため、ま

ず XDL ファ イルが存在するかど うかチェッ ク され、最新のものがある場合は再生成されません。古

い日付のインプリ メンテーシ ョ ン プロセスで [Tools] → [PlanAhead] → [Post Implementation -
Analyze Timing /Floorplan Design] をク リ ッ クする と、デザインを再インプリ メン ト し  PlanAhead
を起動するか、または既存結果データでインプリ メンテーシ ョ ン ツールを再実行せずに PlanAhead
を起動するかを選択するプロンプ トが表示されます。
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PlanAhead プロジェク ト を保存したり閉じた りする と、元の Project Navigator ソース  UCF ファ イ

ルがアップデート されます。Project Navigator デザイン プロセスのステートはこれでリセッ ト され

ます。

Project Navigator との統合およびプロセスについての詳細は、「デザイン解析およびフロアプランの

ウ ィンド ウ  レイアウ ト 」 を参照してください。

インプリ メンテーシ ョ ン後に PlanAhead を使用する方法については、 第 9 章 「インプリ メンテー

シ ョ ン結果の解析」 および第 10 章 「デザインのフロアプラン」 を参照してください。

PlanAhead の表示環境

I/O ピン割り当てのウィンドウ レイアウト

Project Navigator でI/O ピン割り当てのプロセスが実行される と、 PinAhead が自動的に起動しま

す。PlanAhead 内でこの環境を起動するこ と もできます。その場合は [Tools] → [Open PinAhead] ま
たは [Layout] → [Load Layout] → [PinAhead Cockpit] をク リ ッ ク します。

図 5-1 : ISE 統合モードでの PinAhead ウィンドウ レイアウト  
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表示環境のエリ アは次のよ うに定義されています。

1. [Properties] ウ ィンド ウ、[Selection] ウ ィンド ウ、[Netlist] ウ ィンド ウ、[Constraints] ウ ィンド ウ

2. [Clock Regions] ウ ィンド ウ

3. I/O ポート  リ ス ト

4. パッケージ ピン、 コンソール、 結果表示 (タイ ミ ング、 検索、 デザイン ルール チェッ ク )

5. ワークスペース  : [Device] ウ ィンド ウ、 [Package] ウ ィンド ウ、 [Schematic] ウ ィンド ウ、

[Hierarchy] ウ ィンド ウ、 レポート

PinAhead 環境では、 特定のデバイス  パッケージおよびデザイン特有の I/O 情報に関する情報が表

示されます。この環境のウ ィンド ウ  レイアウ トは、PlanAhead のレイアウ ト と異なり ます。[Layout]
→ [Load Layout] → [PlanAhead Default] をク リ ッ クする と、 デフォルトの PlanAhead 環境に戻り

ます。 

PlanAhead 表示環境の詳細は、 第 3 章 「表示環境の使用」 を参照してください。

I/O ピン配置の詳細は、 第 4 章 「I/O ピンの配置」 を参照してください。 

デザイン解析およびフロアプランのウィンドウ レイアウト

Project Navigator の [Processes] ウインド ウで [Floorplan Area/IO/Logic] または [Analyze
Timing/Floorpan Design] を選択するか、 または [Tools] → [PlanAhead] をク リ ッ クする と、

PlanAhead デザイン解析およびフロアプラン環境は自動的に起動します。PlanAhead 内から起動す

る場合は、 [Layout] → [Load Layout] → [PlanAhead Default] をク リ ッ ク します。
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フロアプランを開いてアクティブにする と、 デフォルトのフロアプラン環境レイアウ トが表示され

ます。 

表示環境のエリ アは次のよ うに定義されています。

1. 物理階層、 メ ト リ ッ ク、 ソースのウ ィンド ウ

2. プロパティや選択のウ ィンド ウ  

3. コンソール、I/O ポート、パッケージ ピン、結果 (タイ ミ ング、検索、DRC、 メ ト リ ッ ク ) のウ ィ

ンド ウ

4. ネッ ト リ ス ト 、 制約のウ ィンド ウ

5. ワークスペース  : [Device]、 [Package]、 [Schematic]、 [Hierarchy] ウ ィンド ウ、およびレポート

6. [World] ウ ィンド ウ

PlanAhead 表示環境の詳細は、 第 3 章 「表示環境の使用」 を参照してください。

図 5-2 : PlanAhead のフロアプラン環境 
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PACE / Floorplan Editor から  PlanAhead への移行 
ISE Design Suite 11.1 では、FPGA ピン割り当ておよびフロアプラン機能はすべて PlanAhead で提

供されています。 フル ライセンスの正規版 PlanAhead がこの ISE リ リースで提供されています。 

このセクシ ョ ンでは、PACE または Floorplan Editor で行われていた作業を PlanAhead で行う方法

を説明します。

概要

PlanAhead は Project Navigator またはコマンド  ライン プロンプ トから起動させるこ とができま

す。 Project Navigator 環境と統合されているため、 PlanAhead は次の 4 つのデザイン プロセス  ス
テップで起動できます。

• I/O ピン割り当て (合成前)

• I/O ピン割り当て (合成後)

• エリア/IO/ロジックのフロアプラン (合成後)

• タイ ミング解析/デザインのフロアプラン (インプリ メンテーシ ョ ン後)

各ステップで、以前はスタンドアロンの PlanAhead でのみ使用可能であった強力な機能が提供され

ています。PlanAhead が Project Navigator から起動する と、選択された作業に特定の PlanAhead 機
能だけにアクセスできます。 

スタンドアロンの PlanAhead を起動する と、RTL からビッ ト ス ト リーム生成、そしてデザイン解析

機能まで、 PlanAhead をフルに使用するこ とができます。 

CPLD の場合は、ISE Design Suite 11.1 ではグラフ ィカルなピン割り当て用に PACE がサポート さ

れています。

本書では、PACE や Floorplan Editor で行われていた一般的な作業、主にピン割り当てとエ リ ア ベー

スのフロアプランについて説明します。 各作業は続くセクシ ョ ンで説明し、 同じ作業を PlanAhead
環境を使用して行う方法も簡単に説明します。

Project Navigator からの PlanAhead の起動

Project Navigator の [Processes] ウ ィンド ウには、ピン割り当ておよびフロアプランのための 4 つの

主なプロセスがあ り、 I/O ピン割り当て (合成前)、 I/O ピン割り当て (合成後)、 エ リ ア/IO/ロジッ ク

のフロアプラン (合成後)、タイ ミ ング解析/デザインのフロアプラン (インプリ メンテーシ ョ ン後) が
その 4 つです。

この 4 つのプロセスのいずれかを実行する と選択したタスクに最も適したモードで PlanAhead が
起動します。 Project Navigator と  PlanAhead は完全統合されています。 つま り、 Project Navigator
から  PlanAhead へ必要な入力ファイルがすべて自動的に供給されます。 UCF 制約など PlanAhead
からの出力ファイルは保存される と  Project Navigator プロジェク ト内の該当場所に保存されます。 

Project Navigator から起動されるている場合 PlanAhead は ISE 統合モードで開いており、スタンド

アロンの PlanAhead の機能がすべて使用できるわけではあ り ません。 
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スタンドアロンの PlanAhead の起動

PlanAhead は、標準のコマンド ラ イン シェル プロンプ ト  (Windows または Linux) で 「planahead」
と入力するか、 または Windows の場合、 PlanAhead のデスク ト ップ アイコンをダブルク リ ッ ク し

て起動します。 PlanAhead を使用するには、 まず :

1. 起動画面で [Create a New Project] をク リ ッ ク します。

2. New Project ウ ィザードが開きます。

3. ピン割り当てタスクまで進みます。   

スタンドアロンでの PlanAhead 起動方法の詳細は、第 2 章 「プロジェク トの作成および管理」 を参

照して ください。

デザイン フローの段階によ り、 空のデザイン、 合成前、 合成後のモードで作業を開始できます。 こ

れらのモードは、 PACE および Floorplan Editor で提供されていたものと同様です。

空デザインおよび合成前の I/O ピン割り当て

空デザインのモードでは、既存の HDL やネッ ト リ ス ト  ファ イルを使用せず PlanAhead をスタンド

アロンで起動します。 New Project ウ ィザードで [Do not import sources at this time] を選択し、

PlanAhead を空デザインのモードで開きます。

合成前モードは、少なく と も最上位ポート を含む Verilog または VHDL ファ イル、CSV ファ イル、

または UCF 制約ファイルがあるこ とが前提です。 PlanAhead で [File] → [Import I/O Ports] →
[From HDL/CSV/UCF] をク リ ッ ク し、 空のプロジェク トに I/O ポート をインポート します。

このモードでは PlanAhead は通常初期ピン割り当てツールと して使用されます。 

メモ : 合成ネッ ト リ ス トがない場合、 クロ ッ ク  ポートや関連クロ ッ ク  ロジッ クは認識されません。

ク ロ ッ ク  ポートは細心の注意を払って配置する必要があ り ます。合成ネッ ト リ ス トが入力と して使

用される場合、 クロ ッ ク、差動ペア、 GT、 ク ロ ッ ク関連ロジッ ク配置機能、およびデザイン ルール

チェッ クが多く使用可能になり ます。

空デザイン モードでサポート されているタスクは次のとおりです。

• CSVのインポート  : マイ クロソフ トの Excel のよ うな表計算形式のピンのリ ス ト を使用しピン

割り当てを開始します。 このリ ス トは CVS (カンマ区切り ) ファ イルと して保存されています。

PlanAhead で [File] → [Import I/O Ports] をク リ ッ ク し、 I/O ポート  リ ス ト をインポート しま

す。こ こから個々のピン (またはピンのグループ) を [Device] または [Package] ウ ィンド ウにド

ラ ッグ アンド  ド ロ ップします。

• UCF のインポート  : 既存の UCF ファ イルで定義されたピンのリ ス トがあるデザインの場合、

PlanAhead でこ う した既存 UCF ファ イルを I/O ポート  リ ス トにインポートできます。 こ こか

ら個々のピン (またはピンのグループ) を [Device] または [Package] ウ ィンド ウにド ラ ッグ ア
ンド  ド ロ ップします。 CSV ファ イルのインポート と同様に [File] → [Import I/O Ports] をク

リ ッ ク します。ポートの方向は UCF ファ イルでは定義されていません。ピンを割り当てる前に

ポート方向を [Set Direction] ポップアップ メニュー コマンドで定義する必要があ り ます。

• HDL のインポート  : メ インの I/O ピンを定義する最上位 HDL ファ イルのあるデザインで、そ

のファイルが NGC または EDIF ネッ ト リ ス トに合成されていない場合に使用します。 (この時

点の最上位 HDL ファ イルにはポート定義以外には何も含まれていないこ とが多く、 合成可能

な状態になっていません。 )PACE または Floorplan Editor と同様、 PlanAhead でも このファイ

ルを読み込んで早期にピン割り当て作業を行う こ とができます。 また、 CSV や UCF ファ イル

と同様に、合成前の HDL ファ イルも  [File] → [Import I/O Ports] をク リ ッ ク してインポート し

ます。 
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• I/O ポートの作成 : 既存入力ファイルなしにピン割り当てを開始するには、 [I/O Port] ウ ィンド

ウの [Create I/O ports] ポップアップ メニュー コマンドを使用し、 ピン定義を新たに作成する

こ とができます。 

• 最上位 HDL のエクスポート  : ピン割り当てが完了したら、PACE や Floorplan Editor の場合と

同様に、 HDL ポート  リ ス トにインポート したピン名を含む最上位の Verilog またはVHDL
ファ イルをエクスポートできます。これは HDL コードを記述し始める と きに便利な機能です。

• CSV のエクスポート  : ボード  レイアウ ト  ツールなどの外部アプリ ケーシ ョ ンでも使用できる

よ う、 PlanAhead には CSV フォーマッ トのピン リ ス ト とデータをエクスポートする機能もあ

り ます。

• UCF のエクスポート  : ピン定義が記述された UCF フォーマッ トの制約ファイルをエクスポー

トするこ と もできます。

空デザインおよび合成前のピン割り当ての注意事項

• DRC 機能 : DRC は [Tool] → [Run DRC] をク リ ッ ク して実行できます。 空デザインまたは合

成前のピン割り当てモードで、 ピン割り当ての有効性を確認するために実行できる  DRC は限

られています。通常、 I/O 規格バンク  ルールなどのチェッ クが行われますが、 クロ ッ ク  ルール

などの高度な DRC は実行できません。さ らに多くの DRC が実行できるのは、合成後のネッ ト

リ ス トが PlanAhead で使用できるよ うになった時点です。

• UCF への制約の保存 : ピン割り当てが完了したら、ISE インプリ メンテーシ ョ ン ツールで後続

処理をするため、 制約を UCF ファ イルに保存するこ とができます。  

上記のタスクは、 PACE や Floorplan Editor で行われていたのと同様の初期段階のピン割り当てタ

スクです。 こ う したタスクの詳細や PlanAhead でのピン割り当て機能の一般情報は、 第 4 章 「I/O
ピンの配置」 を参照して ください。 

合成後のピン割り当ておよびエリア ベースのフロアプラン

このモードでは、合成ネッ ト リ ス ト  (EDIF または NGC ファ イル) と、場合によっては既存の UCF
ファ イルがあるこ とが前提です。 これは、 このモードで PlanAhead を使用する場合に最低限必要な

入力ファイルです。

合成後モードで起動する と、PlanAhead で使用可能な機能はさらに増えます。このセクシ ョ ンでは、

PACE や Floorplan Editor から  PlanAhead に移行するのに非常に関連のある次のタスクを説明しま

す。

• PlanAhead の DRC をフルに活用したピン割り当て : ク ロ ッ ク  ルール、 I/O 配置チェッ クなど

が含まれます。合成後モードではさらに多くの DRC が使用可能になるため、できる限り合成後

に DRC を実行するこ とを推奨します。 DRC は [File] → [Run DRC] をク リ ッ ク して実行しま

す。 PlanAhead のI/O DRC の詳細は、 第 4 章 「I/O ピンの配置」 を参照して ください。

• PlanAhead には、 エリ ア ベースのフロアプランを行うための機能もフルに装備されています。

PACE や Floorplan Editor と同様に、グラフ ィカルなデバイス表示機能を利用し、階層ブロ ッ ク

をデバイスの特定領域にマップするこ とができます。

• PACE や Floorplan Editor と同様に、PlanAhead を使用し、グローバル ク ロ ッ ク  バッファ、ブ

ロ ッ ク  RAM、DSP ブロ ッ ク、PLL/DLL などのグローバルなロジッ クを固定するこ と もできま

す。 

• PACE や Floorplan Editor と異な り、特定の LUT、 フ リ ップフロ ップ、SRL など下位ロジッ ク

の詳細なフロアプランも  PlanAhead では実行でき、完全なピン割り当てとフロアプラン機能が

備わっています。
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一般的な I/O ピン割り当ておよびフロアプラン タスク

主な機能はほぼすべて PlanAhead にも装備されているため、 PACE や Floorplan Editor から

PlanAhead への移行は比較的簡単なプロセスです。次のリ ス トは PlanAhead の一般的な機能の一覧

です。 

メモ : 空デザインまたは合成前モードでは利用できない機能もあ り ます。

I/O ピン割り当て

• [I/O Ports] ウ ィンド ウから ド ラ ッグ アンド  ド ロ ップして [Device] や [Package] ウ ィンド ウに

データを移動するこ とができます。[Package] ウ ィンド ウでは、パッケージの上面および下面の

両方の表示がサポート されています。

• ド ラ ッグ アンド  ド ロ ップ操作のと き、バスはピンのセッ ト と して処理され、1 つのまとま り と

して割り当てられます。

• 予め定義されているバスと同様に、 ピンをグループにまとめて割り当てられるよ うユーザー定

義するこ と もできます。

• [I/O Ports] ウ ィンド ウで、I/O 規格、駆動強度、差動ペア バンク といった I/O プロパティを個々

のピンやピンのグループ (バス) に割り当てるこ とができます。

• PlanAhead では [Tools] → [Run WASSO Analysis] をク リ ッ ク して WASSO 解析を実行でき

ます。 PACE や Floorplan Editor をさ らに強化した機能と して、 PlanAhead ではさらに多くの

WASSO ルールに基づいた解析が実行されます。

• デザイン ルール チェッ ク  (DRC) は、 [Tools] → [Run DRC] をク リ ッ ク して実行できます。

• 完全なネッ ト リ ス トのあるデザインには完全な I/O バンク  ルール チェッ クのセッ トが提供さ

れます。

• ク ロ ッ ク  ルールも、ク ロ ッ ク  バッファの配置が有効で最適であるこ とを確認するために実行さ

れます。 ただし、 空デザインまたは合成前モードでは使用できません。

• コンフ ィギュレーシ ョ ン ピンをモード別に使用禁止 : PACE や Floorplan Editor には JTAG
ポート などのデバイス  コンフ ィギュレーシ ョ ン ピンを汎用ユーザー I/O ピンに使用しないよ

うにする機能があ り ました。 PlanAhead ではこれは手動で行う作業ですが、 [Device] または

[Package] ウ ィンド ウで使用禁止にするピンを選択し、 右ク リ ッ クで表示される  [Set Prohibit]
コマンドを使用して使用禁止とマークをするだけです。

• パッケージ移行サポート  : PlanAhead には、同じデバイス  ファ ミ リ内のフッ トプ リ ン トで互換

性のあるパッケージのピンを自動的に使用禁止にする機能があ り ます。 [Package] ウ ィンド ウ

で右ク リ ッ クする と表示される  [Make Part Compatible] コマンドを使用します。

• パッケージ ピン フライ ト  タイム表示 (ワイヤボンドのパッケージでは無効) : PlanAhead では

パッケージ フライ ト  タイムのグラフ ィカルな表示はあ りせんが、ト レース長値は各 I/O ピンの

プロパティで表示できます。 ピンを選択し  [Package] ウ ィンド ウで表示します。

エリアをベースとしたフロアプラン

• PACE や Floorplan Editor のよ うに、PlanAhead でもエリ ア ベースのフロアプランを作成でき

ます。 PlanAhead の用語では、 これは物理ブロッ クまたは Pblock を作成する、 といいます。

[Netlist] ウ ィンド ウで階層のグループを選択し、 右ク リ ッ クで表示される  [Draw Pblock] コマ

ンド、またはツールバー ボタンの [Draw Pblock] を使用します。これで [Device] ウ ィンド ウで

長方形の描画し、 選択したロジッ クのブロ ッ クを長方形内に割り当てるこ とができます。  

• PlanAhead は、 描画された領域にロジッ クが必ずフ ィ ッ トするよ うに確認します。 ロジッ ク使

用率、 キャ リー チェーンの高さ、 および RPM フッ トプ リ ン トが確認されます。
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エリ ア ベースの Pblock の作成および変更に関しては、第 10 章 「デザインのフロアプラン」 を参照

して ください。

新規制約を UCF ファイルに保存

PACE や Floorplan Editor と同様に、ピン割り当ておよびフロアプランの主な出力は UCF ファ イル

です。 プロジェク ト をいったん保存すれば、 以前に使用したツールで生成したのとまったく同じよ

うに UCF ファ イルを使用できます。

ISE インプリ メンテーシ ョ ン結果ページの表示

PlanAhead では、ISE でコマンド  ラインを実行した後のインプリ メンテーシ ョ ン結果をインポート

できます。New Project ウ ィザードには、ISE 結果からプロジェク ト を作成するオプシ ョ ンがあ り ま

す。 このウ ィザードで、 ネッ ト リ ス ト 、 制約、 配置、 およびタイ ミ ング データに関するオプシ ョ ン

を設定しながらプロジェク ト を作成します。 ISE 結果をインポートする詳細は、「ISE 配置およびタ

イ ミ ング結果を使用したプロジェク トの作成」 を参照して ください。

まとめ

PlanAhead では、 PACE および Floorplan Editor と同じ機能が提供され、 ツールの移行が非常に簡

単になっています。 Project Navigator から起動した場合は、 PlanAhead にはリ クエス ト したプロセ

スに特化した機能のみが表示されます。 逆に、 スタンドアロンで起動した場合は、 PlanAhead の全

機能をフルに活用できます。 PlanAhead は、 ピン割り当ておよびフロアプラン用には非常に簡単で

使いやすいツールである一方で、デザインの解析、最適化、デザイン ク ロージャには非常に高度な

機能を提供しています。 PlanAhead の資料や紹介ビデオは、 http://japan.xilinx.com/planahead をご

覧ください。

Floorplanner から  PlanAhead への移行 
ISE Design Suite 11.1 では、FPGA フロアプラン機能はすべて PlanAhead で提供されています。フ

ル ライセンスの正規版 PlanAhead がこの ISE リ リースで提供されています。 

このセクシ ョ ンでは、従来は Floorplanner で行われていたタスク、主に LUT、フ リ ップフロ ップな

どの詳細なフロアプランおよびタイ ミ ング パス解析を PlanAhead で行う方法を説明します。各作業

は続くセクシ ョ ンで説明し、 同じ作業を PlanAhead 環境を使用して行う方法も簡単に説明します。

ピン割り当てまたはエリ ア ベースのフロアプランについては、 「PACE / Floorplan Editor から

PlanAhead への移行」 を参照してください。

Project Navigator からの PlanAhead の起動

一般的な、インプリ メンテーシ ョ ン後のフロアプランの場合、Project Navigator の [Processes] ウ ィ

ンド ウの [Floorplan Design/Analyze Timing (Post-Implementation)] プロセスをダブルク リ ッ ク し

て PlanAhead を起動します。この方法だと、選択したタスクに最も適したモードで PlanAhead が起

動します。Project Navigator と  PlanAhead は完全統合されています。つま り、Project Navigator か
ら  PlanAhead へ必要な入力ファイルがすべて自動的に供給されます。UCF 制約など  PlanAhead か
らの出力ファイルは保存される と  Project Navigator プロジェク ト内の該当場所に保存されます。 

Project Navigator から起動されている場合 PlanAhead は ISE 統合モードで開いており、スタンドア

ロンの PlanAhead の機能がすべて使用できるわけではあ り ません。 
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スタンドアロンの PlanAhead の起動

PlanAhead は標準コマンド ライン シェル プロンプ ト  (Windows または Linux) で「planahead」 と入

力する と起動します。Windows の場合、PlanAhead のデスク ト ップ アイコンをダブルク リ ッ クする

と  PlanAhead が起動します。 PlanAhead を使用するには、 まず :

1. 起動画面で [Create a New Project] をク リ ッ ク します。

2. New Project ウ ィザードが開きます。

3. フロアプランのタスクまで進めます。   

スタンドアロンでの PlanAhead 起動方法の詳細は、第 2 章 「プロジェク トの作成および管理」 を参

照して ください。

一般的に、 フロアプラン タスクの入力ファイルは、 合成後の NGC または EDIF ネッ ト リ ス トおよ

び制約を保存するための UCF ファ イルです。 デザイン/タイ ミ ング解析タスクが目標の場合、 配置

済みの NCD ファ イルおよびタイ ミ ング レポートの TWX ファ イルも必要です。 ISE 結果のイン

ポートについては、「ISE 配置およびタイ ミ ング結果を使用したプロジェク トの作成」 を参照してく

ださい。

一般的なフロアプラン タスク

• [Device] ウ ィンド ウへのド ラ ッグアンド ド ロ ップ : デザイン階層表示から、 個々のプリ ミ ティ

ブ ロジッ ク  オブジェク ト  (LUT、 フ リ ップフロ ップ、 BRAM など) を [Device] ウ ィンド ウに

ド ラ ッグします。 デバイスのサイ トにド ラ ッグする前に [Device] ウ ィンド ウで [Create Site
Constraint Mode] ボタンをク リ ッ ク します。 配置プログラムで指定サイ トにオブジェク ト を配

置するよ うに指定する  LOC 制約が UCF ファ イルに書き込まれます。 どんなオブジェク ト  タ
イプでも この方法でフロアプランできます。

メモ : PlanAhead はユーザー制約の LOC を 「固定」 されている とみなします。

• ピン配置およびエリ ア ベースのフロアプラン機能は、PlanAhead の中心的な機能で、 このタイ

プの操作には DRC がフルに使用可能になっています。

• PlanAhead では配置中に、 オブジェク ト を回転、 左右反転、 フ リ ップするオプシ ョ ンは提供さ

れていません。古いデバイス  アーキテクチャにはこ う した機能は便利でしたが、新しいデバイ

ス  ファ ミ リには推奨しません。

• RPM 作成 : [Export IP] コマンドを使用し、 階層のブロ ッ クを別のネッ ト リ ス トにエクスポー

トできます。 ブロ ッ ク内のオブジェク トにも配置制約が設定されている場合、 この制約もエク

スポート されます。 これは Floorplanner の RPM 作成機能と類似していますが、 デザイン階層

の予め定義されているブロ ッ クに制限されているこ とが留意点です。[Export IP] コマンドは非

階層のロジッ クにはサポート されていません。

• 既存の RPM は Floorplanner よ り も  PlanAhead でよ り認識されます。既存 RPM は [Hierarchy]
ウ ィンド ウにリ ス ト され、 [Pblock Properties] でフロアプランまたは確認できます。

• BEL レベルの制約も、オブジェク ト をスライス内の特定サイ トに制約するよ う書き込まれます

(サイ ト内の特定フ リ ップフロ ップなど)。 PlanAhead ではこのビヘイビアを制御するモードが

2 つあり ます。[Create Site Constraint Mode] と  [Create BEL Constraint Mode] です。オブジェ

ク トの配置が配置済みの NCD ファ イルに読み込まれる場合、 Floorplanner とは異なり、 BEL
ロケーシ ョ ンはデフォルトで保持されます。

• フラ ッ ト なネッ ト リ ス トからのデザイン階層の再生成 : Floorplanner には名前別に階層を再生

成する機能があ り ました。 100% 正確ではあ り ませんでしたが、 デザイン解析やエリ ア ベース

のフロアプランには便利な機能でした。PlanAhead ではこの機能は提供されていません。また、

合成中にデザイン階層を保持したり再構築するには合成ツールで正し く設定するよ う推奨しま
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す。 デザイン階層をビジュアルに表示するには、 このほうが信頼性が高く、 オプシ ョ ンも多い

のです。 階層ネッ ト リ ス ト を作成する  XST オプシ ョ ン (-netlist_hierarchy rebuilt) を使用して

ください 

• Floorplanner ではデフォルトで階層が色分けされていましたが、これは PlanAhead では手動で

行います。 [Netlist] ウ ィンド ウで階層ブロ ッ クを選択し、階層に色を追加できます。 [Highlight
Primitives] をク リ ッ ク してから  [Cycle Colors] をク リ ッ ク します。 この色はデザインには保存

されません。

タイ ミ ング解析 - パスのビジュアル表示

Floorplanner は個々のタイ ミ ング パスの配置を表示するために Timing Analyzer を使用していまし

た。このためには、タイ ミ ング レポートでパスを選択し  Timing Analyzer でパスを Floorplanner に
クロスプローブしていました。 その後、 Floorplanner でそのタイ ミ ング パスにあるオブジェク トが

ハイライ ト され、 パスの接続が表示され、 しばしば、 タイ ミ ングの問題はなんらかの配線問題に起

因しているこ とを突き止めるこ とができました。

PlanAhead では、 配置済みの NCD ファ イルと配線後のタイ ミ ング レポート  (TWX) からのデータ

を読み込んで表示するこ とができ、 PlanAhead 環境で同じタスクを簡単に達成できます。 Project
Navigator から起動する場合、 これらのファイルはプロジェク トに含まれていれば PlanAhead に自

動的に渡されます。ISE Timing Analyzer とのクロスプローブは、PlanAhead では現在サポート され

ていません。 

PlanAhead では [Timing Results] ウ ィンド ウにタイ ミ ング パスがリ ス ト されます。個々のパスを選

択する と  [Device] ウ ィンド ウで表示されます。Floorplanner の機能を上回り、PlanAhead ではパス

やパスのグループを回路図表示にクロスプローブさせるこ と もできます。 [Timing Results] でパス

を選択し右ク リ ッ ク して [Schematic] を選択するか、または F4 キーを押します。1 つの環境内でタ

イ ミ ング パスの物理的なデバイス  (フロアプラン) 表示および回路図表示の両方を使用し、タイ ミ ン

グ解析を行う こ とができるのです。タイ ミ ング パフォーマンス向上のためにフロアプラン制約を使

用する場合は、 PlanAhead 環境でその機能が完全統合されています。 詳細は、 第 9 章 「インプ リ メ

ンテーシ ョ ン結果の解析」 を参照して ください。

ISE インプリ メンテーシ ョ ン結果ページの表示

PlanAhead では、ISE でコマンド  ラインを実行した後のインプリ メンテーシ ョ ン結果をインポート

できます。New Project ウ ィザードには、ISE 結果からプロジェク ト を作成するオプシ ョ ンがあ り ま

す。 このウ ィザードで、 ネッ ト リ ス ト 、 制約、 配置、 およびタイ ミ ング データに関するオプシ ョ ン

を設定しながらプロジェク ト を作成します。 ISE 結果をインポートする詳細は、「ISE 配置およびタ

イ ミ ング結果を使用したプロジェク トの作成」 を参照して ください。

まとめ

PlanAhead は、Floorplanner で行われていた共通タスクの主な機能をすべて提供しているため、ツー

ルの移行は非常に簡単です。 Project Navigator から起動した場合は、 PlanAhead にはリ クエス ト し

たプロセスに特化し た機能のみが表示されます。 逆に、 ス タ ン ド ア ロ ンで起動し た場合は、

PlanAhead の全機能をフルに活用できます。 PlanAhead は、 フロアプラン用には非常に簡単で使い

やすいツールである一方で、デザインの解析、最適化、デザイン ク ロージャには非常に高度な機能

を提供しています。 PlanAhead の資料や紹介ビデオは、 http://japan.xilinx.com/planahead をご覧く

ださい。

http://www.xilinx.com/planahead
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PlanAhead™ のプロジェク ト環境では、 RTL デザイン ファ イルを作成および管理できます。 基本

ソース  ファ イル管理機能、 RTL エディ タ、 RTL 回路図ビューア、 RTL DRC、およびリ ソース見積

り機能が PlanAhead に含まれています。 

論理合成およびインプリ メンテーシ ョ ンは PlanAhead を使用して実行できます。合成およびインプ

リ メンテーシ ョ ン実行の詳細は、第 7 章「デザインのインプリ メンテーシ ョ ン」を参照してください。

本章は、 次のセクシ ョ ンで構成されています。

• 「プロジェク ト環境の使用」

• 「ソースのプロジェク トへの追加」

• 「RTL エディ タの使用」

• 「RTL デザインのエラボレートおよび解析」

プロジェク ト環境の使用

プロジェク ト環境は、 RTL ソース  ファ イルのインポート、 開発、 エラボレート、 および RTL デザ

イン解析に使用します。 現在、 Verilog、 VHDL、 およびコア レベルの NGC/NGO ファ イルを

PlanAhead RTL プロジェク ト内でインポートおよび管理できます。 
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[Sources] ウィンドウの使用

[Sources] にはプロジェク トにインポート されている  RTL ソース  ディ レク ト リおよびファイルが

表示されます。 これらのファイルは、 Verilog または VHDL フォーマッ トの RTL ソース、

NGC/NGO コア ネッ ト リ ス ト 、 または XST 合成用の XCF 制約ファイルです。

[Sources] ウ ィンド ウにはソース  ファ イルが表示され、 また、 ソース  ファ イルの種類、 VHDL ライ

ブラ リ、ロケーシ ョ ン、およびファイルがプロジェク トにローカルでインポート されているか リモー

トで参照されているのかが表示されます。

• [Name] : アルファベッ ト順、 または VHDL、 Verilog、 Core、 SDC、 または XNF という ソー

スの種類別に分類

• [Library] : 各ファイルの VHDL ライブラ リ を表示

• [Location] : インポート されたファイル、 または外部参照ファイルの場所を表示

• [Local] : ファ イルがプロジェク トにインポート されているか、 または外部参照されているかを

表示

カテゴリ別のソース表示

ソースはカテゴ リ別に分類するこ とができます。 [Sources] ウ ィンド ウの右上にある メニューから、

プロジェク ト  ソースの表示方法を選択します。 [Group by Type] を選択する と、 ソースは、 VHDL、
Verilog、 コア、SDC、または XNF という種類別に分類されます。 [Group by Source Root] は、 ソー

図 6-1 : [Sources] ウィンドウ
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スのディ レク ト リ または保存場所別に分類します。 [Flat View] は、すべてのソースをアルファベッ

ト順に表示します。 

[Sources] ウィンドウのポップアップ メニュー コマンドの使用 
ソース  ファ イルは、 [Sources] ウ ィンド ウのポップアップ メニュー コマンドを使用して、追加、表

示、変更ができます。共通のポップアップ メニュー コマンドは、「共通のポップアップ メニュー コ
マンドの使用」 で説明します。 こ こでは [Sources] ウ ィンド ウのコマンドを説明します。

• [Source File Properties] : [Source File Properties] ウ ィンド ウが開きます。

• [Enable Source Files] : エラボレートおよび合成でのソース  ファ イルのステータスをアクティ

ブに設定します。ソース  ファ イルのステータスは [Enabled] または [Disabled] に切り替えるこ

とができます。

• [Disable Source Files] : エラボレートおよび合成でのソース  ファ イルのステータスを非アク

ティブに設定します。ソース  ファ イルのステータスは [Enabled] または [Disabled] に切り替え

るこ とができます。ステータスが [Disabled] になっているソース  ファ イルはグレー表示されて

います。

• [Remove from Project] : 選択したソース  ファ イルを PlanAhead プロジェク トから削除します。

また、 最初にファイルがプロジェク トにインポート されている場合は、 PlanAhead プロジェク

トのインス トール ディ レク ト リから もファ イルを削除します。

• [Find in Files] : [Find in Files] ダイアログ ボッ クスが開き、 選択したファイルで検索する文字

列を入力できます。検索結果は、 [Find in Files] ウ ィンド ウに表示されます。詳細は、 「[Find in
Files] コマンドを使用したソース  ファ イルの検索」 を参照して ください。

• [Open file] : 選択したファイルが、 RTL エディ タで開きます。

• [Add Sources] : 選択したソース  ファ イル、ディ レク ト リ 、およびサブディ レク ト リ をすべてプ

ロジェク トにインポート します。

• [Import into Project] : 選択したソース  ファ イルおよびディ レク ト リ をすべてプロジェク ト

ディ レク ト リにコピーします。

• [Create Source] : [New Source File] ダイアログ ボッ クスが開き、 ファ イル名、保存場所、 ライ

ブラ リおよび種類を入力できます。 新しいソース  ファ イルは RTL エディ タで開きます。

• [Set Library] : 選択した RTL ソース  ファ イルのライブラ リ を選択します。

• [Run Elaboration] : RTL 解析およびエラボレーシ ョ ンを実行します。 この機能で、 リ ソース見

積りおよび RTL 回路図操作が可能になり ます。

図 6-2 : ソースの表示方法の定義
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• [Run Synthesi] : [Run Synthesi] ダイアログ ボッ クスが開き、合成実行の作成および起動ができ

ます。

ソース ファイル プロパテ ィの表示

[Sources] ウ ィンド ウで RTL ソース  ファ イルを選択する と、[Source File Properties] ウ ィンド ウに、

保存場所、 ライブラ リ、 サイズ、 タイムスタンプ、 親ファイルが表示されます。

ド ロ ップダウンで新しいライブラ リ を選択し  [Apply] をク リ ッ クする と、 ラ イブラ リ を設定できま

す。

ソースのプロジェク トへの追加

ソース ファイルまたはディ レク ト リの追加

RTL ソースはいつでもプロジェク トに追加できます。 

1. [Add Sources] コマンドを実行する と、 [Add Sources] ダイアログ ボッ クスが表示されます。 

このダイアログ ボッ クスには、 次のボタンがあ り ます。

♦ [Add Files] : ファ イル ブラウザが開き、 プロジェク トに追加する  RTL ファ イルを選択で

きます。 VHDL ラ イブラ リはインポート時に指定できます。

♦ [Add Directories] : ディ レク ト リ  ブラウザが開き、 選択したディ レク ト リおよびサブディ

レク ト リの RTL ソース  ファ イルすべてがプロジェク トに追加されます。 ディ レク ト リ階

層にある、 認識される拡張子を持つファイルはすべてプロジェク トに追加されます。

♦ [Remove] : ソース  ファ イルを削除します。

♦ [Import Source to the Project] : 元のソース  ファ イルを PlanAhead プロジェク トにコピー

し、 ローカルでこれらのファイルを参照します。 

図 6-3 : ソース ファイル プロパティの表示
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ソースを追加する と き、 [Library] フ ィールドをク リ ッ ク し、 ファ イル名を入力できます。

プロジェク ト  ディ レク ト リへのソースのコピー

プロジェク ト管理を柔軟にするため、PlanAhead では元のソース  ファ イルを外部参照したり、プロ

ジェク ト  ディ レク ト リにコピーして参照したりできます。プロジェク ト を移動またはアーカイブす

る可能性がある場合は、 すべてのファイルがプロジェク ト内に保存されるよ うに、 ファ イルをプロ

ジェク トにコピーします。ソース  ファ イルをコピーせずプロジェク ト外部のロケーシ ョ ンに残す場

合、 コピーは 1 つだけのほうが更新 ・ 管理が簡単です。

[Add Sources] ダイアログ ボッ クスで [Import Sources into Project] をク リ ッ クする と ソース  ファ

イルはローカルのプロジェク トにコピーされます。

図 6-4 : ソース ファイルおよびディ レク ト リのプロジェク トへの追加

図 6-5 : [Add Sources] ダイアログ ボックスでのソース ライブラリ変更
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ソース  ファ イルおよびディ レク ト リは、 [Sources] ウ ィンド ウでも選択でき、 [Import into Project]
ポップアップ メニュー コマンドでプロジェク トにコピーできます。

新規ソース ファイルの作成

Verilog または VHDL ソース  ファ イルは、 [Create HDL Source] コマンドで新規作成できます。

[New Source File] ダイアログ ボッ クスが表示されます。

1. 次の情報を入力します。

♦ [Name] : 作成する  HDL ソース  ファ イルの名前を入力します。

♦ [Location] : ファ イルを作成する場所を指定します。

♦ [Type] : Verilog または VHDL を選択します。

♦ [Library] : ファ イルで参照するライブラ リ を選択します。

♦ [File to Create] : ファ イルの場所および名前が表示されます。

2. 完了したら、 [OK] をク リ ッ ク します。

作成したファイルが RTL エディ タで開きます。RTL エディ タには標準 HDL テンプレートがあ り、

構文の定義に便利です。 詳細は、 「RTL エディ タの使用」 を参照してください。

RTL ソース ファイルのアップデート

外部参照のソース ファイル

RTL ソース  ファ イルがプロジェク トにコピーされていない場合、PlanAhead はそのファイルを外部

参照します。ですからデザインがエラボレート されたと き、または RTL ファ イルがアクセスされた

と き、 RTL ソース  ファ イルへの変更はすぐに認識されます。

プロジェク トにコピーされたソース ファイル

プロジェク ト作成中にプロジェク トに追加された RTL ソース  ファ イル、または [Import to Project]
コマンドで追加された RTL ソース  ファ イルは、 PlanAhead 内で管理されるか、 または元のファイ

ルが変更されたらアップデート されます。 

図 6-6 : [New Source File] ダイアログ ボックス
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ソース  ファ イルのアップデート方法にはいくつかの方法があ り ます。

• RTL エディ タを使用し  PlanAhead 内で RTL の変更をすべて行う。

または

• [Remove from Project] ポップアップ メニュー コマンドを使用して変更した RTL ソースをプ

ロジェク トから削除した後、 [Add Sources] で新し くアップデート したソースを追加する。

または

• [Add Sources] をク リ ッ ク しプロジェク トに新し くアップデート したソースを追加し、

[Disable] ポップアップ メニュー コマンドを使用して古いソースを無効にする。

 RTL エディ タの使用

PlanAhead RTL 環境では、強力な RTL エディ タが提供されており、 RTL ソースの作成や変更に使

用できます。RTL エディ タでは、さまざまなタイプの RTL 構文が色分けされて表示されます。複数

のファイルを同時に開く こ とができ、 タブ付きのウ ィンド ウがファイルごとにワークスペースに表

示されます。 タブをク リ ッ ク して、 表示するファイルを切り替えるこ とができます。 

プロジェク ト環境では RTL エディ タ と、[Schematic]、[Elaboration]、[Hierarchy]、および [RTL] ウ ィ

ンド ウ とのクロスプローブが可能です。

ファ イルが変更されて保存されていない場合は、 タブのファイル名の横にアスタ リ スク  (*) が表示

されます。 [Save Project] コマンドを使用しファイルは保存できます。 

図 6-7 : RTL エディ タ
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RTL エディ タのポップアップ メニュー コマンドの使用 
こ こでは RTL エディ タのウ ィンド ウ  コマンドを説明を示します。

• [Cut]、 [Copy]、 [Paste] : 選択したソース  コードをク リ ップボードに切り貼り、 コピーします。

• [Duplicate Selection] : 選択したテキス ト をコピーしカーソル位置に貼り付けます。 

• [Insert Template] : テンプレート  ブラウザが開き、 RTL ファ イルに挿入する構文を選択できま

す。 

• [Find]、 [Replace] : [Find Text] ダイアログ ボッ クスが表示され、検索する文字列を入力できま

す。RTL エディ タで文字列を選択してダイアログ ボッ クスを表示する と、選択した文字列が検

索文字列と して表示されます。 このダイアログ ボッ クスでは上方向にも下方向にも検索でき、

検索結果すべてを一度に置換するこ と もできます。

• [Find Next]、[Find Previous] : [Find Text] ダイアログ ボッ クスで指定した検索条件に基づいて

検索を実行します。

• [Find in Files] : [Find in Files] ダイアログ ボッ クスが開き、 選択したファイルで検索する文字

列を入力できます。 検索結果は、 [Find in Files] ウ ィンド ウに表示されます。 

• [Indent Selection]、 [Unindent Selection]、 [Comment with Line Comment]、 [Comment with
Block Comment] : 選択範囲のインデン ト、 インデン ト解除、行のコ メン ト化、ブロ ッ クのコ メ

ン ト化を実行します。

• [Run Elaboration] : ダイアログ ボッ クスに最上位モジュール名を入力し  [OK] をク リ ッ クする

と、 RTL 解析ルーチンが起動し、 デザインがコンパイルされます。 詳細は、 「RTL デザインの

エラボレートおよび解析」 を参照して ください。

共通のポップアップ メニュー コマンドは、「共通のポップアップ メニュー コマンドの使用」で説明

します。

[Find in Files] コマンドを使用したソース ファイルの検索

[Find] および [Find in Files] ポップアップ メニュー コマンドを使用する と、選択したファイル内で

文字列を検索できます。 

検索文字列にはワイルドカード  (*) を含むすべての文字列を使用できます。 フ ィルタ  オプシ ョ ンで

は検索対象を、プロジェク トのファ イルすべてまたは開いているファ イルすべてに指定できます。検

索方向も指定できます。

http://www.xilinx.com


PlanAhead ユーザー ガイド japan.xilinx.com 167
UG632 (v 11.1.0)

RTL デザインのエラボレートおよび解析

検索結果は [Find in Files] ウ ィンド ウに表示されます。 検索文字列を含むファイルのリ ス トおよび

各ファイルでの検索結果数が表示されます。特定の結果をク リ ッ クする と  RTL エディ タにファイル

が開き、 文字列がハイライ ト表示されます。 

RTL デザインのエラボレートおよび解析

PlanAhead では、RTL ソースのコンパイルおよび解析が迅速に実行できます。エラボレーシ ョ ンは、

合成実行前にコンパイルした RTL デザインを解析するためものですが、合成前に必須のステップで

はあ り ません。 プロジェク トにインポート された RTL ソース  ファ イルはすべて合成中にコンパイ

ルの可否に関らずエラボレート されます。エラボレーシ ョ ン結果はデザインには保存されません。エ

ラボレーシ ョ ンはデザインが合成されフロアプランが作成されるまで、実行および再実行されます。

1. デザイン ソース  ファ イルがプロジェク トにインポート されていれば、次のコマンドのいずれか

を実行してデザインをエラボレートできます。

♦ [Tools] → [Run Elaboration] をク リ ッ ク します。

♦ ポップアップ メニューで、 [Run Elaboration ] コマンドをク リ ッ ク します。

[Run Elaboration] ダイアログ ボッ クスが表示されます。

図 6-8 : [Find in Files] ダイアログ ボックス

図 6-9 : [Find in Files] ウィンドウ
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2. [Run Elaboration] ダイアログ ボッ クスで最上位モジュールを入力します。 

3. オプシ ョ ンで、 参照ボタンをク リ ッ ク し合成オプシ ョ ンを入力します。 

4. [Synthesis Options] ダイアログ ボッ クスで Verilog または VHDL の言語オプシ ョ ンおよび

ループ数を指定します。

5. [OK] をク リ ッ ク します。

エラボレーシ ョ ン結果の表示

[Elaboration] ウ ィンド ウに、RTL ソースファ イル内のエラーを示すコンパイル結果が示されます。 

[Elaboration] ウ ィンド ウで警告またはエラーの行をどれか選択する と、 該当 RTL ソース  ファ イル

が RTL エディ タに読み込まれ、 問題のソース  コードがハイライ ト されます。

エラーのみをフ ィルタ

RTL エラボレーシ ョ ン結果でエラー メ ッセージのみを表示するよ う フ ィルタを使用するこ とがで

きます。

図 6-10 : [Run Elaboration] ダイアログ ボックス

図 6-11 : エラボレーシ ョ ンの合成オプシ ョ ン 

図 6-12 : エラボレーシ ョ ン結果の表示 
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[Hide Warning Messages] ボタンをク リ ッ ク しエラーのみを表示します。 

[RTL] ウィンドウの使用

エラボレーシ ョ ンが正し く終了する と、 [RTL] ウ ィンド ウが開き、RTL ロジッ ク階層が表示されま

す。

RTL ネッ ト リ ス トは、 ツ リーのプラス記号 (+) およびマイナス記号 (-)、 およびウ ィンド ウ特有の

ツールバー アイコンを使用して、 展開または非展開にできます。

[RTL] ウィンドウのポップアップ メニュー コマンドの使用 
共通のポップアップ メニュー コマンドは 「共通のポップアップ メニュー コマンドの使用」 を参照

して ください。 [RTL] ウ ィンド ウのポップアップ メニュー コマンドは次のよ うになっています。 

• [Schematic] : [RTL Schematic] ウ ィンド ウが開きます。

• [Show Hierarchy] : [RTL Hierarchy] ウ ィンド ウが開きます。

• [Show in Source] : HDL エディ タが開き、 選択したロジッ クがハイライ ト表示されます。

図 6-13 : エラボレーシ ョ ン結果 : [Hide Warning Messages] ボタン

図 6-14 : [RTL] ウィンドウ
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[RTL Hierarchy] ウィンドウの使用

RTL ネッ ト リ ス ト階層は、[RTL Hierarchy] ウ ィンド ウで確認できます。このウ ィンド ウは、[Show
Hierarchy] ポップアップ メニュー コマンドを実行する と開きます。

モジュールの大きさを相対的に示したデザイン ロジッ ク階層が、 [RTL Hierarchy] ウ ィンド ウに図

で表示されます。

ほかのウ ィンド ウで選択されたモジュールは、 [RTL Hierarchy] ウ ィンド ウでハイライ ト表示され

ます。

[RTL Hierarchy] ウ ィンド ウの機能は、インスタンスの [Hierarchy] ウ ィンド ウ と似ています。[RTL
Hierarchy] ウ ィンド ウの操作についての詳細は、「[Hierarchy] ウ ィンド ウの使用」を参照してくださ

い。 

モジュールのリソース見積りの表示

[RTL] ウ ィンド ウの機能は、 [Netlist] ウ ィンド ウ と似ています。 ロジッ ク階層のどのレベルも選択

でき、 ハード ウェア リ ソースを解析できます。 [Instance Properties] ウ ィンド ウの [Statistics] タブ

をク リ ッ クする と、選択されたモジュールまたは [RTL] ウ ィンド ウの最上位モジュールに必要なデ

バイス  リ ソースの予測が表示されます。 ロジッ ク  リ ソースは [Arithmetic]、 [Comparators]、
[Multiplexers]、 [Storage] というふうに分類されます。 メモ リおよびプリ ミ ティブの表が表示され、

すべてのメモ リ名、 深さ、 ビッ ト幅、 ポート数などがリ ス ト されます。 マクロ /プリ ミ ティブはビッ

ト幅別に階層に表示されます。

Resource Estimator では、合成実行前の RTL デザインのハード ウェア リ ソースの情報が使用される

ため、 ランタイムが早くな り ます。 現在、 見積りの正確さは平均 +/-15% です。

図 6-15 : [RTL Hierarchy] ウィンドウ
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[Save] をク リ ッ ク し統計レポート を XML (解析用) または XLS 形式で保存します。

RTL 回路図の解析

[RTL] ウ ィンド ウの機能は、[Netlist] ウ ィンド ウ と似ています。ロジッ ク階層のどのレベルでも、選

択して [RTL Schematic] ウ ィンド ウに表示できます。ロジッ クを選択して [RTL Schematic] ウ ィン

ド ウを開くには、 次のコマンドのいずれかを実行します。

• [Schematic] ボタンをク リ ッ ク します。

• [Tools] → [Schematic] をク リ ッ ク します。

• ポップアップ メニューで [Schematic] をク リ ッ ク します。

図 6-16 : RTL リソース見積りの表示
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[RTL Schematic] ウ ィンド ウの機能は、 [Schematic] ウ ィンド ウ と似ています。 [RTL Schematic]
ウ ィンド ウの操作についての詳細は、 「[Schematic] ウ ィンド ウの使用」 を参照してください。

[Find] コマンドを使用したオブジェク トの検索

いったん RTL デザインをエラボレート したら、 いろいろなフ ィルタ機能を備えた [Find] コマンド

を使用しロジッ ク  オブジェク ト を検索できます。詳細は、「[Find]コマンドを使用したオブジェク ト

の検索」 を参照して ください。

RTL DRC の実行

実行する DRC ルールの選択

PlanAhead では RTL デザイン エラボレーシ ョ ンの後に実行できる  DRC がいくつか提供されてい

ます。 これらの DRC は電力消費低減およびパフォーマンスの改善に焦点を当てています。

1. デザインをエラボレート した後、 次のいずれかのコマンドで DRC を実行します。

♦ [Tools] → [Run DRC] をク リ ッ ク します。 

♦ ツールバーの [Run DRC] ボタンをク リ ッ ク します。

図 6-17 : [RTL Schematic] ウィンドウ

図 6-18 : [Run DRC] ボタン
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[Run DRC] ダイアログ ボッ クスが表示されます。 

2. 目的のルールを選択します。

3. [OK] をク リ ッ ク します。

図 6-19 : [Run DRC] ダイアログ ボックス
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DRC エラーの解析 
エラーが検出されたら、 [DRC Results] ウ ィンド ウが表示されます。 

このウ ィンド ウのナビゲーシ ョ ン機能は次のよ うになっています。

• エラーを選択する と  [Violations Properties] ウ ィンド ウにエラーの情報が表示されます。 

• [Violations Properties] ウ ィンド ウのリ ンクをク リ ッ クする と問題のデザイン オブジェク トが

ハイライ ト されます。

• [Show Source] ポップアップ メニュー コマンドを使用する と  RTL ソースの行がハイライ ト さ

れます。

 RTL DRC ルールの定義

次の表に、 デザイン オブジェク ト ごとの DRC ルール、 目的、 重大度を示します。

図 6-20 : DRC エラーのあるオブジェク トの選択
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RTL ルール

表 6-1 : 電力のルール

ルール名 ルールの略称 説明 重要性

Constantly 
enabled 
synchronous 
RAM

RPRC 常にイネーブルの RAM (自動推論またはイン

スタンシエート されたもの) が片方または両方

のポートで検出されました。 この RAM が常に

アクセスされていないかど うかを判断します。

アクセスされていないのであれば、 この RAM
をディ スエーブルにする ロジッ ク を記述する

こ とで、電力消費を大幅に低減できる場合があ

り ます。

警告

Inefficient 
dangling BRAM 
port

RPRM 接続されていない出力ポートのある  RAM が

検出され、 WRITE_MODE が NO_CHANGE
以外の値に設定されています。 未接続の出力

ポート を設定するため (WRITE_MODE を

NO_CHANGE に設定)、RAM 記述を変更する

と、 ブロ ッ ク  RAM の電力消失を最高 10% ま
で節約できる場合があ り ます。

警告

Shallow RAM 
implemented in 
Block RAM

RPRS Virtex®-5 デバイス  : 幅が 18 ビッ ト を超え、深

さが 64 ビッ ト以下の RAM の場合、 RAM が
FIFO と して使用されている場合を除き、 可能

な限り  SelectRAM (分散 RAM と して参照され

る  LUT ベースの RAM) を選択します。 RAM
が FIFO と して使用されている場合は、 クロス

オーバー ポイン トは深さ  32 ビッ ト以下です。

幅が 18 ビッ ト未満のインターフェイスを構築

する場合、 深さが 128 ビッ ト までの場合は

LUT ベースの SelectRAM が適していますが、

一般的に 128 ビッ ト を超える と、専用ブロ ッ ク

RAM のほうが適しています。 

警告

Inefficient 
mapping of 
small multiplier 
in DSP block

RPDS DSP または、 MULT18X18 などのハード乗算

器 IP にマップされている小型乗算器は MSB
にプッシュする必要があ り ます。 残りの LSB
はグランドにマップする必要があ り ます。 これ

でキャ リー伝搬を最小限に抑える こ とができ

ます。 通常のインプリ メンテーシ ョ ン、 特に乗

算器を自動推論する場合、LSB および符号拡張

を使用して MSB をマップします。

警告
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表 6-2 : パフォーマンスのルール

ルール名 ルールの略称 説明 重要性

Inefficient 
library element 
instantiation

RPWL 別の FPGA ファ ミ リに属す 「library_
component_name」 タ イ プ の イ ン ス タ ン ス

「instance name」 が検出されました。 最適なパ

フォーマンスが得られない場合があ り ます。

ISE® で、 このエレ メン トは選択されているフ

フ ァ ミ リ の類似エレ メ ン ト に自動的にマップ

されます。 しかし、 元のエレ メン ト を自動推論

またはインスタンシエートするソース  コード

を変更すれば、 このエレ メン トにある追加また

は拡張機能を利用できます。 これで、 エ リ ア使

用率、パフォーマンスなどが改善される場合が

あ り ます。

警告

Missing pipeline 
register

RPPR レジス タを介していない出力のある乗算器が

検出されました。 レジスタを追加して乗算器ク

ロ ッ クのパフォーマンスを改善できます。 さ ら

に、 これらのレジスタで非同期制御信号の使用

を避けるのがベス トです。

レ ジ ス タ を 介 し て い な い 出 力 の あ る

RAM/ROM が検出されました。 レジスタを追

加して RAM/ROM ク ロ ッ クのパフォーマンス

を改善できます。 さ らに、 これらのレジスタで

非同期制御信号の使用を避けるのがベス ト で

す。

警告

In efficient 
pipeline register

RPIP 乗算ファン クシ ョ ンの入力または出力に非同

期制御信号がある、 レジスタ  <register_name>
(<file_name>:<line_number>) が検出されまし

た。 専用 DSP ハードウェア リ ソースにはプリ

セッ トやク リ アなどの非同期制御信号はあ り

ません。 デバイスを最適に使用できないので、

レジスタは専用ハードウェア リ ソースには

マップされません。

警告

Found Black 
Box instance no 
belonging to 
UNISIM library

RPBX コンポーネン ト またはモジュール

<component/module_name> の記述が合成中

(<file_name:line>) 使用できませんした。

このブラ ッ ク  ボッ クスへのパスおよびブラ ッ

ク  ボッ クスへのパスは最適化されません。合成

ツールの使用率見積りおよびマッ ピングに悪

影響が出る場合があ り ます。

警告
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Found latch in 
design

RPLD <signal_name> (<file_name>:<line_num>) 信
号のラ ッチ記述が検出されました。 ラ ッチは、

インプ リ メ ン ト されたデザインのビヘイビア

が予想どおり のものである こ と を確認するた

めにインプ リ メ ンテーシ ョ ン後のシ ミ ュレー

シ ョ ンが必要なタイ ミ ング パスを解析しずら

く します。 

警告

Found 
combinatorial 
loop in design

RPCL <signal_name>(<file_name>:<line_num>) 
組み合わせループの信号が検出されました。組

み合わせループは、組み合わせロジッ クのコー

ンで、同じコーンへの部分入力と して出力が使

用される と きに生成されます。 ソースからデス

ティネーシ ョ ンまでの組み合わせ遅延合計は、

フ ィードバッ ク  パス遅延分増やす必要があ り

ます。 このタイプのス ト ラ クチャはデザインの

予想ビヘイビアに必要であるか、 または偶然で

ある場合があ り ます。 

警告

ルール名 ルールの略称 説明 重要性
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第 7 章

デザインのインプリ メンテーシ ョ ン

PlanAhead™ は、さまざまなソフ ト ウェア コマンド  オプシ ョ ンや、タイ ミ ングおよび物理制約を設

定して、複数の合成およびインプリ メンテーシ ョ ンを実行するこ とができる環境を提供しています。

複数の合成およびインプリ メンテーシ ョ ンの実行はキューで待機し、順次に、マルチプロセッサ マ
シンでは同時に起動します。 合成実行には、 ザイ リ ンクスの XST 合成ツールが使用されます。

各インプリ メンテーシ ョ ン コマンドのオプシ ョ ン設定のセッ ト をス ト ラテジと して作成し保存で

きます。ス ト ラテジは ISE® ツールを使用し合成やインプリ メンテーシ ョ ンの実行に適用されます。 

進行状況を確認し、ログ レポートでベス ト な合成およびインプリ メンテーシ ョ ン結果を指定してイ

ンポートできます。

本章は、 次のセクシ ョ ンで構成されています。

• 「合成の実行」

• 「インプ リ メンテーシ ョ ンの実行」

• 「実行の監視および設定」

• 「実行の管理」

• 「実行結果のインポート 」

• 「インプ リ メンテーシ ョ ン実行での Bitgen の実行」

• 「ス ト ラテジの作成」

• 「複数の Linux ホス トでの実行起動」

• 「ISE とのインターフェイス」

保存されているス ト ラテジの詳細は、「デフォルト環境の出力」 を、エクスポート されたファイルの

詳細は、 「ISE インプリ メンテーシ ョ ンの出力」 を参照してください。

合成の実行

合成実行の作成および起動

合成実行は同時に作成および起動したり、 または別々に作成、 設定、 起動したりできます。 
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1 つの合成実行の作成および起動

1. 次のコマンドのいずれかを選択します。

♦ ツールバーの [Run Synthesis] ボタンをク リ ッ ク します。

♦ [Tools] → [Run Synthesis] をク リ ッ ク します。

[Run Synthesis] ダイアログ ボッ クスが表示されます。

[Run Synthesis] ダイアログ ボッ クスには、 オプシ ョ ンがいくつかあ り ます。

• [Run Name] : 合成実行の名前を入力します。 またはデフォルト名をそのまま使用します。

• [Description] : 合成実行の説明を入力します。

• [Top Module Name] : デザインの RTL モジュール名を入力するか、デフォルト名をそのまま使

用します。

• [Synthesis Options] : 参照ボタンをク リ ッ ク し  [Synthesis Options] ダイアログ ボッ クスを開き

ます。 こ こでオプシ ョ ンの最上位 VHDL ライブラ リ名、 Verilog または VHDL オプシ ョ ン、

ループ数を入力します。

• [Strategy] : 実行に適用する合成ス ト ラテジを選択します。 XST バージ ョ ン 10 または 11 のス

ト ラテジを選択できます。 詳細は、 「ス ト ラテジの作成」 を参照して ください。

図 7-1 : [Run Synthesis] ボタン

図 7-2 : [Run Synthesis] ダイアログ ボックス
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• [Part] : パーツを選択するか、 またはデフォルトのパーツをそのまま使用します。

• [Launch Options] : 追加の起動オプシ ョ ンを選択します。

[Specify Launch Options] ダイアログ ボッ クスで次のオプシ ョ ンを設定できます。

♦ [Launch Directory] : 合成実行データを作成および保存する場所を指定します。 

メモ : プロジェク ト  ファ イルには絶対パスが記述されるので、プロジェク ト  ディ レク ト リ

外のデフォルトでない場所を指定する と不便になり ます。

♦ [Launch Runs on Local Host] : ローカル コンピュータのプロセッサで実行を起動するには

このオプシ ョ ンを設定します。

- [Number of Jobs] : 実行に使用するローカル プロセッサの数を定義します。 このオプ

シ ョ ンは複数の実行を同時に起動する場合にのみ使用します。 個々の実行は各プロ

セッサで起動されます。マルチスレッ ド  プロセッサはこのオプシ ョ ンでは使用されま

せん。

♦ [Launch Runs on Remote Hosts] : Linux のみ。リモート  ホス ト を使用して 1 つのジ ョブま

たは複数のジ ョブを実行する場合、 このオプシ ョ ンを選択します。 

図 7-3 : 合成スト ラテジの選択

図 7-4 : 合成実行起動のオプシ ョ ン 
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- [Configure Hosts] : リモート  ホス ト を設定する場合にこのオプシ ョ ンを設定します。

詳細は、 「複数の Linux ホス トでの実行起動」 を参照してください。

♦ [Generate scripts only] : 実行ディ レク ト リおよび実行スク リプ ト をエクスポート ・ 作成す

る場合に設定するオプシ ョ ンです。 PlanAhead からは実行を起動しません。 スク リプ トは

PlanAhead 環境外で後で実行できます。

♦ [Do not launch the run] : [Design Runs] ウ ィンド ウで実行を作成する場合にこのオプシ ョ

ンを選択します。 データのエクスポートや実行の起動はしません。

2. [OK] をク リ ッ クする と、 選択したオプシ ョ ンを使用して実行が作成されます。

複数の合成実行の作成

PlanAhead では、 複数の合成実行を同時に作成 ・起動するこ とができます。 最善の結果が得られる

よ う、 さまざまな合成オプシ ョ ンやツールを試すこ とができます。

1. 複数の合成実行を作成するには [Tools] → [Run Multiple Strategies] をク リ ッ ク します。

2. プロンプ トが表示されたら、[Run Multiple Strategies] ダイアログ ボッ クスで [Synthesis] を選

択します。

[Set Up Synthesis Runs] には次のオプシ ョ ンがあ り ます。 

• [Top Module Name] : デザインの RTL モジュール名を入力するか、デフォルト名をそのまま使

用します。

• [Synthesis Options] : 参照ボタンをク リ ッ ク し  [Synthesis Options] ダイアログ ボッ クスを開き

ます。 こ こでオプシ ョ ンの最上位 VHDL ライブラ リ名、 Verilog または VHDL オプシ ョ ン、

ループ数を入力します。

• [Part] : パーツを選択するか、 またはデフォルトのパーツをそのまま使用します。

図 7-5 : 複数の合成実行の設定
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3. [Next] をク リ ッ ク し  [Choose Synthesis Strategies] に進みます。 

4. 最初の実行に対し  [Name] および [Strategy] を選択します。

5. [More] ボタンをク リ ッ ク し、 ほかの実行を追加します。

6. 追加実行に対しても名前および合成ス ト ラテジを入力します。

7. [Next] をク リ ッ ク し  [Launch Options] に進みます。 [Launch Options] の詳細は、 「1 つの合成

実行の作成および起動」 を参照して ください。

8. [OK] をク リ ッ クする と、 定義した実行が作成され、 指定の起動オプシ ョ ンが実行されます。

合成に関するヒン ト

合成方法については、次の項目を参考にしてください。ISE 合成結果の最適化については、『合成/シ
ミ ュレーシ ョ ン デザイン ガイ ド』 を参照してください。

1. できる限り、ク リ ティカル タイ ミ ング パスが個々のモジュールに接続されるよ う、RTL レベル

でデザインをパーティシ ョ ンします。多数の階層モジュールにまたがるク リ ティカル パスはフ

ロアプランしにく くな り ます。 

2. すべてのモジュールの出力にレジスタを付けてください。これでク リ ティカル パスに関連する

モジュールの数を制限するこ とができます。 

3. 1 つの大型階層ブロッ クにあるロング パスはフロアプランしにく くな り ます。RTL で大型階層

ブロッ クを分割するよ う考慮して ください。

4. デザインの変更頻度が高い場合は、 インク リ メンタル合成を考慮してください。 インク リ メン

タル アプローチでは、個々のブロッ クを別々に合成したり、合成属性 (SYN_HIER=HARD) を
使用して階層を保持するこ とができます。階層保持は、 インク リ メンタル フローに役立ちます

が、 グローバル最適化が階層全体で行われないため、 パフォーマンスが低下する場合があ り ま

す。 インク リ メンタル RTL 合成を試す前に、 この ト レードオフを考慮して ください。

図 7-6 : 合成スト ラテジの選択
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5. 階層の再構築のため、 または合成ネッ ト リ ス トでの階層保持のため、 合成エンジンを制約しま

す。 フラ ッ ト なネッ ト リ ス トは合成面から見て最適かもしれませんが、 確実なフロアプランや

配置制約を行うのが難し くな り ます。 合成ツールのオプシ ョ ンの使用を考慮してください。 た

とえば、階層の再構築には、 XST コマンド  ライン オプシ ョ ン -netlist_hierarchy = rebuilt を使

用します。 これは v9.2 以降の XST で使用できるオプシ ョ ンです。

インプリ メンテーシ ョ ンの実行

PlanAhead では、 ngdbuild、 map、 par、 trce、 および xdl の一連の ISE コマンド  シーケンスの実行

は 「インプリ メンテーシ ョ ン」 と呼ばれます。 bitgen コマンドは、 十分なインプリ メンテーシ ョ ン

結果を得た後に PlanAhead 環境から別に実行するこ とができます。PlanAhead では結果表示および

解析を行う ためのこれらのコマンドが自動的に実行されます。 実行データはすべてプロジェ ク ト

ディ レク ト リに保存されます。

インプリ メンテーシ ョ ン実行の作成および起動

インプリ メンテーシ ョ ン実行は同時に作成および起動したり、 または別々に作成、 設定、 起動した

りできます。 

1 つのインプリ メンテーシ ョ ン実行の作成および起動

1. 次のコマンドのいずれかを選択します。

♦ ツールバーの [Run Implementation] ボタンをク リ ッ ク します。

♦ [Tools] → [Run Implementation] をク リ ッ ク します。

[Run Implementation] ダイアログ ボッ クスが表示されます。

[Run Implementation] ダイアログ ボッ クスには、 オプシ ョ ンがいくつかあ り ます。

• [Run Name] : インプリ メンテーシ ョ ン実行の名前を入力します。またはデフォルト名をそのま

ま使用します。

図 7-7 : [Run Implementation] ボタン

図 7-8 : インプリ メンテーシ ョ ン実行
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• [Description] : インプリ メンテーシ ョ ン実行の説明を入力します。

• [Synthesized Netlist] : インプリ メン トする合成実行の名前を選択します。

• [Floorplan] : インプリ メン トするフロアプランの名前を入力します。

• [Part] : パーツを選択するか、 またはデフォルトのパーツをそのまま使用します。

• [Constraints] : 最上位 UCF 制約ファイルを選択します。フロアプランが選択されている場合フ

ロアプランからの制約が使用されるため、 このフ ィールドは使用できません。

• [Strategy] : 実行に適用するインプ リ メンテーシ ョ ン ス ト ラテジを選択します。 詳細は、 「ス ト

ラテジの作成」 を参照して ください。

• [Launch Options] : 追加の起動オプシ ョ ンを選択します。

[Specify Launch Options] ダイアログ ボッ クスで次のオプシ ョ ンを設定できます。

図 7-9 : インプリ メンテーシ ョ ン スト ラテジの選択 

図 7-10 : インプリ メンテーシ ョ ン実行起動のオプシ ョ ン
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♦ [Launch Directory] : インプリ メンテーシ ョ ン実行データを作成および保存する場所を指

定します。 

メモ : プロジェク ト  ファ イルには絶対パスが記述されるので、プロジェク ト  ディ レク ト リ

外のデフォルトでない場所を指定する と不便になり ます。

♦ [Launch Runs on Local Host] : ローカル コンピュータのプロセッサで実行を起動するには

このオプシ ョ ンを設定します。

- [Number of Jobs] : 実行に使用するローカル プロセッサの数を定義します。 このオプ

シ ョ ンは複数の実行を同時に起動する場合にのみ使用します。 個々の実行は各プロ

セッサで起動されます。マルチスレッ ド  プロセッサはこのオプシ ョ ンでは使用されま

せん。

♦ [Launch Runs on Remote Hosts] : Linux のみ。リモート  ホス ト を使用して 1 つのジ ョブま

たは複数のジ ョブを実行する場合、 このオプシ ョ ンを選択します。 

- [Configure Hosts] : リモート  ホス ト を設定する場合にこのオプシ ョ ンを設定します。

詳細は、 「複数の Linux ホス トでの実行起動」 を参照してください。

♦ [Generate scripts only] : 実行ディ レク ト リおよび実行スク リプ ト をエクスポート ・ 作成す

る場合に設定するオプシ ョ ンです。 PlanAhead からは実行を起動しません。 スク リプ トは

PlanAhead 環境外で後で実行できます。 

♦ [Do not launch the run] : [Design Runs] ウ ィンド ウで実行を作成する場合にこのオプシ ョ

ンを選択します。 データのエクスポートや実行の起動はしません。

2. [OK] をク リ ッ クする と、 選択したオプシ ョ ンを使用して実行が作成されます。
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複数のインプリ メンテーシ ョ ン実行の作成

PlanAhead では、 複数のインプリ メンテーシ ョ ン実行を同時に作成 ・起動するこ とができます。 最

善の結果が得られるよ う、 さまざまなインプリ メンテーシ ョ ン オプシ ョ ンを試すこ とができます。

1. 複数のインプリ メンテーシ ョ ン実行を作成するには [Tools] → [Run Multiple Strategies] をク

リ ッ ク します。

2. [Run Multiple Strategies] ダイアログ ボッ クスで [Implementation] を選択します。 

[Set Up Implementation Runs] には次のオプシ ョ ンがあ り ます。 

♦ [Synthesized Netlist] : インプリ メン トする合成実行の名前を選択します。

♦ [Floorplan] : インプリ メン トするフロアプランの名前を入力します。

♦ [Part] : パーツを選択するか、 またはデフォルトのパーツをそのまま使用します。

♦ [Constraints] : 最上位 UCF 制約ファイルを選択します。フロアプランが選択されている場

合フロアプランからの制約が使用されるため、 このフ ィールドは使用できません。

図 7-11 : 複数のインプリ メンテーシ ョ ン実行の設定
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3. [Next] をク リ ッ ク し  [Choose Implementation Strategies] に進みます。  

4. 最初のインプリ メンテーシ ョ ン実行に対し名前を入力し、 ス ト ラテジを選択します。

5. [More] ボタンをク リ ッ ク し、 ほかの実行を追加します。

6. 追加実行に対しても名前およびインプリ メンテーシ ョ ン ス ト ラテジを入力します。

7. [Next] をク リ ッ ク し  [Launch Options] に進みます。 [Launch Options] の詳細は、 「1 つのイン

プリ メンテーシ ョ ン実行の作成および起動」 を参照して ください。

8. [OK] をク リ ッ クする と、 定義した実行が作成され、 指定の起動オプシ ョ ンが実行されます。

Pblock のインプリ メン ト  
PlanAhead の特色は、Pblock を個別にインプリ メン トできるこ とです。ISE ソフ ト ウェアの -u オプ

シ ョ ンを使用する と  ISE インプリ メンテーシ ョ ンで使用するモジュールを分離できるため、次に説

明するよ うに、 最大のデザイン パフォーマンスを実現する際に多くの利点があ り ます。

スタンドアロンの Pblock をインプリ メン トする と、ISE でそのロジッ クの最高のパフォーマンスが

得られます。これは、ベス ト  ケースの場合のモジュールのパフォーマンスを知る指標とな り ます。ス

タンドアロンの Pblock でタイ ミ ング要件が満たされない場合は、デザイン全体でタイ ミ ングを満た

すのが非常に困難な可能性があ り ます。 

パフォーマンスの問題が発生しやすいデザインのロジッ クは、 その部分のロジッ クをインプ リ メン

ト して固定してから、 最上位のデザインをインプ リ メ ン ト します。 配置が固定されている と、 パ

フォーマンスを非常に維持しやすくな り ます。 最上位インプリ メンテーシ ョ ンでは、 インターコネ

ク トで同じ配線経路が使用できない場合があ り ますが、 その場合は配線遅延が変動します。 ロジッ

ク固定の手法については、 「配置 LOC 制約」 を参照して ください。

デザインの実行は個々の Pblock に対し作成および設定でき、 PlanAhead でフロアプランをインプ

リ メン トする際に使用されるのと同じ監視オプシ ョ ンを使用できます。1 つまたは複数の Pblock に
対しインプリ メンテーシ ョ ン実行を作成できます。

図 7-12 : [Run Multiple Strategies] ダイアログ ボックス
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メモ : Pblock を ISE でインプリ メン トする前に、次のザイ リ ンクス環境変数を設定し、Pblock でロ

ジッ クが自動削除されないよ うにします。

XIL_MAP_NOCLIP_ON_ALL_SIGS_U  (値は 1 に設定)

選択した Pblock の実行作成

[Run Implementation] コマンドは予め選択した Pblock に対し実行します。 

選択した Pblock に ISE コマンドを実行するには、 次の手順に従います。

1. PlanAhead で Pblock を選択します。

2. 次のコマンドのいずれかを選択します。

♦ [Tools] → [Run Implementation] をク リ ッ ク します。

♦ [Run Implementation] ボタンをク リ ッ ク します。

[Run Implementation] ダイアログ ボッ クスの [Pblock ] に選択した Pblock が表示されます。

3. [Run Implementation] コマンドをク リ ッ ク した後に Pblock を選択するこ と もできます。その場

合は、 [Pblock] フ ィールドのド ロ ップダウン メニューから  Pblock を選択します。 

4. 「インプ リ メンテーシ ョ ンの実行」 で説明したよ うに、 実行オプシ ョ ンを選択します。

5. [OK] をク リ ッ ク します。 

[Design Runs] ウ ィンド ウに Pblock の実行が表示され、ほかのインプリ メンテーシ ョ ン実行と同様

にこ こで監視 ・ 管理できます。

図 7-13 : [Run Implementation] ボタン

図 7-14 : Pblock の [Run Implementation] ダイアログ ボックス
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実行の監視および設定

[Design Runs] ウィンドウの使用

実行が作成、 起動、 またはインポート される と、 そのステータスが [Design Runs] ウ ィンド ウに表

示されます。 [Design Runs] ウ ィンド ウを開くには [Tools] → [Design Runs] をク リ ッ ク します。 

このウ ィンド ウでは、定義された実行のステータスや結果が表示され、実行の変更、インポート、起

動、 管理のためのコマンドを実行するこ とができます。 また、 合成およびインプリ メンテーシ ョ ン

実行の管理とレポートにも このウ ィンド ウを使用します。

実行中は左側に緑の矢印がこのウ ィンド ウの左側に表示されます。 完了した実行は青色のチェッ ク

マークに変わり ます。 コマンド実行中は実行の詳細が表示されます。 起動中の実行に影響を及ぼす

こ とな く  PlanAhead を閉じるこ とができます。プロジェク ト を次に開いたと きに、アップデート さ

れた最新ステータスが [Design Runs] の表に表示されます。

表には次の情報が表示されます。

• [Name] : 実行名を表示します。

• [Part] : 実行に選択されているパーツを表示します。

• [Constraints] : 制約ファイル名またはフロアプラン名を表示します。

• [Strategy] : 実行に選択されているス ト ラテジを表示します。 アスタ リ スク  (*) の付いているス

ト ラテジは、 コマンド  オプシ ョ ン値が [Properties] ウ ィンド ウの [Options] で上書きされたこ

とを示します。

• [Status] : 実行ステータスまたは現在実行しているコマンドを表示します。 

• [Progress] : ngdbuild から  xdl までの ISE コマンド  シーケンス全体の進行状況を示します。 手

順によっては時間がかかるこ とがあ り ます。

• [Start] : ISE がデザインを処理し始めた時間です。 

• [Elapsed] : ISE の全コマンドのデザインの処理の経過時間の合計です。

• [Uti (%)] : 合成実行のみに表示されます。 実行の LUT 使用率を示します。

• [Fmax] : 合成実行のみに表示されます。XST 合成レポートからのデータで、実行の予想クロ ッ

ク周波数です。 

• [Timing Score] : インプリ メンテーシ ョ ン実行のみに表示されます。進行中または完了した実行

の現在のタイ ミ ング スコアです。

• [Unrouted] : インプリ メンテーシ ョ ン実行のみに表示されます。 進行中または完了した実行の

未配線のネッ トの数です。

• [Description] : 実行の説明です。この説明は、ス ト ラテジを実行に適用した時点で設定されたも

のですが、 後で修正できます。

図 7-15 : [Design Runs] ウィンドウ
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この表は実行中にダイナミ ッ クに更新されます。 PlanAhead で生成されたスク リプ ト を使用し、

PlanAhead 外で起動される実行に関しては、 PlanAhead を起動した時点でこの表示が更新されま

す。

[Design Runs] ウィンドウのポップアップ メニュー コマンドの使用

[Design Runs] ウ ィンド ウのポップアップ メニュー コマンドは次のとおりです。

• [Synthesis/Implementation Run Properties] : 実行の [Properties] ウ ィンド ウが表示されます。詳

細は、 「実行プロパティの表示および修正」 を参照して ください。

• [Delete] : 選択した実行を削除します。実行を削除する前に、削除を確認する メ ッセージが表示

されます。

• [Apply Strategy] : 新しい実行ス ト ラテジを選択するためのダイアログ ボッ クスが表示されま

す。 このコマンドは、 実行を起動する前にのみ使用できます。

• [Save as Strategy] : ス ト ラテジに対する変更内容を新しいス ト ラテジ ファ イルに保存します。

• [Edit Strategies] : [Tools] → [Options] → [Strategies] をク リ ッ ク して開くダイアログ ボッ クス

が開き、 ス ト ラテジを編集または作成します。

• [Launch Runs] : [Launch Runs] ダイアログ ボッ クスを開き、 選択した実行を起動します。

• [Reset Runs] : [Reset Runs] ダイアログ ボッ クスが開き、前回の実行結果を削除し、実行ステー

タスを [Not Started] に戻します。

• [Import Run] : 合成実行のネッ ト リ ス ト または ISE からのインプリ メンテーシ ョ ン結果を

PlanAhead 環境にインポート します。 [Design Runs] ウ ィンド ウには読み込まれたアクティブ

な実行が太字で表示されます。

• [Run Multiple Strategies] : [Run Multiple Strategies] ダイアログ ボッ クスが開き、 複数の実行

を作成および起動できます。詳細は、「複数の合成実行の作成」または「複数のインプリ メンテー

シ ョ ン実行の作成」 を参照して ください。

• [Run Bitgen] : [Run Bitgen] ダイアログ ボッ クスを開き、 ビッ ト ス ト リームを作成します。 こ

のコマンドは、 完了したインプリ メンテーシ ョ ン実行でのみ使用できます。

• [Export to Spreadsheet] : [Design Runs] の表全体を含んだマイクロ ソフ トの Excel 形式のファ

イルを作成します。
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実行プロパティの表示および修正

各実行には、 表示または変更できる実行プロパティがいろいろあ り ます。 実行プロパティは実行起

動前にしか変更できないものがほとんどです。 実行を起動したら、 [Reset Run] ポップアップ メ

ニュー コマンドを使用してプロパティを表示および編集できます。

実行の一般プロパティの表示

実行を選択し、 [Properties] ウ ィンド ウで [General] タブをク リ ッ ク します。

[Synthesis Run Properties ] では次の情報を表示または編集できます。

• [Name] : 実行名を設定します。 

• [Strategy] : 実行ス ト ラテジを選択します。

• [Description] : 実行の説明を入力します。

• [Status] : 実行ステータスが表示されます。

[Implementation Run Properties ] では次の情報を表示または編集できます。

図 7-16 : 合成の一般プロパティの設定

図 7-17 : インプリ メンテーシ ョ ンの一般プロパティの設定
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• [Name] : 実行名を設定します。 

• [Strategy] : 実行ス ト ラテジを選択します。

• [Description] : 実行の説明を入力します。

• [Status] : 実行ステータスが表示されます。

• [Parent] : 合成ネッ ト リ ス ト またはインプリ メン ト されている  Pblock が表示されます。

• [Run Directory] : 実行データのある、 または実行データが作成されるディ レク ト リが表示され

ます。

実行スト ラテジ オプシ ョ ンの表示

ス ト ラテジで定義されているコマンド  ライン オプシ ョ ンは実行の [Properties] ウ ィンド ウの

[Options] タブをク リ ッ クする と、 表示および変更できます。 

実行を選択し、 [Properties] ウ ィンド ウで [Options] タブをク リ ッ ク します。

すべてのコマンド  ライン オプシ ョ ンおよび予め設定されている値が表示されます。 コマンド  オプ

シ ョ ンの説明はオプシ ョ ンを選択する と表示できます。 

図 7-18 : 合成スト ラテジ オプシ ョ ンの設定
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オプシ ョ ンを選択する と、 右側にあるプルダウン メニューで使用可能な値を表示できます。

スト ラテジに設定された ISE コマンド  オプシ ョ ンの上書き

[Options] タブでス ト ラテジのオプシ ョ ンを変更するこ とができます。 

ウ ィンド ウのポップアップ コマンドを使用し、 ス ト ラテジを上書きし、新しいユーザー定義のス ト

ラテジと して保存 (または名前を変更して保存) するこ とができます。表示されていないコマンド  オ
プシ ョ ンは、 コマンドの下にある  [More Options] フ ィールドを使用して表示するこ とができます。 

[Apply] をク リ ッ クする と、 変更がすべて適用されます。

値を変更した場合は、オプシ ョ ンの横にアスタ リ スク  (*) が表示され、デフォルトのス ト ラテジの値

が変更されたこ とを確認できます。[Design Runs] ウ ィンド ウの [Strategy] にも同様にアスタ リ スク

が表示されます。 

次のセクシ ョ ンで説明するよ うに、ス ト ラテジが開始する と、オプシ ョ ンは編集できなくな り ます。

オプシ ョ ンを編集するには実行を リセッ トする必要があ り ます。詳細は、「実行のリセッ ト 」 を参照

して ください。

図 7-19 : インプリ メンテーシ ョ ン スト ラテジ オプシ ョ ンの設定

図 7-20 : 実行の [Properties] ウィンドウ :[Options] タブ
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実行ステータスの監視

実行を選択し実行の [Properties] ウ ィンド ウの [Monitor] タブをク リ ッ クする と、 進行中の実行ス

テータスを確認できます。 コマンド  ラインに表示されるのと同じ標準コマンド  ステータス  ログが

こ こに表示されます。

[Monitor] タブは、 コマンド実行中は常に更新されます。 スクロール バーを使用して、 コマンド  ロ
グの履歴を表示できます。ログ出力を停止するには [Automatically update the contents of this view]
ボタンをク リ ッ ク します。 コマンド実行中はこのボタンをク リ ッ ク したほうが結果確認しやすくな

り ます。

レポート  ファイルの表示

ISE ツールで生成されたレポート  ファ イルは PlanAhead で表示できます。 実行を選択し、 実行の

[Properties] ウ ィンド ウの [Reports] タブをク リ ッ クする と、使用可能なレポート  ファ イルのリ ス ト

を表示できます。 

図 7-21 : 実行ステータスの監視

図 7-22 : 表示するレポート  ファイルの選択
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ワークスペースに選択したレポート  ファ イルが表示されます。

スクロール バーを使用して、レポート  ファ イルを表示します。特定の文字列を検索するにはツール

バーの [Find] または [Find in Files] ボタンをク リ ッ ク します。 ファ イルの冒頭または終わりに移動

するには [Go to the beginning] または [Go to the End] ボタンをク リ ッ ク します。

実行の管理

既存の実行の起動

[Design Runs] ウ ィンド ウで既存の実行を起動するには [Launch Runs] コマンドを使用します。完了

した実行を含め、 どのステートにある実行でも このコマンドは実行できます。 [Launch Selected
Runs] ダイアログ ボッ クスが開き、 起動オプシ ョ ンを設定します。

1. [Design Runs] ウ ィンド ウで最低 1 つの実行を選択します。Shift キーまたは Ctrl キーを押しな

がら ク リ ッ クする と、 複数の実行を選択できます。

2. 次のコマンドのいずれかを選択します。

図 7-23 : レポート  ファイルの表示
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♦ [Design Run] ウ ィンド ウのツールバーの [Launch selected runs] ボタンをク リ ッ ク しま

す。

♦ [Launch Runs] ポップアップ メニュー コマンドをク リ ッ ク します。

[Launch Selected Runs] ダイアログ ボッ クスが表示されます。

[Launch Selected Runs] ダイアログ ボッ クスでは次のオプシ ョ ンを設定できます。

♦ [Launch Directory] : 合成実行データを作成および保存する場所を指定します。 

メモ : プロジェク ト  ファ イルには絶対パスが記述されるので、プロジェク ト  ディ レク ト リ

外のデフォルトでない場所を指定する と不便になり ます。

♦ [Placement Export] : ユーザー定義で 「固定」 配置になっているもの、または ISE インプ リ

メンテーシ ョ ン実行からのすべての 「固定」および「未固定」の配置制約に対し、配置 LOC
制約を指定します。

♦ [Launch Runs on Local Host] : ローカル コンピュータのプロセッサで実行を起動するには

このオプシ ョ ンを設定します。

- [Number of Jobs] : 実行に使用するローカル プロセッサの数を定義します。 このオプ

シ ョ ンは複数の実行を同時に起動する場合にのみ使用します。 個々の実行は各プロ

セッサで起動されます。マルチスレッ ド  プロセッサはこのオプシ ョ ンでは使用されま

せん。

♦ [Launch Runs on Remote Hosts] : Linux のみ。リモート  ホス ト を使用して 1 つのジ ョブま

たは複数のジ ョブを実行する場合、 このオプシ ョ ンを選択します。 

- [Configure Hosts] : リモート  ホス ト を設定する場合にこのオプシ ョ ンを設定します。

詳細は、 「複数の Linux ホス トでの実行起動」 を参照してください。

図 7-24 : [Launch selected runs] ボタン

図 7-25 : [Launch Selected Runs] ダイアログ ボックス
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♦ [Generate scripts only] : 実行ディ レク ト リおよび実行スク リプ ト をエクスポート ・ 作成す

る場合に設定するオプシ ョ ンです。 PlanAhead からは実行を起動しません。 スク リプ トは

PlanAhead 環境外で後で実行できます。

3. [OK] をク リ ッ クする と、 選択したオプシ ョ ンを使用して実行が作成されます。

4. 選択した実行が [Not Started] 以外のステータスになっている場合、起動前に実行を リセッ トす

るかど うかの確認メ ッセージが表示されます。

実行のリセッ ト

選択した実行の結果を削除するには [Reset Runs] コマンドを使用します。ディ スクから実行データ

を削除するかど うかの確認メ ッセージが表示されます。 できる限りディ スクから実行データを削除

するよ うにして ください。 実行ステータスが [Not Started] に戻り ます。

1. [Design Runs] ウ ィンド ウで実行を少なく と も  1 つ選択します。Shift キーまたは Ctrl キーを押

しながら ク リ ッ クする と、 複数の実行を選択できます。

2. [Reset Runs] ポップアップ メニュー コマンドをク リ ッ ク します。

[Reset Runs] ダイアログ ボッ クスが表示され、選択した実行のインプリ メンテーシ ョ ン データ

をすべてディ スクから削除するかど うかを確認します。

3. [Reset] をク リ ッ クする と、 リセッ トが実行されます。

ISE プロセスが実行またはキューの途中であれば、 停止するよ うにという メ ッセージが表示さ

れます。

4. [Yes] をク リ ッ クする と、 リセッ トが実行されます。

ステータスがリセッ トにな り ます。

実行の削除

[Design Runs] ウ ィンド ウから選択した実行を削除し、 ディ スクからその関連データを削除するに

は [Delete] コマンドを使用します。 削除を確認する メ ッセージが表示されます。

1. [Design Runs] ウ ィンド ウで実行を少なく と も  1 つ選択します。Shift キーまたは Ctrl キーを押

しながら ク リ ッ クする と、 複数の実行を選択できます。

2. 次のコマンドのいずれかを選択します。

♦ ツールバーの [Delete] ボタンをク リ ッ ク します。

図 7-26 : 実行のリセッ ト

図 7-27 : [Delete] ボタン
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♦ [Design Runs] ウ ィンド ウの [Delete] ポップアップ メニュー コマンドをク リ ッ ク します。

♦ [Edit] → [Delete] をク リ ッ ク します。

♦ Delete キーを押します。 

実行結果のインポート

合成実行結果のインポート

PlanAhead では、解析、 I/O ピン配置、 フロアプラン、 インプリ メンテーシ ョ ンのために、合成実行

の結果をインポートするこ とができます。 インポートする と き、 論理ネッ ト リ ス ト確認のためネッ

ト リ ス ト をインポートするか、 フロアプランを作成するかを選択します。 フロアプランを作成する

と、 デザイン解析、 フロアプラン、 インプリ メンテーシ ョ ンを実行できます。 

合成実行が完了したら、 ネッ ト リ ス ト を次のよ うにインポートするこ とができます。

1. [Design Runs] ウ ィンド ウで合成実行を選択します。

2. 次のコマンドのいずれかを選択します。

♦ [Design Runs] ウ ィンド ウのツールバーにある  [Import Run] ボタンをク リ ッ ク します。

• [Design Runs] ウ ィンド ウの [Import Run] ポップアップ メニュー コマンドをク リ ッ ク します。

メモ : [Design Runs] ウ ィンド ウで完了した実行をダブルク リ ッ クする と、[Import Run] ダイアログ

ボッ クスが開きます。

Import Synthesis Results ウ ィザードが開きます。

図 7-28 : [Import Run] ボタン

図 7-29 : Import Synthesis Results ウィザード
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[Create Floorplan after importing] がデフォルトで選択されています。フロアプランを作成する必要

がない場合はこのチェッ クボッ クスをオフにします。

合成結果を使用したフロアプランの作成

Import Synthesis Results ウ ィザードの [Choose a Part and a Floorplan Name] ページが開きます。 

3. このページでは次のオプシ ョ ンを設定します。

♦ [Choose Part] : 参照ボタンをク リ ッ ク してデバイスを選択します。

♦ [Floorplan name] : フロアプランの名前を入力します。

4. [Next] をク リ ッ ク し次に進みます。

[Import Constraints] ページが表示されます。

図 7-30 : Import Synthesis Results ウィザード  : [Choose Part and Floorplan Name] ページ
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5. [Add] ボタンをク リ ッ ク して、 インポートする、最上位の UCF または NCF 制約ファイルを選

択します。 これらのファイルのインポート順は、 [Up] ボタンおよび [Down] ボタンを使用して

変更できます。 [Remove] ボタンをク リ ッ クする と、 ファ イルがリ ス トから削除されます。

モジュール レベルの制約ファイルが使用されている場合は、 こ こに含めないでください。 モ

ジュール レベルの制約のインポートの詳細は、 「モジュール レベルの制約のインポート 」 を参

照して ください。

6. [Next] をク リ ッ ク し次に進みます。

UCF ファ イルが PlanAhead にインポート されます。 この動作には多少時間がかかる場合があ

り ます。 

サマリ  ページが表示されます。

7. [Finish] をク リ ッ ク します。

PlanAhead に、 インポート された合成実行結果が表示され、 フロアプラン作成のオプシ ョ ンを選択

した場合は新しいフロアプランが表示されます。

インプリ メンテーシ ョ ン実行結果のインポート

インプリ メンテーシ ョ ン実行結果は、解析またはフロアプランのために PlanAhead にインポートす

るこ とができます。配置は 「未固定」 の LOC 制約と してインポート され表示されます。 ISE インプ

リ メンテーシ ョ ン ツールでさまざまなロジッ ク  オブジェク トがどこに配置されたかをビジュアル

に確認できます。Trce タイ ミ ング結果もインポート して、タイ ミ ング パス  ロジッ クをビジュアルに

確認するこ とができます。 詳細は、 第 8 章 「デザインの解析」 を参照して ください。

図 7-31 : New Floorplan ウィザード  : [Import Constraints] ページ
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インプリ メンテーシ ョ ン実行が完了したら、次の手順で ISE の配置およびタイ ミ ングの結果をイン

ポートできます。

1. [Design Runs] ウ ィンド ウでインプリ メンテーシ ョ ン実行を選択します。

2. 次のコマンドのいずれかを選択します。

♦ [Design Runs] ウ ィンド ウのツールバーにある  [Import Run] ボタンをク リ ッ ク します。

♦ ポップアップ メニューで [Import Run] をク リ ッ ク します。

メモ : [Design Runs] ウ ィンド ウで完了した実行をダブルク リ ッ クする と、[Import Run] ダイアログ

ボッ クスが開きます。

インプリ メンテーシ ョ ン実行の配置およびタイ ミ ング結果が表示されます。 実行を生成するために

使用された UCF 制約もインポート されます。PlanAhead で制約を変更した場合、フロアプランと し

て保存するよ うプロンプ トが表示されます。

複数の実行結果をインポートするこ と もできます。 インポート された各実行に対し、 PlanAhead の
メ イン ウ ィンド ウ上部に実行名が表示されたタブが表示されます。タブをク リ ッ クする と関連実行

結果データが表示されます。

フロアプラン用の実行結果のインポート

フロアプランに関連した実行結果は上述の方法でインポート されます。 違いは、 フロアプランごと

に 1 つの実行のみが表示されるこ とです。PlanAhead のウ ィンド ウ上部にフロアプラン名が表示さ

れたタブが表示されます。 フロアプラン実行結果がインポート されるたびに、 結果は同じフロアプ

ランのウ ィンド ウ  レイアウ ト  タブに表示されます。

図 7-32 : [Import Run] ボタン
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インプリ メンテーシ ョ ン実行での Bitgen の実行

実行が完了したら  ISE Bitgen コマンドを実行し、ビッ ト ス ト リーム データを作成できます。この方

法は次のとおりです。

1. [Design Runs] ウ ィンド ウで完了した実行を選択します。

2. ポップアップ メニューで [Run BitGen] コマンドをク リ ッ ク します。

[Run Bitgen] ダイアログ ボッ クスが表示されます。

Bitgen の実行前にコマンド  オプシ ョ ンを設定できます。オプシ ョ ンを選択する と、ダイアログ ボッ

クスにオプシ ョ ンの説明が表示されます。プルダウン メニューから使用可能なオプシ ョ ン値を選択

できます。

3. [OK] をク リ ッ ク してコマンドを実行します。

コマンドのステータグは実行の [Properties] ウ ィンド ウの [Monitor] タブに表示され、 Bitgen レ
ポート  ファ イルは [Reports] タブで確認できます。

実行ディ レク ト リにビッ ト  ファ イルが作成されます。

図 7-33 : Bitgen オプシ ョ ンの設定
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ス ト ラテジの作成

合成およびインプリ メンテーシ ョ ン スト ラテジの作成

ス ト ラテジは、 各 ISE インプリ メンテーシ ョ ン コマンドのコマンド  オプシ ョ ンのセッ トです。

PlanAhead には、 よ く使用されるス ト ラテジがいくつか含まれています。 これは内部のベンチマー

クで何度も検証済みです。 これらのス ト ラテジのオプシ ョ ン設定は編集できませんが、 コピーした

ものを変更して、 新しいス ト ラテジを作成できます。 

ス ト ラテジはツールおよびバージ ョ ンごとに特化されています。 ISE の各メジャー リ リースには、

そのバージ ョ ンに特化されたコマンド  ライン オプシ ョ ンがあ り、PlanAhead でもサポート されてい

ます。 特定のツールおよびバージ ョ ンからス ト ラテジを選択またはコピーします。

ス ト ラテジを確認、 コピー、 編集するには次の手順に従ってください。

1. [Tools] → [Options] → [Strategies] をク リ ッ ク します。

[Strategies] ページが表示されます。 定義済みのス ト ラテジのリ ス トが表示されます。 

2. この定義済みのス ト ラテジを編集できるよ うに、 次のいずれかのコマンドを使用して [User
Defined Strategies] エリ アにコピーします。

♦ [Strategies] ツールバーで [Create a copy of this strategy] ボタンをク リ ッ ク します。 

図 7-34 : [PlanAhead Options] ダイアログ ボックス :スト ラテジ

図 7-35 : [Create a copy of this strategy] ボタン
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♦ [Copy Strategy] ポップアップ メニュー コマンドをク リ ッ ク します。

ス ト ラテジのコピーが [User Defined Strategies] エリ アに作成され、 ダイアログ ボッ クス

の右側のコマンド  オプシ ョ ンの値が編集できるよ うにな り ます。ス ト ラテジ ファ イルの詳

細は、 「ス ト ラテジ ファ イル (<strategyname>.psg)」 を参照して ください。

3. [Strategies] ページで編集可能なオプシ ョ ンは、 次のとおりです。

♦ [Name] : 実行に割り当てるス ト ラテジ名を入力します。

♦ [Description] : こ こで指定したス ト ラテジの説明は、[Design Runs] ウ ィンド ウの表に表示

されます。

♦ [Flow] : ス ト ラテジに対応するツールおよびバージ ョ ンを入力します。 

4. コマンド  オプシ ョ ンをク リ ッ クする と、 表の下にオプシ ョ ンの説明が表示されます。 

5. 右側のコマンド  オプシ ョ ンをク リ ッ ク してド ロ ップダウン メニューからオプシ ョ ンを選択し

てコマンド  オプシ ョ ンを変更できます。ド ロ ップダウン メニューには使用可能なオプシ ョ ンが

すべて表示されます。

6. [Apply] をク リ ッ ク してから  [OK] をク リ ッ ク してス ト ラテジを保存します。

新しいス ト ラテジは [User Defined Strategies] の下に表示され、「[Design Runs] ウ ィンド ウの使用」

で説明するよ うに [Design Runs] ウ ィンド ウで使用できます。

保存されたス ト ラテジの詳細については、 「デフォルト環境の出力」 を参照してください。 

共通のグループ スト ラテジの作成

カスタム ス ト ラテジをグループ単位で作成および使用する場合は、任意のユーザー定義のス ト ラテ

ジを次のディ レク ト リにコピーできます。

• <InstallDir>/strategies

図 7-36 : コマンド  オプシ ョ ンと説明
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複数の Linux ホストでの実行起動

PlanAhead には複数の Linux ホス トで実行をパラレルに起動する機能があ り ます。 これは、サンマ

イクロシステムズの Grid Engine や LSF などの簡易版を使用した機能です。ジ ョブ提示アルゴ リズ

ムは、 SSH を使用した Tcl パイプでインプリ メン ト されています。

制限事項

制限事項は次のよ うになっています。

• ホス ト実行は SSH で実行されます。 これは PlanAhead ではなく  Linux OS で提供されるサー

ビスです。リモート コンピュータにログインするたびにパスワードを入力する必要がないよ う、

SSH を設定しておく必要があ り ます。パスワードなしの SSH を設定していない場合、またはパ

スワード入力のプロンプ トが表示されるよ うに SSH を設定してある場合は、付録 C 「パスワー

ドなしの SSH の設定」 を参照してください。 

• セキュ リティ保護のため、 また Windows システムにリモート  シェルがないため、 Linux 間の

ホス ト通信のみがサポート されています。

• ISE ツールのインス トールはログイン シェルで設定され、 $XILINX および $PATH は

.cshrc/.bashrc setup スク リプ トで正し く設定されます。 リモート  コンピュータにログインしほ

かのスク リプ ト をソースせずに 「map -help」 と入力できる場合、 このフローは機能します。 ロ

グイン (.cshrc または .bashrc ) で ISE 設定がされていない場合、[Run pre-launch script] を使用

して環境設定スク リプ ト をすべてのジ ョブ前に実行するこ とができます。

• PlanAhead のインス トール ディ レク ト リはリモート  コンピュータにマウン ト されているファ

イル システムに表示されている必要があ り ます。 PlanAhead インス トール ディ レク ト リが

ローカル ディ スクにある場合は、 リモート  コンピュータでは表示されません。

• PlanAhead プロジェク ト  ファ イル (.ppr) およびディ レク ト リ   (.data および .runs) は、 リモー

ト  コンピュータにマウン ト されているファイル システムに表示されている必要があ り ます。デ

ザイン データがローカル ディ スクに保存されている場合、 それはリモート  コンピュータでは

表示されません。

リモート  ホストの設定 (Linux のみ)
付録 C にあるよ うに SSH を設定したら、リモート  サーバーを使用して PlanAhead で実行を起動す

るこ とができます。 このためには、 まず次の設定をしておく必要があ り ます。

1. 次のいずれかのコマンドを使用し、 リモート  ホス ト を設定します。

♦ [Tools] → [Options] → [Remote Hosts] をク リ ッ ク します。

♦ [Run Synthesis] ダイアログ ボッ クスの [Launch Options] をク リ ッ ク して開く  [Specify
Launch Options] ダイアログ ボッ クスで [Configure Hosts] ボタンをク リ ッ ク します。

♦ [Run Implementation] ダイアログ ボッ クスの [Launch Options] をク リ ッ ク して開く

[Specify Launch Options] ダイアログ ボッ クスで [Configure Hosts] ボタンをク リ ッ ク し

ます。

♦ [Launch Selected Runs] ダイアログ ボッ クスで [Configure Hosts] ボタンをク リ ッ ク しま

す。
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[Run Hosts] ページが表示されます。

2. [Add] ボタンをク リ ッ ク して リモート  サーバーの名前を入力します。

3. [Jobs] でリモート  コンピュータで使用するプロセッサ数を指定します。 個々の実行が各プロ

セッサで起動されます。 マルチスレッ ドのプロセッサは使用されません。

4. [Enable] のチェッ クボッ クスのオン/オフを切り替え、サーバーを使用するかど うかを設定しま

す。 このフ ィールドは選択した実行を起動するサーバーを指定するのに使用します。

5. オプシ ョ ンで、[Launch jobs with] フ ィールドで リモート  アクセス  コマンドを変更できます。デ

フォルトでは、 ssh に設定されています。 

メモ : このフ ィールドを変更する場合はよ く注意してください。 たとえば、 [BatchMode =yes]
を削除する と、 シェルで間違ってパスワードのプロンプ トが表示されるため、 プロセスが停止

していまいます。

6. オプシ ョ ンで、 [Run pre-launch script] をオンにし、 実行起動前にスク リプ ト を定義できます。

ログイン時 (.cshrc または .bashrc) に ISE が設定されていない場合、このオプシ ョ ンを使用し環

境設定スク リプ ト を渡します。

7. オプシ ョ ンで、 [Run post-completion script] をオンにし、 実行完了後にスク リプ ト をカスタム

定義できます。

8. オプシ ョ ンで、 [Send email to] をオンにし、実行完了の通知を送信する電子メール アドレスを

入力できます。

9. 最低 1 つのホス ト を選択し  [Test] ボタンをク リ ッ ク して、サーバーが使用可能で正し く設定さ

れているこ とを確認します。 

メモ : 各ホス トに対しテス ト を実行してください。

10. 選択した リモート  ホス ト を削除するには [Remove] ボタンをク リ ッ ク します。

図 7-37 : リモート  ホストの設定
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11. [OK] をク リ ッ ク し、 リモート  ホス トの設定を有効にします。

ISE とのインターフェイス

PlanAhead ソフ ト ウェアでは、 外部ソフ ト ウェアである  ISE のインプリ メンテーシ ョ ンに必要な

ファイルを選択してエクスポートできます。 PlanAhead を使用してデザインをインプリ メン トする

場合は、 ISE と インターフェイスさせる必要はあ り ません。 

PlanAhead ではインプリ メン ト されたデザインに基づきプロジェク ト を作成するこ とができます。

詳細は、 「インプリ メン ト されたデザイン ベースのプロジェク トの作成」 を参照してください。

制約のエクスポート

フロアプラン制約を ISE にエクスポートする場合、デザイン全体の、 または Pblock レベルの UCF
物理制約ファイルをエクスポート します。 

フロアプラン制約をエクスポートするには、

1. [Floorplan] タブをク リ ッ ク します。

2. [File] → [Export Constraints] をク リ ッ ク します。

[Export Constraints] ダイアログ ボッ クスが表示されます。 

3. 編集可能なフ ィールドを確認し、 必要があれば変更します。

♦ [File Name] : UCF 形式の制約ファイルの名前および保存場所を入力します。

♦ [Export fixed location constraints only] : ユーザーが割り当てた 「固定」 配置 LOC 制約の

みをエクスポートする場合はオンに、固定/未固定の区別なく、 ISE からインポート したす

べての配置制約をエクスポートする場合はオフにします。

4. [OK] をク リ ッ ク し制約をエクスポート します。

指定した最上位 UCF 制約ファイルがエクスポート  ディ レク ト リに作成されます。このファイルは、

ISE のカスタム インプリ メンテーシ ョ ン スク リプ トで入力ファイルと して使用できます。

エクスポート されたファイルの詳細は、「ISE インプ リ メンテーシ ョ ンの出力」を参照してください。

ネッ ト リス トのエクスポート

PlanAhead のネッ ト リ ス ト を ISE にエクスポートする場合、 デザイン全体の、 Pblock レベルの

EDIF 形式のネッ ト リ ス ト  ファ イルをエクスポート します。 

デザイン ネッ ト リ ス ト をエクスポートするには、 次の手順に従います。

1. [Floorplan] タブをク リ ッ ク します。

2. [File] → [Export Netlist] をク リ ッ ク します。

図 7-38 : [Export Constraints] ダイアログ ボックス
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[Export Netlist] ダイアログ ボッ クスが表示されます。 

3. 編集可能なフ ィールドを確認し、 必要があれば変更します。

♦ [File Name] : EDIF 形式のネッ ト リ ス ト  ファ イルの名前および保存場所を入力します。

4. [OK] をク リ ッ ク しネッ ト リ ス ト をエクスポート します。

エクスポート されたファイルの詳細は、「ISE インプ リ メンテーシ ョ ンの出力」を参照してください。

ISE インプリ メンテーシ ョ ン用の Pblock のエクスポート

PlanAhead では、 Pblock レベルのファイルをインプリ メンテーシ ョ ン用にエクスポートできます。

これらの Pblock を構成するロジッ クは、 ロジッ ク階層のどのレベルにも存在します。 Pblock をエ

クスポートする と、Pblock ごとに EDIF ネッ ト リ ス ト  ファ イルと  UCF 物理制約ファイルが作成さ

れます。 

Pblock を EDIF および UCF にエクスポートするには、 次の手順に従います。

1. 1 つまたは複数の Pblock を選択します。

2. [File] → [Export Pblocks] をク リ ッ ク します。

図 7-39 : [Export Netlist] ダイアログ ボックス
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Export Pblocks ウ ィザードが表示されます。 

3. 編集可能なフ ィールドを確認し、 必要があれば変更します。

♦ [Directory name] : ディレク ト リ名を入力するか、参照ボタンを使用してエクスポート先の

ディ レク ト リ を指定します。エクスポート される  Pblock ごとに、<pblockname>_CV とい

う名前のサブディ レク ト リが作成されます。 ISE のインプリ メンテーシ ョ ンごとにわかり

やすい名前のディ レク ト リ を作成する と、 PlanAhead のデザインに関連付けられたさまざ

まな EDIF ファ イルおよび UCF ファ イルを管理しやすくな り ます。 エクスポート先の

ディ レク ト リは、 [Import Placement] コマンドおよび [Import TRCE Results] コマンドに

も反映されます。

♦ [File types to generate]

- [Netlist (EDIF)] : ネッ ト リ ス ト をエクスポートする場合はオンにします。

- [Constraints (UCF)] : すべての制約または固定された配置制約のみをエクスポートす

る場合はオンにします。

♦ [Pblocks] : エクスポート される  Pblock が表示されます。

4. [Add] ボタン、[Remove] ボタン、および [Clear] ボタンをク リ ッ クする と、それぞれ Pblock の
リ ス トへの追加、 選択した Pblock のリ ス トからの削除、 リ ス ト全体の削除が実行されます。

5. [Next] または [Finish] をク リ ッ ク します。

6. [Next] をク リ ッ クする と、 サマ リ  ページにエクスポート  オプシ ョ ンの指定内容が表示されま

す。 

7. [Finish] をク リ ッ クする と、 エクスポートが実行されます。

図 7-40 : Export Pblocks ウィザード
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PlanAhead では、 EDIF ファ イルおよび UCF ファ イルは必ずエクスポート された Pblock ごとに作

成され、ファ イル名は、<pblockname>_CV.edn および <pblockname>_CV.ucf というふうになり ま

す。 エクスポート された Pblock ごとに <pblockname>_CV ディ レク ト リが作成され、 その Pblock
のファイルが保存されます。

ISE インプリ メンテーシ ョ ン結果のインポート

インプリ メン ト されたデザイン ベースのプロジェク トの作成

インプリ メンテーシ ョ ン結果をインポートするプロジェク トの作成については、「ISE 配置およびタ

イ ミ ング結果を使用したプロジェク トの作成」 を参照して ください。

既存プロジェク トへの配置結果のインポート

ISE の配置結果は PlanAhead にインポートできます。配置制約は配置されたロジッ ク  オブジェク ト

すべてで割り当てられます。 配置の結果は、 デザインの最上位レベルまたは個別の Pblock にイン

ポートできます。 

配置結果のインポートには、XDL 形式のファイルが使用されます。PlanAhead では、自動的に ISE
XDL コマンドが実行され、 <design_name>routed.ncd から このファイルが作成されます。 

配置結果をインポートするには、 次の手順に従います。

1. [File] → [Import Placement] をク リ ッ ク します。

[Import Placement] ダイアログ ボッ クスが表示されます。 

2. 編集可能なフ ィールドを確認し、 必要があれば変更します。

♦ [File name] : 参照ボタンをク リ ッ ク し、 XDL 形式のファイルまたは <design_name_
routed>.ncd ファ イルを選択します。 NCD 形式のファイルが選択される と、 PlanAhead で
自動的に XDL 形式に変換され、 インポート されます。

図 7-41 : [Import Placement] ダイアログ ボックス
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♦ [Import placement results for] : 配置をインポートするデザインのレベルを選択します。 ダ

イアログ ボッ クスが表示された時点では、前もって選択されたオブジェク トに基づいたオ

プシ ョ ンがオンになっているので、 正しいデザイン レベルを選択します。

- [Netlist '<netlist_name>'] : 最上位の XDL ファ イルをインポートする場合はオンにし

ます。 これは通常、 最上位デザインで ISE を実行する場合です。 

- [Instance] : 選択したロジッ ク  インスタンスに配置結果をインポートする場合はオン

にします。ダイアログ ボッ クスには、 コマンドの実行前に選択したインスタンスが表

示されます。 このオプシ ョ ンは、ブロ ッ ク  レベルの配置制約をインポートする場合に

便利です。

- [Pblock] : 前にインプリ メン ト された Pblock から結果をインポートする場合はオン

にします。

3. [OK] をク リ ッ クする と、 配置結果がインポート されます。

配置のインポートの結果を次に示します。ネッ トの接続およびト レースされたパスが、Pblock の中

心ではなく、 配置制約のロケーシ ョ ンに表示されるよ うにな り ます。 

既存プロジェク トへの ISE TRCE タイ ミング結果のインポート

TimeAhead を使用して、 ザイ リ ンクスの TRCE コマンドで生成された TWR 形式のタイ ミ ング レ
ポート をインポートできます。 インポートする と、 この章で説明されている信号ト レースおよび表

示機能すべてが TimeAhead 環境で使用できるよ うにな り ます。 

タイ ミ ング結果をインポートするには、 次の手順に従います。

1. [File] → [Import TRCE Results] をク リ ッ ク します。

[Import TRCE Results] ダイアログ ボッ クスが表示されます。 

図 7-42 : [Import TRCE Results] ダイアログ ボックス
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2. 編集可能なフ ィールドを確認し、 必要があれば変更します。

♦ [File name] : PlanAhead でインポートする  TRCE で生成された TWR ファ イルの名前を

指定します。 

♦ [Results Name] : [Timing Results] ウ ィンド ウの結果名のタブに表示される名前を指定し

ます。

♦ [Import timing results for] : インポートするデザインのレベルを選択します。 ダイアログ

ボッ クスが表示された時点では、 前もって選択されたオブジェク トに基づいたオプシ ョ ン

がオンになっているので、 正しいデザイン レベルを選択します。

- [Netlist '<netlist_name>'] : 最上位の TRCE 結果をインポートする場合はオンにしま

す。

- [Instance] : インスタンスに結果をインポートする場合はオンにします。参照ボタンを

ク リ ッ ク して、 インスタンスを選択します。

- [Pblock] : Pblock に結果をインポートする場合はオンにします。 参照ボタンをク リ ッ

ク して、 Pblock を選択します。

3. [OK] をク リ ッ クする と、 タイ ミ ング結果がインポート されます。

TRCE 結果が TimeAhead 環境に表示されます。 

パスの選択、ハイライ ト 、およびト レース機能のすべてが TimeAhead インターフェイスで使用でき

るよ うにな り ます。 

パスの負のスラ ッ ク値は、 赤で表示されます。

列のヘッダをク リ ッ クする と、 リ ス トが並べ替えられます。最初に並べ替えた後で Ctrl キーを押し

ながら別の列のヘッダをク リ ッ クする と、 次にその列で並べ替えられます。 リ ス トの表示順を整え

るために、 さまざまな並び替え条件を選択できます。

1 つのフロアプランで、複数のタイ ミ ング結果を表示できます。上の図に示すよ うに、TRCE または

TimeAhead の結果ごとに、 レポートの下の部分にタブが表示されます。

図 7-43 : TRCE タイ ミング結果
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デザインの解析

本章では、 PlanAhead™ で使用可能なフロアプラン環境のデザイン解析機能について説明します。

解析機能については、第 6 章 「RTL デザインの作成および解析」、 第 4 章 「I/O ピンの配置」 および

第 9 章 「インプリ メンテーシ ョ ン結果の解析」 にも説明があ り ます。

解析機能のほとんどは、インプリ メンテーシ ョ ン ツール実行の前にデザインの潜在的な問題を見つ

けるこ とを目的と したものなので、 デザインをインプリ メン トする前に使用できます。 

また、インプリ メン ト されたデザインを解析するのに便利な機能も豊富に備えています。PlanAhead
では、ISE® のインプ リ メンテーシ ョ ン実行から配置およびタイ ミ ング結果をインポート し、さ らに

詳細な解析とフロアプランを実行するこ とができます。 

本章は、 次のセクシ ョ ンで構成されています。

• 「フロアプラン環境の使用」

• 「I/O ピン配置およびクロ ッ ク  ロジッ クの解析」

• 「RTL デザインの解析」

• 「合成されたデザインの解析」
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フロアプラン環境の使用

[Device] ウィンドウの使用

このウ ィンド ウでは、 論理デバイス、 ク ロ ッ ク領域、 I/O パッ ド、 BUFG、 DCM、 Pblock、 インス

タンス  ロケーシ ョ ン、およびネッ ト接続など、FPGA デバイスのリ ソースがすべて表示されます。具

体的なロジッ クが割り当てられているロケーシ ョ ンは 「サイ ト 」 と呼ばれます。 

選択されているズーム レベルによ り、オブジェク トの表示内容が異なり ます。拡大レベルを大き く

する とオブジェク トの詳細が表示されます。 [Device] ウ ィンド ウで表示されるポップアップやツー

ルバー メニューにズームに関する説明が表示されます。 また、 [Device] ウインド ウのスクロール

バーやダイナミ ッ クな表示移動機能を使用し、 表示させたい箇所に移動できます。 

[Device] ウ ィンド ウで表示されるオブジェク トにカーソルを置く と、 ツールチップが表示されオブ

ジェク ト を確認するこ とができます。また、 [Properties] ウ ィンド ウでオブジェク トのプロパティを

表示するこ と もできます。 オブジェク ト を選択する と、 そのオブジェク ト  タイプに特定のポップ

アップ メニューが表示されます。場合によっては、カーソルを [Netlist] ウ ィンド ウなど、別のウ ィ

ンド ウに移動したと きに、 そのオブジェク トのコマンドが使用できる場合があ り ます。 オブジェク

ト  サイ ト を検索するには [Edit] → [Find] をク リ ッ ク します。

図 8-1 : [Device] ウィンドウ
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ダイナミ ッ ク  カーソルは、 [Device] ウ ィンド ウ内で使用できます。 カーソルの形は、実行するアク

ティビティによって変化します。無効なロジッ ク  リ ソースが割り当てられる と きにも形が変わり ま

す。 詳細は、 「文脈依存カーソルについて」 を参照して ください。

[Device] ウ ィンド ウの左上端には、アイコンが数個あ り ます。これらのコマンドは、「ウ ィンド ウ  バ
ナーのコマンドを使用したウ ィンド ウの操作」 で説明されています。

[Device] ウ ィンド ウは I/O ピン配置プロセス中でも使用します。 この詳細は、 第 4 章 「I/O ピンの

配置」 を参照して ください。

デバイス リソースの表示

PlanAhead では、 選択したデバイスに含まれるさまざまな リ ソースが表示されます。 デバイスのリ

ソースが表示レベルは、 [Device] ウ ィンド ウのズーム レベルによって変わり ます。デバイス特有の

リ ソースはすべてグラフ ィカル サイ トで表示するこ とができます。 

I/O パッ ドおよびクロ ッ ク  オブジェク トは、 ペリ フェラルの周辺と、 デバイスの中心またはその下

に表示されます。I/O バンクは、I/O パッ ドの列のすぐ外側に細い長方形と して淡色で表示されます。

使用可能な I/O サイ トは、 I/O バンクの長方形内が色で埋められます。 ボンディングされていない

I/O バンクを持つデバイスもあ り、 こ う した I/O バンクは空の長方形と して表示されます。 I/O ク
ロ ッ ク  パッ ドは色付きの長方形と して表示されます。 BUFG、 BUFR、 BUFGP などのクロ ッ ク  リ
ソースもすべて区別して [Device] ウ ィンド ウに表示されます。I/O バンクを選択する と、[I/O Bank
Properties] に使用可能なデバイス  リ ソースがすべて表示されます。 

デバイスの内側は、 タイルと呼ばれる小さな長方形に分割されており、 使用されているアーキテク

チャのさまざまな種類のロジッ ク  プリ ミ ティブの配置サイ トから構成されています。 Virtex®-4 お
よび Virtex-5 デバイスにはさまざまな種類のロジッ ク  サイ トがあ り ます。[Device] ウ ィンド ウの各

サイ トにカーソルを置く とツールチップが表示され、そのサイ トの詳細を確認するこ とができます。

図 8-2 : [Device] ウィンドウの拡大表示
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CLB、 スライス、 および BEL は、 ズーム レベルをこれらを表示可能なレベルに設定したと きのみ

表示されます。 

プリ ミ ティブ ロジッ ク  インスタンスは、 表示されている適切なサイ トに割り当てるこ とができま

す。 ISE による配置結果をインポート して、 ロジッ クの割り当てを表示できます。 

図 8-3 : [Device] ウィンドウでインスタンスを長方形として配置
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上の図のズーム レベルでは、配置されたインスタンスがスライス内で長方形と して表示されていま

す。 拡大レベルを大き くする と ロジッ ク  シンボルが表示されます。

ロジッ クは LOC 配置制約を生成するサイ トに割り当てるこ とができます。スライスまたは BEL レ
ベルの制約を使用するゲートに割り当てるこ と もできます。 ISE からインポート されるすべてのロ

ジッ クは、 BEL レベルの制約と して表示されます。 LOC 配置制約の詳細は 「配置 LOC 制約」 を参

照して ください。

クロック領域の表示

ク ロ ッ ク領域は、 さまざまなデバイス  ク ロ ッ ク領域を示す大きな長方形と して表示されます。 この

アウ ト ラ インはク リ ティカルな回路でのフロアプランに役立ちます。[Clock Regions] ウ ィンド ウを

使用して、 さまざまなクロ ッ ク領域を選択できます。 

[Window] → [Clock Regions] コマンドをク リ ッ クする と、 [Clock Regions] ウ ィンド ウを表示でき

ます。ク ロ ッ ク領域を選択する と、[Clock Region Properties] ウ ィンド ウにそのリ ソースの統計プロ

パティが表示されます。 インプリ メンテーシ ョ ンの結果がインポート される と、 ク ロ ッ ク配置の統

計を表示できます。 

図 8-4 : [Device] ウィンドウに表示されるロジック  シンボル
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ク ロ ッ ク領域を選択する と、対応する  I/O バンク、およびクロ ッ クに関連したロジッ ク  サイ ト も選

択されます。

[Device] ウ ィンド ウに表示されるクロ ッ ク領域の表示色を変更するには、[Tools] → [Options] で表

示される  [PlanAhead Options] ダイアログ ボッ クスの [Themes] ページで [Device] タブをク リ ッ ク

し、 [Clock Region] の色を変更します。

[Device] ウィンドウの印刷

[File] → [Print] コマンドをク リ ッ クする と、 [Device] ウ ィンド ウを印刷できます。表示されている

部分のみが印刷されます。 [Device] ウ ィンド ウ全体を印刷するには、 拡大率を変更して全体を表示

してから印刷します。

複数の [Device] ウィンドウの表示

同じフロアプランに対して複数の [Device] ウ ィンド ウを表示できます。複数表示するこ とで、デバ

イスの異なるエリ アで作業できます。 [Window] → [New Device View] をク リ ッ クする と、 2 つ目

の [Device] ウ ィンド ウを表示できます。 2 つ目のウ ィンド ウは [Device (2)] という タブに表示され

ます。 「ワークスペースの分割」 にあるよ うに、 このタブのサイズを変更できます。

図 8-5 : クロック領域のリソース統計
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[Schematic] ウィンドウの使用

回路図は、どのレベルの論理階層または物理階層表示に対しても表示できます。[Schematic] ウ ィン

ド ウを使用する と、デザインのインターコネク トや階層構造を表示したり、 RTL ネッ ト リ ス ト また

は合成されたネッ ト リ ス トの信号パスを ト レースした りできます。RTL ネッ ト リ ス トの解析につい

ては、 第 6 章 「RTL デザインの作成および解析」 を参照してください。

[Schematic] ウ ィンド ウで直接ロジッ クを選択して、 [Device] ウ ィンド ウでフロアプランに使用で

きます。 

[Schematic] ウ ィンド ウを開くには、 次の手順に従います。

1. 1 つまたは複数のロジッ ク  エレ メン ト を選択します。

2. 右ク リ ッ ク して [Schematic] をク リ ッ クするか、または次に示す [Schematic] ボタンをク リ ッ ク

します。 

[Schematic] ウ ィンド ウには、選択したロジッ クのインスタンスまたはネッ トが表示されます。イン

スタンスが 1 つのみ選択された場合は、 モジュールがすべてのピンと共に表示されます。

図 8-6 : 複数の [Device] ウィンドウの表示

図 8-7 : [Schematic] ボタン
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[Schematic] ウ ィンド ウでオブジェク ト を選択する と、 別のウ ィンド ウでもそのオブジェク トが選

択されます。配置結果がインポート されている場合は、 ロジッ クおよびパスが [Device] ウ ィンド ウ

に表示されます。

[Schematic] ウィンドウでのロジック階層の表示

[Schematic] ウ ィンド ウが表示される と き、 上位の階層はすべて、 同心の長方形と して表示されま

す。

図 8-8 : [Schematic] ウィンドウ
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上の図に示すよ うに、 上位の階層ではピンが表示されていません。 このため回路図が見やすくなっ

ています。 モジュールのピンおよびロジッ クは、 個々に展開表示または非展開できます。 ロジッ ク

は、 個々のピン、 インスタンス、 またはモジュール内外のロジッ ク全体から展開表示できます。

選択したモジュールのモジュール ピンを展開表示するには、 [Toggle Autohide Pins] ポップアップ

メニューまたは [Schematic] ウ ィンド ウの [Toggle Autohide pins for selected instance] ボタンをク

リ ッ ク します。

選択したピンからのロジックの展開表示 
ピンからロジッ クを展開表示するためのオプシ ョ ンがいくつかあ り ます。 ピンをダブルク リ ッ クす

る と、そのロジッ ク  ネッ トから次のプリ ミ ティブのロジッ ク  エレ メン ト まですべてが展開表示され

ます。 太いワイヤはバスを表しています。 バスを展開表示する と、 バスのすべてのビッ トが表示さ

れ、 信号を展開表示する と、 次の図に示すよ うに階層の境界を越えて展開表示されます。 

その他にも、 次のフ リ ップフロ ップ セッ ト までのロジッ クを展開表示したり、 I/O までのロジッ ク

を展開表示するオプシ ョ ンがあ り ます。 展開表示で選択されたロジッ クが多すぎる場合は、 回路図

表示には適さないこ とを示すダイアログ ボッ クスが表示される場合があ り ます。 

図 8-9 : [Schematic] ウィンドウでの階層表示

図 8-10 : [Toggle Autohide pins for selected instances] ボタン
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ロジッ クの展開表示オプシ ョ ンを表示するには、 ピンまたはインスタンスを選択して [Expand
Cone] をク リ ッ ク します。 

[Expand Cone] コマンドのオプシ ョ ンは次のとおりです。

• [To Flops] : 最初のフ リ ップフロ ップ、 またはブロ ッ ク  RAM、 FIFO、 エンベデッ ド  プロセッ

サなどの順次エレ メン ト までロジッ ク全体を表示します。

• [To Primitives] : 出力ロジッ ク全体を最初のプリ ミ ティブの表示に追加します。この操作は、ピ

ンをダブルク リ ッ ク したと きのデフォルトです。

• [To IOs] : 出力ロジッ ク全体を I/O の表示に追加します。この場合、多数のロジッ クが表示され

るこ とにな り ます。 PlanAhead では、 ロジッ ク  レベルが 11 以上追加される場合、 このコマン

ドをキャンセルできる警告メ ッセージが表示されます。

選択したインスタンスまたはモジュールのロジックの展開または非展開

選択したモジュールの内側に含まれるロジッ クまたはモジュールの外側の次のレベルの階層に含ま

れるロジッ クすべてを展開または非展開できます。新しいコマンドのセッ ト を 1 つまたは複数のモ

ジュールに実行できます。 これらのコマンドは、右ク リ ッ クで表示されるポップアップ メニューま

たは [Schematic] ウ ィンド ウ内のボタンから実行できます。

図 8-11 : [Schematic] ウィンドウでの信号の展開表示
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これらのコマンドでは、 1 つの階層レベルに関連するすべてのロジッ クが表示されます。 次の図は、

[Expand all logic inside selected instance] を実行した例です。 

回路図での階層移動 
階層インスタンスをダブル ク リ ッ クする と、 現時点で表示されているロジッ クが非展開表示され、

選択されているモジュール内でロジッ クが展開されます。 1 つ上のレベルの階層に移動するには、

[Expand Outside] コマンド と  [Collapse Inside] コマンドを使用します。

表 8-1 : [Schematic] ウィンドウのボタン

ツールバー ボタン コマンド 説明

Expand all logic 
inside selected 
instance

選択したインスタンス内のロジッ クをすべて展

開表示します。

Collapse all logic 
inside selected 
instance

選択したインスタンス内のロジッ クをすべて非

展開表示します。

Expand all logic 
outside selected 
instance

選択したインスタンスの外側のロジッ クをすべ

て展開表示します。

Collapse all logic 
outside selected 
instance

選択したインスタンスの外側のロジッ クをすべ

て非展開表示します。

図 8-12 : 1 つの階層レベル内のすべてのロジックの表示
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[Schematic] ウィンドウの再生成

階層を展開または非展開するコマンドを数回使用する と、 [Schematic] ウ ィンド ウの表示が少し乱

れる場合があ り ます。 この場合は、 [Schematic] ウ ィンド ウの [Regenerate schematic] ボタンをク

リ ッ ク して、 表示をク リーンアップします。 

これで作業中の [Schematic] ウ ィンド ウが再生成されます。

[Schematic] ウィンドウでのオブジェク トの選択

オブジェク トは、 ク リ ッ クする と選択されます。 Ctrl キーを使用する と、 複数のオブジェク ト を選

択できます。 [Select Area] コマンドを使用して複数のインスタンス、 ポート、 およびネッ ト を囲ん

で、複数のオブジェク ト を選択するこ と もできます。[Schematic] ウ ィンド ウでインスタンスを選択

する と、 その他のウ ィンド ウでもそのインスタンスが選択されます。 別のウ ィンド ウでインスタン

スが選択された場合も、 このウ ィンド ウでそのインスタンスが選択されます。 どのウ ィンド ウでオ

ブジェク ト を選択またはハイライ ト しても、 同じものが [Schematic] ウ ィンド ウでもハイライ ト さ

れます。

[Schematic] ウ ィンド ウのポップアップ メニューにはオブジェク トの選択オプシ ョ ンがいくつかあ

り ます。 このオプシ ョ ンについては次のセクシ ョ ンで説明します。

[Schematic] ウィンドウからのオブジェク トの削除

選択したオブジェク トおよび関連する接続を削除するには、 [Schematic] ウ ィンド ウの [Remove
selected elements from schematic] ボタンをク リ ッ ク します。

[Schematic] ウィンドウの印刷

[File] → [Print] コマンドをク リ ッ クする と、[Schematic] ウ ィンド ウを印刷できます。表示されてい

る部分のみが印刷されます。[Schematic] ウ ィンド ウ全体を印刷するには、拡大率を変更して全体を

表示してから印刷します。

[Schematic] ウィンドウのポップアップ メニュー コマンド  
インスタンスおよびネッ ト を [Schematic] ウ ィンド ウで選択して操作を実行できます。 共通のポッ

プアップ メニュー コマンドは、「共通のポップアップ メニュー コマンドの使用」 で説明します。 こ

こでは [Schematic] ウ ィンド ウのコマンドを説明を示します。

• [Expand Cone] : 最初のプリ ミ ティブ、フ リ ップフロ ップ、または I/O まで入力ロジッ ク全体を

展開表示します。

• [Toggle Autohide Pins] : 選択したモジュールのモジュール ピンを表示、 非表示にします。

• [Remove From Schematic] : 選択したオブジェク ト を回路図から削除します。

• [Expand Inside] : 選択したモジュール内のロジッ クすべてを展開表示します。

• [Expand Outside] : 選択したモジュールの外側のロジッ クすべてを展開表示します。 展開され

るのは、 親モジュール ロジッ クのみです。

• [Collapse Inside] : 選択したモジュール内のロジッ クすべてを非展開表示します。

図 8-13 : [Regenerate schematic] ボタン

図 8-14 : [Remove selected elements from schematic] ボタン
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• [Collapse Outside] : 選択したモジュールの外側のロジッ クすべてを非展開表示します。非展開

されるのは、 親モジュール ロジッ クのみです。

• [Select All Primitive in Schematic] : アクティブな回路図に表示されているプ リ ミ ティブ ロ
ジッ クをすべて選択します。 

• [Select Primitive Parents] (インスタンスが選択されたと きのみ使用可能) : 選択したロジッ ク

の親ロジッ ク  モジュールをすべて選択します。

 回路図でのデザイン情報のアノテーシ ョ ン

回路図ピンのスラック、 ファンアウト、 値のアノテーシ ョ ン

[PlanAhead Options] ダイアログ ボッ クスの [Schematic] ページでは、 ソース  ピンにファンアウ ト

値を、 デスティネーシ ョ ン ピンにスラ ッ ク値を表示するよ うに設定できます。 スラ ッ ク値は

TimeAhead を実行しないと表示されません。 

このオプシ ョ ンは、[Tools] → [Options] で表示される  [PlanAhead Options] ダイアログ ボッ クスで

[Schematic] をク リ ッ クする と、 設定できます。 

1. これらの値を設定するには、 ます [Attribute Types] で [Pin] を選択します。

2. [Available DB Attributes] に表示されている  [Fanout] および [Slack] を選択し、右方向の矢印ボ

タンをク リ ッ ク して [Displayed DB Attributes] に移動させます。

3. [OK] をク リ ッ ク します。 

図 8-15 : [PlanAhead Options] ダイアログ ボックス : 回路図ピンのアノテーシ ョ ン
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アノテーシ ョ ンは次のよ うに表示されます。 

セル リファレンスおよび式のインスタンスへのアノテーシ ョ ン 

[PlanAhead Options] ダイアログ ボッ クスでセル リ ファレンスおよび式の値をインスタンスに設定

するこ とができます。 

このオプシ ョ ンは、[Tools] → [Options] で表示される  [PlanAhead Options] ダイアログ ボッ クスで

[Schematic] をク リ ッ クする と、 設定できます。 

1. これらの値を設定するには、 ます [Attribute Types] で [Instance] を選択します。

2. [Available DB Attributes] に表示されているアイテムを選択し、 右方向の矢印ボタンをク リ ッ

ク して [Displayed DB Attributes] に移動させます。

3. [OK] をク リ ッ ク します。

図 8-16 : [Schematic] ウィンドウでの注釈付きピン
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アノテーシ ョ ンは次のよ うに表示されます。 

図 8-17 : [PlanAhead Options] ダイアログ ボックス : 回路図インスタンスのアノテーシ ョ ン

図 8-18 : [Schematic] ウィンドウでの注釈付きインスタンス

http://japan.xilinx.com


230 japan.xilinx.com PlanAhead ユーザー ガイド
UG632 (v 11.1.0)

第 8 章 : デザインの解析

[Schematic] ウィンドウでのタイ ミング パス ロジックの表示

タイ ミ ング パスは、 PlanAhead の [Timing Results] ウ ィンド ウから選択して、 [Schematic] ウ ィン

ド ウに表示できます。選択したパスまたはパス  グループのオブジェク トはすべて、 ロジッ ク階層の

境界およびインターコネク ト  ワイヤと共に表示されます。

メモ : trace.twr のタイ ミ ング レポートに含まれるパスで一部のインターコネク ト  ワイヤが表示さ

れない場合があ り ます。これは、ISE インプリ メンテーシ ョ ンでロジッ クが最適化されて削除された

ためです。[Schematic] ウ ィンド ウでは、選択したパスに実際に含まれるオブジェク トがすべて表示

されます。 ただし、 PlanAhead ではオブジェク トが最適化されて削除されてしまった場合は、 その

接続を含めるこ とはできません。[Schematic] ウ ィンド ウを [Path Properties] ウ ィンド ウ と共に使用

する と、 パスの接続を簡単にト レースできます。 ほとんどの場合、 パスの方向が簡単にわかるよ う

に回路図が描画されています。 詳細は、 「タイ ミ ング結果の解析」 を参照してください。

[Hierarchy] ウィンドウの使用

[Hierarchy] ウ ィンド ウには、 ロジッ ク階層がグラフ ィカルに表示されます。デザインを上位から下

位に表示するこ とで、 デザイン内のモジュール サイズと位置を簡単に識別できます。

図 8-19 : [Schematic] ウィンドウ内のロジック階層
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このウ ィンド ウは、 [Show Hierarchy] ポップアップ メニュー コマンドを実行する と開きます。

このウ ィンド ウには、階層インスタンスのみが表示されます。プリ ミ ティブ ロジッ クはグループ化

されてフォルダに含められ、サブモジュールと して表示されます。プリ ミ ティブ ロジッ ク  フォルダ

の詳細は、「[Netlist] ウ ィンド ウの使用」 を参照して ください。[Hierarchy] ウ ィンド ウのブロ ッ クの

幅は、 LUT、 フ リ ップフロ ップ、 BRAM、 DSP48 などの FPGA リ ソースに基づいています。

選択したロジッ クはハイライ ト されます。 モジュールに含まれるロジッ クを選択する と、 その選択

したロジッ ク部分のみがハイライ ト されます。 

サブモジュールの階層はダブルク リ ッ クする と  [Hierarchy] ウ ィンド ウに表示できます。

図 8-20 : [Hierarchy] ウィンドウ

図 8-21 : モジュール内で選択されたロジックのみのハイライ ト

http://japan.xilinx.com


232 japan.xilinx.com PlanAhead ユーザー ガイド
UG632 (v 11.1.0)

第 8 章 : デザインの解析

Pblock を割り当てるためのロジッ クの親モジュールを選択するには、 [Select Primitive Parents] コ
マンドをク リ ッ ク します。 

[Properties] ウィンドウの使用

すべての PlanAhead のオブジェク トには、関連するプロパティがあ り ます。オブジェク ト を選択す

る と、そのプロパティが自動的に [Properties] ウ ィンド ウに表示されます。ウ ィンド ウ内にオブジェ

ク トに関するさまざまなタイプの情報がタブ別に表示されます。 

このウ ィンド ウはダイナミ ッ ク表示され、 新しいアイテムが選択される と、 表示内容が自動的に更

新されます。 

ほとんどのオブジェク ト  タイプで複数の種類のプロパティが表示されます。 情報整理のため

[Properties] ウ ィンド ウの下部にはタブが追加されています。選択したオブジェク トに関する情報を

表示 ・ 変更するには、 タブを切り替えます。

[Properties] ウィンドウのツールバーの使用

[Properties] ウ ィンド ウのツールバーには、 次のコマンドが含まれています。

図 8-22 : [Properties] ウィンドウに表示されるタブ

表 8-2 : [Properties] ウィンドウのツールバー 

ツールバー ボタン コマンド 説明

[Previous object] 前に選択したオブジェク トに戻り ます。

[Next object] 次に選択したオブジェ ク ト に戻り ます。 この

ボタンは、[Previous object] コマンドを使用し

たと きのみ使用できます。
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[Netlist] ウィンドウの使用

ネッ ト リ ス トは、ロジッ ク  デザインを階層的に表現したもので、最上位ネッ ト リ ス ト名の下には、最

上位モジュールが含まれています。 このウ ィンド ウでは、デザインに含まれるロジッ ク  インスタン

スおよびネッ トが表示されます。ネッ ト リ ス トは、 ロジッ ク  ツ リーの階層を展開または非展開する

こ とでナビゲートできます。スクロール バーを使用する と、ネッ ト リ ス ト  ツ リー全体を表示できま

す。

ネッ ト リ ス ト  ツ リーは、他のウ ィンド ウでネッ ト リ ス ト  オブジェク トが選択される とそのオブジェ

ク ト を表示するために、 ダイナミ ッ クに展開表示されます。 これはデフォルト設定で、 最も便利で

[Automatically update the
contents of this window
when new objects are
selected]

新しいオブジェ ク トが選択されたか、 または

新しいオブジェク ト が元々選択されていたオ

ブジェク ト でスタテ ィ ッ クのままになってい

る と きに、 [Properties] ウ ィンド ウを自動的に

更新します。

[New] 新しいオブジェ ク ト を追加します。 オブジェ

ク ト  タイプやウ ィンド ウによってはこのオプ

シ ョ ンは使用できない場合があ り ます。

[Delete] [Properties] ウ ィンド ウのタブからオブジェ

ク ト を削除します。

[Export statistics] データを後で解析できるよ うに、 ファ イルに

保存します。Pblock、ク ロ ッ ク領域、およびイ

ンスタンスの [Properties] ウ ィンド ウの

[Statistics] タブでのみ使用できます。

[Select/Unselect object] プロパティ を表示しているオブジェ ク トの選

択が解除される と きがあ り ます。 このボタン

を使用して、オブジェク ト を選択、または選択

解除します。

表 8-2 : [Properties] ウィンドウのツールバー 

ツールバー ボタン コマンド 説明
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す。この設定を無効にするには、このウ ィンド ウの [Automatically scroll to selected objects] ボタン

をク リ ッ ク します。

ネッ ト リス ト  ツリーの非展開

ネッ ト リ ス ト  ツ リー全体は、 このウ ィンド ウの [Collapse All] ボタンをク リ ッ クする と非展開にで

きます。 詳細は、 「ウ ィンド ウ特定のツールバー コマンドの使用」 を参照してください。

ネッ ト リ ス ト  ツ リーは、 非展開されて最上位のロジッ ク  モジュールのみが表示されます。

図 8-23 : [Netlist] ウィンドウ

図 8-24 : 非展開されたネッ ト リス ト  ツリー
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[Primitives] フォルダの使用

モジュールにプリ ミ ティブ ロジッ クが含まれている と き、 プ リ ミ テ ィブ ロジッ クは [Primitives]
フォルダに含められます。これによ り、[Netlist] ウ ィンド ウに含められているモジュールの表示を簡

略化できます。 

Pblock に直接 [Primitives] フォルダを割り当てる と、 すべてのプリ ミ ティブが割り当てられます。 

メモ : ネッ ト リ ス ト を更新する際、ロジッ ク名が再合成で変更されている可能性があるので、Pblock
に [Primitive] フォルダを割り当て直す必要がある場合があ り ます。

図 8-25 : [Netlist] ウィンドウの [Primitives] フォルダ
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[Nets] フォルダの使用 
[Nets] フォルダには、 階層に含まれるすべてのネッ トおよびバスが含まれています。 バスを展開す

る と個々のビッ ト を表示できます。 

ネッ ト を選択する と、[Device] ウ ィンド ウでそのネッ トがハイライ ト されます。バスを選択する と、

バスに含まれているすべてのネッ トがハイライ ト されます。ネッ トは、[Schematic] ウ ィンド ウで表

示できます。

[Netlist] ウィンドウのアイコンの説明

ネッ ト リ ス ト  ロジッ クのステートの表現に使用されるアイコンがいくつかあ り ます。

階層ネッ ト リス ト  モジュール

階層ネッ ト リ ス ト  モジュールまたはインスタンスは、次のよ うに黄色の文字 I を含むアイコンで表

示されます。 

Pblock に割り当てられた階層ネッ ト リス ト  モジュール

Pblock に割り当てられた階層ネッ ト リ ス ト  モジュールまたはインスタンスは、次に示すよ うに青色

のチェッ クマークを含むアイコンで表示されます。 

図 8-26 : [Netlist] ウィンドウの [Nets] フォルダ
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NGC から派生したモジュール

NGC または NGO フォーマッ トのコアのネッ ト リ ス ト入力ファイルから派生したモジュールは、次

に示すよ うに赤色の四角が含まれたアイコンで表示されます。NGC ファ イルの名前は、かっこで表

示されます。 

ブラック  ボックス モジュール

ネッ ト リ ス トが関連付けられていないモジュールは黄色い英文字 I が含まれたグレーのアイコンで

表示されます。 これは、 プロジェク ト生成時に検索パスが指定されていなかったか、 またはデザイ

ンの一部が不足しているために発生したものと考えられます。 

プリ ミテ ィブ ロジックのインスタンス

配置制約のないプリ ミ ティブ ロジッ クのインスタンスは、黄色の長方形の中に英文字 i が表示され

たアイコンで表示されます。配置制約のあるプリ ミ ティブ ロジッ クのインスタンスは、青い横線の

付いた黄色の長方形のアイコンで表示されます。Pblock に割り当てられているプリ ミ ティブ ロジッ

クのインスタンスは、 黄色の長方形に青色のチェ ッ クマークが付いたアイ コンで表示されます。

Pblock に配置、割り当てられたプリ ミ ティブ ロジッ クのインスタンスは、黄色の長方形にチェッ ク

マーク と青色の横線が表示されたアイコンで表示されます。 また、 ロジッ クの種類も表示されてい

ます。 

[Netlist] ウィンドウでのロジックの選択

エレ メン ト を選択してメニュー、 ツールバー、 または右ク リ ッ クによるポップアップ メニューから

コマンドを適用できます。 

Shift キーまたは Ctrl キーを使用する と、[Netlist] ウ ィンド ウで複数のエレ メン ト を選択でき、ほと

んどのコマンドは複数のエレ メン トに対し実行できます。 [Netlist] ウ ィンド ウで選択されたロジッ

クは、 ハイライ ト されます。

PlanAhead で選択されたロジッ ク も、 [Netlist] ウ ィンド ウに表示されます。 ネッ ト リ ス トのツ リー

は、 選択したロジッ クすべてが表示されるよ うに自動的に展開されます。 選択したロジッ クの一部

は、ウ ィンド ウのスクロール バーを使用して表示する必要がある場合があ り ます。ネッ ト リ ス ト  ツ
リーを非展開にしても、 ロジッ クの選択は解除されません。

[Netlist] ウィンドウのポップアップ メニュー コマンドの使用

[Netlist] ウ ィンド ウで使用できるポップアップ メニュー コマンドの詳細は、 「共通のポップアップ

メニュー コマンドの使用」 を参照してください。

[Constraints] ウィンドウの使用 
PlanAhead では、 フロアプランで定義されているタイ ミ ング制約のすべてを表示するこ とができま

す。 制約はフロアプラン別に設定でき、 同じプロジェク トでもフロアプランごとに変更するこ とが

できます。 このため、 制約、 デバイス、 I/O ピンなどをいろいろと試すこ とができます。
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[Constraints] ウ ィンド ウでは、 定義済みの値を変更したり、 新しい制約を作成したりできます。 デ

ザインで定義されているタイ ミ ング制約を表示するには、 [Constraints] タブをク リ ッ クするか、 ま

たは [Window] → [Constraints] をク リ ッ ク します。 

[Constraints] ウ ィンド ウが表示されます。 

制約は、2 つの方法で表示されます。上の図で示すよ うに、カテゴ リ別に並べ替えられている と、制

約タイプのレベルを展開または非展開できます。 各タイプの制約の数は、 括弧に示されています。 

すべてのタイ ミ ング制約のリ ス ト を表示するには、[Constraints] ウ ィンド ウで [Group by type] ボタ

ンをク リ ッ ク します。 

タイ ミ ング制約がリ ス ト と して表示される場合は、 次のよ うにな り ます。

図 8-27 : 種類ごとにグループ化された制約

図 8-28 : [Group by type] ボタン

http://www.xilinx.com


PlanAhead ユーザー ガイド japan.xilinx.com 239
UG632 (v 11.1.0)

フロアプラン環境の使用

タイ ミング制約の値の変更

ほとんどの制約の値は、 制約を選択して [Constraints Properties] ウ ィンド ウに表示して変更できま

す。 変更可能な値がこのウ ィンド ウに表示されます。

図 8-29 : リス トごとにグループ化されたタイ ミング制約
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各制約タイプでウ ィンド ウの内容が異なるため、 こ こでは全部は説明しません。 制約の値を定義す

る と きは、 正しい構文を使用して ください。 制約および制約の構文の詳細は、 ザイ リ ンクスの 『制

約ガイ ド』 を参照してください。 変更を加えた後に、 [Apply] をク リ ッ ク して変更を反映させるか、

または [Cancel] をク リ ッ ク して変更を取り消します。

メモ : [Apply] ボタンをク リ ッ ク しないと、 制約の値は変更されません。

新しいタイ ミング制約の追加

新しいタイ ミ ング制約を追加するには、 次の手順に従います。

1. [Constraints] ウ ィンド ウで [Create new constraint] ボタンをク リ ッ ク します。 

図 8-30 : タイ ミング制約の値の変更

図 8-31 : [Create new constraint] ボタン
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[New Timing Constraint] ダイアログ ボッ クスが表示されます。 

2. [Constraint Types] で作成する制約の種類を選択します。

選択する と、 右側に対応するフ ィールドが表示されます。 

3. 正しい構文を使用して制約の値を定義します。 制約および制約のフォーマッ トの詳細は、 ザイ

リ ンクスの 『制約ガイ ド』 を参照して ください。

4. [OK] をク リ ッ ク します。

タイ ミング制約の削除

フロアプランから制約を削除するには、制約または制約グループを [Constraints] ウ ィンド ウで選択

して、ポップアップ メニューで [Delete] をク リ ッ ク します。制約を削除するこ とを確認するダイア

ログ ボッ クスが表示されます。 削除する場合は、 [OK] をク リ ッ ク します。

メモ : タイ ミ ング制約は相互依存しているため、 1 つの制約を削除する と関連する制約がいくつか

削除される可能性があ り ます。

メモ : タイ ミ ング制約の追加、 編集、 および削除は、 やり直すこ とができません。

[Physical Hierarchy] ウィンドウの使用

[Physical Hierarchy] ウ ィンド ウには、デザインを階層に分割した構造が表示されます。物理デザイ

ンは、 ツ リー エレ メン トのプラス記号 (+) およびマイナス記号 (-) を展開または非展開するこ とで

ナビゲートできます。 ツ リー エレ メン ト を選択してメニュー、 ツールバー、右ク リ ッ クによるポッ

プアップ メニューからコマンドを適用できます。 Ctrl キーまたは Shift キーを押しながら選択する

と複数のエレ メン ト を選択でき、 同じコマンドを同時に実行するこ とができます。

物理階層ツ リーはダイナミ ッ クで、 物理階層が変更される と自動的に拡張 ・変更されます。 その他

のウ ィンド ウでオブジェク トが選択される と、[Physical Hierarchy] ウ ィンド ウで該当エレ メン トが

ハイライ ト されます。 

このウ ィンド ウに表示されるオブジェク トは、相対配置マクロ  (RPM) および物理ブロッ ク  (Pblock)
です。 これらのオブジェク ト をこのウ ィンド ウで選択して、 他のウ ィンド ウで変更するこ と もでき

ます。

図 8-32 : [New Timing Constraint] ダイアログ ボックス
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ROOT デザイン Pblock の使用

物理階層には、 まずフロアプラン名の下に ROOT という最上位デザインが含まれます。ROOT は、

PlanAhead に含まれる最上位の Pblock です。 下位の Pblock を作成する と、 これらは Pblock フォ

ルダの下に階層構造で表示され、 親 Pblock の下には 子 Pblock が表示されます。 

Pblock を選択する と、 これに割り当てられているすべてのロジッ クが選択されます。 

[Physical Hierarchy] ウィンドウのアイコンの説明

[Physical Hierarchy] ウ ィンド ウのツ リーには、さまざまなオブジェク トのステート を識別するのに

役立つアイコンがいくつかあ り ます。 このアイコン表示は物理階層が変更される と自動的に更新さ

れます。 

Pblock を作成する と、 [Physical Hierarchy] ウ ィンド ウに階層的に表示されます。図 8-34 に示すよ

うに、 このウ ィンド ウに含まれる各フォルダのタイプ名の末尾に括弧で表示されている番号は、 そ

のフォルダに含まれているオブジェク ト数を示します。

1 つの相対配置マクロ  (RPM) の各インスタンシエーシ ョ ンがこのウ ィンド ウに表示されます。その

場合 Pblock の下の RPM フォルダに表示されます。[Physical Hierarchy] ウ ィンド ウで RPM を選択

する と、 RPM に含まれているロジッ クすべても選択されます。 

インスタンスが割り当てられた Pblock

インスタンスが割り当てられており  [Device] ウ ィンド ウで長方形が定義されている  Pblock は、 中

心が黄色の青色キューブで表示されます。 

インスタンスが割り当てられてられており  [Device] ウ ィンド ウで長方形が定義されていない

Pblock は、 中心が黄色の青色正方形で表示されます。 

図 8-33 : [Physical Hierarchy] ウィンドウ
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インスタンスが割り当てられていない Pblock

インスタンスが割り当てられておらず、 [Device] ウ ィンド ウで長方形が定義されている  Pblock は、

中心に青色の P 文字が示されている青色キューブで表示されます。

インスタンスが割り当てられておらず、 [Device] ウ ィンド ウで長方形が定義されていない Pblock
は、 中心に青色の P 文字が示されている青色正方形で表示されます。

相対配置マクロ (RPM) での作業

デザインに含まれる相対配置マクロ  (RPM) は、 [RPMs] フォルダの下に表示されます。 RPM は
Pblock に割り当てるこ とができます。その場合 Pblock の下の RPM フォルダに表示されます。1 つ
の相対配置マクロ  (RPM) の各インスタンシエーシ ョ ンがこのウ ィンド ウに表示されます。

[Physical Hierarchy] ウ ィンド ウで RPM を選択する と、 RPM に含まれているロジッ クすべても選

択されます。  

図 8-34 : [Physical Hierarchy] ウィンドウに表示される [RPMs] フォルダ
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[RPM Properties] ウ ィンド ウには、 RPM に含まれるすべてのインスタンスが表示されます。

RPM ロジッ クを Pblock に割り当てる と、 RPM のサイズ情報が [Pblock Properties] ウ ィンド ウの

[Statistics] タブに表示されます。

Pblock に割り当てられた RPM の数が、RPM の最長および最大幅の情報と共に表示されます。RPM
のサイズ情報は、 Pblock の形を調整するのに役立ちます。 

図 8-35 : RPM に含まれるインスタンス

図 8-36 : [Pblock Properties] ウィンドウ :[Statistics] タブ
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この情報を保存するには、[Pblock Properties] ダイアログ ボッ クスの [Save Pblock statistics to file]
ボタンをク リ ッ ク し、 ファ イル名を指定します。

Pblock に多数の RPM が含まれる場合は、Pblock のサイズを大き く して ください。 これによ り、 イ

ンプリ メンテーシ ョ ン ツールで RPM をエリ アにフ ィ ッ ト させるこ とができます。

共通のポップアップ メニュー コマンドの使用

ポップアップ メニュー コマンドには、複数のウ ィンド ウで使用できるものが多数あ り ます。次のコ

マンドは、 PlanAhead の多くのウ ィンド ウおよび環境で使用されます。

次のコマンドには、ロジッ クがあらかじめ選択されている と きのみ使用可能なものもあ り ます。ポッ

プアップ メニューの内容は、アクティブなウ ィンド ウや選択されているオブジェク トの種類によっ

て異なり ます。 

次に、 共通の右ク リ ッ ク  コマンドおよびその説明を示します。

• [Instance Properties]/[Pblock Properties]/[Net Properties] : 適切な [Properties] ウ ィンド ウを開

きます。

• [Delete] : 選択したオブジェク ト を削除するこ とを確認するダイアログ ボッ クスが表示されま

す。 [OK] をク リ ッ クする と削除されます。

• [Unplace] : 選択した配置制約を削除します。

• [Assign] : 選択したインスタンスを既存の Pblock に割り当てます。[Select Pblock] ダイアログ

ボッ クスが表示され、 インスタンスを割り当てる  Pblock を選択できます。

• [Unassign] : 選択した Pblock へのインスタンス割り当てを削除します。

• [Draw Pblock] : [Device] ウ ィンド ウで長方形を描画できます。選択したインスタンスを割り当

てた Pblock が作成されます。

• [New Pblock] : [Physical Hierarchy] ウ ィンド ウに、選択したインスタンスが割り当てられた新

しい Pblock を作成します。 長方形は作成されません。

• [Clear Rectangle] : Pblock から選択した長方形を削除します。 Pblock は削除されません。

• [Set Pblock Size] : 任意の場所に新しい長方形を描画できます。ほかの既存の長方形が削除され

ます。

• [Add Pblock Rectanble] : Pblock に長方形を追加できます。 Pblock に長方形以外の形を作成す

る と きに便利です。

• [Select Children] : 選択した Pblock の子 Pblock すべてを選択します。

• [Select Primitives] : 現在の [Schematic] ウ ィンド ウに含まれるプ リ ミ ティブ ロジッ ク  オブ

ジェク ト をすべて選択します。 モジュールを選択した場合は、 そのモジュール内のプリ ミ ティ

ブ ロジッ ク  オブジェク トのみが選択されます。このコマンドは、その他のウ ィンド ウでも使用

できます。

• [Select Primitives Parents] : 選択したプリ ミ ティブ ロジッ ク  オブジェク トの親モジュールすべ

てを選択します。 モジュールを選択した場合、 モジュールは選択されたままになり ます。 この

コマンドはその階層にのみ適用され、 モジュールの親が選択されます。 このコマンドは、 その

他のウ ィンド ウでも使用できます。

図 8-37 : [Save Pblock statistics to file] ボタン
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• [Highlight Primitives] : 選択されたモジュールのプリ ミ ティブ ロジッ クを、 サブメニューで選

択した色でハイライ ト します。 このコマンドは、 多くのウ ィンド ウで使用できます。 

モジュールのグループを選択した場合は、 ポップアップ メニューのサブメニューで [Cycle
Colors] オプシ ョ ンを選択して、 各モジュール プリ ミ ティブに別々の色を使用してハイライ ト

できます。 このコマンドは、 ロジッ ク階層のグループの配置位置を表示する場合にとても便利

です。[Netlist] ウ ィンド ウにあるモジュールのアイコンも同じ色でハイライ ト されるため、対応

するオブジェク トが容易にわかり ます。

• [Unhighlight Primitives] : 選択したプリ ミ ティブのハイライ ト を解除します。 モジュールを選

択した場合は、そのモジュール内のプリ ミ ティブ ロジッ ク  オブジェク トのみのハイライ トが解

除されます。 

• [Schematic] : 選択したロジッ クを含む [Schematic] ウ ィンド ウを新規作成します。 

• [Show Connectivity] : 選択したインスタンスに接続されているネッ ト をすべて選択します。 表

示されているネッ トすべてが接続されているインスタンスを連続して選択しても、 このコマン

ドを正し く実行できます。 再度実行する と、 ロジッ ク  コーンに含まれる次のグループの拡張

ネッ トがハイライ ト されます。 

• [Show Hirarchy] : デザイン全体を表示する  [Hierarchy] ウ ィンド ウを表示します。 このウ ィン

ド ウでは、 モジュール内の選択されたオブジェク トがハイライ ト されています。

• [Fix Instances] : ロジッ クの配置を固定します。ロジッ クが固定される と、ユーザー割り当てと

見なされ、 デフォルトで ISE にエクスポート されます。

• [Unfix Instances] : 固定した配置を解除します。 

• [Highlight] : 現在選択されているハイライ ト色を使用して選択したオブジェク ト をハイライ ト

します。

• [Highlight with] : 選択したハイライ ト色を使用して選択したオブジェク ト をハイライ ト しま

す。

• [Mark] : [Device] ウ ィンド ウで、 選択されたエレ メン トすべてにマーク  シンボルを付けます。

• [Select] : ポップアップ メニューが表示されるロケーシ ョ ンで選択可能なオブジェク ト を リ ス

ト したサブメニューを開きます。 これは、 重なったオブジェク ト間で特定のオブジェク ト を選

択する と きに役立ちます。

• [View] : コマンドのサブメニューを開きます。 

♦ [Zoom] : 現在の表示または選択したオブジェク ト を拡大表示または縮小表示するコマン

ドのサブメニューを表示します。

♦ [Fit Selection] : 選択したオブジェク トすべてを含むよ うに表示をフ ィ ッ ト させます。

♦ [Fit Highlight] : ハイライ ト したオブジェク トすべてを含むよ うに表示をフ ィ ッ ト させま

す。

♦ [Fit Markers] : マークを付けたオブジェク トすべてを含むよ うに表示をフ ィ ッ ト させま

す。

♦ [Options] : [PlanAhead Options] ダイアログ ボッ クスを表示します。 このダイアログ ボッ

クスは、 [Tools] → [Options] でも開く こ とができます。 詳細は、 「PlanAhead の表示オプ

シ ョ ンのカスタマイズ」 を参照して ください。

♦ [Refresh] : 表示を再描画し、 最新の情報に更新します。

• [Metric] : 表示可能なすべてのメ ト リ ッ クを リ ス トするサブメニューを開きます。詳細は、「I/O
ピン配置およびクロ ッ ク  ロジッ クの解析」 を参照してください。
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I/O ピン配置およびクロック  ロジックの解析

詳細は、 第 4 章 「I/O ピンの配置」 を参照してください。

RTL デザインの解析

詳細は、 第 6 章 「RTL デザインの作成および解析」 を参照してください。 

合成されたデザインの解析

デザイン リソースおよびデバイス使用率の統計レポート

デバイス リソース使用率の統計レポート

PlanAhead にはデザインで使用されるデバイス  リ ソースの見積り数をレポートする機能があ り ま

す。 デバイス使用率の統計は次のよ うに表示または出力するこ とができます。

1. [Physical Hierarchy] ウ ィンド ウで、 [ROOT] デザインまたは Pblock をク リ ッ ク します。 

Pblock プロパティが [Pblock Properties] ウ ィンド ウに表示されます。 

2. [Pblock Properties] が表示されない場合は、 [ROOT] または Pblock を右ク リ ッ ク し、 ポップ

アップ メニューで [Pblock Properties] をク リ ッ ク します。

[Pblock Properties] ウ ィンド ウにはタブが 5 つあ り ますが、 この章ではそのうち 4 つについて

説明します。

3. [Statistics] タブをク リ ッ ク します。

[Statistics] タブには、 さまざまなデバイス  リ ソースのデバイス全体での使用状況、 キャ リー

チェーン数と最長チェーンの長さ、RPM 数と最大サイズ、ク ロ ッ ク名と ク ロ ッ クが供給されて

図 8-38 : [Physical Hierarchy] ウィンドウで [ROOT] を選択
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いるインスタンスの数、 I/O 使用率、 および信号とプリ ミ ティブ インスタンスの数などの重要

なデザイン情報が表示されます。

見積り階層デバイス使用率統計のエクスポート

表示されているデータは表計算式ファイルに保存できます。 PlanAhead では階層形式のレポート を

生成するこ とができます。 各レベルにある各モジュールに対し リ ス ト される見積り値をレポートす

るための階層数を定義できます。

1. [Export Statistics] ボタンをク リ ッ ク し、 データを表計算ファイルにエクスポート します。

図 8-39 : [Pblock Properties] ウィンドウ :[Statistics] タブ

図 8-40 : [Export Statistics] ボタン
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[Export Pblock Statistics] ダイアログ ボッ クスが表示されます。

[Export Pblock Statistics] ダイアログ ボッ クスには次のオプシ ョ ンがあ り ます。

♦ [File Name] : 表計算ファイルの名前および保存場所を入力します。

♦ [Format] : XML またはマイクロソフ トの Excel フォーマッ トの出力ファイルを選択しま

す。

♦ [Levels] : レポートで表示される階層のレベル数を設定します。

♦ [Reports to Generate] : Pblock プロパティ統計からの情報タイプを定義します。

2. エクスポート したファ イルに対しオプシ ョ ンを設定します。

3. [OK] をク リ ッ ク します。

デザイン リソース統計のレポート

PlanAhead にはデザインに含まれるデバイス  リ ソースの見積り数をレポートする機能があ り ます。 

同じタイプの見積り統計情報が RTL デザイン プロジェク トから表示およびエクスポートできま

す。 詳細は、 「RTL デザインのエラボレートおよび解析」 を参照してください。

デザイン リ ソース統計は次のよ うに表示されます。

図 8-41 : [Export Pblock Statistics] ダイアログ ボックス
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1. 最上位モジュールまたはインスタンス  モジュールを [Netlist] ウ ィンド ウで選択します。 

ネッ ト リ ス ト またはインスタンスのプロパティがプロパティのウ ィンド ウに表示されます。 

2. 表示されない場合は、モジュールを右ク リ ッ ク し、ポップアップ メニューで [Net Properties] ま
たは [Instance Properties] をク リ ッ ク します。

[Net Properties] には、デフォルトで [Statistics] タブが 1 つ表示されます。[Instance Properties]
には、 5 つのタブがあ り ます。

3. [Instance Properties] を表示するには [Statistics] タブをク リ ッ ク します。

図 8-42 : 最上位モジュールが選択されている [Netlist] ウインドウ
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[Statistics] タブには、プリ ミ ティブ インスタンス数、インターフェイス信号数、クロ ッ ク名、ク

ロ ッ ク信号を受けるインスタンス数、キャ リー チェーン数およびその最大長といった重要なデ

ザイン情報が表示されます。

階層デザイン リソース統計のエクスポート

表示されているデータは表計算式ファイルに保存できます。 PlanAhead では階層形式のレポート を

生成するこ とができます。 各レベルにある各モジュールに対し リ ス ト される見積り値をレポートす

るための階層数を定義できます。

1. [Export Statistics] ボタンをク リ ッ ク し、 データを表計算ファイルにエクスポート します。

図 8-43 : ネッ ト リス ト  リソース統計 

図 8-44 : [Export Statistics] ボタン
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[Export Netlist Statistics] ダイアログ ボッ クスが表示されます。

[Export Netlist Statistics] ダイアログ ボッ クスには次のオプシ ョ ンがあ り ます。

[File Name] : 表計算ファイルの名前および保存場所を入力します。

[Format] : XML またはマイ クロソフ トの Excel フォーマッ トの出力ファイルを選択します。

[Levels] : レポートで表示される階層のレベル数を設定します。

[Reports to Generate] : Pblock プロパティ統計からの情報タイプを定義します。

2. エクスポート したファ イルに対しオプシ ョ ンを設定します。

3. [OK] をク リ ッ ク します。

論理階層の表示

詳細は 「[Device] ウ ィンド ウの使用」および 「[Hierarchy] ウ ィンド ウの使用」 を参照してください。

階層接続の解析

PlanAhead は、 さまざまな論理モジュール間の接続をビジュアルに確認できる機能を含む、 論理階

層を確認する機能を豊富に備えています。場合によっては、最上位ネッ ト リ ス ト  インスタンスで構

図 8-45 : ネッ ト リス ト  リソース統計のエクスポート
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成されるフロアプランをまず作成して、 次に示すよ うに接続フローをビジュアルに確認したほうが

便利なこ とがあ り ます。 

バンドル ネッ トは、 モジュール間で接続が激しいこ とを明らかに示します。 この色と太さは、 ネッ

トの信号数によって設定できます。 バンドル ネッ ト を選択する と、 [Net Bundle Properties] にネッ

ト情報が表示されます。

階層を移動し、 大きな ト ップ レベルのインスタンスのサブモジュールを作成するこ と もできます。

ト ップレベルのフロアプランは I/O ピン配置コンフ ィギュレーシ ョ ンの質を示すもので、 煩雑にな

りかねない配線の問題を識別するのに役立ちます。 各モジュールのリ ソース統計およびクロ ッ ク要

件も、 潜在的な配置問題を知るために確認できます。

ト ップレベルのフロアプラン作成の詳細は 「Pblock の自動コマンドの使用」 を参照してください。

デザイン ルール チェ ック  (DRC) の実行

PlanAhead には、DRC バッチ コマンドのセッ トが含まれており、ISE ソフ ト ウェアの実行前にデザ

インの整合性を確認できます。 DRC は実行されるロジッ ク  チェッ クのタイプ別に分類されていま

す。 

I/O ポートおよびクロック  ロジック  DRC の実行 
DRC ルールの多くは I/O ピン割り当てと クロ ッ ク  ロジッ クに関連しています。I/O ポートおよびク

ロ ッ ク  ロジッ クに関連した DRC の詳細は第 4 章 「I/O ピンの配置」 を参照してください。 

ネッ ト リス トおよびフロアプラン DRC の実行

各ルールは、 次のよ うに選択および実行されます。

1. [Tools] → [Run DRC] をク リ ッ ク します。

図 8-46 : 最上位デザイン接続の表示
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[Run DRC] ダイアログ ボッ クスが表示されます。

2. [Results Name] フ ィールドを表示または編集します。 こ こで指定した名前が [DRC Results]
ウ ィンド ウに表示されるので、デバッグ時に区別しやすい名前を付けます。この名前は出力ファ

イル名と しても使用されます。

3. [Rules to Check] グループ ボッ クスの各デザイン オブジェク トで、 チェッ クするルールの

チェッ クボッ クスをオンにします。 各ルールの詳細は、 「DRC ルールについて」 を参照してく

ださい。

♦ [Expand All] ボタンをク リ ッ クするか、各カテゴ リ またはデザイン オブジェク トの横のプ

ラス記号 (+) をク リ ッ クする と、 階層が展開します。

♦ すべての DRC を実行する場合は、 デザイン オブジェク トの横のチェッ クボッ クスをオン

にします。個別のルールを実行する場合は、その横のチェッ ク  ボッ クスをオンにします。す

べてのデザイン オブジェク トのすべてのルールをチェッ クする場合は、[All Rules] の横の

チェッ クボッ クスをオンにします。

4. [OK] をク リ ッ クする と、 選択した項目がチェッ ク されます。

図 8-47 : [Run DRC] ダイアログ ボックス :ネッ ト リス トおよびフロアプランのルール
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DRC エラーの表示

DRC が完了する と、 結果が表示されます。 

違反は、[DRC Results] で個別に展開表示されます。エラーは赤いアイコン、警告は茶色のアイコン、

情報メ ッセージは黄色のアイコンで区別されています。

[DRC Results] のリ ス トでエラーをどれか選択する と、そのエラーの情報が [Properties] に表示され

ます。 [Properties] のリ ンクをク リ ッ クする と、 [Device]、 [Netlist]、および [Schematic] で、違反が

発生したデザイン エレ メン トがハイライ ト表示されます。

エラーは、 修正する と  [DRC Results] ウ ィンド ウに表示されなくな り、 DRC が再実行されます。

[Run DRC] コマンドを実行し、 エラーが検出されるたびに、 新しい結果のタブが [DRC Results]
ウ ィンド ウに追加されます。結果のファイルも個別に PlanAhead の起動ディ レク ト リに出力されま

す。

DRC ルールについて

次の表に、 デザイン オブジェク ト ごとの DRC ルール、 目的、 重要性を示します。 

• 「フロアプランの Pblock のルール」

• 「バンクのルール」

• 「DCI のルール」

• 「ClkBuf のルール」

• 「DSP48 のルール」

• 「RAMB16 のルール」

• 「ネッ ト リ ス トのルール」

図 8-48 : DRC Results
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メモ : グローバル ク ロ ッ ク  ルール、 IOB ルール、バンク  I/O 規格ルールについては 「I/O ポートお

よびクロ ッ ク  ロジッ ク  DRC の実行」 を参照してください。

フロアプランの Pblock のルール

バンクのルール

表 8-3 : フロアプランの Pblock のルール

ルール名 ルールの略称 説明 重要性

Pblock overlap FLBO 重なり合った Pblock の長方形のチェッ

ク。

情報

Pblock Partition FLBP LUT から  MUXCY および MUXFx への

接続が Pblock のパーティシ ョ ンで切断

されていないかをチェッ ク。

エラー

Longest Carry 
Chain Height

LCCH Pblock の高さに、 割り当てられたキャ

リー チェーンで一番長いチェーンが収ま

るかど うかのチェッ ク。

警告

Resource 
Utilization

UTLZ 割り当てられたロジッ クに対して、

Pblocks のリ ソースが十分であるかを

チェッ ク。

警告 (スライス

ロ ジ ッ ク の場

合)

エラー (非スラ

イス  ロジッ ク

の場合)

Area Group Tile 
Argument

FLBA AREA_GROUP 制約のサイ ト範囲が 
CLB グ リ ッ ド と一致しているかど うか

をチェッ ク。

警告

表 8-4 : DCI カスケードのルール

ルール名 ルールの略称 説明 重要性

DCI Cascade 
Checks

DCIC0 I/O バンクが DCI カスケード  マスタ と し

て使用されているかど うかをチェッ ク。

バンクには VRN/VRP を必要とする  I/O 
規格が設定されているターミナルが必

要。

エラー

DCI Cascade 
Checks

DCIC1 DCI カスケードおよびスレーブ I/O バン

クが同じ  I/O 列にあるこ とをチェッ ク。

エラー

DCI Cascade 
Checks

DCIC2 DCI カスケード  マスタ  バンクからス

レーブ バンクまでの配線が DCI カス

ケード  チェーンの一部であるこ とを

チェッ ク。

エラー

DCI Cascade 
Checks

DCIC3 I/O バンクが DCI カスケード  マスタまた

はスレーブと して使用可能であるこ とを

チェッ ク。

エラー
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バンク  I/O 規格ルールの詳細は 「バンク  I/O 規格のルール」 を参照してください。

DCI のルール

DCI Cascade 
Checks

DCIC4 DCI カスケード  スレーブ I/O バンクにマ

スタが 1 つしかないこ とをチェッ ク。

エラー

DCI Cascade 
Checks

DCIC5 DCI_CASCADE 制約に有効なバンク番

号のみが含まれているこ とをチェッ ク。

無効なバンク番号はレポート されます。

エラー

表 8-5 : IDelay 制御のルール

ルール名 ルールの略称 説明 重要性

IDelayCtrl 
Checks

IDLYCTRL0 IDelayCtrl インスタンスを含む I/O バン

クに少なく と も  1 つの IODelay インスタ

ンスがあるこ とをチェッ ク。

エラー

IDelayCtrl 
Checks

IDLYCTRL1 LOC 制約が設定されている  IdelayCtrl 
インスタンスがデザインに 1 つしかない

こ とをチェッ ク。

エラー

IDelayCtrl 
Checks

IDLYCTRL2 IDelay インスタンスが I/O バンクに 1 つ
あ り、 そのバンクにロッ ク されている  
DelayCtrl インスタンスが 1 つあるこ と、

または LOC 制約の付いていない 
DelayCtrl インスタンスがバンクに 1 つ
あるこ とをチェッ ク します。

エラー

表 8-6 : IDelay 制御のルール

ルール名 ルールの略称 説明 重要性

DCI Cascade 
with part 
compatibility

DCICPC ユーザーに UCF ファ イルをほかの互換

性のあるパーツに読み込み、 DRC を手

動で実行して DCI カスケードが有効で

あるこ とを確認するよ う警告。

警告

表 8-4 : DCI カスケードのルール

ルール名 ルールの略称 説明 重要性
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ClkBuf のルール

IOB ルールの詳細は 「IOB のルール」 を参照して ください。

DSP48 のルール

表 8-7 : IDelay 制御のルール

ルール名 ルールの略称 説明 重要性

BufR & BufIO 
Locations

BUFRIOC0 BUFR および BUFIO インスタンスが同

じタイルに配置されているこ とをチェッ

ク。

エラー

BufR & BufIO 
Locations

BUFRIOC1 BUFR および BUFIO インスタンスをタ

イルに一緒に配置する余裕があるこ とを

チェッ ク。

エラー

表 8-8 : DSP48 ルール

ルール名 ルールの略称 説明 重要性

DSP output 
registers

DPOR DSP48 の出力側にレジスタがあ り ます

が、 このレジスタは同期制御して使用

する必要があ り ます。 (Virtex-4 の場合)

情報

DSP input 
registers

DPIR DSP48 の入力側にレジスタがあ り ます

が、 このレジスタは同期制御して使用

する必要があ り ます。 (Virtex-4 の場合)

情報

DSP output 
pipelining

DPOP DSP48 の出力側にレジスタがあ り ます

が、 このパイプラインのメカニズムを

使用する と、 パフォーマンスが向上し

ます。 (Virtex-4 の場合)

情報

DSP multiplier 
output pipelining

DMOP DSP48 出力はパイプライン化されてい

ません。 パイプラインされている とパ

フォーマンスが向上します。

警告

DSP input 
pipelining

DPIP DSP48 の入力側にレジスタがあ り ます

が、 このパイプラインのメカニズムを

使用する と、 パフォーマンスが向上し

ます。 (Virtex-4 の場合)

情報
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RAMB16 のルール

ネッ ト リス トのルール

タイ ミ ング解析の実行

TimeAhead について

TimeAhead はデザイン作成の段階に応じてさまざまなモードで使用できます。パスの遅延を早い段

階で予測するこ とでフロアプランを容易にするだけでなく、詳細なパス  ト レース、デバッグ、およ

び制約の割り当てにも役立ちます。TimeAhead には、[Estimated] と  [No Interconnect] の 2 つのモー

ドがあ り ます。 フロアプランで割り当てられた制約が Pblock や配置制約のよ うに物理的であるほ

ど、 解析結果も正確になり ます。

表 8-9 : RAMB16 のルール

ルール名 ルールの略称 説明 重要性

RAMB16 output 
registers

RBOR RAMB16 の出力側にレジスタがあ り ま

すが、 このレジスタは同期制御して使用

する必要があ り ます。 (Virtex-4 の場合)

情報

表 8-10 : ネッ トのルール

ルール名 ルールの略称 説明 重要性

Driverless Nets NDRV 各ネッ トに正しいド ライバ ピンがある

こ とをチェッ ク。

警告

表 8-11 : Instance Rules

ルール名 ルールの略称 説明 重要性

Black Box 
Instances

INBB ブラ ッ クボッ クス  (ネッ ト リ ス トの未定

義ロジッ ク ) がないこ とをチェッ ク。

警告
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TimeAhead の実行

1. タイ ミ ング解析は、 次の方法のいずれかで実行できます。

♦ [Tools] → [Run TimeAhead] をク リ ッ ク します。

♦ [Run TimeAhead] ボタンをク リ ッ ク します。 

[Run TimeAhead] ダイアログ ボッ クスが表示されます。

2. 編集可能なフ ィールドを確認し、 必要があれば変更します。

♦ [Results Name] : TimeAhead の実行結果はこ こで指定した名前で [Timing Results] ウ ィ

ンド ウに表示されます。 

♦ [Interconnect] : 使用するタイマのモードを指定します。 次の 2 つのオプシ ョ ンがあ り ま

す。

- [Estimated] : 擬似配線を基に、 ロジッ クおよび標準の配線遅延を見積も り ます。

- [None] : すべてのロジッ ク  プリ ミ ティブ遅延を、配線遅延の見積も り を使用せずに見

積も り ます。 このレポートは、 ISE で MAP を実行した後の TRACE レポート と一致

します。

♦ [Speed Grade] : デバイスのスピード  グレードをテス トするため調整します。

図 8-49 : [Run TimeAhead] ボタン

図 8-50 : [Run TimeAhead] ダイアログ ボックス :
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♦ [Filter Options] : TimeAhead を実行するパスのリ ス ト を絞り込むこ とができます。 ワイル

ドカード  (*) を使用する と、 複数の信号を指定できます。

- [From Pins/Instances] : このピンまたはインスタンス名をソースとするパスを選択し

ます。

- [Through Pins/Instances] : このピンまたはインスタンス名を通過するパスを選択しま

す。

- [To Pins/Instances] : このピンまたはインスタンスを終点とするパスを選択します。 

- [Sort Paths By] : 制約グループ順またはスラ ッ ク順にタイ ミ ング レポート を並べ替え

ます。

- [Transition] : 立ち上がり または立ち下がり を指定します。

- [Setup/Hold Mode] : ホールド解析またはセッ ト アップ解析を指定します。

- [Number of Paths per Clock Group] : 各制約にリ ス トするパスの数を指定します。

- [Number of Paths per Endpoint] : 各パス  エンドポイン トでレポート されるパスの数

を指定します。

3. 項目を指定して [OK] をク リ ッ クする と、 TimeAhead が起動します。

TimeAhead 解析からパスを除外する方法

TimeAhead では、[Filter Options] のフ ィールドで記号を使う こ とで、オブジェク ト をタイ ミ ング解

析から除外できます。

除外の方法

名前 (完全な名前またはワイルド  カード付きの名前) に感嘆符 (!) を付ける と、その条件に合うオブ

ジェク トが除外されます。 

たとえば次のよ うに指定したと します。

[From Pins/Instances] : pblock_1/*

[To Pins/Instances] : !pblock_1/*

TimeAhead 解析には、始点が pblock_1 のインスタンスで、終点が pblock_1 のインスタンスでない

パスが含まれます。

含めるパスと除外するパスを同時に指定する方法

解析に含めるパス と除外するパスを同時に指定できます。

たとえば次のよ うに指定したと します。

[From Pins/Instances] : pblock_1/*

[To Pins/Instances] : pblock_2/* !pblock_3/*

pblock_2 と  pblock_3 に共通のインスタンスがあれば (pblock_3 が pblock_2 内にある場合など)、
同じインスタンスを終点とするパスはレポートに含まれません。

複雑なケース

複雑なケースについては、 次の規則に従ってください。

含める条件が指定されている場合に除外条件が指定されている と、含まれた結果から除外されます。

除外条件のみが指定されている場合は、 ネッ ト リ ス トの リーフレベルのインスタンスはすべて含ま

れます。
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タイ ミ ング結果の解析

[Timing Results] ウ ィンド ウには TimeAhead または ISE の TRACE タイ ミ ング解析ツールからの

タイ ミ ング結果を表示するこ とができます。 [Timing Results] ウ ィンド ウにパスを表示するには、

TimeAhead または TRCE のいずれかを実行する必要があ り ます。 このウ ィンド ウには、 「タイ ミ ン

グ解析の実行」 で説明する[Run TimeAhead] ダイアログ ボッ クスで定義した条件を満たすパスが

含まれます。 TRCE 結果がインポート される と き、 または TimeAhead がデフォルト  オプシ ョ ンで

実行される と き、 パスは制約別にソート されリ ス ト されます。 

TimeAhead が完了するか、 TRCE の結果がインポート される と、 [Timing Results] ウ ィンド ウが表

示されます。

こ こで、 確認、 並べ替え、 特定のパスやインスタンスの選択ができます。 

[Timing Results] ウ ィンド ウには、 各パスに関する次の情報が表示されます。

♦ [Name] : リ ス ト されているパスの制約名が表示されます。

♦ [ID] : 連続した番号で、 基の順序に並べ替えられる際に使用できます。

♦ [Type] : パスがセッ ト アップまたはホールドに関連しているかを表示します。

♦ [Slack] : パスの正または負のスラ ッ クの合計です。

♦ [From] : パスのソース  ピンです。

♦ [To] : パスのデスティネーシ ョ ン ピンです。

♦ [Total Delay] : パスで予測される遅延の合計です。

♦ [Logic Delay] : ロジッ ク遅延が起因の遅延のみが表示されます。

♦ [Net %] : インターコネク トの配置が起因の遅延の割合。

♦ [Stages] : ソース とデスティネーシ ョ ン両方が全体の遅延に影響を及ぼすパス上のインス

タンスの合計これは、 ISE におけるロジッ ク  レベルの計算方法と異なる場合があ り ます。

メモ : TimeAhead では、 キャ リー チェーン インターコネク トがロジッ クの独立した段と して数え

られます。

タイ ミング レポートの並べ替え

列のヘッダをク リ ッ クする と、 リ ス トが並べ替えられます。たとえば、 [Slack] 列のヘッダをク リ ッ

クする と、 スラ ッ クの順番で並べ替えられます。 [Slack] 列をも う一度ク リ ッ クする と、逆の順番に

並べ替えられます。

図 8-51 : TimeAhead のタイ ミング結果
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最初に並べ替えた後で Ctrl キーを押しながら別の列のヘッダをク リ ッ クする と、次にその列で並べ

替えられます。 並べ替えに使用する列の数に制限はあ り ません。

も う一度 Ctrl キーを押して列ヘッダをク リ ッ クする と、 その列の並べ替えが解除されます。

パスのリストのフラッ ト化

デフォルトでパスは制約別に分類されています。 [Timing Results] ウ ィンド ウのツールバーの

[Group by Constraint] ボタンをク リ ッ ク して、 すべてのパスを リ ス ト表示するこ とができます。 

このボタンで、 制約別に分類された リ ス ト とすべてのパスのリ ス トの表示切替ができます。

タイ ミング レポートからのパスの削除

ク リ ティカル パスを見やすくするために、パスを選択してタイ ミ ング レポートから削除できます。 

1. タイ ミ ング レポートから削除するパスを選択します。複数のパスを選択するには、Shift キーま

たは Ctrl キーを押しながらパスをク リ ッ ク します。

2. [Delete] キーを押すか、[Timing Results] ウ ィンド ウで右ク リ ッ ク して表示されるポップアップ

メニューで [Delete] をク リ ッ ク します。

図 8-52 : [Slack] 列と  [Total Delay] 列で並べ替えられた、 タイ ミング結果のリスト

図 8-53 : [Group by Constraint] ボタン
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パスの詳細の表示

リ ス トでパスを選択する と、[Path Properties] ウ ィンド ウにそのパスの情報が表示されます。すべて

のロジッ ク  エレ メン トの詳細な遅延情報やハイパーリ ンクが表示されます。 

このレポートのフォーマッ トは TRCE レポートに似ています。

デフォルトでは、 パスを選択する とそのパスのすべてのインスタンスも選択されます。 レポートに

青のハイパーリ ンクで表示されているオブジェク ト をク リ ッ クする と、 [Netlist] や [Device] など、

ほかのウ ィンド ウでもそのオブジェク トが選択されます。

Shift キーまたは Ctrl キーを使用する と、複数のパスを選択できます。選択されたパスすべてのイン

スタンスすべてが選択されますが、 [Path Properties] ウ ィンド ウには最初に選択されたパスの情報

のみが表示されます。

タイ ミング パス レポートのワークスペースでの表示

タイ ミ ング パス  レポート を見やすくするために、ワークスペースに個別に表示できます。レポート

を表示するには、 次の手順に従います。

1. レポート を表示するタイ ミ ング パスを選択します。

2. [View Path Report] ポップ アップ メニュー コマンドまたは [Timing Results] ウ ィンド ウ  ツー

ルバーの [View timing path report in the workspace] ボタンをク リ ッ ク します。

図 8-54 : [Path Properties] ウィンドウ :[Report] タブ

図 8-55 : [View path timing report in the workspace] ボタン
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[Find]コマンドを使用したオブジェク トの検索

PlanAhead では、 [Find] コマンドを使用してインスタンスまたはネッ ト を検索できます。 [Find] コ
マンドを実行するには、 次の手順に従います。

1. [Edit] → [Find] または [Find] ボタンをク リ ッ ク します。 

[Find] ダイアログ ボッ クスが表示されます。 

2. 編集可能なフ ィールドを確認し、 必要があれば変更します。

♦ [Find] : 検索するオブジェク トのタイプ ([Instances]、 [Nets]、 [Pblocks] など) を選択しま

す。 

♦ [Netlist] : RTL または合成されたネッ ト リ ス トのいずれかを選択します。

♦ [Criteria] : 選択したオブジェク トのタイプに合った検索パラ メータが表示されます。 

最初のフ ィールドでは、 [Name]、 [Status]、 [Type]、 [Parent Pblock]、 [Module]、 [Primitive
count] などから、 検索する属性を指定します。

2 番目のフ ィールドでは、 [matches]、 [doesn’t match]、 [contains]、 [doesn’t contain] から、

検索のブール型を指定します。

3 番目のフ ィールドには、 検索文字列を入力します。 アスタ リ スク  (*) を使用できます。

3. オプシ ョ ンで、 検索条件を追加したり、 異なるタイプのオブジェク ト を同時に検索するための

条件を指定できます。[More] ボタンをク リ ッ クする と、ダイアログ ボッ クスに検索条件の行が

図 8-56 : [Find] ボタン

図 8-57 : [Find] ダイアログ ボックス
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追加されます。最初のフ ィールドでは [AND] または [OR] を選択し、条件を絞り込むのか、異

なるタイプのオブジェク トの検索かを指定します。 次の図では、 [AND] が指定されています。

4. 次のよ うに [OR] を使用する と、 複数のオブジェク ト を同時に検索できます。

5. [Fewer] ボタンをク リ ッ クする と、 検索条件の行が削除されます。

6. [OK] をク リ ッ クする と、 検索が実行されます。

条件を満たした結果すべてが、 [Find Results] ウ ィンド ウに表示されます。

図 8-58 : 検索条件を絞り込んだオブジェク トの検索

図 8-59 : 複数のオブジェク ト  タイプの同時検索
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[Find Results] ウィンドウの使用

[OK] をク リ ッ ク して検索を実行する と、 指定した検索条件に一致するオブジェク トが 
[Find Results] ウ ィンド ウに表示されます。 

[Find] コマンドを実行するたびに、[Find Results] ウ ィンド ウに新しいタブが追加されます。タブに

は検索したオブジェク ト とその検出数が表示されます。

[Find Results] ウ ィンド ウではオブジェク ト を直接選択できます。検索結果のリ ス トからオブジェク

ト を選択する と、ほかの PlanAhead ウ ィンド ウでもそのオブジェク トが選択されます。Shift キーま

たは Ctrl キーを使用する と、複数のエレ メン ト を選択できます。ポップアップ メニューを使用する

と、 選択したエレ メン トにコマンドを実行できます。

列のヘッダをク リ ッ クする と、 リ ス トが並べ替えられます。最初に並べ替えた後で Ctrl キーを押し

ながら別の列のヘッダをク リ ッ クする と、 次にその列で並べ替えられます。

検索結果名の隣の X マークをク リ ッ クする と  [Find Results] ウ ィンド ウが閉じます。

図 8-60 : [Find Results] ウィンドウ
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インプリ メンテーシ ョ ン結果の解析

本章は、 次のセクシ ョ ンで構成されています。

• 「ISE の配置およびタイ ミ ング結果のインポート 」

• 「配置およびタイ ミ ング結果の解析」

• 「ロジッ ク接続の表示」

• 「選択したオブジェク トのハイライ ト 」

• 「配置されたモジュールのハイライ ト 」

• 「選択したオブジェク トのマーク」

• 「デザイン メ ト リ ッ クの表示」

  ISE の配置およびタイ ミング結果のインポート  

New Project ウィザードを使用したISE 配置およびタイ ミング結果のイン
ポート

新規プロジェク ト を作成し、 そのプロジェク トに、 ネッ ト リ ス ト 、 タイ ミ ングおよび配置レポート

ファ イルを ISE® のインプリ メンテーシ ョ ンからインポートするこ とができます。 ISE インプ リ メ

ンテーシ ョ ン結果をインポートする新規プロジェク トの作成については 「ISE 配置およびタイ ミ ン

グ結果を使用したプロジェク トの作成」 を参照して ください。

ISE の配置およびタイ ミング結果を PlanAhead からインポート

ISE の配置およびタイ ミ ング結果をインポート し、デザインの解析に使用できます。どの PlanAhead
ô 実行からでも簡単に結果をインポートできます。 

デザイン インプリ メンテーシ ョ ンの詳細は、 「実行結果のインポート 」 を参照してください。

ISE の配置およびタイ ミング結果を PlanAhead 環境外からインポート

PlanAhead 以外でインプリ メン ト された結果をインポートするには、 [File] → [Import Placement]
および [File] →[Import TRCE Results] コマンドを使用してください。ISE インプリ メンテーシ ョ ン

結果のインポートの詳細は、「ISE インプ リ メンテーシ ョ ン結果のインポート 」を参照してください。

ISE の配置およびタイ ミング結果を Project Navigator からインポート

Project Navigator から  PlanAhead を使用している場合、 Project Navigator で [Analyze Timing
/Floorplan Design] プロセスを実行する と  ISE 配置およびタイ ミ ング結果は自動的にインポート さ
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れます。PlanAhead を使用して前回の実行からの ISE 配置または TRCE タイ ミ ング結果をインポー

トするには、[File] → [Import Placemen] または [File] → [Import TRCE Results] をク リ ッ ク します。 

詳細は、 第 5 章 「Project Navigator からの PlanAhead の使用」 を参照してください。

配置およびタイ ミング結果の解析

ザイリンクス TRCE の結果の表示

PlanAhead ではザイ リ ンクス  trce コマンドで生成されたタイ ミ ング レポート をインポートするこ

とができます。 インポートする と、 すべての信号ト レース機能およびパスの選択、 ハイライ ト 、 ト

レースを含む表示機能を使用して TRCE の結果を解析できます。[Timing Results] ウ ィンド ウでは、

インポート されたタイ ミ ング レポートすべてが個別にタブ表示され、タブにはユーザーが指定した

名前が表示されます。 

TRCE 結果のインポートの詳細は、 「実行結果のインポート 」 および 「既存プロジェク トへの ISE
TRCE タイ ミ ング結果のインポート 」 を参照してください。

[Timing Results] ウ ィンド ウの詳細は 「配置およびタイ ミ ング結果の解析」 を参照してください。

[Device] ウィンドウでのタイ ミング パスの表示

[Timing Results] ウ ィンド ウでパスの行を指定する と、 タイ ミ ング パスをワークスペースの

[Device] ウ ィンド ウに表示できます。パスは [Device] ウ ィンド ウでハイライ ト されます。複数のパ

スを選択でき、 パスのインスタンスもすべて選択され、 ハイライ ト されます。 
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[Schematic] ウィンドウでのタイ ミング パスの表示

[Timing Results] のポップアップ メニューで [Schematic] をク リ ッ クする と、 PlanAhead に

[Schematic] ウ ィンド ウが表示され、 選択されたパスに含まれるインスタンスがすべて表示されま

図 9-1 : [Device] ウィンドウでハイライ ト されたタイ ミング パス
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す。[Schematic] ウ ィンド ウにはインスタンスがはっき り と表示されるだけでなく、階層モジュール

も表示されます。 

パスの [Schematic] ウ ィンド ウには、 オブジェク トがすべて表示されます。 個々のロジッ ク  インス

タンスの [Schematic] ウ ィンド ウには、 選択したインスタンスだけが表示されます。

パスのグループに含まれるインスタンスはすべてこの要領で表示されるため、 フロアプランでどの

モジュールがグループ化されるかがわかり ます。 [Schematic] ウ ィンド ウのポップアップ メニュー

の [Pblock creation] コマンドで、簡単に Pblock への割り当てができます。 [Schematic] ウ ィンド ウ

の詳細は、 「[Schematic] ウ ィンド ウの使用」 を参照してください。

ロジック接続の表示

[Show Connectivity] コマンドの使用

[Show Connectivity] コマンドを使用する と、選択したエレ メン トに接続されたネッ トがすべてハイ

ライ ト されます。 このコマンドは次の方法で使用します。 

1. ネッ ト、 Pblock、 インスタンス、 またはこれらの組み合わせを選択します。

2. ポップアップ メニューで [Show Connectivity] をク リ ッ ク します。

図 9-2 : [Schematic] ウィンドウに表示されたタイ ミング パス
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たとえば、インスタンスまたは Pblock を選択した場合は、これらのエレ メン トに接続したネッ トが

すべてハイライ ト されます。 

[Show connections for selected instances] ボタンをオンにする と、オブジェク ト を新し く選択するた

びに続けて [Show Connectivity] コマンドを実行できます。 

ロジックと  Pblock の接続表示

[Show Connectivity] コマンドを連続して実行する と、 ロジッ ク  コーンを連続して選択および展開

表示できます。 

1. ネッ ト、 Pblock、 インスタンス、 またはこれらの組み合わせを選択します。

2. ポップアップ メニューで [Show Connectivity] をク リ ッ ク します。 上述したよ うに、 選択した

エレ メン トに接続されたネッ トがすべてハイライ ト されます。

3. ポップアップ メニューでも う一度 [Show Connectivity] をク リ ッ ク します。 ネッ トに接続され

たインスタンスのセッ トが選択されます。 

4. ポップアップ メニューでも う一度 [Show Connectivity] をク リ ッ ク します。 選択されたインス

タンスに接続された、 次のレベルのネッ トがハイライ ト されます。 

図 9-3 : [Device] ウィンドウに表示されたネッ トの接続状況

図 9-4 : [Show connections for selected instances] ボタン
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この方法で、 特定のインスタンスまたは I/O ポート までロジッ クのコーンを簡単に展開表示して選

択できます。

[Schematic] ウィンドウでのロジックの展開表示

[Schematic] ウ ィンド ウを使用し、ロジッ クは階層全体に渡って ト レースできます。 ト レースするイ

ンスタンスのピンをダブルク リ ッ クする と、 信号を展開表示できます。

インスタンスおよびモジュールの接続、 その内容もインタラ クティブに展開表示できます。 

[Schematic] ウ ィンド ウで択されたアイテムは [Device] ウ ィンド ウでもハイライ ト されます。 イン

プリ メンテーシ ョ ンの配置結果をインポートする と、ト レースされたロジッ クが [Device] ウ ィンド

ウで見やすくな り ます。

[Schematic] ウ ィンド ウでのロジッ ク表示の詳細は 「[Schematic] ウ ィンド ウの使用」 を参照してく

ださい。

[Connectivity] タブを使用したロジック  パスのト レース 
[Net Properties] コマンドおよび [Instance Properties] コマンドを実行する と、[Connectivity] タブを

含むそれぞれのプロパティ  ウ ィンド ウが開きます。 このタブでは、選択されたロジッ クが展開表示

されます。 

ロジッ クの ト レースは、 次の方法で開始します。

図 9-5 : [Schematic] ウィンドウで展開表示されたロジック
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1. ネッ ト またはインスタンスを選択します。

[Net Properties] ウ ィンド ウまたは [Instance Properties] ウ ィンド ウが表示されます。 

2. 表示されない場合は、 ネッ ト またはインスタンスを右ク リ ッ ク し、 ポップアップ メニューで

[Net Properties] または [Instance Properties] をク リ ッ ク します。

上の例では、 RAM B16 インスタンスが選択されています。 [Instance Properties] ウ ィンド ウの

[Connectivity] タブに、このインスタンスに接続されたネッ トすべてが、接続したピンの名前と共に

表示されます。 ネッ トに含まれるピンの数も表示されます。 ネッ ト ごとに表示するにはリ ス トで行

を選択します。

特定のネッ ト をさ らに ト レースするには、 次の手順に従います。

1. [Connectivity] タブのリ ス トで行を選択します。

図 9-6 : [Instance Properties] ウィンドウ
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2. ポップアップ メニューで [Net Properties] コマンドを選択します。

[Net Properties] ウ ィンド ウの [Connectivity] タブに、ネッ トが接続しているすべてのインスタンス

およびピンが表示されます。 この手順を繰り返して、 デザインの任意のロジッ クを確認できます。

選択した項目から前に戻るには [Previous Object] を、 次に進むには [Next Object] の矢印型のツー

ルバー ボタンをク リ ッ ク して ください。 前に戻る と、 項目のハイライ ト表示が解除されます。

選択したオブジェク トのハイライ ト

オブジェク トのハイライ ト

PlanAhead では、オブジェク ト を柔軟に選択してハイライ ト表示できます。ハイライ トする と、1 つ
または複数の色で複数の配置グループを同時に表示できます。 PlanAhead でどこをク リ ッ ク して

も、 ハイライ トは解除されません。 オブジェク ト をいくつでも選択してハイライ トできます。

PlanAhead ではさまざまな方法でロジッ ク  オブジェク ト を選択できます。 選択したオブジェク ト

は、 ほとんどのウ ィンド ウの [Select] → [Highlight] コマンドまたはポップアップ メニューで

[Highlight] をク リ ッ ク してハイライ トできます。 このコマンドは選択されたロジッ クに実行されま

す。 

Pblock ロジッ クをハイライ トする場合は、[Highlight Primitives] コマンドを実行して下位ロジッ ク

をハイライ トできます。詳細は、 「[Select Primitives] コマンドおよび [Highlight Primitives] コマン

ドの使用」 を参照して ください。

オブジェク トのハイライ ト解除

オブジェク トのハイライ ト を解除するには次のいずれかのコマンドを実行します。

• [Select] → [Unhighlight All] をク リ ッ クする とすべてのオブジェク トのハイライ トが解除しま

す。

• [Select] → [Unhighlight Color] をク リ ッ クする と指定した色のハイライ トが解除します。

図 9-7 : [Connectivity] タブでのネッ トのト レース
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• [Unhighlight All] ボタンをク リ ッ ク します。

配置されたモジュールのハイライ ト

[Select Primitives] コマンドおよび [Highlight Primitives] コマンドの使用

XDL 配置をインポート して、[Highlight Primitives] コマンドを実行する と、Pblock およびロジッ ク

モジュールのプリ ミ ティブ ロジッ ク  エレ メン ト を選択してハイライ トできます。 ロジッ ク  モ

ジュールまたは Pblock を選択して [Highlight Primitives] コマンドを実行した後に、 関連した配置

をハイライ トする色を選択できます。 

複数のインスタンスが選択されていれば、すべてに同じ色を指定するこ と も、[Cycle Colors] コマン

ドを使用して選択したモジュールごとに色を変えるこ と もできます。

[Netlist] ウ ィンド ウのモジュールおよびプリ ミ ティブのハイライ ト色は、[Device]、[Schematic]、お
よび [Package] ウ ィンド ウ と同じです。

図 9-8 : [Unhighlight All] ボタン

図 9-9 : [Netlist] と  [Device] ウィンドウのハイライ ト色の一致
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選択したオブジェク トのマーク

オブジェク トのマーク

PlanAhead の [Device] ウ ィンド ウでは、選択したオブジェク トすべてにマークを付けるこ とができ

ます。 マークを付けておく と、 [Device] ウ ィンド ウで小さなオブジェク ト を表示する場合に便利で

す。マークを付けるには [Select] → [Mark] をク リ ッ クするか、Ctrl + M キーを押します。このコマ

ンドは、 [Netlist]、 [Physical Hierarchy] など、 ほかのウ ィンド ウでも使用できます。 

タイ ミ ング パスをマークする と、 始点は緑、 終点は赤、 中間は黄でマーク されます。 

マークの削除

マークは、 次の方法のいずれかで削除できます。

• [Select] → [Unmark All] をク リ ッ ク します。

• [Unmark All] ボタンをク リ ッ ク します。

図 9-10 : [Device] ウィンドウでマークされたシンボル

図 9-11 : [Unmark All] ボタン
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デザイン メ ト リ ッ クの表示 

[Metrics] ウィンドウの使用

PlanAhead の [Metrics] ウ ィンド ウでは、 デザイン メ ト リ ッ クの リ ス トが示され、 デザインで問題

が発生する可能性があるエリ アが定義された色で表示されます。 現時点のメ ト リ ッ クでは、 Pblock
および配置済みデザイン レベルの両方での使用率およびタイ ミ ング チェッ クが含まれています。 

[Metric Properties] ウ ィンド ウには、次に示すよ うに、メ ト リ ッ クの機能の説明とエラーが発生する

可能性がある箇所をハイライ トするために定義された Bin が表示されます。

図 9-12 : [Metrics] ウィンドウ

図 9-13 : [Metric Properties] ウィンドウ :メ ト リ ックの範囲設定
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[Device] ウィンドウでのメ ト リ ッ ク  マップの表示

[Device] ウ ィンド ウにメ ト リ ッ ク  マップを表示するには、 [Metrics] ウ ィンド ウで メ ト リ ッ クを選

択してから  [Show] チェッ クボッ クスをオンにします。 これで、カラー ベースのメ ト リ ッ ク  マップ

が表示されます。 

まず、 スラ ッ クに関連する メ ト リ ッ クを表示するために、 TimeAhead でのタイ ミ ング解析を

[Estimated] モードで実行する必要があ り ます。CLB または BEL 制約タイプのメ ト リ ッ クを表示す

るには、 ISE のインプリ メンテーシ ョ ンによる配置結果をインポートする必要があ り ます。詳細は、

「既存プロジェク トへの配置結果のインポート 」 を参照して ください。

複数のメ ト リ ッ ク  マップを同時に表示するこ と も可能です。

メ ト リ ッ ク  マップの非表示

[Device] ウ ィンド ウでメ ト リ ッ ク  マップを非表示にするには、 [Metrics] ウ ィンド ウでメ ト リ ッ ク

を選択してから  [Hide] ポップアップ メニューまたはツールバーの [Hide Metrics] ボタンをク リ ッ

ク します。

図 9-14 : [Device] ウィンドウでのメ ト リ ッ クの表示

図 9-15 : [Hide Metrics] ボタン 
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[Metrics Results] ウィンドウの使用

[Show] コマンドを使用する と、 メ ト リ ッ クの結果が [Metric Results] ウ ィンド ウに表示されます。

このウ ィンド ウに表示される情報は、 列のヘッダをク リ ッ クする と並べ替えられます。 最初に並べ

替えた後で Ctrl キーを押しながら別の列のヘッダをク リ ッ クする と、次にその列で並べ替えられま

す。 リ ス トの表示順を整えるために、 さまざまな並び替え条件を選択できます。

これらの結果は、 フロアプランが変更される と自動的に更新されます。 Pblock、 CLB、 プロジェク

ト などの別のタ イプの メ ト リ ッ クは、 別の表で表示されます。 それぞれのタ イプは、 [Metrics
Results] ウ ィンド ウ内の個別のタブに表示されます。 

メ ト リ ッ ク範囲の設定

各マップの Bin 範囲は、 [Metrics Properties] ウ ィンド ウで表示できます。

色および範囲は調整可能で、 範囲を定義するために新しい Bin を追加および削除できます。 この場

合、 [Metrics Properties] ウ ィンド ウの [Apply] ボタンをク リ ッ クするか、 右ク リ ッ ク して [Apply
Changes] をク リ ッ ク します。

新しい範囲の Bin を挿入するには、分割する  Bin を右ク リ ッ ク して [Insert Bin] をク リ ッ ク します。

[Insert Bin] ダイアログ ボッ クスで、 範囲および色を指定します。 

範囲は新し く定義した範囲に合わせて調節されます。

図 9-16 : [Metrics Results] ウィンドウのタイプ別メ ト リ ッ ク  タブ

図 9-17 : [Insert Bin] ダイアログ ボックス
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デザインのフロアプラン

本章は、 次のセクシ ョ ンで構成されています。

• 「フロアプランの概要」

• 「Pblock 作成によるデザインのパーティシ ョ ン」

• 「Pblock を使用した作業」

• 「 リ ソース使用率の統計を使用した Pblock のサイズの決定」

• 「接続に基づいた Pblock の配置」

• 「Pblock の自動コマンドの使用」

• 「配置 LOC 制約」

• 「IP 再利用機能の使用」

フロアプランの概要

PlanAhead™ ではフロアプランがサポート されており、 ク リ ティカルなロジッ クを制約してイン

ターコネク ト を短く し、 遅延を抑えるこ とができます。 PlanAhead でのフロアプランは、 ボタンを

押すだけのフローとは異なり、 物理デザインでインタラ クティブに作業します。 設計者はデザイン

についての知識と  PlanAhead の解析機能を使用して、パフォーマンスを向上させるフロアプランを

定義します。 

フロアプランは、 物理ブロ ッ ク  (Pblock) ロケーシ ョ ンを作成してロジッ ク配置に制約を付けるか、

または個々のロジッ ク  オブジェク ト を特定デバイス  サイ トにロ ッ ク して行います。 

フロアプランのヒン ト

フロアプランしやすくするためのヒン トがいくつかあ り ます。

1. 第 8 章 「デザインの解析」 で説明されている方法を利用し、デザイン データ  フローおよびさま

ざまなモジュールのリ ソース要件を理解します。ブロ ッ ク  メモ リおよびブロ ッ ク演算サイ トの

あるモジュールの配置サイ トにはある程度制限されているため、 これを考慮する必要があ り ま

す。

2. 可能なかぎり、ク リ ティカルなモジュールに対しては Pblock の作成にデザインの知識を利用し

ます。 TimeAhead での解析、 [Schematic] ウ ィンド ウ、 配置配線結果を利用します。 

3. パフォーマンス目的でフロアプランを作成する場合、ク リ ティカル パスを含む階層のみに制約

を付けるよ うにします。場合によっては、固定デバイス  リ ソース  (I/O や PPC) に接続されてい

る階層をフロアプランに含める必要があ り ます。ASIC フローのよ うに、デザインのロジッ クを

すべてフロアプランする と、 一般的にパフォーマンスを犠牲にしてしまいます。 FPGA アーキ

テクチャが ASIC とは違う よ うに、 FPGA ツールも  ASIC ツールとは異なった動作します。
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FPGA デザイン全体をフロアプランしてもパフォーマンス向上につながらないのが一般的で

す。 

4. Pblock プロパティの統計を利用し、 インターコネク トの短くするために Pblock をできる限り

小さ く します。 また、同じ統計を利用し、RPM およびキャ リー チェーンが Pblock の長方形に

フ ィ ッ トするよ うにします。 

5. 大型の Pblock は、細かな配置制約を設定するため、パーティシ ョ ンに区切る必要がある場合が

あ り ます。 一般的に、 1 つの Pblock のサイズはデバイスの 30% 未満に抑えるよ うにします。

Pblock は小型であるほうがよいのです。 

Pblock 作成によるデザインのパーティシ ョ ン

フロアプランのプロセスでは、 始めにデザインの一部またはすべてのロジッ クをグループに分割し

て制約し、 インプリ メンテーシ ョ ン中に移行しないよ うにします。 デザインは、 管理しやすい小さ

な物理ブロ ッ ク  (Pblock) に、階層的に分割されます。 PlanAhead では、論理階層から独立した物理

階層が管理されます。 このため、 論理階層のどこからでも論理モジュールおよびプリ ミ ティブ ロ

ジッ クを Pblock に含めるこ とができます。 ク リ ティカル ロジッ クまたは関連するロジッ クは、 ロ

ジッ クが移行しないよ うにしっかり と  1 つの Pblock にグループ化されるため、インターコネク トの

長さが制限され、 遅延が低減されます。 

[Device] ウ ィンド ウで Pblock の長方形を作成する と、 フロアプランが開始します。 Pblock は、 長

方形を描画しな くても作成できます。 インプリ メンテーシ ョ ン中に、 ISE® ツールでロジッ クのグ

ループ化が試みられます。

パーティシ ョ ン分割は、Pblock を作成して手動で実行するか、パーティシ ョ ン ツールを使用して自

動で実行します。 

Pblock を作成する と、 エクスポート された UCF ファ イルに AREA_GROUP 制約が書き込まれま

れます。 PlanAhead で割り当てられたロジッ ク、 指定範囲、 定義した属性はこの制約ファイルに反

映されます。

Pblock の作成コマンドはいくつかあ り、 次のセクシ ョ ンで説明します。

[Draw Pblock] コマンドの使用

[Draw Pblock] コマンドを使用する と、選択したロジッ クが [Device] ウ ィンド ウで新しい Pblock に
割り当てられます。 コマンドを実行する前に、 Pblock に割り当てるロジッ クを選択しておきます。 

Pblock を作成するには、 次の手順に従います。

1. 任意のウ ィンド ウで Pblock に割り当てるロジッ クを選択します。

2. ポップアップ メニューの [Draw Pblock] または [Draw Pblock] ボタンをク リ ッ ク します。 

3. [Device] ウ ィンド ウでカーソルを Pblock の角を配置する場所に移動します。 

4. マウスの左ボタンを押したまま対角線上の角になる場所に移動して Pblock の長方形を描画し、

ボタンを離します。 

図 10-1 : [Draw Pblock] ボタン
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[New Pblock] ダイアログ ボッ クスが表示されます。 

5. 編集可能なフ ィールドを確認し、 必要があれば変更します。

♦ [Name] : Pblock の名前を指定します。 フ ィールドには、 Pblock のデフォルト名の

Pblock_<instancename> または pblock_n が表示されます。 ほかの名前を使用する場合は

変更します。

♦ [Grids] : Pblock で制約するデバイス  リ ソースの範囲を選択します。 

♦ [Assign selected instances] : オンにする と、選択されたインスタンスが新しい Pblock に割

り当てられます。ロジッ クが間違って選択されているこ と もあるので、確認してください。

6. [OK] をク リ ッ クする と、 新しい Pblock が作成されます。

Pblock は [Device] および [Physical Hierarchy] ウ ィンド ウで表示および選択できます。 

作成時の Pblock のサイズおよび位置は、 手動で作成する場合は重要ではあ り ません。 [Pblock
Properties] ダイアログ ボッ クスの、[Rectangles] タブを使用する と、Pblock の正しいサイズおよび

位置を確認できます。 [Device] ウ ィンド ウで接続状況を表示し、Pblock の正しい位置を指定できま

す。 

図 10-2 : [New Pblock] ダイアログ ボックス
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サイズを決める前にすべての Pblock を小さな長方形と して作成し、 Pblock 間の接続フローを視覚

的に確認した方が便利な場合もあ り ます。 

[New Pblock] コマンドの使用

[New Pblock] コマンドでは Pblock が [Physical Hierarchy] ウ ィンド ウに作成されますが、[Device]
ウ ィンド ウに長方形は作成されません。 コマンドを実行する前に、 新しい Pblock に割り当てるロ

ジッ クを選択しておく必要があ り ます。ロジッ クを選択しない場合は、空の Pblock が作成されます。

Pblock を作成するには、 ポップアップ メニューで [New Pblock] をク リ ッ ク します。 ロジッ クは選

択していてもいな くても構いません。

メモ : 長方形なしで Pblock を作成したほうがフロアプランで都合がよい場合があ り ます。 Pblock
に割り当てられたロジッ クには、 RANGE (範囲) が定義されていない AREA_GROUP プロパティ

が ISE で 設定されます。 ISE では AREA_GROUP プロパティを使用してロジッ クがグループ化さ

れ、 ほかの AREA_GROUP の範囲に配置されないよ うにします。 

[Create Pblocks] コマンドを使用した複数の Pblock の作成

Create Pblocks ウ ィザードを使用する と、複数の Pblock を半自動的に作成できます。ウ ィザードで

は、選択されたネッ ト リ ス トのインスタンスごとに Pblock が作成されます。ウ ィザードを使用する

前に、 各 Pblock に含めるインスタンスのセッ ト を選択しておきます。 

指定したネッ ト リ ス トのインスタンスに複数の Pblock を作成するには、 次の手順に従います。

1. Pblock に含めるインスタンスを選択します。

2. [Tools] → [Create Pblocks] をク リ ッ ク します。

図 10-3 : [Device] ウィンドウの Pblock
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Create Pblocks ウ ィザードが開き、 選択されたインスタンスのリ ス トが表示されます。 

3. このリ ス トにネッ ト リ ス トのインスタンスを追加するには、 [Add] ボタンをク リ ッ ク してブラ

ウザを開き、 インスタンスを選択します。 

4. リ ス トからインスタンスを選択して削除するには、削除するインスタンスを選択し、 [Remove]
ボタンをク リ ッ ク します。

5. リ ス トからネッ ト リ ス ト  インスタンスを削除するには、 [Clear] ボタンをク リ ッ ク します。

6. [Next] をク リ ッ ク します。

7. [Specify a naming sheme for the new Pblocks] ページで、 名前の指定に関するフ ィールドを確

認および編集します。

♦ [Prefix] : Pblock 名の接頭辞を指定します。新しい接頭辞を指定しても、デフォルトのイン

スタンス名や番号を使用してもかまいません。

♦ [Suffix] : [Instance name] を指定する と、 インスタンス名が接頭辞に続きます。 [Numeric]
を指定する と、 1 から開始する番号が接頭辞に続きます。

図 10-4 : Create Pblocks ウィザード  :インスタンスから  Pblock を作成

図 10-5 : Create Pblocks ウィザード  : 名前の指定
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8. [Next] をク リ ッ ク します。

9. [Summary] ページの内容を確認します。

10. [Finish] をク リ ッ クする と、 設定内容を使用して Pblock が作成されます。

作成された Pblock は、 [Physical Hierarchy] ウ ィンド ウに表示されます。 

新規作成された Pblock に長方形を作成するには、 次の手順に従います。

1. [Physical Hierarchy] ウ ィンド ウで、 新規の Pblock を 1 つずつ選択します。

2. [Device] ウ ィンド ウで [Set Pblock Size] ボタンをク リ ッ ク します。

3. [Device] ウ ィンド ウで長方形を描きます。

複数の長方形を含む Pblock の作成

PlanAhead には、 1 つの Pblock に複数の長方形を含む Pblock がある場合があ り ます。 既存の

Pblock に長方形を追加するには、Pblock を選択して [Add Pblock Rectangle] ボタンをク リ ッ ク しま

す。

Pblock の複数の長方形は、 点線で結ばれて表示されます。

図 10-6 : [Physical Hierarchy] ウィンドウに表示された Pblock

図 10-7 : [Set Pblock Size] ボタン

図 10-8 : [Add Pblock Rectangle] ボタン
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複数の長方形がある  Pblock を選択する と、長方形がすべて選択されます。長方形は個別にも、すべ

て同時にも移動できます。 

複数の長方形を含む Pblock で 1 つの長方形のサイズを変更する場合は、 長方形を選択して [Set
Pblock Size] コマンドまたは手動で変更します。

長方形を個別に選択するには、 次のいずれかの手順に従います。

• Pblock の長方形を 1 つ右ク リ ッ ク して [Select] ポップアップ メニュー コマンドで長方形を選

択します。

• Pblock を選択し、 [Pblock Properties] ウ ィンド ウの [Rectangles] タブで、変更する長方形を選

択します。

PowerPC および MGT サイ トにまたがる  Pblock には、 自動的に複数の長方形が作成されるこ とが

あ り ます。 これは、 インプリ メンテーシ ョ ンに適切な長方形の範囲を定義するためです。

図 10-9 : 複数の長方形を含む Pblock
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子 Pblock の作成

Pblock 内に Pblock を作成して、 ロジッ クをよ り厳密に制約するこ とができます。 これはク リ ティ

カルなモジュールのパフォーマンスの向上に非常に役立ちます。使用率の確認中は、最上位 Pblock
に下位 Pblock がすべて含まれます。 

メモ : ISE インプリ メンテーシ ョ ン ソフ ト ウェアでは、 この機能は完全にはサポート されていませ

ん。 ネス ト化した Pblock を作成する とマップおよび配線エラーが発生するこ とがあ り ます。

クロック領域 Pblobk の作成

Pblock は 1 つのクロ ッ ク領域内、または複数の領域内にあるすべてのリ ソースを含めるよ う定義す

るこ とができます。 

Pblock をクロ ッ ク領域と して定義するにはいくつかのステップを踏まなければなり ません。

1. ク ロ ッ ク領域の境界を含める長方形で Pblock を描画します。 

図 10-10 : ネスト化された Pblock の作成
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PlanAhead でクロ ッ ク領域の境界線が表示されます。 ク ロ ッ ク領域の境界線の色や表示方法を

変更する場合は、 「PlanAhead の表示オプシ ョ ンのカスタマイズ」 を参照してください。

ツール ヒ ン トが Pblock 範囲がクロ ッ ク領域であるこ とを示す表示に変わり ます。

2. [New Pblock] ダイアログ ボッ クスで [OK] をク リ ッ ク し、 Pblock の範囲をクロ ッ ク領域と し

て定義します。

図 10-11 : クロック領域 Pblobk の作成

図 10-12 : [New Pblock] ダイアログ ボックスで Pblock をクロック領域として定義
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CLOCKREGION オプシ ョ ンを有効にするには、Pblock の長方形にクロ ッ ク領域の境界を含める必

要があ り ます。CLOCKREGION_X のチェッ クボッ クスをオフにする と従来のロジッ クで指定され

る範囲を使用して Pblock が定義されます。 .

3. [New Pblock] ダイアログ ボッ クスまたは [Pblock Properties] の [General] タブにある

CLOCKREGION のチェッ クボッ クスのオン/オフを切り替えて、 この 2 タイプの Pblock を設

定するこ とができます。

Pblock ク ロ ッ ク領域の座標は [Pblock Properties] の [General] タブに表示されます。

図 10-13 : [Pblock Properties] の [General] タブでのクロック領域の設定
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Pblock を使用した作業

Pblock の図について

Pblocks および割り当てられたインスタンスは、 デフォルトの表示オプシ ョ ンを使用して図で表示

されます。外側の長方形は Pblock の枠です。 Pblock の内側の長方形は、 Pblock に割り当てられた

ネッ ト リ ス ト  インスタンスです。 Pblock には複数のインスタンスを配置できます。 Pblock の内側

に表示されるインスタンスの長方形のサイズは、含まれるロジッ ク数と、同じ  Pblock 内のほかのイ

ンスタンスの対比で決ま り ます。Pblock に割り当てられているインスタンス数が多いと、長方形で

はなく、 直線のよ うに見えるこ とがあ り ます。 

デフォルトの選択規則が設定されている場合、Pblock の長方形を選択する と、含まれるネッ ト リ ス

ト  インスタンスもすべて選択されます。インスタンスは、ほかの Pblock にド ラ ッグして割り当てる

こ とができます。

メモ : Pblock の操作をする場合は、 Pblock に割り当てられたインスタンスの小さな長方形ではな

く、 正しい Pblock の長方形が選択されているこ とを確認してください。 Pblock の操作時にインス

タンスの選択機能をオフにする と、 [Device] ウ ィンド ウで、 割り当てられたインスタンスではなく

Pblock が選択されるため、 間違いを防ぐこ とができます。 インスタンスおよび Pblock の選択方法

を指定するには、[Tools] → [Options] → [Themes] → [Device] をク リ ッ ク し、[Device] ウ ィンド ウ

での選択機能を指定します。詳細は、「[Device] ウ ィンド ウの表示オプシ ョ ンの設定」 を参照してく

ださい。

バンドル ネッ トは Pblock の中央に接続されますが、 I/O ネッ トは Pblock 内のインスタンスの中央

に接続されます。

図 10-14 : Pblocks と割り当てられたインスタンスの図
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子 Pblock の色は区別できるよ うに異なった色で表示されます。色の設定は、[Tools] → [Options] →
[Themes] → [Device] タブで変更できます。

Pblock には複数の長方形が含まれる場合があ り ます。 点線で結ばれている複数の長方形は、 1 つの

Pblock に含まれているものであるこ とを示します。割り当てられたインスタンスの長方形および接

続を表す線は、 一番大きな長方形に表示されます。 

Pblock へのロジックの割り当て

Pblock を作成する と、ネッ ト リ ス ト  インスタンスを割り当てるこ とができます。ロジッ クをド ラ ッ

グ アンド  ド ロ ップするか、 [Assign] ポップアップ メニュー コマンドを使用します。

図 10-15 : インスタンス長方形の中央に表示された I/O 接続

図 10-16 : 複数の長方形を含む Pblock の作成
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ド ラ ッグ アンド  ド ロ ップの手順は次のとおりです。 

1. [Netlist]、 [Schematic]、 [Hierarchy]、 または [Find Results] ウ ィンド ウでロジッ ク  インスタン

スをク リ ッ ク し、 ド ラ ッグします。

2. Pblock の長方形にド ロ ップします。 

[Assign] コマンドを使用する手順は、 次のとおりです。 

1. [Netlist] ウ ィンド ウでロジッ ク  インスタンスを選択します。

2. [Assign] ポップアップ メニュー コマンドをク リ ッ ク します。

[Select Pblock] ダイアログ ボッ クスが表示され、 割り当て可能な Pblock が表示されます。

Pblock へのロジックの割り当て解除

インスタンスを Pblock から削除するには、 次の手順に従ってください。

1. インスタンスを選択します。

2. [Unassign] ポップアップ メニュー コマンドをク リ ッ ク します。 

確認のダイアログ ボッ クスが表示されます。

Pblock の移動 
Pblock を移動するには、 フロアプラン内で Pblock を選択してド ラ ッグし、 移動先でド ロ ップしま

す。Pblock が選択される と、カーソルが手のアイコンに変わり ます。Pblock 内のインスタンスでは

なく、 外側の Pblock の長方形を必ず選択します。 

Pblock を BRAM や DSP などの新しいデバイス  ロジッ ク  タイプを含む場所に移動する と、Pblock
の定義に新しい RANGE タイプを入力するダイアログ ボッ クスが表示されます。 

内部にロケーシ ョ ン配置制約が割り当てられる と、Pblock のビヘイビアが変化します。移動先には、

配置制約の割り当てに十分な リ ソースが必要です。Pblock をド ラ ッグする と、カーソルの形で移動

可能であるかど うかが示されます。 リ ソースが十分でない場合は、 ロケーシ ョ ン制約を削除するか

図 10-17 : [Select Pblock] ダイアログ ボックス
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そのままにするかを選択するダイアログ ボッ クスが表示されます。 ロケーシ ョ ン制約は、固定され

たものと固定されていないものが別々に表示されるので、 それぞれに対して処理を指定できます。

実行中の移動の動作をキャンセルするには Esc キーを押します。 実行中のコマンドが中断します。

メモ : Pblock の移動がう ま くいかない場合は、 [Set Pblock Size] ツールバー ボタンをク リ ッ ク し、

長方形をどこかに描画し直します。 または、 Pblock を移動する前に、配置制約を削除してみてくだ

さい。

Pblock のサイズの変更 
Pblock の大きさを変更するには、 Pblock を選択し、 カーソルを長方形の角または枠に置きます。

カーソルの形がド ラ ッグ シンボルに変化したら、マウス  ボタンを押したまま ド ラ ッグしてサイズを

変更します。

Pblock を BRAM や DSP などの新しいデバイス  ロジッ ク  タイプを含む場所に移動する と、Pblock
の定義に新しい RANGE タイプを入力するダイアログ ボッ クスが表示されます。

Pblock 内部にロケーシ ョ ン配置制約が割り当てられる と、 Pblock のビヘイビアが変化します。 ロ

ケーシ ョ ン制約が Pblock に割り当てられる と、ロケーシ ョ ン制約を削除するかそのままにするかを

選択するダイアログ ボッ クスが表示されます。 ロケーシ ョ ン制約は、固定されたものと固定されて

いないものが別々に表示されるので、 それぞれに対して処理を指定できます。

実行中の移動の動作をキャンセルするには Esc キーを押します。 実行中のコマンドが中断します。

[Set Pblock Size] コマンドの使用

[Set Pblock Size] コマンドを使用する と、既存の Pblock の長方形のサイズを指定および変更できま

す。 既存の Pblock に新規の長方形を作成するには、 次の手順に従います。

1. [Physical Hierarchy] または [Device] ウ ィンド ウで Pblock を選択します。

2. [Set Pblock Size] ボタンをク リ ッ ク します。 

カーソルが変化し  [Device] ウ ィンド ウで新規の長方形を描画できるよ うにな り ます。

3. 新規の長方形の描画にはカーソルを使用します。

このコマンドは、 [New Pblock] コマンドなどで作成された、長方形がまだ定義されていない既存の

Pblock にも使用できます。詳細は、「[Create Pblocks] コマンドを使用した複数の Pblock の作成」を

参照して ください。

Pblock に複数の長方形がある場合は、 このコマンドを使用して 1 つの長方形を再生成できます。

Pblock が多数の長方形で構成されていて見づらい場合などにこのコマンドを使用する と便利です。 

Pblock を BRAM や DSP などの新しいデバイス ロジッ ク  タイプを含む場所に再生成する と、

Pblock の定義に新しい RANGE タイプを入力するダイアログ ボッ クスが表示されます。

Pblock 内部にロケーシ ョ ン配置制約が割り当てられる と、 Pblock のビヘイビアが変化します。 ロ

ケーシ ョ ン制約が Pblock に割り当てられる と、ロケーシ ョ ン制約を削除するかそのままにするかを

選択するダイアログ ボッ クスが表示されます。 ロケーシ ョ ン制約は、固定されたものと固定されて

いないものが別々に表示されるので、 それぞれに対して処理を指定できます。

図 10-18 : [Set Pblock Size] ボタン
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実行中の再生成の動作をキャンセルするには Esc キーを押します。 実行中のコマンドが中断しま

す。

複数の長方形がある Pblock を変更

複数の長方形がある  Pblock を選択する と、長方形がすべて選択されます。長方形は個別にも、すべ

て同時にも移動できます。 

複数の長方形を含む Pblock で 1 つの長方形のサイズを変更する場合は、 長方形を選択して [Set
Pblock Size] コマンドまたは手動で変更します。

長方形を個別に選択するには、 次のいずれかの手順に従います。

• Pblock の長方形を 1 つ右ク リ ッ ク して [Select] ポップアップ メニュー コマンドで長方形を選

択します。

• Pblock を選択し、 [Pblock Properties] ウ ィンド ウの [Rectangles] タブで、変更する長方形を選

択します。

PowerPC および MGT サイ トにまたがる  Pblock には、 自動的に複数の長方形が作成されるこ とが

あ り ます。 これは、 インプリ メンテーシ ョ ンに適切な長方形の範囲を定義するためです。

メモ : AREA_GROUP 制約あたりの範囲の数が多いと、ザイ リ ンクス  ISE のインプリ メンテーシ ョ

ン ツールで最適に処理できません。 L 型や T 型のよ うな単純な配置を使用してください。

図 10-19 : Pblock の長方形を個別に選択
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Pblock 長方形の削除 
Pblock の長方形を削除するには、Pblock を選択して [Clear Rectangle] ポップアップ メニュー コマ

ンドをク リ ッ ク します。

長方形を個別に削除するこ と も、 複数の長方形および Pblock を同時に削除するこ と もできます。

Pblock の長方形を削除しても、 Pblock は [Physical Hierarchy] ウ ィンド ウからは削除されません。

メモ : [Physical Hierarchy] ウ ィンド ウからパーティシ ョ ンを削除するのではなく、Pblock の長方形

を削除する と、 フロアプランで都合がよい場合があ り ます。 パーティシ ョ ンに含まれるロジッ クに

は、 ISE の AREA_GROUP プロパティが適用されます。 配置プロセスの実行中、 ISE では

AREA_GROUP プロパティを使用して、ほかの AREA_GROUP ロケーシ ョ ンに配置されないよ う

にロジッ クのグループ化が試みられます。

Pblock の名前の変更  
[Pblock Properties] ウ ィンド ウの [General] タブを使用して、 Pblock の名前を変更できます。 新し

い名前を [Name] フ ィールドで指定し、 [Apply] をク リ ッ ク します。

Pblock の削除 
次の手順で Pblock を選択して削除できます。

1. [Physical Hierarchy] ウ ィンド ウで Pblock を少なく と も  1 つ選択します。

2. Delete キーを押すか、 ポップアップ メニュー コマンドの [Delete] をク リ ッ ク します。 

3. [Confirm Delete] ダイアログ ボッ クスで、 [Remove Pblock children] オプシ ョ ンをオンにする

と、ネス ト化された Pblock およびそのパーティシ ョ ンも削除されます。オフにしておく と、選

択した Pblock のみが削除され、 ネス ト化されたその他の Pblock は、 1 階層上に移動します。

4. [OK] をク リ ッ クする と、[Physical Hierarchy] ウ ィンド ウから  Pblock パーティシ ョ ンが削除さ

れます。

Pblock プロパティの表示または変更

[Pblock Properties] ウ ィンド ウにはさまざまなタイプの情報が表示されます。 Pblock プロパティを

表示または編集するには、Pblock を選択し、[Pblock Properties] ウ ィンド ウを表示します。このウ ィ

ンド ウには、 次に説明するタブが表示されます。
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メモ : 変更を適用するには、[Apply] をク リ ッ ク します。変更を取り消すには、[Cancel] をク リ ッ ク

します。 [Apply] をク リ ッ クせずに、ほかのアイテムを選択するか、 [Pblock Properties] ウ ィンド ウ

を閉じる と、 変更は適用されません。  

[General] タブ

[General] タブには、 次の編集可能なフ ィールドが含まれます。

• [Name] : Pblock 名が表示されます。 

• [Parent] : 親 Pblock が表示されます。Pblock によってはこのフ ィールドは編集できないこ とが

あ り ます。 親 Pblock が複数ある場合はこのフ ィールドで指定します。

• [Grid Range] : Pblock に AREA_GROUP の RANGE プロパティを指定できます。特定の範囲

を選択する と、選択されたロジッ ク  タイプのみが Pblock エリ アに含まれます。 Pblock が作成

される と、 範囲座標は各ロジッ ク  タイプに対し表示されます。

♦ [CLOCKREGION] : Pblock の範囲をクロ ッ ク領域全体に定義する場合にオンにします。

Pblock の長方形がクロ ッ ク領域境界に一致するよ う描画されます。

図 10-20 : [Pblock Properties] ウィンドウ
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[Statistics] タブ

[Pblock Properties] ウ ィンド ウの [Statistics] タブには、Pblock の詳細情報が表示されます。[Export
Statistics] ボタンをク リ ッ クする と、 情報をテキス ト形式のファイルに保存できます。 

[Statistics] タブには、 次の Pblock 情報が表示されます。

• [Physical Resources Estimates] : デバイスのリ ソース  タイプごとの表が表示されます。 

♦ [Site Type] : Pblock の長方形内で定義されているサイ ト  タイプが表示されます。

♦ [Available] : Pblock に含まれるサイ ト数が表示されます。 

♦ [Required] : Pblock に割り当てられたロジッ クに必要なサイ ト数が表示されます。

♦ [% Utilization] : Pblock に含まれるサイ トの予測使用率 (%) が表示されます。

• [Clock Report] : Pblock に含まれるすべてのクロ ッ ク信号および各クロ ッ クでクロ ッ ク信号が

供給されたインスタンスの数が表示されます。 ローカル ク ロ ッ ク、グローバル ク ロ ッ ク、およ

びリ ソース  ク ロ ッ クがすべて表示されます。

• [Carry Statistics] : Pblock に割り当てられた垂直キャ リー チェーン ロジッ ク  オブジェク トの

数が表示されます。Pblock に割り当てられた中で高さが最大のキャ リー チェーンの Pblock の
高さに対する比率も表示されます。 この値が 100% を超える と、 PlanAhead の DRC エラーお

よび ISE マップ エラーが発生するこ とがあ り ます。

図 10-21 : [Pblock Properties] ウィンドウ :[Statistics] タブ
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• [RPM Statistics] : Pblock に割り当てられた RPM (相対配置マクロ) オブジェク トの数が表示

されます。 Pblock に割り当てられた中で最大の RPM の Pblock に対する高さ と幅の比率も表

示されます。この値が 100% を超える と、PlanAhead の DRC エラーおよび ISE マップ エラー

が発生します。PlanAhead では、複数の RPM が Pblock の長方形に収まるかど うかは示されま

せん。 

• [Clock Region Statistics] : Pblock が重なり合った各クロ ッ ク領域の使用率が表示されます。

• [Net Statistics] : Pblock の内部および外部ネッ トの数が表示されます。

• [Cellview Statistics] : Pblock に割り当てられた論理リ ソースのタイプごとの数が表示されま

す。

• [Boundary-crossing Nets Statistics] : 選択した Pblock に接続されたネッ トの数が表示されま

す。 Pblock 内部のロジッ クに接続されたネッ トは、 境界を通過するネッ ト と見なされます。

[Instances] タブ

[Pblock Properties] ウ ィンド ウの [Instances] タブには、Pblock に含まれるインスタンスの情報が表

示されます。 

インスタンスのフ ィールドは選択可能で、多くのポップアップ メニュー コマンドが使用できます。 

[Rectangles] タブ

[Pblock Properties] ウ ィンド ウの [Rectangles] タブには、 Pblock の長方形の情報が表示されます。

[Rectangle] タブを使用して、 Pblock の長方形を選択できます。 このタブの詳細は、 「複数の長方形

がある  Pblock を変更」 を参照してください。

[Attributes] タブ

[Pblock Properties ] ウ ィンド ウの [Attributes ] タブについては、 次のセクシ ョ ンで説明します。

図 10-22 : [Pblock Properties] ウィンドウ :[Instances] タブ
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Pblock ロジック  タイプ範囲の設定 
[Pblock Properties] ウ ィンド ウの [General] タブで [Grid Range] オプシ ョ ンを指定して、Pblock の
AREA_GROUP の範囲を設定できます。範囲は Pblock の長方形内にあるロジッ ク  タイプ別に設定

します。

Pblock を BRAM や DSP などの新しいデバイス  ロジッ ク  タイプを含む場所に再生成または移動す

る と、 Pblock の定義に新しい RANGE タイプを入力するダイアログ ボッ クスが表示されます。

グ リ ッ ド範囲のオプシ ョ ンをオフにする と、 [Device] ウ ィンド ウでの表示が変化します。 次の図に

示すよ うに、影の部分は、選択された Pblock でオンになっている範囲のロジッ ク  タイプのみを示し

ます。

図 10-23 : ロジック  タイプ別の AREA_GROUP の範囲設定
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Pblock の属性の設定

属性プロパティは、 [Attributes] タブで Pblock に割り当てられます。 属性を割り当てる と、 ISE の
さまざまなオプシ ョ ンが設定されます。

メモ : 属性の設定はインプリ メンテーシ ョ ン結果に影響を及ぼし、 エラーの原因となるこ と もあ り

ます。

図 10-24 : Pblock に含まれるロジックの表示

図 10-25 : [Pblock Properties] ウィンドウ :[Attributes] タブ

http://japan.xilinx.com


304 japan.xilinx.com PlanAhead ユーザー ガイド
UG632 (v 11.1.0)

第 10 章 : デザインのフロアプラン

[Pblock Properties] ウ ィンド ウの [Attributes] タブで Pblock に新しい属性を定義するには、 次の手

順に従います。

1. ポップアップ メニューの [Define] または [Define new attribute] ボタンをク リ ッ ク します。 

[Define Attribute] ダイアログ ボッ クスが表示されます。

2. 割り当てる属性を選択します。

3. [OK] をク リ ッ ク します。

指定したタイプの属性が、 [Attributes] タブに追加されます。 

4. 属性値を指定します。 

使用可能な Pblock 属性は次のとおりです。

♦ [COMPRESSION] : エリ ア グループの圧縮係数を設定します。 パーセン ト値は 0 ～ 100
で、 0 は圧縮なし、 100 は最大圧縮です。 [COMPRESSION] は Virtex®-5 デバイスおよび

map -timing を使用したデザインでは使用できません。

♦ [GROUP] : ロジッ クを物理コンポーネン ト  (スライス) にパッ ク し、 エ リ ア グループ外の

ロジッ クをエ リ ア グループ内のロジッ クにま とめるこ とができます。 

♦ [IMPLEMENT] : エリア グループのロジッ クが再インプリ メン ト されるかど うかを制御

します。

5. [Apply] をク リ ッ クする と、 変更が適用されます。

図 10-26 : [Define new attribute] ボタン

図 10-27 : [Define Attribute] ダイアログ ボックス 
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リ ソース使用率の統計を使用した Pblock のサイズの決定

[Pblock Properties] ウ ィンド ウの使用率の統計を使用して、 Pblock の大きさを決定し、 配置できま

す。長方形内で使用可能なデバイスのリ ソースは、 Pblock に含まれるロジッ ク と比較され、使用率

の予測値が計算されます。

Pblock の使用率の予測値は、 次の手順で表示できます。

1. Pblock を選択し、 [Pblock Properties] を表示します。

2. [Statistics] タブをク リ ッ ク します。 

3. [Statistics] タブで、 次の 3 つの列の使用率予測値を確認します。 

♦ [Available] : Pblock に含まれるサイ ト数が表示されます。

♦ [Required] : 割り当てられたロジッ クに必要なサイ ト数が表示されます。

♦ [% Utilization] : ロジッ ク  タイプごとの予測使用率 (%) が表示されます。Pblock のサイズ

を変更する と、 使用率を適正な値に修正できます。 

4. Pblock に必要な RAM サイ ト数を見るには、 スクロール ダウンします。 

ダイアログ ボッ クスはPblock が変更されるたびにダイナミ ッ クにアップデート されます。

Pblock に特定のロジッ ク  デバイス  エレ メン トのサイ トが含まれない場合は、 次の値が表示されま

す。

• [Available] : 0

• [Required] : 必要な数

• [Utilization] : Disabled (長方形で必要なタイプにサイ トが定義されていない)。 これは エラー

で、 必要なタイプのサイ トが長方形で定義されていないこ とを示しています。

図 10-28 : [Pblock Properties] ウィンドウ :[Statistics] タブ
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メモ : Pblock のスライス使用率は、 サイ トの使用率が最大である という前提で計算されています

が、実際は、配置配線ツールでサイ トの使用率が最大になるこ とはまれです。設計時には、ターゲッ

トの使用率は約 80% 以上で最適化してください。この数値は、使用されるデバイスおよびデザイン

とその制約によって異なり ます。

メモ : Pblock 使用率は、キャ リー チェーン、RPM マクロ、および Pblock 長方形の配置の影響を受

けます。これらの数値は単なる予測で、ISE インプリ メンテーシ ョ ンを正し く実行するための指針と

して使用するためのものです。Pblock のサイズの決定時に、Pblock の統計をすべて考慮してくださ

い。 ISE で正し く配置できるよ うに、 Pblock を拡大する必要がある場合もあ り ます。

図 10-29 : Pblock に使用可能な RAMFIFO36 リソースがない状態 (Disabled)
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接続に基づいた Pblock の配置

PlanAhead の接続フ ィードバッ クはダイナミ ッ クで、 Pblock の配置に役立ちます。 

Pblock 間の結合された接続は、バンドルされたネッ ト と して表示されます。各バンドルは、 Pblock
間の接続の数に基づいてサイズと色が決ま り ます。これは接続数が多い Pblock をわかりやすくする

ためです。バンドル ネッ トが大きな Pblock 同士を近くに配置するのが合理的なアプローチです。通

常 Pblock は、ネッ ト長ができるだけ短くなるよ うに配置し、配線競合や配線密集が起こらないよ う

にします。

バンドル ネッ ト  プロパテ ィの表示

接続情報は、バンドル ネッ ト または個別のネッ トのプロパティを表示して確認できます。接続情報

は、 次の手順で表示できます。

1. ネッ ト またはバンドル ネッ ト を選択します。

2. [Net Properties] ウ ィンド ウまたは [Bundle Net Properties] ウ ィンド ウを表示します。

図 10-30 : 接続を利用したフロアプランの決定
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[Bundle Net Properties] ダイアログ ボッ クスの [Nets] タブにはバンドルに含まれるネッ トが表示

されます。

バンドル ネッ トのデフォルトの変更

色、 線の幅、 および信号カウン ト範囲は、 [Tools] → [Options] → [Themes] ページで、 ウ ィンド ウ

ごとに指定できます。バンドル ネッ トのデフォルト設定の詳細は、「[Device] ウ ィンド ウのバンドル

ネッ ト表示オプシ ョ ンの設定」 を参照して ください。

Pblock の自動コマンドの使用 
PlanAhead では、自動 Pblock 作成コマンドを使用し自動パーティシ ョ ンおよび Pblock 配置ができ

ます。 この方法は主に、最上位のフロアプランを作成してデザインのデータ  フローを表示し、デザ

インのロジッ ク  モジュール間の相対サイズおよび関係を理解するために使用されます。通常設計時

には、デザインのク リ ティカル モジュールおよび回路のコンセプ トがあ り、 これらのモジュールを

使用してフロアプランを開始します。 

自動フロアプランの機能は、 フロアプランの唯一の方法ではなく、 物理デザインを理解するための

ツールと して使用して ください。フロアプランは、ISE ツールを使いこなすために利用する手動のプ

ロセスです。 PlanAhead の自動配置機能は、 デザインのフロアプランを手早く実行するためのもの

ではあ り ません。非スライス  ベースのロジッ クが Pblock エリアに含まれるよ うに、 Pblock を手動

で分割および構成する必要があ り ます。

Pblock の自動作成

Pblock 自動作成コマンドは自動的にパーティシ ョ ンを実行するツールで、ネッ ト リ ス トの最上位レ

ベルにも、 ネッ ト リ ス ト の論理インスタンスのどのレベルにも実行できます。 デフォル ト では、

[Auto-create Pblocks] コマンドは最上位レベルで開始し、1 モジュールずつ下位階層へと進みます。

ネッ ト リ ス トの各ロジッ ク  モジュールに Pblock を作成するか、 フ ィルタしてサブセッ トのみを作

成できます。

このコマンドを実行する と、 インスタンスが自動的に Pblock に配置され、 名前が付けられます。

Pblock 自動作成コマンドを実行するには次の手順に従います。

1. [Tools] → [Auto-create Pblocks] をク リ ッ ク します。

図 10-31 : [Bundle Net Properties] ウィンドウ : [Nets] タブ
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[Auto-create Pblocks] ダイアログ ボッ クスが開きます。

メモ : Pblock を前もって選択しておく と、ダイアログ ボッ クスの内容を変更せずにすみます。 

2. 編集可能なフ ィールドを確認し、 必要があれば変更します。

♦ [Pblock to Partition] : パーティシ ョ ン レベルを選択します。最上位の Pblock、 ROOT、 ま

たは選択した Pblock が表示されます。 

メモ : PlanAhead のパーティシ ョ ンは ISE のパーティシ ョ ンとは関連があ り ません。 この

コマンドでは ISE のパーティシ ョ ンは作成されません。

♦ [Maximum number of Pblocks to generate] : 作成される  Pblock の最大数を指定します。モ

ジュール数が設定数を超える と、 設定されている最大数分の Pblock が作成されます。

♦ [Process instances with instance count of at least] : 設定数よ り少ない数のインスタンスの

Pblock が作成されないよ うにします。

♦ [Preview] : 作成される  Pblock を確認します。

3. [OK] をク リ ッ クする と、 Pblock がデザインに作成されます。 

図 10-32 : [Auto-create Pblocks] ダイアログ ボックス
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Pblock が自動的に作成され、次の図に示すよ うに、最上位ネッ ト リ ス ト  モジュールと同じ名前が付

けられます。 この時点では、 長方形はまだ作成されていません。

Pblock 自動配置プログラムの実行 
PlanAhead の Pblock 配置プログラムを実行する と、自動的に Pblock の大きさが決められ、デバイ

スに配置されます。Pblock のサイズは、スライスの内容のみによって決定されます。Pblock の作成

時には、ほかのデバイス  タイプはすべて無視されます。作成される  Pblock の範囲はすべて定義され

ます。

Pblock 配置プログラムでは、選択された Pblock が手早く配置でき、デザイン内のデータ  フローの

確認に役立ちます。ISE でのインプリ メンテーシ ョ ンの前に手動で Pblock の形を変更し、非スライ

ス  リ ソースを含める必要があ り ます。 

メモ : [Place Pblocks] コマンドで配置した Pblock は、ISE でのインプリ メンテーシ ョ ンには使用で

きない場合があ り ます。 Pblock のサイズは、 スライスの内容のみによって決定されます。 手動で

Pblock のサイズを変更し、 非スライス  ベースのリ ソースを含める必要があ り ます。

Pblock 配置プログラムは、 次の手順で実行します。

1. [Tools] → [Place Pblocks] をク リ ッ ク します。

[Place Pblocks] ダイアログ ボッ クスが開きます。

図 10-33 : 新し く自動作成された Pblock
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2. 編集可能なフ ィールドを確認し、 必要があれば変更します。

♦ [Parent Pblock] : Pblock を配置する階層のレベルを指定します。最上位の ROOT または分

割された Pblock のレベルに配置できます。

♦ [Pblocks to place] : 親 Pblock の下にある  Pblock が表示されます。 

- [Place] : Pblock を配置するかど うかを指定します。 チェッ クボッ クスをオフにして

も、 既存の Pblock 長方形の位置は保持されます。

- [Pblock] : すべての Pblock がリ ス ト されます。

- [Utilization %] : 各 Pblock にスライス使用率のターゲッ ト を設定できます。

♦ [Set Utilization on all Pblocks] : すべての Pblock に、 スライス使用率のターゲッ ト を設定

します。

3. [OK] をク リ ッ クする と、 Pblock がデザインに配置されます。

[Place Pblocks] コマンドの実行中は、 [Place Pblocks Progress] ダイアログ ボッ クスが表示されま

す。

図 10-34 : [Place Pblocks] ダイアログ ボックス
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Pblock はスライス使用率にのみ基づいて大きさが決定され、 配置されます。 

大きな Pblock は、 再び分割して、 [Place Pblocks] を実行できます。

[Partition] コマンドおよび [Place Pblocks] コマンドを使用して最上位フロアプランを作成する方法

は、 PlanAhead のチュート リ アルを参照してください。

配置 LOC 制約

プリ ミ ティブ ロジッ ク  エレ メン トは、サイ ト制約作成モードまたは BEL 制約作成モードで特定の

ロジッ ク  サイ トに割り当てられます。PlanAhead では、サイ ト内の特定ゲートにロジッ クを固定す

る  BEL レベルの制約を割り当てるこ とができます。 

固定された配置制約および固定されていない配置制約について

PlanAhead では、ユーザーによ り割り当てられた配置制約と、 ISE インプリ メンテーシ ョ ン ツール

で割り当てられた配置制約が区別されます。 ユーザーが割り当てた制約とは、 インポー ト された

UCF ファ イルで定義されているか、PlanAhead で手動で割り当てられた制約です。これらの制約は

固定された制約と見なされ、異なる色で表示されます。ISE からインポート された配置制約はすべて

固定されていないものと見なされます。配置制約を選択して [Fix Instances] ポップアップ メニュー

コマンドを実行する と、 固定に変更できます。

固定された制約は配置をロ ッ クするために、すべてデフォルトで ISE インプリ メンテーシ ョ ン ツー

ルにエク スポー ト されます。 固定されていない配置制約をロ ッ クする必要がある場合は、 [Run
Launch Options]、 [Export Constraints]、 または [Export Pblock] ダイアログ ボッ クスから固定され

ていない配置制約をエクスポート します。

図 10-35 : 自動配置された Pblock
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サイ ト制約および BEL 制約について 
保存され、エクスポート されたフロアプランの UCF ファ イルでは、サイ ト制約はインスタンスに割

り当てられた LOC 制約になり ます。ロジッ ク  エレ メン トは CLB スライス  サイ トのみに固定され、

その内部の特定のゲートには固定されません。 

INST “receiver/uartInst/G_98_1” LOC = SLICE_X49Y69;

保存され、 エクスポート されたフロアプランの UCF ファ イルでは、 BEL 制約はインスタンスに割

り当てられた LOC 制約と  BEL 制約になり ます。BEL 制約では、ロジッ ク  エレ メン トが CLB 内の

特定のゲートに割り当てられます。

INST “Channel/receiveRE[8]” BEL = FFX;

INST “Channel/receiveRE[8]” LOC = SLICE_X59Y2;

サイ ト  ロケーシ ョ ン配置制約 (LOC) の割り当て

下位プリ ミ ティブ インスタンスは、ネッ ト リ ス ト  ツ リーから ド ラ ッグして特定サイ トにド ロ ップす

る と配置できます。インスタンスをサイ トに配置する と、ISE で使用するためにエクスポート された

UCF ファ イルに、 LOC (インスタンス  ロケーシ ョ ン) 制約が追加されます。 割り当てられたロケー

シ ョ ンは、 この後の ISE の実行中に固定ロケーシ ョ ンと して割り当てられ、 ロ ッ ク されます。

インスタンスを割り当てる前に、[Create Site Constraint Mode] ボタンをク リ ッ ク し、サイ ト制約作

成モードに切り替えます。 

ダイナミ ッ ク  カーソルでは、移動禁止または既に使用されているサイ トにはインスタンスを配置で

きません。配置できる場所に移動する と、 ダイナミ ッ ク  カーソルは斜線が入った円から矢印または

ひし形に変化します。 また、 ダイナミ ッ ク  カーソルでは、 ロジッ クがスライスに入り きらない場合

にもインスタンスを配置できません。キャ リー チェーン ロジッ クなど、ロジッ クのグループによっ

ては、1 つのオブジェク ト と して移動するため、グループのロジッ クがすべて配置できる場所が必要

です。

ロケーシ ョ ン制約の割り当てが完了したら、 [Assign Instance Mode] ボタンをク リ ッ ク してデフォ

ルトの、 Pblock へのインスタンス割り当てモードに戻り ます。

ロケーシ ョ ン制約プロパティを表示するには、配置制約を選択し、[Instance Property] ウ ィンド ウを

表示します。

BEL 配置制約 (BEL) の割り当て

下位プリ ミ ティブ インスタンスは、ネッ ト リ ス ト  ツ リーから ド ラ ッグして特定サイ トにド ロ ップす

る と配置できます。インスタンスをゲートに配置する と、前述のよ うに、BEL 制約が割り当てられ、

ISE で使用されます。 割り当てられたロケーシ ョ ンは、 この後の ISE の実行中に固定ロケーシ ョ ン

と して割り当てられ、 ロ ッ ク されます。 

図 10-36 : [Create Site Constraint Mode] ボタン

図 10-37 : [Assign Instance Mode] ボタン
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インスタンスを割り当てる前に、 [Create BEL Constraint Mode] ボタンをク リ ッ ク し、 BEL 制約作

成モードに切り替えます。 

ダイナミ ッ ク  カーソルでは、移動禁止または既に使用されているゲート  サイ トにはインスタンスを

配置できません。配置できる場所に移動する と、 ダイナミ ッ ク  カーソルは斜線のはいった円から矢

印に変化します。 また、 ダイナミ ッ ク  カーソルでは、 ロジッ クがスライスに入り きらない場合にも

インスタンスを配置できません。 

ロケーシ ョ ン制約の割り当てが完了したら、 [Assign Instance Mode] ボタンをク リ ッ ク してデフォ

ルトの、 Pblock へのインスタンス割り当てモードに戻り ます。

ロケーシ ョ ン制約プロパティを表示するには、配置制約を選択し、[Instance Property] ウ ィンド ウを

表示します。

図 10-38 : [Create BEL Constraint Mode] ボタン 

図 10-39 : [Assign Instance Mode] ボタン
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配置制約の表示/非表示の変更 
割り当てられた配置制約の表示方法を変更するにはズーム レベルを調節します。ズーム アウ ト表示

では、 LOC および BEL は、 割り当てられたサイ トの内側に塗りつぶされた長方形と して表示され

ますが、 ズーム レベルが上がるに従って、 サイ ト内の特定のロジッ ク  ゲートに割り当てられたロ

ジッ ク と して表示されるよ うにな り ます。

ロケーシ ョ ン制約の表示/非表示を切り替えるには、 [Show/Hide LOC Constraints] ボタンをク リ ッ

ク します。 

LOC 制約および BEL 制約のその他の表示設定を変更するには、 次の手順に従います。

1. [Tools] → [Options] → [Themes] → [Device] をク リ ッ ク します。

[Device] ダイアログ ボッ クスが表示されます。

2. 制約オブジェク トの下の値を変更します。

デバイス  リ ソース  グ リ ッ ド  サイ トの表示設定を変更するには、[Tools] → [Options] → [Themes] →
[Device] をク リ ッ ク し、 [Site] オブジェク トの設定を変更します。

固定された配置制約と固定されていない配置制約の色および選択は個別に設定できます。

図 10-40 : [Device] ウィンドウのズーム アウト表示

図 10-41 : [Show/Hide LOC Constraints] ボタン
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接続の表示切り替えを使用したロジック接続の表示

配置制約が表示されている場合、 個々の配置制約ロケーシ ョ ンのネッ ト接続が表示されます。 配置

制約が非表示の場合、 ネッ トの接続は Pblock 内のロジッ ク  インスタンスの中心に表示されます。

選択したロジッ ク  インスタンスまたはインスタンス  グループの接続を表示するには、次のコマンド

のいずれかを実行します。

• [Show Connectivity] ポップアップ メニュー コマンド  

• [Show connections for selected instances] ボタン 

このモードがオンであれば、 ロジッ ク  オブジェク ト を新し く選択し、接続を表示できます。 このボ

タンをも う一度ク リ ッ クする とオフになり ます。

配置制約の移動

配置制約を移動するには、 次の手順に従います。

1. [Device] ウ ィンド ウ、 [Netlist] ウ ィンド ウ、 または [Schematic] ウ ィンド ウでインスタンスを

ク リ ッ ク して配置制約を選択します。 

2. 選択した配置制約を、 移動可能なほかのサイ トにド ラ ッグ アンド  ド ロ ップします。 

プリ ミ ティブ インスタンスが新しいサイ トに割り当てられます。ロケーシ ョ ン制約から  Pblock
に接続するネッ トの線が表示されます。 

キャ リー チェーンの一部であるロジッ ク  オブジェク ト を移動する と、 キャ リー チェーン全体

が移動されます。 キャ リー チェーン全体が移動可能なサイ トに移動する とカーソルが変化し、

すべてのオブジェク ト を新しい相対ロケーシ ョ ンに移動できます。

RAM および MULT のよ うなロジッ クは、Pblock 長方形の外側のサイ トに割り当てるこ とがで

きるため、 配置を柔軟に固定できます。

3. ロケーシ ョ ン制約の割り当てが完了したら、 [Assign Instance Mode] ボタンをク リ ッ ク してデ

フォルトの、 Pblock へのインスタンス割り当てモードに戻り ます。

ロケーシ ョ ン制約プロパティを表示するには、配置制約を選択し、[Instance Property] ウ ィンド ウを

表示します。

図 10-42 : [Show connections for selected instances] ボタン

図 10-43 : [Assign Instance Mode] ボタン
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選択した配置制約の削除

選択したインスタンス  ロケーシ ョ ン制約を削除するには、 配置されたインスタンスをク リ ッ ク し、

次のいずれかの手順に従います。

• [Tools] → [Clear Placement Constraints] をク リ ッ ク します。 詳細は、 「選択した配置制約の削

除」 を参照して ください。

• [Unplace] ポップアップ メニュー コマンドをク リ ッ ク します。

選択した配置制約の削除

インスタンス  ロケーシ ョ ン制約は、 選択してデザインから削除できます。 制約は、 ISE で割り当て

られたもの、選択したロジッ クまたは Pblock、および特定のロジッ ク  タイプに基づいてフ ィルタし、

削除できます。

オブジェク ト を先に選択しておく と、[Clear Placement Constraints] ウ ィザードで選択したオブジェ

ク トが削除されます。 Pblock が先に選択されている と、 ウ ィザードにはその Pblock 内の配置制約

を削除するデフォルト設定が表示され、 インスタンスが選択されている場合は、 インスタンス削除

のデフォルト設定が表示されます。 

配置制約を削除するには、 次の手順に従います。

1. [Tools] → [Clear Placement Constraints] をク リ ッ ク します。 

Clear Placement Constraints ウ ィザードが開始します。 

2. Clear Placement Constraints ウ ィザードで、削除する配置制約のタイプを選択します。オプシ ョ

ンは、 [Instance placement]、 [I/O Port placement]、 または [Both] です。

3. [Next] をク リ ッ ク します。

図 10-44 : Clear Placement Constraints ウィザード  : 
インスタンス配置、 I/O ポート配置、 または両方の削除
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インスタンスの配置制約の削除

次のページは、 コマンド実行前に選択したオブジェク トのタイプによ り異なり ます。 何も選択され

ていない場合は、表示されません。Pblock が選択されている場合は、Pblock の制約が削除されます。

インスタンスが選択されている場合は、 デフォルトでインスタンスの制約が削除されます。 選択さ

れているものに応じて、 次に示すよ うにほかのオプシ ョ ンも表示されます。

4. [Unplace Instances] ページで、 配置を削除するインスタンスのカテゴ リ を選択します。

5. [Next] をク リ ッ ク します。

図 10-45 : Clear Placement Constraints ウィザード  :
あらかじめ選択したオブジェク トに対応した配置削除のオプシ ョ ン
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[Instance Types to Unplace] ページでは、配置制約タイプをフ ィルタできます。ウ ィザードの最初の

ページでインスタンスの制約のみのオプシ ョ ンが選択されているため、 I/O に関連するチェッ ク

ボッ クスはオフになっています。

6. [Instance Types to Unplace] ページで、 プリ ミ ティブ タイプのチェッ クボッ クスをオンにしま

す。

7. [Next] をク リ ッ ク します。 

図 10-46 : Clear Placement Constraints ウィザード  : 削除するロジック  タイプのフ ィルタ

図 10-47 : Clear Placement Constraints ウィザード  : 固定された制約のフ ィルタ
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8. [Fixed Placement] ページで、固定されたインスタンスを削除するかど うかを指定します。固定

されたインスタンス とは、 デザインに配置または固定されているインスタンス、 または入力

UCF ファ イルにインポート されたインスタンスです。

9. [Next] をク リ ッ ク します。

10. Summary ページの内容を確認し、 [Finish] をク リ ッ ク します。

指定されたプリ ミ ティブ インスタンスの割り当てがデザインから削除されます。

I/O ポート配置の削除

I/O ポートの制約割り当てを削除するには、 次の手順に従います。

1. [Tools] → [Clear Placement Constraints] をク リ ッ ク します。 

Clear Placement Constraints ウ ィザードが開始します。 

2. Clear Placement Constraints ウ ィザードで、削除する配置制約のタイプを選択します。オプシ ョ

ンは、 [Instance placement]、 [I/O Port placement]、 または [Both] です。

3. [Next] をク リ ッ ク します。

次のページは、 コマンド実行前に選択したオブジェク トのタイプによ り異なり ます。 何も選択され

ていない場合は、表示されません。 I/O ポートが選択されている場合は、 I/O ポートの制約が削除さ

れます。 選択されているものに応じて、 次に示すよ うにほかのオプシ ョ ンも表示されます。 

図 10-48 : Clear Placement Constraints ウィザード  : I/O ポート配置または両方の削除
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4. [Unplace Ports] ページで、 配置を削除する  I/O ポートのカテゴ リ を選択します。

5. [Next] をク リ ッ ク します。

6. [Fixed Placement] ページで、固定されたインスタンスを削除するかど うかを指定します。固定

されたインスタンス とは、 デザインに配置または固定されているインスタンス、 または入力

UCF ファ イルにインポート されたインスタンスです。

図 10-49 : Clear Placement Constraints ウィザード  :
あらかじめ選択したオブジェク トに応じた I/O ポート削除のオプシ ョ ン

図 10-50 : Clear Placement Constraints ウィザード  : 固定された制約のフ ィルタ
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7. [Next] をク リ ッ ク します。

8. サマリ  ページの内容を確認し、 [Finish] をク リ ッ ク します。

指定された I/O ポートの割り当てがデザインから削除されます。 

前に割り当てられたポートは、新しいUCF ファ イルを読み込む前は削除されません。新しいポート

の割り当てによ り、 前の割り当てが上書きされます。 新しいポート割り当て制約のインポート前に

すべてのポート割り当てを削除して ください。

Pblock と割り当てられた配置制約の移動

ロケーシ ョ ン制約が割り当てられた Pblock は移動できます。配置制約はすべて移動先で割り当て直

されます。 

Pblock 内部にロケーシ ョ ン配置制約が割り当てられる と、Pblock のビヘイビアが変化します。移動

先には、配置制約の割り当てに十分な リ ソースが必要です。Pblock を移動できない場所にド ラ ッグ

する と、 カーソルの形が変化し、 不適切な移動先であるこ とが示されます。 リ ソースが十分でない

場合は、ロケーシ ョ ン制約を削除するかそのままにするかを選択するダイアログ ボッ クスが表示さ

れます。ロケーシ ョ ン制約は、固定されたものと固定されていないものが別々に表示されるので、そ

れぞれに対して処理を指定できます。

ISE インプリ メンテーシ ョ ン中の配置のロック

PlanAhead で割り当てられた配置制約は固定と見なされ、 エクスポート された制約は、 ISE のイン

プリ メンテーシ ョ ンでロ ッ ク されます。 PlanAhead には、 配置制約を選択して削除する方法が何通

りかあるため、残しておく  LOC の制御ができます。Clear Placement Constraints ウ ィザードを使用

する と、配置制約を Pblock 単位で、選択したものだけを、または選択したもの以外のものを削除で

きます。 Pblock ベースでインプリ メンテーシ ョ ンを実行して、 選択した Pblock の配置をロ ッ クす

るこ と もできます。 

[Fix Instances] ポップアップ メニュー コマンドを使用する と、 ロジッ クを固定できます。

PHOHIBIT の設定

PROHIBIT 制約はデバイスのどのロジッ ク  サイ トにも作成できます。 この方法は次のとおりです。

1. [Device] ウ ィンド ウでサイ ト を選択します。 

[Select Area] を使用し複数のサイ ト を選択できます。詳細は、 「[Select Area] コマンドの使用」

を参照して ください。

2. 右ク リ ッ ク し、 [Set Prohibit] をク リ ッ ク します。

使用禁止になったサイ トには赤い X マークが表示されます (図 10-51)。
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IP 再利用機能の使用 

IP 再利用の概要

配置ロケーシ ョ ンおよび AREA_GROUP 制約を設定済みのインスタンス  モジュールは、 エクス

ポートおよび再利用できます。PlanAhead は、配置制約を含むモジュール レベルの EDIF ファ イル

および UCF をエクスポートする機能を備えています。 エクスポート されたファイルはインポート

して、 ほかのデザインで再利用できます。 この機能は、 チームで設計する場合や、 同一のモジュー

ルに配置をコピーする場合にも使用できます。 

IP モジュールの作成および再利用

IP 再利用のインスタンスのエクスポート

配置制約を再利用するには、 XDL を使用して PlanAhead にインポートする必要があ り ます。 詳細

は、 「ISE の配置およびタイ ミ ング結果のインポート 」 を参照してください。

IP モジュールと してエクスポートできるのは、 階層構造のネッ ト リ ス ト  インスタンスのみです。 

インスタンス  レベルのネッ ト リ ス トおよび配置制約をエクスポートするには、 次の手順に従いま

す。

図 10-51 : [Device] ウィンドウでの使用禁止サイ ト
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1. [Netlist] ウ ィンド ウで、 エクスポートするインスタンスを選択します。

2. [File] → [Export IP] をク リ ッ ク します。

Export IP ウ ィザードが表示されます。 

3. 編集可能なフ ィールドを確認し、 必要があれば変更します。

♦ [Instance] : エクスポートするインスタンスを指定します。参照ボタンをク リ ッ ク し、エク

スポートするインスタンスを選択します。ダイアログ ボッ クスには、 コマンドの実行前に

選択したインスタンスが表示されます。

♦ [Directory name] : ファ イルのエクスポート先のディレク ト リ名が表示されます。変更可能

です。PlanAhead では、<instance name> サブディ レク ト リが自動的に作成され、インスタ

ンスごとにエクスポート されたファイルが保存されます。

♦ [File types to generate] : エクスポートするファ イルのタイプを指定します。オプシ ョ ンは、

[Netlist (EDIF)] および [Constraints (UCF)] のいずれかまたは両方です。

♦ [Constraint files to generate] : 出力 UCF ファ イルに含める制約のタイプを指定します。

- [Physical constraints] : 割り当てられたインスタンスすべての物理制約を出力します。

- [RPM constraints] : LOC 制約を適切な RLOC および RPM セッ ト制約で置き換えま

す。

4. [Next] をク リ ッ ク し次に進みます。

サマ リ  ページに、 作成されるファイルが表示されます。 

5. [Finish] をク リ ッ クする と、 ファ イルがエクスポート されます。

IP モジュールの再利用

エクスポート されたインスタンス  IP ファ イルは、ほかのデザインで再利用できます。エクスポート

された IP ファ イルの形式ではモジュールの元のロジッ ク  インターフェイスが保持されるため、 再

利用が容易です。ブラ ッ ク  ボッ クスを作成し、エクスポート されたインスタンス と完全に同一のイ

図 10-52 : Export IP ウィザード
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ンターフェイスを使用する必要があ り ます。ロジッ ク合成に XST を使用する場合は、合成時のタイ

ミ ング情報の生成に、 エクスポート された EDIF ファ イルを使用できます。 合成でネッ ト リ ス トが

作成されたら、 そのネッ ト リ ス ト を使用して新規のプロジェク ト を作成します。 プロジェク トの作

成の詳細は、 「New Project ウ ィザードを使用した新規プロジェク トの作成」 を参照してください。

インスタンス EDIF ネッ ト リス トのインポート

IP モジュールを再利用するには、最初にインスタンス  EDIF ネッ ト リ ス ト をインポートする必要が

あ り ます。 ネッ ト リ ス ト をインポートするには、 次の方法のいずれかを実行します。

• プロジェク トの新規作成時は、 [File] → [New Project] をク リ ッ ク して、 New Project ウ ィザー

ドで検索パスを指定し、 新しいプロジェク トにモジュールを追加します。

• 既存のプロジェク トでは、 フロアプランの作成後に [File] → [Update Netlist] をク リ ッ ク して

モジュールをインポート します。 

モジュール レベルのネッ ト リ ス トのアップデートの詳細は、 「モジュール レベルのネッ ト リ ス トの

アップデート 」 を参照して ください。 

配置制約 (UCF) のインポート

モジュールのネッ ト リ ス トがインポート されたら、 次に配置制約をインポート します。 配置制約を

インポートするには、 次の手順に従います。

1. [Netlist] ウ ィンド ウでインスタンスを選択します。

2. [File] → [Import Constraints] をク リ ッ ク します。

選択されたインスタンスが [Import Constraints] ダイアログ ボッ クスに表示されます。
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3. [Import physical constraints for] で [Instance] をオンにし、 インスタンスを選択します。

4. [Add] ボタンを使用し、IP インスタンス用にエクスポート された UCF ファ イルを選択します。

5. [OK] をク リ ッ ク し、 制約をインポート します。

物理制約および AREA_GROUP 制約が、 作成された場所に再生成されます。 

メモ : 新しいターゲッ ト  デバイスにサイ ト  ロケーシ ョ ンが存在している必要があ り ます。

同一のモジュールへの配置のコピー

配置制約は、 「IP モジュールの再利用」 で説明されているよ うに、 インスタンスを個別に選択し、

[File] → [Import Constraints] をク リ ッ クする と、 同一のモジュールにコピーできます。 1 つのイン

スタンスに制約がインポート される と、その Pblock を移動して次のインスタンスを同じ場所にイン

ポートできます。 モジュールごとに、 この手順を繰り返します。

図 10-53 : モジュール レベルの制約のインポート  
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ChipScope を使用したデザインのデバッ
グ

本章は、 次のセクシ ョ ンで構成されています。

• 「PlanAhead と  ChipScope の統合の概要」

• 「コア挿入フローを使用する場合の要件および制限」

• 「コア挿入フローの使用」

• 「デザインのインプリ メンテーシ ョ ン」

• 「ChipScope Analyzer の起動」

PlanAhead と  ChipScope の統合の概要

ChipScope Pro の統合によ り、PlanAhead™ に ChipScope Pro ILA デバッグ コアを合成後に簡単に

挿入および接続できます。 ウ ィザードを使用し、 ほとんどのデザインのデバッグをすばやく簡単に

実行できます。ウ ィザード以外の GUI 機能や Tcl コマンド  フローは、精密なデバッグやネッ ト接続

のために使用できます。このフローは、PlanAhead 環境内で多機能な ILA コアを接続するこ とがで

きます。

図 11-1 : PlanAhead/ChipScope 統合の図説

X11123

ChipScope
ILA Debug

Cores

PlanAhead / Chipscope
Core Insertion

User’s Design Logic

User’s Design Logic
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コア挿入フローを使用する場合の要件および制限

PlanAhead/ChipScope 統合で ChipScope Pro デバッグ コアを挿入するには、ISE® 11.1 ツールおよ

び PlanAhead がインス トールされているこ とが前提です。ChipScope Pro 11.1 Analyzer およびザイ

リ ンクスの Platform USB ケーブルがランタイム デザイン デバッグに必要です。ChipScope Pro の
詳細については、 http://japan.xilinx.com/support/documentation/index.htm にある 『ChipScope Pro
11.1 Software and Cores User Guide』 を参照してください。 

PlanAhead/ChipScope 統合の制限事項は次のとおりです。

• Project Navigator / ChipScope Pro のコア挿入フローと互換性があ り ません。

• ISE 統合モードの場合、 このフローは使用できません。

• ChipScope Pro ICON コアに既存デバッグ コアが接続されている場合、表示はできますが変更

はできません。

• コア外部でインスタンシエート された BSCAN プリ ミ ティブへの接続を必要とする  BSCAN
プリ ミ ティブなしに生成された ICON が既存する場合、このフローはその ICON とは互換性が

あ り ません。

• PlanAhead ではデバッグ コアが合成後のデザイン ｎ  ネッ ト リ ス トに追加されるため、 合成中

に行われる ト リ ミ ングや最適化が原因で、 デバッグできないネッ トがある場合があ り ます。 

• 現在、 ChipScope Pro ILA コアのみがこのフローで作成および接続できます。

• NGC コア ファ イル内でのプローブがインターフェイス信号のみに制限されています。

• このフローでは、 PlanAhead 11、 ISE 11、 ChipScope Pro 11 を使用する必要があ り ます。 これ

らのツールのほかのバージ ョ ンは使用できません。

コア挿入フローの使用

ChipScope デバッグ コアの PlanAhead での挿入は、 PlanAhead ユーザーのレベルの応じていろい

ろな方法で実行するこ とができます。 簡単な方法と しては、 GUI のウ ィザードを使用し、 デバッグ

するために選択したネッ トに基づいて、 ILA コアを自動作成および設定できます。 また ChipScope
のメ イン ウ ィンド ウで個々のコア、ポート、およびパラ メータを設定するこ と もできます。さ らに、

Tcl デバッグ コマンドを使用し、スク リプ ト を手動で作成したり再生するこ と もできます。この 3 つ
の方法を合わせて利用し、 デバッグ コアをすばやく挿入およびカスタマイズするこ と もできます。

http://www.xilinx.com/cgi-bin/SW_Docs_Redirect/sw_docs_redirect?locale=en&topic=support+docs
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デバッグ コア挿入モードの決定

表 11-1 はデバッグ目標に基づきどの挿入モードを使用すべきかをま とめたものです。 

デバッグのためのネッ トの選択

PlanAhead/ChipScope デバッグ フローでの最初のステップは、 デバッグするネッ トの識別です。

PlanAhead では、[Netlist] ウ ィンド ウでネッ ト またはバスを選択し、[Add to ChipScope Unassigned
Nets] ポップアップ メニュー コマンドを実行するたけの簡単な作業です。 ネッ トの選択は、

[Schematic] ウ ィンド ウでもできます。

割り当てられていないネッ トのリスト

PlanAhead では、 [Window] → [ChipScope] をク リ ッ ク して表示される  [ChipScope] ウ ィンド ウで

割り当てられていないネッ トの リ ス ト  (図 11-3) が管理されます。これは、デザイン全体を確認して

いる と きにネッ ト をブッ クマークしておける便利な リ ス トです。 [Netlist] または [Schematic] ウ ィ

ンド ウからネッ ト をド ラ ッグして、後でデバッグするために保存しておく こ とができます。 [Add to

図 11-2 : デバッグ コアの挿入モード

ChipScope
Wizard

ChipScope Window
in Main PlanAhead GUI

ChipScope Tcl debug commands

Fast and simple

Precise control

X11122

表 11-1 : デバッグ目標およびコア挿入モード

デバッグ目標 コア挿入モード

選択したネッ トに対しデフォルト設定を使用して ILA デバッグ コア

をすばやく作成します。

ChipScope ウ ィザード

既存の出バグ コアのパラ メータを変更します。 ChipScope ウ ィンド ウ

既存のデバッグ コアを手動で作成または削除します。 ChipScope ウ ィンド ウ

ILA コアの ト リガまたはデータ  ポート を手動で作成、 削除、 設定しま

す。

ChipScope ウ ィンド ウ

ネッ ト を ト リガ、 データ、 ク ロ ッ ク  チャネルに手動で割り当てます。 ChipScope ウ ィンド ウ

デバッグ コマンドを記録したスク リプ ト を再生します。 Tcl コマンド
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ChipScope Unassigned Nets] ポップアップ メニュー コマンドでネッ ト をこのリ ス トに追加するこ

と もできます。

ChipScope ウィザードを使用したデバッグ コアの挿入

PlanAhead にデバッグ コアを追加するには、 ChipScope のデバッグ ウ ィザードを使用するのが最

も簡単です (図 11-4)。 まず、 未割り当てのネッ ト  リ ス トからまたは直接ネッ ト をク リ ッ ク してデ

バッグするネッ ト を選択します。 次に、 [Tools] → [Set Up ChipScope] をク リ ッ ク して、 ウ ィザー

ドの指示に従ってデバッグ コアを接続および設定します。

図 11-3 : [ChipScope] ウィンドウの未割り当てネッ ト  リス ト

図 11-4 : ネッ トの選択および ChipScope ウィザードの起動
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デバッグするネッ トおよびクロック  ド メ インの指定

ChipScope ウ ィザードでは、 選択した各ネッ ト またはバスに対し、 正しいクロ ッ クを自動検出しま

す (図 11-5)。複数のクロ ッ クが検出された場合、ド ロ ップダウン リ ス ト を使用してクロ ッ クを選択

できます。 さ らに、 [Add/Remove Nets] ボタンをク リ ッ ク してネッ ト を選択/選択解除できます。各

ネッ ト またはバスは、 ト リ ガ、 データ、 またはその両方と して使用できるよ う設定できます。 ネッ

トおよびクロ ッ クの設定が正しい場合は、 [Next] をク リ ッ ク しサマ リ  ページに進みます。

ILA コアの挿入

ChipScope ウ ィザードでは、 ク ロ ッ ク  ド メ インにつき  1 つの ILA コアを挿入します。 デバッグの

ために選択されたネッ トは、インスタンシエート された ILA コアの ト リガおよびデータ  ポート と し

て自動的に割り当てられます。 ウ ィザードの最終画面はコア作成のまとめのページで、 検出された

クロ ッ ク数、 作成および削除される  ILA コアの数が表示されます (図 11-6)。 内容を確認したら

[Finish] をク リ ッ ク し、 デザインに ILA コアをインスタンシエートおよび接続します。

図 11-5 : デバッグするネッ トおよびクロック  ド メインの指定
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ChipScope ウィンドウを使用したデバッグ コアの追加とカスタマイズ

ILA コア挿入に対する詳細な設定は、 ChipScope ウ ィザードではできないので、 [ChipScope] ウ ィ

ンド ウを使用します。 このウ ィンド ウでは、 コアの作成および削除、 ネッ ト接続のデバッグ、 およ

びコア パラーメ タの変更を設定できます。 [ChipScope] ウ ィンド ウを表示するには、 [Window] →
[ChipScope] をク リ ッ ク します (図 11-7)。  

図 11-6 : ILA コアのデザインへの挿入

図 11-7 : ChipScope ウィンドウを開く
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[ChipScope] ウ ィンド ウは、PlanAhead のメ イン ウ ィンド ウの下にある  [ChipScope] タブをク リ ッ

ク して開く こ と もできます (図 11-8)。 

[ChipScope] ウ ィンド ウには、ICON コン ト ローラ  コアに接続されたデバッグ コアのリ ス トが表示

され、 このウ ィンド ウの下部に、未割り当てのネッ トの リ ス ト も管理されます。デバッグ コアおよ

びポートは、 ポップアップ メニューまたはウ ィンド ウの左側にあるツールバーから制御できます。

デバッグ コアの作成および削除

ChipScope デバッグ コアは、 [ChipScope] ウ ィンド ウで [Create ChipScope Debug Core] ポップ

アップ メニューまたはツールバーのボタンをク リ ッ ク し作成できます。親インスタンスの変更、 コ

ア名のデバッグ、コアのパラーメ タ設定ができます (図 11-9)。既存のデバッグ コアを削除するには、

[ChipScope] ウ ィンド ウでコアを選択し、[Delete] ポップアップ メニュー コマンドをク リ ッ ク しま

す。

図 11-8 : [ChipScope] ウィンドウ
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デバッグ コア ポートの追加、 削除、 およびカスタマイズ

デバッグ コアの追加および削除だけでなく、各デバッグ コアのポート を追加、削除およびカスタマ

イズするこ とができます。 ポート を追加するには次の手順に従います。

1. コアを選択します。

2. [Create ChipScope Debug Port] ポップアップ メニュー コマンドまたはツールバーのボタンを

ク リ ッ ク します。

図 11-9 : コアの作成
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[Create Debug Port] ダイアログ ボッ クスが表示されます。

3. ド ロ ップダウン リ ス トからポートのタイプを選択します。 

[Options] でポートに対しオプシ ョ ンを設定します。 ポート幅はデフォルト値が表示されます

が、 ポートからネッ ト を追加および削除するごとに値が変化します。 

4. [OK] をク リ ッ ク します。

デバッグ ポート を削除するには、 [ChipScope] タブでポート を選択し、 [Delete] ポップアップ メ
ニュー コマンドをク リ ッ ク します。

デバッグ コアへのネッ トの接続および接続解除

ネッ トおよびバス  (ネッ トのベクタ ) は [Schematic] または [Netlist] ウ ィンド ウからデバッグ コア

のポートへド ラ ッグ アンド  ド ロ ップできます (図 11-11)。 これで、選択内容に応じてポートが自動

的に拡張します。また、ネッ ト またはバスを右ク リ ッ ク し、 [Assign to ChipScope Debug Port] を選

択するこ と もできます。デバッグ コアのポートからネッ トの接続を解除するには、ポートに接続さ

れているネッ ト を選択し、 [Disconnect Net] ポップアップ メニュー コマンドをク リ ッ ク します。

図 11-10 : デバッグ コアのポートのカスタマイズ
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デバッグ コアおよびポート  パラメータのカスタマイズ

ChipScope デバッグ コアにはカスタマイズ可能なパラ メータがあ り ます。このパラ メータにアクセ

スするには、 [ChipScope] ウ ィンド ウで ChipScope デバッグ コアをセン楽します。 [Properties] タ
ブで [Options] をク リ ッ ク しコア パラ メータを設定します (図 11-12)。 ポート  パラ メータは、

[Properties] で [Options] タブを選択し、デバッグ コアの ト リガまたはデータ  ポート をク リ ッ ク して

変更します。

図 11-11 : デバッグ コア ポートへのネッ トのド ラッグ アンド  ドロップ

http://www.xilinx.com


PlanAhead ユーザー ガイド japan.xilinx.com 337
UG632 (v 11.1.0)

コア挿入フローの使用

図 11-12 : デバッグ コアのパラメータ
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デバッグ コアのインプリ メンテーシ ョ ン

ChipScope Pro の ICON および ILA コアは PlanAhead でブラ ッ クボッ クス と して始めは作成され

ます。 これらのコアはマップ、配置、配線を実行する前にインプリ メン ト しておく必要があ り ます。

ChipScope デバッグ コアのインプリ メンテーシ ョ ンは、 [Tools] → [Run Implementation] をク リ ッ

ク してインプリ メンテーシ ョ ンを実行する と きに自動的に実行されます。しかし、[ChipScope] ウ ィ

ンド ウの左側にある  [Implement] ボタンをク リ ッ ク してフロアプランまたはタイ ミ ング解析用にデ

バッグ コアを手動でインプ リ メン トするこ と もできます。各ブラ ッ ク  ボッ クス  デバッグ コアに対

しザイ リ ンクスの CORE Generator がバッチ モードで起動します。 この処理には、多少時間がかか

る場合があ り ます。この間、進捗状況を示すダイアログ ボッ クスが表示されます (図 11-14)。デバッ

図 11-13 : デバッグ ポートのパラメータ
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グ コアのインプリ メンテーシ ョ ンが完了する と、デバッグ コアのブラ ッ ク  ボッ クスが完了し、生成

されたインスタンスをプッシュできます。

ChipScope Analyzer のネッ ト接続の CDC ファイルの使用

ChipScope Analyzer の CDC ファ イルはデザイン インプリ メンテーシ ョ ンが完了する と自動的に

生成されます。 [ChipScope] ウ ィンド ウで [Export Debug Net Names] ポップアップ メニュー コマ

ンドを使用し  CDC ファ イルを手動でエクスポートするこ と もできます。 この CDC ファ イルは

ChipScope Analyzer にインポート され、 ILA コア データおよびト リガ ポートのネッ ト名を自動的

に設定します。

デザインのインプリ メンテーシ ョ ン

ChipScope デバッグ コアが作成され接続されたら、 標準 PlanAhead インプリ メンテーシ ョ ン フ
ローを実行しデバイスのビッ ト ス ト リームを作成するこ とができます。 このインプリ メンテーシ ョ

ン フローは [Tools] → [Run Implementation] をク リ ッ ク して開始できます。

ChipScope Analyzer の起動

ChipScope Pro Analyzer がインス トールされている場合は PlanAhead から直接起動するこ とがで

きます。ChipScope Pro Analyzer を起動する前に、[Run Bitgen] ポップアップ メニュー コマンドを

使用し、 デザインの最新ビッ ト ス ト リームが作成されているこ とを確認します。 ChipScope Pro
Analyzer を起動するには次のいずれかの操作を実行します。

• [ChipScope] タブをク リ ッ ク し、 右ク リ ッ クでアクセスできる  [Launch ChipScope Analyzer]
を選択します。

• [Design Runs] タブをク リ ッ ク し、右ク リ ッ クでアクセスできる  [Launch ChipScope Analyzer]
を選択します。

PlanAhead が起動する と、ビッ ト ス ト リーム ファ イル (BIT ファ イル) および CDC ファ イルが自動

的に ChipScope Pro Analyzer に渡されます。

図 11-14 : デバッグ コア インプリ メンテーシ ョ ンのステータス バー
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付録 A

メニューおよびツールバー コマンド

この付録には、 次の PlanAhead コマンドに対するクイ ッ ク  リ ファレンスが含まれています。

• 「メ イン メニュー コマンド」

• 「ツールバー コマンド」

メイン メニュー コマンド

次の表に、 PlanAhead ソフ ト ウェアのメ イン メニュー コマンドを示します。 ウ ィンド ウのポップ

アップ メニュー コマンドは、 このマニュアルの別の章を参照してください。

コマンドには、特定の PlanAhead モードでのみ使用できるものがあ り ます。使用できないコマンド

は、 ディ スエーブルされるかグレー表示されています。

[File] メニュー

[File] メニューには、 次のコマンドが含まれています。 

表 A-1 : [File] メニューのコマンド

コマンド 説明

New Project 新しいプロジェク ト を作成するための New Project ウ ィザードを起動します。 

Open Project PlanAhead で以前に保存された既存のプロジェク ト  ファ イルを開きます。プロジェク

ト を開く と、 そのプロジェク トに関連する以前に開いたフロアプランもすべて開きま

す。また、 ISE®でのインプリ メンテーシ ョ ン実行すべての最新のステータスも復元さ

れます。

Reopen Project 以前に開いたプロジェク トの リ ス トからプロジェク ト を開きます。

Save Project 作業中のプロジェク ト を保存します。

Save Project As 作業中のプロジェク ト を別名または別のディ レク ト リで保存します。

Close Project 作業中のプロジェク ト を閉じます。 変更が保存されていない場合は、 保存を尋ねるダ

イアログ ボッ クスが表示されます。

New Floorplan 新しいフロアプランを作成するための New Floorplan ウ ィザードを起動します。 

Reopen Floorplan 以前に開いたフロアプランのリ ス トからフロアプランを開きます。

Save Floorplan プロジェク トのフロアプランを保存します。 変更が保存されていない場合は、 保存を

尋ねるダイアログ ボッ クスが表示されます。
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Save Floorplan As フロアプランを別名でまたは別のディ レク ト リに保存します。 元のフロアプランは閉

じられて、 プロジェク ト内に保存されます。

Copy Floorplan フロアプランおよび適用可能な物理制約を新しいターゲッ ト  デバイスにコピーしま

す。 

Close Floorplan プロジェ ク ト内のアクテ ィブなフロアプランまたは選択した複数のフロアプランを

閉じます。閉じたフロアプランはプロジェク ト内に含まれており、[Floorplans] ウ ィン

ド ウで開く こ とができます。

Revert Floorplan 最後に保存してからフロアプランで実行された操作をすべて取り消し、 元の状態のフ

ロアプランに戻します。

Delete Floorplan プロジェ ク ト内のアクテ ィブなフロアプランまたは選択した複数のフロアプランを

閉じて、 ディ レク ト リから削除します。 

Add Sources ソース  ファ イルまたはディ レク ト リ全体をプロジェク トに追加します。

Create Source [New Source File] ダイアログ ボッ クスが開き、 ソース  ファ イルを作成します。

Import I/O Ports ピンの割り当てのために CSV (カンマ区切り ) または HDL ファ イルのポート  リ ス ト

をインポート します。

Import Constraints 表示されているフロアプランに制約をインポート します。[Import Constraints] ダイア

ログ ボッ クスで制約ファイル (UCF) を選択します。

Import Placement 個々の Pblock またはデザイン全体に ISE の配置結果 (XDL フォーマッ ト ) をイン

ポート します。

Import TRCE Results ザイ リ ンクス  TRCE レポートの結果をインポート します。

Update Netlist モジュール レベルのネッ ト リ ス ト を更新するために Update Netlist ウ ィザードを起動

します。

Export Netlist [Export Netlist] ダイアログ ボッ クスが開き、ISE で使用する  EDIF ネッ ト リ

ス ト  ファ イルをエクスポート します。 
Export Constraints [Export Constraints] ダイアログ ボッ クスが開き、ISE で使用するフロアプラ

ン制約をエクスポート します。

Export Pblocks 選択した Pblock または複数の Pblock のネッ ト リ ス トおよび物理制約ファイルをエク

スポート します。

Export IP ハード  IP を再利用できるよ うに、論理フォーマッ トの論理インスタンスを配置制約と

共にエクスポート します。 配置制約は、 LOC、 BEL、 RLOC、 および SLICE 制約を

使用して作成できます。

Export I/O Ports PCB 回路シンボルまたは RTL ヘッダ生成に使用する  CSV (カンマ区切り ) フォー

マッ ト、UCF (ユーザー制約ファイル)、 または HDL ファ イルのポート  リ ス ト をエク

スポート します。

Print 作業中のウ ィンド ウを印刷します。このコマンドは、[Schematic] ウ ィンド ウ、[Device]
ウ ィンド ウ、 [Package] ウ ィンド ウ、または [Hierarchy] ウ ィンド ウが開いている と き

にのみ使用できます。

Exit アプリ ケーシ ョ ンを終了します。

表 A-1 : [File] メニューのコマンド
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[Edit] メニュー

[Edit] メニューには、 次のコマンドが含まれています。 

[View] メニュー

[View] メニューには、 次のコマンドが含まれています。 

表 A-2 : [Edit] メニューのコマンド

コマンド 説明

Properties 現在選択されているオブジェク トの詳細情報を示す [Properties] ウ ィンド ウを表示します。

Delete 現在選択されているオブジェク ト を削除します。

Unplace 選択したプリ ミ ティブ インスタンスおよび I/O ポートの配置を解除します。

Undo 作業中のセッシ ョ ンで直前に実行した Tcl コマンドを取り消します。

Redo 最後に実行した [Undo] コマンドをやり直します。 

Cut 選択したテキス ト をエディ タから切り取り、 ク リ ップボードに貼り付けます。

Copy ク リ ップボードに選択したオブジェク ト をコピーします。現段階では、フロアプランおよび

タイ ミ ング制約のみをコピーできます。

Paste ク リ ップボードの内容を貼り付けます。

Find [Find] ダイアログ ボッ クスを開いて特定のインスタンスまたはネッ ト を検索します。

Find in Files [Find in Files] ダイアログ ボッ クスが開き、 選択したファイルで文字列を検索します。

表 A-3 : [View] メニューのコマンド

コマンド 説明

Zoom In アクティブなグラフ ィ ッ ク  ウ ィンド ウを 200% 拡大して表示します。

Zoom Out アクティブなグラフ ィ ッ ク  ウ ィンド ウを 50% 縮小して表示します。

Zoom Fit アクティブなグラフ ィ ッ ク  ウ ィンド ウの内容全体をフ ィ ッ ト させます。

Zoom Area アクティブなウ ィンド ウで長方形を描画して、 そのエリ アを拡大表示します。

Fit Selection ズーム レベルを調整してアクティブなウ ィンド ウに選択したアイテムをすべてフ ィ ッ ト さ

せます。

Fit Highlight ズーム レベルを調整してアクティブなウ ィンド ウにハイライ ト したアイテムをすべて

フ ィ ッ ト させます。

Fit Markers ズーム レベルを調整してアクティブなウ ィンド ウにマークを付けたアイテムをすべて

フ ィ ッ ト させます。

Refresh アクティブなウ ィンド ウでグラフ ィ ッ クを再描画します。
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[Tools] メニュー

[Tools] メニューには、 次のコマンドが含まれています。 

表 A-4 : [Tools] メニューのコマンド

コマンド 説明

Create Pblocks Create Pblock ウ ィザードで、選択したインスタンスを割り当てた Pblock を複数

作成します。

Auto-create Pblocks [Auto-create Pblock] ダイアログ ボッ クスが開き、Pblock へインスタンスが自動

的に配置され、 名前が付けられます。

Place Pblocks [Place Pblocks] ダイアログ ボッ クスで Pblock のサイズを自動的に変更して配置

します。

Auto-place I/O Ports デバイス全体または選択した部分を I/O バンク規則、差動ペア規則、およびグロー

バル ク ロ ッ ク  ピン規則に従って配置します。 これは、PinAhead の機能の 1 つで

す。

Clear Placement Constraints Clear Placement Constraints ウ ィザードを起動して、 ポート または配置ロケー

シ ョ ン制約を選択して削除します。

Schematic ワークスペースに新しい [Schematic] ウ ィンド ウを開いて、 現在選択されている

エレ メン トの回路図を開きます。

Show Connectivity 選択したインスタンス、ネッ ト 、または Pblock に接続されているエレ メン ト を選

択します。 このコマンドを連続して使用し、 ロジッ ク  コーンをファンアウ ト また

は選択できます。

Show Hierarchy ワークスペースに [Hierarchy] ウ ィンド ウを開き、 ロジッ ク階層全体をグラ

フ ィ ッ ク表示します。 ツ リー内の選択されたロジッ クは、 ハイライ ト されます。

Run TimeAhead [Run TimeAhead] ダイアログ ボッ クスを開いて、TimeAhead スタティ ッ ク  タイ

ミ ング アナライザの設定をカスタマイズして実行します。 

Run Elaboration RTL 解析およびエラボレーシ ョ ン機能を起動し、 リ ソース予測および RTL 回路

図操作が可能になり ます。

Run DRC [Run DRC] ダイアログ ボッ クスを開いて、 デザイン ルール チェッ ク  (DRC) の
設定をカスタマイズして実行します。

Run PinAhead PinAhead 環境レイアウ ト を開き、デザインおよびデバイスの I/O 要件を満たすよ

うに I/O ピン配置を定義します。

Run WASSO Analysis [Run WASSO Analysis] ダイアログ ボッ クスを開いて WASSO 解析レポート を

生成します。 

Run Synthesis [Run Synthesi] ダイアログ ボッ クスが開き、 合成実行の作成および起動

ができます。

Run Implementation [Run Implementation] ダイアログ ボッ クスが競う し、1 つまたは複数のホス トで

インプ リ メンテーシ ョ ン ス ト ラテジを実行します (Linux のみ)。

Run Multiple Strategies [Run Multiple Strategies] ダイアログ ボッ クスが開き、 合成実行を設定します。
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[Window] メニュー

[Window] メニューには、 次のコマンドが含まれています。 

Run Tcl Script [Run Script] ダイアログ ボッ クスで Tcl スク リプ ト  ファ イルを選択して実行しま

す。

Options [Options] ダイアログ ボッ クスを開いて、表示、選択、シ ョート カッ トのオプシ ョ

ン、 ス ト ラテジなどを設定します。

表 A-4 : [Tools] メニューのコマンド

表 A-5 : [Window] メニューのコマンド  

コマンド 説明

Netlist [Netlist] ウ ィンド ウを表示します。

RTL Netlist [RTL] ウ ィンド ウを表示します。

Sources [Sources] ウ ィンド ウを表示します。

Floorplans [Floorplans] ウ ィンド ウを開きます。

Physical Hierarchy [Physical Hierarchy] ウ ィンド ウを表示します。

Package Pins [Package Pins] ウ ィンド ウを表示します。

I/O Ports [I/O Ports] ウ ィンド ウを表示します。

ChipScope [ChipScope] ウ ィンド ウを表示します。

Constraints [Constraints] ウ ィンド ウを表示します。

Clock Regions [Clock Regions] ウ ィンド ウを表示します。

Metrics [Metrics] ウ ィンド ウを開きます。

Selection [Selection] ウ ィンド ウを表示します。

World [World] ウ ィンド ウを表示します。

Console [Console] ウ ィンド ウを表示します。

Timing Results [Timing Results] ウ ィンド ウにタイ ミ ング結果を表示します。

DRC Results [DRC Results] ウ ィンド ウに DRC 結果を表示します。

WASSO Results [WASSO Results] ウ ィンド ウを表示します。

Find Results [Find Results] ウ ィンド ウに検索したオブジェク ト を表示します。

Find in Files Results [Find in Files] ウ ィンド ウに検索したオブジェク ト を表示します。

Elaboration Log [Elaborate Design] コマンドの結果ログを表示します。

Design Runs [Design Runs] ウ ィンド ウに実行を表示します。 

Metric Results [Metrics Results] ウ ィンド ウを表示します。

New Device View ワークスペースに新しい [Device] ウ ィンド ウを開きます。

New Package View ワークスペースに新しい [Package] ウ ィンド ウを開きます。
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[Select] メニュー

[Select] メニューには、 次のコマンドが含まれています。 

View Log File planAhead.log が開きます。このログ ファ イルにはPlanAhead のコマンドを実行したと き

に生成される メ ッセージの内容が含まれています。 

View Journal File planAhead.jou が開きます。このジャーナル ファ イルには起動した PlanAhead セッシ ョ ン

の TCL コマンドすべてが含まれています。

表 A-5 : [Window] メニューのコマンド  

表 A-6 : [Select] メニューのコマンド

コマンド 説明

Unselect All 選択したエレ メン ト をすべて選択解除します。

Unselect Type 特定のタイプのエレ メン トの選択を解除します。

Select Area アクテ ィブなワークスペースでエ リ アを選択するためにカーソルで長方形を描画できるよ

うにします。

Highlight アクティブなハイライ ト色を使用して選択したオブジェク ト をすべてハイライ ト します。

Unhighlight All オブジェク トのハイライ ト をすべて解除します。

Unhighlight 選択したオブジェク トのハイライ ト を解除します。

Unhighlight Color 指定した色のハイライ ト を解除します。

Mark [Device] ウ ィンド ウで選択したオブジェク トにマークを付けます。

Unmark [Device] ウ ィンド ウでオブジェク トに付けたマークを解除します。

Unmark All オブジェク トのマークをすべて削除します。

Show Source エディ タを開き、 選択したロジッ クのソースをハイライ ト表示します。

Show Definition 非プリ ミ ティブの RTL インスタンスに制限されますが、 RTL エディ タを起動し、 インスタ

ンシエート された Verilog モジュール/VHDL エンティティの定義をハイライ ト します。 
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[Layout] メニュー

[Layout]メニューには、 次のコマンドが含まれています。 

[Help] メニュー

[Help] メニューには、 次のコマンドが含まれています。 

表 A-7 : [Layout] メニューのコマンド

コマンド 説明

Load Default Layout ユーザー定義のデフォルトのウ ィンド ウ  レイアウ トがある場合は、そのレイアウ トが読み

込まれます。

Save as Default 
Layout

現在のウ ィンド ウ設定をデフォルト と して保存して、 PlanAhead の起動時に使用します。

このレイアウ トは PlanAhead が起動するたびに使用されます。 

Windows では、 次のディ レク ト リにファ イルが保存されます。

C:\Documents and Settings\<username>\Application 
Data\HDI\layouts\application_layout\default.layout

Linux または Solaris では、 次のディ レク ト リにファ イルが保存されます。

~/.HDI/layouts/application_layout/default.layout

Clear Default Layout 現在のユーザー定義のデフォルト  レイアウ ト を消去します。

Save Layout As 現在のウ ィ ン ド ウ設定をユーザー定義の名前で保存し ます。 これらのレ イアウ ト は、

PlanAhead の起動時に手動で読み込むこ とができます。 

Windows では、 次のディ レク ト リにファ イルが保存されます。

C:\Documents and Settings\<username>\Application 
Data\HDI\layouts\floorplan_layout\<layoutname>.layout 

Linux または Solaris では、 次のディ レク ト リにファ イルが保存されます。

~/.HDI/layouts/application_layout/<layoutname>.layout

Load Layout 以前に保存したレイアウ ト、 デフォルトの PlanAhead レイアウ ト、 または PlanAhead で
提供されるその他のレイアウ ト を読み込みます。

Remove Layout 以前に保存したユーザー定義のレイアウ ト を削除します。

Undo 最後に実行したコマンドを取り消します。

Redo 最後に実行した [Undo] コマンドをやり直します。

表 A-8 : [Help] メニューのコマンド

名前 説明

PlanAhead User Guide 『PlanAhead ユーザー ガイ ド』 を別のウ ィンド ウに開きます。

PlanAhead 
Methodology Guide

『PlanAhead Methodology Guide』 を別のウ ィンド ウに開きます。

Tutorial PlanAhead のチュート リ アルを別のウインド ウに開きます。

Release Notes 『PlanAhead Release Notes』 を別のウ ィンド ウに開きます。

Check for Updates ザイ リ ンクスの Web サイ トにソフ ト ウェア アップデートがあるかを確認し、アップデー

トが可能な場合はインス トールするためのメ ッセージが表示されます。
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ツールバー コマンド

PlanAhead には、 よ く使用されるコマンドを含むツールバーがあ り ます。 次の表に、 各コマンドの

ツールバー ボタンおよびシ ョート カッ ト  キーを示します。

License XLCM (Xilinx License Configuration Manager) を起動しソフ ト ウェア ライセンスを確

認・管理します。 ソフ ト ウェア ライセンスには FLEXnet Publisher が使用されています。

XLCM はライセンスを識別するために使用します。

PlanAhead on the Web デフォルト  ブラウザに、 ザイ リ ンクスのウェブサイ トの PlanAhead のページを開きま

す。 

Getting Started Getting Started ページを開きます。

About PlanAhead PlanAhead のバージ ョ ン情報および著作権情報を表示します。

表 A-8 : [Help] メニューのコマンド

名前 説明

表 A-9 : ツールバー コマンド

ツール

バー
コマンド名

シ ョート

カッ ト  
キー

説明

New Project New Project ウ ィザードを開きます。

Open Project [Open Project] ダイアログ ボッ クスを開きます。 

New Floorplan New Floorplan ウ ィザードを開きます。

Save Project Ctrl + S 現在のフロアプラン名でプロジェク ト を保存します。

Run Tcl Script [Run Script] ダイアログ ボッ クスが開き  Tcl スク リプ ト を選択・実行

できます。

Undo Ctrl + Z アクティブな PlanAhead セッシ ョ ンで実行したコマンドを取り消し

ます。

Redo Shift
Ctrl+Z

アクティブな PlanAhead セッシ ョ ンで取り消したコマンドをやり直

します。

Delete Delete 現在選択されているアイテムを削除します。

Find Ctrl + F [Find] ダイアログ ボッ クスを開いて特定のデザイン エレ メン ト を検

索します。

Run TimeAhead [Run TimeAhead] ダイアログ ボッ クスを開いて、スタティ ッ ク  タイ

ミ ング解析を実行します。

Run DRC [Run DRC] ダイアログ ボッ クスを開いて、デザイン ルール チェッ ク

(DRC) を実行します。
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Run Synthesis F11 [Run Synthesis] ダイアログ ボッ クスが開き、 合成実行の作成および

起動ができます。

Run Implementation [Run Implementation] ダイアログ ボッ クスが開き、1 つまたは複数の

ホス トでインプリ メンテーシ ョ ン ス ト ラテジを実行します (Linux
のみ)。

Options [PlanAhead Options] ダイアログ ボッ クスを開きます。

Schematic F4 ワークスペースに新しい [Schematic] ウ ィンド ウを開き、あらかじめ

選択してあったエレ メン ト を表示します。

New Device View ワークスペースに新しい [Device] ウ ィンド ウを開きます。

Clear Placement 
Constraints

Clear Placement Constraints ウ ィザードが開きます。 このウ ィザード

は、 あらかじめ選択したオブジェク トに基づいています。

Zoom In Ctrl + I アクティブなウ ィンド ウを拡大表示します。

Zoom Out Ctrl + O アクティブなウ ィンド ウを縮小表示します。

Zoom Area Ctrl + R ユーザー定義の長方形エリ アを拡大表示します。 

Zoom Fit Ctrl + G アクティブなウ ィンド ウ表示をフ ィ ッ ト させます。

Fit Selection F9 選択したオブジェ ク トすべてを表示するよ うにアクテ ィブなワーク

スペースをフ ィ ッ ト させます。

Select Mode 標準の選択モードに設定します。

Select Area エリ ア選択モードに設定します。

Highlight 選択したオブジェク ト をハイライ ト します。

Mark Crtl + M [Device] ウ ィンド ウで選択したオブジェク トにマークを付けます。

Unhighlight All Ctrl + K オブジェク トのハイライ ト をすべて解除します。

Unmark All オブジェク トのマークをすべて削除します。

Unselect All F12 選択したエレ メン ト をすべて選択解除します。

表 A-9 : ツールバー コマンド
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付録 B

XilinxUpdate を使用したインストール 
メモ : この章の説明は、 PlanAhead™ のフル バージ ョ ンにのみ適用されます。

この付録は、 次のセクシ ョ ンから構成されています。

• 「PlanAhead のリ リース  ス ト ラテジ」

• 「XilinxUpdate の実行」

• 「アップデートの自動検出」

PlanAhead のリ リース スト ラテジ

PlanAhead ソフ ト ウェアのリ リース  ス ト ラテジは、 ほかのザイ リ ンクス  ソフ ト ウェア ツールと同

様です。 新しい技術の導入や、 カスタマに迅速に対応するため、 定期的に新規リ リースが入手でき

るよ うになっています。 このリ リースのバージ ョ ンは (11.1、 11.2...) です。 [Help] → [About
PlanAhead] をク リ ッ クする と、 現在インス トールされている  PlanAhead のバージ ョ ンを確認でき

ます。

新しいリ リースを確認するには、 [Help] → [Check for Updates] をク リ ッ ク します。

ザイ リ ンクス  ツール インス トールの詳細は、『ISE Design Suite 11 : インス トール、ライセンス、お

よびリ リース  ノート 』 を参照してください。

XilinxUpdate の実行

PlanAhead に XilinxUpdate ユーティ リ ティが追加され、新しいリ リースのダウンロードおよびイン

ス トールが実行できるよ うにな り ました。 このユーティ リ ティではインス トールされているすべて

のツールを検出し、 ザイ リ ンクスの Web サイ トにアップデートがある場合はユーザーに通知しま

す。 ユーザーは、 ザイ リ ンクス  ツールのアップデート を選択してインス トールできます。 
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アップデート を確認およびインス トールするには、 [Help] → [Check for Updates] をク リ ッ ク しま

す。

[Advanced] ボタンをク リ ッ クする と、 プロキシ設定の確認および設定ができます。

1. [Check for Updates] ボタンをク リ ッ クする と、 ザイ リ ンクス  Web サイ トで確認されたすべて

の製品のアップデート情報のリ ス トが表示されます。 

2. ダイアログ ボッ クスでアップデート を希望するツールを設定します。

3. [OK] をク リ ッ ク し、 アップデート をダウンロード してインス トールします。 

アップデートの自動検出

PlanAhead は、 起動のたびにインク リ メンタル リ リースが自動的に検出されるよ うに設定できま

す。[Tools] → [Options]  をク リ ッ ク し、[PlanAhead Options] ダイアログ ボッ クスの [General] ペー

ジで、 [Automatically check xilinx.com for software updates on startup] をオンにします。

図 B-1 : XilinxUpdate の [Welcome] ページ
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アップデートの自動検出

図 B-2 : [Automatically check xilinx.com for software updates on startup] オプシ ョ ン
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付録 C

パスワードなしの SSH の設定

この付録は、 次のセクシ ョ ンから構成されています。

• 「SSH の設定」

 SSH の設定

複数 PlanAhead™ を複数のホス トで実行するには、 Linux OS で提供されているサービス、 セキュ

ア シェル (SSH) を使用します。PlanAhead で複数ホス ト を設定する前に SSH を設定しておく と、リ

モート コンピュータにログインするたびにパスワードを入力する必要があ り ません。SSH は、Linux
ターミナルまたはシェルで次のコマンドを入力して設定します。

メモ : これは一度設定しておけば、 繰り返し設定する必要はあ り ません。

1. Linux ターミナルまたはシェルで次のコマンドを実行し、 パブリ ッ ク  キーをプライマ リ  コン

ピュータで生成します。必須ではあ り ませんが、 セキュ リ ティ保護のため、 プライベート  キー

を入力および記憶しておく よ うにします。

ssh-keygen -t rsa

2. パブリ ッ ク  キーを リモート  コンピュータの authorized_keys ファ イルに追加します。 次の

remote_server には、 有効なホス ト名を入力します。

cat ~/.ssh/id_rsa.pub | ssh remote_server “cat - >> 
~/.ssh/authorized_keys”

3. プライベート  キーを取得するため次のコマンドを実行し、 キーを有効にします。

ssh-add

これで、 どの リモート  コンピュータでもパスワードを入力せずに使用できます。新しいコンピュー

タに初めてアクセスする場合は、 パスワードを入力するよ う求められますが、 その次回からは入力

する必要はあ り ません。 毎回パスワードの入力を求められる場合は、 システム管理者に連絡し、 パ

スワードを入力せずにSSH が使用できる  Linux アカウン ト を設定してもらいます。

SSH が設定されたら 「 リモート  ホス トの設定 (Linux のみ)」 に進んでください。

http://japan.xilinx.com


356 japan.xilinx.com PlanAhead ユーザー ガイド
UG632 (v 11.1.0)

付録 C : パスワードなしの SSH の設定

http://japan.xilinx.com


PlanAhead ユーザー ガイド japan.xilinx.com 357
UG632 (v11.1.0) 2009 年 4 月 27 日

C
ChipScope

ChipScope Analyzer の起動  339
インプリ メン ト   339
コア挿入の使用  328
統合  327

Console ウ ィンド ウ   91
Tcl ヘルプの使用  92
コマンド  ラインの使用  92

Constraints ウ ィンド ウ   237
タイ ミ ング制約の削除  241
タイ ミ ング制約の値の変更  239
新しいタイ ミ ング制約の追加  240

CSV ポート  リ ス ト  「PinAhead - CSV 
ファ イル」 を参照

D
Design Runs ウ ィンド ウ

BitGen の実行  203
Import Run ダイアログ ボッ クス   

199, 201
Device ウ ィンド ウ   117, 216

I/O ポートの配置  128
デバイス  リ ソースの表示  217
印刷  220
複数の Device ウ ィンド ウの表示  

220
ク ロ ッ ク領域の表示  219

DRC  253
DRC の実行  253
I/O ピンおよびクロ ッ ク  ルール  

135, 137
I/O 関連  113, 128
RTL 関連  172
エラーの表示  136, 174, 255
ルールについて  137, 174, 255

DRC の実行  172

F
Floorplan Editor

PlanAhead への移行  152
Floorplanner

PlanAhead への移行  156
Floorplan タブ

Pblock の操作

Pblock の削除  298

G
Getting Started  38

H
HDL エディ タ   165
HDL フォーマッ ト  ヘッダ 
「PinAhead」 を参照

Hierarchy ウ ィンド ウ   230

I
I/O Ports ウ ィンド ウ   114
I/O ネッ ト  「接続」 を参照

I/O ピンの配置 「PinAhead」 を参照

I/O ポート  インターフェイスの作成  
126

I/O ポートの作成  123
IP 再利用  323
ISE

インプリ メンテーシ ョ ン  208
配置およびタイ ミ ング結果  269

ISE 統合 「Project Navigator との統
合」 を参照

M
Metrics ウ ィンド ウ   279

Device ウ ィンド ウでのメ ト リ ッ ク
の表示  280

Metrics Results ウ ィンド ウの使用  
281

メ ト リ ッ ク  マップの非表示  280
メ ト リ ッ ク範囲の設定  281

N
Netlist ウ ィンド ウ   233

Netlist ウ ィンド ウでのロジッ クの
選択  216

Netlist ウ ィンド ウのアイコンの説
明  236

Nets フォルダの使用  236
Primitives フォルダの使用  235

ウ ィンド ウのポップアップ メ
ニュー コマンド   237

ネッ ト リ ス ト  ツ リーの非展開  234
New Device ウ ィンド ウ   220

P
PlanAhead Options ダイアログ ボッ ク

ス   98
PACE

PlanAhead への移行  152
Package Pins ウ ィンド ウ   115

I/O ピンの使用禁止

Package ウ ィンド ウ   116
I/O ピンの使用禁止

I/O ポートの配置  128
パッケージ ピンのプロパティの表
示  117

差動 I/O ペアの表示  116
印刷  117

Pblock 「フロアプラン」 を参照

Physical Hierarchy ウ ィンド ウ   241
Physical Hierarchy ウ ィンド ウの

アイコンの説明  242
ROOT Pblock の使用  242
相対配置マクロ  (RPM) での作業  

243
PinAhead  111

CSV ファ イル

インポート   121
エクスポート   144
ユーザー列  122
内容  121

Device ウ ィンド ウ   117
DRC 「DRC」 を参照

GT I/O ポートの配置  133
HDL ファ イル

I/O ポートのインポート   122
I/O Ports ウ ィンド ウ   114
I/O バンク  リ ソースの表示  118
I/O ピンの使用禁止  125
I/O ポート  インターフェイスの作
成  112, 114, 126

I/O ポートのインポート   121
I/O ポートの作成  123
I/O ポートの自動配置  113, 132
I/O ポートの設定  124
I/O ポートの配置  128

索引

http://japan.xilinx.com


358 japan.xilinx.com PlanAhead ユーザー ガイド

UG632 (v11.1.0) 2009 年 4 月 27 日

DRC の使用  128
I/O バンクへの配置  128

I/O 関連のクロ ッ ク  ロジッ クの配
置  133

I/O ポートの配置

順次配置  131
定義された領域への配置  130

Package Pins ウ ィンド ウ   115
Package ウ ィンド ウ   116
UCF ファ イル

I/O ポートのインポート   123
WASSO 解析の設定  141
起動  82, 112
ク ロ ッ ク領域リ ソースの表示  119
デバイス  リ ソース   117
デフォルトのレイアウ ト   82
レイアウ ト   149

PinAhead の起動  112, 149, 82
PlanAhead 製品概要  5
PlanAhead デフォルト  レイアウ ト   150
PlanAhead と  ChipScope の統合  327
PlanAhead と  Project Navigator の統合  

145
PlanAhead のコンフ ィギュレーシ ョ ン

ソフ ト ウェア アップデートの確認  
351

バンドル ネッ トのデフォルトの変
更  308

PlanAhead の開始

Getting Started ページの使用  40
PlanAhead 出力  24

CSV ファ イル  24
ISE インプ リ メンテーシ ョ ン デー

タ

ChipScope コア ネッ ト リ ス ト   
31

EDIF ネッ ト リ ス ト   29
ISE 実行スク リプ ト   32
制約ファイル  31

  29
実行ディ レク ト リ   29

RTL ファ イル  24
環境デフォルト   25

ISE インプ リ メンテーシ ョ ン 
ス ト ラテジ ファ イル  27

シ ョート カッ トの定義  26
初期化ファイル  26
デフォルトのレイアウ ト表示  

26
コマンド  ログおよびレポート   24

DRC 結果ファイル  25

TimeAhead の結果および制
約ファイル  25

WASSO 解析レポート   25
エラー レポート  ファ イル  25
デザインの論理ネッ ト リ ス ト
および Pblock 統計レポー
ト  ファ イル  25

コマンド  ジャーナル ファ イ
ル  25

コマンド  ログ ファ イル  24
プロジェク ト  データ   27

プロジェク ト  ディ レク ト リ   
27

プロジェク ト  データ  ディ レ
ク ト リ   28

プロジェク ト  ファ イル  27
フロアプラン データ  ディ レ

ク ト リ   28
プロジェク ト  ネッ ト リ ス ト   

28
PlanAhead の開始  37

Tcl スタート アップ スク リプ トの
使用  39

起動  37
コマンド  ライン オプシ ョ ン  38

PlanAhead の起動  37
PlanAhead の実行  37
PlanAhead の入力  21

CSV ファ イル  22
HDL ファ イル  23
ISE TRCE タイ ミ ング結果  24
ISE 配置結果  23
RTL ファ イル  22
最上位ネッ ト リ ス ト   23
制約ファイル  22, 23
モジュール レベルのネッ ト リ ス ト
およびコア  23

フロアプラン

Pblock の操作

Pblock へのロジッ クの割り当
て  294

Project Navigator との統合  145
I/O ピン割り当て (合成後)  147
I/O ピン割り当て (合成前)  146
エリ ア/IO/ロジッ クのフロアプラ

ン (合成後)  148
タイ ミ ング解析/デザインのフロア
プラン (インプリ メンテーシ ョ
ン後)  148, 152

Properties ウ ィンド ウ   232
接続

バンドル ネッ トのデフォルトの変
更PlanAhead のコンフ ィギュ
レーシ ョ ン

バンドル ネッ トのデフォルト
の変更  308

PlanAhead のコンフ ィギュレーシ ョ ン

ツールのシ ョート カッ ト  キーの設
定  104

表示オプシ ョ ンの設定  98

R
RTL Hierarchy ウ ィンド ウ   170
RTL エディ タ   165

ウ ィンド ウのポップアップ メ
ニュー コマンド   166

RTL デザインのエラボレーシ ョ ン  
167

フ ィルタの使用  168
結果の表示  168

RTL ネッ ト リ ス トのウ ィンド ウ   169
ウ ィンド ウのポップアップ メ
ニュー コマンド   169

リ ソースの見積り   170
RTL 回路図ウ ィンド ウ   171

S
Schematic ウ ィンド ウ   221

ウ ィンド ウのポップアップ メ
ニュー コマンド   226

オブジェク トの選択  226
タイ ミ ング パス  ロジッ クの表示  

230
選択したピンからのロジッ クの展
開表示  223

印刷  226
階層移動  225
回路図の再生成  226
回路図ピンへのファンアウ トおよ
びスラ ッ クのアノテーシ ョ ン  
227

選択したモジュールのロジッ クの
展開または非展開  224

ロジッ ク階層の表示  222
Selection ウ ィンド ウ   96
Sources ウ ィンド ウ   160

ウ ィンド ウのポップアップ メ
ニュー コマンド   161

T
Tcl スク リプ トの実行  39

http://japan.xilinx.com


PlanAhead ユーザー ガイド japan.xilinx.com 359
UG632 (v11.1.0) 2009 年 4 月 27 日

Timing Results  262, 270
Device ウ ィンド ウでのタイ ミ ング 

パスの表示  270
Schematic ウ ィンド ウでのタイ ミ

ング パスの表示  271
TRCE タイ ミ ング結果の表示  270
タイ ミ ング パス  レポートのワー

クスペースでの表示  264
タイ ミ ング レポートからのパスの
削除  263

タイ ミ ング レポートの並べ替え  
262

パスの詳細の表示  264

W
WASSO 解析  141

WASSO 解析結果の確認  142
WASSO 解析の設定  141

World ウ ィンド ウ   92

X
XilinxUpdate

アップデートの自動確認  106

い

印刷  89
Device ウ ィンド ウ   220
Package ウ ィンド ウ   117
Schematic ウ ィンド ウ   226

インスタンスの Hierarchy ウ ィンド ウ   
230

インプリ メンテーシ ョ ン

ISE とのインターフェイス

ISE の配置結果のインポート   
211

実行  184, 189
ISE 結果のインポート   201
Run での Bitgen の実行  203
複数の Linux ホス ト   206

ス ト ラテジ

共通のグループ ス ト ラテジの
作成  205

実行

複数の Linux ホス ト   355
  179

ChipScope フロー  339
ISE とのインターフェイス   208

ISE の TRCE 結果のインポー
ト   212

Pblock  188
ス ト ラテジ  179, 204

ISE コマンド  オプシ ョ ンの変
更  205

ス ト ラテジの作成  204
インプリ メンテーシ ョ ン実行  184, 189
インポート

制約  326
I/O ポート   121

え

エラボレーシ ョ ンの実行  167

お

オプシ ョ ン  98
オブジェク トの選択

オブジェク トの選択機能の設定  
97

  94
Select Area コマンドの使用  94
選択したオブジェク トすべての表
示  95

選択ルールの設定  97
複数のオブジェク トの選択  94

オブジェク トのハイライ ト

オブジェク トのハイライ ト解除  
276

プリ ミ ティブのハイライ ト   277
オブジェク トのハイライ ト解除  276
オブジェク トのマーク   97, 278

マークの削除  278
オブジェク トの選択

Find コマンドを使用したオブジェ
ク トの検索  265

Select コマンドの使用  95
オブジェク トのハイライ ト

オブジェク トのハイライ ト 「オブ
ジェク トのハイライ ト 」 を参照

オブジェク トのマーク   97
オブジェク トのマーク 「オブジェ

ク トのマーク」 を参照

プリ ミ ティブの親モジュールの選
択  95

プリ ミ ティブの選択  277
オプシ ョ ン  227

か

カーソル  98
文脈依存カーソルについて  98

解説

PlanAhead  5
このマニュアル  5

カスタム レイアウ ト   108

く

ク ロ ッ ク領域  219

こ

合成  179
実行  179

実行結果のインポート   199
複数の Linux ホス ト   355, 206

ス ト ラテジ  204, 179
ス ト ラテジの作成  204
共通のグループ ス ト ラテジの
作成  205

コマンド  オプシ ョ ンの変更  
205

デザイン リ ソース使用率統計  247
エクスポート   248, 251

合成オプシ ョ ン  168
合成の実行  179
固定された制約  312
固定されていない制約  312
コマンド

共通のポップアップ メニューおよ
びウ ィンド ウ特有のツールバー 
コマンド   245

  341
ツールバー  348
メ イン メニュー  341

し

出力ファイル  24
資料

用語の説明  33
新規プロジェク ト   41

せ

制約  70
制約のインポート   70
モジュール レベルの制約のイン

ポート   71
接続  272

Schematic ウ ィンド ウでのロジッ
クの展開表示  272, 274

http://japan.xilinx.com


360 japan.xilinx.com PlanAhead ユーザー ガイド

UG632 (v11.1.0) 2009 年 4 月 27 日

階層の解析  252
接続に基づいた Pblock の配置  

307
バンドル ネッ トのデフォルトの変
更  308

バンドル ネッ トのプロパティおよ
び内容の表示  307

そ

ソース  ファ イルのプロパティ   162
ソースの作成  164
ソースの追加  162
ソフ ト ウェア アップデート

アップデートの自動確認  106
  351

た

代替パーツの選択  119
タイ ミ ング解析

解析対象からパスを外す  261
  259

TimeAhead の実行  259

て

デザイン フロー  19
ダイアグラム  20
基本  20
実行試行  20
デザイン解析

フロアプラン  21
デザイン リ ソース使用率統計  247

エクスポート   248, 251
デバイスの互換性  119
デフォルトのレイアウ ト   109

と

ド ラ ッグを元に戻す  108

に

入力ファイル  21

ね

ネッ ト リ ス ト  アップデート

最上位ネッ ト リ ス トのアップデー
ト   62

  62
モジュール レベルのネッ ト リ ス ト

のアップデート   63
ネッ ト リ ス トのアップデート   62, 64
ネッ ト表示 「接続」 を参照

は

配置制約

BEL 制約の割り当て  313
ISE インプリ メンテーシ ョ ン中の

配置のロッ ク   322
ISE の配置結果のインポート   211
LOC 制約またはサイ ト制約の割

り当て  313
LOC 制約および BEL 制約につい

て  313
LOC 制約の表示/非表示の変更  

315
PROHIBIT の設定  322
移動  316

Pblock と割り当てられた配置
制約  322

固定された制約と固定されていな
い制約  312

選択した LOC 制約の削除  317
選択した LOC/BEL 制約の削除  

317
同一のモジュールへの配置のコ

ピー  326
プリ ミ ティブ ロジッ ク接続の表示  

316
配置配線  208
パッケージ ピン プロパティ   117
バンドル ネッ ト  「接続」 を参照

ひ

表示オプシ ョ ン  98
表示環境

共通のポップアップ メニューおよ
びウ ィンド ウ特有のツールバー 
コマンド   245

  81
ウ ィンド ウの設定

ウ ィンド ウをデフォルトのレ
イアウ トに戻す  109

ウ ィンド ウを開く   85
ウ ィンド ウ  レイアウ トの保存  

108
ウ ィンド ウ操作の取り消し   

109
ウ ィンド ウの自動非表示  86

ウ ィンド ウの復元  109
ウ ィンド ウ  バナーのコマンド
を使用したウ ィンド ウの操
作  86

表示エリ ア内でのウ ィンド ウ
位置の定義  107

表示エリ アのサイズの定義  
87

ほかの表示エリ アへのウ ィン
ド ウの移動  107

オブジェク トの選択  94
ステータス  バー  93

Java メモ リ使用率ゲージ  93
ク ロ ッ ク   93
現在のモード  フ ィールド   93
座標フ ィールド   93
情報メ ッセージ フ ィールド   

93
ツールのシ ョート カッ ト  キーの設
定  104

デフォルト表示レイアウ ト   81
表示オプシ ョ ンの設定  98

Device ウ ィンド ウのデフォル
トの設定  100

General ページのデフォルト   
106

I/O タブのデフォルト   101
カスタム テーマの保存と復元  

103
ソフ ト ウェア アップデート確
認の設定  106

デフォルトの淡色テーマまた
は濃色テーマの設定  103

バンドル ネッ トの表示オプ
シ ョ ンの設定  101

ルッ ク  アンド  フ ィールのオ
プシ ョ ン  106

ピンの使用禁止 「PinAhead」 を参照

ふ

複数ス ト ラテジの実行  182, 187
プロジェク ト

種類

RTL ベース   43
インプリ メンテーシ ョ ン結果
ベース   43

空  43
合成ネッ ト リ ス ト  ベース   43

新規ソースの作成  164
制約のインポート   70

モジュール レベルの制約のイ
ンポート   71

http://japan.xilinx.com


PlanAhead ユーザー ガイド japan.xilinx.com 361
UG632 (v11.1.0) 2009 年 4 月 27 日

最上位の制約のインポート   
70

ネッ ト リ ス ト  アップデート

最上位ネッ ト リ ス トのアップ
デート   62

プロジェク ト を開く

既存のプロジェク ト を開く   
60

複数のプロジェク ト を開く   
61

フロアプラン

Pblock の操作

Pblock のサイズの変更  296
Pblock の移動  295

Pblock を使用したデザインのパー
ティシ ョ ン  284

Pblock の操作

子 Pblock の作成  290
自動 Pblock コマンドの使用

Pblock 自動配置プログラムの
実行  310

接続に基づいた Pblock の配置  
307

リ ソース使用率の統計を使用した 
Pblock のサイズの決定  305

Pblock の図について  293
Pblock の操作  293

Pblock へのロジッ クの割り当
て  294

Pblock へのロジッ クの割り当
て解除  295

Pblock を使用したデザインのパー
ティシ ョ ン

選択したモジュールへの New 
Pblocks コマンドの使用  
286

Draw Pblock コマンド   284
New Pblock コマンド   286

自動 Pblock コマンドの使用  308
パーティシ ョ ン ツールの実行  

308
接続  307
Pblock の操作

Pblock 長方形の削除  298
Pblock の名前の変更  298
Pblock プロパティの表示  298

  283
フロアプラン  「プロジェク ト  - フロア
プラン」 を参照

フロアプランの削除  78
フロアプランの保存  78
フロアプランを閉じる   77
付録

A) メニューおよびツールバー コ
マンド   341

B) XilinxUpdate を使用したイン
ス トール  351

C) パスワードのプロンプ ト なしの 
SSH の設定  355

プロジェク ト

種類  40
RTL ベース   40
インプリ メンテーシ ョ ン結果
ベース   41

空  40
合成ネッ ト リ ス ト  ベース   40

  40
ソースの追加  162
ソースをプロジェク トにコピー  

163
ネッ ト リ ス ト  アップデート   62

モジュール レベルのネッ ト リ
ス トのアップデート   63

フロアプラン  67
フロアプラン プロパティの表
示および編集  75

フロアプランのコピー  79
フロアプランの作成  67
フロアプランの削除  78
フロアプランの保存  78
フロアプランの名前の変更  

79
フロアプランを閉じる   77

プロジェク トの開始  37
Getting Started ページの使用  

40
New Project ウ ィザードの使

用  41
プロジェク ト を開く   60

Getting Started プロジェク ト   
40

Getting Started ページの使用  
40

プロジェク ト を閉じる   62
プロジェク ト を開く   61
プロジェク ト を新規作成する   41
プロジェク ト を閉じる   62
ブロ ッ ク  ベースのデザイン

ISE でのインプリ メンテーシ ョ ン
のための Pblock のエクスポー
ト   209

Pblock のインプリ メン ト   188
IP モジュールの作成および再利用  

323

も

文字列の検索  265
Find in Files コマンドの使用  166
Find Results ウ ィンド ウの使用  

167, 267
Find コマンドを使用したオブジェ

ク トの検索  265

よ

用語集  33

り

リ ソース使用率

統計  247
リ ソース使用率の統計を使用した 

Pblock のサイズの決定  305
リ ソース使用率統計

エクスポート   248, 251
リ ソース使用率

モジュールの見積り   170
リモート  ホス ト  (Linux)

設定  206, 355

れ

レイアウ ト

カスタム レイアウ トの保存  108
デフォルトのレイアウ ト   109
レイアウ トの読み込み  109
PinAhead Cockpit  149
PlanAhead デフォルト   150

わ

ワークスペース

共通コマンド   245
ウ ィンド ウ   88
ワークスペース  ウ ィンド ウを開く   

89
ワークスペース  ウ ィンド ウを閉じ

る   90
ワークスペースの分割  90

http://japan.xilinx.com

	ソフトウェア マニュアル
	PlanAhead ユーザー ガイド
	このマニュアルについて
	PlanAhead について
	PlanAhead の機能

	Project Navigator 環境との統合
	マニュアルの内容
	その他のリソース
	ザイリンクスのトレーニング
	資料
	ビデオ デモンストレーション

	表記規則
	書体
	オンライン マニュアル


	目次
	1 : PlanAhead デザイン フローの理解
	PlanAhead デザイン フロー
	基本デザイン フロー
	実行試行フロー
	デザイン解析およびフロアプラン フロー

	入力および出力ファイル
	PlanAhead の入力
	レポートの出力
	デフォルト環境の出力
	プロジェクト データの出力
	ISE インプリメンテーションの出力

	PlanAhead の用語

	2 : プロジェクトの作成および管理
	PlanAhead の起動
	Linux
	Windows
	PlanAhead コマンド ライン オプション
	PlanAhead の Tcl スタートアップ スクリプトの使用

	Getting Started ページの使用
	PlanAhead プロジェクトの種類
	I/O ピン配置の空プロジェクト
	RTL ソースをベースにしたプロジェクト
	合成ネットリストをベースにしたプロジェクト
	インプリメントされたデザイン結果をベースにしたプロジェクト

	New Project ウィザードを使用した新規プロジェクトの作成
	プロジェクト名およびプロジェクト ディレクトリの入力
	デザイン ソース データ タイプの選択
	I/O ピンを配置する空のプロジェクトの作成
	RTL ソースをインポートしたプロジェクトの作成
	EDIF または NGC 形式の合成ネットリストを使用したプロジェクトの作成
	ISE 配置およびタイミング結果を使用したプロジェクトの作成

	プロジェクトの管理
	既存プロジェクトを開く方法
	複数のプロジェクトを開く
	プロジェクトを閉じる
	合成ネットリスト ベースのプロジェクトのネットリストのアップデート

	フロアプランを使用した作業
	フロアプランとは
	フロアプランの作成
	制約のインポート
	モジュール レベルの制約のインポート
	フロアプランでのデザイン制約のアップデート
	複数のフロアプランの作成
	複数のフロアプランの管理
	フロアプラン プロパティの表示および編集
	フロアプランを閉じる
	フロアプランの削除
	フロアプランの保存
	フロアプランのコピー
	フロアプランの名前の変更


	3 : 表示環境の使用
	表示環境
	PinAhead のウィンドウ レイアウト
	プロジェクト環境ウィンドウ レイアウト
	フロアプラン環境ウィンドウ レイアウト

	ウィンドウの操作
	表示ウィンドウの切り替え
	ウィンドウを開く
	ウィンドウ バナーのコマンドを使用したウィンドウの操作
	自動非表示の使用
	ウィンドウのフロート
	表示エリアのサイズの定義
	ウィンドウ特定のツールバー コマンドの使用

	ワークスペース ウィンドウの使用
	ワークスペース ウィンドウとは
	ワークスペース ウィンドウを開く
	ワークスペースの全画面表示
	ワークスペースのフロート表示
	ワークスペースの印刷
	ワークスペース ウィンドウを閉じる
	ワークスペースの分割

	共通のウィンドウの使用
	[Console] ウィンドウおよび Tcl コマンド ライン
	[World] ウィンドウの使用
	ステータス バーの使用

	オブジェクトの選択
	オブジェクトの選択
	選択したオブジェクトすべての表示
	[Selection] ウィンドウの使用
	選択したオブジェクトのハイライト
	選択したオブジェクトのマーク
	選択ルールの設定
	ワークスペース ウィンドウのオブジェクトの選択機能の設定
	文脈依存カーソルについて

	ウィンドウの環境設定
	PlanAhead の表示オプションのカスタマイズ
	PlanAhead の動作オプションの設定
	表示エリア内でのウィンドウの移動
	カスタム ウィンドウ レイアウトの作成
	ウィンドウ レイアウトの復元


	4 : I/O ピンの配置
	PinAhead の概要
	PinAhead 環境の使用
	[I/O Ports] ウィンドウの使用
	[Package Pins] ウィンドウの使用
	[Package] ウィンドウの使用
	[Device] ウィンドウの使用

	デバイス リソースの表示
	パッケージ ピンのプロパティの表示
	I/O バンク リソースの表示
	クロック領域リソースの表示

	互換性のあるパーツの選択
	I/O ポートのインポート
	CSV 形式のファイル
	HDL 形式のファイル
	UCF フォーマット ファイル

	I/O ポートの定義および設定
	I/O ポートの作成
	I/O ポートの設定
	I/O ピンおよび I/O バンクの使用禁止
	I/O ポート インターフェイスの作成

	I/O ポートの配置
	インタラクティブなデザイン ルール チェックの使用
	I/O ポートの I/O バンクへの配置
	I/O ポートの定義された領域への配置
	I/O ポートの順次配置
	I/O ポートの自動割り当て
	ギガビット トランシーバ I/O ポートの配置

	I/O 関連のクロック ロジックの配置
	I/O 配置制約の削除
	I/O ポートおよびクロック ロジック関連の DRC の実行
	WASSO 解析の実行
	パッケージ ピンの情報のエクスポート
	I/O ポート リストのエクスポート

	5 : Project Navigator からの PlanAhead の 使用
	統合の概要
	ISE および PlanAhead の統合プロセス
	ロジックおよび制約の渡し
	I/O ピン割り当て (合成前)
	I/O ピン割り当て (合成後)
	エリア/IO/ロジックのフロアプラン (合成後)
	タイミング解析/デザインのフロアプラン (インプリメンテーション後)

	PlanAhead の表示環境
	I/O ピン割り当てのウィンドウ レイアウト
	デザイン解析およびフロアプランのウィンドウ レイアウト

	PACE / Floorplan Editor から PlanAhead への移行
	概要
	Project Navigator からの PlanAhead の起動
	スタンドアロンの PlanAhead の起動
	空デザインおよび合成前の I/O ピン割り当て
	合成後のピン割り当ておよびエリア ベースのフロアプラン
	一般的な I/O ピン割り当ておよびフロアプラン タスク
	ISE インプリメンテーション結果ページの表示
	まとめ

	Floorplanner から PlanAhead への移行
	Project Navigator からの PlanAhead の起動
	スタンドアロンの PlanAhead の起動
	一般的なフロアプラン タスク
	タイミング解析 - パスのビジュアル表示
	ISE インプリメンテーション結果ページの表示
	まとめ


	6 : RTL デザインの作成および解析
	プロジェクト環境の使用
	[Sources] ウィンドウの使用
	ソース ファイル プロパティの表示

	ソースのプロジェクトへの追加
	ソース ファイルまたはディレクトリの追加
	新規ソース ファイルの作成
	RTL ソース ファイルのアップデート

	RTL エディタの使用
	RTL エディタのポップアップ メニュー コマンドの使用
	[Find in Files] コマンドを使用したソース ファイルの検索

	RTL デザインのエラボレートおよび解析
	[RTL] ウィンドウの使用
	[RTL Hierarchy] ウィンドウの使用
	モジュールのリソース見積りの表示
	RTL 回路図の解析
	[Find] コマンドを使用したオブジェクトの検索
	RTL DRC の実行


	7 : デザインのインプリメンテーション
	合成の実行
	合成実行の作成および起動
	合成に関するヒント

	インプリメンテーションの実行
	インプリメンテーション実行の作成および起動
	Pblock のインプリメント

	実行の監視および設定
	[Design Runs] ウィンドウの使用
	実行プロパティの表示および修正

	実行の管理
	既存の実行の起動
	実行のリセット
	実行の削除

	実行結果のインポート
	合成実行結果のインポート
	インプリメンテーション実行結果のインポート

	インプリメンテーション実行での Bitgen の実行
	ストラテジの作成
	合成およびインプリメンテーション ストラテジの作成
	共通のグループ ストラテジの作成

	複数の Linux ホストでの実行起動
	制限事項
	リモート ホストの設定 (Linux のみ)

	ISE とのインターフェイス
	制約のエクスポート
	ネットリストのエクスポート
	ISE インプリメンテーション用の Pblock のエクスポート
	ISE インプリメンテーション結果のインポート


	8 : デザインの解析
	フロアプラン環境の使用
	[Device] ウィンドウの使用
	[Schematic] ウィンドウの使用
	[Hierarchy] ウィンドウの使用
	[Properties] ウィンドウの使用
	[Netlist] ウィンドウの使用
	[Constraints] ウィンドウの使用
	[Physical Hierarchy] ウィンドウの使用
	共通のポップアップ メニュー コマンドの使用

	I/O ピン配置およびクロック ロジックの解析
	RTL デザインの解析
	合成されたデザインの解析
	デザイン リソースおよびデバイス使用率の統計レポート
	論理階層の表示
	階層接続の解析
	デザイン ルール チェック (DRC) の実行
	タイミング解析の実行
	タイミング結果の解析
	[Find]コマンドを使用したオブジェクトの検索


	9 : インプリメンテーション結果の解析
	ISE の配置およびタイミング結果のインポート
	New Project ウィザードを使用したISE 配置およびタイミング結果のイン ポート
	ISE の配置およびタイミング結果を PlanAhead からインポート
	ISE の配置およびタイミング結果を PlanAhead 環境外からインポート
	ISE の配置およびタイミング結果を Project Navigator からインポート

	配置およびタイミング結果の解析
	ザイリンクス TRCE の結果の表示
	[Device] ウィンドウでのタイミング パスの表示
	[Schematic] ウィンドウでのタイミング パスの表示

	ロジック接続の表示
	[Show Connectivity] コマンドの使用
	[Schematic] ウィンドウでのロジックの展開表示
	[Connectivity] タブを使用したロジック パスのトレース

	選択したオブジェクトのハイライト
	オブジェクトのハイライト
	オブジェクトのハイライト解除

	配置されたモジュールのハイライト
	[Select Primitives] コマンドおよび [Highlight Primitives] コマンドの使用

	選択したオブジェクトのマーク
	オブジェクトのマーク
	マークの削除

	デザイン メトリックの表示
	[Metrics] ウィンドウの使用
	[Device] ウィンドウでのメトリック マップの表示
	メトリック マップの非表示
	[Metrics Results] ウィンドウの使用
	メトリック範囲の設定


	10 : デザインのフロアプラン
	フロアプランの概要
	フロアプランのヒント

	Pblock 作成によるデザインのパーティション
	[Draw Pblock] コマンドの使用
	[New Pblock] コマンドの使用
	[Create Pblocks] コマンドを使用した複数の Pblock の作成
	複数の長方形を含む Pblock の作成
	子 Pblock の作成
	クロック領域 Pblobk の作成

	Pblock を使用した作業
	Pblock の図について
	Pblock へのロジックの割り当て
	Pblock へのロジックの割り当て解除
	Pblock の移動
	Pblock のサイズの変更
	[Set Pblock Size] コマンドの使用
	複数の長方形がある Pblock を変更
	Pblock 長方形の削除
	Pblock の名前の変更
	Pblock の削除
	Pblock プロパティの表示または変更
	Pblock ロジック タイプ範囲の設定
	Pblock の属性の設定

	リソース使用率の統計を使用した Pblock のサイズの決定
	接続に基づいた Pblock の配置
	バンドル ネット プロパティの表示
	バンドル ネットのデフォルトの変更

	Pblock の自動コマンドの使用
	Pblock の自動作成
	Pblock 自動配置プログラムの実行

	配置 LOC 制約
	固定された配置制約および固定されていない配置制約について
	サイト制約および BEL 制約について
	サイト ロケーション配置制約 (LOC) の割り当て
	BEL 配置制約 (BEL) の割り当て
	配置制約の表示/非表示の変更
	接続の表示切り替えを使用したロジック接続の表示
	配置制約の移動
	選択した配置制約の削除
	選択した配置制約の削除
	Pblock と割り当てられた配置制約の移動
	ISE インプリメンテーション中の配置のロック
	PHOHIBIT の設定

	IP 再利用機能の使用
	IP 再利用の概要
	IP モジュールの作成および再利用
	同一のモジュールへの配置のコピー


	11 : ChipScope を使用したデザインのデバッ グ
	PlanAhead と ChipScope の統合の概要
	コア挿入フローを使用する場合の要件および制限
	コア挿入フローの使用
	デバッグ コア挿入モードの決定
	デバッグのためのネットの選択
	ChipScope ウィザードを使用したデバッグ コアの挿入
	ChipScope ウィンドウを使用したデバッグ コアの追加とカスタマイズ

	デザインのインプリメンテーション
	ChipScope Analyzer の起動

	付録 A : メニューおよびツールバー コマンド
	メイン メニュー コマンド
	[File] メニュー
	[Edit] メニュー
	[View] メニュー
	[Tools] メニュー
	[Window] メニュー
	[Select] メニュー
	[Layout] メニュー
	[Help] メニュー

	ツールバー コマンド

	付録 B : XilinxUpdate を使用したインストール
	PlanAhead のリリース ストラテジ
	XilinxUpdate の実行
	アップデートの自動検出

	付録 C : パスワードなしの SSH の設定
	SSH の設定

	索引


