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Xilinx is disclosing this Document and Intellectual Property (hereinafter “the Design”) to you for use in the development of
designs to operate on, or interface with Xilinx FPGAs. Except as stated herein, none of the

Design may be copied, reproduced, distributed, republished, downloaded, displayed, posted, or transmitted in any form
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Xilinx does not assume any liability arising out of the application or use of the Design; nor does Xilinx convey any license
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engineering or technical support or assistance provided to you in connection with the Design.
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The PlanAhead™ software code includes source code for the following programs:

CenterPoint XML

The initial developer of the Original Code is CenterPoint — Connective Software.
Software Engineering GmbH.

Portions created by CenterPoint — Connective Software

Software Engineering GmbH are Copyright © 1998-2000

CenterPoint - Connective Software Engineering GmbH. All Rights Reserved.
Source Code for CenterPoint is available at http://www.cpointc.com/XML/

NLView Schematic Engine

Copyright © Concept Engineering.

Static Timing Engine by Parallax Software Inc.

Copyright © Parallax Software Inc.

Java Two Standard Edition

Includes portions of software from RSA Security, Inc. and some portions licensed from IBM are available at
http://oss.software.ibm.com/icu4j/

Powered By JIDE

http://www.jidesoft.com

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY
EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR
TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

www.xilinx.com



& XILINX.

Free IP Core License

This is the Entire License for all of our Free IP Cores.

Copyright (C) 2000-2003, ASICs World Services, LTD. AUTHORS
All rights reserved.

Redistribution and use in source, netlist, binary and silicon forms, with or without modification, are permitted provided
that the following conditions are met:

Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following
disclaimer in the documentation and/or other materials provided with the distribution.

Neither the name of ASICS World Services, the Authors and/or the names of its contributors may be used to endorse or
promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND ANY
EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR
TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
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PlanAhead Software Tutorial

Design Analysis and Floorplanning for
Performance

Introduction

This tutorial introduces some of the capabilities and benefits of using the Xilinx® PlanAhead™ software for
designing high-end FPGAs. The document consists of a series of step-by-step exercises highlighting
methods to achieve and maintain better performing designs in less time. The steps detail the following:

e Pre-implementation design and analysis capabilities.

e Implementation exploration features.

e Implementation results floorplanning.

Note: This tutorial covers a subset of the features of the PlanAhead software product bundled with the
ISE® Design Suite. Additional features are covered in detail in other tutorials.

If you have any questions or comments regarding this tutorial, contact Xilinx Technical Support.

Sample Design Data

This tutorial uses sample design data that is included with the PlanAhead software. The tutorial design
data is located in the following directory:

<ISE_install_Dir>/PlanAhead/testcases/PlanAhead_Tutorial.zip

Extract the zip file into any write-accessible location to perform the tutorial. The location of the unzipped
PlanAhead_Tutorial datais referred to as the <Extract_Dir> throughout this document.

Note: If you are using the location,
<ISE_install_Dir>/PlanAhead/testcases/PlanAhead_Tutorial, you can use the
Getting Started > Open an Example Project links to open the tutorial designs. When you run
the tutorial exercises, the sample design data is modified.

Each time you run through the tutorial a new copy of the original PlanAhead_Tutorial data is required.
This tutorial requires that you run a design through implementation.

This design is intentionally small to allow the tutorial to be run with minimal hardware requirements and to
enable timely completion of the labs. It may not be the best candidate for performance improvement
through floorplanning because typically the best results are seen with the larger devices.

£ XILINX. www.xilinx.com 7
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Xilinx ISE and PlanAhead Software

The PlanAhead software is installed with ISE Design Suite. Before starting the tutorial, ensure that the
software is operational and the sample design data is installed. For installation instructions and
information, refer to ISE Design Suite 12: Installation, Licensing, and Release Notes:
http://www.xilinx.com/support/documentation/sw_manuals/xilinx12_3/irn.pdf

Access to the Xilinx ISE Placement and Routing software is required. The tutorial results may be different
with other ISE releases.

Xilinx Command Line Tools

To perform this tutorial, you must have access to the Xilinx command line tools, including the following:
NGDBuild, Map, PAR, TRACE and XDL. Previously run ISE results are included and used in the tutorial.
Required Hardware

A minimum of 2 GB or more of RAM is recommended for use with PlanAhead software on larger devices.
For this tutorial, a smaller xc6vIx75t design is used, and the number of Planners open at one time is
limited. 1 GB is sufficient, but it will impact performance.

PlanAhead Software Documentation and Information

For information about the PlanAhead software, see the following documents:
o PlanAhead User Guide (UG632) - Provides detailed information about the PlanAhead software.
http://www.xilinx.com/support/documentation/sw_manuals/xilinx12_3/PlanAhead UserGuide.pdf

e  Floorplanning Methodology Guide (UG633) - Provides floorplanning hints.
http://www.xilinx.com/support/documentation/sw_manuals/xilinx12 3/Floorplanning Methodology Guide.pdf

For additional information about PlanAhead, including video demonstrations that cover the benefits of
using the software and more tutorials, go to http://www.xilinx.com/planahead.

Tutorial Objective

This tutorial takes you through of the various analysis, floorplanning and implementation features of the
PlanAhead software. The exercises cover the following topics:
e Analyze device utilization statistics to target alternate devices and choose the optimal device.

¢ Run Design Rule Checks (DRC) to quickly resolve constraint conflicts that would otherwise cause
implementation errors.

o Use the Netlist, Logic Hierarchy, and Schematic views to explore logic.

e Perform a quick estimation of timing performance to assess design feasibility and identify
potential problem areas.

e View, modify, or create constraints in the design.

e Analyze the design hierarchical connectivity and data flow as well as identify critical logic
connectivity and clock domains.

e Floorplan the timing critical logic to improve timing.

When completing this tutorial, focus on the processes and functionality of the PlanAhead software to
determine how you can take advantage of these features in your designs.

8 www.xilinx.com £ XILINX.
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Tutorial Steps

This tutorial is separated into steps, followed by general instructions and supplementary detailed steps
allowing you to make choices based on your skill level as you progress.

This tutorial introduces the pre-implementation design analysis features of the PlanAhead software.
These features enable early detection of potential design issues, exploration of alternate devices, and
floorplanning.

This tutorial has the following steps:

Step 1: Viewing the Device Resources and Clock Regions
Step 2: Exploring the Logical Netlist Hierarchy

Step 3: Displaying Design Resources Statistics

Step 4: Running Design Rule Checks (DRC)

Step 5: Performing Timing Analysis

Step 6: Modifying the Design Timing Constraints

Step 7: Exploring Logic in the Schematic

Step 8: Implementing the Design

Step 9: Analyzing the Timing Results

Step 10: Highlighting Module Level Placement

Step 11: Exploring Connectivity

Step 12: Using Placement Constraints

Step 13: Viewing Hierarchical Connectivity

Step 14: Using the Search Capability to View Clock Domains
Step 15: Floorplanning Timing Critical Hierarchy

If you need help completing a general instruction, go to the detailed steps below it, or if you are ready,
skip the step-by-step directions and move on to the next general instruction.

£ XILINX. www.xilinx.com
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Step 1: Viewing the Device Resources and Clock Regions  Step 1

1-1. Launch the PlanAhead software.
1-1-1. Open the CPU (Synthesized) Project with the top_£full Constraint Set active.

. On Windows, select the Xilinx PlanAhead 12 Desktop icon or
click Start > Programs > Xilinx ISE Design Suite 12.3 > PlanAhead > PlanAhead.

. On Linux, cd to the
<Extract_Dir>/PlanAhead_Tutorial/Tutorial_Created_Data directory, and
enter planAhead.

The PlanAhead environment opens (Figure 1).

[@] PlanAhead 123 =N =R

File Tools Window Help

PlanAhead® 1

Getting Started Documentation
) : .
/_’] Create New Project BTSE = ) What's New
i\ New Project Wizard will guide you through the process of selecting \Z Important information regarding this release of Planahead.
\ design sources and a target device for a new project.

=\ Open Project User Guide
A8\ &)
\E f Open any previously created project. E rx More detailed info on PlanAhead commands, dialogs, and buttons.

yir Open Recent Project
‘\ 'g Open one of the most recently used projects.

Open Example Project
Open one of the tutorial projects.

Td Console — 0O o x

_ Methodology Guides

Further assistance adopting FlanAhead flows.

PlanAhead Tutorials

Invaluable for first time users or to try new features.

i} Pa&itH

No Project | ¢

Figure 1: PlanAhead Getting Started Page
Notice the PlanAhead Getting Started page with links to open or create projects and to view
documentation.

1-1-2. Select File > Open Example Project > CPU (Synthesized).

The PlanAhead environment opens (Figure 2).

10 www.xilinx.com £ XILINX.
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[@] project_cpu_netlist - Project Manager - [C:\Xilins\planAhead\testcases\PlanAhead_Tutorial\Projects\project_cpu_netlist\project_cpu_netlist.ppr] - PlanAhead 12.3 =R
File Edit View Flow Tools Window Select Layout Help
EEwoaX AL/ PEDE®| Ready
Project Manager Project Manager
: . Sources - 0O a X ol
45 Project Settings | 4% Project Settings Edit (4 [@] Project State %
= o= wet i =
045 Add Sources — - — Project Mame:  project_cpu_netlist Status: Ready
=+ Design Sources (<) )
E;}- Add/Create Constraints 5= EDIF (4) Product Family: Virtexs MNextStep:  Implement
. H i @ usbEngine 1£ushf_top.edf DefaultPart:  xcBvlx75tff784-1
Project S =
E roject summary i @ usbEngine0#usbf_top.edf m
- . : top.edf (top) Compilation %
| Metlist Design |v| %: FF;E' \;;':tT df %
. rjglne op.& Implementation
== Constraints (2)
I) - - constrs_1 (=ctive) Part: wcbvlx75tF784-1
¢ Implement ¢ e top_fullucf (target) H Strategy:  [SE Defaults
& E constrs_2 Constraints: constrs 1
| D |v| w8 o top_fipn.ucf (target)
Resources FS
‘ . Resource information is not available.
eneee @ Implemented Timing E3
Timing information is not available,
Next:  Implement
-@ijectsummarv x 4@
J
Td Console - 0O g
; open_project {C:\Xilinx\planAhead\testcases\Flanthead Tutorial\PFrojects\project_cpu netlist\project_cpu netlist.ppr} -
NFO: [HD-ProjDB 1] Scanning sourcea...
NFO: [HD-ProjDB 2] Source 3can complete
3
Post-Synthesis Flow

Figure 2: PlanAhead Environment

1-1-3. In the PlanAhead main window, ensure that the Constraints constrs_1> top_full.ucf is
active (Figure 3).

Sources - [

T = m et 2[E
== Design Sources (4)
. =1 EDIF (4)
“.{ffi = usbEngine1usbf top.edf
i = usbEngined#ushf_top.edf
i-{fie top.edf (top)
L@ fRENgine #fftTop.edf
== Constraints (2)
E&E‘ constrs_1 (active)
‘0% o top_fullucf (target)
[} constrs_2

o
-

Figure 3: Sources View with Constrs_1

£ XILINX. www.xilinx.com 11
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1-1-4. Open the design and constraints by clicking on Netlist Design in the Flow Navigator (Figure 4).

Netlist Design -

Figure 4: Netlist Design button

1-1-5. The tool will now open the netlist and top_full.ucf as shown (Figure 5).

E project_cpu_netlist - Netlist Design - [C\Xilinx\planAhead\testcases\PlanAhead_Tutorial\Projects\project_cpu_netlist\project_cpu_netlist.ppr] - PlanAhead 123 EI@
File Edit View Flow Tools Window Select Layout Help
FECRMAXHFTERLHBEPARAD BOFG WS Ready
o i i i strs SH784-1 (active)= AL i Design Pla 0 Pla
TR otis Design _netlisL 1 _const 1 | xc5v:7534-1 (ectie): TR v O X
Metlist — O a 1
Netlist Design - ¢ T
= g
oo 7l P
Resource Estimation =
@ RunDRC b
I,
[ Run Noise Analysis I
[
@ Report Timing N |
53 I
m Slack Histogram 4 I
\@ Set up ChipScope =]
[> &
ags
; v a8
Implement
€ £
b
&
:4% £ Sources | £ Timing.. | [B Physica::, [ Netlist
L. B
Properties — O g I’Q?
¢ & |5k
K
2
4
« '@
@ Device x| I, ProjectSummary X 4 @
Td Consale -0 g =
Z INFO: [HD-UCFReader 0] Parsing UCF File : C:\Xilinx\plankhead\testcases\Plankhead Tutorial\Projects\project_cpu netlist\project_cpu_netlist.srcs\cc »
g INFO: [HD-UCFReader 1] Finished Parsing UCF File : C:\¥ilinx\plankhead\testcases\Plankhead Tutorial\Projects\project_cpu netlist\project_cpu netliz
=
) { INFQ: [HD-LIE 0] Reading timing library C:/Xilinx/planthead/./parta/xilinx/virtexé/virtexé.lik .
@ INFO: [HD-LIBE 1] Done reading timing library C:/Hilinx/plankhead/./parts/xilinx/virtexé/virtexé.lib .
Eﬂ .:.
< I r
2 Tcl Console | [5 Reports
Post-Synthesis Flow

Figure 5: CPU Netlist in Netlist Design

1-1-6. In the Device view, use Zoom Area to examine various device resources as follows:

Click in the upper left corner of the device, and drag down and to the right. This will draw a Zoom
Area rectangle. Repeat to generate an area small enough to see the device resources (Figure 6).

12 www.xilinx.com £ XILINX.
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Figure 6: Zooming into the Device to view CLBs and Logic Gate Sites.
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1-1-7. Slowly, move the cursor over the various device resources to view the tooltips, and take note of
the following:
e SLICE coordinates appear in the status bar at the bottom of the PlanAhead main window.
e If the mouse lingers on a site a tooltip shows the same.
e |/O port locations and I/O buffer assignments appear inside 1/0O banks.
e Tall magenta tiles indicate a RAMB36 site that can also hold two RAMB18s or a FIFO.
e Tall cyan tiles indicate sites for two DSP48s.
e Square blue tiles are a CLB containing 2 SLICEs.
1-2. Select any sites and notice that the Site Properties view displays
information about the site.
1-2-1. Select several different types of Sites and view the Site Property information.
1-2-2. Click in the Device view and drag the cursor up and to the left, or press the Ctrl+G keys to Zoom
Fit the Device view to see the whole device.
The Device view shows the clock regions, which you can use to help guide floorplanning. The
Clock Region view lists all of the Clock Regions in the device. The Clock Region Properties view
displays clock region information to indicate potential clock contentions prior to implementation.
Viewing Clock domains is covered later in the tutorial.
1-3. Open the Clock Regions view.
1-3-1. Display a clock region in the Device view as follows:
e Select the Window > Clock Regions command.
e Select one of the clock regions listed in the table.
The clock region is highlighted in the Device view (Figure 7).
£ XILINX. www.xilinx.com 13
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Netlist Design - netlist_1 - constrs_1 | xcbvlx75tff784-1 (active)«

|2

Clock Regions - 0O a = 2 ] —— B = == ==
€ = £ £ = EEE |
Id MName Row  Column P o == E = : |
1 X0Y0 0 0 = _D —— E = f o E9ES
] oo 1] (] ¥l e ES SIS=(E g CRIESNES
3 X0Y2 2 0 158 z E= = ==
4 %10 0 1 ) z == H H aRH
5 X1Y1 1 1 & B = g ==
& X1Y2 2 1 Y & == EEER ERIERE = =
Il = 1 s | & e B e e — a8 [
r = ' Sl=
1 B an | B
1 = ==
?_3 L = apH
aga 1 = an | B
o 1 = == == =
fis ik = Eil==ll==
3 o i [ 1
" 4 ns = (=] f o | oo
o ola H ERlE= ==
éﬁ’ L = BH EHIEH
& Sou.. | @ Tmi.. | B Phys..| 1 Netis, m Clo., | | = o Sl=s| ==
: E ERIESSS
Clock Region Properties — O g x o 2k = i Sl==i==
= ' = d E =
¢ oEE " | i
B = T A FEIEEmE BM O
X0Y1 . E = == = ] Lhl=
® EEEE | e
i = - = =
Physical Resource Estimate: = EK & = 3 : =
Type of Site Count "e’ f ff i Z f
GLOBALSIG 31 = == E ==
PMY 1 T e ) e 0
TIEQFE 1264 - < m @
General | Statistics | Resources | If0 Banks & Device * ¥ Project Summary X ]|

Figure 7: Viewing Clock Region Properties

1-3-2. Click the Properties view to show the Clock Region Properties view. If the properties window is

not visible use the Windows > Properties command.

1-3-3. Click the Statistics tab, and scroll to examine the logic contents. (Shown in the bottom of
Figure 7).

1-4. Explore Clock Region resources

1-4-1. In Properties click on the Resources tab to see the locations of the BUFR and IDELAYCTRL sites.

1-4-2. In the Resources list, select one of the BUFRs, and notice it is highlighted in the Device view.

1-4-3. Right-click and select Mark to mark the site.
1-4-4. Select the Fit Selection toolbar button A to view the selected objects.

1-4-5. Select the Unmark All toolbar button @( to remove the mark.

1-4-6. In the Device view, Zoom Fit to fit the whole device.

1-4-7. In the Clock Region Properties view, click the I/O Banks tab to examine the 1/0 Banks related to

the clock region.

1-4-8. In the Clock Region Properties view, select one of the I/O banks, and notice it is highlighted in the

Device view as well.

14 www.xilinx.com £ XILINX.
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1-4-9. Click the I/O Planner button. from the title bar to enter the pin planning
layout.

The view layout has changed to make it easier for pin planning. The Package view is now open.

The 1/0 bank is highlighted in both the Device and Package views.

1-4-10. Click the Design Planner button to return to the default layout.

£ XILINX. www.xilinx.com
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Step 2:Exploring the Logical Netlist Hierarchy Step 2

2-1. Use the Netlist view to explore the design hierarchy.

2-1-1. In the Netlist view, click the Collapse All toolbar button &

2-1-2. Click the expand widget next to cpuEngine to expand the module.

The Netlist should now look similar to the one shown below (Figure 8).

Metlist O *
< H[E
ﬂ kop =

- Mets (1026)

B[ Primitives {153

EI cpuEngine {orlZ00_kop)

[ [ Nets (2215)

[#- [ Primitives (11

- [ cpu_dbg_dat_j (FifcBuffer MO1 cpu d

- [@] cpu_dbg_dat_o (FifoBuffer_MNOZ_cpu_c

- [G@] cpu_dwb_dat_i (FifoEuffer)

cpu_dwb_dat_o (FifoBuffer_cpu_dwb

- [@] cpu_iwb_adr_o (FifoBuffer_MO3_cpu_i

cpu_iwb_dat_i (FifoBuffer MO cpu_in

-[@] cpu_iwb_dat_o (FifoBuffer _MOS_cpu i

- [@] dwib_biu {or1200_wh_bid)

itaby_biu {or 1200 _iwb_bia}

-[@] or1200_cpu {or1200_cpu)

- [@] or1200_dc_top {or1200_dc_top)

- [@] or1200_dmmu_top {or 1200_dmmu_top]

- [@] or1200_du (or1200_du) o

arl 200_ic_kop {orl 200 _ic_kopd

-[@] or1200_imnu_top for 1200 _imnmu_top)

- [G@] or1 200 _pic for 1200_pic)

- [T or1200_pm (or 1200_prm)

- [G] or1 200 _grmern_top l{n:nrlEIJEl_qmem_tn:n_pH
| f

+

+

-

Figure 8: Expanding the Netlist View
Note: There is a Primitives folder in the Netlist view that contains the top-level instances of each
module.

2-1-3. Expand the Primitives folder. These are the instances immediately under the cpuEngine level,
not in any sub-module.

2-1-4. Expand the Nets folder. These are the nets immediately under cpuEngine.

2-1-5. In the Netlist view, click the Collapse All toolbar button % to simplify the netlist view.
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2-2. Select netlist modules and view where the logic resides in the design
hierarchy.

2-2-1. In the Netlist view, expand the usbEngine0 module.
2-2-2. Select the u4 module.
2-2-3. Right-click and select the Show Hierarchy command.

2-2-4. The Hierarchy view opens in the Workspace (Figure 9).

Netlist Design - netlist 1 - constrs_1 | xcbvlx75tff784-1 (active)« g i 1/0 Planner

Metlist - 0O a X

= >El

Moe

(= Nets (1025)

I Primitives (153)

[&] cpuEngine (or 1200_top)

[&] fftEngine (fftEngine#fftTop)

[&] mgtEngine (motTop)

usbEngined (usbEngined#usbf_top)

= Nets (738)

(=) Primitives [102)

[&] dma_out (FifoBuffer)

[@] u0 (usbf_utmi_if)

[@] vl (usbf_pl)

[@] u2 (usbf_mem_arb)

m

[@] u5 (usbf_wb)

[&] usbEngineSRAM (rtR.am)

[&] usb_dma_wb_in (FifoBuffer_usb_dma_wb_in)
(- [@] usb_in (FifoBuffer_NO1_usb_in)
= [@] usb_out (FifoBuffer_NO2_usb_out)

--[@] usbEngine1 {usbEngine 1#usbf_top)

-[@&] whArbEngine (wh_conmax_top)

R4k X

et
(£}

[r
k)

‘ '@
& Sou., l@‘ﬁmi” Phyﬁ)\m netl.. L Cloc.. ] @ Device X | E Project Summary % @' Hierarchy X] 4 b B

Figure 9: Displaying the Instance Hierarchy View

The Hierarchy view displays the hierarchical relationship of the modules and the relative sizes. The
selected logic module displays in the Hierarchy view, which is useful to visualize the module location and
relative size prior to floorplanning. You can select modules directly from this view for floorplanning. Logic
selected in other views is highlighted in the Hierarchy view.

2-2-5. Select any module in the Hierarchy view, and notice it is selected in the Netlist view as well.

2-2-6. Click the Unselect All main Toolbar button, R or press F12.
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Step 3: Displaying Design Resources Statistics Step 3

The PlanAhead software utilization analysis provides design statistics to help determine the
optimal device for the design. The tool helps the user see how the logic resources are split
between modules. It is easy to explore multiple device types to determine the best overall
utilization and performance estimations.

3-1. View the resource estimates of the entire design.

3-1-1. In the Flow Navigator, select Netlist Design > Resource Estimation, or click the Resource
Estimation toolbar button.
The Resource Estimation opens in the Workspace.

3-1-2. Double click on the Resource Estimation tab to maximize the window. Alternately, right-click on
the Resource Estimation tab and select Maximize from the popup menu. The Resource
Estimation view shows resource utilization per level of design hierarchy (Figure 10).

Note that tabs in the Workspace do not have buttons in the upper right for Maximize and the other
window actions. The window actions are available via right-click menu on the tab instead.

3]

Resource Utilization
Estimated resources are compared with xcavlx75tfra4-1.

Reqgister

Available: [ ] 23120

m

Estimation: +- ] 14981 (16% of availzble) top

LuT

Availzhle: I | 46560

Estimation: -] ] 20701 (44%: of avalable) top

Blodk Memary

Available: [ ] 156

Estimation: [ | 126 (30%: of available) top

D5P43

Available: [ ] 288
Estimation: - 100 (3456 of available) top

Figure 10: Resource Estimation View

3-1-3. In the Resource Estimation view, click the expand widget next to Estimation under Block
Memory (Block RAM). You will see that usbEngine0 and usbEnginel are the two largest
consumers of Block RAM.

3-1-4. Try expanding some of the other resources.
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3-1-5.
3-1-6.

3-1-7.

3-1-8.
3-1-9.

3-2.

3-2-1.

3-2-2.
3-2-3.
3-2-4.
3-2-5.

3-2-6.

Select usbEnginel from the Block RAM Estimation section.
Click the Hierarchy tab.

Note: The usbEnginel is selected in the hierarchy browser as well. Selecting something in one
view selects the object in other views as well.

Click the X button & Hierarchy < {5 cjose the Hierarchy view.

Click the X button %l Resource Estimation x| {5 close the Resource Estimation view.

Select Layout > Load Layout > PlanAhead Defaults to restore the default window layout.

Explore the Resources in a more detailed view.

This is another way to see the resources in the part. The tool does not break apart resources by
hierarchy. The view gives some more detailed information.

Select the Physical Constraints view from the upper left of the Main Viewing Area (Figure 11).

Netlist Design - netlist_1 - constrs_1 | xcbx75tff784-1 (active)«

Physical Constraints — O o #
™ o i
A= =

|3| netlist_1
E""'IE-ﬂ ROOT

& Sources | £ Timing C.. Physica.. | ] Metist Clock Re..

Figure 11: Physical Constraints View

Select the ROOT design

Select the Pblock Properties view.

Select the Statistics tab, if necessary.

View the Physical Resource Estimates displayed in the Pblock Properties view (Figure 12).

Maximize the Pblock Properties using L in the upper right corner of the Properties view..
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Phlack Properties - O " Pblock Properties - O a
< g hdhd:C L g
(e] ROOT @ Roor
i TEMAC_SINGLE 4 [¥] 0 ke
Physical Resource Estimates USR_ACCESS 1 0 ]
Site Type Available  Reguired Carry Statistics
LuT 46580 20701 45 _ _
FO_LD 93120 14381 17 Mumber of carry chains  Lonagest chain
SLICEL 7480 3301 45 400 cpuEngine/cpu_dba_dat_i/buffer_fifoMcoun
SLICEM 4130 1875 45
BSCAN 4 0 0 Clock Report
BUFGCTRL 32 16 50 1 Domain (Module) Resource
BUFHCE 72 0 0|37 DIVZ_OUT{ MGT_USRCLK_SOURCE ) Global
BUFIODQS 36 a 0 DIVZ_OUT{ MGT_USRCLE_SOURCE_NO1_txoutdk_dcm1_i ) Global
BUFR 13 0 0 DIVZ_OUT{ MGT_USRCLK_SOURCE_NO2_txoutck_dcm2_i) Global
CAPTURE 1 a 0 DIV2_OUT{ MGT_USRCLK_SOURCE_twoutdk_dcm_i ) Global
CFG_IO_ACCESS 1 1] 0 adr[2] _GMD_376_o_Mux_6_o_BUFG( usbf rf) Global
DCI 9 a o] cpuClk_BUFGP{ top ) Global
DCIRESET 1 0 0 fftClk_BUFGP( top ) Global
DMA PORT i i) i} phy_dk_pad_0_i_BUFGP( top ) Global
DSPASE1 283 100 3 | phy_ck_pad_1_i_BUFGP(top ) Global
EFUSE ISR 1 1] LISbC"(_BUFGP{ tDD ) Global
FRAME ECC 1 o whClk_BUFGP{ top ) Global
GTXEL 12 8 &7 »
IBUFDS_GTXE1 5 0 0 DSEEE
ICAP 2 a a IOPorts BondedIOs  Utilization
IDELAYCTRL g 0 0 144 477 34.12 %
ILOGICEL 360 a 4]
IODELAYEL 350 a 1] Primitive Statistics
MMCM_ADY [ 4 &7 S =
OLOGICE 380 a 0 Primitive type Count
PCIE_2_0 1 0 0 Lot 21120
PMVERAM 21 o 0 e (=]
2 oo | e
RAMBFIFO35EL 156 126 81 BMEM 135
>=RAMBFIFQ356E1 117 MULT 100
=RAMB13E1 13 CLK a0
STARTUP 1 a 0 0 141
SYSMON 1 0 0 DMEM 173 1
TEMAC_SINGLE 4 0 o|f~ OTHERS 235 0l
1| i} 3
< | m 3
e Sttt e R e General | Statistics | Instances | Rectangles | Attributes

Figure 12: Viewing Design Resource Statistics

3-2-7. Scroll through the design statistics displayed in the Pblock Properties view.

Note: The Statistics tab shows the device resource utilization for each type of logic element, carry
chain count, longest length, Clock Report, 10 utilization, and Primitive instance and interface net
counts. If this design had any RPMs, the RPM count and maximum size information would be
shown also.

3-2-8. Restore the Pblock Properties & .

£ XILINX.
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Step 4: Running Design Rule Checks (DRC) Step 4

Xilinx recommends running the Design Rule Checker before implementation to check for some

common design issues. The ISE place and rotue tools have the set of sign off DRCs and take
precedence over the DRCs in this tool.

4-1. Run the Design Rule Checker (DRC).
4-1-1. Select Tools > Run DRC.
The Run DRC dialog box appears (Figure 13).

P

fe’] Run DRC ==
Results Mame: |results_1

Output File: (=]
Rules to Chedk: 51 of 51

M iy A
S = [

=i All Rules (51]
Floorplan (5]

Bank (16]
-3 DCI (2
ClkBuf (1]
108 (2]
DSP43 (5]
RAMB16 (1]
- Netlist (3]

[ Select All H Clear All ]

[ oK ] [ Cancel

Figure 13: Running DRC

4-1-2. Click OK to run all rule checks.
The DRC Results view opens and indicates that there are several DSP48 warnings (Figure 14).

DRC Results - results_1 {235 violations)

= 0O a x
ey =1
N | Mame Severity  Details
|| 22 Al Viclations (235) -
= =J-[£ DSP48 (231) B=
= |- & DSP output pipelining (DPOF)
= ([ DPOP #1 Warning  DSP Mmult_xi[31]_vi[31]_MuLt_2_OUT2 output is not pipelined. Pipelining DSP48 ouput will improve performance. Both ...
& DPOP #2 Warning  DSP Mmult_xi[31]_yi[31]_MuLt_2_OUT1 output is not pipelined. Pipelining DSP48 ouput will improve performance. Both ...
DPOP #3 Warning  DSP Mmult_xi[31]_vi[31]_MulLt_2_OUT output is not pipelined. Fipelining DSP48 ouput will improve performance. Bath ... 7
DPOP #4 Warning  DSP Mmult_n0027 output is not pipelined, Pipelining DSP48 ouput wil improve performance, Both multiplier fadder outpu. .. =]

@ results_1 (235 violations) x 4 B

Figure 14: Design Rule Violations Window
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Errors, warnings and information messages appear in the DRC Results window. Errors are
indicated by a red icon. Warnings are indicated by an orange icon. Information messages are
indicated by a yellow icon. Even if the DRCs issue an Error, implementation may complete

successfully.
4-1-3. In the DRC Results view, click the DPOP #1 Warning.

The Violation Properties view opens and describes the violation.

4-1-4. In the Violations Properties view, click Mmult_xi[31]_yi[31]_MuLt_2_ouT2 (Figure 15).

Wiolation Properties — O g =
B k| K

i DPOP #1

DEP Mwalt x3i[317 wil[317 Mult 2 0OUT: output is not

pipelined. Pipelining DEP43 ouput will improve

performance. Both multiplier/adder output can be
pipelined.

£ >
General | Details
Figure 15: Violations Properties Window

4-1-5. Select the Netlist view.

Notice that Mmult_xi[31]_yi[31]_MuLt_2_0UT2 is selected (Figure 16).

Metlisk e
= 7l |[E
— o 1200 _rult_mac Cor 1200 _mulk_mac) L
G- = Nets (1395)
b [ Primitives (12181
= arl 200_grmultpZ_32x32 (or 1 200_gmultp?_32x32)
G- Nets (370)
=) [ Primitives (40
e [ Mmult [ 31 ]_wi[31]_MuLt_2Z_oUT (DSP4EE L)
e [ Mrmult_d[31]_vi[31]_MuLt_Z_oUT1 (D5P4sEL)
Sl _xi[31]_wil31]_Mult_2_OUTZ (DSP43E1)
e [ Mrmnult_[31]_vi[31]_MuLt_2_OUT3 (D5P43EL )
o [ Mimult [ 31 ]_wi[31]_MuLt_2_oUT4_0 (FOR)
e Ml il 31 sl MO 2 oIT4 1 (FORY b
'] Netlist Physical Constraints | £ Timing Conskraints

H

0

Figure 16: Instance in Netlist View

4-1-6. In the DRC Results view, scroll down the list of violations.
4-1-7. Close the DRC Results view by clicking the X button in the tab.
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Step 5: Performing Timing Analysis Step 5

Before running implementation it can be usefull to determine the feasibility of the design’s timing
constraints to perform an early static timing estimation, including estimated route delays. These
timing numbers are estimates of what will happen in the FPGA. The implementation step is the
only way to get sign-off timing numbers. That information only shows up when importing a run.
This step will show what can be done to investigate timing before synthesis. Keep in mind the
Report Timing and the Slack Histogram commands do not show sign-off timing numbers.

5-1. Analyze timing end points in the Slack Histogram.

The tool will bin the end points based on slack and present a histogram. It is possible to visualize
how many end points are tight on timing versus those that have a margin.

5-1-1. Select Tools > Slack Histogram.
5-1-2. Change the Number of bins to 20.

The Generate Slack Histogram for Endpoints dialog box should look like the one in Figure 17.

@8 Generate Slack Histogram for Endpoints

Histogram name: | results_1
Qptions | Timer Settings

Endpoint Scope

Delay type:  max -

Clock, nare:

(]
Group name: E]

Slack Range

Greater than: Ise default
Less than: Use default
Bin Display

Mumber of bins: 0%
Significant digits: ]

Command: |create_slack_histogram -delay_tvpe max -num_bins 20 -si

[ o] 4 l [ Cancel

Figure 17: The Generate Slack Histogram for Endpoints Dialog Box

5-1-3. Click the Timer Settings tab.
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5-1-4.

5-1-5.

ERER S

Mumber of Endpoints

9000

8000

W L=y} |
[=] [=] [=]
[=] [=] [=]
[==] [=] [==]
1 1 1

4000 3

3000 4
4=

3955 3785
1000 731
e . 6 24 15 _84 46

Inspect the settings.

Note: The Timer Settings tab lets you change how the tool accounts for route delay. The timer
can estimate route delay or assume there is no interconnect routing delay.

Click OK.
A histogram will display showing binned end points (Figure 18).

4575

Id MName Slack  Type  Group  Ct
(=3 1 fitEngine/fftInst/arnd 1/transformLoop[0].ct/Madd_xReg[15]_uReg[15]_add_4 OUT1fA[0] -0,525 Pin -
o 2 fitEngine/fftInstfarnd 1/transformLoop[0]. ct/Madd_xReg[15] _uReg[15]_add_4_OUT1fA[10] -0,525 PFin =
o 3 fftEngine/fftinstfarnd 1/transformLoop[0]. ct/Madd_xReqg[15]_uReg[15]_add_4_OUT1fA[11] -0.525 Pin 1
l.:h.l A T nnime Tt e d 1 e freeal aaa Dol .;ur-rmn—..-l.-l 2ellnal1ET o neal1El A4 A marmaiala7l | M C7E M . @
@ Device x | E Project Summary X l [Il| Histogram - results_1 xJ 4 b B
Figure 18: Slack Histogram
Notice the failing end points are displayed in the red bin on the left side of the slack 0 column
separator. These end points are expected to have timing problems.
5-1-6. Click on various bins.
Note: The end points in the lower view filter as the bins are selected. The slack range is also
updated.
5-1-7. Select the left most bin, which is the bin with endpoints expected to fail timing.
5-1-8. Inspect the end points.
Note: Most of the timing end points are Block RAMs in the fttEngine block.
5-1-9. Select an instance from the filtered histogram report. It cross selects in the netlist view.
5-1-10. Click the X button to close the histogram Il Histogram - results_1 x|
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5-2. Run Timing Analysis and analyze the initial results and information in the
Timing Results view.

5-2-1. Select Tools > Report Timing.

The Report Timing dialog box opens (Figure 19) to the Targets tab, which enables you to specify

timing start and end points.

(8 Report Timing ['5_<|

Results Mame: | resulks_1 |

Targets | Options | Advanced | Timer Settings

Start Paints

Fram: | | E

Through Paink Groups

[Rsiral -]
1. Thraugh: | | E] I:I

Mare

End Points

Toi | s [issiral_~]

Command: |repurt_timing -delay_type max -path_tvpe full_clock_expanded -|

[ ok |[ Cancel ]

Figure 19: Running Timing Analysis.
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5-2-2. Select the Options tab (Figure 20).

rE Report Timing gy | I — Iﬂ1

Results Mame: |results_1

Targets: Options | Advanced | Timer Settings

Report
Path delay type: max -

Path report format: |full_dod:_expanded -

[7] Do not report unconstrained paths

I
Path Limits
Mumber of paths per group: 3D| =
Mumber of paths per endpoint: 1F
Limit paths to group: E]
Path Display

Display paths with slack greater than:
Display paths with slack less than:

Significant digits: =

Sortpathsby:  slack -

Command: |report_timing -delay_type max -path_type ful _dodk_expanded

Ok l l Cancel

Figure 20: Report Timing Options Tab

5-2-3. In the Number of paths per group field, type 30.

5-2-4. Click the Advanced and Timer Settings and inspect the tabs. Do not change anything.
5-2-5. Click OK to run analysis.

The Timing Results view opens (Figure 21).

Timing Results - Repart Timing - resulks_1(30 paths) - O a *

A | Wame Type Slachk- 1 Fram To

,LZE =% Constrained Paths (30} ~

ety % Path1 Sebup -0.525 FFEngine/FFtInstfarnd1 transFormLoop[0]. ck/Mmult_n0027/P[13] FFtEngine FFtInstfarnd] ftransformLoop[0].ctjMadd_xReqg[15]_uReg[15]_add_4_OUTI1fA[0]

LET:J % Path2 Setup -0,525 FftEngineffftInstfarnd1transformLaop[0]. ctfMmult_n0027fP[28] FitEngine FftInst/arndl jtransformLoop[0].ct/Madd_xReg[15]_uReg[15]_add_4_oUT1fal10]

Ed ‘& Path3 Setup -0,525 fFtEngineffftInstfarnd1/transformLoop[0]. cefMmult_no027fP[22] FitEngine fftinst/arndl jtransformLoop[0].ct/Madd_xRea[15]_uReg[15]_add_4_ouUT1/al11]

_?J (% Path4 Sebup -0.525 FFtEngine/FFtInstfarnd1 ftransFormLoop[0]. ckMmult_n0027/P[30] FFtEngine FFtInstfarnd] feransformloop[0].ctiMadd_xReqg[15]_uReg[15]_add_4_OUT1fA[1Z]

& F Paths Setup -0,525 FFtEngineffftInstfarnd1transformLaop[0]. ctfMmulk_n0027fP[31] FFtEngine FftInst/arndl jtransformLoop[0].ct/Madd_xReg[15]_uReg[15]_add_4_<UT1/A[13] »
< b=
& Report Timing - results_1{30 paths) x 4 p @

& DRC Results . (3 Timing Results

Figure 21: Analyzing Timing Analysis Results
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5-2-6.
5-2-7.

5-2-8.

5-2-9.

The list of paths display in the report in the Timing Results view. The report shows Path Type,
Slack, Source, Destination, Total Delay, Logic Delay, Net Delay Percentage, Stages of logic, start
clock, and destination clock. Failing paths appear in red.

Maximize the Timing Results view.
Scroll down the list of paths.
Note: The From and To values are in one of the fftEngine modules.

Click the To column header twice to sort the list by Source.The report is now reverse sorted by
To column values.

Note: You can sort all of the table style views in the PlanAhead software in the same way.
To perform a reverse sort, click the column header again.
To perform a secondary sort, press the Ctrl key and select another column header.

Restore the Timing Results view.

5-2-10. Close the Timing Results view.
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Step 6:Modifying or Creating Timing Constraints Step 6

PlanAhead enables constraint creation and modification in several ways. To edit the UCF file
directly in the text editor, double-clicking on the file in the Sources view. Alternately the GUI
provides a specialized UCF interface, described in this step.

6-1. Modify the Timing Constraints to reduce delay on fftEngine.
6-1-1. Select the Timing Constraints view tab grouped near the Netlist view.
6-1-2. Expand the CIk period >Timespec period folders.

6-1-3. Select the TIMESPEC_TS_fftClk (Figure 22).

0,
X

Tirnirg Conskrainks — O
A = =%
=-Clk period (PERIOD) (6 A
'J;_--Basic period (0}
=-Timespec period (&)
>,@, TIMESPEC TS_cpuClk = PERICOD "cpuClk” 13 ns;
{4, TIMESPEC TS _wbClk = PERIOD "wh(Clk" 9 ns;
-, TIMESPEC TS _usbClk = PERIOD "ushClk" 5.25 ns;
>,@, TIMESPEC TS_phy_clk_pad_0_i = PERIOD "phy_clk_pad_0_i" 11 ns;
>,@, TIMESPEC TS_phy_clk_pad_1_i = PERIOD "phy_clk_pad_1_i" 11 ns;
W T1MESPEC T5_FrtClk = PERIOD "FRECIK" 7 nis;
+-Derived period (0}
+-Pad-clk offset (OFFSET) (00
F-Path delay (FROM-TiON (2)
+-Time groups (5]
}-False path (TIS) (00
- C3FF chin delay (1) i
& Sources | 57 Metlisk Physical Constraints~ 52, Timing Constraints

JF-F 5

I oy

il

Figure 22: Selecting Timing Constraints to review Values

6-1-4. In the Timing Constarint Properties view, change the Period field value from 7 to 8. (Figure 23)
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Conskraint Properties - O o
*oBE R
£ TS FRECIk

ICF: TIMESPEC T5_ffRClk = PERIOD "FFECIK" 7 ns;

Source:  Ciiline_installiplandheaditestcases\Planahead _TutorialProjectsiproject_cpu_ne

Timespec name: | T5_fftclk | —
Period Specification 3
Period: E lns = |

[ Duty Cycle: | | [~ =

[ [ mpply ][ [ Cancel ]

Figure 23: Modifying a Period timing constraint

6-1-5. Click Apply to accept the changes.

6-1-6. In the Timing Constraints view, turn off the Group by type button % to view all the design timing
constraints in a list instead of by category (Figure 24).

oy
#

Timing Constraints - [
Q== "G

£ TIMESPEC T5_cpuClk = PERIOD “cpuclk™ 13 ns;

£ TIMESPEC T5_wbClk = PERIOD “whClk™ 9 ns;

£ TIMESPEC T5_usbClk = PERIOD "usbClk™ 5.25 ns;

8 TIMESPEC T5_phy_dk_pad_0_j = PERIOD "phy_dk_pad_0_i" 11 ns;

8 TIMESPEC T5_phy_dk_pad_1_i = PERIOD "phy_dk_pad_1_i" 11 ns;

#, TIMESPEC TS_fftClk = PERIOD "fRtClk” 8 ns;

£ NET "cpucCl™ THM_NET = "cpuclk™;

£ NET "whClk™ TMM_NET = "whlk™

£ NET "usbClk™ THM_NET = "usbClk™;

£ NET "phy_clk_pad_0_i" TNM_MNET = "phy_dk_pad_0_i";

5 MET "phy_clk_pad_1_i" TNM_NET = "phy_dk_pad_1_i%

£ NET "FRCIK™ TNM_MET = "FReClk™;

£ NET "cpuEnginefor 1200_cpu/for 1200_alu/= TPTHRU = "GRP_ALL_DATACUTS

£, MET "cpuEnginefor 1200 _cpu/for 1200_lsu/*" TFTHRL = "GRP_LSU";

£, TIMESPEC TS_ALU_MCP = FROM "cpuClk”™ THRU "GRP_ALU_DATAOUT" TO "cpuClk™ T5_cputlk * 2;
&, TIMESPEC TS_LSU_MCP = FROM “"cpuClk”™ THRU "GRP_LSU™ TO “puClk™ T5_cpuClk * 2;

& Sources l_ 31 Metlist l_ Physical Constrainth_ 2, Timing Constraints
Figure 24: Viewing a List of all Timing Constraints Defined
Note: If needed, it is possible to remove timing constraints. To remove timing constraints from the

design, select the constraint, right-click and select the Delete popup command. Deleting
constraints is outside the scope of this tutorial.
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6-2. Create a new Timing Constraint.

It is possible to define new timing constraints for clocks, false paths, and others from inside the tool. This
step will show how but the constraint will not be saved.

6-2-1. Click the New Timing Constraint button o to open the New Timing Constraint dialog box (Figure
25).

@8 New Timing Constraint

Conskraint Types Basic period

G Timespec period Clock net: ||:|:|uCIk - |

& Derived period Period Specification

& Input pad ko clk offset

& Clk ko oukput pad offsek Period: |III | |ns - |
£ Path delay (FROM-TO)

£ Basic group (THM) [ Duty Cycle: | |

£ Mulki group (TIMEGRF)

{5 Object False path [ ] Input jitter: | | | |
& Group False path

& Feedback.

ok [ Cancel

Figure 25: New Timing Constraint Dialog Box

6-2-2. Explore some of the Constraint Types.

6-2-3. Click Cancel to close the New Timing Constraint dialog box.
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6-3. Rerun Timing Analysis to see what changes with the new PERIOD on
6-3-1. In the Flow Navigator, select Report Timing again to rerun timing analysis with the new PERIOD
value.
6-3-2. Click OK to launch the run.
6-3-3. When the Timing Results view appears, select Path 1 in the list.
6-3-4. Maximize the Path Proprties view (Figure 26) using the Maximize button i
Path Properties O X
PR RIS
& Path 1
= Summary ~
|_Name # Path 1
Slack. -0.496
Source <« usbEngine0jush_dma_wb_infbuffer_Ffifo/Mram_fifo_ramiDOBDO[14]
Destination [ usbEnginedfu4/funct_adr_0fCE
Requirement 5.215
Delay 5,710
Saurce Clack T5_ushClk { rising at 0.000ns)
Destination Clack.  TS_ushClk { rising at 5.250ns)
= Source Clock Path
|_ Delay Type Delay Cumulative Location Logical Resource
0,000 0.000 5] AH11 [Cr usblk
niet {Fo=0} 0,000 0.000 8 ushClk_BUFGERT
[ AH11 [ usbClk_BUFGR{IELFGT
IBUFG 0,794 0.794 [5] AH11 1 usblk_BUFGRJIELIFGO
net (fo=1) 1,609 2403 s usbiclk,_BUFGRJIBURG_2_BUFG
[ usbClk_BUFGR/EUFG)T
BUFG 0,092 2,495 < usbClk_BUFGEPIBUFGIC
net (Fo=1570) 1.609 4,104 it usbEnginen/ush_dma_wb_in/buffer_Fifojdk_i
[ usbEnginenfusb_dma_wb_in/buffer_fif ofMram_Fif
Tatal 4,104 4.104
= Data Path
|_ Delay Type Delay Cumulative Location Logical Resource
RAMBEIGE] 2073 2073 < usbEnginedfush_dma_wb_in/buffer_fifoffram_Fif
net (Fo=40} 1.609 3682 & usbEnginen/uS/wh_addr_i[14]
[ usbEnginenfus/state_rf_we_d1/I1
LT 0,068 3,750 < usbEnginedfus/state_rf_we_d1fo
net (fo=17) 0.801 4,551 it usbEnginen/ud/we
[ usbEngine0usfadi{a]_we_AND_2411 o11[I0
LUTS 0.063 4.619 < usbEnginenfudfadr[6]_we_AND_2411_011/0
net (fo=4} 0.371 4,990 i usbEnginenu4/M11
[ usbEnginedfudfadi{é]_we_AND_2414 o113
LUT# 0,065 5.058 < usbEnginedfud/adr[6]_we_AND_F414_olfO
net {fo=7} 0,375 5433 it usbEnginen/ud/adr{8]_we_AND_2414 o
@ usbEnginen/u4,/funct_adr_0J/CE
FDRE 0,277 5,710 |.ill usbEnginen us/funck_adr_0
Tatal 5.710 5.710
Logic: 2.554
Met: 3.156
- Destination Clock Path
|_ Delay Type Delay Cumulative Location Logical Resource
0,000 0.000 [E] AH11 [Cr usblk
niet {Fo=0} 0,000 0,000 % ushClk_BLUFGER]T
[E] AH1L [ usbClk,_BUFGP/IBUFG)T w
i PR P T e o .
General | Report | Instances | Options
Figure 26: Viewing the Path Properties
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6-3-5.

Note: The paths have changed to reflect the new timing constraint for fftClk even though no
command was issued to save the new constraints to disk. Timing is run against the constraints in
memory. The tool shows the path for the Source Clock, the Destination Clock, as well as the
critical logic. All of the logic objects in the path and their associated delays are shown the Path
Properties report.

In the Path Properties view, select the Restore button &' to return the view to the original
location.
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Step 7:Exploring Logic in the Schematic

Step 7

To explore logic in the Schematic view, you can experiment with the schematic commands for
traversing and expanding logic. For example, you can selectively remove logic from the
schematic and traverse the logic modules.

7-1. View timing paths in the schematic.
7-1-1. Select Path 1 in the Timing Results view.
7-1-2. Right-click and select Schematic.
7-1-3. Click Unselect All ™ or press F12.
Notice that the path logic is shown in the Schematic view (Figure 27).
\"_7 -~
usbEngingd
usb ama wt In
Euder Ais
I'.::‘: Wram Ao ram
T =l ooR L FOEOOR 12
OO RACDF 15
LT M
:CI.K.B“FEI.K
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-npm;n':q e preres I:.sw = [ aalS]_wa A Dbid o1 Aunct aar ¢
:qum zg::::- - b i g —:1 . . aunq_m..wn 2411_o11 :.I.: . - L
—ErE PN CAPAORS 0 f —Hz - —-= - ar 3
—MECTORIrTERR  DOFROOR S = —a —e =] —+
ot rnal = -
—FECCER IR LuTS
T RARAFTE MR uskd_pt
i i
ﬂ,:ll} :F!STFI.GB
¥ Luczaciea
RAWHISE]
- P L L I 1 L L)
AfcBuffer usb ama wh In

4

usbEnginsdfusty rop

111

@ Device = | &, Project Summary % | #2] Schematic =

Figure 27: Viewing Timing Path Logic in the Schematic

Notice that the levels of hierarchy are drawn with concentric rectangles. It is very easy to identify

the logic modules associated with critical path logic.

7-1-4. Close the Schematic view by clicking the X button in the Schematic tab.

7-1-5. Use the mouse and the Shift key to select all of the paths in the Timing Results view that have a
From value beginning with usbEngine0/...

7-1-6. Right-click and select Schematic.
All of the logic associated with each selected path displays and is selected in the Schematic view
(Figure 28).
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Figure 28: Viewing Multiple Timing Paths in the Schematic

7-1-7. In the Netlist view, click the Collapse All toolbar button = .

7-1-8. With the group of paths still selected and the cursor in the Schematic view, right-click and select
Select Primitive Parents.

The three modules with the path logic are highlighted in the Netlist view.
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7-2.
7-2-1.
7-2-2.

7-2-3.
7-2-4.

7-2-5.

7-2-6.

Inspect where the critical hierarchy is in the design hierarchy.
Select the Show Hierarchy popup menu command or press F6 .
Use Zoom Area on the left side around usbEngine0 to see the critical hierarchies.

Hint: To activate the Zoom Area mouse stroke, move the cursor to be just outside the top left
corner of the driver. Hold down the left mouse button and drag the mouse to the bottom right
corner of the driver. Release the mouse. Repeat as needed to see the three modules with the

Rk X o
|

path logic highlighted in the Hierarchy view (Figure 29).
|

<l i |

I
> @

@ Device x| K Project Summary < | %2 Schematic % | i Hierarchy < 4
Figure 29: Viewing Selected Logic in the Hierarchy View

In the Hierarchy view tab, click X to close the view.

[

Use the Zoom Area mouse stroke to zoom in on the single instance inside the highlighted module

on the left in the Schematic view
Select the RAMB36E1.

Click the Collapse Outside button ah (Figure 30).
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Figure 30: Critical Path Source

7-2-7. Double-click the ADDRARDADDR[15:0] pin (in the top left of the Block Ram) and notice that the
logic connected to it is expanded (Figure 31).
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Figure 31: Interactively Expanding Logic in the Schematic View

7-2-8. Double-click newly expanded top instance wr_addr_0. This adds the logic to which it connects
to the schematic.

7-2-9. In the Schematic view, select the Previous schematic button ""'.
You can use the Previous schematic and Next schematic toolbar buttons to browse the various
views displayed in the Schematic view. This enables you to toggle the various levels of schematic
expansion.
Note: The Edit > Undo command is not applicable to the schematic view.

7-2-10. Select the smaller buffer_fifo module hierarchical rectangle containing the RAMB36E1
instance.

i

7-2-11. In the Schematic view, click the Expand Inside button #%].

7-2-12. Zoom Fit in the schematic (Figure 32).
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Figure 32: Expanding Logic Inside of Schematic Modules.

7-2-13. Click the Select Area toolbar button R and draw a rectangle around some of the logic in the
Schematic view.

7-2-14. Click the Remove selected elements from schematic toolbar button X . Notice that some logic is
no longer displayed.

Note: This tutorial covers only a subset of the Schematic view commands and options for
traversing the logic.

7-2-15. Use the on the right side of the Netlist Design bar to close down the Netlist Design
7-2-16. If prompted click OK to close the Netlist Design.
7-2-17. When to tool prompts you to Save Netlist Design, click No.

In the next steps Place and Route will run with the original 7ns constraint on fftClk.
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Step 8:Implementing the Design Step 8

8-1. Review the Implementation tools actions on the design.

8-1-1. If the Sources view is hidden from view, select Window > Sources to display it.

8-1-2. In the Sources view, click Expand All = to see all source files (Figure 33).

Project Manager

SoUrces — O o #
™ o i
A= =t
(=i Design Sources (4
E}I—' EDIF (4
----- i@ usbEngine1#usbf_top.edf
“f @ usbEngined#usbf_top.edf
----- e top.edf (top)
“fif o fiEngine #fftTop. edf
=+ Constraints (2)

E}m" constrs_2

----- Y @ top_fpn.ucf (target)

Figure 33: Expanded Sources View

When running the implementation tools, PlanAhead uses the active constraint file by default.
Make sure that consts_1 using top_full.ucf is active. If Netlist Design or Implemented
Design are open with changes, those changes will be used instead of the UCF on disk.

8-1-3. Doubile click on top_full.ucf to view the text.
8-1-4. Ensure TS_fftClk looks as follows
TIMESPEC TS_fftClk = PERIOD "fftCIk" 7 ns;

8-1-5. Use _* to close the UCF. Save changes if needed.
8-1-6. In the Flow Navigator, click the Implement button to start implementation (Figure 34).

>

Implement

Figure 34: Start Implementation.

This launches the ISE Place and Route tools; specifically NGDBuild, Map, PAR, Trace, and XDL.
The process will take about 60 minutes on a fast machine.
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Leave the tool alone while implementation runs. The status bar in the upper right reflects the
progress (Figure 35).

Implementing (MAP) 20%: [ ] [ Cancel ] ‘

Figure 35: Implementation Bar

When implementation finishes, the tool will show an Implementation Completed dialog box
(Figure 36).

o "

Implementation Completed @

I:o:l Implementation successfully completed.

Mext

@ Dpen Implemented Desigri

1 Generate Bitstream

1 View Reports

[] Don't show this dialog again

QK ] I Cancel

Figure 36: Implementation Completed

8-1-7. Click the Open Implemented Design radio button.
8-1-8. Click OK.

The tool reads the place and route files to show where each instance was placed and what trce
is reporting for timing (Figure 37). To re-open the implemented design later, click the

Implemented Design | +
Implemented Design button in the Flow Navigator
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Figure 37: The Implemented Design

8-1-9. Click the Compilation Messages tab to display the Compilation Messages view.

8-1-10. If needed, click the expand widget by Place and Route to see the messages generated at this
step (Figure 38).

Compilation Messages — 0O a x
C'\ PhysDesignRules: 367 - The signal «GTPRESET_IN_IBUF > is incomplete. The signal does not drive any load pins in the design. -
) i Place & Route (par) (4 s, 1info message)
'f Timing: 3386 - Intersecting Constraints found and resolved. For more information, see the TSI report. Please consult the Xilinx Command Line Tools User Guide for information on generat
= Par: 288 - The signal GTPRESET_IN_IBUF has no load. PAR wil not attempt to route this signal. I
® Par: 468 - Your design did not meet timing. The following are some suggestions to assist you to meet timing in your design.Review the timing report using Timing Analyzer (In [SE select P
& ParHelpers: 361 - There are 1 loadless signals in this design. This design will cause Bitgen to issue DRC warnings.

Zar: 283 - There are 1 loadless design i i i -
o < | m = b
2 Td Console | E5] Compilation Log | Compilation Messages | |2 Reports | (% Design Runs

Figure 38: Compilation Messages

Note: The Compilation Messages view collects all information, warning, and error messages
generated by the implementation tools. Click the blue exclamation circle button in the local toolbar
to hide Information messages. Click the yellow exclamation circle button to hide Warnings.

8-1-11. Click the Reports tab to display the Reports view (Figure 39).
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Reports
MName Maodified Size
E-Translate (ngdbuild)
‘-3 NGDBuild Report 8/22/10 8:45 AM 4KB
=-Map (map)
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-3 MAP Report 8/22/10 9:07 AM 439 KB
- 2 Physical Synthesis Report
[=I-Place & Route (par)
- 2 Pad Repart &/22/10 9:13 AM 157 KB
[ PAR Report 8/22/10 9:13 AM 596 KB
=B mrmatee Danort SN G173 AR NER

= Td Console | E5] Compilation Log | & Compilation Messages | 2| Reports

Figure 39: Viewing ISE Report files

8-1-12. Double-click on any one of the reports to view the report.
8-1-13. Close the report file.
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Step 9:Analyzing the Timing Results Step 9

You can analyze timing results from the implementation to drive the floorplanning effort. You
can also use the path sorting and selection techniques available in the Timing Results view with
the imported TRACE report data.

9-1.

9-1-1.

9-1-2.
9-1-3.

Explore the Implementation timing results.

Double-click in the empty space on the top title bar labeled Implemented Design — impl_1 to
maximize the work area.

In the Timing Results view, select Path 1 (Figure ).

Right-click and select the Mark popup command.
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Figure 40: Selecting the Most Critical Timing Path

The imported timing paths are shown on a constraint-by-constraint basis. When you select paths
in the Timing Results view, the Path properties view shows the details of the timing path.

Because the placement was imported, the path is highlighted in the Device view. If needed bring
the device view forward. The visualization makes it easy to understand how to take appropriate
floorplanning steps to improve the timing.

After running the Mark command, the red and green diamonds show the timing path start and
end points (Figure ).
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Figure 41: Placement of the Timing Path

9-1-4. Select Select > Unmark All to clear the marks.

Timing paths are grouped by constraints. The worst failing paths are in TS_fftCIk. It is useful to
look at the paths in other clock domains as well. Select and explore some of the passing paths in
TS_usbClk.

9-1-5. Press Shift and select all of the paths in TS_usbC1k. Do not grab paths from other timing
constraints.

9-1-6. Right-click and select the Schematic popup menu command.

The Schematic view shows all of the instances on the selected paths (Figure ).
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Figure 42: Examining Failing Timing Paths in the Schematic

9-1-7. In the Netlist view, click the Collapse All button.

9-1-8. In the Schematic view, right-click and select the Select Primitive Parents popup menu command
to select the smallest parent modules that contain all of the instances in the selected paths
(Figure ).
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Figure 43: Selecting Path Object Parent Modules for Floorplanning

Notice that the corresponding logic modules are selected in the Netlist view.

Switch to the Device View.

Click the X button = Schematic 3 4 q|nqe the open Schematic views.

From the Device view toolbar, click Hide All Timing Paths button R
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Step 10: Highlighting Module Level Placement Step 10

You can determine a floorplanning strategy by examining previous implementation results. You
can analyze module placement and guide Pblock locations by understanding how the logic was
implemented without floorplanning.

10-1. Highlight modules with cycling colors to easily view placement.
10-1-1. In the Netlist view, right-click and select Highlight Primitives > Cycle colors command.
10-1-2. Click the Device tab to view the highlighting.

The primitives in each module are highlighted in a different color (Figure ).
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Figure 44: Highlighting Module Placement.

Notice the wide dispersal of the primitives. Scroll around and change the Zoom level. Notice that
many of the instances are block RAMs. These might benefit from Floorplanning to improve timing.

Hiding the other placement constraints using the Show/Hide Placement Constraints 4 tool
bar button may make the highlighting more visible.

10-1-3. In the main Toolbar, select the Unhighlight All button. ol

10-1-4. In the Netlist view, click the Collapse All button. &
10-1-5. In the Netlist view, select the usbEngine0 and usbEnginel modules.

10-1-6. Right-click and select the Highlight Primitives > Color 1. Alternately, use any color that stands
out (Figure 45).
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Figure 45: Highlighting USB Netlist Module.

Notice the wide dispersal of the module’s placement (Figure 45). usbEnginel and usbEngine0
may be good candidates for floorplanning. Floorplanning will be covered in the next steps.

10-1-7. From the main toolbar, click the Unhighlight All button o .
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Step 11: Exploring Connectivity Step 11

The PlanAhead software has extensive logic expansion, selection and highlighting capabilities. These
capabilities can be used to validate that modules are suitable to floorplan. For example, logic modules
that connect to logic throughout the device may not be suitable for floorplanning, while tightly grouped
and self-contained modules are suitable.

Routing congestion and timing inconsistency can be alleviated by floorplanning logic outside of the critical
logic areas, preventing logic from migrating into the critical areas.

11-1. Visualize the I/O Connectivity.

11-1-1. In the Device view, turn on the Show/Hide I/O Nets button 2%
Green lines show the connectivity from the placed logic to the 1/0 pins (Figure ). If no green lines

appear, click the Show LOC constraints button = .
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Figure 46: Device View with I/O Connectivity.
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11-1-2.

11-1-3.

11-1-4.

11-1-5.
11-1-6.

11-1-7.

11-1-8.

Notice the I/O lines on the left side of the chip cross a long distance.

Click one of the I/0O Nets that connect to the top part of Bank 14 - the I/O Bank in the bottom left
of the chip.

Inspect the Netlist view.

The net is a bit of the bus usbEngine0/dma_out/buffer_ fifo/DataOut_pad_o.

In the Netlist view, click the Collapse All button. &
In the Netlist view, select usbEngine0 and usbEnginel.
Right-click and select the Show Connectivity popup menu command.

Notice that the interface nets that connect usbEngine0 and usbEnginel to the rest of the
design are shown in yellow (Figure).

Right-click and select the Show Connectivity popup menu command again to select all of the
logic objects that the interface nets connect to.

Right-click and select the Show Connectivity popup menu command once again to highlight all
of the nets that fanout from those selected logic objects.

You can use the Show Connectivity command to highlight or select a cone of logic from any
source net or logic object.
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Figure 47: Using the Show Connectivity Command

11-1-9. Click Unselect All \B’;\ or press F12.
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Step 12:Using Placement Constraints Step 12

This step will show how to look for placement based on primitive type and clear all the
placement created by place and route during implementation.

12-1. Viewing Placed Instances.
12-1-1. Select Edit > Find.
12-1-2. Change the Primitive field to Block RAM (Figure ).

@8 Find r5__<|
Criteria
Type | i ~ | [FEEET

[]Match Case

o] 4 H Cancel ]

Figure 48: Find Dialog Box

12-1-3. Select OK.
12-1-4. Select a Block RAM in the Find Results view.

12-1-5. Use the Shift key and select the first and last Block RAM, or press Ctrl+A to select all Block
RAMs.

The Device view will have all the Block RAMs selected (Figure ).
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Figure 49: Device View with Block RAMs
If there are a lot of extra nets selected, toggle the Show connections for selected instances button
ﬂ%. It can be useful to select primitive types based on the hierarchy only. Try selecting only the
Block RAMs in usbEngine1. Since the Block RAMs are spread out over the device, there is no
reason to keep the placement.
12-2. Clear all placement constraints using the Clear Placement Constraints
command.
This step will show how to clear out placement to make it easier to understand data flow in a later
step. The Clear Placement Constraints dialog box can selectively remove the placement
constraints. The 1/0 and clock related resources are separated from the fabric logic because they
usually do not change. This enables you to quickly remove the placement constraints imported
from the ISE software runs. Logic type filters are provided to selectively remove placement
constraints by type also.
12-2-1. Select Tools > Clear Placement.
12-2-2. In the Clear Placement Constraints dialog box, select the Instance placement radio button

(Figure ).
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Clear Placement Constraints
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Figure 50: Clearing Placement Constraints

12-2-3. Click Next to display the Unplace Instances page.

12-2-4. Select Unplace All instances.

12-2-5. Click Next to display the Instance Types to Unplace page.
12-2-6. Click Default to use the Default selection.

Notice the configurable filters is available to selectively clear or keep logic LOC constraints by
type.

12-3. Click Next to display the Fixed Placement page.
12-3-1. Select Keep 17 Fixed Instances.

12-3-2. Click Next to display the Clear Placement Summary page.
12-3-3. Click Finish after reviewing the Summary page.

12-3-4. In the Netlist view, click the Collapse All button &
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Step 13: Viewing Hierarchical Connectivity Step 13

It can be useful to look at the connectivity between the modules of the netlist. In this section,
you will use various tools to show the design connectivity. The netlist hierarchy will be broken
apart into a physical hierarchy — called a Pblock. The Pblock will be placed to analyze design
data flow. The Pblock is saved into the constraints file as an AREA_GROUP constraint.

13-1. Use the Auto-create Pblocks command to split up the top level of the
Design

13-1-1. Select Tools > Auto-create Pblocks.

In the dialog box, review the options with which you can define the maximum number of Pblocks

to create and specify the minimum Pblock size.

If more modules exist than the total number of Pblocks specified for creation, the PlanAhead
software creates Pblocks with the largest modules.

13-1-2. Click OK to accept the six selected modules.

Notice the top-level Pblocks in the Physical Constraints view (Figure ). In the Netlist view the icon
next to the 6 modules changed from L2l to [#l to show the instance had been placed in a Pblock.
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Figure 51: Partitioning the Top-level Design

13-2. Use the Place Pblocks command to place the newly created Pblocks.
13-2-1. Select Tools > Place Pblocks.

Notice that the Place Pblocks dialog box contains options with which you can select Pblocks to
place and to adjust the target SLICE utilization sizes on Pblocks.

Note: The Place Pblocks command is intended to quickly create selected Pblocks.

Pblocks are sized based on SLICE logic only. Other non-SLICE ranges are not considered.
Therefore, the Pblocks created using the Place Pblocks command might need modification to
pass though the implementation tools successfully.

13-2-2. Click OK to place the Pblocks (Figure ).
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Figure 52: Place Top-Level Pblocks

The Place Pblocks command may place the Pblocks differently from one run to the next. The
placement might not be identical to the placement shown.
LT

If connectivity is not displayed, make sure that the Show/Hide I/O Nets toolbar button “ and
Show/Hide Bundle Nets toolbar button 4% in the Device view are toggled on.

Hint: You can use these buttons throughout this tutorial to turn connectivity display on and off.

The bundle nets and I/O flight lines help to visualize the connectivity in the design. Pblocks can
quickly be arranged to untangle the connectivity. This provides early indications of data flow
through the design and highlights where potential routing congestion could occur. Bundles show
the number of nets shared between two Pblocks. To see the definitions go to Tools > Options >
Themes > Bundle Nets.
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13-3. Adjust the placement and size the Pblocks based on connectivity and
resources.

13-3-1. If needed, adjust the placement of the Pblocks to untangle the connectivity (Figure ).

manufemennen nnlnnl‘}%

Figure 53: Reshaping Pblocks to Display Hierarchical Connectivity

Al
Hint: In the Device view, use the Set Pblock Size toolbar button (el to redraw rectangles
anywhere in the device. Move or redraw the rectangles to show a clear diagram of the logic
connectivity. At this point, you do not need to size the Pblock to satisfy the resource requirements.

13-3-2. Click OK in the Set Pblock dialog box to accept all Grid Types within the Pblock rectangle.

Note the connectivity to usbEnginel and usbEngine0. These two blocks have timing issues.
Look at the 1/0 connectivity to see where the two blocks might be placed.

13-3-3. Select a Pblock, and click the Statistics tab in the Pblock Properties view (Figure ).
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Figure 54: Sizing Pblocks Based on Resource Estimation

Notice the Physical Resource Estimates for the Pblock. You can use these resources when sizing
Pblocks to ensure adequate resources exist within the Pblock rectangle in order to accommodate
the logic to which it is assigned.

Scroll down the list of Pblock Property Statistics.

It is often easier to create floorplans and manipulate Pblocks when certain objects are made non-
selectable, such as 10 nets, bundle nets and instances.

13-4. Set the View Options to make some objects not selectable.

13-4-1. Select Tools > Options.

13-4-2. In the PlanAhead Options dialog box, click the Themes category on the left to show the color
Themes options.

13-4-3. At the bottom of the dialog box, click the Device tab.

13-4-4. In the Select column, deselect the Assigned Instance and IO Net object types
(Figure ).
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Figure 55: Setting View Options

13-4-5. Click the Save As button, enter a name of your choice, and click OK.

Notice that you can save your own custom view option configurations for use later.
13-4-6. Change back to the PlanAhead Dark Theme or PlanAhead Light Theme.

13-4-7. Click OK.

The PlanAhead software displays the connections between the Pblocks with bundle nets. The
color and line width of a bundle net indicate the number of signals within the bundle. The settings
for color, net count, and line width are configurable in the Bundle Nets tab of the PlanAhead
Options dialog box.

13-5.

13-5-1.
13-5-2.
13-5-3.

Examine the Bundle Net Properties.

Examine the Bundle Nets Properties view.

In the Device view, select one of the colored bundle nets.

within the bundle between the two modules (Figure ).

In the Bundle Net Properties view, click the Properties tab to see a list of all the nets contained
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Figure 56: Displaying Bundle Net Properties
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Step 14: Using the Search Capability to View Clock Domains Step 14

Effective floorplanning is often dependent on proper placement of the synchronous elements in
different clock domains. You can highlight clock domains to visualize connectivity, enabling
proper Pblock placement relative to clock regions. This step will floorplan the design to
understand data flow and design connectivity. Pblocks will be created for every level of design
hierarchy. Running the design through Implementation with all these pblocks would hurt
timing.At the end of the step, the pblocks will be erased. The next step will floorplan a little

differently to improve performance.
14-1.

Select and mark the global clock nets.

14-1-1. Select Edit > Find.
14-1-2. In the Find dialog box, set the following options:
¢ Find: Nets
o First field: Type
e Second field: is
e Third field: Global Clock
14-1-3. Ensure the Unique Nets Only button is enabled, and click OK.
14-1-4. Select the Pins column header twice to sort the Find Results view.
14-1-5. In the Find Results view list, select usbClk_BUFGP .
Notice the highlighted net leading to I/Os in the two usbEngine Pblocks (Figure ).
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Figure 57: Viewing Clock Net Destinations
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14-2. Use the Schematic View to see how the global clock net fans out to the
primitives in the design.

14-2-1. With the global clock net still selected in the Find Results view, right-click and select the
Schematic popup menu command.

The Schematic view shows the usbC1k_BUFGP net connected to a group of registers.

14-2-2. At the top of the schematic, Zoom in on the usbC1k_BUFGP BUFGP (Figure).
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Figure 58: Viewing the Clock Signal in the Schematic

14-2-3. Close the Schematic view.

14-2-4. In the Physical Constraints view, press the Shift key, and select all six Pblocks.

14-2-5. Select the Delete toolbar button. X
14-2-6. If prompted, select OK to confirm the deletion.
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Step 15: Floorplanning Timing-Critical Hierarchy Step 15

Floorplanning timing critical hierarchy or hierarchy that talks to 10s with limitied internal
connectivity can improve timing performance. The previous steps show that usbEnginel and
usbEngine0 talk to 10s on the left side of the chip. The usbEnginel and usbEngine0 can go
in the corners on the left-hand side. Unlike the previous step, this step will floorplan just a
couple hierarchies.

15-1. Place Pblocks for timing critical hierarchy.
15-1-1. Click the Device tab.

a30
e

15-1-2. In the Device view, ensure that I/O Nets are being displayed

(=]
15-1-3. In the Netlist view, select the Collapse All button ey

15-1-4. In the Netlist view, select usbEngine0.

15-1-5. From the Device view toolbar, select Draw Pblock 'ﬁ.
The cursor turns to a cross.
15-1-6. Draw a rectangle in the bottom left-corner of the device view.
15-1-7. Click OK to dismiss the New Pblock dialog box.
15-1-8. Look at the Pblock Properties.
15-1-9. Click on the Statistics tab.
This Pblock is being sized to go through implementation.

15-1-10. Size the Pblock to have100% block RAM Utilization and approximately 60% Slices
utilization. Do not span the center column gap. See Figure for the Pblock placement.
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15-1-11.
15-1-12.
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Figure 59: usbEngine0 Placed

Select usbEnginel from the netlist view and create a similar Pblock in the top left.

Do not overlap the Pblocks. The end result will look like Figure 60.
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Figure 60: Floorplan both USB Timing Critical Blocks
15-1-13. In the top right of the Implemented Design, click X.
15-1-14. Click OK and Yes to save.
The tool returns to the Project Manager.
15-1-15. In the Sources view, open top_full.ucf. Scroll to the bottom of the UCF and notice

the new AREA_GROUP lines. The design could be run through implementation.

15-2. Optional step - run the floorplan through P+R to see how timing changes.
15-2-1. Click the green Implement button again.

15-2-2. Click OK when the tool asks if it should re-run implementation.

15-2-3. When implementation finishes re-load and inspect the timing.

Note: This floorplan improves timing but does not close timing. If you are not seeing timing
improvement you can use a floorplan that ships with the tool by doing the following:

1) Select constrs_2 in the Sources window.
2) Choose Make Active from the popup window.

3) Click Implement.
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Conclusion

In this tutorial, you used the PlanAhead software to explore and analyze the synthesized design and
targeted device prior to running the implementation tools. This enabled you to find potential design issues
and errors early in the design cycle, rather than discovering issues during implementation. In addition,
you used the graphical presentation of design resource estimates, design rule violations, timing
estimation, constraints and connectivity to help you understand your design and any potential problem
areas.

After running the design through the implementation tools, you viewed implementation results and
examined timing results. You then analyzed critical path objects in the schematic, and selected the parent
modules of those path objects. You highlighted module placement and displayed the connectivity of the
modules using the Show Connectivity command. You cleared the ISE software-assigned placement.
After analyzing the design, you created a floorplan to improve timing.
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