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Chapter 1

Schematic Viewer: Brief Overview

Design Flow Benefits

The goal of this tutorial is to provide a quick introduction to the main capabilities of the
Schematic Viewer available from the ISE® Design Suite and how you can use these
capabilities for design analysis and debugging. With the rapid growth in the size and
complexity of FPGA designs, it is critical to have tools that ease the way you analyze and
debug your designs.

Some common questions can be answered by using the Schematic Viewer:
¢ How is my HDL code interpreted by the synthesis tool?

e How is my HDL code mapped to the target technology?

¢ Where is my critical timing path situated?

In addition, today’s advanced designs are often completed by several designers located in
different parts of the world, where each designer is responsible for a part of the design.
This complicates design analysis even further, and good debugging tools become critical.

Graphical tools such as the Schematic Viewer, PlanAhead™ software, and FPGA Editor
significantly simplify design analysis.

In this tutorial, we introduce the latest version of the Schematic Viewer, a tool which
provides powerful ways to view and analyze your designs from different perspectives.

Key Features

The Schematic Viewer provides a flexible interface that allows you to focus on the part of
the design that interests you. This ability to incrementally expand or “localize” the view on
demand provides a significantly faster means to navigate through your design.

The Schematic Viewer provides you with powerful analysis features, such as:
* Drawing the schematic by selecting the only elements of interest

e Extracting Input/Output logic cones

e Removing objects that are not of interest

* Navigating “Forward/Back” history of previous analysis steps

e Working with multiple schematics of the same netlist

RTL and Technology Schematic Viewers Tutorial = www.xilinx.com 5
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Schematic Viewer

The Schematic Viewer as shown in Figure 1-1 has significantly improved performance,
which improves your ability to deal with higher complexity designs.

Ultimately, the Schematic Viewer provides you with the fundamental capabilities to

visualize:

¢ RTL views of the design

e Post-synthesis netlists

¢ (ritical timing path delays reported in the post-place and route timing report (from

Timing Analyzer)

RTL View

RTL View is a Register Transfer Level graphical representation of your design. This
representation (. ngr file produced by Xilinx Synthesis Technology (XST)) is generated by
the synthesis tool at earlier stages of a synthesis process when technology mapping is not
yet completed. The goal of this view is to be as close as possible to the original HDL code.
In the RTL view, the design is represented in terms of macro blocks, such as adders,
multipliers, and registers. Standard combinatorial logic is mapped onto logic gates, such as

AND, NAND, and OR.

Post-Synthesis Netlist

Graphical representation of the post-synthesis (“optimized and mapped”) netlist (. ngc
file produced by XST) contains Xilinx primitives as defined in the UNISIM library, such as
LUTs, DCM, I/O buffers, and flip-flops. The Schematic Viewer allows you to visualize the
primitive properties and the constraints attached to them.

Critical Path View

When used as a cross probe target from the Timing Analyzer report, the critical timing path
of your design is represented using the post-place and route netlist. This netlist is different
from the post-synthesis netlist and represents your design in terms of slices.

www.Xxilinx.com
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Flexibility for Both Project Navigator and Command Line Users

Your particular design methodology (command line vs. Project Navigator) determines
which set of features you can use in the Schematic Viewer. Use the following table to
familiarize yourself with the features available to you.

Case 1: ISE Project Navigator
Table 1-1: Design Features

Synthesis Tool RTL View Post-Syr.ltheS|s Critical Path Notes
Netlist
Use ISE environment to fully implement your
XST Yes Yes Yes design, and XST is your synthesis tool
. Use ISE environment to fully implement your
Third party ) ) Yes design, and use a third-party synthesis tool.

Case 2: Command Line

Although you cannot launch Schematic Viewer in a standalone mode, there is a
workaround to emulate this use model and enable you to use the Schematic Viewer to
explore the XST RTL View or XST post-synthesis netlists. Post-map and post-place and
route netlists are not handled in this mode.

Please refer to Chapter 10, Lab 7: Using the Schematic Viewer as a Standalone Tool for
more information.
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Chapter 2

Tutorial Description

Overview

Throughout this tutorial, we will use the small stopwatch design which is delivered with
the Xilinx® ISE® software installation as an example design. We intentionally selected a
small design to allow you to complete the labs as quickly as possible.

Less than one hour is required to complete the entire tutorial which covers all major

features.

We suggest:

¢ Running the labs in order. That said, the labs are independent and can be run in any
order if you want to immediately focus on one particular functional area.

e Creating a separate design directory for each lab and copying the original design files
to that directory. Please refer to Chapter 3, Lab Preparation: Getting Started, for more

information.

Because the majority of Schematic Viewer features can be accessed using either the RTL,
Post-Synthesis netlist, or Critical Path views, we will use the Post-Synthesis netlist view in
the majority of labs to demonstrate the main features.

The following table gives you a brief overview of all the labs.

Table 2-1: Lab Overview

Title

Duration

Covered Features

Chapter 4, Lab 1: Basic
Features

9 minutes

Selecting Schematic Viewer startup mode
Working with the Schematic Wizard
Understanding the Schematic Viewer interface
Zooming views

Expanding schematics

Removing elements from a schematic
Coloring new elements

Navigating history

Using Start/End signal markers

Chapter 5, Lab 2: Working 9 minutes

with Hierarchical Netlists

Selecting hierarchical blocks in the Schematic Wizard
Expanding hierarchical blocks
Starting schematic exploration with the top-level block

RTL and Technology Schematic Viewers Tutorial
UG685 (v13.1) March 1, 2011

www.Xxilinx.com



http://www.xilinx.com

Chapter 2: Tutorial Description

& XILINX.

Chapter 6, Lab 3: Using 6 minutes Visualizing critical paths in the Schematic Viewer
Schematic Viewer for Timing Annotating the critical path with path delays
Analysis
Chapter 7, Lab 4: Simplifying 7 minutes Using Start/End signal markers
Design Analysis Deleting schematic elements
Using multiple schematics of the same netlist
Starting a new schematic with selected elements
Using colors to mark various elements
Chapter 8, Lab 5: Comparing 5 minutes Loading and comparing two netlists of the same design
Two Design Implementations
Chapter 9, Lab 6: Dealing with 3 minutes Handling large designs
Large Designs
Chapter 10, Lab 7: Using the 3 minutes Learning how command line users can take advantage of the

Schematic Viewer as a
Standalone Tool

Schematic Viewer

Prerequisites
The labs you will run through require some basic knowledge about the ISE Project
Navigator environment. Before starting these labs, you should know:
* How to open and close an existing project
e How to add a new UCF (implementation constraint file) to the project and specify
basic timing constraints using Constraint Editor
* How to run the basic implementation flow
¢ How to launch and use Timing Analyzer
10 www.xilinx.com  RTL and Technology Schematic Viewers Tutorial
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Lab Preparation: Getting Started

Installing a Design

Throughout the labs, you will use the small stopwatch design and target a Spartan®-3E
xc3s100e-4-vq100 device. This design is delivered with the Xilinx® ISE® software
installation.

1. In Project Navigator, select File > Open Example.

2. In the Open Example dialog box, select the watchvhd design and specify
c:\viewer_labs\labsl as the Destination Directory.

The watchvhd project is unarchived in the specified destination directory and is
opened for use in Project Navigator.

Setting Up Project Navigator Preferences

To ensure that the lab graphics provided in this tutorial match the schematic you see on
your screen, you have to setup the Light Background Color Scheme for Schematic Viewer
before starting the lab.

1. To open the Preferences dialog box, select Edit > Preferences.

2. In the left pane, expand RTL/Technology Viewers and select the Color Scheme
sub-category.

RTL and Technology Schematic Viewers Tutorial = www.xilinx.com 11
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Figure 3-1:

Color Scheme Selection

3. Select Light Background Color Scheme in zone 1 (see Figure 3-1) of the dialog box,

click Apply, and click OK to finish.

Now you are ready to start the labs.
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Lab 1: Basic Features

Objectives

The goal of this lab is to familiarize you with the basic Schematic Viewer operations which
will be used extensively in later exercises. These include:

* Selecting Schematic Viewer startup mode

e  Working with the Schematic Wizard

* Understanding the Schematic Viewer interface
e Zooming views

¢ Expanding schematics

* Removing elements from a schematic

¢ Coloring new elements

e Navigating history

¢ Using Start/End signal markers

Note: For the sake of clarity and simplicity, all the above features will be demonstrated using a
flattened post-synthesis netlist. Hierarchical netlist navigation will be introduced in the next lab.

Lab

Step 1: Creating the Lab Project

Create and open the stopwatch project and set the Light Background Color Scheme for
Schematic Viewer, as described in the Chapter 3, Lab Preparation: Getting Started.

Step 2: Setting XST Options and Synthesizing the Design

1. In the Processes pane, right-click Synthesize - XST, and select Process Properties to
open the Synthesis Options dialog box.

RTL and Technology Schematic Viewers Tutorial = www.xilinx.com 13
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2.

Set the Keep Hierarchy option to No as shown in Figure 4-1.

(E‘?'te?'?rf" - Property Mame Yalue
SV”thBSi_S Options | | ibrary Search Order )
HOL Options | ; —
Wilir: Specific Options | | Keep Hisrarchy LI ]
| Metlist Hierarchy |as O&imized |
| Global Ootimization Goal AllCInrkNebs vl

Figure 4-1: Setting Keep Hierarchy Option

Synthesize the design by double-clicking the Synthesize - XST process in the
Processes pane.

Step 3: Launching the Schematic Wizard

Before you can view a schematic of your design, you need to select the elements you want
to use as a starting point for your design exploration.

You can start design exploration in the two different startup modes:

Start with the Explorer Wizard. In this mode, the Explorer Wizard is the initial screen,
which allows you to select the elements that you want to see on the initial schematic.
This mode will be used in the current lab.

Start with a schematic of the top-level block. In this mode, the Explorer Wizard is
bypassed and an initial schematic is created with only the top-level block displayed.
You can then use the logic expansion capabilities of the Schematic Viewer to start
expanding from the top-level block. You need to familiarize yourself with the basic
Schematic Viewer operations and learn how you can manipulate hierarchical blocks
before using this mode. Please refer to Chapter 5, Lab 2: Working with Hierarchical
Netlists for more information on this startup mode.

After synthesis is complete, start the Schematic Viewer by double-clicking the View
Technology Schematic process found in the Processes pane, or, alternatively, by
selecting Tools > Schematic Viewer > Technology View from the menu.

Select the Start with the Explorer Wizard startup mode as shown in Figure 4-2.

= Set RTL/Tech Viewer Startup Mode @

Select how the RTL/ Tech Viewer behaves when it is initially imeoked
Startup mode
(@ Start with the Explorer Wizard
In this mode, the Explorer Wizard is the initial screen, and allows

you o salect the elements that you want to see on the nitial
schematic

O Start with a schemaltic of the top-leval block

Ins this moda, the Explorer Wizard is bypassad and an initial scharmatic
s craated with only the top-level block displayed. You can then uss
the logic expansion capabilities of the Viewar to start expanding from
the fop-level block

¥ou can akeo change the startup mode by selecting Edit->Preferences under
the RTL,Tech Viewer page

[#] Show this dialog on startup o

Figure 4-2: Set Viewer Startup Mode
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The Schematic Wizard enables you to select elements for exploration start up. See
Figure 4-3.

Create Technology Schematic

1) Select items you want on the schematic fram the “Available Elerments” list and move them to the “Selected Elements” list
- Use the Filter control to filter the “Available Elements” list by name
23 Press the “Create Schematic” button to generate a schematic view using the itermns in the “Selected Elements"” list

Available Elements Selected Elements
= g stopwatch
| Primitives
! Signals <- Remove
| Top Level Ports
<<- Remove Al

* v| [ Filter ] Create Schematic

Figure 4-3: Schematic Wizard

The Available Elements window shows all the objects available in the design. They are
classified in the following categories: primitives, signals, top-level ports, and
hierarchical blocks.

Note: Hierarchical blocks are visible in hierarchical netlists only. Please refer to Chapter 5, Lab
2: Working with Hierarchical Netlists for more information on working with hierarchical designs.

3. Select MACHINE/sreg_ FSM_FFd1 and MACHINE/sreg FSM_FFd1-In from the
primitives category of Available Elements and add them to the Selected Elements list
using the Add button. See Figure 4-4.

fivadable Elaments - Selectad Elements
= MACHINEfrst D MACHINE sreq_FSM_FFd1
= MACHINE[5teg_PSM_FFdi 2 MACHINEjsreg_FSM_PEdL-In
« MACHINEfsteg_FSM_FFd1-In < Remove

T MACHINE[sreg_FSM_FFd1-In_Swi
O MACHINE erng P FFdicin SW1 | << Remove &1

Figure 4-4: Available Elements

If the list of elements is too long, you can use the Filter to reduce the search scope. As
an example in our case, you can specify MACHINE/sreg_FSM_FFd1* as a search
criteria as shown in Figure 4-5.

fivadoble Elemerts Lo Selected Elements

= MACHINEfsreg_F3M_Frdl
+ MACHINEforeg_FSM_FRdi-In
= MACHINE[sreg_FSM_FRdi-In_Swo

T MACHINE{sreq_FSi_FFd1-In_5w1 v

MACHINEsreq_FSM_FFd1® v Htevs ]
Figure 4-5: Filtering

4. Press the Create Schematic button to create the schematic.

RTL and Technology Schematic Viewers Tutorial = www.xilinx.com 15
UG685 (v13.1) March 1, 2011


http://www.xilinx.com

Chapter 4: Lab 1: Basic Features

& XILINX.

Step 4: Using the Schematic Viewer Interface

The Schematic Viewer graphical user interface (GUI) has the following components as

shown in Figure 4-6.
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Figure 4-6: Schematic Viewer

The schematic window is the main window where you explore your design by adding

This toolbar contains the functions specific to the Schematic Viewer.

This panel contains two types of information: objects visible on the schematic
(instances, pins and signals) and object properties. For example, you can select a
BRAM primitive in your schematic and see all its properties, including BRAM

1.
or removing elements.
initialization values.
Note: You must select the View
4.

(shown in Figure 4-7)

by Category tab to see this panel.

This toolbar contains functions shared by different graphical tools such as Zoom

AL HEAR

Figure 4-7: Zoom Toolbar

Note: Menu control functions are accessible from specific or general toolbars and can be invoked
from the menus. For example, all zoom functions can be called from the View > Zoom menu.

We will mainly deal with the schematic window and toolbars in the labs.
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Step 5: Zooming

Zooming is a basic function which is constantly used during design analysis. Schematic
Viewer has five zooming operations which can be accessed from the general toolbar shown
in Figure 4-7, or via the View > Zoom menu. However, the Schematic Viewer supports
specific mouse stroke operations, allowing you to perform zoom operations much more
quickly.

We suggest that you play with different zoom operations to familiarize yourself with them.
They will be very helpful during the rest of the tutorial. Table 4-1 gives an overview of
Zoom operations and their access methods:

Table 4-1: Zoom Functions

Zoom Operation Toolbar Menu Command Shortcut

Zoom In p View > Zoom > In Do either of the following:

e Press F8.

¢ (Click and drag down and
to the left.

Zoom Out = View > Zoom > Out Do either of the following;:

e DPress F7.

* Click and drag up and to
the right.

Zoom to Full p- View > Zoom > To Full View Do either of the following:

e DPress F6.

¢ Click and drag up and to
the left.

Zoom to Box pad View > Zoom > To Box Starting from the upper left
corner, click and drag to

draw a bounding box
around the area.

Zoom to Selected y View > Zoom > To Selected Select the objects you want
to center in the window, and

press F11.

Step 6: Expanding the Schematic View

Although the initial schematic view is your starting point, you will typically want to
expand the view to include more objects of interest. There are several ways to expand the
schematic.

First, you need to select an element to which you would like to add a new (not yet visible)
element. You can select the following types of elements to be expanded: net, block, pin of a
block, and port.

To expand the view from the selected object, use the mouse right-click context menu and
select the elements you want to add, such as drivers, loads, driver and loads, or to extract,
such as an input or output logic cone.

RTL and Technology Schematic Viewers Tutorial = www.xilinx.com 17
UG685 (v13.1) March 1, 2011


http://www.xilinx.com

Chapter 4: Lab 1: Basic Features & XILINX.

On the current schematic, select different objects and observe the context menu. Although
similar, the exact content depends on the object type chosen and where it is located in the
design.

lut3 fde

CIR

() Shaw Naat Drive (Dutput) Fin Show All Block Inputs -d"]

o Show Next Load (Input) Pn Show All Block wits E
MACH FFd1-In Show All Block Inputs/Cutputs

L Freferences.., B> Add Input Cona... Ah#Shift]

) Add Ouput Cona., Alt#Shift+

Show All Signal Blocks

19 Hew Schematic With Setected Objects
O Remon: Selctsd Objects

Freferences...

Figure 4-8: Context Menu

Example

1. Select the I2 pin of the lut3 primitive, and select Show Next Drive (Output) Pin from
the context menu to see its driver. The following schematic appears, as shown in
Figure 4-9.

ut3

|

MAGHINE/sreg_FSM_FFdi-n_SW1  MACHINE/sreg_FSM_FFatdn ACHINE/sreg_FSM_Frd1

Figure 4-9: Example Schematic

2. The newly added lut4 element has a different color. The Schematic Viewer
automatically colors newly added objects so they can be easily localized on the
schematic. You can enable or disable this feature using the Schematic Viewer toolbar
(see Figure 4-10). In addition, you can modify new object colors using the Preference
menu.

(Eal
Figure 4-10: Coloring Icon

3. If you want to incrementally expand nets, block pins, or ports, you can just point the
mouse on the desired object and perform a left mouse double-click. This is a very
handy shortcut over using the context menu.

18 www.xilinx.com  RTL and Technology Schematic Viewers Tutorial
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Double-click the 10 pin of lut3 primitive, and the result appears as shown in

Figure 4-11.

-

MACHINE/sreg_FSM_FFd1-In_SW1

. R S

MACHINE/srag_FSM_FFd3

lutd

Figure 4-11:

MACHINE/sreg_FSM_FFd1-In

lut3 fde

-

-1 S

ok
MACHINE/sreg_FSM_FFd1

Incremental Expansion

A new fdc flip-flop was added to the schematic, but it is connected to I0 pin by a net
in the form of a dashed line. The presence of a dashed line means that there are other
objects connected to this net in your design, but they are not yet visible.

4. Continue to double-click the (dashed-line) net until it becomes a solid line, meaning

that all elements connected to the net are now visible as shown in Figure 4-12.

utd

FLbt

ACHINEEEg_ P _FRat-n_Sie
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VACHINEseg P31 FFo
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HACHINE'SER _FSi_Cuft

utd

WACHINE seg_F3_FFa-n

uts
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2] e

VACHINE seg_F3_FFaZn

ut3

2] face
[

MACHINESe g F3d_Cuttt

utd

plrt

il enabiet

Figure 4-12:

Connecting the Net
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Step 7: Using Start/End Signal Markers

Start/End signal markers allow you to easily identify source and destinations of a selected
signal.

1. To use this feature you have to first enable it using a button in the Schematic Viewer
toolbar. This button has two states. The green state indicates the feature is enabled, and
the red state indicates the feature is disabled. Push the button shown in Figure 4-13 to
put it into the enabled state.

(@
Figure 4-13: Start Signal Marker

r]
Figure 4-14: End Signal Marker

2. Select any signal on the schematic to see its source and destinations. See Figure 4-15.

ut4

o]
o

A

T
WACHINE seg_F3! FFo

-

WACHINE seg_FS) FRotn_Swd | MATHINEmeg 3l FFatn

= |-

e

.

{AHINE g FRIFRa2 WACHINESen_F3!_Oug!

L

WACHINEseg_F3)_FFa-n

e

.

WACHINE=eg_FSH_FFoz-n

.

.

MACHINE meg F2I_Qur

ontED enabiet

Figure 4-15: Sources and Destinations

Step 8: Navigating the History

The “back” button (or Ctrl+Z) provides the ability to return to previous schematic steps,
and the “forward” button (or Ctrl+Y) provides the ability to move forward. For example,
you can use the back to return to a previous schematic step so you can continue design
exploration in a different direction. See Figure 4-16 and Figure 4-17.
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@
Figure 4-16: Back Button

@
Figure 4-17: Forward Button

1. Push the back button several times to get the following view, shown in Figure 4-18.

lutd lut3 fde

- -

- -

S - 1, T
MACHINE/sreg_FSM_FFd1

MAGHINE/sreg_FSM_FFd1-in_SW1  MAGHINE/sreg_FSM_FFd1-in

fdc ut2

=
- o .o

MACHINE/srog_FSM_FFa3 MACHINE/sreq_FSM_Out01

Figure 4-18: Previous View

2. Select the lut2 primitive, and select Show All Block Inputs/Outputs from the
right-click context menu. See Figure 4-19.

litd ut3 fde

£ -

]

A,

- | =1 (-1
£

—h ]
MACHINE/sreg_FSM_FFd1

MACHINE/sreg_FSM_FFd1-In_SW1  MACHINE/sreg_FSM_FFd1-In

fdc ut2 ]

L : = |
MACHINE/sreg_FSM_FFd3

MACHINE/rs
MACHINE/sreg_FSM_Out01 WAEEME

fdc

oF
MACHINE/sreq FSM_FFd2

Figure 4-19: Show All Block Inputs/Outputs
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Step 9: Removing Elements from the Schematic

During schematic expansion you may find that some previously added elements are not of
interest for your particular design analysis. These elements can be selected and removed
from the schematic. You can use Delete keyboard key, the delete button from the toolbar as
shown in Figure 4-20, or the Edit > Delete menu command.

Og
Figure 4-20: Delete

To select a single element, just use a single click. To select multiple elements, you can select
the first one and then incrementally add other ones by holding the Ctrl key and clicking
them. Or, you can use in-box selection by holding down the Ctrl key and dragging over the
objects you want to select.

1. Select the lut4 and lut3 primitives on the schematic.

2. Press the Delete keyboard key to remove them.

- -

Pr—
MACHINE/sreg_FSM_FFd1

fde ut2

— ]
MACHINE/sreg_FSM_FFd3

MACHINE/rst

MACHINE/sreg_FSM_Outd1

Figure 4-21: Deleting Items
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Conclusion
In this lab you learned the basic operations available in the Schematic Viewer:
* Selecting Schematic Viewer startup mode
¢ Using the Schematic Wizard to select elements to start a schematic investigation
¢ Performing zoom operations based on mouse strokes
e Expanding schematics in different ways
e Coloring new elements
¢ Navigating history
e Using Start/End signal markers
* Removing elements from schematics
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Lab 2: Working with Hierarchical
Netlists

Objectives

The goal of this lab is to familiarize yourself with hierarchical netlists and to learn how you
can manipulate hierarchical blocks during design analysis. This includes:

¢ Expanding external/internal hierarchical blocks

¢ Showing and hiding the entire contents of a hierarchical block

In addition, you will learn some special considerations you need to take into account when
working with hierarchical blocks.

Finally, you will see how to start schematic exploration using the Starting schematic
exploration with the top-level block startup mode introduced in Chapter 4, Lab 1: Basic
Features.

Lab

Step 1: Creating the Lab Project
Create the stopwatch project and set the Light Background Color Scheme for Schematic
Viewer as described in Chapter 3, Lab Preparation: Getting Started.

Step 2: Setting XST Options and Synthesizing the Design

1. Inthe Processes pane, right-click Synthesize - XST, and select Process Properties to
open the Synthesis Options dialog box.

2. Set the Keep Hierarchy option to Yes as shown in Figure 5-1.

Cakeqgory

Property Marne Yalue
SY”thBSils Options keep Hisrarchy s W
HOL Cptions — % i
ilinx Specific Options | | Metlist Hierarchy As Optimized v
=lahal Cinbirnizabinn Saal [ nlir‘l‘.—.rtm.:l-f u.

Figure 5-1: Keep Hierarchy
3. Synthesize the design using Synthesize - XST from the Processes pane.
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Step 3: Launching the Schematic Wizard

1. After synthesis is complete, start the Schematic Viewer by double-clicking the View
Technology Schematic process, and select the Start with the Explorer Wizard startup

mode.

2. In the Schematic Wizard, all hierarchical blocks (including the top-level block) are
represented by the hierarchy symbol as shown in Figure 5-2. You can click the plus
symbol in front of a hierarchical block to further expand its contents.

)

Figure 5-2: Hierarchy Symbol

3. Select the hierarchical block named MACHINE, and move it to Selected Elements
using the Add button, and then click Create Schematic. See Figure 5-3.

Auvaisble Elements - Selected Elements
Wiy decncr (&> ] |& mone
& & Inst_doml P —

2 bled < femove |

« N —

Hoa sty

-
'V

Create Schemati |

Figure 5-3: Selecting Hierarchical Elements

Step 4: Understanding Hierarchical Block Symbols

The created schematic appears as shown in Figure 5-4.

i

=

® |

i Design Summary (Syrthesized) |

statmach
CLK | clken
locked _|
reset _| [ intenalPin | [ Externaipin |
| = ~ ~ A =~
stristop | 3 :stf.{"

A 4
MACHINE

stopwatch (Tech) ] skopwateh (Tech2)

Figure 5-4: Schematic Representation
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Two items distinguish a hierarchical block from a primitive:

All hierarchical blocks have triangles in four symbol corners as shown in Figure 5-4
and Figure 5-5.

In addition to external pins, hierarchical blocks also have internal pins. Internal pins
allow you to explore the content of a hierarchical block while showing it on the same

page.

b
Figure 5-5: Triangle Symbol

Expansion operations from the mouse right-click context menu (available for primitive
pins and blocks) are available for internal and external pins and for the hierarchical block
itself. In addition, you can use the incremental expansion approach (mouse double-click)
on internal and external pins.

Step 5: Expanding Hierarchical Blocks

1. Double-click the internal and external strstop pin of the MACHINE block to get the
following schematic (Figure 5-6).
inv statmach:1
i ¥y - ' E
A ax f ut3 | o
stristopinv 1_INV_0 g |
sreg FSM_FFd3-In_F
A
MACHINE
Figure 5-6: Machine Block
2. Right-click the clken external pin of the MACHINE block, and select the Show Next
Load (Input) Pin option.
The CNT60enablel block appears as shown in Figure 5-7.
inv statmach:1 lut2
% o lut3 e
strtstopinv1_INV_0 locked |
— 2] B cnt60enable1
sreg_FSM_FFd3-In_F
MACHINE
Figure 5-7: Expanding Blocks
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Step 6: Showing and Hiding Block Contents

You can view the entire contents of the hierarchical block by using the View Hierarchical
Block icon (Figure 5-8) from the schematic toolbar or by using the right-click context menu.
To hide its contents, use the Hide Hierarchical Block icon (Figure 5-9).

4

Figure 5-8: View Hierarchical Block Icon

#

Figure 5-9: Hide Hierarchical Block Icon

1. Selectthe MACHINE block, and press the View Hierarchical Block icon to see its entire
contents as shown in Figure 5-10.

-

Figure 5-10: View Block Contents

2. Select the MACHINE block, and press the Hide Hierarchical Block icon to hide its
entire contents as shown in Figure 5-11.

inv statmach lut2
: : : © CLK clken
strtstopinv1_INV_0 locked |
reset | i [ o
stristop st _io_|
MACHINE cnt60enable1

Figure 5-11: Hide Block Contents
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Step 7: Using Bottom-Up Design Expansion

In the previous steps, you were mainly dealing with top-down schematic expansion. Now
we will use the Schematic Viewer in a “bottom-up” mode.

1. Select the following two tabs (Figure 5-12), and close them using the close window
button (Figure 5-13).

stopwatch.ngei 1 Q stopwatch {Tech2) @

Figure 5-12: Tabs to Close

»
Figure 5-13: Close Window Button

2. Restart the Schematic Viewer by selecting the View Technology Schematic process
and selecting the Start with the Explorer Wizard startup mode.

3. Select the sreg_ FSM_FFd3-In_F from within the MACHINE hierarchical block, add it
to the Selected Elements, and then click Create Schematic. See Figure 5-14.

Fuvadshle Elarments A Selectad Elaments
5 & MACHINE gdd-> | | sreq FsM FF3InF
| Hierarchical Black Pins :
o =
O sreqg FSM_FFd3
D e FSM_FFd3-In [[<<-Remove aa |
*. sreq FSM_FFd3-In_F
T zreg_FSM_FFdi-In_G
- Sl !
sreg_F3H_FFds® ~ Fiter Creste Schematic

Figure 5-14: Restarting Schematic Viewer

4. Select the sreg_ FSM_FFd3-In_F, and select Show All Block Inputs from the right-click
context menu.

5. Comparing the start-up schematic (Figure 5-15) with the one we obtained at Step 6:
Showing and Hiding Block Contents (Figure 5-16), you see that the
sreg_ FSM_FFd3-In_F primitive is not placed inside the MACHINE hierarchy block.
In addition, MACHINE I/Os are represented as primary design pins.

fde ut3
o Q
=
C | i 2
4]
CLR

sreg_FSM_FFd3 sreg_FSM_FFd3-In_F

[locked

stristop >
Figure 5-15: Start-Up Schematic
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inw statmach:1

i t3
shristopiny 1_INY_0 gt |

sreg FSM_FFd3-n_F

MACHINE

Figure 5-16: Step Schematic

6. Further incremental design exploration shows that schematic expansion stops at
MACHINE hierarchy boundaries as shown in Figure 5-17.

fde ut3 muxfd

10

1"

s

m . sreg_ FSM_FFd3-In
sreg_FSM_FFd3 sreg_FSM_FFd3-In_F

locked

Sfiistop)>

lut2 fdp

,70 a
" [o]

10

rst

sreg_FSM_Out01

Figure 5-17: Hierarchical Boundaries
To cross hierarchy in a bottom-up direction, use the Pop to the Calling Schematic icon
(Figure 5-18):
2
Figure 5-18: Pop to the Calling Schematic

7. Press the Pop to the Calling Schematic icon to cross hierarchy in a bottom-up direction
as shown in Figure 5-19.

statmach: 1

MACHINE

Figure 5-19: Upper Hierarchical Level

You can now continue further schematic exploration inside as well as outside the
MACHINE block. Use the Pop to the Calling Schematic icon each time you need to go to
the upper hierarchy level.
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Step 8: Starting Schematic Exploration with the Top-Level Block

In Chapter 4, Lab 1: Basic Features, we introduced two modes to start schematic

exploration:

e Start with the Explorer Wizard

e Start with a schematic of the top-level block

Until now, we exclusively used the first mode. Now we will learn how to use the second

mode.

1. Close all currently opened schematic tabs using the close window button.

2. Restart the Schematic Viewer by selecting the View Technology Schematic process.

3. Select the Start with a schematic of the top-level block startup mode, and press the
OK button as shown in Figure 5-20:

E Set RTL/Tech Viewer Startup Mode E

Startup mode

schematc

Select how the RTL/ Tech Viewer behaves when it is initially invoked

O Start with the Explorer Wizard

In this mode, the Explorer Wizard ks the initial soreen, and allows
you o sebect the elements that you want to see on the initial

(=) Start with a schematic of the top-level block

In this mode, the Explorer Wizard ks bypassed and an nifial schematic
s created with only the top-level block displayed. You can then use

the logkc expansion capabilities of the Viewer to start expanding from
the top-level biock

‘foul can atso change the startup mode by selecting Edit->Preferences under
the RTL/Tech Viewer page

[#] Show this dialog on startup

e ]

Figure 5-20: Startup Modes

The following startup schematic appears, as shown in Figure 5-21.

CLK

stopwatch

ONESOUTH:0)

RESET

TENSOUT(6:0)

| STRTSTOP

TENTHSOUT(®:0)

Figure 5-21:

A4
stopwatch

Top-Level Block

4. You can start design exploration by using all previously described schematic

expansion methods.
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Conclusion

In this lab, you learned how to use the Schematic Viewer on a design with hierarchical
blocks. This included learning how the blocks are represented in the Schematic Wizard and
how they can be expanded for design analysis.

In addition, you learned how to start schematic exploration using the Starting schematic
exploration with the top-level block startup mode introduced in Chapter 4, Lab 1: Basic
Features.
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Lab 3: Using Schematic Viewer for
Timing Analysis

Objectives

Lab

Critical timing paths from the post-place and route timing report can be easily visualized
in the Schematic Viewer by cross probing from the Timing Report to the Schematic Viewer.
The visualized critical path can be used as a starting point for further design exploration.
Moreover, it is easy to annotate the critical path with timing delays.

The goal of this lab is to demonstrate how to cross probe from the timing report to the
Schematic Viewer and how to annotate the visualized timing path with reported delays.

Step 1: Creating the Lab Project

Create the stopwatch project and set the Light Background Color Scheme for Schematic
Viewer as described in the Chapter 3, Lab Preparation: Getting Started.

Step 2: Specifying Timing Constraints

To use the cross probing mechanism, add a new UCF file called stopwatch.ucf to the
project. Then, using Constraints Editor, specify a period constraint of 3.5 ns for the CLK
signal as shown in Figure 6-1.

Clock signal definition
() specify time

Time: 3.5 Units: ns v

Figure 6-1: Clock Signal Definition

Step 3: Specifying XST Options and Implementing the Design

1. In the Processes pane, right-click Synthesize - XST, and select Process Properties to
open the Synthesis Options dialog box.
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2. Set the Keep Hierarchy option to Yes as shown in Figure 6-2.

Cakeqgary

Property Name yalue
Synthesis Options Keep Higrarchy Vos -
HOL Cptians — —
o iline Specific Options Metlist Hierarchy As O’&timized w
r=lnhal rinkirnizabinn Gaal Al Ak hlake e

Figure 6-2: Keep Hierarchy

3. Implement the design by double-clicking the Place & Route process in the Processes
pane, as shown in Figure 6-3.

4. Open Timing Analyzer for the post-place and route design.

=- f3  Place &Route
= P2  Generate Post-Place & Riaute Static Timing
Analyze Post-Place & Route Static Timing

Figure 6-3: Analyze Post-Place & Route Static Timing

Step 4: Viewing the Critical Path in the Schematic Viewer

In the timing Report Navigation section, select the critical path to access the detailed data
path information. The detailed path view allows you to cross probe (from the mouse
right-click context menu) to different views, for example, FPGA Editor or a Datasheet

vView.
= Report Ravigation Slack “  Source Destination Path Delay Requirement Logic Levels
= Tiesing report descrigtion I|_ 5514 |
Tt Sumeiany g
(%] & Informational messages 2 2028 MACHINEfsreg F3M_FRd3  sicbyfmsboount jgoutsin O 5.514 3.500 3
= T Timng constrants 3 “2.00% MACHINElreg_FSM PRI sty lmsbeount goutsg_2 5,514 3,500 3
+ T T5_CLK = PERIOD TIMEG, — - mp——— — pEifsase)
ertinatien Clocks € AFIEANY AE 2 i
= T L1 [l = -
2 .T ;‘Isr:“ndcml‘q 0_F Clock Uncertainty: 0. 000ne
i Hold paths PRI FFds o —— 2
! . C_MSMMM {h:ahon Pelay Type Peleyine] Foyrical Farcuice
+ Derived Conatraint Report } Legical Rascurce({s)
+ {) Rabaxl @ I X0 Igko 0.591 MACHINE feceg_FEM_FFd3
T ¥ ; = 3
L]
View 2T F2 nat {(fanouc=7§ 0.655 MACHINE/sreq FOR FF42
TNEH [Pt Tink
ki FRGA Edir e R O
4T4.FL net (fanout=7) 0.930 EY
MF : 0220 = (3 rooa [©)
REG
SLICE XI4¥E.GL neat {fancuc=3}p 0.1z sn \iaw .
ELICE_MI4TE. ¥ Tile 0.75%  ed s i FPGA Editor
iy
suzca xesvs.cx net {fanous=2) o.284 g m
SLICE WISTS.CLK Touck 0.555 mr
< ¥| £

Figure 6-4: Report Navigation

In this lab, we will focus on the links dedicated to Schematic Viewer only (Figure 6-4):

* Selecting (1) Maximum Data Path allows you to visualize the entire data path.

* Selecting (2) a net from the Physical Resource column visualizes just a portion of a
data path connected by a selected net.
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1. Right-click Maximum Data Path, and select Show in Technology Viewer. This draws
the selected data path in the Schematic Viewer as shown in Figure 6-5.
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2. Observe the following;:

® The start point of the critical path is marked with a start icon (Figure 6-6).

)

Figure 6-6: Start Icon

Figure 6-5: Schematic Viewer

¢ Slices are represented as hierarchical blocks. This means that you can explore their

internal contents using internal pins as well as their external connections.

*  You can use all available features (described in earlier labs) to further explore the

schematic.

Step 5: Annotating the Schematic with Timing Delays

Delays from detailed path report (Figure 6-7) can be directly visualized on a schematic.

Maximum Data Path: MACHIME =sreq FSM FFA3I to sixt

meshoount fgoutsig O

Location

SLICE_K1ZYZ.
SLICE_XK1ZYZ.

SLICE_HKZ4T4.
SLICE_HKZ4T4.

Delay type

net {fanout=7)
Tilo

net {fanout=7)
e

Delayins)

SLICE_X13YZ.

0.930
0.753

Physical Besource
Logical Besourceis)
MACHINE fsreg FSHM FFd3
MACHINE fsreq FSHM _FFd3
MACHINE fsreqg FSM _FFd3
rstint

MACHINE fsreqg FSHM Outll

clkenable
cntelenable

Figure 6-7: Path Report

1. Select the schematic sheet with the visualized data path.

2. Press the Annotation icon (Figure 6-8) from the Schematic Viewer toolbar.

e

Figure 6-8: Annotation Icon
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3. In the following dialog box, check the Delay Values option. Check the Pin Names option
as shown in Figure 6-9.

& Select Block Pin Annota... [

Selact the properties bo dsplay at each block pin
] signal Masnes
(] Dobay Yahaes

Lo J[ coms [ o |

Figure 6-9: Select Block Pin Annotation

A schematic view of the data path annotated with timing delays appears, as shown in

Figure 6-10.
:\::- SEauriavIn.a
= A |
Comps:SLICEL:1
‘ couT
; Bels:SLICEL_FFX _
B = | st F2:0.9¢
: GE (@ 501 ns | xa
2 ol FX
) REV_|
F&
= | :
o i ; BACHING a beount / gout 51
L] Locacion Dalay type E Fhysical Rescurce E
IACHINEered - S i
g SLICE_X13YZ.XQ Isko MACHINE/sreg_FSM_FFd3
UACHINE/sxea FOM FFd3
SLICE_M1EYZ.FZ net [ fanouc=7) 0.655 HACHINE /sveq FSH_FFdd

P

Figure 6-10: Data Path Annotated with Timing Delays

Conclusion
In this lab, you learned how the Schematic Viewer can be used to help visualize key
information during timing analysis. You were able to select critical timing paths from the
timing report, and graphically visualize them in the Schematic Viewer. Finally, you
annotated the critical path in the Schematic Viewer with timing delays from the timing
report.

36 www.xilinx.com  RTL and Technology Schematic Viewers Tutorial

uUG685 (v13.1) March 1, 2011


http://www.xilinx.com

& XILINX.
Chapter 7

Lab 4: Simplifying Design Analysis

Objectives

Very often, during design exploration, you must deal with a significant number of
elements incrementally added to the schematic sheet. The sheer number of elements on the
schematic can complicate the design analysis process.

The goal of this lab is to show you several methods to reduce design complexity and make
the analysis process more efficient. These methods include capabilities to:

¢ Use Start/End Signal markers to quickly identify source and destinations of selected
signals

* Remove elements that are not of interest from the schematic sheet
¢ Work with multiple schematics of the same netlist
e Start a new schematic by selecting a subset of elements from the current design view

® Use colors to highlight a specific design instance or a group of similar elements

The first two methods were already described in Chapter 4, Lab 1: Basic Features;
therefore, the main focus is the last three features.

Lab

Step 1: Creating the Lab Project
Create the stopwatch project and set the Light Background Color Scheme for Schematic
Viewer as described in Chapter 3, Lab Preparation: Getting Started.

Step 2: Setting XST Options and Synthesizing the Design

1. In the Processes pane, right-click Synthesize - XST, and select Process Properties to
open the Synthesis Options dialog box.

2. Set the Keep Hierarchy option to No as shown in Figure 7-1.

Category

= - Property Mame Value
Synthesis Options | || ibapy Search Order )
HODL Cptions ; -
Wilir: Specific Options | | Keep Hisrarchy Mo ) b
| Metlist Hierarchy As O&imized bl
| Global Ootimization Goal AllCInckets “
Figure 7-1: Keep Hierarchy Option
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3. Synthesize the design using the Synthesize - XST process.

Step 3: Working with Multiple Schematics of the Same Netlist

To demonstrate this feature, we will select a flip-flop and analyze its input and output logic
cones. To simplify schematic complexity, you will place the input logic cone on one sheet
and the output logic cone on another sheet.

1. After synthesis is complete, start the Schematic Viewer by launching the View
Technology Schematic process, and select the Start with the Explorer Wizard startup
mode.

2. Select the MACHINE/sreg FSM-FFd1 flip-flop for schematic startup, and then click
Create Schematic.

3. Select the visualized flip-flop, and select Add Input Cone from the right-click menu.

The input appears as shown in Figure 7-2.

QO B

tttttttt hungeit E] stopwatch (Tech10) aj

Figure 7-2: Adding Input

4. Click the Stopwatch.ngc tab to return to the Schematic Wizard. Select Create
Schematic to open a new schematic tab. Select the visualized flip-flop, and select Add
Output Cone from the right-click context menu.
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The output appears as shown in Figure 7-3.
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Figure 7-3: Adding Output

Observe that you were able to reduce complexity of the design view by dividing it into two
pieces. The capability to visualize multiple schematics can be used for many different
purposes. One of them is discussed in Chapter 8, Lab 5: Comparing Two Design
Implementations, where you will see how to use this feature and to compare two different
netlists of the same design.

Step 4: Starting a New Schematic by Selecting Elements from the Current

View

Suppose during design debugging you are able to localize the source of a problem and
would like to focus just on that limited portion of the design. However, the drawn
schematic might have many other elements that are not of direct interest and clutter the
view.

Of course, as described earlier, you can try to select those objects you are not interested in
and remove them. Another way to accomplish this is to return to the Schematic Wizard and
start a new schematic by selecting required elements. Depending on your particular
design, these methods can be tedious and time-consuming.

Often, the best way to handle this is to directly select the required elements from the
current view and start a new schematic by pushing the Start Schematic icon (Figure 7-4)
from the schematic toolbar.
x|
Figure 7-4: Start Schematic Icon

Note: In this case, the Schematic Viewer does not create a new schematic sheet. It places the new
schematic on the same sheet.
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1. Select the Stopwatch (Tech1) tab on the schematic.
2. On this sheet, select elements surrounded by the rectangle as shown in Figure 7-5.

Figure 7-5: Stopwatch (Tech1) Schematic
3. Press the Start Schematic icon to start new schematic. The new schematic appears as
shown in Figure 7-6. You can continue to further expand as described in earlier lab
segments.

Jut3 fdc

MACHINEfsreg_FSM_FFdi-in.  MACHINE/sreg FSM_FFd1

Figure 7-6: New Schematic
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Step 5: Using Colors to Highlight a Group of Specific Elements

Select the Stopwatch (Tech2) tab on the schematic. The schematic appears as shown in
Figure 7-7.

. L

]

IR LT IR
i

bbb

Figure 7-7: Stopwatch (Tech2)

You can see many elements in this view. We will highlight all fd* type flip-flops using a
different color as a means to simplify analysis.

1. Open the Preference dialog box by selecting Edit > Preferences.

2. Under the RTL/Technology Viewers category, select the User Color Rules
sub-category as shown in Figure 7-8. This is where we can define specific color rules
for our needs.

= Preferences - User Color Rules E|

Edtors When setting the colors of the objects In genersted schematics, these ertries are
[rkegr shed Tocks evahusbed in the order ksted, The first entry that matches the schematic cbiject vwill be
Process Completion Motific. used ko define the color of that obiject.
ISE Tt Ecitoe
Templstes
RTLTchnoksgy Veewers Friry Dark, Light Color
Cickor Schenme | Bk Printer
How Chiect Cokors o Racurcuad ae

Lo [ eeme J[ e J[ rew ]

Figure 7-8: Preferences Dialog Box

3. Click the New button to open the Color Rules dialog box.
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4. Specify fd_ff_colors as a name for the color rule. Then click the New button to add a new

rule.

£ Color Rules X

[ Lad)

Mo
[Fel_fF_colors

Thee condition:s in this ruls sre svaluated in the order shown, IF any condition resultz in a
true value, the rule will be usad bo color the cbjsct in the generabed schamatic,

Corditions:
Property Name Oparator s Mave Up
{_Enncnvpe | Matches (wiidcord) () fd*

[ ot J[ comet J[ teb |

Figure 7-9: Color Rules Dialog Box

5. Select Block Type for Property Name, then select Matches (Wildcard) as Operator,

and finally type fd* as a value as shown in Figure 7-9, and press OK.

6. Inthe Light Background column, select Gray as the color (see Figure 7-10) for created
fd_ff colors, and then press OK.

E Preferences - User Color Rules EI
Category
Integrated Tacls ~
Process Completion Notific. ‘When satting the colors of the cbjects in genersted schematics, these erkries are
ESE Text Editor evahsatad in the onder ksted, The first erkry that matches the schesmatic object vl be
Larp iage Templstes wzed bo defire the color of that shiject,
= RTLTechriogy Wievwers
Ciokor Scheme: T
Narr Cljecct Colors
Entry Dark. Light: Celor
e N | ewound  wogend
= ‘Schematic Edtor = e
E;:k fd_f¥ _cclors [ pefae [ Gy J[] pefm
d |
Drevics Familles ,i EI . - -]
Friotrg LN N Emy |
Sheet Sizes
S Symbod Edkor o] @
Chack
Pl o o 0
Tining Analyzer o M Lp Phcve Din rxmm T[] New... L
< >
Figure 7-10: Selecting Light Background Gray

42

www.Xxilinx.com

RTL and Technology Schematic Viewers Tutorial

UG685 (v13.1) March 1, 2011


http://www.xilinx.com

& XILINX. Conclusion

Now all flip-flops are colored differently (gray), which allows to you to easily
recognize them on the schematic sheet as shown in Figure 7-11.

]
iiaEdlG

]

—_—
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A%E

il
L]

\
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Figure 7-11: Colored Items

When you expand the schematic by adding new elements with particular colors defined in
the Color Rules (as we did for £fd* flip-flops), specific colors may be not be visible, because
they are overwritten by New Object Colors. To see specific colors, disable New Objects
Coloring using the Color icon.

| o

Figure 7-12: Color Icon

Conclusion
In this lab you worked with several methods that allowed you to simplify the design
analysis process:
¢ Creating multiple schematics of the same netlist
¢ Starting a new schematic by selecting some elements from the current design view
* Using Color Rules to color all fd type flip-flops in a particular color to easily recognize
them on the schematic sheet
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Lab 5: Comparing Two Design
Implementations

Chapter 8

Objectives

To meet design requirements (such as speed, area, and power requirements), you may

need to modify the original HDL sources or change synthesis and implementation options.

Performing such changes sometimes requires you to understand the impact of these

changes in the final implementation.

The Schematic Viewer can help you in these situations, because it allows you to visualize

and compare different design netlists. Please note that this can be done for the XST RTL
view and post-synthesis netlists. Post-map and post-place and route netlists are not

handled in this mode.

The goal of this lab is to show you how to create two design implementations with XST and
visualize them in the Schematic Viewer.

Lab

Step 1: Creating a Lab Project

Create the stopwatch project and set the Light Background Color Scheme for Schematic
Viewer as described in Chapter 3, Lab Preparation: Getting Started.

Step 2: Setting XST Options and Synthesizing the Design

1.

In the Processes pane, right-click Synthesize - XST, and select Process Properties to

open the Synthesis Options dialog box.
Set the Keep Hierarchy option to Yes as shown in Figure 8-1.

SRR Property Name Yalue
Synthesis Options Keep Hisrarchry Yos
HOL Cptions o [ﬁ _
wilinz Specific Options | | Metlist Hisrarchy As Cpttimized

lnhal Mnbirizabinn Goal Al el hlabe

Figure 8-1: Selecting Keep Hierarchy

Synthesize the design using the Synthesize - XST process.

Open a shell prompt, go to the project directory, and copy stopwatch.ngc file to

default_run.ngc.
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Open the Xilinx Specific Options dialog box, set the Register Balancing option to Yes
(see Figure 8-2), and then re-run XST.

Qategory - Property Mame ¥alue A
Synthesis Options Equivalent Register Removal
HOL Cptions

wilinx Specific Options | |Pegister Balancing _"
|Mave First Flio-Floo Staoe [l

Figure 8-2: Select Register Balancing
During the Synthesis process, with Register Balancing enabled, XST reports that
several FFs were moved forward:

Register (s) sreg FSM_FFd3 sreg FSM_FFdl sreg_FSM _FFd2 has(ve) been
forward balanced into : sreg FSM Outll_FRB.

Take a look at how this is reflected in the Schematic View.

Step 3: Loading and Comparing Two Netlists

1.

Open the Technology Viewer by using the View Technology Schematic process for the
latest generated netlist in the Start with the Explorer Wizard mode. Select the
hierarchical block icon (see Figure 8-3) and create the schematic.

5 MACHINE
Figure 8-3: Hierarchical Block Icon

Open the previously stored default_run.ngc netlist by selecting File > Open File.
Select the Start with the Explorer Wizard mode. Project Navigator loads the netlist
and starts the Schematic Viewer Wizard. Using the wizard, select the MACHINE
hierarchical block icon (Figure 8-3) and create the schematic.

Simultaneously view the two schematics sheets horizontally using the Dual View icon
(Figure 8-4) from the general toolbar. To expand the view, double-click the inside pins
of the RST and CLKEN pins. The display appears as shown in Figure 8-5.

Figure 8-4: Dual View Icon
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& default_run (Techi)

b statmach 1

MACHINE

b statmach: 1

seg_ FEM, Cutti_FRE

MACHINE

Figure 8-5: Dual View of Schematic

4. The bottom netlist was generated using the Register Balancing mechanism. Note how
XST moved forward several FFs (creating sreg_ FSM_Out11_FRB) towards the output
of clken pin to improve design performance.

Conclusion
In this lab you visualized and compared two netlists for the same design, where each was
generated using different XST options.
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Lab 6: Dealing with Large Designs

Objectives

The latest FPGA families from Xilinx® allow you to implement ever larger and more
complex designs, which can significantly complicate the analysis process. For the largest of
designs, having hundreds of thousands of design elements is entirely possible. Visualizing
the entire design on a single page is not practical.

This lab provides several tips on how you can deal with complex designs while keeping
good visibility and preserving good responsiveness using the Schematic Viewer.

Tip 1: Using Hierarchical Netlists

The presence of hierarchy in the post-synthesis netlist significantly reduces its complexity
for design analysis process as well as for the Schematic Viewer. Please note that the XST
RTL netlist is fully hierarchical.

Preserving Hierarchy

XST enables you to either fully or partially preserve design hierarchy. However,
hierarchical preservation prevents logic optimization across hierarchical boundaries of
preserved blocks. As a consequence, this may negatively impact design performance.

Therefore, when using hierarchical preservation during synthesis, you have to ensure that
you still meet design goals.

Rebuilding Hierarchy

Another way to generate a hierarchical netlist without a design performance impact is to
use the Netlist Hierarchy option. If the value of this option is set to Rebuilt (as shown in
Figure 9-1), XST automatically reconstructs the hierarchy of the final netlist even if it was
fully flattened during optimization.
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:GlobHOpr.m.anm Gasl As Cichierized |
|Generate RTL sehemati _
| Read Cores: )
|Coeers Search Directories G )|

< 3| Property deploy level: |Advanced | O] oisplay switchnames | Defaut |

Figure 9-1: Rebuilt Option
This feature is not set by default, because it may increase XST synthesis runtime and could
affect the accuracy of area estimation reports.

We suggest you run tests of this option on your current design to ensure that synthesis
runtime is acceptable.

Tip 2: Using Multiple Schematic Sheets

Conclusion

Even if the hierarchy of your design is fully reconstructed, a single hierarchy level may still
contain thousands of elements, complicating visualization and analysis.

If you need to deal with a significant number of elements, we suggest you take advantage
of the capability to visualize the same netlist on multiple schematic sheets as shown in
Figure 9-2. As you have seen in earlier labs, this process can be fully controlled and
adapted for your specific needs.

Figure 9-2: Multiple Schematic Sheets

Please refer to Chapter 7, Lab 4: Simplifying Design Analysis for more information.

In this lab you have seen an overview of methods you can use to handle large designs. The
first method consists of ways to generate hierarchical netlists. The second method suggests
using multiple schematic sheets to reduce the number of elements you need to visualize at
any one time.
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Lab 7: Using the Schematic Viewer as a
Standalone Tool

Objectives

Command line users often need to run point tools, such as FPGA Editor or Schematic
Viewer, for design analysis.

In the ISE® software, you cannot launch Schematic Viewer in a “standalone” mode.
However, there is a workaround for this limitation, which allows you to explore the XST
RTL View or XST post-synthesis netlists. Post-map and post-place and route netlists are not
handled in this mode.

The goal of this lab is to demonstrate how the Schematic Viewer can be used to emulate a
standalone tool to view XST RTL and post-synthesis netlists.

Use Table 10-1 to localize the required netlist.
Table 10-1: Netlist File Extensions

Netlist Extension
XST RTL ngce
XST post-synthesis ngr

Lab

Step 1: Creating the Lab Project

Create the stopwatch project and set the Light Background Color Scheme for Schematic
Viewer as described in Chapter 3, Lab Preparation: Getting Started.

Step 2: Setting XST Options and Synthesizing the Design

1. In the Processes pane, right-click Synthesize - XST, and select Process Properties to
open the Synthesis Options dialog box.

2. Set the Keep Hierarchy option to Yes as shown in Figure 10-1.

RTL and Technology Schematic Viewers Tutorial = www.xilinx.com 51
UG685 (v13.1) March 1, 2011


http://www.xilinx.com

Chapter 10: Lab 7: Using the Schematic Viewer as a Standalone Tool

& XILINX.
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HOL Options | o —l— |
o ilina Specific Options i Metlist Hierarchy As Optimized

lahal Cinkirmizabinn Goal

Figure 10-1:

LAl larlhaks

Keep Hierarchy

3. Synthesize the design using the Synthesize - XST process.

4. After synthesis is complete, close the project by selecting File > Close Project. Note

that Project Navigator remains open.

Step 3: Opening the Post-Synthesis Netlist in Schematic Viewer

1. The post-synthesis XST stopwatch.ngc netlist is located in the project directory (the
.ngc file can be generated from command line mode). To open this netlist in
Schematic Viewer, select File > Open File.

2.

Select the Start with the Explorer Wizard startup mode. Project Navigator loads the

netlist and starts the Schematic Viewer Wizard as shown in Figure 10-2. Now you can

move on and explore your design.

EZ ISE Project Navigator - [stopwatch (Tech)]

j=4 Flle Edit View Project Source Process  Took  Window  Hal

Conscle

<

Console | Errors

¥ oo oo M
& x

Create Technology Schematic
No project is open
Select one of the buttons below b get

started, Mo, check out the “What's New®™
el page, avalsble from the Heip”
e,

LI!SWWORG Avadable Elements Selected Elaments
T = & seomoch
Open Praject. ., = Primitives -
Gpen Example... . Top Level Ports
s & decodsr
v & e g
& lsbled
% & MACHINE
+ & mbled
& skety |
v
stopwatch (Tech)

1) Select items you want on the schematic from the “available Elements" list ar
- Usa the Filter control to filter the “dvailable Elements” list by name
2) Press the "Create Schematic” button to genarate a schematic view using the

1 A

Warrings | Find in Files Results

0 & x

|

Figure 10-2: Schematic Viewer Wizard

Conclusion
This lab demonstrated how the Schematic Viewer can be used by command line users in a
“standalone” mode. You can open any post-synthesis XST netlist in the Schematic Viewer
without first opening a project.
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Appendix A

Additional Resources

Xilinx Resources

ISE Design Suite: Installation and Licensing Guide (LIG798):
http:/ /www.xilinx.com/support/documentation/sw_manuals/xilinx13_1/iil.pdf

ISE Design Suite 13: Release Notes Guide (UG631):
http:/ /www.xilinx.com/support/documentation /sw_manuals/xilinx13_1/irn.pdf

Xilinx® Documentation:
http:/ /www.xilinx.com /support/documentation

Xilinx Global Glossary:
http:/ /www.xilinx.com/support/documentation/sw_manuals/glossary.pdf

Xilinx Support: http:/ /www.xilinx.com/support
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