I/0 Pin Planning Tutorial

PlanAhead Design Tool

This tutorial document was last validated using the following software version: ISE Design Suite 14.1

If using a later software version, there may be minor differences between the images and results shown in
this document with what you will see in the Design Suite.
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/0 Pin Planning Tutorial

This tutorial introduces the Xilinx® PlanAhead™ software capabilities and benefits when
performing I/O pin assignment for FPGA devices. It describes the procedure for creating and
assigning I/0 ports to physical package pins. The I/O Planning view environment enables you to
create, import, and configure the initial list of I/O ports. You can group the related ports into
Interfaces and then assign them to package pins.

The objective of this tutorial is to familiarize you with the I/O pin planning process using the I/O
Planning functionality in the PlanAhead tool. There are two parts to this tutorial that can be
performed independently. The first part briefly describes I/O planning capabilities prior to
having a synthesized netlist or RTL Sources with I/O ports defined. The second part describes
I/O planning functionality after synthesis. Most of the PlanAhead I/O planning features are
described in Part2. However, many of them are available at prior to running synthesis as well.

The capabilities include semi-automated interactive modes to allow controlled I/O port
assignment. Fully automatic pin placement is also available for some device architectures. The
I/O Planning view environment shows the relationship of the physical package pins and banks
with their corresponding I/O die pads. Intelligent decisions can be made to optimize the
connectivity between the PCB and the FGPA device.

You can perform I/O pin assignment at various stages of the design cycle. You can perform I/O

exploration and assignment with an I/O Planning project even before the design source files are
available. You can import a Comma Separated Value (CSV) format file for I/O planning, or export
it for use in PCB schematic symbol or Hardware Description Language (HDL) header generation.

The PlanAhead tool also enables you to I/O pin plan in the elaborated Register Transfer Level
(RTL) design or in the synthesized netlist design. The PlanAhead tool performs more
comprehensive I/O and clocking DRCs when using a netlist design.

Not all commands or command options are covered in this tutorial. This tutorial uses the
features contained in the PlanAhead tool, which is bundled as a part of ISE® Design Suite
version 14.1.

Software Requirements

The PlanAhead tool is installed with ISE Design Suite software. Before starting the tutorial, be
sure that the PlanAhead tool is operational, and that the tutorial design data is installed.
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For installation instructions and information, see the ISE Design Suite: Installation and Licensing
Guide (UG798) at http://www.xilinx.com/support/documentation/sw_manuals/xilinx14 1/iil.pdf.

Hardware Requirements

Xilinx recommends a minimum of 2 GB of RAM when using the PlanAhead tool on larger
devices. For this tutorial, a smaller xc7k70t design is used, and the number of designs open at
one time is limited. Although 1 GB is sufficient, it can impact performance.

Tutorial Design Description

The small sample design used in this tutorial includes:

e A RISC processor CPU core

e A pseudo FFT

e Four gigabit transceivers (GTs)

e Two USB interfaces

The design targets an xc7k70t device. A small design is used to:

e Allow the tutorial to be run with minimal hardware requirements
e Enable timely completion of the tutorials

e Minimize data size

Locating Tutorial Design Files

Copy the files from the ISE software installation area:

<ISE_install_area>/ISE_DS/PlanAhead/testcases/PlanAhead_Tutorial.zip

Extract the zip file contents into any write-accessible location.

The unzipped PlanAhead_Tutorial data directory is referred to in this tutorial as the
<Extract Dir>.

The tutorial sample design data is modified while performing this tutorial. A new copy of the
original PlanAhead_Tutorial data is required each time you run the tutorial.
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Part 1: Using I/O Pin Planning Projects (pre-synthesis)

The PlanAhead tool provides an I/O Pin Planning view layout that displays views more applicable
to placing I/O Ports and clock logic. You can open the I/O planning layout without a design to
analyze device resources.

These first few I/O Pin Planning steps involve pre-synthesis techniques to begin I/O Planning
early prior to a synthesized netlist. Most of the features are also available for an Elaborated RTL,
Synthesized or Implemented Design. I/O Pin Planning can be performed at any stage of the
design process. Post-synthesis I/O Planning enables a much more robust set of DRCs and clock
placement capabilities.

Step 1: Creating a New Project and Exploring the Views

1. Open the PlanAhead tool and create the project_pinout I/O Pin Planning project.

2. On Windows, double-click the Xilinx PlanAhead 14.1 Desktop icon, or select: Start >
All Programs > Xilinx Design Tools > ISE Design Suite 14.1 > PlanAhead >
PlanAhead.

3. On Linux, go to
<Extract_Dir>/PlanAhead_Tutorial/Tutorial_Created_Data directory and
type planAhead.

4. In the Getting Started page, select Create New Project.

5. Click Next to confirm the project creation and to display the Project Name dialog box.

[ New Project . P [—J&
Project Name
Enter @ name for your project and specify a directory where the project data files will be stored
Project name: | project_pinout
Project location: | C:\14.1_Tutorials\PlanAhead_Tutorial\Tutorial_Created_Data \:l
| Create Project Subdirectory
Project will be created at: C:\...\Tutorial_Created_Data\project_pinout
| < Back ” Mext = ] Finish Cancel
Figure 1: New Project Name and Location Dialog Box
I/O Pin Planning Tutorial www.xilinx.com 6
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6. Type the Project name, project_pinout.

7. Enter the Project location:
<Extract_Dir>/PlanAhead_Tutorial/Tutorial Created Data.

8. Click Next to open the Design Source dialog box.

9. Select I/0O Planning Project.

F |
[€] New Project - ﬁ
Project Type
Specify the type of project to create. (gﬂ.
- ETL Project
ou will be able to add sources, generate IP, run RTL analysis, synthesis, implementation, design planning
and analysis.

Do not specify sources at this time

= Post-synthesis Project
You will be able to add sources, view device resources, run design analysis, planning and implementation.

Enable Partial Reconfiguration

(@ I/O Planning Project
Do not specify design sources. You will be able to view part/package resources.

y Import ISE Place & Route results
~ You will be able to do post-implementation analysis of your design.

-y Imported Project
Create a PlanAhead project from a Synplify, XST or ISE Project File.

[ < Back ” Next = ] Finish

Figure 2: Specifying an 1/0 Pin Planning Project

10. Click Next to open the Import Ports dialog box.
11. Select Do not import I/O ports at this time.
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[€] New Project - S
Import Ports (optional)

You may specify a CSV, XDC, or UCF file to define and configure your ports. If you skip this step f@ﬁ
now, you can impaort ports later and/or create ports manually.

() Import CSV:

() Import UCF:

(@) Do not import 1/0 ports at this time

I l < Back ” Next > ] Finish

Figure 3: Import Ports from Existing UCF or CSV Files

12. Click Next to open the Default Part selector dialog box.

13. In the Filter section, click the Family pull down menu and select Kintex-7. Notice the list
is filtered to show those devices.

14. In the Search field, type 70T. Notice the 70T devices.
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.
f€] New Project

-——ﬂ

Default Part

Choose a default Xilinx part or board for your project. This can be changed later.

Reset All Filters

Search: | C- 70t

(10 matches)

Specify Filter

Product Category | All - Package All Remaining -

B Boards Family | Kintex-7 - | Speed Grade | All Remaining -
Sub-Family | All Remaining - | Temp Grade | All Remaining M

£ xc7k70tfbge76-2

676 300 fa1000 82000 fi35 240 f8 |

i Deui /O Fin Available  LUT — Block
evice Count I0Bs Elements Ipriops RAMs
@xc?k?ﬂtfbg‘%ﬁ‘}-l 484 283 41000 82000 135
@ xc7k70tfbg484-2 484 283 41000 82000 135
@xc?k?ﬂtfbg‘%ﬁ‘%—ﬂ 484 285 41000 82000 135
o S xc7k70tfbg484-3 484 285 41000 82000 135
@xc?k?ﬂtfbgﬁ?ﬁ-l 676 300 41000 82000 135

DSPs

240
240
240
240
240

Gh
Trans ||

[ NN

15.
16.

I/O Pin Planning Tutorial

& xc7k70tfbgb76-2L 676 300 41000 82000 135 240 8

& xc7k70tfbg676-3 676 300 41000 82000 135 240 8

& xc7k70tifbg434-2L 484 285 41000 82000 135 240 4

& xc7k70tifbg676-2L 676 300 41000 82000 135 240 8
< | T r O
[ < Back ][ Next = ] Finish

Figure 4: Selecting a Family and Default Part

Select the xc7k70tfbg676-2 device and click Next.

Click Finish to create the project.
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[&] project_pinout - [C:\14.LTutcna\S\P\anAlﬁdJutoria|\Tutor\'aLCreated,Data\project L pinout\project_pinoutppr] - PlanAhead 14.1 . — W =E0 X
. — —
File Edit Flow Tools Window Layout View Help
g2 8 & Q % | X & [3 170 Planning - | P &)
Flow Navigator «| | 1/0 Design - xc7k70tfbg676-2 X
Q= Netlist — O & % |[fPackage x|® Device x o x
=[E
Project Manager bl =
S0 (empty)
4 1f0 Design
(&) Migrate to RTL
““31 Import /O Ports
@ Report DRC
[ Report Noise
=% Export /O Ports
& Sources, [ Netlist

Properties [ I L

23

5 Properties | = Clock Regions

; Package Pins -0g x
A Hame Prohibit Port 1/OStd Dir Vcco  Bank  Bank Type Type Diff Pair  Clock Voltage Config XADC
! |5 & All Fins (676) .
23| [ 70 Bank 0 (De Dedicated
B B = I/0 Bank 1. Dedicated
I = B /O Bank 13 (H High Range
l Bl o /O Bank 14 (H: High Range =
EH-m» T/0 Bank 15 (Hi High Range
=} m» /O Bank 16 (Hi High Range
tan T/O Bank 32 (D Dedicated
= 1/0 Bank 33 (Hi High Perfo...
E A /0 Bank 34 (H High Perfo... -
L « 0 v O
[ 5 Td Console | © Messages |+ Package Pins | O- /O Ports
Figure 5: 1/0 Pin Planning Environment
17. Explore the various views in the I/O Planning layout. Many are empty because I/O Ports
are not yet defined.
18. Right-click on either the Device or Package view tabs to select New Vertical Group.

Notice that the Device and Package views are now both displayed. Being able to visualize
the I/O bank locations both internally on the die and externally on the package helps you
plan for an optimal I/O port assignment.

Step 2: Examining Device 1/0 Resources

The PlanAhead tool I/O pin planning environment lets you explore various device resources.

The different views graphically display and cross-select the location of various I/O, clock, and
logic objects to help you make I/O and device-related design decisions. The Package Pins view
and I/O Bank Properties view provide some 1I/O related information typically found in the device
data sheets.

Next, you:
e Select several I/O banks to show the package-to-die relationship
e View I/O bank properties

e Select and expand the I/O Bank 14 to view package pin specifications

I/O Pin Planning Tutorial www.xilinx.com 10
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Examining 1/O Banks

1. In the Package Pins view, select an I/O Bank such as I/0 Bank 33.

Notice that I/O Bank 33 is selected in the Device and Package views.

2. To select a bank in the Package view, double-click any pin from the I/O bank. The first
click selects the pin, and the second click selects the I/O bank in which that the pinis a
part of.

[§] project pinout - [CA141.T ials\Pla _zu, anTut '_Clcmlcd_mixu@mmmmwlpmf PlanAhead 14.1 — -_"—- [T ——
I-IL Lul Iu\v\ st Wrda'v L.:yUJl View HLp o N o - - © [Or search "
gFEeEmex &K LG Eyorasnng - W% D
Flow Nevigator “ 10 Deslgn  xe7kT0tbge7e 2 1
| flela"u_ - D0O& % ||#package = O& * |@Device = oa& *
ot ||
< 1/ 0 Design
©] Migrate to RTL
%! Import IO Ports.
D Report DRC
5 Report Noisy & Sources (M) Methet
# Export 'O Forts O Bank Properties .
* =+ %

s 1O Bank 33 (High Performance)
i HWame Frohdbit Port VOSW Dir W
B 1w
R_avia
General | Fort Summary | Package Pins | 10 Port 4 »

4 Propertles @ Clock Regions

Package Pins — O x

| Nome Frohibit Port VOStd  Dir Voo Gank  BankType  Type Diff Pair  Clock  Voltage  Config
fl = Y0 Bank 32 ed
mmlul_-__--”m _-__I
High Perfo... Multi-function
vn n High Perfa.... Liser 10 up
wil 33 High Perfo... User 10 5T
\ﬂ 33 High Perfo... User 10 P
;v vr 3 High Perfo... User IO LN
A wio 33 High Perfo... User 10 uP
I s we 33 High Perfo... User 10 [ED)
& ve 3 High Perfo... User 10 4P

I & Td Console | = Messages . 5 Package Pins | T V0 Ports

Figure 6: Cross Highlighting 1/Os and 1/0 Banks

An alternate method is to click the Package View Layers button I, located in the
Package View toolbar. Expand the I/O Banks, select any I/O Bank, right click it and
choose Select Objects.

The Layer Control can also be used to display specific Multi-Function Pins, such as Vref,
adjust the look of the Package view, highlight specific bank types, or hide transceiver
banks.

The selected I/O bank location is highlighted in the Package view.

3. Expand the selected I/0 Bank in the Package Pins view to display the package pin
information for each pin in the I/O Bank. The internal package trace min and max delays
are shown also (scroll the view to the right to see them). These are the routing delays
between the pin on the package and the pad on the die.

4, Scroll down the list and select any I/O Bank.

I/O Pin Planning Tutorial www.xilinx.com 11
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10.

11.

Select the General tab in the I/O Bank Properties view.

Review the I/O count and voltages. This information is populated as I/O Ports are
assigned to the I/O bank. This allows you to search for compatible I/O banks to place the
remaining I/O Ports.

Select the various tabs in the I/O Bank Properties view.

O

Click the Maximize button in the Package Pins view banner.

The Package Pins view is maximized.

Select the Expand All button = in the Package Pins view.

Scroll to the right and view the pin information in the table.

= o
Unselect the Group by I/0 Bank button | = in the Package Pins view to expand and
flatten the list.

Step 3: Prohibiting Pins from 1/O Assignment

You can prohibit I/O package pins from having I/O Ports assigned to them. In the following
sequence, you will sort the Package Pins view by Voltage to select all VREF I/O pins, then use the
Set Prohibits popup command to prohibit placement on those pins.

1.

i A W

o

Click the Voltage column header twice and scroll to the top of the list to locate the VREF
values.

Use the Shift key to select all VREF Voltage pins.
Right-click and select Set Prohibit.
In the Package Pins view header, click the Restore button &

The Package Pins view is restored. The Package view now displays prohibited pins.

In the main toolbar, click Unselect All \'“\\

Zoom in to an area of the Package view to view the Prohibited pins marked with red ®s,
as shown in the following figure. To zoom, click and drag a rectangle in the Package view
starting with a click at the upper left of the zoom area and drag to the lower right zoom
area.

I/O Pin Planning Tutorial www.xilinx.com 12
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m

Figure 7: Examining Prohibited VREF Package Pins

8. Zoom Fit the Package view. Click and drag the cursor from the lower right to the upper

left in a diagonal motion.

Step 4: Creating and Configuring 1/O Ports

In this step you will create and configuring a new I/O bus port called mybus.

1. Click the I/O Ports view tab.

2. Right-click in the I/O Ports view and select Create I/O Ports.

The Create I/O Ports dialog box opens.

I/O Pin Planning Tutorial
UG674 (v 14.1) May 8, 2012
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Create

Name: |mybus |

Direction:

Diff Pair: | |

Create Bus: From | []E| To | 31 E|

I/O Standard: | LVCMO5S18 ~|

Drive Strength: | default ~|

Slew Type: | SLOW (default) ~|

Pull Type: | NOME ~|

Input Termination Type: | NONE (default) ~|
[ ok || cancel |

1

Figure 8: Create I/O Ports

Note: The Configure I/O Ports command opens a similar dialog box that enables you to
configure existing I/O Ports.

3. Type mybus in the Name field.

4 Click the checkbox for Create Bus.

5. Select the default I/O Standard LWVCMOS18 from the drop down menu.
6 Review the other options and click OK.

The new I/O Ports display in the I/O Ports view.

1/0 Ports - O a =

C\ Marmne Direction  Meg Diff Pair  Sike  Fixed Bank  IjO Std Wecco o Wref Drive Strength Slew Type  Pull Type OFF-Chip T...  IN_TERM

=

- 1/0 Ports

Figure 9: Displaying Newly Added 1/0 Ports

7. Select Edit > Undo to remove the recently added mybus I/O ports.
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Step 5: Importing an 1/O Port List

The PlanAhead tool can import a variety of file formats to begin the I/O pin planning process.
You can import CSV, UCF, or RTL format files and perform I/O pin exploration and assignments.
You can also create I/O Ports interactively, which was covered in the last step.

Use care with early input methods for I/O pin planning. Without a synthesized netlist, the I/O
Ports placement and DRC routines do not take clocks, clock relationships, or GT logic into
account in their calculations. When possible, perform 1/0 pin assignment after importing a
synthesized netlist. Legal I/O pinouts are guaranteed only after the design has run through the
ISE implementation tools, and after DRCs for I/O and clock placement are run without error.

Importing and Examining the CSV Format I/O Port List

1. In Windows Explorer, open the following I/O Ports CSV file:
<Extract_Dir>/PlanAhead_Tutorial/Sources/10_Ports_import.csv

2. Examine the I/O ports spreadsheet format and content, and exit without saving.

3. In the PlanAhead tool environment, select Import I/O Ports from the Flow Navigator,

located on the left side.

4. Select CSV File and browse to select:

<Extract_Dir>/PlanAhead_Tutorial/Sources/10_Ports_import.csv
5. Click OK.

The Device and Package views display the assigned Ports, and the I/O Ports view is now
populated with the imported I/O Ports, as shown in the following figure. If you are going
to import a CSV file, do this before defining ports with the Create I/O Ports command
because they will be overwritten.

1/0 Ports = 0O o x
“A| Name Direction  Meg Diff Pair  Site  Fixed Bank I/O Std Veeo  Vref  Drive Strength  Slew Type  Pull Type  Off-Chip Termination  IN_TERP
X2 Al ports (135) A
= -3 Dataln_pad_0_i (8)  Input LVCMOS18 1.8 12 SLOW NONE NONE
ke -3 Dataln_pad_1_i (8) Input LVCMOS518 1.8 12 SLOW NOME NOME
- -3 DataOut_pad 0 o (8) Output LVEMOS18 1.8 12 sLowW FP_VTT_50 NONE
O @ DataOut_pad_1_o (8) Output LVEMOS18 1.8 12 SLOW FP_VTT_S0 NOME | _
I -3 LineState_pad_0_i (2) Input LYCMOS518 1.8 12 SLOW NOMNE NOME |=
-3 LineState_pad_1_i (2) Input LYCMOS18 1.8 12 SLOW NOME NOME
E -4 OpMode_pad_0_o (2) Output LVEMOS18 1.8 12 sLowW FP_VTT_50 NONE
@ OpMode_pad_1_o (2) Output LVEMOS18 1.8 12 SLOW FP_VTT_S0 NONE
-3 or1200_pm_out (4) Output LYCMOS518 1.8 12 SLOW FP_VTT_50 NONE
-2 RXP_IN (16) Input RXN_IN DIFF_HSTL... SLOW NOME NOME
- TXP_OUT (16) Output TXN_OUT DIFF_HSTL... 1.8 SLOW NP_WVTT_50_FP_VTT... NOME
Q) vControl_pad_0_o (4) Output LVYCMOS518 1.8 12 5LOW FP_VTT_50 NOME é‘
< 1 »

2 Tcl Console | © Messages | 5 Package Pins- [+ I/ O Ports

Figure 10: 1/0 Bus Ports are Grouped by Bus

The buses are grouped together and are expandable.
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Step 6: Exporting the Device and 1/0 Pin Assignments

You can export the I/O Port assignments to UCF, CSV, VHDL or Verilog format files. This is useful
for creating HDL headers and PCB schematic symbols. The CSV format output file contains
package information for all pins, which can be used to begin I/O Port assignments.

Exporting the I/O Ports List Using the Export I/O Ports Command

1. Select File > Export > Export I/O Ports.
2. Select CSV, UCF, Verilog, and VHDL in the Export I/O Ports dialog box.

Specify Types to Generate
csvy C:\14.1_Tutorials\PlanAhead_Tutorial\Tutorial_Created_Data\project_pinout\jio_1.csv

UCF C:\14.1_Tutorials\PlanAhead_Tutorial\Tutorial_Created_Data\project_pinout\io_1.ucf

Verilog C:\14.1_Tutorials\PlanAhead_Tutorial\Tutorial_Created_Data‘\project_pinout\project_pinout.v

WHDL | C:\14.1_Tutorials\PlanAhead_Tutorial\Tutorial_Created_Data\project_pinout\project_pinout.vhd

ojojoja

’ OK l I Cancel

Figure 11: Exporting I/O Ports to a CSV Spreadsheet and UCF File

3. Click OK to accept the default file names and locations.
4. Open an Explorer window and browse to, and open the exported files located in:
<Extract_Dir>/PlanAhead_Tutorial/Tutorial_Created_Data/project_pinout

If defined, the Interface group names are included in the spreadsheet. Printed circuit
board designers can use this spreadsheet to create Interface-specific schematic symbols.
Creating I/O Port Interfaces is covered in an upcoming step.

Step 7: Migrating the I/0O Planning Project to an RTL Project

You can migrate the I/O Port assignments made in I/O Planning Projects to an RTL Project. This
enables additional Sources to be added and a path through to implementation. The I/O Port
assignments and names will be translated into an RTL header and UCF Source files in an RTL
Project.

Note: Once you migrate an I/O Planning Project to an RTL Project, you cannot go back to the
original I/O Project.

1. Select Migrate to RTL in the Flow Navigator.
The Migrate to RTL dialog box appears.
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f€] Migrate To RTL

[0} Migrate the current Pin Planning Project into an RTL Project. The conversion
"= cannot be undone.

Top RTL file nAhead Tutorial\Tutorial_Created Data\project_pinoutiio_1. E]

Metlist format Verilog -
Write diff buffers

0K ] [ Cancel

Figure 12: Migrating an 1/0O Planning Project to an RTL Project

2. Click OK to accept the default file names and locations.
3. Notice the RTL Project is now displayed. The Sources view contains the newly created
source files.

Closing the Newly Created RTL Project

4. Select File > Close Project.
5. Click OK in the Confirm Close Project dialog box.
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Part 2: 1/0 Planning Features using a Synthesized Design

Many of the features presented in this tutorial are available in several places during the design
flow. As Part 1 describes, an I/O Planning Project can begin the I/O assignment process well
before any RTL or synthesized netlist is available. In RTL Projects, I/O Planning can also be
performed pre-synthesis by opening the elaborated RTL design. The most comprehensive set of
features and DRCs are available after synthesis by opening the synthesized design.

The I/O Planning features provide several ways to analyze, group and place the I/O ports onto
package pins or the I/O die pads.

For control over I/O port placement, you can drag the selected I/O Ports into the Package or
Device views interactively using one of the following semi-automatic placement modes:

e Place I/O Ports in an I/O Bank
e PlaceI/O Ports in an Area
e Place I/O Ports Sequentially

In addition, the I/O Planning features enables you to toggle DRCs on and off during I/O
placement.

Step 8: Opening the Synthesized Netlist-Based Project

1. Click the Open Project link in the Getting Started view, or select File > Open Project.

2. Browse to select the following project file:

<Extract Dir>/PlanAhead_Tutorial/Projects/project _cpu_netlist/project c
pu_netlist.ppr

Alternately, select Open Example Project > CPU (Synthesized) from the Getting
Started page. If needed, use File > Save Project As... to save a local writeable copy of
the project at <Extract_Dir>/PlanAhead_Tutorial/Tutorial_Created_Data

3. In the Sources view, expand the Constraints constr_1 folder and double-click on the
top.ucf file.

Notice this UCF file only contains timing constraints and no I/Os yet.
Close the top.ucf file.

Select the constr_1 folder and right-click to select Make Active.

N o uos

Select Open Synthesized Design in the Flow Navigator to open the synthesized design.
Alternately, you can select Flow > Open Synthesized Design from the main menu.
8. From the Layout pull-down located in the main toolbar, select I/O Planning.

9. The I/0 Planning view layout displays.
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Step 9: Examining the 1/O Ports in the Design

10. In the I/O Ports view banner, click the Maximize View button &,
11. Click Expand All = in the I/O Ports view.

12. In the I/O Ports view, click to unselect Group by Interface and Bus =
13. Scroll down the list of buses and signals.

The I/O Ports now display as a flat list rather than grouped by bus.

I/ Parts — O b

Q Id  Mame Direction  Interface  MNegDiff Pair  Site  Fixed  Bank  [jOStd Woco o Vref Drive Strength Slew Type  Pull Type  OFf-Chip Termination
Cr 43 orl200_pic_nks Input default (LWCMOS1E) 1.8 12 SLOW NOME NONE A
O 44 or1200_pm_out[0] Cubput default (LWCMOS1E) 1.8 12 SLOW NONE FP_YTT_50

o |G s ort200_em_outl1] Cubput default (LWCMOS1E) 1.8 12 SLOW NOME FP_YTT_S0

E10 46 orl200_pm_out(z] Output default (LWCMOS1E) 1.8 12 SLOW MONE FP_YTT_50

= < 47 or1200_pm_out[3] Cutpuk default (LYCMOS18) 1.8 12 Lo MOME FP_YTT_S0

ron|®d 48 phy_rst_pad_0_o Oukput default (LYCMOS18) 1.8 12 SLOW MONE FP_YTT_50

U0 49 phy_rst_pad_1 o Oukput default (LYCMOS18) 1.8 12 SLOW MONE FP_YTT_50

[E]|Cr 50 reset Input default (LYCMOS18) 1.8 12 SLOW HOME HOMNE £
[ 51 RuxActive_pad_0_i Input default (LYCMOS18) 1.8 12 SLOW HOME HOME
Cr 52 RxActive_pad_1_ Input default (LWCMOS1E) 1.8 12 SLOW NONE NONE
Or 53 RxErrar_pad_0_ Tnput default (LYCMOS1E) 1.8 12 SLOW NONE NONE
O+ 54 RuError_pad_1_ Tnput default (LWCMOS1E) 1.8 12 SLOW NOME NONE
O 55 REP_IN[O] Input RM_IN[O]
[ 56 R¥P_IN[1] Input RM_IN[1]
O 57 ReP_IN[Z] Input FeM_IN[Z]
O 5@ ReP_IN[3] Input P _IN[3]
O 59 REP_IN[4] Input Fe_IN[4] -
4 T v 3
B Tel Canscle | & Messages | B3 Compilation | (3 Reports | [% Design Runs | 5 Package Pins - [ I/0 Ports

Figure 13: Examining 1/O Standard and Diff Pair Requirements

The Neg Diff Pair fields are populated for some of the buses indicating that they are
differential pair buses.

Step 10: Configuring 1/0s and Setting 1/O Standards
PlanAhead can be used to interactively sort and select I/O Ports to assign the proper I/O
standard, drive strength, slew type, pull type and input termination constraints.

Note: For 7-Series devices, all /O Ports must have explicit values for the IOSTANDARD
constraint in order to generate a bitstream file. The word “default” is displayed in red to indicate
that these values must be applied manually. The reason for this is that 7-Series devices have low
and high voltage I/O Banks and extra care must be applied when assigning I/O standards.

Setting the /O Standard Constraints

1. Click on the Neg Diff Pair column header to sort by diff pair port type.

2. Scroll to the top of the list and you should see no Neg Diff Pair ports, select the first port.
3. Use the Shift key and scroll to select all I/O Ports that are not diff pair ports.
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IfO Porks — O o =

1
Id  Mame Direction  Interface  Meg Diff Pair  Site  Fixed | Bank | Ifo skd Weeo o Wref Drive Strength Slew Type  Pull Type  OFF-Chip Termination

o 9% RXH_IN[O]

O 97 Ry Input Rk_IN[1]
™ =
4

am ovo TME?T Trraik OvRTRERT

i b @J

Tl Consale LD Messages LH Compilation L}] Reparks Llﬁ, Design Runs LS) Package Pins~, [ I/0 Ports ]

Figure 14: All Single Ended Ports Selected

4. Right-click and select Configure 1/0 Ports.

Notice the various drop-down menus to set I/O Configuration constraints. The I/O
standard field displays the default value.

5. Click in the I/0 Standard drop-down menu to scroll to select LWVCMOS18 and click OK.
Notice the I/O Std column entries are now set to LVCMOS18.

The Neg Diff Pair signals are associated with GT pins, so an I/O standard is not
applicable. Once these Ports are placed on GT pins, these fields will be empty.

Step 11: Creating 1/O Port Interfaces

It can be beneficial to group I/O Ports associated with various 1/O interfaces. The I/O Planning
layout lets you define groups of pins, buses or other interfaces together as an “Interface.” This
ability helps with I/O Port management and with generating interface-specific PCB schematic
symbols. It also forces the I/O Port automatic placement command to group the entire interface
together on the device (where possible).

Creating Interfaces for Similar I/O Port Groups

The design used in this tutorial has two USB interfaces, each containing many I/O ports. The I/O
port names are differentiated by _0_and _1_. You will create Interfaces for all signals in USBO
and USB1.

1. Click the Show Search button q*| in the I/O Ports view.
2. Type _0_ in the Search field.
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I/O Ports
< Search: _0_ (43 matches
_
Z Id MName Direction Interface |
= |# 1 Dataln_pad_0_i[0] Input
= - 2 DataIn_pad_0_i[1] Input
) & 3 DataIn_pad_0_i[2] Input
pary| B2 4 Dataln_pad_0_i[3] Input
% 5 Dataln_pad_0_i[4] Input
¥ 6 Dataln_pad_0_i[5] Input
[ 7 DataIn_pad_0_i[6] Input
[ 8 DataIn_pad_0_i[7] Input
< 9 DataOut_pad_0_o[0] Output
<4 10 DataOut_pad_0_o[1] Output
<4 11 DataOut_pad_0_o[2] Output
<4 12 DataOut_pad_0_o[3] Output
Lo 12 Natamit nad 0 nl41 Mt

Figure 15: Selecting USB_0_ Related Ports

3. Select one of the ports in the filtered list.
4, Press Ctrl+A to select all ports in the filtered list.
5. Right-click and select Create I/O Port Interface....
The Create I/O Port Interface dialog box opens.
6. Type USBO in the Name field.
[#] Create I/O Port Interface A &J
Create a new I/O Port interface for project 'project_c...
Name: USBO
. [] Assign 6 selected I/O port buses to the new interface.
[¥/] Assign 11 selected I/O ports to the new interface.
[ oK ] [ Cancel ]
Figure 16: Create 1/0O Port Interface
7. Click OK.
8. In the Search field, change _0_to _1_and follow the same steps to create a USB1 I/O
Port Interface.
9. Click the Show Search button “» to remove the Search filter.
= ==
10. Click the Group by Interface and Bus =, and the Collapse All == buttons.
The I/O ports list is condensed with all of the USB related ports in Interface groups.
I/O Pin Planning Tutorial www.xilinx.com 21

UG674 (v 14.1) May 8, 2012


http://www.xilinx.com/

v
i. X"-lNX Part 2: 1/0 Planning Features using a Synthesized Design

11. Expand the Scalar ports folder to view the clocks resets and other ports.

12. Click the Restore button & in the view banner.

The I/O Ports view is restored to the original location, shown in the following figure.

IfO Ports - 0O g =
A | Mame Direction  Meq Diff Pair  Sike  Fixed Bank I/ Std Veco Wref Drive Strength Slew Type  Pull Type  OFF-Chip T...  IN_TERM
| =+ all ports (135) -
wa| B UsBO43) (Multiple) LYCMOS18 1.8 12 SLOW HONE (Multiple)
;_:: + o UsB1 (43) {Multiple) LVCMOS18 1.8 12 SLOW MNOME {Mulkiple)
= @4 or1200_pm_... Output LYCMOS18 18 12 SLOW NONE FP_YTT_50
3| BB REPINGE) Input RAN_IN
H-43 THP_OUT (18} Output  THN_OUT
= = [ Scalar porks (13}
E -~ [» GTPRESE... Input LWCMOS1E 1.8 12 SLOW MOME MOME £
[ orl200_c... Input LWZMOS1E 1.8 12 SLOW MOKE MOKE
- [Or or1200_p... Input LWCMOS1E 1.8 12 SLOW NOME NOME
Cr reset Inpuk LMCMOS1E 1.8 12 SLOW MOMNE MOMNE
= Or sysClk Input LVCMOS18 1.8 12 SLOW NOME NOME

[ TILEO_RE... Input TILEO_REFCL...
-~ [Or TILE1_RE... Input TILE1_REFCL...
[ TILEZ_RE... Input TILEZ_REFCL... -
-+ Cr TILE3_RE... Input TILE3_REFCL... ol

= Tel Console | (O Messages | i Compilation | [5) Reports | % Design Runs | 3 Package Pins - Cr I/0 Ports

Figure 17: Viewing I/O Port Interface Groups and Scalar Ports

Step 12: Viewing Multi-function Package Pins

Some Xilinx devices have a set of package pins that can be used for a variety of purposes
depending on the design configuration. These are referred to as Multi-function pins. The mode
in which you intend to configure the device or the use of memory controllers or a PCI interface
can require use of some of these pins. The Package Pins view can be examined to ensure that no
conflicts exist. In this step you will view the package pins data and multi-functional pins.

1. Click the Package Pins view tab.

2. In the Package Pins view banner, click the Maximize View button H.

3. Click Expand All = in the Package Pins view

4. Scroll down and to the right to examine the pins information such as Bank Type, Clock,

Voltage, Config, and Site Type. The information displayed in the Package Pins view is
dynamically updated as I/O Ports are placed in the design.

5. In the Package Pins view, click to unselect Group by 1/0 Bank ]

The Package Pins now display as a flat list rather than grouped by I/O Bank.

6. Click the Type column header to sort based on the Type field.
7. Scroll to view the Multi-function pins
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Package Pins

- e
b Id MName Prohibit Port IO Std Dir Vcco Bank  Bank Type  Type ' Diff Pair Clock Voltage Config
Z &2 LOD WEL NUNE L
e | 5 187 YO NOME GMND
| B 188 Y19 NOME GND
P & 189 P25 [ 13 High Range Multi-function L&6M VREF
5190 F23 L] 13 High Range Multi-function L11P SRCC
£ 191 N23 [ 13 High Range Multi-function L11N SRCC
192 N21 L] 13 High Range Multi-function L12P MRCC
£ 193 N22 [ 13 High Range Multi-function L12N MRCC
S 194 R21 L] 13 High Range Multi-function L13P MRCC
£ 195 P21 [ 13 High Range Multi-function L13N MRCC
5 196 R22 L] 13 High Range Multi-function L14P SRCC
B 197 R23 [ 13 High Range Multi-function L14M SRCC
198 T19 L] 13 High Range Multi-function L19N VREF
£ 109 B24 [ 14  High Range Multi-function L1P
5200 A25 L] 14  High Range Multi-function L1N
£ 201 B22 [ 14  High Range Multi-function L2P
2202 A2 L] 14  High Range Multi-function L2N
£ 203 B25 [ 14  High Range Multi-function L3P PUD...
5 204 B26 L] 14  High Range Multi-function L3N
£ 205 A23 [ 14  High Range Multi-function L4P
206 A24 L] 14  High Range Multi-function L4N
£ 207 D26 I 14  High Range Multi-function L5P
< | (1]

2 Tcl Console | © Messages | Bl Compilation | (21 Reports | % Design Runs-_ > Package Pins | C- I/0 Forts

Figure 18: Viewing Multi-Function Pins

8. Examine the following columns:
¢ Device Configuration pins (Config)
o XADC
e Gigabit1/O

These logic objects can impact I/0O assignment because many of them rely on multi-
function pins and have fixed I/0O requirements. If the design used in this tutorial
contained these logic objects, this table would be filled out accordingly, allowing you to
examine multi-function pins.

Restore the Package Pins view.

9. In the Package Pins view, click the Group by I/O Bank button E?E.

10. Click Collapse All = to return the tree table display to the default display structure.

Note: The PlanAhead tool has several tree table style views. There are search and filtering
capabilities available in these views. See “Using Tree Table Style Views" in the Using the Viewing
Environment chapter of the PlanAhead User Guide (UG632 )for more information.
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Step 13: Setting Device Configuration Modes

In the PlanAhead tool you can set one or more device configuration options. Some
configuration modes can have an impact on multi-function I/O pins also. The related pins
display this information in the Config column of the Package Pins view.

1. Select Tools > I/O Planning > Set Configuration Modes.... The Set Configuration
Modes dialog box opens.

f€] set Configuration Modes ﬁ

[] master SPTx1 JTAG/Boundary Scan
[] Master SPIx2

The JTAG configuration mode allows the device to be configured through the JTAG port. This is often

[] Master SPI x4 used with board testers, for debug, and for indirectly programming SPI flash or parallel NOR flash

|:| Master Serial connected to the FPGA configuration port. The Xilinx download cables and the ChipScope Pro tool use

[ slave serial the TTAG configuration mode. Supporting this mode for debug is recommended even if another mode will
be used by the production design.

[] master BPI-Up x8

[] Master BPI-Up x16 For more detail on this configuration mode. see the Kintex-7 Configuration User Guide.

[ slave SelectMap x8

I:‘ Slave SelectMap x16
|:| Slave SelectMap x32
JTAG/Boundary Scan

[] master SelectMap x8 JTAG Header

|:| Master SelectMap x16 7 Series FPGA
TDO TDO
TDI TDI
™S ™S
TCK TCK

Device
UGSTD ¢3_02 061710
i "Select Al || clear al
Figure 19: Selecting Device Configuration Modes
2. In the Set Configuration Modes dialog box, select one or two of the other modes to

view the descriptions, schematics, and related data sheets.
3. Leave it set on JTAG/Boundary Scan and click Cancel.

Setting a Configuration Mode results in the pins associated with it to be displayed at the
top of the Package Pins view allowing you to examine potential multi-function pin
conflicts.

I/O Pin Planning Tutorial www.xilinx.com 24
UG674 (v 14.1) May 8, 2012


http://www.xilinx.com/

v
i. X"—l er Part 2: 1/O Planning Features using a Synthesized Design

Step 14: Defining Alternate Compatible Devices

During the FPGA design process, you can change the target device when a design decision calls
for a larger or different type. The PlanAhead tool lets you define alternate compatible devices
up-front so I/O assignments can work across the selected set of devices. This capability is
typically limited to devices that use a common package.

This step ensures that the I/O pinouts work across the selected set of devices.
1. Select Tools > I/O Planning > Set Part Compatibility....
The Set Part Compatibility dialog box opens.

"] Add and/or remove PROHIBIT constraints to
" package pins such that the device is compatible
with all selected parts.

Compatible Parts

[ |8 xc7k160tfbg676
[ xc7K160tffg676
[ @ xc7k325tfbg676
[ |8 xc7k325tifg676
[ xc7ka10tfbgs76
[ xc7k410tffg676

0K

Figure 20: Defining Compatible Parts

2. Select the top xc7k160tfbg676 device.
3. Click OK.
4. In the confirmation dialog box, click OK to indicate that no Prohibits were placed.

The Prohibits are assigned based on the most restrictive parts. In this example you are
targeting the smallest device for this package, so no prohibits are placed.

Step 15: Placing I/O Ports

The PlanAhead tool provides several ways to place the I/O Ports onto either package pins or I/O
die pads. The automatic placement command tries to place the entire selected group of I/O
Ports, adhering to I/O bank rules while grouping buses and Interfaces together.

By default, the PlanAhead tool uses interactive Design Rule Checks (DRCs) during I/O placement.
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For more control over I/O port placement, you can drag the selected I/O Ports into the Package
or Device views using one of the following semi-automatic placement modes:

e Place I/O Ports in an I/O Bank
e Place I/O Ports in an Area

e Place I/O Ports Sequentially

Placing the USBO Port Interface using Place Ports in an I/O Bank

1. In the I/O Ports view, select the USBO Interface.

2. In the Package view, click to expand the Place Ports button ”t?;
3. Select Place 1I/0 Ports in an I/0 Bank.

As you drag the cursor over the Package Pins, the assignment pattern displays the
number of pins to be placed shows in the tooltip.

The Information bar at the bottom of the PlanAhead tool displays information about the
objects being dragged over, including I/O Banks and Package Pins.

Synthesized Design * - constrs_1 | xc7k70tfhg676-2 (active) X
Netlist -0 g x @ Device x Og = [ Package x Og =
= Hl|E] kil

top -

&

)

+-[@ clkgen = [ @

- [4] cpuEngine ( T a;

- [T fftEngine (f =

[ mgtEngine Lk

F-[4] usbEnginen -l &

EH-[E usbEnginel (usbf_top_usbEnginel)

L e ol |

£

& Sources, Gl Netlist

v
&

@

I/O Port Interface Properties - 0O g x
++HELEE+
o USBO

3k 3= | P 5

5
i

Name: USBO
Number of Ports: 43

[

General | /O Ports

& Properties | @ Clock Regions

1/0 Ports — O g %
@, Name Direction Neg Diff Pair Site Fixed Bank I/O Std Veeo  Vref  Drive Strength  Slew Type  Pull Type  Off-Chip Termination  IN_
=

B + @ USB1 (43) (Multiple) LVCMOS18 1.8 12 sLow (Multiple) O

+€ 0rl200_pm_out (4) Output LVCMOS18 1.8 12 sLow FP_VTT_50 NOM

Figure 21: Place I/O Ports in an 1/O Bank

4. Click I/0 Bank 14 on the top, right side of the package to drop the 1/O Ports.

The 1/O Ports are assigned in the order in which they appear in the I/O Ports view.
Assignment locations are vectored out from the initial pin selected.
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Placing the USB1 I/O Port Interface using Place Ports in Area

5 In the Device view, zoom in to the upper half of the device.
6. In the I/O Ports view, select the USB1 Interface.
7. In the Device view, click to expand the Place Ports button #

8. Select Place 1/0 Ports in Area.
The cursor displays a cross indicating that you can draw a rectangle.

9. Draw a rectangle starting at the bottom of the first I/O bank in the top half of the device
and drag it up and to the right until all /O Ports are placed in the rectangle within the
top clock region.

i Device x Oa

Figure 22: Placing USB1 1/O Ports in an Area

Placing the RXP_IN Differential Pair Bus

10. Select the RXP_IN bus in the I/O Ports view.

11. In the Device view, click to expand the Place Ports button 4|
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12. Select Place 1/0 Ports Sequentially.

13. Drag and click to place the first diff pair I/O Port into one of the GT I/O Banks on a
designated pin. (Hint: the GT banks are the two upper left ones.)

ZERARY A

>
=

R | &

r
v

Figure 23: Placing Diff Pair I/O Bus Ports Sequentially

Both diff pairs associated with the GTs were placed on legal sites. You might see a tool
tip indicating that the selected site is not legal and stating why it is not legal.

You can manually enter a pin location in the Site field in the I/O Port Properties view.

After placing the first set of GT diff pair pins, PlanAhead queues up the next group of
pins to place.

14. Place all 8 RXP_IN GT Port groups in the two upper left I/O Banks. The cursor Tooltips will
help guide you to legal pin selections to place the I/O Banks.

Note: GT logic objects are automatically grouped by PlanAhead to ensure proper behavior when
I/O Ports are placed or moved. Both sets of Diff Pair I/O Ports as well as the GT itself are all
placed and moved as a group.

Removing the Split Workspace View for the Device and Package Views

Now that the I/O Ports are placed, the Package view is no longer needed to share the
Workspace view. The split view can be removed easily. To remove the split view:

15. Right-click on the Package or Device view tab to select Move to Previous Tab Group.
16. Select the Device view tab to bring it to the front.

17.  Adjust the view size, and Zoom fit the view, if needed.
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Step 16: Placing Clock Logic

The PlanAhead tool lets you place critical clock or I/O related logic. After a synthesized netlist is
imported, clocks and clock relationships can be explored and used to lock down these logic
objects onto specific device sites. The PlanAhead tool automatically groups some logic, such as
GTs and their associated I/O pin pairs. This makes selection and placement of GTs and other
related logic less prone to errors.

Searching for the Global Clock Logic in the Design

1. Click the Find button @ or select Edit > Find.
The Find dialog box opens.

2. Adjust the selection filters to match the following figure (Type is Clock).
f€] Find
Find | Instances -
Criteria
Tyoe ~1[is : -

[ ] match Case
Open in a new tab

[ DK ] [ Cancel

Figure 24: Using Find to Search for Clock Logic

3. Click OK.

The Find Results view opens.
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Find Results - Instances - Type is 'Clock' (14)
Q,

3 Id MName Cell Instance Pins

i @1 mgtEngine/gt_usrclk_source/bufg_inst BUFG 2

@ /|[@ 2  ckgen/ckf_buf BUFG 2
[ e clkinl_buf IBUFG 2
[i4  clkgen/clkoutl_buf BUFG 2
[ 5 clkgen/clkout2_buf BUFG 2
16  clkgen/clkout3_buf BUFG 2
[l 7 clkgen/clkout4_buf BUFG 2
e ckgen/clkout5_buf BUFG 2
[l 9 clkgen/clkouts_buf BUFG 2
[l 10 clkgen/mmcm_adv_inst MMCMEZ_ADV 69
@l 11 mgtEnglne,-fgt usrclk _source/txoutclk_bufg0_i BUFG 2
040 = i S, e . [T | I ha '}

Instances - Type is 'Cbl:k' (14) =
& Tcl Console | © Messages | B Compilation | 2 Reports-. ¥ Find Results | % D

Figure 25: Viewing the Clock Objects Found

4. Scroll down the list of objects, and observe the following:
e BUFG
e MMCME2_ADV

Step 17: Using the Schematic to Trace Clock Logic

The Schematic view can be used to expand and explore any logic in the design. Placement
constraints can be applied from the Schematic view.

1. In the Find Result view, select the first MMCME2_ADV Cell.

Find Results - Instances - Type is 'Clock’ {14)

A Id  Mame Cell Instance Pins
S0 2 ckgenfdkf_buf BUFG 2
,@r kil 3 dkin1_buf I[BUFG 2
G 4 dkogen/dkout1_buf BUFG 2
Ll 5 dkaen/dkout2_buf BUFG 2
@ s dkogen/dkout3_buf BUFG 2
@l 7 dkaen/dkout4_buf BUFG 2
@ s dkgen/dkout5_buf BUFG z
[ dkaen/fdkouts_buf BUFG 2
1 e S =)
[i] 11  mgtEnginefgt_usrdk_source/twoutdk_bufgl_i BUFG
i mntErminedat uerslls emnres Memodell bofad 0@ BLIES 2

Instances - Type is "Clock” {14) =
=) Td Consale | O Messages | Bd Compilation | [2 Reports- off Find Results | %

Figure 26: Selecting Clock Logic to Trace in the Schematic

2. In the Find Results view, click the Schematic button fr'ﬂ.
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3. In the Schematic view, double-click the CLKIN1 input port on the upper left of MCM

module
4. Double-click to expand the CLKFBIN input pin on the MCM module.
5. Double-click on the 5 MCM output pins CLKOUT1-5 to expand the BUFGs.
6. Clean up the connections by clicking the Regenerate Schematic button in the
Schematic view ..
i Package x | @ Device x |!# Schematic x Oo X
->|] 9 Instances 9 Mets
+ clkgen n
-]
o mmecm_ady_inst
| CLKFBOUT |-
SN
clkf_buf CLKFBOUTE [~
ey ' ! CLKFEIN  CLKFBSTOPFED|— clkout?_buf
[5 clkind _buf BUFG —|CLKINSEL CLKINSTOPPED |—
—'|>'3 sy CLKINA CLKOUTO BUFG
= IBUFG —CLKINZ CLKOUTOR clkout3_but
e DADDRS:0] CLKOUTA | o
T DOLK CLKOUT1B -
— DEN CLKOUTZ
DI[15:0] CLKOUTZB | clkoutd_huf
DUVE CLKOUTS 4'|>E
PSCLK CLKOUTZE - BUFG
PSEN CLKOUTS clkouts._but
PSINCDEC CLKOUTS | 0
P PR N CLKOUTE -
- BUFG
& —RsT Co[1s:0]
DROY clkout_huf
LOCKED -
PSDONE |- BUFG
MMCMEZ_ADY
clock_generatar L
4 3

Figure 27: Exploring Clock Logic Connectivity

You can easily expand and explore logic in the Schematic view. Select or highlight logic
in the Schematic view to cross-select or highlights it in all other views.

You can also drag logic directly out of the Schematic for placement into the Device,
Package or Clock Resources view.

7. Close the Schematic view tab.
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Step 18: Exploring the Clock Resources View

1. In the Workspace, select the Clock Resources view tab.
2. If no view tab exists, select Window > Clock Resources to display the view.
3. Click the Maximize Workspace button U in the view banner to display the view full
screen.
4. Scroll around and examine the Clock Resources view.
[ Package x| @ Device x B2 Clock Resources x San
N = xc7k7otfbg676-2 i
5
el = Top Half
g
= 3 Clock Region X0Y3 = Global Buffers @ Y=3 = Clock Region X1Y3
=1||| =) = I/O Bank 16 (High Range) =l 1/O Bank 36 (Unbonded) =l GT Bank 116
Site Instance Site Instance
BUFR_X0Y15 GTXE2_CHANMNEL_X0Y7 lill ghxe2_i (GTXE2_CHANMEL) | =
BUFR_X0Y14 GTXE2_CHANNEL_X0Y6 kil gtxe2_i (GTXEZJZHANNEL] B
BUFR_X0Y13 GTXE2_COMMON_X0Y1
BUFR_X0Y12 GTXE2_CHANNEL_X0YS [l ghe2_i (GTXE2_CHANMEL)
BUFIO_X0Y15 GTXE2_CHANNEL_X0Y4 lill gbxe2_i (GTXE2_CHANMEL)
BUFIO_X0Y14 A4XTXP3 kil TXP_OUT_4_0OBUF (OEUF]
BUFIO_X0Y13 B6:XRXP3 kil RXP_IN_4_IBUF (IBUF)
BUFIO_X0Y12 AJXTXN3 [l TXN_OUT_4_OBUF (OBUF)
IDELAYCTRL_X0Y3 B5:XRXN3 kil RXN_IN_4_IBUF (IEUF]
BUFMRCE_X0Y6 B2:XTXP2 kil TXP_OUT_3_OBUF (OEUF]
BUFMRCE_X0Y7 C4:XRXP2 [l RXP_IN_3_IBUF (IBUF)
PLLE2_ADV_X0Y3 B1:XTXN2 [l TXN_OUT_3_OBUF (OBUF)
MMCME2_ADV_X0Y3 D6:REFCLKOP
G11:SRCC C3:XRXN2 kil RXN_IN_3_IBUF (IELIF]
10:5RCC D5:REFCLKON
10:MRCC F5:REFCLK1N
10:MRCC F6:REFCLK1P
12:MRCC D2:XTXP1 kil TXP_OUT_0_OBUF (OEUF]
11:MRCC E4:XRXP1 [l RXP_IN_0_IBUF (IBUF)
E11:SRCC D1:XTXN1 [l TXN_OUT_0_OBUF (OBUF)
D11:SRCC E3:XRXN1 kil RXN_IN_0_IBUF (IEUF]
F2:XTXP0 kil TXP_OUT_1_OBUF (OEUF]
G4:XRXPO (il RXP_TN_1_IBUF (IBUF)
F1:XTXNO [l TXN_OUT_1_OBUF (OBUF)
G3:XRXNO [l RXN_IN_1_IBUF (IBUF)

Figure 28: Viewing Clock Resources in the Clock Resources View

The Clock Regions, I/O Banks, and various device resources display in their relative
location as found on the device.

You can expand or collapse sections of the Clock Resources to hide or display the
resources as needed. Logic that is placed is displayed under the Instance columns.

Placed clock resources such the GTXE2s and their associated Diff Pair ports are displayed
in the chart along with BUFGs and MMCMs

Step 19: Placing the MCM Instance

1. Click the Find Results view tab on the bottom of the screen to display the view.

2. Select the MMCME2_ADV instance and drag it into the Clock Resources view on the
Instance field next to one of the MMCME2_ADV Sites.

Note: If the instance does not drag out of the Find Results view, click the Netlist view tab and
drag to place it from there.
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Notice how you can place clock and related I/O logic in the Clock Resources view.

Netlist — O & % || #Package x|@ Device X | Clock Resources x
= >[E] A, ||l @ BuFr_xov10
¢ - [il] XST_GND (GND) » | || =2|||| & BUFR_xOY9
=@ clkgen (clock_generator) Z [] BUFR_XO0Y8
- = Nets (18) [E] BUFID_X0Y11
(= [ Primitives (10) &]|||| & BUFIO_x0Y10
----- (il clkf_buf (BUFG) El BUFIO_X0Y9
----- (i clkouti_buf (BUFG) £ BUFIO_X0Y8
----- (i clkout2_buf (BUFG) & IDELAYCTRL_X0Y2
----- [ clkout3_buf (BUFG) £] BUFMRCE_X0v4
- | [E] BUFMRCE_X0YS
----- [l clkoutd_buf (BUFG) B FLiE ADY RY2
""" @ dkouts_buf (BUFG) i E MMCMEZ_ADV_X0Y2 e e =
""" (@ clkout_buf (BUFG) - B G17:SRCC {il VStatus_pad_Y¥i_4_IBUF (3B...
""" E“ [E] F18:SRCC [l vstatus_pad 1 i 3 IBUF (IB...
""" [l XST_GND (GND) [E] F17:MRCC [l vStatus_pad_1_i_2_IBUF (IB...
""" [l XsT_vCe (vCC) i [l E17:MRCC [l vstatus_pad_1_i_1_IBUF (IB...
[+-[3] couEnaine (ori200 fon) [E] E18:MRCC [l vstatus_pad_1_i_0_IBUF (IB...
< | I | r O B D18:MRCC fi VControl_pad_1_o_3_OBUF ...
& Sources, G Netdist | < o
Find Results - Instances - Type is 'Clock' (14)
N Id  Name Cell Instance Pins
" |un s  ckgenjckoutl_put BUHG 2
|| 5 clkgen/clkout2_buf BUFG 2
[l 6 dkgen/ckout3_buf BUFG 2
il 7 dkgen/ckoutd_buf BUFG 2
[il 8 clkgen/clkouts_buf BUFG 2
[ila clkgen/clkouté_buf BUFG 2
(%110 Jclkgen/mmem_adv_inst  _ [MMCME2 ADV]69 |
[il 11  magtEngine/gt_usrclk_source/txoutclk_bufgl_i BUFG 2
[il 12 mgtEngine/gt_usrclk_source/txoutclk_bufgl_i BUFG 2
[il 13  mgtEngine/gt_usrclk_source/txoutclk_bufg2_i BUFG 2
[il 14 mgtEngine/gt_usrclk_source/txoutclk_bufg3_i BUFG 2
||E|Instances - Type is 'Clock’ (14) x |

3 Tdl Console | © Messages | [ Compilation | 2 Reports, 1 Find Results | % Design Runs | > Package Pins | D- /0 Ports |

Figure 29: Displaying Placed MMCM_ADV Logic Instance

3. Close the Find Results view.

4. In the Clock Resources view, click the Restore Workspace button =& in the view banner

to return the view layout.

5. Click the Device view tab in the Workspace.

Step 20: Running Design Rule Checks - “DRC”

The PlanAhead tool has an extensive set of I/O related DRCs to be sure that
I/O Ports are assigned accordingly. You can explore and resolve any violations interactively.
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Reporting the I/0O Related DRC Checks

1. Click Report DRC in the Flow Navigator.

2. Deselect the Placer, Netlist, Floorplan, DSP48, and RAMB rule categories.

Results Name: |drc_1

Output File: D

Rules to Check: 38 of 1220

g A
asE

=+ All Rules (1220)
- Bank (18)
G 108 (19)
O Placer (14)
B Netlist (1158)
[+ Floorplan (5)
[ ClkBuf (1)
[0 DSP4s (4)
B RAMB (1)

Select All || Clear Al |

Open in a new tab

Figure 30: Run 1/0 Related DRCs

3. Expand the selected rules to examine the rule types.

4. Click OK.

The DRC violations view now opens.

DRC - drc_1 (2 violations)

Name

= = All Vielations (2)
& 108 (2)

FRE H 2

B'Q Unspecified I/O Standard (NSTD-1)
@ NSTD #1

1
Severity Details

=} @ Unconstrained Logical Port (UCIO-1)
@ UCIO #1 Critical Warning |17 out of 135 logical ports have no user assigned specific location constraint (LOC). This design will fail to generate a bitstream unless all I...

Critical Warning 40 out of 135 logical ports use /O Standard (IOSTANDARD) value 'DEFAULT', instead of a user assigned specific value. This design will fai...

@ drc_1 (2 violations) x

2 Tdl Console | © Messages | Ed Compilation | 21 Reports | % Design Runs | 5 Package Pins | O+ /O Ports & DRC

Figure 31: Reporting DRC Violations

The Violations indicate that I have several I/O Ports missing LOC and IOSTANDARD
constraints. The design will fail to create a bitstream file as is. We could use the
techniques describe in this tutorial to place and configure the remaining I/O Ports.
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5. Select one of the Violations and examine the Violation Properties view

Notice that links in the Violations Properties view allowing you to select the offending
logic objects.

6. Close the DRC view.

Step 21: Running Simultaneous Switching Noise Analysis - “SSN”
Simultaneous Switching Noise (SSN) analysis can also be performed to help identify potential
signal integrity concerns.

1. In the Flow Navigator, click Report Noise.

2. Click OK in the Run SSN Analysis dialog box.

The Noise report view opens.

Noise - ssn_1 —F g =
fnir;;;gs ‘L\J Name Port Yo std Veco  Slew  Drive Strength (mA)  Off-Chip Termination  Remaining Margin (%) Notes
| - YO Bank 0 (De -
Linke 29| - s /O Bank 12 (D
= IO Bank 13 (H;
= 1/O Bank 14 (Hi LVCMOS18 1.80 sLOW 12 multiple
5 H26 DataOut_pad_0_o[0]  LVCMOS18  1.80 SLOW 12 FP_VTT_50 62.96
2 F25 DataOut_pad_0_o[1]  LVCMOS18  1.80 SLOW 12 FP_VTT_50 62.96
"0 E26 DataOut_pad_0_o[2] LVCMOS18 1.80 sLOW 12 FP_VTT_50 62.96
PG5 DataOut_pad_0_o[3]  LVCMOS18  1.80 SLOW 12 FP_VTT_50 62.96 i
£ G26 DatsOut_pad_0_o[4]  LVCMOS18  1.80 SLOW 12 FP_VTT_50 62.96 1
SYE25 DataOut_pad_0_o[5] LVCMOS18 1.80 sLOW 12 FP_VTT_50 62.96
-2 D25 DataOut_pad_0_o[6] ~ LVCMOS18  1.80 SLOW 12 FP_VTT_50 62.95
0G24 DataOut_pad_0_o[7]  LVCMOS18  1.80 SLOW 12 FR_VTT_50 62.96
M E22 OpMode_pad_0_o[0] LVCMOs18 1.80 sLow 12 FP_VTT_50 62.96
-5 820 OpMode_pad_0_o[1] ~ LVCMOS18  1.80 SLOW 12 FP_VTT_50 62.95
2 D26 SuspendM_pad_0_a LVCMOS18 1.80 SLOW 12 FP_VTT_50 62.96
»5 A20 TermSel_pad_0_o LVCMOs18 1.80 sLow 12 FP_VTT_50 62.96
s 22 TxValid_pad_0_o LVCMOS18 1.80 SLOW 12 FP_VTT_50 62.96
221 VControl_Load_pad_0_o LVCMOS18  1.80 SLOW 12 FP_VTT_50 62.96
2 Haa vControl_pad_0_o[0]  LVCMOS18  1.80 SLOW 12 FP_VTT_50 62.96
"3 H21 VControl_pad_0_o[1] LVCMOS18 1.80 sLOW 12 FP_VTT_50 62.96
G2t VControl_pad_0_o[2]  LVCMOS18  1.80 SLOW 12 FP_VTT_50 62.96
#2126 VcControl_pad_0_o[3] LVCMOS18 1.80 sLow 12 FP_VTT_50 62.96
30 A23 XevSelect_pad_0_o LVCMOS18 1.80 sLOW 12 FP_VTT_50 62.96
-DC3 phy_rst_pad_0_o LVCMOS18  1.80 SLOW 12 FP_VTT_50 62.95
=} m» /O Bank 15 (High Ranc 20) LVCMOS18 1.80 SLow 12 multiple
H DataOut_pad 1_o[0] LVCMOS18 1.80 sLOW 12 FP_VTT_50 62.96
[T DataOut_pad_1_o[1]  LVCMOS18  1.80 SLOW 12 FP_VTT_50 62.95
[RI] DataOut_pad_1_o[2] ~ LVCMOS18  1.80 SLOW 12 FR_VTT_50 62.96 -
< m 3 @
Hssn_1 x

& Tel Console | © Messages | Bl Compilation | 5 Reports | & Design Runs | 5 Package Pins | O /O Ports-. [l Noise

Figure 32: Noise Results View

Examining the SSN Results View

Maximize the Noise view and
Scroll down and expand the list of I/O Banks.
Select Summary in the upper left categories list and examine the information.

Select Messages and Links to examine the information.

N o v~ W

Restore the Noise View.

Simultaneous Switching Noise (SSN) analysis can also be performed to help identify potential
signal integrity concerns.
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Step 22: Updating the Constraint Files with Interactive Assignments

PlanAhead is an interactive constraint assignment environment. Through the course of
performing this Tutorial, we have made numerous modifications to the physical constraints in
the design. These changes are currently stored in memory. Use the Save Design command to
write the changes back to the project constraint files. The Save Design As command can be used
to create a new Constraints Set containing all of the currently assigned constraints.

Save the Design

1. Select File > Save Design.
2. In the Sources view double-click the top.ucf file under Constraint folder constr_1.
Notice the new physical constraints applied.

3. Close the top.ucf file.

Close the PlanAhead Tool

4. Select File > Exit.
5. Click OK to close PlanAhead.
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Conclusion

In this tutorial, you:

e Used the I/O pin planning environment to explore device resources and define alternate
compatible devices for the design.

e Imported, created, and configured I/O Ports.
e Created Interfaces by grouping the related I/O Ports together.

e Used the semi-automatic placement modes to assign critical I/O Ports to package pins.
Placement of the remaining I/O Ports was done using automatic placement.

e Exported and examined the I/O Ports list, which can be used for HDL header or PCB
schematic symbol generation.

e Opened a netlist-based project and placed GTXE, MMCM_ADV, and BUFG objects using
logic connectivity as a guide for correct placement.

e Ran DRCs and Noise Analysis to validate legal I/O placement.

e Updated the constraint files with the interactive assignments.
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