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Quick Front-to-Back Overview Tutorial 
This tutorial provides a quick introduction to some of the capabilities and benefits of using the 
Xilinx® PlanAhead™ design tool. The PlanAhead tool can be used during various stages of the 
design process for a variety of purposes. 

Many of the PlanAhead tool analysis features are covered in more detail in other tutorials. Not 
every command or command option is represented here. This tutorial uses the features 
contained in the PlanAhead design tool product, which is bundled as a part of the ISE® Design 
Suite. 

Software Requirements 
The PlanAhead tool is installed with ISE Design Suite software. Before starting the tutorial, be 
sure that the PlanAhead tool is operational, and that the tutorial design data is installed.  

For installation instructions and information, see the ISE Design Suite: Installation and Licensing 
Guide (UG798) at http://www.xilinx.com/support/documentation/sw_manuals/xilinx14_1/iil.pdf. 

Hardware Requirements 
Xilinx recommends a minimum of 2 GB of RAM when using the PlanAhead tool on larger 
devices. For this tutorial, a smaller design is used, and the number of designs open at one time 
is limited. Although 1 GB is sufficient, it can impact performance.  

Tutorial Design Description 
The small sample design used throughout this tutorial consists of a design called bft. There are 
several VHDL and Verilog source files in the bft design. 

The design targets an xc7k70t device. A small design is used to allow the tutorial to be run with 
minimal hardware requirements and to enable timely completion of the tutorial, as well as to 
minimize the data size. 

  

http://www.xilinx.com/
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Locating Tutorial Design Files 
Copy the files from the ISE software installation area: 

 <ISE_install_area>/ISE_DS/PlanAhead/testcases/PlanAhead_Tutorial.zip 

  

Extract the zip file contents into any write-accessible location.  

The unzipped PlanAhead_Tutorial data directory is referred to in this tutorial as the 
<Extract_Dir>. 

The tutorial sample design data is modified while performing this tutorial. A new copy of the 
original PlanAhead_Tutorial data is required each time you run the tutorial. 

http://www.xilinx.com/
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Step 1: Creating a New Project 
PlanAhead tool enables several types of projects to be created depending on where in the 
design flow the tool is being used. Register Transfer Level (RTL) sources can be used to create a 
project for development and analysis, synthesis, implementation and BIT file creation.  

Open the software: 

• On Windows, double-click the Xilinx PlanAhead 14.1 Desktop icon, or select:    Start > All 
Programs > Xilinx  Design Tools > ISE Design Suite 14.1 > PlanAhead > PlanAhead. 

• On Linux, change the directory to 
<Extract_Dir>/PlanAhead_Tutorial/Tutorial_Created_Data, and type 
planAhead. 

The PlanAhead Getting Started Help page opens. 

 

Figure 1: Getting Started Page  

The PlanAhead Getting Started page contains links to open or create projects, and view the 
documentation. 

http://www.xilinx.com/
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Creating a new RTL Project Called Project_1  

This step uses some RTL Source Files in the 
<Extract_Dir>\PlanAhead_Tutorial\Sources\hdl directory. 

1. Select the Create New Project link on the Getting Started page. 

The Create a New PlanAhead Project confirmation dialog box opens. 

 

Figure 2: New Project Overview 

2. Click Next. 

The Project Name page opens. 

 

Figure 3: New Project Name and Location Page 

http://www.xilinx.com/
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3. Set the Project location to: 
<Extract_Dir>\PlanAhead_Tutorial\Tutorial_Created_Data. 

4. Enter the Project name: project_bft, then click Next. 

The Design Source page opens. 

 

Figure 4:  New Project Design Sources 

5. Click the RTL Project option, and then click Next. 

The Add Sources page opens. 

Adding Directories, Files, and the VHDL Library and Source Type 

1. Click the Add Files button and browse to the following directory: 

<Extract_Dir>/PlanAhead_Tutorial/Sources/hdl 

2. Press the Ctrl key to select async_fifo.v, bft.vhdl, bft_tb.v, and FifoBuffer.v, and click OK. 

Set the simulation test bench file bft_tb.v as a Simulation only source file. 

3. Click on the Synthesis and Simulation entry in the HDL Source for field for bft_tb.v and 
select Simulation only.  

4. Click the Add Directories button, and browse to select the following directory:  

<Extract_Dir>/PlanAhead_Tutorial/Sources/hdl/bftLib. 

Set the VHDL Library for all of the sources in the bftLib directory. 

http://www.xilinx.com/
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5. Click on the work entry in the Library field for bftLib, and type bftLib. 

6. If needed, click these two checkboxes to select Copy Sources into Project, and Add 
Sources from Subdirectories. 

7.   Verify that the page looks like the following figure. 

 

Figure 5: New Project:  Selecting Sources to Add to the Project 

8. Click Next.  

The Add Existing IP page opens. You can select existing IP (Intellectual Property) from CORE 
Generator™ software .xco project files. However, this tutorial does not include importing IP 
into the project. 

http://www.xilinx.com/
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Figure 6: Adding Custom IP as Sources 

9. Click Next. 

 The Constraints Files page opens.  

 

Figure 7: New Project: Adding Constraint Files 

http://www.xilinx.com/


 Step 1: Creating a New Project 

Quick Front-to-Back Overview Tutorial  www.xilinx.com  11 
UG673 (v14.1) May 8, 2012 

Adding a Constraint File 

1. Click the Add Files button, browse to select the following file: 

<Extract_Dir>/PlanAhead_Tutorial/Sources/bft_full.ucf 

2. Click OK. 

3. Click Next. 

 The Default Part page opens. 

Selecting a Default Part 

1. In the Filter section, click the Family pull-down menu and select Kintex-7. 

Notice the list is filtered to only show Kintex®-7 devices. 

2. In the Search field, type 70t.  

Notice the 70t devices listed. 

3. Select the xc7k70tfbg484-2 device, and click Next. 

  
Figure 8: New Project: Selecting a Family and Default Part 

http://www.xilinx.com/


 Step 1: Creating a New Project 

Quick Front-to-Back Overview Tutorial  www.xilinx.com  12 
UG673 (v14.1) May 8, 2012 

4.   Review the New Project Summary page, and click Finish. 

The PlanAhead environment opens. Note the Flow Navigator, which is located on the left 
edge.  It will be used throughout the rest of the tutorial to explore and implement the 
design. 

 

Figure 9: PlanAhead Environment 

  

http://www.xilinx.com/
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Step 2: Using the Sources View and the Text Editor 
The PlanAhead tool allows different file types to be added as design sources including Verilog, 
VHDL, NGC format cores, UCF/NCF constraint files, and specific simulation sources. The files 
display by Hierarchy, Library or Compile Order in the Sources view. A text editor is supplied to 
create or develop RTL sources. Third party text editors can also be configured. 

Exploring the Sources View and Project Summary 

1. Examine the information in the Project Summary. This will update as the design progresses. 

2. Click on the + icon to expand the Sources under the bft module. 

3. Click on the + icon to expand the Constraints folder. 

4.   Examine the Sources view. Scroll or resize the view, if needed. 

 

Figure 10: Viewing Sources 

The Design Sources folder helps keep track of VHDL and Verilog source files. Notice the 
design hierarchy is displayed by default.  The Filter Sources by Missing Files or Instantiations 
button is disabled, which means the displayed hierarchy is complete.  If this were enabled, 
you would use it to resolve the missing pieces of your design. The Source types are broken 
out into separate folders for Design Sources, Constraints, Simulation Sources, IP, etc. In the 
Libraries tab, sources are grouped by file type, while the Compile Order tab shows the file 
order used for synthesis. IP would be shown in a separate tab at the bottom as well, if we 
had some in the Project. 

http://www.xilinx.com/
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Exploring the Sources View Commands and Text Editor 

1. Select one of the VHDL sources in the Sources view. 

2. Right-click to review the commands available in the Sources view popup menu.  

3. Select Open File, and use the scroll bar to browse the text in the Text Editor. 

Note:  Alternatively, you can double-click on source files in the Sources view to open them in 
the Text Editor. 

4. With the cursor in the Text Editor, right-click and select Find in Files.  

The Find in Files dialog box opens with various search options.  

 

Figure 11: Using the Find in Files Command 

5. Type clk, and click Find. 

The Find in Files view displays in the messaging area at the bottom of the PlanAhead 
environment. 

http://www.xilinx.com/
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Figure 12: Viewing the Find in Files Results 

6. In the Find in Files view, expand and select one of the occurrences of clk and notice that the 
Text Editor now displays the file and occurrence. 

7. Close the Find in Files – Occurrences view. 

8. Close each of the open RTL file tabs in the Text Editor. 

The PlanAhead tool also includes an RTL analysis and IP customizing environment. This 
environment is covered in the RTL Design and IP Generation Tutorial: PlanAhead Design Tool 
(UG675).  

You can click the Open Elaborated Design button under RTL Analysis in the Flow Navigator to 
quickly explore the features. The RTL design is elaborated first, which enables various analysis 
views including an RTL Netlist, Schematic, Graphical Hierarchy, and estimated resource statistics. 
The views have a “cross-select” feature, which allows you to debug and optimize the RTL. There 
are also several RTL Design Rule Checks (DRCs) to check for areas to improve performance or 
power on the RTL. 

The Xilinx IP Catalog provides access to the Xilinx CORE Generator™ tool to generate IP. You can 
sort and search the Catalog in a variety of ways. IP can be customized, generated, and 
instantiated.  

http://www.xilinx.com/
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Step 3: Simulating the Design 
The PlanAhead tool is integrated with the Xilinx ISim logic simulation environment. The 
PlanAhead tool enables you to add and manage synthesis sources in the project. You can 
configure simulation options and create and manage various simulation source sets. You can 
launch behavioral simulation prior to synthesis using RTL sources and launch timing simulation 
post-implementation. 

The Behavioral Simulation command configures and launches a single ISim run, which is the 
basic flow used in this tutorial. It can be accessed in the Flow Navigator view on the left side of 
the PlanAhead environment, shown in the following figure. 

 

Figure 13: Launching Behavioral Simulation 

Exploring Simulation Options and Launching Behavioral Simulation 

1. Select Project Settings from the top of the Flow Navigator 

Notice the simulation related options in the General Options dialog such as Language 
Options. 

2. Toggle the Target Simulator menu to notice QuestaSim/ModelSim or ISim Simulator.  

http://www.xilinx.com/
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Figure 14: Launching Behavioral Simulation 

 

3. Select ISim Simulator. 

4. Select the Simulation icon on the left to view Simulation specific options. 

5. Examine the various options under each of the tabs and click Cancel. 

6. In the Flow Navigator, select Run Behavioral Simulation. 

The Launch Behavioral Simulation dialog box opens.  

 

Figure 15: Launch Behavioral Simulation Dialog Box 

http://www.xilinx.com/
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7. If bft_tb is not specified as the Simulation Top Module Name, click the browse button  , 
and select bft_tb, and click OK. 

8. Click the Options button. 

The Simulation Options dialog box opens.  

 

Figure 16: Simulation Options Dialog Box 

Notice the simulation launch options. 

9. Click the Simulation tab, and examine the options, and click Cancel. 

10. Click Launch to invoke the ISE Simulator (ISim) simulation environment. 

The ISim simulation environment opens. 

http://www.xilinx.com/
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Figure 17: ISim Simulation Environment 

Editing source files in the ISim environment results in the PlanAhead source files being 
updated as well. The two tools are referencing the same sources. Refer to the ISE Simulator 
(ISim) In-Depth Tutorial (UG682), for information about simulation using ISim. 

11. In ISim, select File > Exit and click the Yes button if prompted to close ISim.  

  

http://www.xilinx.com/
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Step 4: Synthesizing the Design 
The PlanAhead tool enables one or more synthesis runs to be configured, launched, and 
monitored, either sequentially or simultaneously. 

The Synthesize command configures and launches a single run which is the basic flow used in 
this tutorial. It can be accessed in the Flow Navigator view on the left side of the PlanAhead 
Environment. 

 

Figure 18: Flow Navigator Synthesize Drop Down Menu 

The Flow Navigator launches all major design compilation processes including synthesis, 
implementation, and generate bitstream. Optionally, it also lets you open the Elaborated RTL 
Design, the Synthesized Design, and the Implemented Design results to enable design analysis 
and constraints assignment at each phase of the design process. 

  

http://www.xilinx.com/
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Exploring Synthesis Options, Launching Synthesis, and Monitoring a 
Run 

1. In the Flow Navigator, select Synthesis Settings. 

The Synthesis Project Settings dialog box opens. 

 

Figure 19: Project Synthesis Settings 

2. Review the available options. 

3. Click the Strategy drop-down menu and review the available Synthesis Strategies 

4. Click Cancel. 

5. In the Flow Navigator click Run Synthesis to launch the run. 

Notice the Status bar in the upper right corner displays Running XST, which indicates that 
synthesis is now running. Clicking the Cancel button halts the synthesis run and removes run 
data. 

The Compilation view displays the output messages from the ISE commands, and the 
Messages view displays a filtered list of Warnings and Errors. Clicking on the Synthesis 

http://www.xilinx.com/
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messages in the Messages view opens the RTL file and displays the corresponding line of 
RTL code that it is referencing. 

Note:  Clicking Run Implementation or Generate Bitstream will run all of the required steps 
including synthesis, if it they had not yet been run, or if the results are out of date. 

Note:  Right-clicking on Synthesis in the Flow Navigator displays a menu of additional 
commands and launch options. 

Opening the Synthesized Design 

1. Allow the synthesis run to complete. Select Open Synthesized Design in the Synthesis 
Completed dialog box and click OK. 

2. If prompted, click Yes to close the RTL Design. 

The PlanAhead Synthesized Design environment displays with the synthesized netlist, target 
part, and active constraint set applied.  

 

Figure 20: Opening the Synthesized Design 

Note:  Right-clicking on Synthesis in the Flow Navigator and selecting the New Synthesized 
Design command enables additional Synthesized Designs to be opened simultaneously with 
different netlists, constraints, or target devices. 

http://www.xilinx.com/
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Viewing the XST Report Log File 

1. Click the Reports view tab at the bottom of the PlanAhead environment. 

Note: If there is no view tab available, select Window > Reports. 

2. Double-click the XST Report to view the XST report in the Workspace. 

3. To examine the XST report scroll, through the report. 

4. Close the XST Report by clicking on the X in the view tab. 

The PlanAhead tool also includes a ChipScope™ debug core insertion environment. This 
environment is covered in the PlanAhead Software Tutorial: Debugging with ChipScope 
(UG677). You can use the PlanAhead features to explore and select logic signals to debug. 
The debug cores can be configured, implemented, and automatically added into the top 
level design netlist. The cores are also maintained through design netlist iterations. 

 

The PlanAhead tool provides a powerful design analysis and floorplanning environment to 
explore and experiment with the design.  

Notice the available commands in the Flow Navigator under Synthesized Design. 

5. Select Tools from the PlanAhead main menu and examine the available categorically 
displayed commands. 

6. Select I/O Planning from the pull-down menu in the toolbar at the top of the PlanAhead 
environment. 

 

Figure 21: Opening the I/O Planning View Layout 

There are several view layouts available to help you perform different design tasks. For 
example, the I/O Planning layout provides views to enable I/O pin exploration and constraint 
assignment. The Design Analysis layout provides views to analyze the logic in the design and 
apply constraints. You can also create and display custom layouts.  The last layout selected 
will be used by default the next time that design is opened. 

7. Examine the various views and information presented, for example the Package view in the 
workspace and the I/O Ports view. 

http://www.xilinx.com/
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Note: The PlanAhead tool includes an I/O planning environment. This environment is covered in 
the I/O Pin Planning Tutorial: PlanAhead Design Tool (UG674). You can perform I/O pin planning 
prior to synthesis in the RTL Design or after synthesis in the Synthesized Design. After synthesis, 
the features expand to enable proper I/O and clock planning with related DRCs. 

8. Select Default Layout from the same pull-down menu in the toolbar. 

You can close the Synthesized Design environment after your analysis and constraint 
definition completes. This helps preserve system memory and avoids having multiple editing 
environments open simultaneously. For the purposes of this tutorial, it is left open. You can 
Click the Close button in the view banner or select Close from the Synthesis pull-down menu 
in the Flow Navigator to close the Synthesized Design. 

http://www.xilinx.com/
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Step 5: Implementing the Design 
The PlanAhead tool provides the flexibility for experimenting with implementation options. You 
can apply multiple implementation Strategies to multiple runs to find the best performing 
results. 

Exploring Implementation Options, Launching Implementation, and 
Monitoring a Run 

1. In the Flow Navigator, select Implementation Settings. 

The Implementation Project Settings open.  

 

Figure 22: Implementation Settings 

 Notice the ability to configure the Constraint Set to be applied to the run. 

3. Examine the Implementation Options 

http://www.xilinx.com/
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4. Click the Strategy drop-down menu and review the available Implementation Strategies and 
click Cancel. 

5. In the Flow Navigator, click Run Implementation to launch the run. 

Notice the Status in the upper right corner displays Running NGDBuild, indicating that ISE 
implementation is now in progress. 

The Compilation view displays the output of the ISE commands, and the Messages view 
displays a filtered list of Warnings and Errors. 

6. While the run is implementing, you could click the Synthesized Design button in the Flow 
Navigator to examine some of the post-synthesis analysis capabilities such as timing, power, 
and utilization reporting. 

7. After the Run completes, select the Open Implemented Design option in the 
Implementation Completed dialog box, and click OK. 

8. Click Yes to close the Synthesized Design before opening the Implemented Design. 

  

http://www.xilinx.com/
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Step 6: Analyzing the Results 
The PlanAhead tool enables placement and timing results to be imported quickly for analysis 
from any of the completed runs. The PlanAhead tool imports placement and displays it in the 
form of “unfixed” LOC placement constraints. The TRACE timing results display in the Timing 
view. 

Note: For more information about Design Analysis and Floorplanning, see Design Analysis and 
Floorplanning for Performance: PlanAhead Design Tool (UG676). 

Opening the Implemented Design and Briefly Examining the Results 

The PlanAhead environment displays with the Implemented Design loaded. 

 

Figure 23: Opening the Implementation Results 

Clicking the Open Implemented Design button in the Flow Navigator also opens the 
Implemented Design environment. There are options in the pull-down menu for opening 
Implemented Designs with different run results. 

http://www.xilinx.com/
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Notice the placement is imported into the Device view and the TRACE timing results are 
displayed in the Timing view. Your results might differ from the figure above. 

1. Click the Reports view tab at the bottom of the PlanAhead environment. 

Note: If there is no view tab available, select Window > Reports. 

2. Double-click on the MRP Report and examine scrolling through the report. 

3. Close the MRP Report by clicking the X button in the Workspace view tab. 

4. In the Device view, click the Hide/Show I/O Nets button  to turn on the I/O connectivity. 

5. In the Device view, click the Hide/Show I/O Nets button  to turn off the I/O connectivity. 

6. Click the Timing view tab and, select the top timing path. 

The path is highlighted in the Device view and the logic objects on the path are selected in 
other views. 

 

Figure 24: Highlighting Timing Paths from the Implementation Results 

http://www.xilinx.com/
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7. In the Path Properties view banner, click the Maximize button . 

The Path Properties view displays in full screen. 

 

Figure 25: Viewing Path Properties 

Notice the Path Properties report looks very similar to the TRACE report. Selecting any of the 
Logical Resources or Locations (e.g. SLICE_X36Y79) selects the logic object or site for viewing 
in Device or other view window. 

8. Click the Restore button  in the Path Properties view banner to bring the view back to 
the original location. 

9. In the Timing view, make sure the first path is still selected and click the Schematic button 

from the view toolbar  or select the command from the popup menu. 
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The Schematic view opens. 

 

Figure 26: Viewing Timing Paths in the Schematic 

Notice that the schematic displays the logic objects on the selected paths as well as the logical 
hierarchy. This helps identify logic modules for floorplanning. It also displays links to find the 
Nets and Instances displayed in the current view. 

Note: The PlanAhead tool also includes a design analysis and floorplanning environment. This 
environment is covered in the Design Analysis and Floorplanning for Performance: PlanAhead 
Design Tool (UG676). You can use the analysis features to explore the design or the 
implementation results. You can apply constraints aimed at better and more consistent results. 

10. Close the Schematic view. 

11. Experiment with the various analysis features under Implemented Design in the Flow 
Navigator. 
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Step 7: Creating the Bitstream File 

Configure and Run Generate Bitstream to Create a BIT file for the 
Design 

1. Click Bitstream Settings in the Flow Navigator. 

The Bitgen Project Settings open. 

 

Figure 27: Generating Bitstream Options 

2. Select Cancel. 

3. Click Generate Bitstream in the Flow Navigator. 

The Running Bitgen progress bar opens. When the Bitstream is generated, a dialog box 
opens to inform you that the bitstream was successfully generated.  Click the OK button to 
dismiss it. 

4. In the Flow Navigator, notice that you can launch ChipScope Analyzer and the iMPACT 
programming tool after a bitstream file is generated. 

http://www.xilinx.com/
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Reviewing the Project Summary for the Implemented Design 

1. Select the Project Summary view tab, and review the information presented. 

2. Close the PlanAhead tool by selecting File > Exit, click Yes to save, and OK. 
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Conclusion 
In this tutorial, you: 

• Used a small PlanAhead RTL project to step quickly through the basic PlanAhead design 
flow, starting by creating an RTL project, and exploring RTL sources in the Text Editor.  

• Reviewed the simulation options and launched ISim.  

• Reviewed the various synthesis run options, ran synthesis. 

• Imported the results by opening the synthesized design.  

• Explored implementation options 

• Ran implementation.  

• Monitored run results and viewed command report files.  

• Imported run results, and analyzed a timing path.  

• Created a bitstream file. 
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