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Design Analysis and Floorplanning Tutorial

Overview

This tutorial introduces some of the capabilities and benefits of using the Xilinx® PlanAhead™
software for designing high-end FPGAs. The document contains a series of step-by-step
exercises that highlight methods to achieve and maintain better performing designs in less time.
The steps detail the following:

e Pre-implementation design and analysis capabilities
e Implementation exploration features
e Implementation results floorplanning

Note: This tutorial covers a subset of the features of the PlanAhead software product bundled
with the ISE® Design Suite. Additional features are covered in detail in other tutorials.

Tutorial Objectives

This tutorial takes you through the various analysis, floorplanning, and implementation features
of the PlanAhead software. The exercises cover the following topics:

e Analyze device utilization statistics to target alternate devices and choose the optimal
device.

e Run Design Rule Checks (DRC) to quickly resolve constraint conflicts that would otherwise
cause implementation errors.

e Use the Netlist, Logic Hierarchy, and Schematic views to explore logic.

e Perform a quick estimation of timing performance to assess design feasibility and identify
potential problem areas.

e View, modify, or create constraints in the design.

¢ Analyze the design hierarchical connectivity and data flow, as well as identify critical logic
connectivity and clock domains.

¢ Floorplan timing-critical logic to improve timing.

When using this tutorial, focus on the processes and functionality of the PlanAhead software to
determine how you can take advantage of these features in your designs.

Design Analysis and Floorplanning Tutorial www.xilinx.com
UG676 (v14.5) April 10, 2013
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Tutorial Design Description

The small sample design used in this tutorial includes:
e A RISC processor CPU core

e A pseudo FFT

e Four gigabit transceivers (GTs)

e Two USB interfaces

Software Requirements
The PlanAhead tool is installed with ISE Design Suite software. Before starting the tutorial, be
sure that the PlanAhead tool is operational, and that the tutorial design data is installed.

For installation instructions and information, see the ISE Design Suite 14: Release Notes,
Installation, and Licensing (UG631).

Hardware Requirements

Xilinx recommends a minimum of 2 GB of RAM when using the PlanAhead tool on larger
devices. For this tutorial, a smaller xc7k70t design is used, and the number of designs open at
one time is limited. Although 1 GB is sufficient, it can impact performance.

Preparing the Tutorial Design Files

Copy the files from the ISE software installation area:
<ISE_install area>/ISE_DS/PlanAhead/examples/PlanAhead_Tutorial.zip

Extract the zip file contents into any write-accessible location which will be referred to in this
tutorial as the extraction directory, or <Extract dir>.

RECOMMENDED: The tutorial sample design data is modified while performing this
tutorial. A new copy of the original PlanAhead Tutorial data should be extracted
each time you run this tutorial.

Design Analysis and Floorplanning Tutorial www.xilinx.com 6
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Lab 1: Design Analysis

Step 1: Viewing the Device Resources

1. Launch the PlanAhead Software.
e On Windows, select the Xilinx PlanAhead 14 Desktop icon or click:

Start > All Programs > Xilinx Design Tools > ISE Design Suite 14.1 > PlanAhead >
PlanAhead

e On Linux, go to the following directory
<Extract Dir>/PlanAhead Tutorial/Projects, and type planAhead.

The PlanAhead environment opens, as shown in FIGURE 1.

Getting Started Documentation
—=\ Create New Project T A Release Notes Guide
/ - New Project Wizard will guide you through the process = Information about installation and new IDS features
"\ of selecting design sources and a target device for \ in this release.
Y= a new project.

—=\ Open Project ’ User Guide

/ J ﬁ "\ : 2 X @ More detailed info on PlanAhead commands, dialogs,
\ S Open any previously created project. X i bt
i Open Recent Project Methodology Guides
.\ r g Open one of the most recently used projects. W Further assistance adopting PlanAhead flows.
Open Example Project == PlanAhead Tutorials
> Open one of the tutorial projects. “m Invaluable for first time users or to try new features.

Figure 1: Getting Started Page

The PlanAhead Getting Started page contains links to open or create projects and to view
documentation.

2. Select File > Open Project.

Browse to: <Extract Dir>/PlanAhead Tutorial/projects/project cpu hdl/
and open project cpu hdl.ppr.

Design Analysis and Floorplanning Tutorial www.xilinx.com 7
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Step 1: Viewing the Device Resources

The PlanAhead environment opens with the project open, as shown in FIGURE 2.

[€] project_cpu_hdl - [C/Data/PlanAhesd_Tutorial/Projects/project.cpu_hdl/project_cpu_hdlppr] - PlanAhead o o)==
File Edit Flow Toels Window Layout View Help Q- se
FE2 ook X D08 @K LG 5Soefiayut | K| ® Ready
[Flow Navigator % Project Manager - project_cpu_hdl x
e 5 Sources - —Oex I Project Summary X | O x
o Project q:;rgg -Ogmlﬁ E @ Project Settings g4t % [ Messages &
@ Project Settings b °D°’g'mm | Projectname:  project_cpu_hdl Summary: O errors
(5% Add Sources B Product family:  Kintex-7 0 eritical warnings
LF 1P Catalag | BB top (t Projectpart:  xcTk70tfbos75-2 0 warmings
(@) Run Behavioral Smuation 612 Smuiaiion Sources Topmodde name:  1op
Gy 2 Synthesis 2z [|» Implementation 2
> (@ Open Elaborated Design Status: = Ready Status: =P Ready
Part: e TRT0bETE-2 Part: e T0tbgh76-2
‘ 5""‘;‘ - Strategy:  Planthesd Defats Strategy:  [SE Defaults
EE i R L Flow: xsT Flow: ISE
 Run Synthesis | Mcrovchy | Phxouiss]] Comple Oy Constrants: consirs 2 Constrants: consirs 2
> [ Open Synthesized Design £y Sources | 7 Templates "
........ i <
Properties -0 x =
‘ ngw - « >[5 ° Resource information i not avalable.
mm ==
[» Run tmplementaton (& 1mplemented Timing &
> [ Open Implemented Design Timing information is not avadable,
MNext: Run Implementation
4 Program and Debug
@ Bitstream Settings
¥ Generate Bitstream
& Launch ChipScape Analyzer
B Launch iMPaCT
DesgnRuns -0 %
A | Name Part Constraints  Strategy Status  Progress Start Hapsed Ui (%)  FMax (M
b of SRR *eTI0OETS-2 constrs_2  PlanAhead Defaults (ST 14) Notstarted 0%
& = impl_1 XcTKT0HBQET6-2 constrs_2  ISE Defaults (ISE 14) Motstarted 0%
»
4
»
L
%
|, T =]
"5 7Td Console | (> Messages | GlLog | 3 Reports (S Design Runs
Figure 2: Default Layout View
3. Inthe Sources View, expand the Constraints folder to ensure constrs_2 is the active
constraint set, as shown in FIGURE 3.
Sources =-=0a X
azs wa hE
Messages: (I 1 warning
[=}57 Design Sources (6)
#-& Global Include (1)
#- Verilog Header (4)
@ top (top.v) (7)
[=HE Constraints (3)
[+ constrs_1
= i constrs_2 (active)
-4 top_fullucf (target)
(&5 constrs_3
[ H‘ierarchy: Libraries | Compile Order
4 Sources |  Templates |
Figure 3: Sources View
Design Analysis and Floorplanning Tutorial www.xilinx.com 8
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Step 1: Viewing the Device Resources

If needed, select constrs_2, right-click to open the popup menu, and select Make active.

4. Open the Design Runs view and examine the runs information.

Both Synthesis and Implementation runs are managed in the Design Runs view. Multiple

runs, employing different strategies for synthesis or implementation, can be defined and
managed from this view as well.

You can see, as shown in FIGURE 4, that both Synthesis and Implementation runs show a
status of Not Started.

Design Runs -0 a X
CJ\ Name Part Constraints ~ Strategy Status Progress Start Elapsed Ut (3%) FMax (MHz)  Timing Score
o |5 synth_1 xc7k70tfbg676-2 constrs_2  PlanAhead Defaults (XST 14) Notstarted [ 10%

ke = impl_1 Xc7k70tfbg676-2 constrs_2  ISE Defaults (ISE 14) Notstarted [ 10%

=

4

[FY

<l

=

= -

Figure 4: Design Runs View

5. In the Flow Navigator, select Run Synthesis to synthesize the design.
6. Watch the Log view for the transcript of the synthesis tool, XST.

The run takes several minutes to complete. The Synthesis section of the Project Summary
shows that the Synthesis run is in progress, as shown in FIGURE 5.

2 synthesis 2
Status: ) Running XST

Part: xc7k70tfbgb76-2

Strategy:  PlanAhead Defaults

Flow: XST

Constraints: constrs 2

Figure 5: Synthesis Running

7. After synthesis completes, select Open Synthesized Design from the Synthesis Completed
dialog and click OK.

Design Analysis and Floorplanning Tutorial www.xilinx.com 9
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Step 1: Viewing the Device Resources

The Synthesized Design opens, and the Design Runs view shows the status of XST Complete,

as shown in FIGURE 6.

t;J project_cpu_hdl - [C:/Data/PlanAhead_Tutorial/Projects/project_cpu_hdVproject_cpu_hdLppr] - PlanAhead = finl=) @
File Edit Flow Tools Window Layout View Help
FE20 AR 2 Q @ X I 3 Hoefauttayout | K &) Synthesis Complete
Flow Navigator « Synthesized Design - constrs_2 | xc7k70tfg676 2 (active X
\ o O Netist =0 x X Project Summary X | @ Device X | 7 Schematic X o
4 Project Manager J =
@ Project Settings L Nets
¥ Add Sources + Primitives
5 {1) digen
L 1P Catalog 5 {l] cpungine
(@] Run Behavioral Smulation + (i} fEngne
# (4] mgtEngine
4 RTL Analyss 4 oy
4% Open Elaborated Design & {l] wbArbEngne
4 Synthesis
@ Synthesis Settings
& Run Synthesis
4 [3] synthesized Design
{2, Edit Timing Constraints
& Report Tening \ Sources ) Netlist
B Report Cock Interaction Propertes -0 e %
D Report DRC - <%
15 Report Noise
% Report Utiization
Schematic
4 Implementation
@ Implementation Settings
> Run Implementation
; Design Runs - D x
4 Program and Debug A, | Name Part Constraints  Strategy Status Progress Start Elapsed UM (%) FMax(MHz)  Timing Score
&) Shskeen Setiogs 2|5 @ smth_1 XCKTOtbg676-2 constis 2 Planhead Defaults (XST 14) XST Complete! [N 100% 1/22/136:... 00:02:55  5§3.000  113.608
¥ Generate Bitstream %  impl_1 XC7K70tfog676-2 constrs_2 1SE Defaults (ISE 14) Notstarted [ ]0%
4 Td Console Messages = [ Log Reports (5 Design Runs
Figure 6: CPU Netlist in Netlist Design
8. In the Layout Selector, in the main toolbar, change the view layout to the Default 23 oefautiayout -
Layout if that is not the current window = ,
30 1/0 Planning
9. In the Device vi Zoom Area by clicking and holding the left o e
. n € pevice view, use £oom Area by ClicKIng an olding e leTt mouse 90 Figorplanning
button, while dragging down and to the right =5 ChipScope
“m Save As New Layout...
Reset Layout F5

This will draw a Zoom Area rectangle and zoom into the Device view. Repeat this
process as needed to zoom into the Device view close enough to see the different device

resources as shown in FIGURE 7.

In the Device view, the PlanAhead tool displays the FPGA device resources that can be used
to implement the design, as a matrix of tiles. Sites are available within a tile for placement of
netlist instances. The available sites include, for example, SLICEs, RAMs, MULTs, and DSPs,
and vary in shape and color in the Device view to differentiate the object types contained in
the site. Slices are fundamental building blocks of Xilinx FPGAs, containing LUTs and

Design Analysis and Floorplanning Tutorial www.xilinx.com
UG676 (v14.5) April 10, 2013
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registers, though the specific contents of a slice may vary with the device family. For more
information on these terms, see the Xilinx Glossary.

| I Project Summary X | Device X | ‘7] Schematic X F L2 X

BEL: C6LUT
~ Type: LUTE
BEL pins: 7

Site: SLICE_X40Y125

Figure 7: Zooming into the Device to View

10. Move the cursor slowly over the various device resources to view the tooltips, and take note
of the following:

11. Select several different types of device resources in

I/O port locations and I/O buffer assignments appear inside I/O banks.

Tall dark red tiles indicate a RAMB36 site that can also hold two RAMB18s or a FIFO
layout.!

Tall green tiles indicate sites for DSP48s.
Square blue tiles are configurable logic blocks (CLBs) containing SLICEs.

SLICE coordinates appear in the status bar at the bottom right of the PlanAhead tool
main window.

CARRY4_AMUX SLICE_X44Y119 SLICEM

the Device view.

12. In the Properties view, examine the BEL, Site, and Tile property information.

! The colors mentioned here are for the Vivado IDE default color scheme. Your colors may be
different

Design Analysis and Floorplanning Tutorial www.xilinx.com 11
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Step 2: Viewing the Clock Resources

You can open the Properties view if it is not already open, by using Window > Properties.

13. In the Device view, click and hold the left mouse button, and drag the cursor up and to the
left, or press Ctrl+0, to Zoom Fit the Device view to see the whole device.

Step 2: Viewing the Clock Resources

The Device view also shows the clock regions, which you can use to help guide floorplanning for
the design. The Clock Regions view lists all the clock regions in the device. The Clock Region
Properties view displays clock region information to indicate potential clock contentions prior to
implementation. Viewing clock domains is covered later in the tutorial.

1. Select Window > Clock Regions to display the Clock Regions view.
2. Select one of the clock regions listed in the table.

The clock region is cross-selected in the Device view as seen in FIGURE 8.

Clock Regions T i Py £ 3. Project Summary X | & Device X Oowv X
Id Name Row Column I/OBanks

a1 X0Y0 0 0 13

M 2 X0Y1 1 0 14

o 4 X0Y3 3 0 16

a8 S X1Yo 0 1 33

& 6 X1Y1 1 1 34

o 7 X1y2 2 1

i 8 X1Y3 3 1

& Sources | ] Netlist =4l Clock Regions

Clock Region Properties =z ARX
+ » %5
M X0Y2
Name: X0Y2 2
X left: 0
Y top: 53
X right: 65
Y bottom: 103
Number of instances: 49
Number of sites: 2600 M

General | Attributes | Statistics | Resources | Instances |Sites |Tie q » B

Figure 8: Viewing Clock Regions

3. Examine the Clock Region Properties view.

4. In the Properties view, click the Statistics tab, and scroll to examine the device resources of
the selected region.

At this point, without any logic placed onto the device, only the count of resources is

available. Later, as logic is assigned to resources through placement, the utilization of the
resources is also displayed.

Design Analysis and Floorplanning Tutorial www.xilinx.com 12
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5. In the Properties view, click the Resources tab to see details of the BUFR and IDELAYCTRL
sites.

6. In the Resources tab, select one of the BUFRs, and notice it highlights in the Device view.

7. Inthe Device view toolbar menu, enable Autofit Selection ’Q'l to have the PlanAhead tool
automatically zoom and center the selected object.

8. In either the Device view or the Properties view, right-click to open the popup menu and
select Mark to mark the selected object.

9. In the Device view, use Zoom Fit to fit the whole device.

Notice the presence of the mark allows you to locate the object even when viewing the
whole device.

10. Select the Unmark All main toolbar button * to remove the mark.

11. In the Clock Region Properties view, click the I/O Banks tab to examine the I/O Banks related
to the clock region.

Note: You may need to scroll across the bottom of the Properties view to see the I/O Banks tab.
12. In the I/O Banks tab, select one of the I/O banks.

The selected I/O bank is cross-selected in the Device view as well.
13. In the Layout Selector, in the main toolbar, change the view layout to the I/O Planning view.

You can also select Layout > I/0 Planning from the main menu. ~
95 pefault Layout -

The view layout has changed to facilitate pin planning in the design. The S Defauit Layout
o . . . L2 1/O Planning
Package view is opened in the graphical workspace, and the Package Pins 53 Clock Planning
view is open at the bottom of the PlanAhead tool. &5 Floorplanning
7S ChipScope
The selected I/O bank is highlighted in both the Device and Package Pins & 22::&2:‘::‘:&"°“'-" e
views.

14. In the Layout Selector, change the tool layout back to Default Layout.

Step 3: Exploring the Logic Hierarchy

This section discusses features of the PlanAhead tool that help you to explore and understand
the hierarchy of the design.

1. Click the Netlist view, and if needed, click the Collapse All button &
2. Expand the cpuEngine module by clicking the + button next to the module.

You see a tree hierarchy as shown in FIGURE 9.

Design Analysis and Floorplanning Tutorial www.xilinx.com 13
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Netiist

e I

=2

Step 3: Exploring the Logic Hierarchy

13 top

+

+

+

+
+)
5
+
+
+
#
*
+
+
+
+

Nets (1024
Primitives (12

+-{@] dkgen (cdock_generat
=-{%] cpuEngine (or1

FEREEEEEE

Nets (2210
Primitives (1

] cpu_dbg_dat_i (FifoBuffer NOS ¢ bg
cpu_dbg_dat_o (FifoBuffer NO10_cp

cpu_dwb_dat_i (FifoBuffer_NO14
cpu_dwb_dat_o (FifoBuffer_NOS8_cp
cpu_iwb_adr_o

cpu_iwb_dat_i

cpu_iwb_dat_o

] dwb_biu (or 1200
] iwb_biu
(3]

or1200_cpu
or1200_dc_top

& Sources ) Netlist @ Clock Regions

m

Figure 9: Expanding the Netlist View

3. Inthe cpuEngine module, expand the Primitives folder.

These are the primitive logic cells immediately inside the cpuEngine module. They do not
include the sub-modules of the cpuEngine, or primitives of those sub-modules.

4. Expand the Nets folder.

These are the nets immediately inside the cpuEngine module.

Select the u4 module.

© N o v

Design Analysis and Floorplanning Tutorial

UG676 (v14.5) April 10, 2013

Expand the usbEngine0 module.

www.xilinx.com

In the Netlist view, click the Collapse All button % to simplify the view.

Right-click to open the popup menu, and select Show Hierarchy, or press F6.
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The Hierarchy view opens in the graphical workspace, as shown in FIGURE 10.

- |
O i I K ST i G

N | sl R I G (00
GAARAMERRIAL [N1N  (RCREIGIARARAEL CHIIN S| MREEDN (00 (imw |
I ||

Figure 10: Hierarchy View

The selected logic module displays in the Hierarchy view. The Hierarchy view displays the
hierarchical relationship of the modules and their relative sizes. The widths of the blocks in
the Hierarchy window are relative to the device resources consumed by each block. It lets
you see how a timing path traverses the logic hierarchy, or gauge how big a module is
before floorplanning the module. You can select modules directly from this view for
floorplanning. Logic selected in other views is highlighted in the Hierarchy view.

9. Select any module in the Hierarchy view, and notice that the module is selected in the Netlist
and other views, as well.

10. Click the Unselect All main toolbar button, ™ or press F12.

11. Close the Hierarchy view by clicking the X button in the view tab.

Step 4: Displaying Device Utilization Statistics

The PlanAhead tool provides design statistics for resource utilization to help determine the
optimal device for the design. The tool helps you see how the logic resources are split between
modules. It is easy to explore multiple device types to determine the best overall utilization and
performance estimations.

Viewing the Resource Estimates of the Entire Design

1. From the Flow Navigator Select Report Utilization.

The Report Utilization view opens, as shown in FIGURE 11, showing the resource utilization by
logic type, and providing additional details for each level of design hierarchy.

Design Analysis and Floorplanning Tutorial www.xilinx.com 15
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Report Utilization

(]
o

Report utilization
Estimated resources are compared with xc7k70tfbgs76-2.
Show More Detals

Register

Step 4: Displaying Device Utilization Statistics

=0 a X

Available: [

] 2465000

Estimation: - 15896 (5% of available

LT

Available: I

] 123000

Estimation: - [ 22065 (18% of available

Block Memory

Available:

DSP4g

Available:

] 240

Clock Manager

Available:

112

Estimation:

Gigabit Transceiver

Available:

Global Clock Buffer

Available:

132

allable) top

Io

Available:

1 300

Figure 11: Report Utilization View

In the Report Utilization view, click the expand the Plus icon * next to Estimation under Block

Memory (block RAM).

You see that usbEngine0 and usbEnginel are the two largest consumers of block RAM,

together accounting for more than half of the utili

Notice that usbEnginel is selected in the Netlist vi

zation.

Select usbEnginel from the block RAM Estimation section.

ew as well.

Exploring the Resources in a More Detailed View

The Report Utilization view has a link to “Show More Details”. Clicking this link opens the Pblock
Properties view to let you examine the device resources in greater details.

1.

Design Analysis and Floorplanning Tutorial
UG676 (v14.5) April 10, 2013
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In the Report Utilization view, click the Show More Details link.
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The Pblock Properties view displays, showing the ROOT level of the design.

The PlanAhead tool provides the ability to divide the design into smaller, more manageable
physical blocks (Pblocks). Pblocks can include logic modules and primitive logic from
anywhere in the design hierarchy.

The tool automatically creates a single Pblock from the top-level of the design, or the ROOT
module, even when there are no other Pblocks defined. In this section you will examine the
resources available in the ROOT module.

2. Inthe Pblock Properties view, select the Statistics tab, if necessary.

3. View the Physical Resource Estimates that display in the Pblock Properties view, as shown
in FIGURE 12.

Pblock Properties -0 a X
« »> BRI
e} ROOT

Physical Resource Estimates

Site Type Available  Required % Ut
LUT 41000 22065 54
FD_LD 82000 15896 20
SLICEL 6900 3710 54
SLICEM 3350 1807 54
BSCAN 4 0 0
BUFGCTRL 32 12 38
BUFHCE 96 0 0
BUFIO 24 0 0
BUFMRCE 12 0 0
BUFR. 24 0 0
CAPTURE 1 0 0
CFG_IO_ACCESS il 0 0
DCI 2 0 0 -

£ m » O

General | Attributes | Statistics | Instances Connectiv 4 p B

Figure 12: ROOT Module Statistics

4. Scroll down the design statistics displayed in the Pblock Properties view.

The Statistics tab displays the device resource utilization for each type of logic element, carry
chain count, longest length, Clock Report, I/O utilization, and Primitive instance and interface
net counts.

Note: If this design had any RPMs, the RPM count and maximum size information would be
shown as well.

5. Close the Report Utilization view.
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Step 5: Running Design Rule Checks (DRC)

Xilinx recommends running the Design Rule Checker (DRC) before implementation to check for
some common design issues. The ISE implementation tool DRCs are used for design sign-off,
and take precedence over the DRCs in the PlanAhead software.

1. Select Report DRC in the Flow Navigator.

The Run DRC dialog box opens. By default, all DRC checks are selected. You can expand the
various DRC rule categories, and enable or disable DRCs that are appropriate for the specific
design phase or area of interest, as shown in FIGURE 13.

[€] Report DRC =)
Results name: | drc_1
Qutput file: |:]
Rule deck: all -

Rules to Check: 1334 of 1334
o B3
= All Rules (1
+1-vf Netlist (1206
+-v Bank
+-v Flow (1
- DSP48 (4
+-vl Implementation
r
r
0
r

}-v Floorplan (8
vl IOB (35

I Placer

}-v RAMB (1

: Select Al [ Clear Al |

V| Openin a new tab
[ ok |[ cancel |

Figure 13: Report DRC

2. Click OK to run all rule checks.

The DRC Results view opens and indicates that there are several DSP48 and block RAM
warnings. Errors, warnings and information messages display in the DRC Results view as
shown in FIGURE 14. Messages provide the following color-coding:

e Information messages have a blue icon.
e Warnings have a yellow icon.

e Critical Warnings have an orange icon.
e Errors have a red icon.

Note: DRC errors do not prevent Implementation from being run.
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DRC -drc_1 (207 violations)

Step 5: Running Design Rule Checks (DRC)

-0 a x
a Name Severiéy Details
|| B 2 All Violations (207
|| =@ pspas (203)
Ba £ DSP input pipelining (100
L& (@ DSP input pipelining (DP1P-1
Y =1 DSP output pipelining (10
(#-@ DSP output pipelining (DPOP-1)
=I-[> DSP output registers (3
(=@ DSP output registers (DPOR-1)
(1) DPOR #1 Warning  DSP cpuEnginefor 1200_cpu/or 1200_mult_mac/or 1200_gmuitp2_32x32/Mmult_xi[31]_yi[31]_MuLt_2...
i) DPOR #2 Warning  DSP cpuEngine or 1200_cpu/or 1200_mult_mac/or 1200_gmultp2_32x32/Mmult_x[31]_yi[31]_MuLt_2...
%) DPOR #3 Warning  DSP cpuEnginefor 1200_cpu/or 1200_mult_mac/or 1200_gmuitp2_32x32/Mmult_xi[31] _yi[31]_MuLt_2...
=7 Netlist (4
E- 5 Instance (4)
=[5 Required Pin (4)
= RAMBISE1 (4
=@ writefirst (REQP-165
@ REQP #1 Advisory  Synchronous docking for BRAM (cpuEngine for 1200_du/thar_ram/ramb16_s36_s36) in SDP mode wit...
@ REQP #2 Advisory  Synchronous docking for BRAM (cpuEnginefor 1200_du/tbia_ram/ramb 16_s36_s36) in SDP mode with...
@ REQP #3 Advisory  Synchronous docking for BRAM (cpuEngine for 1200_du/tbim_ram/ramb16_s36_s36) in SDP mode wit...
@) REQP #4 Advisory  Synchronous docking for BRAM (cpuEngine for 1200_du/tbts_ram/ramb16_s36_s36) in SDP mode with...

@ drc_1 (207 violations) X

Figure 14: Design Rule Violations

3. In the DRC Results view, click the DPOR #1 Warning.

The Violation Properties view opens and describes the violation. There are links to the
specific violations in the design associated with this rule, as shown in FIGURE 15.

| Violation Properties _oax
+ »BR]
(1) DPOR #1

DSP Mmult xi[31] wif[31] Mult 2 OUT output is connected to
asynchronous registers (p0_0, p0_ 1, p0_2, p0_3, p0_4,

p0_S,
p0_14, p0_15, p0_16). If you use synchronous controls you

0_6, p0_7, p0_8, p0_9, p0_10, p0_11, p0_12, p0_13,

General | Details

will get better results both in area and delay (DSP48 has
synchronous registers built in).

Figure 15: Violation Properties View

4. Right click in the Violations Properties view to open the popup menu.

Notice that by default the tool will automatically select the objects in the DRC message.

5. Select the Netlist view.

Notice that Mmult xi[31] yi[31] MuLt 2 OUT and the related flip-flops are selected.
You might need to scroll through the Netlist view to see the selected objects, as shown in

FIGURE 16.
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Netiist =002 X

= 7|
+)-() Primitives (1216 al
=-{3] or1200_gmuitp2_32x32
-E Nets (46

Primitives (135
Al Mmult_xi[31]_yi[31]_Mult_2_OUT ml)
i) Mmult_xi[31]_yi[31]_MuLt_2_OUT1 (DSP43
il Mmult_xi[31]_yi[31]_MulLt_2_OUT2 (L
i) Mmult xu[31] _yi[31]_Mult_2_OUT3 (0

-

m » B

& Sources )] Netlist | @ Clock Regions

Figure 16: Violation Objects in the Netlist View

6. In the DRC Results view, expand and scroll through the list of design violations.

7. Close the DRC Results view by clicking the X button in the tab.

Step 6: Performing Timing Analysis

In this step, you will investigate timing before implementing the design.

Before running implementation, it can be helpful to perform an early static timing estimation,
including estimated route delays, to determine the feasibility of successfully implementing the
timing constraints. The PlanAhead tool timing engine provides an estimate of what the route
delays will be, and does not report on whether the design has actually met timing (post-
implementation).

IMPORTANT: Even with a fully placed and routed design, only the TRCE timing tool indicates
whether a design has met timing. The PlanAhead Report Timing command should not be used for
timing sign-off.

1. In the Flow Navigator, select Report Timing.

The Report Timing dialog box opens to the Targets tab, as shown in FIGURE 17, in which you
can specify timing paths start, through, and end points to analyze. If you do not specify
targets, the Report Timing command analyzes all timing paths in the design.
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Step 6: Performing Timing Analysis

-

[€] Report Timing
,0, Generate a timing report.

Results name: | timing_1

Targets | Options | Advanced | Timer Settings |

5 %]

Start Points

From: E] Transition | RisefFall ~
Through Point Groups

1. Through: E].’ransm:-1 Rise/Fall ~

End Points

To: @ Transition | RisefFall ~

Command: report_timing -delay_type min_max -max_paths 10 -sort_by grc

[¥] Open in a new tab

[} Open in Timing Analysis layout

Figure 17: Report Timing

2. Select the Options tab, shown in FIGURE 18.
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@ Report Timing @

,:0:, Generate a timing report.

Results name: | timing_1
Targets Options | Advanced | Timer Settings

Report
Path delay type: min_max ~

|| Do not report unconstrained paths

Path Limits
Number of paths per group: 30l
Number of paths per endpoint: 15
Limit paths to group: E]
Path Display

Display paths with slack greater than:
Display paths with slack less than:
Significant digits: 3=

Sortpathsby: | group ~

Command: report_timing -delay_type min_max -max_paths 30 -sort_by grc
[V] Open in a new tab

[] Open in Timing Analysis layout

oK [ cancel

Figure 18: Report Timing Options

3. In the Number of paths per group field, type 30.

4. Click the Advanced and Timer Settings tabs, and inspect the various options. Make no
changes on those tabs.

In the Timer Settings tab, the Interconnect pull-down has two values: Estimated and None.
At this point in the design, prior to placement and routing, the net delays are estimated
based on a routing delay model. You can also optionally exclude net delay from timing
analysis.

The timing engine differs from the ISE timing engine; it cannot give you exact route delays.

5. Click OK to run timing analysis.
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N

The Timing view opens as shown in FIGURE 19.

Timing - Report Timing - timing_1 - o
2 S 4= * 3% ( Timing Checks - Hold
General Information  » O | Name Sk From To
i ?if:gzr;d.c ; :Zf = Constrained
S:emph =] = dkgen/phyCko (3
m = 2 Path1 -0.099 usbEngine0/resume_req_r/C usbEngine0 /u0/u0Mshreg_resume_req_s/D
= 2 Path2 -0.048 usbEngine0/ud/inta/C usbEngine0/resume_req_i_reg/D
X 2 Path3 -0,048 usbEngine0/susp_o_pipe/C usbEngine0fsusp_o/D
\ 2 Path4 -0.048 usbEngine0fu4/u0/dma_ack_wr1/C usbEngine0/u4/u0/r4/D
“ 2 Paths -0.048 usbEngine0fu4fu1/dma_ack_wr1/C usbEngine0/udfu1/r4/D
! 2@ Path6 -0.048 usbEngine0fu4/u10/dma_ack_wr1/C usbEngine0/u4fu10/r4/D
2 Path7 -0.048 usbEngine0fu4/ull/dma_ack_wr1/C usbEngine0fu4ful1/r4/D
2 Path8 -0.048 usbEngine0/u4/u12/dma_ack_wr1/C usbEngine0fu4fu12/r4/D

< I L

Y Report Timing - timing_1 X

/3 Td Console Messages | O Log | 5 Reports | (% DesignRuns (5 Timing @& DRC

Figure 19: Timing Analysis Results

The list of paths returned by Report Timing display in the Timing view. Paths show under
folders indicating the relative clock constraint. Paths with negative slack display in red. The
list of paths are initially grouped by constraint. You can disable this, and list all paths without
grouping, by disabling the Group by Constraint command on the timing report tool bar
menu. =

The tree view on the left displays general information, and the command settings used when
Report Timing was run. It also lets you view results for either Setup or Hold analysis if
available.

6. Maximize the Timing view.

7. Click Setup from the tree on the left side of the Timing view.

8. Scroll down the list of timing paths.

Notice that most of the timing paths have start and end points in the cpuEngine module.

9. Click the To column header twice to sort the list by Source.

The report is now reverse sorted by To column values. You can sort all of the table style
views in the PlanAhead tool in the same way:

e To perform a reverse sort, click the column header twice.

e To add a secondary sort criteria, press Ctrl and select another column header.

10. Click Hold from the tree on the left side of the Timing view and scroll down the list of paths.
Prior to implementation, you should focus on Setup violations, as Hold checks are
dependent on routing.

11. Click Settings from the tree on the left side of the Timing view and examine the timer
settings.

12. Restore the Timing view, and Close.
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Step 7: Implementing the Design

With a synthesized netlist, and preliminary DRC and timing analysis complete, you are now
ready to implement the design. The PlanAhead tool integrates ISE place and route technology
(MAP and PAR) to implement the design.

1. If the Sources view is hidden from view, display it by selecting Window > Sources.

!
¥ &

2. In the Sources view, click the Collapse All button, Z
shown in FIGURE 20.

and then expand constrs_ 2, as

Sources - 0O
QIS e RE

E s7 Design Sources
+-I Global Indude (1
+ Verilog Header
+-woge top (top.

=]-4=y Constraints
+-mm constrs_1
~l-¢m constrs_2

14 top_fullucf (taroet

+-m constrs_3

+ Simulation Sources (1

M
X

Hierarchy | Libraries | Compile Order
45 Sources ] Netlist | @ Clock Regions

Figure 20: Active Constraint Set
When running the implementation tools, the PlanAhead software uses constraints from the

active constraint set by default. It also writes constraints to the target constraint file. Make
sure that constrs_2 using top full.ucf is the active constraint set.

IMPORTANT: If a Netlist Design or Implemented Design is open with changes that have not yet
been saved to disk, the in-memory changes will be used instead of the UCF on disk.

3. Double-click top_full.ucf to open the file to examine the contents of the constraint file.

4. Close the file without saving any changes you might have made.

Creating Implementation Runs

PlanAhead lets you configure and run multiple Synthesis and Implementation runs in parallel or
simultaneously. In the following steps you configure multiple implementation runs, but only
launch one run.

1. In the Flow Navigator, right-click Implementation to open the popup menu.
2. Click Create Implementation Runs.
3. In the Create New Runs dialog box, click Next.
The Configure Implementation Runs dialog box opens with an impl 2 run already defined.

You update the strategy used by that run, and add a few more, as seen in FIGURE 21
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EI Create New Runs

Cc 1-, T 'o

tation Runs

Create Implementation Runs
Mame Synth Name

Consfraints Set Part

Create and configure one or more implementation runs using various Part, Constraints, flows and strategies

Strategy
impl_2 @ synth_1 (active) ¥ @ xcTk70tbg676-2 + | MapTiming (ISE 14) - [x]
mpl 3 @ synth_1 (active) v | | constrs_2 (actve) v | [@ xcakotfogezs-2 ~ | % MapGiobaloptpartigh (ISE 14) - | @)
impl_4 & synth_1 (active) + || &5 constrs_2 (active) _-‘c}xﬁk?ﬂtﬂ)gﬁ?ﬁ-z = & MaplLogicOptParHighExtra (ISE 14) - [z

[ <Bak

I Next > ]

Xl

Runs to create: 3

Cancel

Figure 21: Configure Implementation Runs

4. Under Strategy for the impl_2 run, change it from the default to MapTiming.

5. Click More several times to add new implementation runs with new strategies.

Each new run added uses the next strategy from the list of defined strategies. You can select
different strategies for the run as needed.

6. Click Next to review the Launch Options dialog box, as shown in FIGURE 22.

E] Create New Runs
Launch Options

Options
Launch runs on local host:

*) Generate scripts only

Configure hosts for launching runs, and/or set advanced launch options

Launch directory: | 3 <Default Launch Directory>

Number of jobs: | 1 ¥

[ < Back J[ Next >

Figure 22: Launch Options

7. Select Do not launch now, and click Next.
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8.

10.

Review the Create New Runs Summary dialog box and click OK.

The new implementation runs you created are added to the Design Runs view, but are not
launched at this time. You can select any of them in the Design Runs view to make them the
active run, and then launch them together or individually.

In the Design Runs view, select impl_1, and ensure that it is the active run.

You can use the Make Active command from the popup menu to make it the active run if
necessary.

In the Design Runs view, right click, and select Launch Runs from the popup menu.

TIP: You can select more than one run in the Design Runs view, and use Launch Runs to launch
multiple runs.

11.

12.

Implementation takes several minutes to complete as it runs the design through the ISE
Place and Route tools; specifically, NGDBuild, Map, PAR, TRACE, and XDL. While it is running,
you can watch the Log view for a transcript of the various tools being run.

Because implementation is run as a separate process in the background of the PlanAhead
tool process, you can continue to work with your design in a number of ways in the
PlanAhead tool. For instance, run some of the reports shown in the Flow Navigator under
Synthesized Design, like Report Noise or Report Clock Interaction, or open and explore the
Schematic view.

Notice that as you do some of these things, implementation continues to run in the
background.

After implementation completes, in the Implementation Completed dialog box, select
Open Implemented Design and click OK.

If prompted, select Yes to close the Synthesized Design.

Note: You may have disabled this prompt at some time if you elected to "never show this
dialog again”. To restore the prompt, go to Tools > Options > Window Behavior, and
check the Show dialog before switching to a different design checkbox.

The results for the implemented design import into the PlanAhead tool from the ISE tools.
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The Device view shows the placement of each instance, and the post-place and route timing
information reports from TRCE in the Timing view, as seen in FIGURE 23.

4 Synthess
@ Synthesis Settngs
> Run Synthesis
&> Open Synthesized Design

4 Implementation
@ Implementation Settings
[ Run Implementation
4 | M| Implemented Design
(23, Edit Timing Constraints
(& Run TRCE
¥ Report Clock Interaction
@ Report DRC
1 Report Noise
#] Report Utizaton
§§5 XPower Analyzer
(B3] FPGA Editor
(X Run Timing Smulation
4 Program and Debug

@ Bitstream Settings
¥ Generate Bitstream

1 Default Layout

[€] project_cpu_hd! - [C:/Data/PlanAhead_Tutorial/Projects/project_cpu_hd/project_cpu_hdLppr] - PlanAhead
File Edit Flow Tools Window Layout View Help

Implemented Design impl_1 | constrs_2 | xc770tfbg676 2 (actve.

g8 (HOSPRHAOBX LB
Flow Navigator «
A pag B9 Nethst
e
4 Proj M -
ject Manager 3 top
@ Project Settings 3 Nets
5% Add Sources Primitves
i) dkgen
LF 1P Catalog D cxingine
(@ Run Behavioral Simuiation i) fREngine
i) mQtEngne
o i) usbEngned
4 RTL Arfa):ﬂ 7] usbe 1
&> Open Blaborated Design il wbArbEngine

¢5 Sources ) Netlist
Properties

+ 2%

Timing - TRCE - impl_1

QB { Timing Checks - Setup
Settings <P & [ pname
Statistics %
1 a . Constrained
Ketup (210) >
petx . Fifes 5 Path
Component Swite *, P:m :
MAXPERIOD - $ Path ;
MINHIGHPUL 2 A
MINLOWPLL! > FA
MPOFRIAN 7 Path S
’
TRCE - impl_1
£ Td Console Messages | Bl Log Reports

@, TS_dkgen_cpuCk = PERIOD TIMEGRP “cgen_cpuck” TS _sysCk / 0.5 HIGH 50%;

-0 X

-0 x

% Project Summary X § Device X

Implementation Complete

o @ (e

Siack  From

0.277 usbEngine Ludfinta
0.318 ushEngine Lfudfnta
0.335 usbEngine0/fudfinta
0.376 usbEngine0/udfinta
0.377 usbEngine 1ju4finta

% Design Runs (3 Timing

To

cpuEngine for 1200_cpufor 1200_ctrlfsig_trap
cpuEngine for 1200_cpufor 1200_ctrifsig_trap
cpuEngine for 1200_cpujfor 1200_ctrl/sig_trap
cpuEngine for 1200_cpufor 1200_ctrifsig_trap
cpuEngine jor 1200_cpufor 1200_ctri/sig_trap

13. Click the Messages view to display the Messages view.

Figure 23: Implemented Design

14. Click the Collapse All toolbar button &

15. Expand the Implementation messages.
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16. Use the Expand Map folder to see the messages generated by this tool, as shown in
FIGURE 24.

7M:ssogs _DOax |
O, V1) 349 warnings || () S84 infos [/ (i) 11 status messages 70w A

o

w4 | ® () PlanAhead Commands
3| & @ Analysis Results (335

S| ® 1) Synthesis (343 wa
[ )] Py ) Implementation (
@ @ Translate (
=-(D Map (1 warning, 1

() [LIT 701] PAD symbol "TILED_REFCLK_PAD_N_IN" has an undefined IOSTANDARD.

@ [LIT 243] Logical network fftEngine/fftinst/egressLoop[2].egressFifo/buffer_fifo/infer_fifo.almost_empty_reg has no load.

@ [LIT 395] The above info message is repeated 62 more times for the following (max. 5 shown):
fftEngine/fftinst/egressLoop(2] .egressFifo buffer_fifo/infer_fifo.almost_full_reg,
fftEngine/fftinst/ingressLoop[0].ingressFifo/buffer_fifo/infer_fifo.almost_empty_reg,
fftEngine/fftinst/ingressLoop(0].ingressFifo buffer_fifo/infer_fifo.almost_full_reg,
fftEngine/fftInst/ingressLoop[4].ingressFifo /buffer_fifo/infer_fifo.almost_empty_reg,
fftEngine/fftinst/ingressLoop[4] .ingressFifo buffer_fifo/infer_fifo.almost_full_reg
To see the details of these info messages, please use the -detad switch. -

@ [LIT 244] Al of the single ended outputs in this design are using slew rate limited output drivers. The delay on speed critical =)

Figure 24: Implementation Messages

The Messages view collects all information, warning, and error messages from the various
tools integrated into the synthesis and implementation processes.

17. Click the Reports view.

18. If the Reports view is not opened, select Window > Reports to display the Reports view, as
shown in FIGURE 25.

Reports — o |
X | Name Modified Size
123 | E-Synthesis (xst)
] '3} XST Report 1/22/13 7:00 AM 712.4KB
| @-Translate (ngdbuild
'2) NGDBuild Report 1/22/13 2:27PM 3.1KB
2] MRP Report 1/22/13 2:33PM 174.7KB
'3 MAP Report 1/22/13 2:33PM 8.4KB
B Physical Synthesis Report
=)-Place & Route (par)
2 Pad Report 1/22/13 2:36 PM 136.6 KB
2) PAR Report 1/22/13 2:36 PM 17.2KB
3} Unroutes Report 1/22/13 2:36 PM 0.2KB
I webTalk Report
B WebTalk Log
[=)-Static Timing Report (trce)
'3) Trace Report 1/22/13 2:37PM 770.7KB
[#)-Bit file generation (bitgen

Figure 25: Implementation Reports

19. Double-click the report name to view the actual report.

20. Close the report files.
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Step 8: Viewing Timing Paths

You can analyze timing results from the implementation process to help define a floorplanning
strategy. You can use the path sorting and selection techniques available in the Timing view with

the timing report imported from TRCE during implementation.

Marking Timing Paths

1. Click the Timing tab.

2. Inthe Timing view, select Path 1, as shown in FIGURE 26.

Timing - TRCE - impl_1 0O x
QA TS ¢ 4 Timing Checks - Setup
1
Settings * A Name Slack  From To TotalDelay LogicDelay Net%  Stages
Statistics P -
5 Timing Checks (417 v | 22 Constrained A
M(ZIO) o =@, TS_dkgen_cpuCk = PERIODTDJEGRPd(gencptﬂ(TSsysO(IOSHIGl-iSO%
L Component Swicing ks 4, [l 2 i Y e e T ) I
MAXPERIOD (& [ = @ Path2 0.318 usbEngine 1/ud/finta qxfngne/otlzoo cpujor 1200_ctrl/sig_trap
MINHIGHPULSE (28 |* }\ ¥ Path3 0.335 usbEngine0/udfinta cpuEnginefor 1200_cpu/or 1200_ctrl/sig_trap 9 212 1 074 88 3 11
MINLOWPULSE s X ¥ Path4 0.376 usbEngine0/u4finta cpuEngine for 1200_cpu/or 1200_ctrl/sig_trap 9.171 1.207 86.8 14
MINPERIOD (1 ¥ Path 5 0.377 usbEngine 1/u4/inta cpuEngine for 1200_cpu/or 1200_ctrl/sig_trap $.001 1.207 86.6 14
' : ¥ Path6 0.435 usbEngine0/u4/inta cpuEngine for 1200_cpu/or 1200_ctrl/sig_trap 9.112 1.207 86.8 14
e/ =P Dath 7 N 447 iichFnnine 1 /idfinta rreFnnins lne 1900 _cruilar 19200 _ctrllcin_tran R Q21 1102 R7 7 14 :
< m =) | m r g
%) TRCE - impl_1

15 Td Console | () Messages | [ Log | |5 Reports | (% DesignRuns  (J Timing

Figure 26: Analyzing Timing

3. Right-click to open the popup menu, and select Mark.

The timing paths show on a constraint-by-constraint basis. When you select paths in the
Timing view, the path selects in the Device view, and the Path Properties view shows the

details of the timing path.

The Mark command, marks:

e Timing path start points with a green diamond,
e Through points with a yellow diamond

e End points with a red diamond.
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This helps you quickly visualize the data flow through the timing path, as shown in
FIGURE 27.

| | X Project Summary X | &P Device X Owe X

ﬂ - ) 4

m

@ & 88| 2

B
B L e

Figure 27: Marked Timing Path

4. Select the Unmark All button in the main toolbar, or View > Unmark All to clear the marks
from the Device view.

In the Timing view, the timing paths group by constraints as a default.
In the Timing view, click Collapse All to display only the reported constraints.
Expand the TS clkgen usbClk timespec to view the listed paths.

Click once in the From column head to sort the timing paths according to the start points.

© N o wu

Select all the paths in TS _clkgen usbClk with usbEnginel/* as a start point. Do not
grab other paths.

9. Right-click and select Schematic from the popup menu.
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The Schematic view shows all of the instances on the selected paths, as shown in FIGURE 28.

Step 8: Viewing Timing Paths
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Figure 28: Schematic View of Timing Paths
10. In the Netlist view, click the Collapse All button.
11. In the Schematic view, right-click and use Select Primitive Parents.
Design Analysis and Floorplanning Tutorial www.xilinx.com 31

UG676 (v14.5) April 10, 2013




v
!A X"_l NX» Step 8: Viewing Timing Paths

This selects the parent modules of the currently selected instances in the timing paths. The
corresponding logic modules select in the Netlist view. This helps you identify the
hierarchical location of the selected timing path in the overall design, as shown in FIGURE 29.
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Figure 29: Schematic Primitive Parents

12. In the Netlist view, right-click to open the popup menu, and select the Show Hierarchy
command, or press F6.

The Hierarchy view opens, as shown in FIGURE 30, with the selected modules highlighted.
These are the hierarchical design modules associated with the selected timing paths.

According to the Hierarchy view, the timing path logic is mostly contained in the
usbEnginel module, and constitutes a large percentage of that block. Also notice that
usbEngine0 is a similar module, if not identical.

These usbEngine blocks are the foundation of your floorplan in the remainder of this
tutorial.

13. Click the X button to close the Hierarchy view by.

Design Analysis and Floorplanning Tutorial www.xilinx.com 32
UG676 (v14.5) April 10, 2013



i¢ X"_l NX Step 8: Viewing Timing Paths
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Figure 30: Viewing Hierarchy for Floorplanning

Traversing Schematic Hierarchy
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1. Click to display the Schematic view that you opened previously, as shown in FIGURE 30.

2. Click the Unselect All ™ button, or press F12.

The levels of hierarchy are drawn with concentric rectangles. It is very easy to identify the

logic modules associated with timing path logic.
3. On the left of the Schematic view, select the RAMB36E1.

4. In the Schematic view, right-click to open the popup menu, and select
Expand/Collapse > Collapse Outside.

The block Ram is isolated.

5. On the upper left of the block RAM symbol, double-click the
ADDRARDADDR[15:0] pin.

Double-clicking the outside of a pin expands the schematic outward
from the pin. This is the same as selecting the pin and using the
Expand Cone to Primitive from the popup menu.

6. At the top of the newly added logic, select the infer_fifo.wr_addr_0
cell.

7. Right-click and select Expand Cone > To Primitives from the popup
menu, or double click the selected cell.

Design Analysis and Floorplanning Tutorial www.xilinx.com
UG676 (v14.5) April 10, 2013

ushEngine1

usb_dma_wb_in

o

buffer_fifo

Wram_fifo_ram

L8110 ¢ o510 11 188883131393 @

ADDRARDADDR[15:0]
|\DDREWRADDR[15:0]

CASCADEINA

CASCADEINE

CLIKARDCLI

cLiBwWRCLIK

DIADIE1-0] CASCADEOUTA
DiEDI31:0] CASCADEQUTE
DIPADIR[30] DBITERR
DIPEDIP[3.0] DOADO[3 0]
ErNARDEN DOBDOH 0]
ENEWREN DOPADOP[3.0]

[NIECTDRITERR  DOPEDOP[ED]
INJECTSEITERR  ECCRARITY[7.O]
REGCEAREGCE RDADDRECCIRD]
RECCER SEITERR
RETRAMARSTRAM
RETRAME
R=TREGARSTRES
ReTREGE

EAE]

EBWE7 0]

RAMBIBET

async_fifo_1_buffer_fifo

FifoBuffer_ush_dma_wh_in

usbf_tap_usbEngine1

33




& XILINX.

Step 8: Viewing Timing Paths

This adds the logic connected to the selected symbol into the schematic, as shown in FIGURE 31.
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Figure 31: Interactively Expanding Logic in the Schematic View

In the Schematic view, select the Previous schematic button. s

You can use the Previous schematic and Next schematic toolbar buttons to browse the
various views displayed in the Schematic view. Switching between views lets you toggle the
various levels of schematic expansion.

Note: The Edit > Undo command is not applicable to the Schematic view.

9.

Close the Schematic view by clicking the X button.

10. Click the Unselect All button ™ or press F12.

11. In the Netlist view, click the Collapse All button. &
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Conclusion

In this lab, you have opened the CPU HDL project, and examined various aspects of the design
using tools available within the PlanAhead tool. You have examined the hierarchy of the design,
and the timing report prior to implementation, and synthesized and implemented the design.
Finally, you examined the messages and reports generated by the PlanAhead tool.

This concludes Lab #1. You can proceed at this time to Lab #2, or use the following steps to exit
the tool:

1. Click File > Close Project to close the CPU HDL design.
2. Click File > Exit to exit the PlanAhead tool.
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Lab 2: Floorplanning the Design

Step 1: Analyzing Placement and Connectivity

Examining the placement and connectivity of the design allows you to develop a strategy for
floorplanning to improve placement, routing, and achieve timing closure. The PlanAhead tool
has extensive logic expansion and highlighting capabilities. These features can be used to
examine the placement achieved through implementation, and identify candidates for
floorplanning. For example, tightly grouped and self-contained hierarchical modules may be
suitable candidates for floorplanning, while modules that connect to logic scattered throughout
the design and across the device may not be suitable.

Highlighting Module Placement

You can analyze the placement of hierarchical modules resulting from prior implementation
runs. By examining preliminary implementation results, you can determine a floorplanning
strategy to help improve placement, and achieve timing closure and routing.

1. In the Netlist view, select usbEngine0 and usbEnginel.
2. Right-click and select Highlight Primitives > Cycle Colors.
3. Click the Device tab to view the highlighting.

The primitives in each module highlight in a different color, as shown in FIGURE 32.

Netiist =aEliALX
3] top
+ Nets

+ Primitives (1
+-{@] dkgen (c
+-{#] cpuEngine
+-{4] fftEngine (f
+-{&] mgtEngine
+)-{i] usbEngine1
+-{d] wbArbEngine

&5 Sources ;] Netlist

Instance Properties o 1 [ B ¢
& L X &
usbEngine0

Name: usbEngine0

Cell: usbf_top

Type: Others

Number of instance pins: 166

Number of nets: 166

General | Attributes | Statistics | Instance Pins | Children | ¢ » @

Figure 32: Highlighting Module Placement
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6.
7.
8.

Notice the grouped placement of the primitives within each module. Scroll around and
change the Zoom level. Notice the logic is spread out. The block RAMs from the two blocks
may be intermingled. These modules might benefit from floorplanning to improve timing.
In the Device view, click the Device View Layers button I

Uncheck the box next to Instances.

Various logic elements of the Design, or resources of the Device, can be hidden to make the
Device view less cluttered and easier to interpret, as shown in Figure 33.
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Figure 33: Enabling/Disabling Device View Options

Check the box next to Instances to restore the placement.
Click the Device View Layers button U to hide the menu.

From the main toolbar, click the Unhighlight All button X

Visualizing Connectivity

You can show or hide the I/O nets in the Device view, to display connections from placed
instances to the I/O Pins. This feature lets you quickly visualize logic that should be placed closer
the I/O blocks on the device, and aids in floorplanning and placement of the design.

1

2.

In the Device view, select the Show I/O Nets toolbar button s

Examine the connections. Look closely at any connections that cross from one side of the
device to the other, or cross a long distance from port to pin. These indicate placement
problems that should guide your floorplanning.

Click to select one of the I/O Nets.
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3. Inspect the net name in the Netlist view, and examine the net properties in the Properties
view, as shown in FIGURE 34.
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Figure 34: Device View with I/0 Connectivity

4. In the Netlist view, click the Collapse All button, £ and select usbEngine0 and usbEnginel.

5. Right-click and select the Show Connectivity popup menu command.

The interface nets that connect usbEngine0 and usbEnginel modules to the rest of the
design are highlighted, as shown in FIGURE 35.

6. Right-click and select Show Connectivity a second time.

This selects all of the logic objects to which the interface nets connect, expanding outward
from the connection to the primitives.

7. Right-click and select Show Connectivity a third time.
This highlights all of the nets that fanout from the selected logic objects.

Note: You can use the Show Connectivity command to highlight or select a cone of logic from
any source net or logic object.

8. Click the Unselect All button ™ or press F12.
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Figure 35: Show usbEngine Module Connections

Step 2: Using Placement Constraints

This step shows how to:
e Search for logic based on primitive type

e Fix placement constraints to prevent logic from being moved in subsequent placement
iterations

e C(Clear the placement of all cells to clear the device for floorplanning.

Finding Cells and Fixing LOCs

1. Select Edit > Find.

2. Change the Instances search Criteria to be Type > is > Block Memory, as shown in
FIGURE 36.
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Figure 36: Find Dialog Box

3. Select OK.
4. Select any block RAM in the Find Results view.

The block Ram is selected in the Device view. If the block RAM is too small to see, you can

enable the Auto-Fit Selection button Q' for the PlanAhead tool to zoom into, and center
the selected object.

5. In the Find Results view, press the Shift key and select the first and last block RAM, or press
Ctrl+A to select all block RAMs.

You see all the block RAMs selected in the Device view.
6. Right-click to open the popup menu, and then select Fix Instances.
7. In the main toolbar, select the Unselect All button.

8. Zoom in and notice that “Fixed” cells display in a different color than unfixed cells, as seen in
FIGURE 37.
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.
2. Project Summary X & Device X 02 X

Figure 37: Fixed Block RAMs

IMPORTANT: Both fixed and unfixed cells are placed. Fixed and Unfixed are terms that
describe the way the PlanAhead tool views placed cells in the design.

e A Fixed cell is placed by you, or another designer, or was imported from a constraints
ﬁ file. The PlanAhead tool determines that these placed cells are fixed, and are not
moved unless explicit direction is provided to do so.

e The PlanAhead tool places Unfixed cells during implementation. These placed cells are
unfixed, or loosely placed, by the PlanAhead tool, and can be moved as needed in
design iterations.

If you save the design at this point, the File > Save Constraints command writes the placement
constraints (LOC) to the target constraints file (UCF) for the active constraint set. The placement
locks for subsequent implementation attempts.

O TIP: You can use the Save Constraints As command to create a new UCF file, leaving the
original constraints intact.

If the design has unsaved changes, PlanAhead prompts you to save upon closing the
Implemented Design.
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Clearing Placement Constraints

Having fixed the placement for certain cells, you now clear the placement of all cells from the
device, to prepare for floorplanning the design.

The Clear Placement Constraints dialog box selectively removes placement constraints. The
PlanAhead tool provides filters for you to remove placement of specific logic elements
selectively.

1. Select Tools > Floorplanning > Clear Placement.

2. In the Clear Placement Constraints dialog box, select the Instance placement radio
button, and click Next.

The Instance Types to Unplace dialog box presents a list of logic types from the currently
selected cells, and lets you selectively clear or keep LOC constraints by logic type.

Notice that, in FIGURE 38, Clock and IO logic is not selected by default. The I/O and clock
related resources are separate from the fabric logic because they do not change as often,
and; therefore, might not need to be unplaced.

E] Clear Placement Constraints

(=5
Instance Types to Unplace
Below is a list of types of the 43427 spedfied instances. Only instances of the selected m

types will be unplaced.

_Prmitive Types to Unplace
[¥] Flop &Latch (15834)
7| LUT (21247)

V| MuxFx (381)
V| CarryLogic (5529)
10 (147)
V| Block Memory (126)
[¥] Block Arithmetic (100)
Clock (13)

| Distributed Memory (50)

[ setal ][ Cearal |[ Defaut |

Cancel

Figure 38: Instance Types to Unplace

TIP: If you have anything selected when you run the Clear Placement command, the Unplace
Instances dialog box opens before the Instance Types to Unplace dialog box. This lets you choose
to unplace the selected cells, the unselected cells, or all cells.
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3. Choose Select all logic types but IO, to unplace everything but the ports.
4. Click Next, as shown in FIGURE 39, to display the Fixed Placement dialog box.

This dialog box displays only when you select fixed cells to be unplaced. In this design the
block RAMs are fixed, but you unplace them here.

Eﬂ Clear Placement Constraints

i3]
Fixed Placement
Some of the instances you are about to unplace are marked as Fixed. Do you want to unplace these

fixed instances?

Fixed Instances
Keep 138 fixed instances

<Back || Mext> | : | cancel

Figure 39: Unplace Fixed Cells

5. Select the radio button next to Unplace all 43280 placed instances” .

6. Click Next to display the Clear Placement Summary page.

7. Click Finish to clear the placement constraints from the design.

8. In the Netlist view, click the Collapse All button. &

? The number of placed instances in your design can vary.
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Step 3: Floorplanning with Pblocks

The floorplanning process requires the definition of associated groups of logic, called physical
blocks, or Pblocks. In this step you will:

Use various features of the PlanAhead tool to redefine the netlist hierarchy into a physical
hierarchy of Pblocks.

Place the Pblocks and examine the connectivity between them to visualize the design data
flow.

Arrange the Pblocks as a floorplan of the design on the device, and save the placement to
the constraints file.

Creating Pblocks

1. From the main menu, select Tools > Floorplanning > Auto-create Pblocks.

The Auto-create Pblocks dialog box opens with a list of Pblocks to generate from the
netlist hierarchy. The number of blocks to generate, and the minimum primitive count for
each block determines the list of blocks. You can change these values as needed so that you
are floorplanning the largest blocks in the design. In this case, you use the defaults provided.

[€] Auto-create Pblocks (=25

Pblodk to partition: ROCT -
Maximum number of Pblocks to generate: -

Process instances with primitive count of at least: He
Preview
7 Pblocks are going to be generated for the following instances:
usbEngine 1
usbEngined
cpuEngine
fftEngine
mgtEngine
whArbEngine
dkgen

ok |[ cancel |

Figure 40: Auto-create Pblocks

2. Click OK to accept the default Pblocks.

3. From the View Layout drop-down in the main toolbar menu, select the Floorplanning layout

The Physical Constraints view opens, and lists the newly-created Pblocks.

In the Netlist view the icon next to the hierarchical modules that are defined as Pblocks

changes from o j/j, to show that the module is placed in a Pblock.

Design Analysis and Floorplanning Tutorial www.xilinx.com 44
UG676 (v14.5) April 10, 2013



& XILINX.

Step 3: Floorplanning with Pblocks
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Figure 41: Pblocks in the Physical Constraints View

Placing Pblocks

1. From the main menu, select Tools > Floorplanning > Place Pblocks.

The Place Pblocks dialog box opens as shown in FIGURE 42. This dialog box lets you specify
the SLICE utilization ratio for all Pblocks, or for each Pblock separately.

f@] Place Pblocks (5w
Parent Pblock
ROOT -
Pblocks to place
Place  Pblock Utilization %

pblock_dkgen 87

pblock_cpuEngine 87

pblock_fftEngine 87

pblock_mgtEngine 87

pblock_usbEngined 87

pblock_usbEnginel 87

pblock_wbArbEngine 87

NEEEEEE

Set Utiization on All Pblocks... |

Figure 42: Place Pblocks

IMPORTANT: The Place Pblocks command is intended to quickly size and place selected Pblocks.
Pblocks are sized based upon SLICE logic only. Other non-SLICE logic is not considered in

ﬁ determining the Pblock size. Therefore, the Pblocks created using the Place Pblocks command
might need to be resized later to successfully complete implementation.

2. Click OK to accept the default values, and place the Pblocks.
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The tool sizes and places the Pblocks into the Device view as shown in FIGURE 43.

| | X Project Summary X | Device X /7 Schematic X Oog X

Ca bl usbEagine
Ly : — =

Figure 43: Initial Placement of Pblocks

TIP: The placement of Pblocks is dependent upon a number of factors, including some
randomization of the placement seed, therefore your placement results might differ from what is
shown here.

The bundle net connections between Pblocks and the I/O connections help you visualize the
data flow between modules in the design, and highlights areas where potential routing
congestion could occur. You can manually rearrange the Pblocks to untangle the
connectivity.

If they are not displayed, in the Device view Options 2| enable the Bundle Nets to display
them, and enable the Show/Hide 1/0 Nets toolbar button ** to show the I/O connections.

The color of the bundle nets also indicates the number of nets shared between two Pblocks.
In FIGURE 43, the red bundles indicate between 60 and 200 connections, and the light blue
bundle indicates between 200 and 500 connections.
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You can see and change the color definition of bundle nets by using the Tools > Options
command, opening the Colors dialog box, and selecting the Bundle Nets tab.

3. In the Device view, select a bundle net.

The Bundle Nets Properties view displays the list of nets contained within the bundle
between two Pblocks, as shown in FIGURE 43 PAGE, 46.

Bundle Net Properties - 0g *
+ %k
¥ Bundle Net (118)

Id Name Instance Pins  Flat Pins  Driver

# 1  wbArbEngine/s1/s1_cyc_o 1
e 2 usbEnginel/u4finta 1
3 whbArbEngine/s1/s1_stb_o 1
& 4 usbEnginel/susp_o 1
= 3 whArbEngine/s1/s1_we_o 1
& 6  usbEnginel/wb_ack_o 1
& 7  usbEnginel/wb_data_o[31] 1
e 8 usbEnginel/wb_data_o[30] 1
& 9  usbEnginel/wb_data_o[29] 1
& 10 usbEnginel/wb_data_o[28] 1
# 11 usbEnginel/wb_data_o[27] 1
& 12 usbEnginel/wb_data_o[26] 1
#» 13 usbEnginel/wb_data_o[25] 1
# 14 usbEnginel/wb data ol241 1

= Properties | @ Clock Regions

MWW W WWwWwWwWwhNWwN BN
AL LLLLLLL<LLL

Figure 44: Bundle Net Properties

Finding Global Clocks
In this step, you use the Find command to locate and select the USB Global Clock (usbClk) to
identify the clocked Pblocks.

Effective floorplanning is often dependent on proper placement of the synchronous elements
from different clock domains. You can highlight clock domains to visualize connectivity and
ensure that Pblocks are properly placed to effectively utilize clock resources on the device. To
learn more about clock resources and clock management, refer to the Xilinx 7 Series FPGAs
Clocking Resources User Guide (UG472), or to the appropriate guide for the target device.

1. Select Edit > Find.
2. In the Find dialog box, set the following options:
e Find: Nets
e First field: Type
e Second field: is
e Third field: Global Clock
3. Ensure to check the Unique Nets Only checkbox, and click OK.

4. 1In the Find Results view, click the Name column header once to sort the column, and select
clkgen/usbClk_o.
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Notice the selected net, highlighted in white in FIGURE 43 PAGE, 46., leading from the
clkgen Pblock to the two usbEngine Pblocks.

Find Results - Nets - Type is 'Global Clock’ (12) — 0O a X

= Id Name i Instance Pins  FlatPins  Driver

Al # 1 dkgen/dkfbout_buf 2 2 v

& & 2 dkgenfcpuClk_o 1 3,345 v
# 3 dkgen/fitClk_o 1 1,504 v
& 4 dkgenfphyClk0_o 1 3,738 v
& S dkgen/fphyClk1_o 1 3,738 v
(-6 JokgenfusbCloo i fis;7 ] ]
& 7 dkgenfwbClk_o 1 1,502 v
& 8 mgtEnginefgt_usrck_source /DRPCLK_OUT 1 9 v
& 9 mgtEnginegt_usrdk_source/GTO_TXUSRCLK_OUT 1 211 v
& 10 mgtEngine/gt_usrck_source/GT2_TXUSRCLK_OUT 1 211 v
& 11  mgtEngine/gt_usrdk_source/GT4_TXUSRCLK_OUT 1 211 v
& 12 mgtEngine/gt_usrdk_source/GTS_TXUSRCLK_OUT 1 211 v
# Nets - Type is ‘Global Clock’ (12) x

Figure 45: Selecting the Global Clock

Moving and Resizing Pblocks

With an initial placement of the Pblocks, you can begin to rearrange the Pblocks to better
visualize the data flow through the design. This requires moving the Pblocks on the device, and
possibly resizing the Pblocks.

To better focus on the two usbEngine blocks that you identified for floorplanning, select and
clear the other Pblocks from the Physical Constraints window.

1.

In the Physical Constraints window, select pblock cpuEngine, pblock fftEngine,
pblock mgtEngine, pblock clkgen, and pblock wbArbEngine.

Right-click and open the popup menu, then select the Delete command.

This deletes the selected Pblocks, leaving only the usbEngine0 and usbEnginel Pblocks.
The other Pblocks helped you understand the data flow through the different modules of
the design, but you do not need them for the final floorplan.

In the Physical Constraints view, select the usbEngine0 Pblock, or select it directly in the
Device window.

4. Move the Pblock by dragging it to a location on the lower half of the Device view.
The placement you choose should seem appropriate based on the displayed connections
between the Pblocks and to the I/O ports. To reduce timing delay, you should place the
Pblock near the I/O ports to which it is connected.
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When you place the Pblock in its new location, the Move dialog box, shown in FIGURE 46,
prompts you to select which resource types in the new location to enable for use by the
Pblock.

rE]Move (==

0. New position of pblock pblock_usbEngine 1 endloses disabled
resource types. Which should be enabled?

| Selectal H Clear All_|

L OK [ Cancel

Figure 46: Move Pblock

5. Select OK to include all resource types in the moved Pblock.

6. Select the usbEnginel Pblock in the Physical Constraints view, or select it directly in the
Device window.

7. Move it by dragging it to the top half of the Device view.

Again, the placement of the Pblock should be based on its connections, and you will again
be prompted by the Move dialog box as seen in FIGURE 46.

With the usbEngine blocks placed approximately where you want them, in the upper and
lower half of the Device view, you must now resize the Pblocks to include the required
resources.

8. In the Physical Constraints view, select the usbEngine0 Pblock, or select it directly in the
Device window.

9. Right-click in the Device view to open the popup menu, and select the Set Pblock Size
command.

The cursor turns to a cross-hair.
10. Draw a rectangle over clock region X0Y1, on the left side the Device view.

The Set Pblock dialog box opens. If you have sized the rectangle along the clock region
borders, you are prompted to confirm the entire Clock Region as the resource for the
Pblock.
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If not, the tool prompts you to indicate the specific device resources available for use by the
Pblock, as shown in FIGURE 47.

f€] Set Pblock =25

e Which resources do you wish pblock_mgtEngine to constrain?

Grids
7] iicE -
7] DSP48 =
J|RAMB18
7] RAMB36 il
Select All Clear all
[ o [ coamcel |

Figure 47: Set Pblock Size

11. Click OK to accept either.

If a Choose LOC mode dialog box, as seen in FIGURE 48, opens during the move or resize, it
means that some logic cells were placed inside the Pblock, and they are now being moved
or resized out of the Pblock.

For this design some registers are embedded in the I/O pads. The placement of these cells
was not cleared during Clearing Placement Constraints because I/0 placement was not
cleared.

If a Pblock covers these I/Os, but then is moved or resized so they are not covered, the
PlanAhead tool prompts you to decide how these placement constraints should be handled.

12. For this tutorial, leave the LOCs in their original positions. Accept the default and click OK.

[€] Choose LOC mode

Description
Some location constraints are on sites being removed from the
PBlock. What should happen to them?

Action

@ Leave all location constraints in their current positiory

Delete location constraints outside new site ranges
Delete unfixed location constraints outside new site ranges

Delete all location constraints of the pblock

o ][ concd

Figure 48: Choose LOC Mode

13. Look at the Pblock Properties view, and click the Statistics tab.
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The Statistics tab of the Pblock Properties window, as seen in FIGURE 49, shows the Physical
Resource Estimates for the Pblock. These statistics display the following:

e The different site types available on the device in the area covered by the Pblock
e The amount of resources required by the logic assigned to the Pblock
e The current utilization %.

The red values indicate there are insufficient resources available to meet the requirements of
the design logic assigned to the Pblock. In this case, the Pblock must be resized to increase
its resources, or the design will not complete implementation.

Pblock Properties =02 X 1. Project Summary X &P Device X | i Schematic X .12 X
- O_,j > | "
3) pblock_usbEngine0

Physical Resource Estimates
Site Type Available Requred % Ut
e -

wr 5846 115
FD_LD 10224 4650 %6

748

SLICEM 530 60
DSP48E1 40

RAMBFIFO36E1 20

,J S &
oda
o

Carry Statistics
Number of carry chains  Longest chain
148 pblodk_usbEngine0 /usbEngine0/u 1fu3/M

Clock Report

Domain (Module) Resource  Instances
phyCko0_o( dock_generator ) Global 3737
usbCk_o( dock_generator ) Global 780
wbClk_o( dock_generator )  Global 184

Clock Region Statistics

CLOCKREGION  Pblock Sites in CR

X0Y0 2.2%

X0Y1 94.3% -
m +

General | Attributes = Statistics Instances | Connectivity | 4 » @

&» Sources | ] Nethst 2 Properties

Figure 49: Pblock with Insufficient Resources

14. Scroll down to the bottom of the Pblock Properties view and examine the information
provided.

15. Resize the usbEgine0 Pblock to cover Clock Regions X0Y0 and X0Y1, and click OK to
accept the Clock Regions as the Pblock range.

The Physical Resource Estimates in the Pblock Properties view should now reflect sufficient
resources for the required logic.

16. Select the usbEnginel Pblock and resize it to cover the two Clock Regions above the
usbEngine0 Pblock, Xx0Y2 and X0Y3.
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Pblock Properties — 0O 2 X% 2 Project Summary X & Device X ‘7 Schematic X & X
&k 2
i) pblock_usbEngine 1
Physical Resource Estimates =
Site Type Available  Required
wr 12000 5841 %9
FD_LD 24000 4650 20
SLICEL 2000 973 4“9
SLICEM 1000 488 9
BUFHCE 25 0 0
BUFIO 8 0 0
BUFMRCE 4 0 0
BUFR 8 0 0
DSP48E1 80 0 0
IDELAYCTRL 2 0 0
IDELAYE2 100 0 0
ILOGICE3 100 0 0
IN_FIFO 8 0 0
10833 4 0 0
10B33M 48 0 0
108338 48 0 0
IPAD 2 0 0
MMCME2_ADV 2 0 0
OLOGICE3 100 0 0
OUT_FIFO 8 0 0
PHASER _IN_PHY 8 0 0
PHASER_OUT_PHY 8 0 0 =
PHASER_REF 2 0 0
General Attributes = Statistics | Instances | Connectivity | ¢ » B
as Sources | ] Netiist # Clock Regions 2 Properties

Figure 50:Pblocks with Sufficient Resources

Your design should now look like FIGURE 50. The two Pblocks are placed and sized
appropriately, and you are now ready to run the floorplan through place and route.
However, you first need to save the Pblock constraints.

17. Select File > Save Constraints As, as shown in FIGURE 51, and click OK.

E] Save Constraints As @

o Save design as a new Constraint Set.

Spedify Constraint Set
New Constraint set name:  fonstrs_4

V| Make active

[ ok [ cancel

Figure 51: Save Constraints As

When you save as this configuration you leave the current implementation constraints alone,
and save the new floorplan constraints to a new constraint set. This preserves the prior
implementation results, while allowing you to move forward with your new floorplan.

O TIP: Notice the dialog default settings will create a new constraint set and make it active for the next
run. This method will preserve your original constraints files

18. In the top right of the Implemented Design view banner, click X to close the view.
19. Click OK to exit, and click No if prompted to save.

The Implemented Design closes, and the PlanAhead tool returns to the Project Manager.
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Step 4: Implementing the Floorplan

The PlanAhead tool saves the floorplan in the top full.ucf constraints file in the new
constraint set, constrs_4. You can now implement the design with the floorplan constraints to
improve the timing of the design.

1. In the Sources view, double-click top full.ucf in constrs 4 to open the file in the Text
Editor.

Notice the format of the original UCF constraints file was maintained. The tool added the
AREA GROUP constraint at the bottom of the file.

2. Scroll to the bottom of the file and notice the new AREA GROUP lines.

These lines constrain the hierarchical modules, and logic from those modules, to regions of
the device, and to resources within those regions.

3. Close the top full.ucf filein the Text Editor.

Recall that you created multiple implementation runs earlier in this tutorial, in
CREATING IMPLEMENTATION RUNS. You now use one of those runs to implement the design
with the floorplan constraints.

4. 1In the Design Runs view, select the impl 2 run.
5. With the run selected, look at the Implementation Properties view.

The Implementation Properties view displays the properties of the selected run, as shown in
FIGURE 52. If the Properties view is not open, you can use the Window > Properties
command to open it.

Implementation Run Properties | [ Ea oS
| [@Apply || [#Cancel |

= impl_2*

Name: impl_2

Part: @ xc7k70tfbg676-2 (active) [j

Description: MAP Timing Driven High Effort Norn
Status: Not started

Synthesis run: | ¥ synth_1 ]

Constraints: &z constrs_4 (active) v

General | Attributes | Options | Log | Reports | Messages | Partitions

Figure 52: Implementation Properties

6. Change the Constraints field to select the constrs 4 constraint set.

Note: If you did not complete, or save the floorplan from the previous steps, constraint set
constrs_3includes a completed floorplan in the top fpln.ucf constraints. You can select
constrs_3 here if needed.

7. In the Implementation Properties view, click the Apply button as shown in FIGURE 52.
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8. With impl 2 selected in the Design Runs view, right-click to open the popup menu and
select Make active.

9. From the Flow Navigator menu, select Run Implementation.

This launches the implementation run with the usbEngine blocks placed according to your
floorplan. The Implementation Completed dialog box displays when the run is finished.

10. In the Implementation Completed dialog box, select Open Implemented Design, and
click OK.

The design has been implemented with the floorplan you created for the usbEngine
blocks. You can see this by highlighting the blocks as you did earlier in this tutorial.

11. In the Netlist window, select usbEngine0 and usbEnginel.
12. Right-click for the popup menu, and select Highlight Primitives > Cycle Colors.

You can see the new placement implemented as a result of the floorplan strategy you
developed in this tutorial. You can compare it to the prior placement results from the first
implementation pass. See FIGURE 53 for current results, and Figure 32 for prior results.

Netiist e 2 [ Ll % Project Summary X &9 Device X B52 %
= =
15 top
* Nets
3 Primitives (15
+-{@] dkgen
+-{@] cpuEngine
+-[d] fftEngine (ff
+-{@] mgtEngine
+- & usbEngine0
+)-{#] usbEngine1
+)-[@] wbArbEngine
s Sources [} Netlist
Instance Properties A X
& OJ b
A usbEngined
Name: usbEngine0
Pblock: (@ pblock_usbEngined |
Cell: usbf_top
Type: Others
Number of instance pins: 166
Number of nets: 166
General | Attributes | Statistics | Instance Pins  Chic q » @

Figure 53: Implemented Floorplan

13. Select File > Exit and click OK to confirm.

The PlanAhead tool closes.
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Conclusion

In this tutorial, you used the PlanAhead software to explore and analyze the synthesized design
and targeted device prior to running the implementation tools. This enabled you to find
potential design issues and errors early in the design cycle, rather than discovering issues during
implementation. In addition, you used the graphical presentation of design resource estimates,
design rule violations, timing estimation, constraints, and connectivity to help you understand
your design and any potential areas with issues.

After running the design through the synthesis and implementation tools, you:

Viewed implementation results and examined timing results.

«Analyzed critical path objects in the schematic, and selected the parent modules of those
path objects.

Highlighted module placement and displayed the connectivity of the modules using the
Show Connectivity command.

Analyzed placement and routing of critical timing paths.
Floorplanned the possible placements based upon the hierarchy of the design.

Implemented the floorplanned design.
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