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Quick Front-to-Back Overview Tutorial 

Introduction 

This tutorial provides a quick introduction to some of the capabilities and benefits of using the 

Xilinx® PlanAhead™ design tool. The PlanAhead tool can be used during various stages of the 

design process for a variety of purposes. 

Many of the PlanAhead tool analysis features are covered in more detail in other tutorials. Not 

every command or command option is represented here. This tutorial uses the features 

contained in the PlanAhead design tool product, which is bundled as a part of the ISE® Design 

Suite. 

Tutorial Design Description 

The small sample design used throughout this tutorial consists of a design called bft. There are 

several VHDL and Verilog source files in the bft design. 

The design targets an xc7k70t device. A small design is used to allow the tutorial to be run with 

minimal hardware requirements and to enable timely completion of the tutorial, as well as to 

minimize the data size. 

Software Requirements 

The PlanAhead tool is installed with ISE Design Suite software. Before starting the tutorial, be 

sure that the PlanAhead tool is operational, and that the tutorial design data is installed.  

For installation instructions and information, see the ISE Design Suite 14: Release Notes, 

Installation, and Licensing (UG631). 

Hardware Requirements 

Xilinx recommends a minimum of 2 GB of RAM when using the PlanAhead tool on larger 

devices. For this tutorial, a smaller xc7k70t design is used, and the number of designs open at 

one time is limited. Although 1 GB is sufficient, it can impact performance.  

http://www.xilinx.com/cgi-bin/docs/rdoc?v=14.5;t=release+notes
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Preparing the Tutorial Design Files 

Copy the files from the ISE software installation area: 

<ISE_install_area>/ISE_DS/PlanAhead/examples/PlanAhead_Tutorial.zip 

Extract the zip file contents into any write-accessible location which will be referred to in this 

tutorial as the extraction directory, or <Extract_dir>.  

 

 

RECOMMENDED: The tutorial sample design data is modified while performing this 

tutorial. A new copy of the original PlanAhead_Tutorial data should be extracted each time 

you run this tutorial. 
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Lab 1: Front-to-Back Overview 

Step 1: Creating a New Project 

PlanAhead tool enables several types of projects to be created depending on where in the 

design flow the tool is being used. Register Transfer Level (RTL) sources can be used to create a 

project for development and analysis, synthesis, implementation and BIT file creation.  

 On Windows, double-click the Xilinx PlanAhead 14.4 Desktop icon, or select: 

Start > All Programs > Xilinx  Design Tools > ISE Design Suite 14.4 > PlanAhead > 

PlanAhead1 

 On Linux, change the directory to 

<Extract_Dir>/PlanAhead_Tutorial/Tutorial_Created_Data, and type 

planAhead. 

The PlanAhead Getting Started page opens with links to create new projects, open existing or 

example projects, and view the documentation. 

 

Figure 1: Getting Started Page  

                                                 

1 Your installation may not be called Xilinx Design Tools on the Start menu. 



  

Quick Front-to-Back Overview Tutorial  www.xilinx.com  8 

UG673 (v14.5) April 10, 2013 

Creating a new RTL Project  

This step uses RTL Source Files from the Tutorial directory: 

<Extract_Dir>/PlanAhead_Tutorial/Sources/hdl 

 Select the Create New Project link on the Getting Started page. 1.

The Create a New PlanAhead Project confirmation dialog box opens. 

 Click Next. 2.

The Project Name page opens. 

 

Figure 2: New Project Name and Location Page 

 Set the Project location to: 3.

<Extract_Dir>/PlanAhead_Tutorial/Tutorial_Created_Data. 

 Enter the Project name: project_bft, then click Next. 4.

The Design Source page opens. 
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Figure 3:  New Project Design Sources 

 Click the RTL Project option, and then click Next. 5.

The Add Sources page opens. 

Adding Source Files 

 Click the Add Files button and browse to the following directory: 1.

<Extract_Dir>/PlanAhead_Tutorial/Sources/hdl 

 Press the Ctrl key to select async_fifo.v, bft.vhdl, bft_tb.v, and FifoBuffer.v, and click OK. 2.

 Set the simulation test bench file bft_tb.v as a Simulation only source file. 3.

 Click on the Synthesis and Simulation entry in the HDL Source for field for bft_tb.v and 4.

select Simulation only.  

 Click the Add Directories button, and browse to select the following directory:  5.

<Extract_Dir>/PlanAhead_Tutorial/Sources/hdl/bftLib. 

 Set the VHDL Library for all of the sources in the bftLib directory. 6.

 Click on the work entry in the Library field for bftLib, and type bftLib. 7.

 If needed, click these two checkboxes to select Copy Sources into Project, and Add 8.

Sources from Subdirectories. 

 Verify that the page looks like the following figure. 9.
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Figure 4: New Project: Selecting Sources to Add to the Project 

 Click Next.  10.

The Add Existing IP page opens. You can select existing IP (Intellectual Property) from CORE 

Generator™ software .xco project files. However, this tutorial does not include importing IP 

into the project. 

 Click Next. 11.

The Constraints Files page opens.  

Adding a Constraint File 

 Click the Add Files button, browse to select the following file: 1.

<Extract_Dir>/PlanAhead_Tutorial/Sources/bft_full.ucf 

 Click OK. 2.

The bft_full.ucf file appears in the Add Constraints dialog box.  
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Figure 5: New Project: Adding Constraint Files 

 Make sure the Copy constraints into project checkbox is enabled.  3.

 Click Next.  4.

The Default Part page opens. 

Selecting a Default Part 

 In the Filter section, click the Family pull-down menu and select Kintex-7. 1.

Notice the list is filtered to only show Kintex®-7 devices. 

 In the Search field, type 70t.  2.

Notice the 70t devices listed. 

 Select the xc7k70tfbg484-2 device, and click Next. 3.
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Figure 6: New Project: Selecting a Family and Default Part 

 Review the New Project Summary page, and click Finish. 4.

 

Figure 7: New Project Summary 

The PlanAhead environment opens. The Flow Navigator is located on the left edge. It will be 

used throughout the rest of the tutorial to explore and implement the design. 
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Figure 8: PlanAhead Environment 
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Step 2: Using the Sources View and the Text Editor 

The PlanAhead tool allows different file types to be added as design sources including Verilog, 

VHDL, NGC format cores, UCF/NCF constraint files, and specific simulation sources. The files 

display by Hierarchy, Library or Compile Order in the Sources view. A text editor is supplied to 

create or develop RTL sources. Third party text editors can also be configured. 

Exploring the Sources View and Project Summary 

 Look at the information presented in the Project Summary. This window is updated as the 1.

design progresses through the design flow. 

 In the Sources view, click on the ‘+’ icon to expand the bft module. 2.

You can see the various RTL source files that you added when you created the project. 

Remember, you added RTL files and the bftLib directory, and its sub-directories.  

 In the Sources view, click on the ‘+’ icon to expand the Constraints folder. 3.

 

Figure 9: Viewing Sources 

In the Sources view the Design Sources folder helps keep track of VHDL and Verilog source 

files. Notice the Hierarchy tab is displayed by default, showing the design hierarchy. The 

Filter Sources by Missing Files or Instantiations button is disabled, which means the 

displayed hierarchy is complete. If this were enabled, you could use it to resolve any missing 

source files in your design.  

The Source types are broken out into separate folders for Design Sources, Constraints, 

Simulation Sources, IP, etc. In the Libraries tab, sources are grouped by file type, while the 
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Compile Order tab shows the file order used for synthesis. Any IP in the project would be 

shown in a separate IP tab in the Sources view. 

Opening the Text Editor 

 Select one of the VHDL sources in the Sources view. 1.

 Right-click to review the commands available in the Sources view popup menu.  2.

 Select Open File, and use the scroll bar to browse the text in the Text Editor. 3.

 

TIP: Alternatively, you can double-click on source files in the Sources view to open them in the Text 

Editor. 

 With the cursor in the Text Editor, right-click and select Find in Files.  4.

The Find in Files dialog box opens with various search options.  

 

Figure 10: Using the Find in Files Command 

 Type clk, and click Find. 5.

The Find in Files view displays in the messaging area at the bottom of the PlanAhead 

environment. 
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Figure 11: Viewing the Find in Files Results 

 In the Find in Files view, expand and select one of the occurrences of clk and notice that 6.

the source file is opened in the Text Editor, and the specific occurrence is highlighted. 

 Close the Find in Files view. 7.

 Close each of the open RTL file tabs in the Text Editor. 8.

The PlanAhead tool also includes an RTL analysis and IP customizing environment. This 

environment is covered in the RTL Design and IP Generation Tutorial: PlanAhead Design Tool 

(UG675).  

When you click the Open Elaborated Design button under RTL Analysis in the Flow Navigator, 

the RTL design is elaborated, enabling various views of the design including an RTL Netlist, 

Schematic view, Hierarchy view, and estimated resource statistics. The different views have a 

“cross-select” feature, which helps you to debug and optimize the RTL design. There are also 

several RTL Design Rule Checks (DRCs) to check for areas to improve performance or power. 

The Xilinx IP Catalog provides access to the Xilinx CORE Generator™ tool to generate IP. You can 

sort and search the Catalog in a variety of ways. IP can be customized, generated, and 

instantiated.  

Step 3: Simulating the Design 

The PlanAhead tool is integrated with the Xilinx ISim logic simulation environment. The 

PlanAhead tool enables you to add and manage synthesis sources in the project. You can 

configure simulation options and create and manage various simulation source sets. You can 

launch behavioral simulation prior to synthesis using RTL sources and launch timing simulation 

post-implementation. 

The Behavioral Simulation command configures and launches a single ISim run, which is the 

basic flow used in this tutorial. It can be accessed in the Flow Navigator view on the left side of 

the PlanAhead environment, shown in the following figure. 

http://www.xilinx.com/cgi-bin/docs/rdoc?v=14.5;d=PlanAhead_Tutorial_RTL_Design_IP.pdf
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Figure 12: Launching Behavioral Simulation 

 Select Project Settings from the top of the Flow Navigator. 1.

Notice the simulation related options in the General Options dialog such as Language 

Options. 

 Select the Simulation icon on the left to view Simulation specific options. 2.

 Toggle the Target simulator field to notice the choices of QuestaSim/ModelSim or ISim 3.

Simulator.  

 

Figure 13: Launching Behavioral Simulation 

 Select ISim Simulator. 4.
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 Examine the various options of the Project Settings dialog box and click Cancel. 5.

 In the Flow Navigator, select Run Behavioral Simulation. 6.

The Launch Behavioral Simulation dialog box opens.  

 

Figure 14: Launch Behavioral Simulation 

 If bft_tb is not specified as the Simulation Top Module Name, click the browse button  , 7.

and select bft_tb, and click OK. 

 Click the Options button. 8.

The Simulation Options dialog box opens.  

 

Figure 15: Simulation Options 

Notice the various options on the Compilation tab. 

 Click the Simulation tab and the Advanced tab, and examine the various options.  9.

 Click Cancel. 10.
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 Click Launch to invoke the ISE Simulator (ISim) simulation environment. 11.

The ISim simulation environment opens. 

 

Figure 16: ISim Simulation Environment 

Editing RTL source files in the ISim environment results in the PlanAhead source files being 

updated as well. The two tools are referencing the same source files. Refer to the ISim In-Depth 

Tutorial (UG682), for information about using ISim. 

 In ISim, select File > Exit and click the Yes button if prompted to close ISim.  12.

  

http://www.xilinx.com/cgi-bin/docs/rdoc?v=14.5;d=ug682.pdf
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Step 4: Synthesizing the Design 

The PlanAhead tool enables one or more synthesis runs to be configured, launched, and 

monitored, either sequentially or simultaneously. 

The Synthesize command configures and launches a single run which is the basic flow used in 

this tutorial. It can be accessed in the Flow Navigator view on the left side of the PlanAhead 

Environment. 

 

Figure 17: Flow Navigator - Synthesize Drop Down Menu 

The Flow Navigator launches all major design compilation processes including synthesis, 

implementation, and generate bitstream. Optionally, it also lets you open the Elaborated RTL 

Design, the Synthesized Design, and the Implemented Design results to enable design analysis 

and constraints assignment at each phase of the design process. 

Exploring Synthesis Options 

 In the Flow Navigator, select Synthesis Settings. 1.

The Synthesis Project Settings dialog box opens. 

 Review the available options. 2.

 Click the Strategy drop-down menu and review the available Synthesis Strategies 3.

 Click Cancel. 4.
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Figure 18: Synthesis Settings 

Running Synthesis 

 In the Flow Navigator click Run Synthesis to launch the run. 1.

Notice the Status bar in the upper right corner displays Running XST, which indicates that 

synthesis is now running. Clicking the Cancel button halts the synthesis run and removes run 

data. 

The Log view displays the output messages from the ISE commands, and the Messages view 

displays a filtered list of Warnings and Errors. Clicking on the Synthesis messages in the 

Messages view opens the RTL file and displays the corresponding line of RTL code that the 

message is referencing. 

 

TIP: Right-clicking on Synthesis in the Flow Navigator displays a menu of additional 

commands and launch options. 

 When the synthesis run completes, select Open Synthesized Design in the Synthesis 2.

Completed dialog box and click OK. 

 If prompted, click Yes to close the RTL Design. 3.
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The PlanAhead Synthesized Design environment displays with the synthesized netlist, target 

part, and active constraint set applied.  

 

Figure 19: Opening the Synthesized Design 

 

TIP: Right-clicking on Synthesis in the Flow Navigator and selecting the New Synthesized 

Design command enables additional Synthesized Designs to be opened simultaneously 

with different netlists, constraints, or target devices. 

Viewing the Synthesis Report 

 Click the Reports view tab at the bottom of the PlanAhead environment. 1.

If there is no view tab available, select Window > Reports. 

 Double-click the XST Report to view the XST report in the Workspace. 2.

 To examine the XST report scroll, through the report. 3.
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 Close the XST Report by clicking on the X in the view tab. 4.

The PlanAhead tool also includes a ChipScope™ debug core insertion environment. This 

environment is covered in the PlanAhead Software Tutorial: Debugging with ChipScope 

(UG677). You can use the PlanAhead features to explore and select logic signals to debug. 

The debug cores can be configured, implemented, and automatically added into the top 

level design netlist. The cores are also maintained through design netlist iterations. 

The PlanAhead tool provides a powerful design analysis and floorplanning environment to 

explore and experiment with the design. This environment is covered in the Design Analysis 

and Floorplanning Tutorial: PlanAhead Design Tool (UG676). 

Notice the available commands in the Flow Navigator under Synthesized Design. 

 Select Tools from the PlanAhead main menu and examine the available commands. 5.

 Select I/O Planning from the View Layout pull-down menu in the toolbar at the top of the 6.

PlanAhead environment. 

 

Figure 20: Opening the I/O Planning View Layout 

There are several different layouts of the tool views available to help you perform different 

design tasks. For example, the I/O Planning layout provides views to enable I/O pin 

exploration and constraint assignment. The Design Analysis layout provides views to analyze 

the logic in the design and apply constraints. You can also create and display custom 

layouts.  The last layout selected will be used by default the next time that design is opened. 

Note: The I/O planning environment is covered in the I/O Pin Planning Tutorial: PlanAhead 

Design Tool (UG674). 

 Examine the various views and information presented, for example the Package view in the 7.

workspace and the I/O Ports view. 

 Select Default Layout from the same pull-down menu in the toolbar. 8.

You can close the Synthesized Design environment after your analysis and constraint definition 

completes. This helps preserve system memory and avoids having multiple editing environments 

open simultaneously. For the purposes of this tutorial, it is left open. You can Click the Close 

button in the view banner or select Close from the Synthesis pull-down menu in the Flow 

Navigator to close the Synthesized Design. 

http://www.xilinx.com/cgi-bin/docs/rdoc?v=14.5;d=PlanAhead_Tutorial_Debugging_w_ChipScope.pdf
http://www.xilinx.com/cgi-bin/docs/rdoc?v=14.5;d=PlanAhead_Tutorial_Design_Analysis_Floorplan.pdf
http://www.xilinx.com/cgi-bin/docs/rdoc?v=14.5;d=PlanAhead_Tutorial_IO_Pin_Planning.pdf
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Step 5: Implementing the Design 

The PlanAhead tool provides the flexibility for experimenting with implementation options. You 

can apply multiple implementation Strategies to multiple runs to find the best performing 

results. 

Exploring Implementation Options 

 In the Flow Navigator, select Implementation Settings. 1.

The Implementation Project Settings open.  

 

Figure 21: Implementation Settings 

Notice the ability to configure the Constraint Set to be applied to the run. 

 Examine the Implementation Options 2.

 Click the Strategy drop-down menu and review the available Implementation Strategies and 3.

click Cancel. 
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Launching Implementation 

 In the Flow Navigator, click Run Implementation to launch the run. 1.

Notice the Status in the upper right corner displays Running NGDBuild, indicating that ISE 

implementation is now in progress. 

The Log view displays the output of the ISE commands, and the Messages view displays a 

filtered list of Warnings and Errors. 

The implementation run is processed in the background, so that you can continue with other 

design tasks in necessary. While the run is implementing, you could click any of the post-

synthesis analysis features such as timing, power, and utilization reporting in the Flow 

Navigator. 

 After the Run completes, select the Open Implemented Design option in the 2.

Implementation Completed dialog box, and click OK. 

 Click Yes to close the Synthesized Design before opening the Implemented Design. 3.

Step 6: Analyzing the Results 

The PlanAhead tool enables placement and timing results to be imported quickly for analysis 

from any of the completed runs. The PlanAhead tool imports placement and displays it in the 

form of “unfixed” LOC placement constraints. The TRACE timing results display in the Timing 

view.  

For more information about Design Analysis and Floorplanning, see Design Analysis and 

Floorplanning Tutorial: PlanAhead Design Tool (UG676). 

The PlanAhead environment displays the loaded implemented design, seen in Figure 23. 

Clicking the Open Implemented Design button in the Flow Navigator also opens the 

Implemented Design environment. There are options in the pull-down menu for opening 

Implemented Designs with different run results. 

Notice the placement is imported into the Device view and the TRACE timing results are 

displayed in the Timing view. Your results might differ from those shown in Figure 23. 

 Click the Reports view tab at the bottom of the PlanAhead environment. 1.

If there is no Reports view available, select Window > Reports. 

 Double-click on the MRP Report and examine scrolling through the report. 2.

 Close the MRP Report by clicking the X button in the Workspace view tab. 3.

 

http://www.xilinx.com/cgi-bin/docs/rdoc?v=14.5;d=PlanAhead_Tutorial_Design_Analysis_Floorplan.pdf
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Figure 22: Opening the Implementation Results 

 In the Device view, click the Hide/Show I/O Nets button  to turn on the I/O connectivity. 4.

 In the Device view, click the Hide/Show I/O Nets button  to turn off the I/O connectivity. 5.

 Click the Timing view tab and, select the top timing path. 6.

The path is highlighted in the Device view and the logic objects on the path are selected in 

other views. 
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Figure 23: Highlighting Timing Paths 

  7.

  7.

 In the Path Properties view banner, click the Maximize button . 7.

The Path Properties view displays in full screen. 
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Figure 24: Viewing Path Properties 

Notice the Path Properties report looks very similar to the TRACE report. Selecting any of the 

Logical Resources or Locations (e.g. SLICE_X36Y79) selects the logic object or site for viewing 

in Device or other view window. 

 Click the Restore button  in the Path Properties view banner to bring the view back to 8.

the original location. 

 In the Timing view, make sure the first path is still selected and click the Schematic button 9.

from the view toolbar  or select the command from the popup menu. 

The Schematic view opens. 
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Figure 25: Viewing Timing Paths in the Schematic 

Notice that the schematic displays the logic objects on the selected paths as well as the 

logical hierarchy. This helps identify logic modules for floorplanning. It also displays links to 

find the Nets and Instances displayed in the current view.  

 

TIP: The PlanAhead tool also includes a design analysis and floorplanning environment. This 

environment is covered in the Design Analysis and Floorplanning Tutorial: PlanAhead Design Tool 

(UG676). You can use the analysis features to explore the design or the implementation results. You 

can apply constraints aimed at better and more consistent results. 

 Close the Schematic view. 10.

 Experiment with the various analysis features under Implemented Design in the Flow 11.

Navigator. 

  

http://www.xilinx.com/cgi-bin/docs/rdoc?v=14.5;d=PlanAhead_Tutorial_Design_Analysis_Floorplan.pdf
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Step 7: Creating the Bitstream File 

 Click Bitstream Settings in the Flow Navigator. 1.

The Bitgen Project Settings open. 

 

Figure 26: Bitstream Settings 

 Select Cancel. 2.

 Click Generate Bitstream in the Flow Navigator. 3.

The Running Bitgen progress bar opens. When the Bitstream is generated, a dialog box 

opens to inform you that the bitstream was successfully generated.   
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Figure 27: Bitstream Generated 

 Click the OK button to dismiss the dialog box and open the Reports view. 4.

 In the Flow Navigator, notice that you can launch ChipScope Analyzer and the iMPACT 5.

programming tool after a bitstream file is generated. 

 

Figure 28: Project Summary of Implemented Design 
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Reviewing the Project Summary for the Implemented Design 

 Select the Project Summary tab, and review the information presented. 1.

 Close the PlanAhead tool by selecting File > Exit, click Yes to save, and OK. 2.

Conclusion 

In this tutorial, you: 

 Used a small PlanAhead RTL project to step quickly through the basic PlanAhead design 

flow, starting by creating an RTL project, and exploring RTL sources in the Text Editor.  

 Reviewed the simulation options and launched ISim.  

 Reviewed the various synthesis run options, ran synthesis. 

 Imported the results by opening the synthesized design.  

 Explored implementation options 

 Ran implementation.  

 Monitored run results and viewed command report files.  

 Imported run results, and analyzed a timing path.  

 Created a bitstream file. 
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