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RTL Design and IP Generation Tutorial 

Introduction 

This tutorial provides an overview of the Register Transfer Level (RTL) development and analysis 

environment, in which you will: 

 Import RTL sources and review them using the Text Editor 

 Run Behavioral Simulation on the bft module 

 Run elaboration to compile the RTL 

 Use a variety of RTL analysis features to explore your compiled RTL design. These include: 

 Analyze the RTL logic hierarchy using the RTL schematic 

 Estimate RTL resources 

 Run RTL Design Rules Checks (DRCs)  

 Browse the Xilinx® IP Catalog, and customize and implement an Intellectual Property (IP) 

core in the design 

Many of the PlanAhead™ software analysis features are covered in more detail in other tutorials. 

Not every command or command option is covered.  

The objective of this tutorial is to familiarize you with the RTL development and analysis process 

using the PlanAhead tool. 

Tutorial Design Description 

The small sample design used in this tutorial includes: 

 A RISC processor CPU core 

 A pseudo FFT 

 Four gigabit transceivers (GTs)  

 Two USB interfaces 

The design targets an xc7k70t device. A small design is used to: 

 Allow the tutorial to be run with minimal hardware requirements 

 Enable timely completion of the tutorials 

 Minimize data size 
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Software Requirements 

The PlanAhead tool is installed with ISE Design Suite software. Before starting the tutorial, be 

sure that the PlanAhead tool is operational, and that the tutorial design data is installed.  

For installation instructions and information, see the ISE Design Suite 14: Release Notes, 

Installation, and Licensing (UG631). 

Hardware Requirements 

Xilinx recommends a minimum of 2 GB of RAM when using the PlanAhead tool on larger 

devices. For this tutorial, a smaller xc7k70t design is used, and the number of designs open at 

one time is limited. Although 1 GB is sufficient, it can impact performance.  

Preparing the Tutorial Design Files 

Copy the files from the ISE software installation area: 

<ISE_install_area>/ISE_DS/PlanAhead/examples/PlanAhead_Tutorial.zip 

Extract the zip file contents into any write-accessible location which will be referred to in this 

tutorial as the extraction directory, or <Extract_dir>.  

 

 

RECOMMENDED: The tutorial sample design data is modified while performing this 

tutorial. A new copy of the original PlanAhead_Tutorial data should be extracted 

each time you run this tutorial. 

 

  

http://www.xilinx.com/cgi-bin/docs/rdoc?v=14.5;t=release+notes
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Lab 1: RTL Design 

Step 1: Creating a New RTL Project 

The PlanAhead tool lets you create several project types depending on where in the design flow 

the tool is being used. RTL sources can be used to create a project for development and 

analysis, synthesis, implementation, and bit file creation. 

Opening the PlanAhead Tool 

Open the PlanAhead tool: 

 On Windows, select the Xilinx PlanAhead 14.5 desktop icon or: 

Start > All Programs > Xilinx Design Tools > ISE Design Suite 14.5 > PlanAhead > 

PlanAhead 

 On Linux, change the directory to 

<Extract_Dir>/PlanAhead_Tutorial/Tutorial_Created_Data, and type 

planAhead. 

The PlanAhead Getting Started page opens, providing links to open or create projects, and view 

the documentation. 

 

Figure 1: Getting Started Page  
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Creating a New RTL Project 

 On the Getting Started page, select the Create New Project link. 1.

 In the Create a New PlanAhead Project confirmation dialog box, click Next. 2.

The Project Name page opens:  

 

Figure 2: Entering the New Project Name 

 Enter the Project name: project_rtl. 3.

 For Project Location, browse to, and select: 4.

<Extract_Dir>\PlanAhead_Tutorial\Tutorial_Created_Data. 

 Click Next to open the Project Type page, as shown in Figure 3. 5.

 

Figure 3: Project Type 
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 Select Specify RTL Project, and click Next. 6.

The Add Sources page opens: 

Adding Source Files 

 

Figure 4: New Project: Add Sources Dialog Box 

 Click Add Directories, browse to: 1.

<Extract_Dir>/PlanAhead_Tutorial/Sources/hdl  

 Verify that the following checkboxes are selected: 2.

 Copy sources into project. 

 Add sources from subdirectories. 

 Check that the Add Source dialog box matches what is shown in Figure 4, and click Next. 3.

The Add Existing IP page opens.  

 Click Next to skip past this since you will not be adding any IP at this time. 4.

The Add Constraints Files page opens: 
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Adding a Constraints File 

 

Figure 5: Selected Constraint File to Add to the Project 

 Click Add Files and browse to select the following file:  1.

<Extract_Dir>/PlanAhead_Tutorial/Sources/top.ucf 

 Click OK.  2.

 Ensure the Copy constraints into project option is set to on, and click Next. 3.

The Default Part page opens. 
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Selecting a Default Part 

 In the Filter section, click the Family pull-down menu, and select Kintex-7.  The list is 1.

filtered to only show Kintex®-7 devices  

 In the Search field type 70t. The 70t devices are listed. 2.

 

Figure 6: Selecting a Family and Default Part 

 Select xc7k70tfbg676-2 and click Next. 3.

 Review the New Project Summary page, and click Finish. 4.

 The PlanAhead environment opens. 
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Figure 7: Default View Layout 

Step 2: Managing Source Files 

The PlanAhead tool allows different file types to be added as design sources, including Verilog, 

VHDL, and NGC format cores. The files are listed by category in the Sources view.  

Exploring the Sources View and Project Summary 

 Examine the information currently displayed in the Project Summary of the new project. 1.

More information is displayed as the design progresses through the design flow.  

 Examine the Sources view as shown in Figure 8. 2.
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Figure 8: Viewing the Hierarchy 

The Hierarchy tab of the Sources view is displayed by default. The Design Sources folder 

currently lists round_2 as the top module of the design, as indicated by the hierarchy 

icon. The PlanAhead tool will automatically determine the top module; however, at this time 

many of the source files in the project are not properly defined, preventing this feature from 

being successful. The bft.vhdl file references entities from the bftLib, however several 

VHDL files have incorrect library names which prevent the entities from being found as 

shown by the missing file  icon in Figure 8. You need to correct the Library names in order 

for the design to compile and display the correct hierarchy. 

Setting VHDL Library Names 

VHDL Library names can be set for individual files or for directories when using the Add Sources 

dialog box. When you created this project, you added the hdl directory while adding source 

files. This included the bftLib subdirectory, but you did not specify the Library Name for the 

files in that directory at that time. You will do that now.  

 Click the Libraries tab. 1.

 Expand the Work and Unreferenced folders in the VHDL folder. 2.

 Hold the Ctrl key and select bft_package.vhdl, round_1-4.vhdl, and core_transform.vhdl 3.

 Right-click to open the popup menu, and select the Set Library command. 4.

 Enter the Library Name: bftLib. 5.
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Figure 9: Setting VHDL Library Names 

 Click OK. 6.

 Verify that the VHDL folder now looks as shown in Figure 10.  7.

 

Figure 10: VHDL Library 

Configuring Simulation Source Files 

 In the Libraries tab of the Sources view, expand the Verilog folder and the work subfolder.  1.

 Scroll to the bottom of the work folder and expand the Unreferenced folder. 2.

You should see the bft_tb.v source file. It is a simulation test bench and needs to be set to 

Simulation Only.  
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 Select the bft_tb.v file and right-click to select Move to Simulation Sources. 3.

 Click the Collapse All button   in the Sources view header. 4.

 Expand the sim_1 folder under Simulation-Only Sources. 5.

The test bench file is now shown as unreferenced under the Simulation-Only Sources 

folder. The file will become a referenced file when it is set as the top file for simulation in a 

later step.  

 

Figure 11: Viewing the Simulation-Only Sources 

Defining Global Include Files 

 In the Sources view header, click the Search button.  1.

 In the Search field, enter timescale. 2.

Notice that only files with that name appear. 

 Select the Verilog timescale.v file, and right-click it to select Set Global Include. 3.

Notice that the file displays under the new Global Include folder. This insures that the 

same`timescale directive is included for all Verilog source files.  
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Figure 12: Set Global Include  

 In the Sources view header, click the Search button  to close the Search field and to 4.

display all files. 

Setting Compilation Order  

The PlanAhead tool will automatically select a top module, and order and display source files 

based on compilation order required by the top module. However, you can also manually 

specify a top module.  

 In the Sources view, click the Hierarchy tab. 1.

 

Figure 13: Hierarchy with Top Module 
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Notice that the design hierarchy now displays as shown in Figure 13. When the VHDL library, 

bftLib, was properly defined, and the various entities and modules referenced by the 

design could be located, the PlanAhead tool identified the top module of the design, and 

sorted the source files for compilation according to the requirements of that top module.  

 In the Hierarchy tab of the Sources view, expand the top module, and select the mgtEngine. 2.

 

Figure 14: Specifying the Top Module  

 Right-click to open the popup menu, and select Set as Top  3.

The mgtEngine block is defined as the top-module in the Sources view, and is marked by 

the hierarchy icon  as shown in Figure 14, indicating it is now the top-level of the 

hierarchy.  

 In the Sources view, select the Compile Order tab. 4.

You will notice that the required source files and the compile order of those files are 

updated based on the new top module.  

Note: The Compile Order tab displays source files in the order in which they will be 

compiled, first to last. The top module is usually the last. 

To manually enable or disable a file, select the file, right-click to open the popup menu, and 

select Enable File or Disable File. To manually change the Compile Order, select the file, 

right click, and select Move to Top, Move Up, Move Down, or Move to Bottom.  

If you move or reorder files in the Compile Order tab, the PlanAhead tool may prompt you 

to enable manual compile order as shown in Figure 15. You can also turn on manual compile 

order by setting the Hierarchy Update mode from the popup menu of the Hierarchy tab of 

the Sources view.  
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Figure 15: Enable Manual Compile Order 

 Select the Hierarchy tab in the Sources view. 5.

 Right-click in the Sources view, select Hierarchy Update.  6.

Examine the three different update modes that are available, ranging from fully automatic to 

completely manual file control. 

 Hit the Esc key to cancel the context menu. 7.

For this exercise though, you will now restore the top module.  

 Select the top module, right-click and select Set as Top. 8.

The source file and compile order should be updated to reflect the restored top module. 

 In the Sources view, Select one of the VHDL or Verilog files, right-click to examine the 9.

available popup menu commands for source files. To dismiss it, press the Esc key. 

 In the Sources view, double-click a VHDL or Verilog source file to open it in the Text Editor. 10.

 Right-click in the Text Editor to view the available popup commands. 11.

 Close the Text Editor by clicking on the X in the view tab. 12.

Creating a New RTL Source File and Importing a Template 

The PlanAhead tool enables you to create new Verilog or VHDL source files. Xilinx provides 

standard language templates for you to use as a starting point for a variety of logic and code 

constructs. 

 In the Flow Navigator under Project Manager, select Add Sources. 1.

 In the Add Sources dialog box, select Add or Create Design Sources, and click Next. 2.

 Click Create File… button in the Add or Create Design Sources dialog box. 3.

The Create Source File dialog box opens:  
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Figure 16: Create Source File 

 In the File name field, type myFile, and click OK. 4.

 In the Add Sources dialog box, click Finish.  5.

The Define Modules dialog opens to help you to define the ports of a new Verilog module 

or VHDL entity. In this case however, you will use a template from the Xilinx Language 

Templates to define this module.  

 Click the Cancel button and Yes to confirm.  6.

The new empty myFile.v is added to the Sources view, and listed under the Non-module 

Files folder list in the Sources view. 

 In the Sources view, expand the Non-module Files folder and double-click myfile.v to open 7.

the file in the Text Editor. 

 Click the Templates view tab next to the Sources view, or use the Window > Language 8.

Templates command from the main menu.  

 Expand the Verilog subfolders to examine the types of templates available. 9.

Figure 17 shows the Language Templates view. The Xilinx Language Templates provide many 

standard logic elements for the different Xilinx FPGAs in both Verilog and VHDL, as well as  

UCF constraint templates for defining design constraints. The top half of the Language 

Templates view lists the available language and constraint templates.  

For this exercise you can select any Kintex-7 template. In Figure 17 the Global Clock Buffer 

with Clock Enable (BUFGCE) has been selected from the Kintex-7 folder of the Device 

Primitive Instantiation folder. The bottom half of the Language Templates view displays a 

preview of the currently selected template.  

 In the Text Editor, right-click and select Insert Template. 10.

The template text is now inserted in the myFile.v file. The template text is inserted at the 

current location of the cursor in the text Editor window.  

Note: You can also copy text from the preview pane of the Language Template view by 

selecting the desired text and using the Copy command. You can then paste it into the Text 

Editor window as needed. 
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Figure 17: Xilinx Language Templates 

 Close myFile.v in the Text Editor by clicking the X button. 11.

 In the Save Text Editor Changes dialog box, Click No to close the file without saving. 12.

 In the Sources view, click the Collapse All button. 13.
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Step 3: Running Behavioral Simulation 

The Xilinx ISE Simulator (ISim) logic simulation environment is integrated with the PlanAhead 

tool. ISim can be used for behavioral or timing simulation. You can run behavioral logic 

simulation on the entire design, or on an individual module.  

 In the Flow Navigator, select Run Behavioral Simulation.  1.

The Launch Behavioral Simulation dialog box opens.  

 

Figure 18: Launch Behavioral Simulation 

 Click the file browser icon for the Simulation Top Module Name field.  2.

This field lets you define the top-level module to launch simulation from. In this exercise, you 

will specify the test bench for the bft module which can be found in the fftEngine block 

under the Sources view.  

 Select bft_tb, and click OK.  3.

 Click the Options button on the Launch Behavioral Simulation dialog box.  4.

This opens the Simulation Options form as shown below. This form lets you define various 

options and directives for the ISim fuse compiler and simulator. Refer to the PlanAhead User 

Guide (UG632), for more information on these various options.  

 

Figure 19: Simulation Launch Options 

http://www.xilinx.com/cgi-bin/docs/rdoc?v=14.5;d=PlanAhead_UserGuide.pdf
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 Click Cancel to close the Simulation Options dialog box. 5.

 Click Launch, and wait for ISim to open.  6.

 

Figure 20: Running ISim for Behavioral Simulation 

You can explore the ISim environment at this time. Refer to the ISim In-Depth Tutorial 

(UG682), for information about using ISim.  

 Close the ISim window by using the File > Exit command from the main menu.  7.

 Click Yes to confirm closing the tool if necessary. 8.

  

http://www.xilinx.com/cgi-bin/docs/rdoc?v=14.5;d=ug682.pdf
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Step 4: Elaborating and Analyzing the RTL Design 

The PlanAhead tool provides RTL elaboration capabilities to compile RTL source files in the 

project. Once elaborated, the RTL views enable cross-selection of logic objects. Displayed 

compilation errors and warnings are cross-selectable to module definition or instantiation lines 

in the RTL code. The RTL logic hierarchy is expanded and available for analysis. Opening the RTL 

Design from the Flow Navigator automatically elaborates the RTL design and displays the 

Design Analysis view layout. 

 The RTL Netlist and Hierarchy views display the logic hierarchy of the design.  

 The RTL Schematic enables interactive logic exploration.  

 The Find command enables searching of RTL logic objects.  

 The Instance Properties view displays information about the selected logic instantiation 

including resource estimation.  

 The RTL DRCs highlight potential areas of the design to improve power or performance. 

Elaborating and Opening the RTL Design 

 Under RTL Analysis in the Flow Navigator, select Open Elaborated Design. 1.

 If prompted, click OK in the Warnings dialog. 2.

The RTL Design is elaborated and opened. 

 Click the Messages view tab  and click the Collapse All toolbar button 3.

 Expand the Elaborated Design folder, and scroll through the various messages associated 4.

with the open_rtl_design command. 

 

Figure 21: Viewing RTL Elaboration Messages 
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Examining the RTL Netlist and Hierarchy 

 In the RTL Netlist view, expand the usbEngine0 instance by clicking the plus sign (+). 1.

 Select the usbEngine0/u0 instance. 2.

 In the RTL Netlist view, right-click to open the popup menu, and select the Go to Definition 3.

popup command. 

The RTL file usbf_utmi_if.v opens in the Text Editor. This is the RTL code that defines the 

UTMI Interface module. The file opens to the line containing the usbf_utmi_if module 

definition.  

 

Figure 22: RTL Netlist - Go to Definition 

 In the RTL Netlist view, right-click and select the Go to Instantiation popup command.  4.

The RTL file usbf_top.v opens to the line containing the usbf_utmi_if instance. 

 In the RTL Netlist view, right-click and select the Show Hierarchy popup command. 5.

The RTL Hierarchy view opens with the usbEngine0/u0 module selected. The modules 

display with blocks sized relative to the amount of logic contained in them, making it easy to 

locate large modules. 
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Figure 23: Hierarchy View 

 To close the RTL Hierarchy, click X on the view tab.  6.

 To close the Text Editor, click X on all open RTL files. 7.

Traversing the Schematic 

 In the RTL Netlist view, expand and select the usbEngine0/u0/u0 instance (the level below 1.

the previous selection). 

 In the RTL Netlist view, click the Schematic button to open the schematic window.  2.

You can also right-click and select the Schematic command from the popup menu.  
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Figure 24: RTL Schematic 

 Double-click the LineState[1:0] pin on the outside of the u0 module to expand the 3.

schematic outward from the pin as shown in Figure 20. 

For additional schematic exploration capabilities, see the Design Analysis and Floorplanning 

Tutorial: PlanAhead Design Tool (UG676). 

 

TIP: Click and drag using the left mouse button in the RTL Schematic view from the lower right to 

the upper left to use the Zoom Fit command. 

 Select the LineState_r instance in the RTL Schematic view. 4.

 In the Schematic view, right-click to open the popup menu and select the Go to 5.

Instantiation to go to the selected logic instance in the usbf_top.v file.  

 

http://www.xilinx.com/cgi-bin/docs/rdoc?v=14.5;d=PlanAhead_Tutorial_Design_Analysis_Floorplan.pdf
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Figure 25: Expanding Logic 

 Close the various open Text Editor, Hierarchy, and Schematic windows. 6.

 In the RTL Netlist view, click the Collapse All button .  7.

Using the Find Command 

 Click the Find button in the main toolbar , or select Edit > Find to open the Find dialog 1.

box. 

 

Figure 26: Using Find 
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 Examine the Find filter options.  2.

 Set the Criteria to Type > is > Block Memory, and click OK. 3.

The Find Results view opens to display the results of the find operation.  

 

Figure 27: Find Results 

 Select one of the Block RAMs in the Find Results; right-click to open the popup menu and 4.

select Go to Instantiation. 

The instance is selected in the RTL Netlist view and displayed in the Text Editor. 

 Close the Find Results view and the Text Editor. 5.
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Step 5: Estimating Resource Utilization 

With the elaborated RTL Design opened, you can begin to examine the resource requirements 

of the design. The Project Summary provides a view of the Resources required by the design at 

each step in the design flow. Obviously the estimation of required resources in the RTL design is 

going to be less accurate than the resources utilized by the synthesized or implemented design, 

but it does begin to offer some insight into the requirements of the design.  

 In the Project Summary, select the Run Report RTL Utilization command. 1.

The RTL Resource Estimation opens in the Project Summary. 

 In the RTL Netlist view, select top. 2.

 In the Netlist Properties view, select the Statistics tab. 3.

 

Figure 28: RTL Resource Utilization 

The RTL Macro Resources displays in the Netlist Properties view, as shown in Figure 20. If the 

Netlist Properties view is not displayed, select Window > Properties from the main menu. 
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Figure 29: RTL Netlist Property Statistics 

 Scroll down the Netlist Properties view to examine the various categories of statistics. 4.

 RTL Macro Resources 

 RTL Hierarchy Resources 

 RTL Primitive Statistics 

 RTL Memory Resources 

 Net Boundary Statistics 

 Clock Report 

 In the RTL Netlist view, select other modules and examine the statistics in the Properties view 5.

for those selected modules.  

Notice that the Netlist Properties view has changed to the Instance Properties view for the 

selected modules. This is because you are no longer viewing the top-level of the design. The 

statistics presented in the Properties view are now for the resources required by the module, 

rather than for the whole design. 
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Step 6: Running RTL Design Rule Checks 

PlanAhead provides Design Rule Checks (DRC) that can be run on the RTL Design. These include 

LINT-style RTL checks for power or performance improvement suggestions. There are basic I/O 

bank and voltage rules for the RTL Design also. After the design is synthesized, a more 

comprehensive set of logic design, I/O, and clock DRCs is available for the Synthesized Design. 

 From the Flow Navigator, select Report DRC. 1.

 In the Run DRC dialog box, expand and examine the RTL rules, and click OK. 2.

 

Figure 30: Running DRC 

The DRC Results view opens as shown in Figure 31. 
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Figure 31: DRC Report 

 The DRC Results viewer color codes messages as follows: 3.

 Errors with a red icon 

 Critical Warnings with an orange icon 

 Warnings with a yellow icon 

 Informational messages with a blue icon 

 Select the UCIO #1 latch warning in the violations list. 4.

The Violation Properties view displays with information about the violation and links to 

select the offending logic objects.  

 Close the DRC Results view. 5.

 Close the RTL Design by clicking the Close X icon in the Elaborated Design banner. Click OK 6.

in the confirmation dialog box if needed. 

Step 7: Selecting IP from the Xilinx IP Catalog 

The PlanAhead tool is integrated with the CORE Generator™ tool to provide an IP Catalog with 

search and filtering capabilities. This allows you to easily find the desired IP. You can customize, 

instantiate and implement the core into your FPGA design from within the PlanAhead tool. You 

can access the IP Catalog from the Project Manager and Elaborated Design environments. 

Opening and Searching the IP Catalog  

 Select IP Catalog from the Flow Navigator. 1.

 Expand some of the IP categories. 2.

 Select any IP and explore the available toolbar buttons and popup menu commands. 3.
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Figure 32: Browsing the IP Catalog 

The Details for a selected IP display at the bottom of the IP Catalog view. By default, only the 

most recent version of the IP supported for the target device family is displayed.  

You can change the list of IP cores listed in the catalog by enabling and disabling commands 

on the toolbar menu of the IP Catalog view. 

 To view all IP in the catalog, toggle the Hide Superseded and Discontinued IPs  button 4.

and the Hide Incompatible IPs button  .  

 To view a flattened list of IP, disable the Group by Category toolbar button . 5.

 Type fir in the Search field at the top of the view. 6.

 Select a FIR Compiler IP. 7.

The details of the IP core are displayed in the Details panel at the bottom of the IP Catalog 

view. 

 From the popup menu, select the Data Sheet command. 8.

This will open a PDF view of the datasheet for the selected IP core. Examine the datasheet, 

and close the PDF viewer when finished. 

 Clear the Search field to expand the Catalog list. 9.
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Customizing an IP Core 

 Enable the Group by Category button.   1.

 Click the Collapse All button   in the IP Catalog toolbar menu. 2.

 Expand the Math Functions > Adders & Subtracters folder.  3.

 Double-click the Adder Subtracter to run the Customize IP command. 4.

This opens the Customize IP dialog box for the selected core, as shown in Figure 33. This is 

the interface to the CORE Generator™ software in the PlanAhead tool. Different IP will 

display different dialog boxes for customization.  

Examine the different fields and information available in the Customize IP dialog box. 

 In the B Input Width field, type 18. 5.

 Click Generate. 6.

Clicking Generate has a different effect when launched from PlanAhead than when run from 

CORE Generator standalone.  

 In standalone mode, the CORE Generator™ software automatically launches XST to 

synthesize the IP core.  

 When launched from the PlanAhead tool, the synthesis step is not run automatically. This 

lets you instantiate and configure multiple IP cores into your RTL design before 

launching synthesis. You can synthesize the IP as part of the overall design, or synthesize 

it standalone as a block of the design. 

When the Adder Subtracter core has been generated, it is added to the design, and listed 

under the IP Sources tab of the Sources view. In addition, since a new source has been 

added to the design, the Elaborated Design is shown as being out-of-date and must be 

reloaded, but first the new IP core must be instantiated into the design.  
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Figure 33: Customizing IP 

Instantiating the IP Core 

At this time, the Adder Subtracter core definition is added to the project files, and is available for 

use in the design. However, the core has not yet been integrated into the design. At this time 

you will create an instance of the IP in the RTL design.  

 In the upper right of the Elaborated Design banner, click the ‘X’ button to close the design. 1.

 In the Sources view, select the IP Sources tab and click the Expand All button.  2.

 Double-click the c_addsub_v11_0_0.veo file to open the instantiation template in the Text 3.

Editor. 
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Figure 34: Viewing the Instantiation Template 

 Select the text in the Text Editor, starting just below the line labeled “Begin Cut here…” 4.

and ending at the line with “//INST_TAG_END”.  

 Click the Copy Text button. 5.

The copied text can easily be pasted into any RTL source file to instantiate the IP module 

into your design.  

With the IP instantiated into your design, the IP can be synthesized along with the rest of the 

design, or as a standalone module. You can also generate the simulation files required to 

simulate the IP core as part of the design.  

 Select the c_addsub_v11_0_0 IP core from any tab in the Source view.  6.

 Right-click to open the popup menu and select the Generate Output Products command.  7.

The Manage Output Products dialog box opens as is shown in Figure 35. This lets you 

generate the specific files needed to support the IP core in the overall design.  
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Figure 35: Manage IP Output Files 

 Examine the dialog box, and then close it. 8.

You can also change the parameters of an IP core by selecting it in the Sources view and 

using the Re-customize IP command from the popup menu. This will open the Customize IP 

dialog box as was seen previously in Figure 33.  

 Close the .veo instantiation template file in the Text Editor. 9.

 Close the IP Catalog. 10.

 Select File > Exit. If prompted, click No to save and OK to close PlanAhead. 11.
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Conclusion 

In this tutorial, you: 

 Used a small RTL project to examine the PlanAhead RTL development and analysis 

environment. 

 Started by creating an RTL project, explored RTL sources and the RTL editor.  

 Ran behavioral simulation, elaborated the RTL design, and explored the analysis capabilities, 

which included examining the RTL logic hierarchy, RTL schematic exploration, searching for 

logic types, reviewing RTL resource and running RTL DRCs.  

 Examined the Xilinx IP Catalog, and customized, and instantiated a small adder IP core. 
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