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Partial Reconfiguration of a Processor
Peripheral Tutorial

Introduction

This tutorial shows you how to develop a partial reconfiguration design using the Xilinx®
Platform Studio (XPS), Software Development Kit (SDK), and the PlanAhead™ design tool. You
will use XPS to create a processor hardware system that includes a lower-level module defining
one Reconfigurable Partition (RP) and two Reconfigurable Modules (RM). The two RM perform
addition and multiplication functions. You will use SDK to create a software application that
enables you to perform partial reconfiguration.

XPS and SDK are part of the Embedded Design Kit (EDK), which is included in the ISE® Design
Suite Embedded and System Editions.

You will use PlanAhead to:
e Floorplan the design including defining a reconfigurable partition for the reconfigurable
region
e Create multiple configurations and run the partial reconfiguration implementation flow

to generate full and partial bitstreams.

You will use the ML-605 evaluation board to verify the design in hardware using a Compact
Flash (CF) memory card to configure the FPGA device initially and then partially reconfigure the
device using the AXI HWICAP peripheral by loading the partial bitstream files stored on the CF
under the user software control.

This tutorial covers only a subset of the features contained in the PlanAhead tool bundled with
ISE Design Suite Release. Other features are covered in other tutorials.

Tutorial Objectives

The FPGA design in this tutorial is targeted to the Virtex®-6 FPGA ML605 Evaluation Board. The
design targets a Virtex-6 xc6vIx240tff1156-1 device.

After completing this tutorial, you will be able to:
e Generate a processor system using XPS and SDK.

e Use the Partial Reconfiguration design flow capability in PlanAhead to generate full- and
partial-bitstreams to dynamically reconfigure an FPGA design using the AXI HWICAP
peripheral.
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Understanding the Processor System

This tutorial demonstrates how to implement a design that can be dynamically reconfigured
using the AXI HWICAP peripheral. The design consists of a peripheral capable of performing a
math function, having two unique capabilities: addition and multiplication.

You will verify the functionality with HyperTerminal under user application control. The dynamic
modules are reconfigured using the AXI HWICAP peripheral.

Terminal
Program

Compact
Flash

UserLogic

Figure 1: Top-Level Design

Software Requirements

The PlanAhead tool is installed with ISE Design Suite software. Before starting the tutorial, be
sure that the PlanAhead tool is operational, and that the tutorial design data is installed.

IMPORTANT: Partial Reconfiguration is a licensed feature of the PlanAhead tool. Completing this
i} tutorial requires a valid license to access the Partial Reconfiguration feature.

For installation instructions and information, see the ISE Design Suite 14: Release Notes,
Installation, and Licensing (UG631).

Hardware Requirements

Xilinx recommends a minimum of 2 GB of RAM when using the PlanAhead tool on larger
devices. For this tutorial, a smaller design is used, and the number of designs open at one time
is limited. Although 1 GB is sufficient, it can impact performance.
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Preparing the Tutorial Design Files

This tutorial uses a reference design, UG744_design_files.zip, which must be unzipped to a
write-accessible directory. You can download a copy of the reference design from:

http://www.xilinx.com/cqgi-bin/docs/rdoc?v=14.5;t=planahead+tutorials

Extract the zip file contents into any write-accessible location which will be referred to in this
tutorial as the extraction directory, or <Extract_dir>.

RECOMMENDED: The tutorial sample design data is modified while performing this
tutorial. A new copy of the original PlanAhead_Tutorial data should be extracted each time
you run this tutorial.

This tutorial includes a project file that has already been implemented. To reduce the data size,
some implementation files were removed from the design, leaving only the required results data
in the run directories.

Project Directory Structure

The directory structure is:

4 UG744_design_files
edk
image
image_solution
4 rESOUTCES
4 Math
adder
multiplier
4 math_vl_00_a
data
devl
4 hdl
vhdl
4 recenfig_modules_source
rp_adder
rp_mult
4 TestApp

Src

Figure 2: The Project Directory

e The /edk directory is used to create a processor system.
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e The /image directory is used to hold the generated full configuration bitstream file in
the System ACE™ format and partial bitstream files.

e The /image solution directory contains the final system.ace and partial bit files for a
quick test.

e The /resources directory contains:

o Source files used to generate the netlists of the addition and multiplication
functions,

o A pre-compiled netlist for the addition and multiplication functions in Math and
associate sub-directories, and

o A software application to demonstrate the functionality.
e The math processor core (pcore) provides:
o The necessary processor bus connections

o The required peripheral services (in this case, one slave register and a software
reset), and

o A placeholder for the math functionality module
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Lab 1: Partial Reconfiguration of a Processor

Step 1: Creating a Processor Hardware System

1.

Select Start > All Programs > Xilinx Design Tools > Xilinx Design Suite 14.5 > EDK >
Xilinx Platform Studio to open XPS.

In the Getting Started page, click Create New Project Using Base System Builder to open
a Create New XPS Project using BSB Wizard dialog box.

Browse to: <Extract Dir>/edk
Click Save.

Keep the default options of using ISE tools and AXI System as the interconnect type, and
click OK.

You will create a system for a Virtex®-6 ML605 evaluation platform.

1. In Board and System Selection form, select Xilinx as a Board Vendor.

2. In Board Name field, select Virtex-6 ML605 Evaluation Platform.

3. In Board Revision field, select D.

4. Click Next with other default options selected.

5. Select 50.00 MHz from the Processor Frequency drop-down menu.

6. Select 64 KB from the Local Memory Size drop-down menu.

7. In the selected peripherals list on the right, remove all devices except: RS232_Uart_1 and
SysACE_CompactFlash.

8. Click R§232_Uart_1 and configure it with a baud rate of 115200.

9. Click Finish.

10. If the Next Step dialog box opens, click OK to start using Platform Studio and open the
System Assembly View window as shown in Figure 3.
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n | Businterfaces | Ports | Addresses

}I{ I'E.:I I'E.:I Mame Bus Mame IP Type IP Wersion

— | igxidlite O 1r axi_inter.. 10&6.a

O microflaze O dimb 1r Imbov10  2.00b

L microflaze 0 dmb 1 Imbov10  2.00b

. H- microbaze 0 1r microbla... 8.50.a

T -[ H-microbaze O bram Mock 1r bram_bl.. 1.00.a

H- microbaze O d bram_cird 1 Imb_bra.. 3.10.c

< Hmicrobaze 0§ bram_cird 1 Imb_bra.. 3.10.c

f +- debug module 7 mdm 210.a

f +- Sy ACE CompactFlash 1r axi_sysace 1.01la

9 +- R5222 Uart 1 1r axi_uartli.. 1.02.a

clock_generator 0 1r clock_ge.. 4.03.a

proc_sys_reset (0 1 proc_sys.. 3.00.a

Figure 3: Displaying the System Assembly View

Partial Reconfiguration Design Details

1. Copy the <Extract Dir>/resources/math vl 00 a folderto ./edk/pcores

2. In<Extract Dir>/edk/pcores/math vl 00 a/hdl/vhdl, examine the
user logic.vhd file.

At line 133, and at line 158, it declares a component that will be used in the
reconfigurable partition.

The data inputs to the component are clocked at lines starting at 191.

The reset input to the component is a combination of the hardware bus reset and
software reset.

The software reset is generated by a soft reset block located at line 310 in
math.vhd file located in the same directory.

The software reset is necessary to reset the reconfigured logic after reconfiguring the
partition.

Note: If line numbering is hidden from view in XPS, turn line numbers on as follows:

S T

Select Edit > Preferences > ISE Text Editor.
Click to select the Show line numbers check box.
Click Apply and then OK.

Rescan the User Repositories in XPS by selecting Project > Rescan User Repositories.

In the IP Catalog tab, MATH displays in the USER folder under the Project Local pcores

folder.

7. Expand the USER folder.
8. Select MATH.

Partial Reconfiguration of a Processor Tutorial www.xilinx.com 10
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10.

11.

12.

Double-click MATH to add an instance of the IP to the System Assembly.
A properties form opens.

Click OK twice to add the IP with the default settings and connect it to the microblaze_0
instance.

In the IP Catalog tab, select the FPGA Internal Configuration Access Port (v2.03.a) IP (axi
hwicap) under the FPGA Reconfiguration folder, right-click and select Add IP.

This adds the instance of the IP to the System Assembly View.

Click OK twice to accept the default settings and connect the IP to the microblaze_0
instance.

Note: When the IP cores are added, interface connections are made, and the addresses are
automatically assigned.

Connecting the Ports

> W

In the System Assembly View, select the Ports tab.
Expand the axi_hwicap_0 instance.
Select Hardware > Launch Clock Wizard.

In the Clock Wizard form, select 50.0000 for the ICAP_Clk of the axi hwicap 0 instance,
select <AUTO> under the source column, and click OK.

Click OK to close the form.

The connection appears as shown in Figure 4.

+ Bus Interfsces | Ports Addresses
Name Connected Port Direction Range Class

+-iExternal Ports

axidlite_ 0

microblaze_0 dimb

microblaze_0 ilmb

microblaze 0

microblaze_0 bram_block

microblaze 0 d_bram_ctrl

microblaze_ 0 i bram_ctrl

debug_module

axi_hwicap_0
ICAP_Clk clock_generator_0:CLKOUTO  #
EOS_IN 7

7

e
e
e
e

-+ -+ =

CLK

I
I
0 INTERRUPT
|

IP2INTC Irpt
+- (BUS_IF) S_AXT Connected to BUS axidlite 0 |
SysACE_CompactFlash
RS232 Uart_1
math_0
clock_generator_ 0
proc_sys_reset_0

+ FF

Figure 4: Connecting Clock Source to ICAP
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Partial Reconfiguration Design Details

The axi hwicap pcore allows a separate clock domain for the hwicap so it can be run at 100
MHz when the system is run at a higher speed. In this tutorial, the system clock is 50 MHz and
hence, we are running the entire design in a single clock domain.

Notice that there is EOS_IN port on the axi hwicap 0 instance. This port is available for the
designer to connect to a separate signal that can be asserted only when the system is stable and
the reconfiguration can be done, to take care of a situation where reconfiguration command
may be issued before the system is stable. You can instantiate a STARTUP block and connect the
port correctly and automatically by selecting configuration parameter instantiate STARTUP
primitive in the HWICAP core option in the hwicap pcore configuration GUL

1. Select the Bus Interfaces tab.

2. Double-click on the axi_hwicap_0 instance and click on the check box of instantiate
STARTUP primitive in the HWICAP core option in the User tab.

3. Click OK to accept the settings.

4. Select the Ports tab and observe that EOS_IN port is not listed as it is connected to STARTUP
block which is automatically instantiated with the selected option.

Generating Netlists

To run the Platform Generator, select Hardware > Generate Netlist.

This generates the peripheral and system netlists, and the system.bmm files, all of which are
used during implementation in the PlanAhead tool.

Partial Reconfiguration of a Processor Tutorial www.xilinx.com 12
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Step 2: Creating a Software Project

After the hardware netlist is generated, use the Software Development Kit (SDK) available with
EDK to:

e Create a software project

e Import the provided source files

e Compile the provided source file

e Generate an executable file

Exporting Hardware Design to SDK, and Creating a Board Support
Package, making sure to add xilfatfs library support

1. In XPS, select Project > Export Hardware Design to SDK... to launch SDK.
2. Uncheck Include bitstream and BMM file.
3. Click Export & Launch SDK.

A workspace location dialog box opens.

4. Browse to the <Extract Dir>/edk/SDK/SDK Export directory, and click OK to open
SDK after importing hardware specification of the system.

5. In SDK, select File > New > Board Support Package.
Notice that the default Project Name is standalone_bsp_0 and the OS is standalone.
6. Click Finish with default settings.
The Board Support Package Settings window opens.
7. Check the xilfatfs check box to select the FAT file system support for the Compact Flash

card.
Mame Yersion Description
Iwipl40 1.04.a IwIP TCP/IP Stack librany: IwIP v1.4.0, Xilinx..
W wilfatfs 1.00.a Prowvides readfwrite routines to access file..
wilflash 3.04.a HKilinx Flash library for Intel /AMD CFI com..,
wilisf 3.0La Hilinx In-system and Serial Flash Library
Hilmfs 100.a HKilinx Memory File System

Figure 5: Selecting File System Support

8. Click OK to accept the settings and close the form.

Partial Reconfiguration of a Processor Tutorial www.xilinx.com 13
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Creating a Xilinx C Project

Select File > New > Application Project.

Type TestApp for the Project Name.

Select Use Existing option under the Board Support Package field and click Next.
Select Empty Application in the Project Application Template pane.

Click Finish.

v o whd o

Generating a Test Application

In the Project Explorer view, select TestApp.

Right-click and select Import.

Double-click General.

Double-click File System.

Browse to the <Extract Dir>/resources/TestApp/src/ folder.
Click OK.

Selectmain.c and xhwicap parse.h.

Click Finish.

©® N o v~ W N =

This compiles the source files and generates TestApp.elf in the
<Extract Dir>/edk/TestApp/Debug/ folder.

Partial Reconfiguration Design Details

Examine the <Extract Dir>/resources/TestApp/src/main.c file.

This code includes a function, beginning on line 164, which loads a partial bit file from the
CompactFlash and writes to the ICAP.

The calls to this function, beginning on line 433, instruct the program to load a specific partial
bit file and then assert software reset.

When the blank bitstream is loaded, the software reset is not required since there is no real logic
residing in the reconfigurable region.

Generating a Linker Script

1. Be sure that the Heap and Stack sizes are set to 2048 (0x800).
2. In SDK Project Explorer view, select TestApp.
3. Right-click and select Generate linker script.

4. Change the Heap size and the Stack size to 2048.

Partial Reconfiguration of a Processor Tutorial www.xilinx.com 14
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Generate a linker script — ‘-—-  — X |
Generate linker seript
Control your application's memaory map.

Basic | Advanced

Project: TestA,
L = Place Code Sections in:  microblaze_0_i_bram_ctrl_microblaze_0_d_bram_ctrl «

Output Script:
: - Place Data Sections in: microblaze_0_i_bram_ctrl_microblaze_0_d_bram_ctrl =
peripheral_lab\edk\SDK\SDK_Export\TestApp\src\Iscript.ld f
Modify project build settings as follows: Place Heap and Stack in: microblaze_0_i_bram_ctrl_microblaze_0_d_bram_ctrl -
Set generated script on all project build configurations VI Heap Size: 2KB
Stack Size: 2KB
| |
Memory Base Address Size

microblaze_0_i_bram_ctrl_.. 0x00000000 64 ..

» Fixed Section Assignments

@] Generate ‘ I Cancel

Figure 6: Generating a Linker Script

Click Generate.
Click Yes to overwrite the existing copy and recompile the application again.

Select File > Exit to close SDK.

© N o wu

In XPS, select File > Exit to close XPS.

Step 3: Creating a PlanAhead Project

Now that you have generated the required netlist files for the design, you will use the PlanAhead
tool to:

e Floorplan the design

o Define reconfigurable partitions

e Add reconfigurable modules

¢ Run the implementation tools

e Generate full and partial bitstreams

In this step, you will create a new project.
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Creating a PlanAhead Project, and Importing the Generated Netlist
Files

1.

To open PlanAhead, select Start > All Programs > Xilinx Design Tools > Xilinx ISE Design
Suite 14.5 > PlanAhead > PlanAhead.

2. Click Create New Project.
3. Click Next.
4. Browse to and select the <Extract Dir>/ directory for the Project location.
5. Click Select.
6. Type PlanAhead for the Project name in the New Project wizard.
7. Make sure that Create Project Subdirectory is checked.
E] New Project &j
Project Name
Enter a name for your project and spedify a directory where the project data files m
will be stored
Project name:  PlanAhead|
Project location: | C:\PartialReconfiguration\reconfig_peripheral_lab e
/| Create Project Subdirectory
Project will be created at: C:\... \reconfig_peripheral_lab\PlanAhead
| < Back H Next > Finish ]W
Figure 7: New Project Wizard
8. Click Next.
9. In the Project Type page, select Post-synthesis Project.
10. Check the Enable Partial Reconfiguration option.
Note: If you forget to check the option, you can still enable it from the project (netlist based
only) by selecting Tools > Project Settings > General and clicking the Partial
Reconfiguration Project check box. This must be done before a partition can be defined as
reconfigurable.
11. Click Next.
Important! The Enable Partial Reconfiguration option is available only if you have a license
for Partial Reconfiguration.
Partial Reconfiguration of a Processor Tutorial www.xilinx.com 16
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E] New Project m ‘

Project Type
Specify the type of project to create, gg

RTL Project
You will be able to add sources, generate IP, run RTL analysis, synthesis, implementation, design planning
and analysis. N

Do not specify sources at this time

@ Post-synthesis Project
| You will be able to add sources, view device resources, run design analysis, planning and implementation.

| [7] Do not specify sources at this time N
(] Enable Partial Reconfiquration

1/O Planning Project
i Do not specify design sources. You will be able to view part/package resources. i
1 Import ISE Place & Route results ]
" You will be able to do post-implementation analysis of your design.
Imported Project
Create a PlanAhead project from a Synplify, XST or ISE Project File.
||

Figure 8: Importing Synthesized Netlists

12. Click the Add Files button.
13. Browse to the <Extract Dir>/edk/implementation/ folder.
14. Select all NGC files including the system.ngc file, and click OK.

15. In the Top column, click the radio button next to system.ngc to identify it as the top-level
design file.

Partial Reconfiguration of a Processor Tutorial www.xilinx.com 17
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E] New Project

Step 3: Creating a PlanAhead Project

L X

Add Netlist Sources

Specify netlist files to add to your project. Use the 'Add Files' button to select the file that contains the design 'Top' module and part.

Id Name
i) system.ngc
i3] system_axidlite_D_wrapper.ngc
] system_axi_hwicap_0_wrapper.nac
i) system_axi_hwicap_0_wrapper_fifo_generator_v8_3_1.ngc
5 system_axi_hwicap_0_wrapper_fifo_generator_v8_3_2.ngc
] system_clock_generator_0_wrapper.ngc
W 7  system_debug_module_wrapper.ngc
8 system_math_0_wrapper.ngc
9 system_microblaze_0_bram_block_wrapper.nac
| 10 system_microblaze_0_d_bram_ctrl_wrapper.nac
@ 11  system_microblaze_0_dimb_wrapper.ngc
@ 12 system_microblaze_0_i_bram_ctrl_wrapper.ngc
@ 13  system_microblaze_0_ilmb_wrapper.ngc
# 14 system_microblaze_0_wrapper.ngc
@ 15 system_proc_sys_reset_0_wrapper.ngc

@ 16
i 17

system_rs232_uart_1_wrapper.ngc
system_sysace_compactflash_wrapper.ngc

Location
C:PartialReconfigurationreconfig_peripheral_lab\edk\implementation
C:\PartialReconfigurationyeconfig_peripheral_lab\edk\implementation
C:\PartialReconfigurationyeconfig_peripheral_lab\edk\implementation
C:\PartialReconfiguration\reconfig_peripheral_lab\edk\implementation
C:PartialReconfigurationyeconfig_peripheral_lab\edk\implementation
C:\PartialReconfigurationreconfig_peripheral_lab‘\edk\implementation
C:\PartialReconfigurationreconfig_peripheral_lab\edk\implementation
C:\PartialReconfigurationreconfig_peripheral_lab\edk\implementation
C:\PartialReconfigurationyeconfig_peripheral_lab\edk\implementation
C:\PartialReconfigurationyeconfig_peripheral_lab\edk\implementation
C:\PartialReconfiguration\reconfig_peripheral_lab\edk\implementation
C:PartialReconfigurationyeconfig_peripheral_lab\edk\implementation
C:\PartialReconfigurationyeconfig_peripheral_lab\edk\implementation
C:\PartialReconfigurationyeconfig_peripheral_lab\edk\implementation
C:\PartialReconfigurationreconfig_peripheral_lab\edk\implementation
C:\PartialReconfigurationyeconfig_peripheral_lab\edk\implementation
C:\PartialReconfigurationreconfig_peripheral_lab\edk\implementation

[ AddFiles...

| [ Add Directories... ]

| V] Copy Sources into Project

Add Sources from Subdirectories

16.

17.
18.
19.
20.
21.
22.

Figure 9: Selecting the Top-level Netlist File

Click Next.

The Add Constraint files (optional) page opens.

Click Add Files.

Browse to <Extract Dir>/edk/data/

Select system.ucft.

Click OK.

Click Next to open the Default Part page.

Click on the Boards under the Specify column, click on the drop-down button of the Family
and select Virtex-6, and select Virtex-6 ML605 Evaluation Platform as shown in the
following figure. Click on the Boards under the Specify column, click on the drop-down
button of the Family and select Virtex-6, and select Virtex-6 ML605 Evaluation Platform

as shown in the following figure.
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f€] New Project R u

_-‘

Default Part
Choose a default Xilink part or board for your project. This can be changed later. g:(:j

Specify Filter

@ Parts Family | Yirtex-6 -
Package | ff1156 -
I Speed grade | -1 -
Reset Al Filters |
Search: | L
1/0 Pin available LUT )
| | Board Part Count ICBs Elerments RlERE

240tf1156-1 150720 301440

4 T r O
[ < Back ” Mext = Firish

Figure 10: Selecting the Target Device

23. Click Next.
24. Click Finish.

The project is created. The Project Manager pane displays the modules present in the
design.
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 Project Manager - PlanAhead

Sources

QXS watE

(-157 Design Sources (17)
& NGC (17)

{fi o system.ngc (top)
) o system_axi4lite_0_wrapper.ngc

gl o system_axi_hwicap_0_wrapper.ngc

i) o system_axi_hwicap_0_wrapper_fifo_generator_v8_3_1.ngc
i--{gff o system_axi_hwicap_0_wrapper_fifo_generator_v8_3_2.ngc
{4 o system_clock_generator_0_wrapper.nac

i-{fi o system_debug_module_wrapper.ngc

{4y o system_math_0_wrapper.ngc

i)  system_microblaze_0_bram_block_wrapper.ngc

{4 o system_microblaze_0_d_bram_ctrl_wrapper.ngc

i-{fi o system_microblaze_0_dimb_wrapper.ngc
gl @ system_microblaze_0_i_bram_ctrl_wrapper.ngc

il o system_microblaze_0_ilmb_wrapper.ngc
{4 » system_microblaze_0_wrapper.ngc
il » system_proc_sys_reset_0_wrapper.ngc
~{gfl @ system_rs232_uart_1_wrapper.ngc

i {4} o system_sysace_compactflash_wrapper.ngc

== Constraints (1)

(=i constrs_1

i3 o system.ucf (target)

Libraries  Compi Order |
B &Soumesf_QTenplahesl

Figure 11: Design Hierarchy in PlanAhead
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Step 4: Defining a Reconfigurable Partition

This design has one reconfigurable partition that you must explicitly define.

Defining a Reconfigurable Partition (RP) With a Black Box
Reconfigurable Module (RM).
1. Click Open Synthesized Design under Netlist Analysis step of the Project Manager Flow
Navigator pane to invoke the netlist files parser.
This is necessary to access a lower-level module to define a reconfigurable partition.

A warning message indicating that one instance will be converted to a black box because
the netlist file for it is missing. This is expected because no netlist has been associated with
this module yet.

A Netlist tab displays the hierarchical view of the system.
2. Click OK twice.
3. Expand the math_0 instance.
4. Select math_0/USER_LOGIC_I/rp_instance in the Netlist view.

T
*

Metlist — O
= |E

3 system

[EHE Mets (1524)

1 Primitives (26

axidlite_0 (systerm_axidlite_0_wrapper)

axi_hwicap_0 (systern_axi_hwicap_0_wrapper)

clock_generator 0 (=ysterm_clock_generator 0 wrapper)
debug_rmadule (systerm_debug_module_wrapper)

E}. math_0 {systermn_math_0_wrapper)

S Mets (234)

¢ -5 Primitives (2097

C ol math_DAJSER_LOGIC_ Ip_instance ()

microblaze_0 (system_microblaze_0_wrapper)
microblaze_0_bram_block (systerm_microblaze _0_bram_block_wrapper)
microblaze_0_d_bram_ctrl (systern_microblaze_0_d_brarm_cir|_wrapper)
.. microblaze_0_dimb (systern_microblaze_0_dimb_wrapper)

FHE] microblaze_0_i_bram_ctrl (system_microblaze 0 i_bram_cirl_wrapper)
i microblaze_0_ilmb (system_microblaze_O0_ilmb_wrapper)
proc_sys_reset 0 (system_proc_sys_resef 0_wrapper)

t RS232_Uart_1 (system_rs232_uart_1_wrapper)

FHE] SysACE_CompactFlash (system_sysace_compactflash_wrapper)

Figure 12: Netlists Hierarchy View

Partial Reconfiguration of a Processor Tutorial www.xilinx.com 21
UG744 (v14.5) April 25, 2013


http://www.xilinx.com/

v
i; X"—l NX? Step 4: Defining a Reconfigurable Partition

5. Right-click and select Set Partition.
The Set Partition dialog box opens.
6. Click Next twice.

7. Select Add this Reconfigurable module as a black box without a netlist.

8. Type math_BB in the RM name field since the partition does not yet have a defined netlist.

E] Set Partition o
Reconfigurable Module Name
Enter a name for the new Reconfigurable Module for instance
‘'math_0/math_0/USER_LOGIC_I/rp_instance'.

Reconfigurable Module Name:

Netlist already available for this Reconfigurable Module

@ Add this Reconfigurable Module as a black box without a netlist

TN T

Figure 13: Setting a Partition

9. Click Next.
10. Click Finish.

Note: The black box icon has changed to a diamond shape.
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Step 5: Adding Reconfigurable Modules

This design has two Reconfigurable Modules (RMs) for the Reconfigurable Partition (RP). In this
step, you add the two modules.

Adding Two Reconfigurable Modules: Adder and Multiplier

1. In the Netlist window, select the math 0/USER LOGIC I/rp instance.
2. Right-click and select Add Reconfigurable Module.
The Add Reconfigurable Module dialog box displays.
3. Click Next.
4. In the Reconfigurable Module Name field, type adder.
5. Verify that Netlist already available for this Reconfigurable Module is selected.

E] Add Reconfigurable Module

Reconfigurable Module Name

Enter a name for the new Reconfigurable Module for instance
‘'math_0/math_0/USER _LOGIC_Ifrp_instance'.

Reconfigurable Module Name: adderl

@ MNetlist already available for this Reconfigurable Module

Add this Reconfigurable Module as a black box without a netlist

Figure 14: Adding a Reconfigurable Module

6. Click Next.
Browse to <Extract Dir>/resources/Math/adder/ and select the rp.ngc file.

7. Click OK.
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E] Add Reconfigurable Module

Specify Top Netlist File
Specify the EDIF or NGC netlist that contains the Reconfigurable Module m

- 0

L0y HC : Par tialReconfiguration reconfig_peripheral_labyesources\Math'\adder'yp.ngc m
Netlist directories (optional)
X

' Add Directories. .. ]

Copy Sources into Project

< Back ” Next > ] Finish Cancel

Figure 15: Locating the adder Version of math.ngc

8. Click Next twice.
9. Click Finish.

In the Netlist pane, expand Reconfigurable Modules hierarchy under
math_0/USER_LOGIC_I/rp_instance to view the adder RM entry.

10. Follow the steps in Step 5 to add a multiplier RM from the
<Extract Dir>/resource/Math/multiplier/rp.ngc directory. Name the RM mult.

The Netlist window displays three Reconfigurable Modules (including the black box) for the
math Reconfigurable Partition.
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T
X

Metlist - O
= HE
3 system

[EHE Mets (1524)
FHE Primitives (26)
FHE] axidlite_D (zystemn_addlite_0_wrapper)
-@ ani_hwicap_0 (system_axi_hwicap_0_wrapper)
FHE] clock_generator_0 fsystern_clock_generator_0_wrapper]
-@ debug_madule (system_debug_module_wrapper)
EHE] math_0 (system_math_0_wrapper)
CREHE Mets (2840
=) Primitives (=09
=B math_0USER_LOGIC Ifp_instance (rp)
E}-r; Reconfigurable Modules (3}

O adder

; L@

HHE] microblaze_0 (system_microblaze_0_wrapper)

-@ microblaze_0_bram_black (systerm_microblaze_0_bram_block _wrapper)
FHE] microblaze_0_d_bram_ctrl (systerm_microblzze_0_d_bram_cirl_wrapper)
-@ microblaze_0_dlmb (system_microblaze_0_dlmb_wrapper)

FHE] microblaze_0_i_bram_cirl isystern_microblaze_0_i_bram_cirl_wrapper)
-@ microblaze_0_ilmb (system_microblaze_0_ilmb_wrapper)

[HHE] proc_sys_reset_0 (system_proc_sys_reset_0_wrapper)

-@ RS232_Uart_1 (system_rs232_uart_1_wrapper)

HHE] SysACE_CompactFlash (system_sysace_compactflash_wrapper)

Figure 16: PlanAhead Project with adder and mult RMs added
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Step 6: Defining the Reconfigurable Partition Region

Next, floorplan the RP region. Depending on the type and amount of resources used by each
RM, the RP region must be appropriately defined so it can accommodate any RM variant.

Setting the Reconfigurable Region

1. Zoom to the top left quarter of the FPGA.
2. Select Window > Physical Constraints.
3. In the Physical Constraints tab, select pplock math 0/USER LOGIC I/rp instance.
4. Right-click, and select Set Pblock Size.
Physical Constraints = O a =
QA I = |E
-: 4] netlist_1
=} (8) ROOT
3| pblock_math_0_USER_LOGIC_I_rp_instance|
Pblock Properties - O g X

Figure 17: Setting Physical Constraints

5. Move the cursor in the Device window.

6. Click and drag the cursor to draw a box that bounds SLICE_X8Y230:SLICE_X17Y239, as shown
in the next figure.

You must draw a box around this region because the multiplier (mult) RM requires one
DSP48E and the adder RM requires 32-bit tall carry chain.

The current grid coordinates are reported in the status bar at the bottom of the PlanAhead
window.

At the completion of this step, the Set Pblock dialog box displays.
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I Project Summary X | & Dewice X | 2] Schematic X Og X

8 &) @

2

R0| ¥ (BR3¢

Figure 18: Closer View of the Pblock Area

7. In the Set Pblock dialog box, verify that SLICE and DSP48 are checked as the resources to be
reconfigured, shown in the following figure.

8. Click OK.
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f€] set Polock

,"" | Which resources do you wish
& pblock_math_0_USER_LOGIC_I_rp_instance to constrain?

Grids

..............

Figure 19: Setting Pblock with SLICE and DSP48

Partial Reconfiguration of a Processor Tutorial www.xilinx.com 28
UG744 (v14.5) April 25, 2013


http://www.xilinx.com/

& XILINX.

Step 7: Running the Design Rule Checker

Step 7: Running the Design Rule Checker

Xilinx recommends that you run a Design Rule Check (DRC) in order to detect errors as soon as

possible.

Selecting and Running PR-specific DRCs

1. Select Tools > Report DRC.

2. Deselect All Rules.

3. Select Partial Reconfig.

4. Click OK to run the PR-specific design rules.

[& Report DRC

Results name: |drc_1
Cutput file:

Rule deck: all

Rules to Check: 17 of 1364

O i A
e —

- all Rules (1264)
0 Netlist (1204)
+-[d Bark (35
+-0 ChBuf (2)
- Flow (1)
4100 DSP4g (4)
+- [ Implemeantation (=)
+-[d Floorplan (=)
- Clock (1)
0 108 (26)
+-[d Partition (10)
+-[d Placer (290
+-b Partial Reconfig (173
0 RAMB (1)
+-[d Team Design (2)

I Select All H Clear all ‘

Cpen in a new tab

[ o

” Cancel ‘

Figure 20: Running Design Rule Checks

You will see warnings stating that Reconfigurable Modules (RMs) have not been

implemented.
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Step 8: Creating the First Configuration, Implementing,
and Promoting

Now you can create and implement the first configuration.

Creating a New Strategy

Use the -bm option pointing to the system.bmmn file for the new strategy.

1. Select Tools > Options.
2. Select Strategies in the left pane.
3. Select ISE 14 in the Flow drop-down box.
4. Under PlanAhead Strategies, select ISE Defaults.
5. Click the + button to create a new strategy.
Flow: |BISE 14 v
User Defined Strategies
--PlanAhed Create New Strateg

;Y ISE Defaults

55 MapTiming

B MapGlobalOptParHigh

55 MaplogicOptParHighExtra

B MapGlobalOptLogicOptRetimin

55 MapTimingIgnoreKeepHierarch

& MapCoverBalanced

5 MapCoverArea

5B ParHighEffort

Figure 21: Creating a New Strategy

6. Name the new strategy ISE14_BM, and set the Type to Implement.
7. Click OK.
8. Under Translate (ngdbuild), click in the More Options field.
9. Type -bm ../../../edk/implementation/system.bmm, and click Apply.
10. Click OK.
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Running the Implementation Using Mult as a Variant

At the bottom of the PlanAhead tool user interface, select the Design Runs tab.
Select the config_1 run.
In the Implementation Run Properties window, select the General tab.

In the Name field, type mult as the run name.

v o whd o

Click Apply to change the run name from config_1 to mult.

Implementation Run Properties - O
& %L

=2 mult

o]
X

Name: mult
Part: @ xc6vix240tff1156-1 (active) | | - |

Description: | ISE Defaults, induding packing regi

Status: Mot started
Constraints: | g constrs_1 (active]
q 1 b g

General | Options | Monitor | Reports [ Me 4 » B

4 Properties | & Clock Regions

Figure 22: Implementation Run Properties View

6. In the Options tab, change the Strategy to ISE14_BM.

7. Click Apply.

8. In the Partitions tab, click the Module Variant column drop-down button and select mult as
the variant.

9. Click Apply.
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10.

11.
12.

13.

14.
15.
16.

Implementation Run Properties - O o %
& = %5

= mult

Name Module Variant  Action Import frq
] Static Logic Implemeni » NfA

4 1 L3

o

General | Options | Monitor | Reports | Messages | Partitions
. Properties | @ Clock Regions

Figure 23: Implementation Run

In the Sources window, expand Reconfigurable Module Sources entry and expand mult
entry, if needed, right-click on rp.ngc, and select Replace File... to reload the same rp.ngc
file.

Note: On the Windows version of the tools, you will need to reload the Reconfigurable
Module’s ngc file which will be implemented next. You do not need to do this step when the
black box is the RM.

Browse to the same folder and click OK to load the the file.

In the Netlist window, make the corresponding module (mult) active, right-clicking on its
entry and selecting Set As a Active Reconfigurabe Module.

You can confirm whether the correct RM is loaded or not by selecting the RP and then right
clicking on the RP in the Device view window and selecting Schematic.

In the Design Run window, select mult, and right-click and select Launch Runs to run the
implementation.

Select Launch Runs on Local Host.

Click OK.

Click Save (if a dialog box shows up) to save the project and run the implementation.
The implementation runs.

When implementation is finished running, the Implementation Completed dialog box opens
to let you open the implemented design, or promote the implemented partitions.
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17. Select the Promote Partitions radio button, and click OK.

18. In the Promote Partitions dialog box, click OK to promote the current configuration so the
implemented results are available for the subsequent configurations.

E] Promote Partitions =~ - - ’ u

,0, Please select runs to be promoted. This copies the partitions in implemented run to the
"Y' specified promote directory. After promoting runs, you can import the partitions into
runs.

Select Runs to promote

[

{ Run Directory

| = M mult ...onfig_peripheral_lab\PlanAhead\PlanAhead.promote \Xmult
{C] Static Logic
& math_0/math_0/USER_LOGIC_I/rp_instance - mult

| Select Implemented | | Clear Al |

[V] Automatically manage Partition action and import location

Figure 24: Promoting Partitions
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Step 9: Creating Other Configurations, and
Implementing

After you have created the first configuration, the static logic implementation is reused for the
rest of the configurations. Next, you will create the desired number of additional configurations
and implement them.

Make the Second Reconfigurable Module Active

Note: In the Windows version of the tool, you must load the netlist of the active RM.

1. In the Netlist window, expand the math_0 > math_0 > Reconfigurable Modules and right-
click on the adder, and select Set As a Active Reconfigurabe Module.

2. In the Sources window, expand reconfigurable Module Sources entry and expand adder
entry, if needed, right-click on rp.ngc, and select Replace File... to reload the same rp.ngc
file.

3. Browse to the original location, select the rp.ngc file, and click OK.
4. Click on Reload as the netlist has changed.

Note: You do not need to do this for a black box instance, as there is no ngc file associated
with that RM.

Also note: If you have more than two RMs, then on Windows, you cannot create and run
multiple runs as shown in the next section, Creating Multiple Runs. Instead, you will have to
make one RM active, reload the corresponding ngc file, create a run, and run the
implementation for each RM until only one RM and a black box are left.

Creating Multiple Runs

1. Select Flow > Create Runs.
The Create New Runs window opens.
2. Click Next twice.

3. In the Choose Implementation Strategies and Reconfigurable Modules page, change the
name of the configuration from config_1 to adder.

4. Click More.
5. Change the name of config_1 to black_box.
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' E] Create New Runs u

| Choose Implementation Strategies and Reconfigurable Modules

Create and configure runs using various strategies and Module Variants for Reconfigurable @
Modules. ¥
Create Implementation Runs
I | Name Strategy Make Active (optional) Partition Action
V| adder |12 15E14 BM (1SE 19) < o | math_ojmi| [ ]| [ X |
1 ﬁ
|| |packbox |Bseamoses) | 5 [math_o/m: [-] [ ]

| Runs to create: 2

" < Back “ Next > Finish

Figure 25: Creating Multiple Runs

6. In the adder configuration row, click the Partition Action field.

7. For the rp_instance row, click the Module Variant column drop-down arrow, and select
adder as the variant to be implemented, as shown in Figure 26.
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( 5 Ers - - G F eew-m . r—=§*—1[
@ Specify Partition . ] * B : < —

,’6‘, Choose Module Variants for Reconfigurable Modules and actions

—

Name Module Variant  Action Import from
[ static Logic Import  « C:\PartialReconfiguration'\reconfig_peripheral_lab\PlanAhe...
'l * math_0/math_0/USER_LOGIC_I/rp_instancefy T v C:‘ParﬁaReconﬁgwaﬁonVcconﬁg _peripheral_lab\PlanAhe...
math_BB
adder
mult

Figure 26: Selecting Adder Module Variant

8. Click OK.

9. Similarly, select math_BB variant for the black_box run (row).
10. Click Next.

11. Select Launch Runs on Local Host.

12. Click Next.

13. Click Finish to run the implementations for both configurations.

14. Click Cancel when the runs are finished.
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Step 10: Running Partial Reconfiguration to Verify
Utility

Next, you will check to be sure that the static implementation, including interfaces to
reconfigurable regions, is consistent across all configurations. To verify this, you can run the
PR_Verify utility.

Running the PR_Verify Utility

1. Run the PR_Verify utility to make sure that there are no errors.
2. In the Configurations window, select any of the configurations.

3. Right-click, and select Verify Configuration.

Configurations - O a X
A< SEEES 8
Configuration Module Variant  Status

& adder (2) F Promote Partitions...
E3

- black_box (2) Unpromote Configuration...

Verify Configuration...

Load Configuration

&l Physical Constraints . <" Configurations | —

Implementation Run Properties
Fl L]

Export to Spreadsheet...

Figure 27: Verifying All Configurations

4. Press Shift and select all configurations.
5. Click OK.

6. The PR_Verify utility runs and reports that there were no errors.
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Step 11: Generating Bit Files

After PR_Verify validates all the configurations, you can generate full and partial bit files for the
entire project.

Generating Full and Partial Bitstreams

1. Inthe Design Runs window, press Shift and select the following three designs runs:

e mult
e adder
¢ black box

2. Right-click and select Generate Bitstream.
This runs the bitstream generation process and generates full and partial bitstreams.

The bit files are placed in the mult, adder and black box directories under the
<Extract Dir>/PlanAhead/PlanAhead.runs/ directory.

3. Click OK.
4. Save the project.
5. Close PlanAhead by selecting File > Exit.
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Step 12: Creating an Image, and Testing

For this step you need to open an EDK shell, and create both a download.bit and a
system.ace file in the image/ directory. Copy the generated partial bit files, place them in the
image/ directory, and name them adder.bit, mult.bit, and blank.bit.

Renaming Partial Bitstream Files, and Generating the system.ace File

1. Launch the ISE Design Suite command prompt from your Windows environment by selecting
Start > All Programs > Xilinx Design Tools > Xilinx ISE Design Suite > Accessories > ISE
Design Suite Command Prompt.

2. Inthe command window, go to the <Extract Dir>/image/ directory.
3. Execute the following command to generate the download.bit file (with the software
component included) from adder.bit (with the hardware component) only.

dataZ2mem -bm ../edk/implementation/system bd

-bt ../PlanAhead/PlanAhead.runs/adder/adder.bit

-bd ../edk/SDK/SDK_Export/TestApp/Debug/TestApp.elf tag microblaze 0 -o b
download.bit

Hint: Copy the command text from this document and paste it in the shell or command
window by right-clicking and selecting Paste.

This generates the download.bit in the image/ directory.

4. In the Bash shell, execute the following command to generate the system.ace file in the
image/ directory.

xmd -tcl genace.tcl -jprog -target mdm -hw download.bit -board ml605 -ace
system.ace

5. Using Windows Explorer, copy and rename the following files, as shown in the following
table.
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File Name Copy to Rename File To
Directory
<Extract_Dir>/PlanAhead/PlanAhead.runs/adder/ | /image adder.bit

adder_math_0_math_0_user_logic_i_rp_instance_ad
der_partial.bit

<Extract_Dir>/PlanAhead/PlanAhead.runs/mult/m | /image mult.bit
ult_math_0_math_0_user_logic_i_rp_instance_mult_

partial.bit

<Extract_Dir>/PlanAhead/PlanAhead.runs/black_b | /image blank.bit

ox/black_box_math_0_math_0_user_logic_i_rp_inst
ance_math_bb_partial.bit

Copying the system.ace and Three Partial Bit Files on a Compact Flash

Memory Card

1. Place a blank Compact Flash memory card in a Compact Flash writer.

2. Using Windows Explorer, copy the three partial bit files and the system. ace file from
<Extract Dir>/image/ folder to the Compact Flash card.

3. Place the Compact Flash card in the ML605 board.

4. Set the SACE Mode pins (S1) to 0111 (dn-up-up-up) to configure the FPGA device from the
Compact Flash.

5. Connect your PC to the ML605 with the provided USB cable.

6. Install the driver, if necessary. For instructions, see the ML605 Hardware User Guide:
http://www.xilinx.com/support/documentation/boards and kits/ug534.pdf

7. Start a HyperTerminal window, connecting using COMx at 115200 baud and power ON the
ML605 board.

8. Press CPU Reset.

9. Follow the menu and test various reconfigurations.
Typing O at the menu will let you enter two operands and display the results. Typing M, B,
or A at the menu will let you partially reconfigure the multiplication, blanking, addition
functionality respectively.
Try various reconfigurations and enter operands after each reconfiguration to verify that the
design indeed works.
When blanking bitstream is loaded, you should see the output of -1 as there is no logic
present in the reconfigurable partition to perform the operation.
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Conclusion

In this tutorial, you:
e Created a processor system using XPS.
e Added a user peripheral which included a place holder for the reconfigurable partition.
e Generated netlist files.
e Created an application using SDK.

e Generated a full bitstream as well as partial reconfiguration bitstreams using the
PlanAhead tool.

e Generated an ACE file for Compact Flash memory card.

e Verified the functionality using the ML605 evaluation board.
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