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Lab Reference Guide

Preliminary Version

Note: At the time of the release of the course from which you obtained this guide, updates were
still being made to this Lab Reference Guide. As such, this guide is in a preliminary state.

For the final 2025.2 version, go to https://www.amd.com/en/training/customer/adaptive-
computing/downloads.html.

Introduction

This Lab Reference Guide is a collection of how to topics for commonly performed tasks in AMD
device and embedded development.

The guide is divided into the following sections:

¢ Vivado Design Suite Operations

e Vivado Analyzer Operations

o Vitis Model Composer Operations

o Vitis Unified IDE Operations

o Vitis Unified IDE HLS Component Operations
e QEMU Operations

e PetaLinux Operations

e Board, OS, COM, and IP Address Tasks

Each section may contain sub-sections.

Understanding the Lab Environment
Understanding the Lab Environment
The labs and demos provided in this course are designed to run on a Linux® platform.

One environment variable is required: TRAINING PATH, which points to the location of the lab
files. This variable comes configured in the CloudShare/CustEd_VM environments.

Some tools can use this environment variable directly (that is, $STRAINING PATH is recognized
and automatically expanded), and some tools require manual expansion
(/home/amd/training for the CloudShare/CustEd_VM environments). The lab instructions
describe what to do for each tool. Other environments require the definition of this variable for
the scripts to work properly.

The Vivado™ Design Suite and the Vitis™ Unified IDE offer a Tcl environment used in many
labs. When either tool is launched, it starts with a clean Tcl environment with none of the procs
or variables remaining from any previous launch of the tools.

If you sourced a Tcl script or manually set any Tcl variables and you closed the tool, when you
reopen the tool, you will need to re-source the Tcl script and set any variables that the lab
requires. This is also true of terminal windows—any variable settings will be cleared when a
new terminal opens.

AMDZ www.amd.com 3
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Nomenclature

Formal nomenclature is used to explain how different arguments are used. The following are
some of the more commonly used symbols:

Symbol

Description

Example

Explanation

<text>

Indicates a
field

cd <dir>

<dir> represents the name of the
directory. The < and > symbols are
NOT entered. If the directory to
change to is XYZ, then you would
enter cd XYZ into the environment.

[text]

Indicates an
optional
argument

1ls [ | more]

This could be interpreted as 1s
<Enter>orls | more
<Enter>. The first instance lists
the files in the current Linux
directory, and the second lists the
files in the current Linux directory,
but additionally runs the output
through the more tool, which
paginates the output. Here, the
pipe symbol (| ) is a Linux operator.

Indicates
choices

cmd <zCUl04

| VCK190>

The cmd command takes a single
argument, which could be zcu104
OR vCK190. You would enter
either cmd zCU104 or cmd
VCK190.

© Copyright 2026 Advanced Micro Devices, Inc.
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Vivado Design Suite Operations

In This Section

Creating and Opening OpPerationS...........oeuuuuuuuiiiee et e et e e e e eeeeenens 5
Vivado Add Sources OPErationS ............oeiiiiiiiiiieiie et 26
Embedded OPErations ...........oooiiiiiiiiiii e 33
Vivado IP Integrator Operations..............uuuii e 37
Vivado Elaborated Design Operations.............couiiiiiiiiiiiiie et 82
Vivado Simulation OPErationS..............iiiieuuie e 84
Vivado Synthesis Operations...........coooiiiiiuiii e 86
Vivado Implementation Operations ...........c.viiiiiiiiiiii e 91
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Vivado Hardware Session OPerationsS.............oveueiiiiiiieeee e 102

Creating and Opening Operations

In This Section

Launching the Vivado DeSign SUITE.........coooiiiiiiiiiii e 6
Launching the Vivado Design Suite Using a Linux Terminal ..............cccooiiiiiiiiiiiiiieiee e 7
Launching the Vivado Design Suite Tcl Shell...........cooooii 8
Creating a New Vivado Design Suite Project with Sources.............cccoovviiiiiiiiiiiie e, 8
Creating a Blank Vivado Design Suite Project ... 16
Opening a Vivado Design SuUite Project....... ..o 19
Opening Source Code inthe Editor...........ouuuiiiii e 19
Creating an HDL SOUICE File .........i i 20
Opening @ File iNthe EAILOr ........... e 22
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Closing the Vivado Design Suite Project .............coooii i 25
Closing the Vivado DeSign SUILE ..........oeuiieiiee e 25
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Launching the Vivado Design Suite

Here are two ways to open the Vivado Design Suite.

1-1.  Open the Vivado Design Suite.

1-1-1.  Click the Vivado icon ﬂ) from the taskbar.

'

Figure 1: Launching the Vivado Design Suite from the Taskbar

Note: It takes a few moments to launch. The order of the icons in your environment
may be different.

Alternatively, open the Linux terminal window (<Ctrl + Alt + T>) and enter the
following:

source /opt/amd/2025.2/Vivado/settings64.sh; vivado

Note: This installation path is valid for the CustEd VM and CloudShare environments.
Use the proper path for your environment.

The tool opens with a Welcome window. From here you can create a new project, open
an existing project, enter Tcl commands, and access documentation and examples.

6 www.amd.com AMDA1
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1-1-2.

[Optional] Maximize the window as there is a lot of information to see.

File Flow Tools Window Help | Q- Quick Access

Vivado

AMDZ
Vivado

ML Edition

Quick Start

Create Project >
Open Project >

Open Example Project »

Perform common
project tasks

Recent Projects

|

Tasks

Manage IP >

Open Hardware Manager >
Vivado Store >

Access non-project
tasks

Learning Center

Documentation and Tutorials >

Quick Take Videos >

Find documentation and

examples

What's New in >

Tcl Console

Q £ I B E @

v

Projects appear most recent
first (Tools > Settings)

. start_gui

View status messages
and executed Tcl
commands

72— Julfe| 3

< //
Type a Tcl command here

Search the database and
perform design tasks using| *
Tcl commands

v

>

Figure 2: Vivado Design Suite Welcome Screen

Hint: If the Tcl Console is not visible, double-click the Tcl Console tab to make it

visible.

AMDA
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Launching the Vivado Design Suite Using a Linux Terminal

1-1.

1-1-1.
1-1-2.

[Linux users]: If your system has not been configured with a shortcut on
the desktop or taskbar, then proceed with setting up and launching the
Vivado Design Suite environment.

Press <Ctrl + Alt + T> to open a new terminal window.

Enter the following command to set up the Vivado Design Suite environment
appropriately:

source /opt/amd/Vivado/2025.2/settings64.sh; vivado

Note: This installation path is valid for the CustEd VM and CloudShare environments.
Use the proper path for your environment.

Launching the Vivado Design Suite Tcl Shell

1-1.
1-1-1.

Launch the Vivado Design Suite Tcl shell.

Open a Linux terminal window (press <Ctrl + Alt + T>) and enter the following
commands:

[host]$ source /opt/amd/2025.2/Vivado/settings64.sh
[host]$ vivado -mode tcl

Note: The installation path (/opt/amd) is valid for the CustEd VM and CloudShare
environments. Modify the path as necessary for your environment.

This opens the Tcl interactive shell in the terminal itself.

Terminal

Figure 3: Vivado Tcl Interactive Shell in Terminal

www.amd.com AMD
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Creating a New Vivado Design Suite Project with Sources

Projects begin with the creation of a new project. The project contains sources,
settings, graphics, IP, and other elements that are used to build a final bitstream.

1-1. Create a new Vivado Design Suite project.

1-1-1.  Click Create New Project (1).

Fi o Tools
AMD{1
Vivado AM Dn Create a New Vivado Project
ML Editan . This wizard will guide you through the creation of a new project.
Vivado
ML Edition To create a Vivado project you will need to provide a name and a
location for your project files. N u will specify the type of

flow you'll be working with. Finally, you will specify your project
sources and choose a default part

Quick Start

ocreate Project >
.Open Project >
Open Example Project >
®

el T o R e T iy _w assr—— —al

Figure 4: Creating a New Vivado Design Suite Project

This will launch the New Project Wizard.

1-1-2.  Click Next to begin entering the specifics for this project (2).

AMDZD1 www.amd.com
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1-2.

1-2-1.
1-2-2.

1-2-3.

1-2-4.

You will now encounter a series of dialog boxes asking you to enter
different pieces of information describing the project.

Enter your project name in the Project name field (1).
Enter the following location in the Project location field (2):
project

Important: The Vivado Design Suite is capable of expanding variables when running
under both the Linux and Windows environments. The available environment variables
(regardless of the OS) must be predicated with the '$' symbol.

Alternatively, you can use the browse feature to navigate to where you want the project
to reside.

Uncheck the Create Project Subdirectory option if it is selected (3).
Leaving this checked will create an unnecessary level of hierarchy for the lab.

New Project x

Project Name
Enter & name for your project and specify a directory where the project data files will be |
stored.

|

project name: | Per instructions @
Project location: | Per instructions & ) -]
(|:| Create project subdirector}r( 3 )

Project will be created at:

(4) |
L?) | < Back | Mext = Cancel
|

Figure 5: Entering the Project Name and Location

Click Next to advance to the next dialog box (4).

Here you will specify your project type as either an RTL project or a post-synthesis
project. An RTL project enables you to add or create new HDL files and synthesize
them, whereas the post-synthesis project requires pre-synthesized files. When an
empty design is created, an RTL project is used.

10
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1-2-5. Select RTL Project since this project will be based on source code (rather than a
netlist) (1).

1-2-6.  Since you will be adding RTL files in the next instruction, deselect the Do not specify
sources at this time option (2).

New Project ¢
Project Type
Specify the type of project to create. |
%&TL Project
;?1:; :wa’?;iéle to add sources, create block designs in IP Integrator, generate IP, run RTL analysis, synthesis, implementation, design planning
( Do not specify sources at this tume( 2 '
Project is an extensible Vitis platform
Post-synthesis Project
You w{ll be able ta add sources, view devicegesources, run dgsign analysis, planning and implementatign.
'f?:' < Back Next Be Cancel
Figure 6: Setting the Project Type to RTL

1-2-7.  Click Next to accept the selection and advance to the adding sources stage (3).

1-3. Now that the project name, type, and location have been entered, the
wizard invites you to add source files to the project. You can add entire
directories where the sources are located, add specific files, or create new
sources.

Begin by adding the sources to your project.

1-3-1.  Click the Plus icon (+) to begin adding objects to the project.

1-3-2. Select Add Files from the pop-up menu to begin adding your source files to the
project.

New Project X
Add Sources
e e e et
Add Flles H add Directories || Create File

O] < Back | nex> | cancel | |
Figure 7: Adding Sources to the Project
After you add all the necessary files, the remainder of this dialog box will be addressed.
The Add Source Files dialog box opens.

AMD1 www.amd.com 11
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1-3-3. Browse to the project directory (1).
Figure 8: Adding Source Files

1-3-4. Multi-select your HDL sources from the list of source files and directories (2).
Note: There are equivalent Verilog and VHDL sources. Here you can choose either.
Verilog files have the extension . v, whereas VHDL files end with . vhd.
Hint: To use multi-select, press <Ctrl> and select each file.
Hint: Since this directory contains both VHDL and Verilog sources, you can use the
File Type drop-down list and select VHDL files or Verilog files to filter what files are
presented (3).
If you select afile, its contents are shown in the preview pane (4).
As you select files, they appear in the File Name field (5).

1-3-5. Click OK to accept the selected files and add them as sources to the project (6).
'tl)'he Add Source Files dialog box closes and brings you back to the Add Sources dialog

OX.
12 www.amd.com AMDA1
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1-3-6.

1-3-7.
1-3-8.

1-4.

1-4-1.
1-4-2.

1-4-3.
1-4-4.

1-4-5.

1-4-6.

Ensure that the Scan and Add RTL Include Files into Project and Copy Sources
into Project options are selected (1).

Select the target language using the drop-down list (2).
Click Next (3).

New Project x

Add Sources
Specify HDL, netlist, Block Design, and IP files, or directories containing those files, to add to your project, Create a new
source file on disk and add it to your project, You can also add and create sources later, ‘

+ - t 3

Index Name Library HDL Source For Location

< >

0 Add Files l l Add Directories | | Create File

Scan and add RTL jnclude files into project

vIICopy sources into project

Target language: | VHDL v Simulator language: | Mixed v

(2) < Back & Cancel

Figure 9: Setting Options in the Add Sources Window

Add any existing IP modules to the Vivado Design Suite project.
If you have existing IP modules, you will add them here.

Click the Plus icon (+) again to select the IP files.
Select Add Files to open the Add Source Files dialog box.

Since all Add Source Files dialog boxes are the same, you can refer to the previous
Add Source Files dialog box illustration.

Select or multi-select your IP modules.
Click OK to accept the selected files and add them as sources to the project.

If you have additional files located in other directories, you can repeat this instruction
for each directory.

Confirm that the Scan and Add RTL Include Files into Project option is selected
(used for Verilog, no effect for VHDL) in the Add Sources dialog box.

This will automatically pull in any include files used by Verilog sources.
Confirm that the Copy Sources into Project option is selected.

This will make a local copy of the source in the project space. Selecting this option
enables you to make changes to the local copy without affecting the original source file.

AMDA
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1-4-7.  Select your preferred language from the Target Language drop-down list.

This choice only affects which language is used for the generation of templates and
wrappers. You can add files in any language regardless of which target language is
selected. If you do not generate or use any templates or wrappers, this step is
irrelevant, and you can select any language.

1-4-8. Click Next to complete the adding of RTL sources and advance to adding any
constraint files.

1-5.  Add any existing constraint files to the Vivado Design Suite project.
If you have existing constraints, you will add them here.

1-5-1.  Click the Plus icon (+) to select the type of object you want to import (1).
1-5-2.  Select Add Files to open the Add Source Files dialog box.
The Add Source Files dialog box opens.

Since all Add Source Files dialog boxes are the same, you can refer to the previous
Add Source Files dialog box illustration.

1-5-3. Browse to the project directory.

Add Sources X

Add or Create Constraints

Specify or create constraint files for physical and timing constraint to add to your
project.

5 ify constraint set: ~

-~
Coni = widd Files. .. Location

Create File... |

< >

Add File | createFile |
{2

I\/ Copy constraints files into project

3
‘/:?/' I Finish Q‘ Cancel

Figure 10: Adding Constraints

1-5-4.  Select or multi-select your constraints file.
1-5-5. Click OK to accept the selected files and add them as sources to the project.

If you have additional files located in other directories, you can repeat this instruction
for each directory.

1-5-6. Confirm that the Copy constraints files into Project option is selected (2).

This will make a local copy of the source in the project space. Selecting this option
enables you to make changes to the local copy without affecting the original source file.

1-5-7.  Click Next to advance to selecting a target device (3).

14 www.amd.com AMD
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1-6. Select the target part by first filtering by board and then by family. If you
are not using a supported board, you will need to filter by part.

1-6-1.  Select Boards from the Select area (1).

1-6-2. Select the vendor of your board from the Vendor drop-down list in the Filter area (2).
This filters the available boards to those that are populated with any member of the
selected library.

1-6-3.  Select the board board from the list.

Alternatively, you can select the board directly from the list at any time while in this
dialog box.
New Project x
Default Part
Choose a default AMD part or board for your project. ‘
Reset All Filter @
Q o, T,
Search: | v :
< b - ‘
| [refresn |
Figure 11: Selecting the Board for the Project

1-6-4. Click Next to advance to the summary (3).

A summary of your project is displayed. If you want to change any of the information
that you entered, you can do so now by clicking Back until you reach the correct dialog
box and making the correction, or you can create the project now and edit the project
properties, add or remove files, etc. later.

1-6-5.  Click Finish.

Your project is constructed, and you are presented with the Vivado Design Suite main
workspace environment.

AMD1 www.amd.com 15
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Creating a Blank Vivado Design Suite Project

"Create Project" is the starting point for all designs. Projects contain sources,
settings, graphics, IP, and other elements that are used to build a final bitstream
and analyze a design. The Create New Project Wizard in the Vivado Design
Suite allows you to specify HDL and other project resource files that will be
included in the project.

1-1.

1-1-1.

1-1-2.

1-2.

1-2-1.
1-2-2.

1-2-3.

Create a new, blank Vivado Design Suite project.

Click Create Project to begin the process (1).

Vivado

FEile Flow Tools Window Help

New Project

AM Dn Create a New Vivado Project

. This wizard will guide you through the creation of a new project.
Vivado
ML Edition To create a Vivado project you will need to provide a name and a
location for your project files. Next, you will specify the type of
flow you'll be working with. Finally, you will specify your project
ources and choose a default part

~ Quick Start ;

Create Project >
Open Project >

Open Example Project >
®

el T _ N e ST e Syl

AMDA

Vivado
ML Edition

P

Figure 12: Creating a New Vivado Design Suite Project

This will launch the New Project Wizard.

Click Next to exit the introductory dialog box and begin entering project-specific
information (2).

Describe the various aspects of the project.

Enter your project name in the Project name field (1).
Enter the following location in the Project location field (2):
Enter project location here

Important: The Vivado Design Suite is capable of expanding variables when running
under both the Linux and Windows environments. The available environment variables
(regardless of the OS) must be predicated with the '$' symbol.

Alternatively, you can use the browse feature to navigate to where you want the project
to reside.

Uncheck the Create Project Subdirectory option if it is selected (3).

16

www.amd.com AMDA1
© Copyright 2026 Advanced Micro Devices, Inc. together we advance_



Lab Reference Guide

1-2-4.

1-2-5.
1-2-6.

1-2-7.

Leaving this checked will create an unnecessary level of hierarchy for the lab.

New Project x

Project Name
Enter a name for your project and specify a directory where the project data files will be
stored.

Project name: I Per instructions (D
Project Jocation: | Per instructions (2) [+
([:] Create project subdirector}r@

Project will be created at:

(?) = Back Cancel

Figure 13: Entering the Project Name and Location

Click Next to advance to the next dialog box (4).

Here you will specify your project type as either an RTL project or a post-synthesis
project. An RTL project enables you to add or create new HDL files and synthesize
them, whereas the post-synthesis project requires pre-synthesized files. When an
empty design is created, an RTL project is used.

Select RTL Project (1).

Select Do not specify sources at this time to instruct the Vivado tool to create a
blank project (2).

While existing sources could be entered at this time, you will enter them later so that
you can move through this portion of the project creation process more quickly.

New Project x

Project Type
Specify the type of project to create,

(@) BTL Project
g ileliiat’b e to add sources, creat

synthesis, irnglementa_tion. design pla

signs in IP Integrator, generate IP, run RTL analysis,
analysis.

Ilwl Do not specify sources at this time

|| Project is an extensible Vitis platform

y Post-synthesis Project
__ You will be able tgf™dd sources, g devige resources, run design analysis, plannipg apd,
You will be able taghdd So ige regources, i design analy d

LAy . 0je.
Create a new Vivado project from a predefined template,

l:'\_?':' | = Back | Cancel

Figure 14: Specifying Project Options

Click Next to advance to the target device/platform selection (3).

AMDA
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1-3.

1-3-1.

1-3-2.

1-3-3.

1-3-4.

1-3-5.

Select the target part by first filtering by the board name. If you are not
targeting a supported board, you will need to filter by the part.

Click Boards from the Default part area to filter by the board type rather than by the
specific part (1).

Select the vendor of your board from the Vendor drop-down list in the Filter area (2).
This limits the number of boards seen to those manufactured by the specified vendor.
Select the board board from the list.

If you accidentally click the hyperlink, a web page will open for that board. You can
close the browser page.

If the board you want to use is not immediately visible, click the Refresh button to
update the board catalog.

Note: While the web page contains important information and resources for the board,
these details are not needed to complete this lab.

New Project x

Default Part
Choose a default AMD part or board for your project. ‘

Reset All Filter @

Vendor: | All v Name: | All v Board Rev: | Latest v

Display Name Preview Status  Wendor File Version Part /O Pin Count

< 2

‘ Refresh ‘
| ""' < Back cancel |

Figure 15: Selecting the Board for the Project

Click Next to advance to the summary (3).

A summary of your project is displayed. If you want to change any of the information
that you entered, you can do so now by clicking Back until you reach the correct dialog
box. After the project is created, the project properties can still be edited.

Click Finish to accept these settings and build the project.

Your project is constructed and leaves you in the operational portion of the Vivado
Design Suite GUI.

18
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Opening a Vivado Design Suite Project

1-1. Open the existing Vivado Design Suite project your project name.
1-1-1.  Click Open Project from the Quick Start section (1).
The Open Project dialog box opens (2).
1-1-2. Browse to the following directory in the Look in field (3):
project
Note: The drop-down arrow shows the directory hierarchy.
1-1-3.  Select your project name from the files displayed (4).

File Flow Tools Window Help Q- Quick Access L4

AMDZ\ )
Vivado -
ML Edition 4

Quick Start

Create Project > g
Open Project > Y

Open Example Pruject >

Open Project

: Look in: I Per instructions ( 3 ’ v toP, @XC EEE
: Recent Directories
E@ File Preview
Yem >
< > -
rie game: | Per instructions (4 )
Files of type:  Vivadao Project Files (.xpr) v
Cancel

Figure 16: Opening an Existing Project

1-1-4.  Click OK to open the selected project (5).
The project now opens in the Vivado Design Suite.

AMDZD1 www.amd.com 19
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Opening Source Code in the Editor

1-1.  Open the desired source file in the editor.
1-1-1.  Under the Sources tab, locate the desired source file.

Note: This process is valid for any of the sub-tabs under Sources. Typically the
Hierarchy and Libraries sub-tabs are the most commonly used as these organize the
user files in the most convenient fashion.

BLOCK DESIGN -
d Sources = )Design Signals | Board ? 00
Qa ¢ + o

Lo

< ¥
Hierarchy @ |IP Sources Libraries Compile Order

Figure 17: Sources Tab

1-1-2. Double-click the desired source file to open it in the editor.

Note: You can also also right-click and select Open File to open the file in the editor.

Creating an HDL Source File

1-1. Create a new HDL source file called your HDL sources.
1-1-1.  Select Add Sources in the Flow Navigator under Project Manager.

w PROJECT MANAGER
£} Settings

Q = & +
Add Sources

~ Design Sources (5)
Language Templates

#

Sources ?

¥ IP Catalog 5 Coefficient Files (4)
> Constraints (1)
» P INTEGRATOR > Simulation Sources (5)

e o | i P - 2 eyl it i
Figure 18: Selecting Add Sources
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1-1-3.

1-1-5.

Select Add or create design sources (1).

Add Sources x

AMD“ Add Sources
Vivado

ML Edition

This guides you through the process of adding and creating sources
for your project

Add or create constraints @

(i Add or create design scurces)

) Add or create simulation sources

® @@

Figure 19: Selecting Add or Create Design Sources

Cancel

Click Next (2).

The Add or Create Design Sources dialog box opens.

Click the Plus (+) icon and select Create File.

Add Sources x

Add or Create Design Sources
‘ Specify HDL, netlist, Block Design. and IP files, or directaries containing those file types to add to your project. Create a [ ‘

new source file on disk and add it te your project,

Add Files...
‘.. Add Directories
.
A(Treate File...
addFles || addDirectories || create Flle

| ® |

Figure 20: Selecting Create File

The Create Source File dialog box opens.

Select your preferred language from the File type drop-down list.
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1-1-6. Enter your HDL sources as the file name.
Add or Create Design Sources
Specify HDL. netlist, Block Design, and IP files, or directories containing those file types to add to your [
project. Create a new source file on disk and add it to your project.
N
Create a ne(w source file and add it to
File type: Per Instruction
File name: Per Instruction
| File location: & <Localto Project>=  ~ | |
Heo ' mm =
®
Figure 21: Entering File Name and Type
1-1-7.  Click OK in the Create Source File dialog box.
1-1-8.  Click Finish to add the new source file(s).

The Define Module dialog box opens.

Opening a File in the Editor

This process is used to look at any type of text-based file. It is suggested that if
the file you want to open is part of the project, then you merely double-click the
filename when in the Hierarchical view or the Library view.

1-1. Open your file in the built-in editor.
1-1-1.  Select File > Text Editor > Open File.
‘EHE i:ml‘!ﬂw Iools  Reports }mnn:« ELSIM‘ View  Hel
B :
Close Proje: !
¢
Checkpoint %
T
Figure 22: Opening a Text File from the File Menu
A file browser window opens.
1-1-2. Navigateto the location of the text file to open.
1-1-3.  Select your file.
1-1-4. Click OK.
The text file opens in the workspace area.
22 www.amd.com AMDZA
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Importing IP

IP can be imported from a number of tools provided that they adhere to the IP-
XACT standard. Once created, the Vivado Design Suite must be made aware of
the presence of the IP. This is typically performed from an open project.

The instructions below describe the process of importing a single IP; however,
the steps can be repeated as necessary to collect different IPs from various

locations.

1-1. Import your IP cores into the open project.

1-1-1.  Using the Flow Navigator, select Project Manager > Settings (1).
The Project Settings Dialog box opens with the General tab open.

1-1-2. Expand IP (2) and click Repository to access the IP settings (3).

@ Project Settings A
Add Sources General ;
re
Language Templates Simulation
T | Catalog Elaboration
Synthesis
Implementation
v |IP INTEGRATOR ’
e erate Device Image y
Create Block Design i
Open Block Design Repository
Pack
Generate Block Design ackager
Tool Settings ‘
v AGIMULATION. Project

Figure 23: Accessing the Project's IP Settings
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1-1-3.  Click the Plus icon (+) to open the file browser to point to the IP repository in which
your IP is located (1).

1-1-4. Browse to where your IP is located (2).
1-1-5.  Click Select (3).

IMPORTANT: If the IP repository that you have selected has the IP in zip format, then
you will need to continue as described below. If, however, your IP has been expanded
(for example, if you are revisiting this step or adding another piece of IP), then it will
automatically appear in the IP in Selected Repository field. You can simply click OK to
complete the repository inclusion process.

The selected IP repository is scanned for all IP that is listed in the Select IP To Add To
Repository dialog box.

LEDcntrl - [fhome/xilinx/training/AXIbldPeriph/lab/LEDcntrl.xpr] - Vivado 2021.1

_ Default L
IP > Repository IP Repositories X
Add directories to the list of repositories. You may t

a selected repository. If an IP Is disabled then a tool . .4,

reason. vitoaREd, Xk = C|
Directory: | |
IP Repggifories ; ~
20 V1 N
No content
Refresh All

o / y
=] =] =

Figure 24: Adding the IP Repositories and the Specific IP

A window opens, showing the number of IPs being added to the project.
1-1-6. Click OK to close the Add Repository dialog box.
1-1-7.  Click OK again to exit the project settings.

24 www.amd.com AMDA1
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Closing the Vivado Design Suite Project

1-1. Close the project.
1-1-1.  Select File > Project > Close to close the project.

The Close Project dialog box opens.

Close Project x|

o OK to close project ?

[ [Joon't show this dialog again
| o |

Figure 25: Close Project Dialog Box

1-1-2.  Click OK.

Closing the Vivado Design Suite

1-1. Close the Vivado Design Suite.
1-1-1.  Select File > Exit.
The Exit Vivado dialog box opens.

Exit Vivado x

o 0K to exit Vivado?

[[Joon't show this dialog again |

Figure 26: Exit Vivado Dialog Box

1-1-2.  If you are asked to save the project or a portion of the project, select whichever
elements of the project you want to save, then click Save to save the selected
elements; otherwise, click Don't Save.

1-1-3.  Click OK when you are asked to exit the Vivado Design Suite.

Note: You can choose to select the Don't show this dialog again option to avoid being
asked for confirmation when exiting the Vivado Design Suite.

AMDZ www.amd.com 25
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Vivado Add Sources Operations

In This Section

Adding an HDL SOUICE Fle .......ooeieiieee e e 26
Adding a Simulation SoUrCe File ...........uuiiiii e 27
Adding @ ConStraint File ..........ui e e 29
Creating a SystemVerilog Simulation Source File ... 30
Adding EXisting CONSTraintS ........cooeiiiiiii e e 32

Adding an HDL Source File

HDL source files can be added to the design at any time.

1-1.
1-1-1.

Add an HDL source file to the design.
Select Add Sources under the Flow Navigator tab in the Project Manager.

v PROJECT MANAGER  »
- i

Sources —
£ Settings
Q = & +
Add Sources
~ Design Sources (5
Language Templates

“F IP Catalog H Coefficient Files (4
y Constraints (1

~ P INTEGRATOR > Simulation Sources (5

- ._"Wﬂr—-.“ N Y W PV at” b

Figure 27: Selecting Add Sources

The Add Sources dialog box opens, allowing you to add HDL source files to the project.

Add Sources x

AM Dn Add Sources

This guides you through the process of adding and creating sources

Vivado for your project

ML Edition
Add or create constraints

®) Add or create design sources)

Add or create simulation sources

@

P
v @ cencel

Figure 28: Selecting Add or Create Design Sources

Click Next to begin selecting source files (2).

The Add or Create Design Sources dialog box opens and prompts you to add existing
HDL source files or to create new HDL sources files.
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1-1-3.  Click the Plus (+) icon to open the context menu (1).
1-1-4. Select Add Files to begin adding the source files to the project (2).
1-1-5. Browse to the following directory if it is not open already:
your source directory
1-1-6.  Select your HDL sources.
1-1-7. Double-click the source file name in the Add Source Files dialog box to select the file(s)
or click OK (3).
1-1-8. Ensure that the Copy sources into project option is selected (when building IP this
will be listed as Copy sources into IP Directory) (4).
| Add or Create Design Sources | L Eupport = told @XC CUES
| Specify HDL, netlist, Block Design, and If Recent Directories
| new source file on disk and add it to yoy -
| % 9
| [ Add Directories... §
| Create File,.,
-
Scan and add RTL include files into| File name: |
? ) Copy sources into project{ 4 Files of type: Design Source Files (.vhd, vhdl, vhf, vhdp, vho, v, W, verilog, vr, vg, vb, tf. viog, vp. vm, veo, svo, vh,
";’.' =< Back [ Einish ®| Cancel
Figure 29: Adding Files
1-1-9.  Click Finish in the Add or Create Design Sources dialog box to add the HDL sources
to the project (5).
AMD1 www.amd.com 27
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Adding a Simulation Source File

HDL simulation files can be added to the design at any time.

1-1. Add simulation files to the design.
1-1-1.  Select Add Sources under Project Manager in the Flow Navigator.
~ PROJECT MANAGER »
Sources ? -
£ Settings
Q = £ +
~ Design Sources (5)
Language Templates
¥ IP Catalog 5 Coefficient Files (4)
> Constraints (1)
v P INTEGRATOR > Simulation Sources (5)
e w - *w =l -~ ‘ ﬁh—J“”' w-
Figure 30: Selecting Add Sources
1-1-2.  Select Add or create simulation sources.
Add Sources
Q\ZdDDa This guides you through the process of adding and creating sources for your project
ML Edition () add or create constraints
() add or create design sources
Iil:i Add or create simulation sources l
Figure 31: Add Sources Dialog Box
1-1-3.  Click Next.
1-1-4.  Click the Plus (+) icon to open the pop-up menu.
1-1-5. Select Add Files to open the Add Source Files dialog box which allows you to browse
to the desired directory.
1-1-6. Browse to the following directory if it is not open already:
STRAINING PATH/<the topic cluster name>/support
1-1-7. Select your HDL sources.
1-1-8. Click OK in the Add Source Files dialog box.
1-1-9. Ensure that the Copy sources into project option is selected.
1-1-10. Click Finish to add the file(s) to the project.
28 www.amd.com AMDA1
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Adding a Constraint File

Constraint files can be added to the design at any time. Here's how to add an
existing constraint file.

1-1. Add the constraint file to the Vivado Design Suite project.
1-1-1.  From the Flow Navigator, expand Project Manager (1).

1-1-2.  Click Add Sources to open the wizard (2).

1-1-3. Select Add or create constraints (3).

Add Sources x
P
AMDa Add Sources
. This guides you through the process of adding and creating sources for your project

Vivado

ML Edition ®) Add or create constraints |
) Add or create design sources |
) Add or create simulation sources

Figure 32: Adding Constraints

1-1-4.  Click Next to advance to the next screen (4).

1-1-5.  Click the Plus icon (+) to select whether you want to import or create a constraint file
(1).
Add Sources x

Add or Create Constraints

Specify or create constraint files for physical and timing constraint to add to your
project.

5 constraint set: -

~
con| SPAdd Files... Location

Create File... |

< >
| addriles ][ createrie |
{2
[Iz\ Copy constraints files into project
®

Figure 33: Adding Constraints

1-1-6.  Click Add Files to open the Add Constraint Files dialog box.
The Add Constraint Files dialog box opens.
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1-1-7.

1-1-8.

1-1-9.

1-1-10.

Browse to the 1location of your files directory.

[KCU105 users]: Select your constraints file.

[VCK190 users]: Select VCK190_uart_led_Project_Flow.xdc.

Click OK to accept the selected files and add them as sources to the project.

If you have additional files located in other directories, you can repeat this instruction
for each directory.

Confirm that the Copy constraints files into project option is selected (2).

This will make a local copy of the source in the project space. Selecting this option
enables you to make changes to the local copy without affecting the original source file.

Click Finish in the Add or Create Design Sources dialog box to add the sources to the
project.

Creating a SystemVerilog Simulation Source File

1-1. Create a new SystemVerilog file called your HDL sources.
1-1-1.  Select Add Sources in the Flow Navigator, under Project Manager.
~ PROJECT MANAGER .
Sources ? 1
L+ Settings
a = & + }
~ Design Sources (5
Language Templates
T IP Catalog > = Coefficient Files (4
> Constraints (1
~ |P INTEGRATOR > Simulation Sources (5
e vt __p e O . Y I _p WP L
Figure 34: Selecting Add Sources
1-1-2. Select Add or create simulation sources.
Add Sources
&\EEEN This guides you through the process of adding and creating sources for your project
ML Edition Add or create constraints
Add or create design sources
I ®) Add or create simulation sources ]
®
Figure 35: Add Sources Dialog Box
Note that selecting Add or create simulation sources will designate the file for
simulation only. When creating a design source file, you would select Add or create
design sources, which will designate the file for both synthesis and simulation.
30 www.amd.com AMD
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1-1-3.

1-1-4.

1-1-5.
1-1-6.

1-1-7.
1-1-8.

1-1-9.
1-1-10.

Click Next.

The Add or Create Simulation Sources dialog box opens.

Click the Plus (+) icon and select Create File.

Add or Create Simulation Sources

Specify simulation specific HDL files, or directories containing HDL files, to add to your project. Create a new source file on disk and add it ‘
to your project.

Specify simulation set &= sim_1 v
Add Files

Add Directories...

Creale File Use Add Files, Add Directories or Create File buttons below

‘ Add Files ‘ ‘ Add Direclories ‘ ‘ Create File

)
) = Back Ne) Cancel

Figure 36: Selecting Create File

The Create Source File dialog box opens.

Enter your HDL sources as the file name.

Select your preferred language from the File type drop-down list.

4 Add Sources =

Add or Create Simulation Sources
4 Create Source F_ =
Specity simulation specific HDL files, or directories containing HDL files, to a
Create anew source file and add tto your project

to your project

File type: Select File Type
@ File name: As Per Instructions

Specify simulation set: & sim_1 -

File location: | &7 <Local to Project> v

Use Add Files, Add Directories of

Add Files H Add Directories ‘[ Create File )

2 .
(2 <Back Ne Cancel

Figure 37: Entering Testbench Filename and Type

Click OK in the Create Source File dialog box.
Click Finish.
The Define Module dialog box opens.

Click OK to create the module without ports, since this module does not require them.

Click Yes to confirm that there the module definition has not been changed.

AMDA
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Adding Existing Constraints

1-1. Add your constraints file to the design.
1-1-1.  Click Add Sources under Project Manager in the Flow Navigator.
1-1-2.  Select Add or create constraints (1).
Add Sources X
AM Da Ac.ld S.()urces | |
Viva d o ;r:ésjecittudes you through the process of adding and creating sources for your
ML Edition 1
I (®) Add or create constraints ( )
() Add or create design sources
() Add or create simulation sources
Figure 38: Adding a Constraint File to a Vivado Design Suite Project
1-1-3.  Click Next to advance to the next dialog box (2).
1-1-4.  Click the blue Plus icon (+).
1-1-5. Select Add Files to open the Add Constraint Files dialog box.
1-1-6. Browse to the STRAINING PATH/CustEdIP directory.
Remember: You can always open a terminal window and enter echo
$TRAINING_PATH to see the value of this variable.
1-1-7.  Select your constraints file as the desired constraint file (1).
Add Constraint Files x
Look in: v tadE, @BXC EEE
@ Recent Directories ‘
File Preview
File name: m |
Files of type: | Design Constraint Files (.sdc, xdc) @J v
“ Cancel
Figure 39: Selecting One or More Constraint Files
1-1-8.  Click OK to select the file (2).
1-1-9.  Click Finish to add the constraint file to the project.
32 www.amd.com AMDA1
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Embedded Operations

In This Section

Exporting Only the Hardware DescCription...........cooieiiiiiiiiiii e e 33
Exporting the Hardware Description and Bitstream for Software Development...................... 35

Exporting Only the Hardware Description

Exporting only the hardware description rather than the completed bitstream is
beneficial during the hardware development cycle in that the software engineers
can begin writing code for the platform before needing the bitstream.

This engages the software developers earlier in the cycle and provides additional
time for the hardware engineers to make final tweaks to the hardware portion of
the design and ensure that the design meets timing.

1-1. Export only the hardware description.
1-1-1.  Select File (1) > Export (2) > Export Hardware (3).

Edit Flow Tools Reports Window Layout \iew Hel
o

Project v | = », B O X

Add Sources... BLOCK DESIGN - rgb2gray

Sources Design Sigr

a = = +

Save Block Design As...

Close Block Design
~ [ Design Sources (1

Checkpoint
=P > @5 rgb2gray_wrappel
? Constraints
~ [ Simulation Sources (1
b sim_1 (1
IP 3 0
: » = Utility Sources
Text Editor »

»
— r—( : )L
C £ Export Hardware...

Export Bitstream File...

Export Block Design...

Export Simulation...

Figure 40: Exporting a Design

The Export Hardware dialog box opens.
1-1-2.  When the Export Hardware Platform welcome page opens, click Next.
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1-1-3.  Select the type of output (1).
If your design is a PS-only design, select Pre-synthesis.
Otherwise, ensure that your design is completely implemented with a generated
bitstream and select Include bitstream.
Export Hardware Platform *x
zoeltlttﬁ:lt:v\atfarm properties to inform downstream tools of the intended use of the target platform's hardware
( Pre-synthesis
[This platform includes a hardware specification for downstream software tools, ( 1 )
( ?hc\‘sug\eagg?ﬁrﬁ:mudes the complete hardware implementation and bitstream, in addlt\on to the hardware)
specification for software tools.
= Back Cancel
Figure 41: Selecting What to Export
1-1-4.  Click Next to advance to the next dialog box (2).
1-1-5.  Select the XSA file name, which is the name of the output file (1).
This is automatically populated; however, you can select a different name.
1-1-6.  Populate the Export to field with the location of the files to be exported from the Vivado
Design Suite as the export location (2).
This option enables you to specify a location for the exported hardware definition.
Often it is beneficial to choose a directory separate from the hardware design files.
With the default <Local to Project> option, the Vivado Design Suite will export the
hardware definition to a sub-directory of the current Vivado Design Suite project
directory.
Export Hardware Platform *
::te:jthe name of your hardware platform file, and the directory where the XSA file will be stored.
(1)
x5A file name: | Per Instructions
Exporttoi | Per Instructions []
The XSA will be written to: @
Figure 42: Identifying the Export File Name and Location
1-1-7.  Click Next to advance to the next dialog box (3).
1-1-8.  Click Finish to proceed with the export.
This will create a file containing a description of the hardware and may contain a
bitstream as well at the selected export path.
34 www.amd.com AMDA1

© Copyright 2026 Advanced Micro Devices, Inc. together we advance_



Lab Reference Guide

Exporting the Hardware Description and Bitstream for Software
Development

1-1. Export the design for the software development tools.

The Vivado Design Suite enables you to export a description of the
embedded system design in the form of an XSA file. This XSA can contain
the design's bitstream.

1-1-1.  Select File (1) > Export (2) > Export Hardware (3).

Edit Flow Tools Reparts Window Layout View Helf
m
Project vl C T >

I Add Sources... BLOCK DESIGN - rgb2gray
Sources x Design
Save Block Design As...
a = & +

Close Block Design
~ [ Design Sources (1

> @ rgb2gray_wrappel
> = Constraints

Checkpoint 3

~ [ Simulation Sources (1
> sim_1 (1

IP 3
° > = Utility Sources

Text Editor 3

~y'mport 3 - |_
Export Export Hardware...
2 Print... Export Block Design...

) Export Bitstream File...
Exit

Export Simulation...

B Y

Figure 43: Exporting a Design

The Export Hardware Platform dialog box opens.
1-1-2.  Click Next to advance past the explanation panel.
1-1-3.  Select the type of output (1).
If your design is a PS-only design, select Pre-synthesis.

Otherwise, to ensure that your design is completely implemented and a bitstream is
created, select Include bitstream (for Zynqg UltraScale+ devices) or Include device
image (for Versal devices).

Export Hardware Platform

X

Output
5 tth e platform properties to inform downstream tools of the intended use of the target platform's hardware

@ Pre-synt ithe
This platfor, a hardware specification for downstream software tools

Include bitstream
This platform includes the complete hardware implementation and bitstream, in addmun to the hardware
specification for software tools.

Figure 44: Selecting What to Export

1-1-4.  Click Next to advance to the next dialog box (2).
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1-1-5. Enter your XSA file name as the XSA file name, which is the name of the output file
(1).
Usually, this is automatically populated; however, you can change this name.

1-1-6. Leave the Export to field with its auto-populated path, unless you want to select a
different path (2).

This option enables you to specify a location for the exported hardware definition.
Often, it is beneficial to choose a directory separate from the hardware design files.

With the default <Local to Project> option, the Vivado Design Suite will export the
hardware definition to a sub-directory of the current Vivado Design Suite project

directory.
Export Hardware Platform x
Files
Enter the name of your hardware platform file, and the directory where the XSA file will be stored.

XSA file name:l Per Instructions Q
Export to: | Per Instructions [++]
The XSA will be written to: 2
< Back & Finish | | Cancel

Figure 45: Identifying the Export File Name and Location

1-1-7.  Click Next to advance to the next dialog box (3).
1-1-8.  Click Finish to proceed with the export.

This will create a file containing a description of the hardware and may contain a
bitstream as well at the selected export path.
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Vivado IP Integrator Operations

In This Section

Creating an IP Integrator BIOCK DeSIgN..........uuiiiiiiiiiii e 37
CloSiNg @ BIOCK DESIGN. ...ttt e e e ettt e e e e e e e e eeataa e e e e eaeeeenna 39
(@] o7=T o o =1 =1 o Te3 Jql I 1= T o P 40
Zoom Operations in the IPI Block Diagram EditOr............ccooiiiiiiiiiiiiiieei e 40
Adding a Processor to the BIOCK DESIgN............uuiiiiiiiiieeie e 41
Adding a Zyng Family Processor BIOCK ..............oiiiiiiiiiii e 43
Adding a Processing System BIOCK...........ooiiiiiiiiiii e 47
Running Block Automation forthe PS ... 49
Customizing the Processing System IP .........ooorniiii e 51
Customizing the Zynq UltraScale+ MPSOC PS ... 55
Selecting a Zynq7 PS Preset Template ..o 57
Customizing the MIiCroBlaze ProCeSSOr ...........ii i 57
Adding IP to an IP Integrator BIOCK DeSIgN.........ccuuiiiiiiiii e 59
CUSTOMIZING [P ..o e ettt e e e e e e et eaeaba e e e e aaeeeenees 61
Making Manual Connections Between Two Objects in the IP Integrator............ccc...cooeo 61
Renaming @n IP BIOCK ........ oottt e e e e e et e e 63
Adding a Port to an IP Integrator Block Diagram.............ccouuiiiiiiiiiiieiii e 64
Making a Pin or Interface EXternal ............cooooiiiiii i 66
Running Connection AUtOMELION. ...........ii i 67
Running BIOCK AULOM@LION ... e e 68
Locating Objects in the Board DeSIgN ........ccooeiiiiiiiiiiieie e 69
Mapping Peripheral AQAreSSES .........oiiiiiiiie e 70
Generating OULPUL PrOAUCES .......oeeiieeeiie e e e eeees 72
Creating a Hierarchical Block in @ BIOCK DeSIgN............uuuuiiiiieiiieiiiiiie e 74
Adding IP to @ Hierarchy BIOCK ...........coooiuuiiiiii e 74
Expanding the Contents of a Hierarchical BIOCK .............cc.uiiiiiiiiiiii e 75
Opening a Hierarchical Block in @ New Tab...........ccooi e 76
Regenerating the LayOuL ......... .o 78
Running a Design Rule Check/Design Validation.................uuiiiiiiiiiiiiii e 79
Validating the BIOCK DESIGN .........ciiiiii e e 80
Saving the BIOCK DESIQN.....c.uniiii e e e e e e 80
Generating a Wrapper for a BIOCK DeSIgn ........coovviiiiiiiiii e 80
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Creating an IP Integrator Block Design

The Vivado IP integrator is a graphical tool that assists you in "stitching" together
various pieces of IP. This tool can be used for both embedded and non-
embedded designs.

1-1.
1-1-1.
1-1-2.

1-1-4.

Create a Vivado IP integrator block diagram.
Expand IP INTEGRATOR in the Flow Navigator if necessary (1).
Click Create Block Design to start creating a new IP subsystem (2).
Flow Navigator = @& ? _
~ PROJECT MANAGER
£ settings
Add Sources

Language Templates

IP Catalog
IP INTEGRATOR o
Create Block Design

Open Block Design

Generate Block Design

Vil RN e
Figure 46: Launching the IP Integrator

Name the design name of your block design when the Create Block Design dialog
box opens (1).

Create Block Design

Please specify name of block design.

Directory: s =Local to Project= ~ ‘

a .

|
Design name: I Per Instructions

Specify source set: Design Sources ~
P L

Figure 47: Creating an IP Integrator Block Design

Click OK to open a new, blank IP integrator canvas (2).
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The IP integrator workspace opens with a note in the canvas area inviting you to begin
adding IP.

PN sLock pesian

Q A o HEle + E * C Defaut View - E

Properties

o Console 1
Q= & Il B E@

Figure 48: Initial View of the IP Integrator Tool

Closing a Block Design

1-1. Close the block design.
1-1-1.  [Optional] If you want to preserve the block design, press <Ctrl + S>.
1-1-2.  Select File > Close Block Design.

Alternatively, you can click the "X" in the upper right-hand corner of the Block Design
view.

Confirm Close X

o QK to close 'Block Design'?

[J pon't show this dialog again

Figure 49: Confirming Block Design Closure

Note: You can select Don't show this dialog again if you do not want to confirm
closure in the future.

1-1-3.  Click OK.
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Opening a Block Design

1-1.  Open the name of your block design block design.

1-1-1.  Access the Sources > Hierarchy view.

1-1-2.  Locate the block design in the listing of the hierarchical sources.

If it is not readily viewable, click the Expand all icon (5).

1-1-3.  Double-click the block design entry.

The block design is indicated with a block design icon (r'Jr'-).

BLOCK DESIGN -
Sources X Design | Signals | Board ? 00
a T s + &

~ = Design SV
v @ ( ) (1)

@ R

> @ ( ) (2)
> Caonstraints

b Simulation Sources (1)

Hierarchy | |P Sources Libraries Compile Order

Figure 50: Opening an Existing Block Design

Zoom Operations in the IPl Block Diagram Editor

There are two methods to perform zoom operations in the block diagram editor.

o Method 1: Use the mouse gestures to zoom in for closer examination.

Click-Drag Click-Drag to Lower
Right Zooms Are

Click-Dragto -~

Lower Left - - - .~ .
ZoomsIn

Click-Drag to Upper
Left Zooms to Fit
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o Method 2: Use the horizontal toolbar to the top of the block design canvas.

Diagram ¥ Address Editor b4 Diagram-micr

e s ¥
4

processing_system:

- L o -rlL_.Z}-ND_?Pa:c:ﬁi_nE S}ﬂ“ﬂ' if

Figure 51: Block Diagram Zoom Toolbar

Adding a Processor to the Block Design

1-1.  Add your processor to the IP integrator canvas.
1-1-1.  Open the IP catalog in one of two ways:
o Click the Add IP icon.

2w o @ = C oy

Ry

L |
This design is empty. Press tI@ﬁcn to add IP.

dl

Figure 52: Opening the IP Catalog from the Add IP Icon

Diagram

-OR -
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o Right-click any background space in the workspace and select Add IP.

Diagram

-
&
+

Rigllt-click

., Fre
., Wr  SelectAll
-
L ]
‘—*C+ AddIP... Cirl+ )
Add Module...
IP Settings

Figure 53: Opening the IP Catalog from Right-Clicking the Workspace

Important Note: Using Window > IP Catalog will add the new IP to the top level of hierarchy
of the design—it will NOT add the IP to the diagram! You can, however, float the Window > IP
Catalog and drag-and-drop from the catalog onto the canvas of the block design.

Once the IP catalog opens, you can search for the processor block.

Search: |

¥ 1G/2.5G Ethernet PCS/PMA or SGMII ~ Search by
¥ 2D Graphics Accelerator Bit Block Transfer TEXt

4F 3GPP LTE Channel Estimator Cnntent

3GPP LTE MIMO Decoder

:‘;:

#F 3GPP LTE MIMO Encoder Search

T2 agmm Manually
by

4 AHB-Lite to AXI Brdge Scrolling

F Audio 125 Transmitter/Receiver
IF AXl-Stream FIFO

F AX] 1G/2.5G Ethernet Subsystem
iF AX|4-Stream Accelerator Adapter
4F AX|4-Stream Broadcaster

W

EMNTER to select, ESC to cancel, Ctrl+C for IP details

Figure 54: Two Mechanisms to Search for IP

1-1-2.  Enter part of the processor name into the Search field to narrow the search parameters

(1).
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For example, zynq will show the PS for the selected Zynqg family or microblaze for the
MicroBlaze processor. Note that the PS IP will only appear when a family containing
this IP or a board with this part has been selected for the design.

10)
T Zyng UltraScale+ MPSoC @

F ZYNQ UltraScale+ SYNC IP

F ZYMNQ UltraScale+ WCU

F ZYNQ UltraScale+ VCU DDR4 Controller

L Batd

(4 matches)

ENTER to select, ESC to cancel, Ctrl+Q for IP details

Figure 55: Searching for the Zynq UltraScale+ MPSoC Block

1-1-3. Double-click your processor to add its IP block to the design (2).
Diagram ¥ Address Editor X b 4
@ a 3 B o q + & C U «f
,* Designer Assistance available. Run Block Automation f
’
r zyng_ultra_ps e 0 A '{
AN
M_AXI_HPMO_LPD <+ 1
maxihpm0_lpd_aclk pl_resetn /
® pl_clko {
UltraSCALE* p
L Zynqg UltraScale+ MPSoC - h
s w Pt gt P et P o P "‘
Figure 56: Zynq UltraScale+ MPSoC Block Symbol
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Adding a Zynq Family Processor Block

1-1.

1-1-1.

Add a Zynq PS processor block to the design. While the specifics of the
processing systems found in the Zynq 7000 SoC, Zynq UltraScale+
MPSoC/RFSoC, and Versal devices differ, the process of instantiating
them is the same.

There are several ways to open the IP catalog. Select one of the following
procedures to add IP to the canvas.

Use one of the following methods to open the IP catalog:

o Click the Add IP icon (+) in either the middle of the canvas or the toolbar.

This icon can be found in the middle of the canvas only when you are starting with a
blank page.

Diagram

This design is empty. Press th

"\.*‘..M "\ ‘»

Figure 57: Opening the IP Catalog from the Initial Information Bar Display
-OR --

o Right-click any background space in the workspace and select Add IP.

Diagram X Address Edito x
@ Q I = < Q + = » C 9 T f

Q  Search...
. We  SelectAll

........ > G. AddIP.. )

Add Module...

Figure 58: Opening the IP Catalog by Right-Clicking the Workspace
—-OR --

o Press <Ctrl + I> to access the IP catalog.
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Note: Although the convention is to show the capital letter, the key combination uses a
lower case 'i'

Once the IP catalog opens, you can search for the Zynq SoC processor block.

Search: |

¥ 1G/2.5G Ethernet PCS/PMA or SGMII ~ Search by

4 2D Graphics Accelerator Bit Block Transfer TEXt

4F 3GPP LTE Channel Estimator Cnntent

IF 3GPP LTE MIMO Decoder s h

4F 3GPP LTE MIMO Encoder carc

e Manually
by

4 AHB-Lite to AXI Bndge Scrolling

¥ Audio 125 Transmitter/Receiver
IF AXl-Stream FIFO

F AXl 1G/2.5G Ethernet Subsystem
iF AX|4-Stream Accelerator Adapter
4F AXl4-Stream Broadcaster

W

EMNTER to select, ESC to cancel, Ctrl+C for IP details

Figure 59: Two Mechanisms to Search for IP

1-1-2.  Enter zynq into the Search field to narrow the search parameters (1).

The proper IP will appear depending on the board or device that you selected. The PS
of the Zynq 7000 device will appear as ZYNQ7 while the MPSoC/RFSoCs will show as
Zynq UltraScale+ MPSoC, and so forth. Only the IP supporting the device you selected
will appear in the IP list.

Note that the processing system for the Versal devices is referred to as "Control,
Interfaces & Processing System" and will NOT appear under a search for "Zynq" as it
is not in the Zynq family of devices.

(3 matches)
Se ynq (1 match) .- CIPS (1 match)
(: ZYNQ7 Processing Systb Contro\ Interfaces & Processing Systeb
oller 2 2

Figure 60: Selecting Multiple Architectures

ZYNQ UltraScale+ VCU O

This is the IP for the entire processing system (PS).
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1-1-3.  Double-click the IP name to add the processing system block to the design (2).
Diagram ¥ Address Editor x
@ e N &= © Q s +  # C o

? Designer Assistance available. Run Block Automation

zyng_ultra_ps e O

M_AXI HPMO LPD |3
maxihpml lpd_adk d_reasind
» d_cki

UltraSCALE?

Zyng UltraScale+ MPSoC

N

Figure 61: Zynq UltraScale+ MPSoC/RFSoC PS Block Symbol

Diagram x Address Editor x ¥
nA "

@ a H xB O Q + = ;:’
* Designer Assistance available. Run Block Automation -
processing_system7_0 P
( 4

DOR + ||
- FIXED_IO + || J
= M_AX| GPO ACLK M_AXI GPO +[ii y
ZYNO' FCLK_CLKO
FCLK_RESETD_N lf
1
L

ZYNQ7 Processing System f

-

:r
|

Figure 62: Zynq 7000 SoC PS Block Symbol

Diagram E |
@ @ M X o a = + B #, C o = DefaultView v 1
» Designer Assistance available. Run Block Automation f
4

versal_cips_0 ri

L

@ }

S 4

Control, Interfaces & Processing System 2

e f V = et i i IR o e '{

Figure 63: Versal Adaptive SoC CIPS Block Symbol
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Adding a Processing System Block

1-1. Add a processing system block to the design.
The processing system is available for multiple devices, including the
Zynq 7000 SoC, MPSoCs, RFSoCs, and other families. Only the
processing system for the specific family can be added to the design.
That is, you cannot add a Zynq 7000 SoC processing system to a Versal
part.
There are several ways to open the IP catalog. Since this is a blank
canvas, you are invited to click the add IP icon in the middle of the
canvas.
1-1-1.  Click the Add IP icon (+) to open the IP catalog.
Diagram ? ?
O +
&, embd_design j
This design is empty. Press 1|'|E®3Llﬂi-2|'| to add IP.
4
Figure 64: Opening the IP Catalog from the Initial Information Bar Display
Regardless of whether the design already has IP placed, you can always open the IP
catalog in one of several ways:
o Click the Add IP icon (+) in the toolbar of the workspace.
Diagram .'
o © = C f
’
4
Figure 65: Opening the IP Catalog from the Add IP Icon
—-OR --
AMD1 www.amd.com 47

together we advance_ © Copyright 2026 Advanced Micro Devices, Inc.



Lab Reference Guide

o Right-click any background space in the workspace and select Add IP.

Diagram »* Address Editor *
@ @ X = o Q + ¥ # C g T
L ]
.
.
-
. Q, search..
%, Ws  SelectAll

..UIIIIBI>G- AddIP...

Add Module...

Pinpina

Figure 66: Opening the IP Catalog by Right-Clicking the Workspace

-OR -

o Press <Ctrl + I> to access the IP catalog.

Note: Using Windows > |P Catalog will add the new IP to the top level of hierarchy of the
design — it will NOT add the IP to the diagram! You can, however, float the Windows > IP
Catalog and drag-and-drop from the catalog onto the canvas of the block design.

Once the IP catalog opens, you can search for the processing system block.

Search: |

4= 1G/2 5G Ethernet PCSPMA or SGMI ~ Search by

¥ 2D Graphics Accelerator Bit Block Transfer Text

4F 3GPP LTE Channel Estimator Cnntent

IF 3GPP LTE MIMO Decoder 3 h

4F AGPP LTE MIMO Encoder earc

e Manually
by

4 AHB-Lite to AXI Bndge Scrolling

¥ Audio 125 Transmitter/Receiver
IF AXl-Stream FIFO

IF AXI 1G/2.5G Ethernet Subsystem
IF AXl4-Stream Accelerator Adapter
4F AXl4-Stream Broadcaster

W

EMTER to select, ESC to cancel, Ctrl+Q for IP details

Figure 67: Two Mechanisms to Search for IP
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1-1-2.  Enter zynq into the Search field to narrow the search parameters (1).

The processing system for the selected family appears. The exception to this is that an
MPSoC PS is used by both the MPSoC and RFSoC parts, so if an RFSoC device is
targeted, a Zynq UltraScale+ MPSoCs PS is used.

(1 match)

Figure 68: Selecting the Zynq UltraScale+ MPSoC IP

This is the IP for the entire processing system.
1-1-3.  Double-click the IP entry to add the processing system block to the design (2).

zyng_ultra_ps e 0

M_AXI_HPMO_LPD i}
maxihpm0_lpd_aclk pl_resetn0
® pl_clkd

UltraSCALE+

Zyng UltraScale+ MP5oC

Figure 69: Zynq UltraScale+ MPSoC Block in the Block Diagram

Running Block Automation for the PS

Many IP blocks are supported by Designer Assistance. Designer Assistance
automates many of the commonly used basic connections and/or configurations.

1-1. Use Designer Assistance to make preliminary connections to the IP block.

1-1-1.  If the block design is not already open, select the Diagram tab in the Block Design
pane to view the block design.

Aclcl’essEcIi:C' b
Q = E (9 a +

*
Ful Designer£$Lstance availabIeCRun Elock.ﬂ.utomatioa -

YoagulW
Figure 70: Selecting the Diagram Tab

1-1-2.  Click Run Block Automation to launch Designer Assistance.
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1-1-3.

1-1-4.

1-1-5.

The Run Block Automation dialog box opens.

If multiple IPs have not yet been configured with the Block Automation, they will appear
in the left-hand pane. This allows bulk selecting IP.

Select only the name of the PS block from the left-hand pane (1).
This will bring up the specific options for the PS in the right-hand pane.

You now have an opportunity to apply a board preset. If you apply the board preset,
this will undo any modifications that you made to the PS using the Re-customization
Wizard.

Select this option ONLY if you have not made any changes to the PS's configuration.
Select or deselect the Apply Board Preset option (2).

Warning: Having this selection enabled will overwrite any work done using the Re-
customization Wizard.

Run Block Automation *

Automatically make connections in your design by checking the boxes of the blocks to connect, Select a block on
the left to display its configuration options on the right. n

Q| = | S

v &4 All Automatian (1 out of | This option sets the board preset on the Processing System. All current

i | Name of PS B|ock©:er‘ties will be overwritten by the board preset. This action cannot be

Description

ne.

E: Apply Board Preset will discard existing IP configuration - please
uncheck this box, if you wish to retain previous configuration.

{ Instance: fayng_ultra_ps_e_0

Options

Apply Board Preset: IJIO

<
| =
G Cancel

Figure 71: Running the Designer Automation Assistance on the PS
The dialog box lists the connections that will be created: the FIXED_IO (MIO
connections) and the DDR interface connections.

Click OK to run the block automation on the PS (3).
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Customizing the Processing System IP

The processing system (PS) contains a large number of customizable features.
The following instructions will illustrate how to access various sections of the PS.
Because the Re-customization Wizard differs among the different processing
systems, explicit directions regarding what to turn on or off is omitted. This step is
one of exploration rather than achieving a specific outcome.

While the Re-customization Wizard for the Versal devices is significantly
different, it fundamentally performs the same types of tasks: identifying which
peripherals are used, how they are configured, which AXI connections are
available to the PL, etc.

The figures and instructions focus on the Zynq family of PS, and the details of the
Versal device's PS are not discussed here; however, notes regarding the Versal
device are included where appropriate.

1-1. Access the Re-customization dialog box.
1-1-1.  Double-click the PS block.

The specific name of this block varies with the type of device. Some variation of "Zynq"
will bring up the PS for the Zynq 7000 devices as well as the MP/RFSoC devices. The
Versal device has its processing system IP as "CIPS" for Control, Interfaces &
Processing System.

Users with projects targeting a ZCU104 board or any other MPSoC or RFSoC device
will see a ZYNQ UltraScale+ block. Zed/ZC702 users will see a Zynq entry specific to
the part or board selected. Versal adaptive SoC users (VCK190) will see the CIPS
module.

-OR --
Right-click the PS/CIPS block and select Customize Block.

il
b

1 Block Properties P80 ax|_per
‘ | % Highlight L]
— ZYNQ™ ... -
l_nght—CIlck UltraSCALE+ & | Comr sem gl
1 K
Q, Search FSETN
rst_ps8 Y4 96M W Selectal AXI Interconi
4+  Addip..

slowest_sync_clk

ext_reset_in
g auwx_resel_in
= mb_debug_sys_rst
= dem_lacked

* -

peripheral_aresetn[0

Add Module..

s Make External

®  Run Block Automation...
Customize Block...

Processor System Reset IP Dacumentation ' {

-

Figure 72: Opening the Re-customization Wizard for the PS (MP/RFSoC Example
Shown)

The Re-customization dialog box opens to reveal the PS's block design.
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1-2.

1-2-1.

1-2-2.

1-2-3.

[Zynq 7000 SoC users]: Import board-specific settings.

If you are using a supported evaluation board, you will probably want to
load the pre-defined settings as it contains many of the parameters
specific to that board (such as DDR memory timing parameters, enabled
peripherals supported by that board, etc.) A similar capability is available
for the MPSoC/RFSoC devices and is explained elsewhere.

You can also create a .bd file for your custom board if you want and
import those settings.

The Zynq UltraScale+ MPSoC presets behave differently than the Zynq
7000 device presets. The Zynq 7000 device presets contain settings for
various evaluation boards while Zynq UltraScale+ MPSoC presets enable
you to save and recall your own specific settings. The equivalent
functionality can be found for the MP/RFSoC devices using Block
Automation.

Click Presets to access the pre-defined values associated with one of the supported
boards that supports the Zynq 7000 SoC (such as the ZC702 or ZedBoard).

Note: If you are building a board of your own, it is possible to create your own preset
for that board. Presets are very convenient as they can describe the DDR settings as
well as enable the peripherals and their pin mappings for the specific board. This saves
a tremendous amount of effort for the designer.

1 Re-customize IP
i
ZYNQ7 Processing System |

@ Documentation | Presets IP Location &F Import XPS Settings

Page Navigator Zynq Block Design

Zynq Block Design

PS-PL Configuration

Peripheral I/0 Pins as0)

MIO Configuration | -

Clock Configuration Hux
(MIO)

DDR Configuration [ussa

SMC Timing Calculation ENET 1 Central

Interrupts (53:16)

Figure 73: Accessing the Presets (Zynq PS)

If you have a Tcl script that describes the configuration of the PS, you can load it by
selecting Presets > Apply Configuration.

Select your board for the preset.

This will configure the PS for the settings specific to that board, including DDR timing
parameters, peripherals, etc.

Note: The Versal device contains a multitude of presets and individual groups that can
be uniquely preset for specific purposes. These settings can be saved as a system-
level preset and recalled at will.

Skip the next instruction as it duplicates this instruction, but for Versal device users.
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The next instruction provides you with general guidance as to how to customize

various

aspects of the PS. At the end of this instruction, you will be provided with

specific guidance regarding how you are to customize the PS.

1-3. [Versal adaptive SoC users]: Explore the Re-customization Wizard.

1-3-1. When the wizard opens, click Next to move past the "Presets" page.

1-3-2.  Click the PS PMC block to open a configuration window for the processing system and
platform management controller (1).
This block more closely aligns with the Zynq families in that it provides access to the
configuration information for the peripherals, AXI interconnects, clocking, etc.
New in the Versal family's architectures is the network on chip (NoC), which facilitates
rapid data movement among the maijor blocks in the system and, unlike the other
processing systems which contains their own DDR memory controllers, the CIPS block
requires the NoC to gain access to up to four independent or coordinated DDR
memory controllers.

1-3-3.  Click each element in the list to see the options available for that sub-section (or click
Next which will proceed through the list).

1-3-4.  Click Cancel to return to the previous page without making any changes (2).

1-3-5.  Click the CPM block to access the CPM (PCle block and CPM interface) configuration
settings (3).

1-3-6.  Explore the various modes available for the PCle blocks.

1-3-7.  Click Cancel to return to the previous page without making any changes (4).

®- n ®
............. < 7 p—— ~

Figure 74: CIPS Re-customization Wizard - Page 2

1-3-8.  Click Cancel to exit the wizard.
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1-3-9.  Enter the following in the Tcl command line to run the Tcl proc to configure the Versal
device CIPS:
versalCIPSconfigure
This proc configures the CIPS IP so that the following instructions can be performed.
1-4. [All Zynq device users]: Select the page or specific block to re-customize.
1-4-1.  Click the topic in the Page Navigator or any green (active) box from the diagram.
Along the left are the navigational tabs that you will use to access different groups of
parameters.
Note: Advanced mode is available for the MPSoC/RFSoC families, but not for the Zynq
7000 family. The figure below represents the MPSoC devices' Re-customization main
dialog box. The Zyng 7000 family is similar, but less complex.
A(j::'f:;giés:f;gﬁ’_':;:" | yna ultrascales MpSo€ Click the Page Navigator Topic
N
(m:k":anﬂgutauon l }‘ — m |
PS—P\:Zur‘-:guiat\cn l N @
b SATA O SATA 1 »
Core SW -—‘-—‘ §§ L
Figure 75: Navigating the Zynq PS Recustomization Dialog Box
o PS-PL Configuration: This page contains all the signals that cross the PS-PL
boundary. For the Zyng 7000 devices, these signals are broken down further into:
= General: Contains default baud rates for the UARTSs, FTM trace buffer settings,
PS-PL cross triggering enables, enables for the clock triggers, and reset.
= DMA Controller: Contains enables for the four peripheral request interfaces.
= GP Master AXI Interface: Enables/disables access to the GP Master AXI
Interfaces to the PL.
= GP Slave AXI Interface: Enables/disables access to the GP Slave AXI
Interfaces from the PL.
= HP Slave AXI Interface: Enables/disables access to the HP Slave AXI
Interfaces from the PL and sets the port width.
= ACP Slave AXI Interface: Enables/disables access to the ACP Slave AXI
Interface from the PL.
o Peripheral 1/0 Pins (for Zyng 7000 SoC only)
o /0O Configuration (MIO Configuration for Zyng 7000 SoC)
o Clock Configuration
o DDR Configuration
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o SMC Timing Calculation (for Zynq 7000 SoC only)
o Interrupts (Zynqg UltraScale+ has this setting under PS-PL Configuration)
o PS-PL Configuration

Customizing the Zynq UltraScale+ MPSoC PS

The Zynq UltraScale+ MPSoC PS contains many customizable features. The
following instructions will illustrate how to access various sections of the Zynq
UltraScale+ MPSoC PS, not necessarily indicating which settings to configure.

1-1. Access the Re-customization dialog box.
1-1-1.  Double-click the Zynq UltraScale+ icon.
—-0OR --

Right-click the Zynq UltraScale+ icon and select Customize Block.

F a

A Block Propeties.
- ZYNQ,

.y
1 “re.., UltraSCALE* | X o
4.....
-
"0. Search...
-
.'

Select All

»

Highlight

m X

# 0

*e 4+  Adde
*. Add Module
*a, L Make External

.'._\ #  Run Block Automation

Customize Block.
IP Documentation

“vwwww
Figure 76: Customizing the Zynq UltraScale+ MPSoC

The Re-customization dialog box opens to reveal the Zynq block design.
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1-2. Select the page or specific block to re-customize.
1-2-1.  Click the topic in the Page Navigator or any green (active) box from the Zynq
UltraScale+ MPSoC block diagram.
Along the left are the navigational tabs that you will use to access different groups of
parameters.
i. Re-customize IP S i
Zynq Ultrascale + MPSoC Click the page --Alternatively--
Navigator topic Click any green box to |
‘ 0Dccumentat|on 'U-Presets an take navigate to speciﬁc
Page Navigator traScale+ Block Design
[ switch To Advanci \rgﬁr'm-ram%
RPU Lo —
PS Ultrascale+ Blos APU n e
1/ Configuration cL ‘ ‘ﬂ/ \M/
| Clock Configuration |o|!| {258IERY ‘ :—_L_ -] r(} GPU Mali-400
DOR Configuration I { PClo Gan2 x1/x2/xd
| PS-PL Configuration . Iﬂ“ﬂ‘
-‘-.| GEM 0 GEM 1 :X: | Display Port
|_|“'“ \—‘“”3 o Core SW ig 4
§ om0 Jlusma |7 L - :
iz
*’I SPO 5PI1 zu
| s | o |gh R
‘ <--| [F] 1’c1 4—.E= g ‘
q—-{um’o ” UART 1 ‘ s _ §E
= [y %és
(41 AnlL LPD_DMA ‘ :nnn.u::ni?:::;g:t'!.mnnnn ‘ Eg | ELE |
i | oK | ‘ Cancel |
Figure 77: Re-customize IP Dialog Box
o PS-PL Configuration: This page contains all the signals that cross the PS-PL
boundary. These signals are broken down further into:
= General: Contains interrupts from PS to PL and PL to PS, Address
Fragmentation parameters and others such as the RTC, DMA, and Live Audio
and Video settings.
» PS-PL Interfaces: Contains enables for all the available AXI masters and slaves
including the ACP and ACE slave AXI interfaces.
= Debug: PS - PL cross-trigger inputs and outputs and general-purpose inputs
and outputs.
o 1/O Configuration
o Clock Configuration
o DDR Configuration
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Selecting a Zynq7 PS Preset Template

1-1. Configure the ZYNQ7 processing system using the Preset template.

1-1-1.  Double-click the ZYNQ7 Processing System IP block to open the Re-customize IP
dialog box.

1-1-2.  Click Presets in the Re-customize IP dialog box.

This preset contains settings appropriate for your board, such as peripheral pin
locations, DDR memory parameters, etc.

1-1-3.  Select the preset for your board.

¢ Re-customize IP '
Zynq UltraScale+ MPSoC (]/ :
0 Dncumematmn IP Location 5
Page Navigator PS UltraScale+ Block Design

<

Switch To Advanced Mode

RPU
ES UltraScale+ Negion

Figure 78: Selecting a Preset Template

1-1-4.  Click OK to load the values associated with this preset.

Customizing the MicroBlaze Processor

1-1. Configure the MicroBlaze processor system with a Typical configuration.

The Typical configuration is one of several customizable configurations. It
includes an MDM interface for debugging, instruction and data caches for
use with DDR memory, and exception/interrupt handling. This
configuration provides a balance between frequency, area, and overall
performance.

1-1-1.  Double-click the MicroBlaze IP block or right-click the MicroBlaze IP block and select
Customize IP.

Block Properties.
# Highlight

r+ Al X Delete
i MicroBlaze ® i3 | & °”
L .'_ a Q. search
'-‘ W selectAl
Right-click -_‘ + g,

Add Module

s Make Exdternal

Figure 79: Starting Customization on the MicroBlaze Processor
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1-1-3.

1-1-4.
1-1-5.

1-1-6.
1-1-7.

1-1-8.

The Re-customization IP dialog box opens.

Select Typical from the Predefined Configurations > Select Configuration drop-down
list.

B .

z

croBlaze (11.0)

MicroBlaze ™

ge Informa

rrrrrrrrrrrrrr

Figure 80: Selecting the Typical Configuration for the MicroBlaze Processor

Notice that the Enable MicroBlaze Debug Module, Use Instruction and Data Caches,
and Enable Exceptions options are automatically selected as part of the Typical
configuration. Cache memory is good to have when dealing with slower memories such
as DDR and Flash.

Review the default settings for the Typical configuration.

The MicroBlaze processor can be built as either a 32-bit or 64-bit implementation.
Select the 32-bit Implementation.

Leave the General Settings pull-down option at PERFORMANCE.

While the predefined configurations and general settings (implementation optimization)
choices define the general configuration and options of the MicroBlaze processor,
other options can be selected and overloaded into the default settings made by these
configurations. Generally, these options address supporting hardware for the core
processor's capabilities and includes debugging capabilities through the MDM, caches,
memory management units, etc.

If selected, deselect the Use Instruction and Data Caches option.

Ensure that the Enable MicroBlaze Debug Module Interface and Enable
Exceptions options are selected.

This is done to illustrate how preconfigured settings can be overridden by the user.
Cache is most useful when applied in conjunction with DDR memory. If the MicroBlaze
processor is running entirely out of block RAM, the caches may actually degrade the
performance of the system.

Note that there are several pages where modifications to this configuration can be
made. You can explore these settings as time permits.

Click OK to save this configuration.
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Adding IP to an IP Integrator Block Design

1-1.  Open the IP catalog.
1-1-1.  The IP catalog can be opened in several ways:

o If the design is empty, add IP by clicking either of the '+" icons.

Diagram ’
bR & # C (

-
This design is empty. Press th button to add IP. )

Figure 81: Opening the IP Catalog from the Initial Information Bar Display

o Right-click any background space in the workspace and select Add IP.

Diagram » Address Editor *
@ a X m O Q + E)‘CCJ':’
s
*
-" Q, search..
%, Ws  SelectAll
ol
pRELELL )G‘ AddIP... )

Add Module...

Figure 82: Opening the IP Catalog by Right-Clicking the Workspace

o Press <Ctrl + I> to open the IP catalog.

Important Note: Using Windows > |IP Catalog will add the new IP to the top level of the
design's hierarchy—it will NOT add the IP to the diagram! It is, however, possible to float this
window and drag-and-drop IP into the Block Design canvas.
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1-2. Once the IP catalog opens, search for the desired piece of IP and add it to
the canvas.

1-2-1.  Type all or part of the IP name into the Search field.
1-2-2. Locate the desired piece of IP.

Hint: You can scroll with the mouse or use the scroll bar on the right side of the list.
The more of the IP name that you provide, the fewer items that you will need to
manually scroll through.

Search: |
4F 1G/2.5G Ethernet PCSIPMA or SGMII ~ Search by

¥ 2D Graphics Accelerator Bit Block Transfer Text
4F AGPP LTE Channel Estimator Content
AGPP LTE MIMO Decoder

:‘;:

{F 3GPP LTE MIMO Encoder Search

e Manually
by

# AHB-Lite to AXI Bidge Scrolling

¥ Audio 125 Transmitter/Receiver
4F AXl-Stream FIFO

IF AXI 1G/2.5G Ethernet Subsystem
IF AXl4-Stream Accelerator Adapter
4F AXl4-Stream Broadcaster

W

EMTER to select, ESC to cancel, Ctrl+Q for IP details

Figure 83: Two Mechanisms to Search for IP
1-2-3. Double-click the name of the IP to add it to the design (if you use this method, the IP
catalog will close after the IP has been added to the design).
or
Drag-and-drop the IP into the workspace.

The IP catalog remains open once the IP has been added to the design. This is a
convenient way to quickly add multiple pieces of IP. Pressing the <Esc> key or clicking
an open space in the canvas will close the IP catalog.
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Customizing IP

Almost every piece of IP is customizable. This provides a great deal of flexibility
to the designer to create a system that is tailored to specific needs.

1-1. Open the Re-customization Wizard for the desired piece of IP.
1-1-1.  Double-click the IP block.
Alternatively, you can right-click the IP block and select Customize Block from the
context menu.
Block Properties... '
r % Highlight 3 f
Op1[7:0] . -«
Op2[7:0] nght'CIwk p ¥ Delete f
? E copy
L 1
| Q  Search.. {
: W SelectAl
1 4+  AddIP.. -
‘\\ ) Addv‘lodle... '
- {
jentation » f
‘Mw P g SRS
Figure 84: Opening the Recustomization Wizard for a Piece of IP
The Re-customization Wizard for that piece of IP opens.
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Making Manual Connections Between Two Objects in the IP Integrator

Making connections is a simple process in the IP integrator tool. Hover over a
port or interface on a block with your mouse (the cursor changes to a pencil icon
from the arrow icon). You can then click-drag the connection to a legal port or
interface. As the connecting wire is stretched to its destination, an assistant runs
in the background and places a green check mark next to all the ports or
interfaces that can be connected when the cursor approaches a legitimate
connection point.

There are two mechanisms for making these connections: Using the Run
Connection Automation feature, which is available for most IP, and manual
connections. The latter is addressed here.

1-1. Connect two IP blocks using the manual connection technique.

A "net" is another name for the wire, signal, or connection between two or
more pins.

1-1-1.  Click a port or interface to begin the connection process.

Hover Mouse to
Get Pencil Cursor

Figure 85: Hovering the Mouse Over a Port to Get the Pencil Icon

The port or interface is highlighted, showing that it has been selected and the cursor
changes to a pencil, indicating that it is ready to draw/connect a wire.

1-1-2.  Drag the pencil to another port or interface.
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As the cursor approaches a valid port or interface, a green arrow appears next to legal
connections points.

A

)
«

&
Found‘\purt,
|
_ -
<

Figure 86: Finding Legal Connection Points

1-1-3. Release the mouse button to make the connection.

AN

Figure 87: Finishing the Connection

Interfaces are connected in exactly the same way, except that interfaces are comprised
of a bundle of signals rather than a single wire. The tools are designed to automatically
make the proper connections between two compatible interfaces.

Note: If you want to exit this drawing mode, press <Esc>.
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Renaming an IP Block

Renaming an IP block often helps the designer keep track of what that particular
piece of IP does rather than what it is.

1-1.

1-1-1.
dialog box (1).

Rename the IP block with the new name for this piece of IP.

Click the desired IP block in the Block Design window to open its Block Properties

The current name of the selected IP block appears in the Block Properties window
when the General tab (located towards the bottom left of the window) is selected.

1-1-2.

b

Block Properties

4F util_vector_logic_0 @

MName:

Parent name:

General Properies IP

Figure 88: Renaming an IP Block

1-1-3.

Press <Enter> to save the change.

b

Enter the new name (with the new name for this piece of IP) for this specific piece of
IP into the Name field (2).

Name of Specific
Instance of IP M

{1

Name of IP Type
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Adding a Port to an IP Integrator Block Diagram

Ports are constructs that allow signals to pass between hierarchical levels. Ports
can be combined together to form interfaces. Here you will learn how to create a
single port. Ports can take on a variety of special cases, all of which can be
selected through the type parameter.

Port Type Meaning

Clock Clock signals: placed on clock networks; enter the frequency in the
Frequency field

Reset Reset network

Interrupt For embedded systems: ports marked as interrupt are entered into the
interrupt select table for the processor(s)

Data General-purpose data signals

Clock Enable |Clock enable signals: used with clocks

Other Undefined signals: cannot be connected to ports other than those
marked as "other"

1-1. Create a port.
1-1-1.  Right-click an unoccupied section of the Vivado IP integrator canvas (1).
1-1-2.  Select Create Port (2).

Lasdow onaldil ..

ng ht' Create Comment
click CCreate Port... )

L ;‘ Create Interface Port...
.

H "t" Regenerate Layout
. .
*
‘... ,e** | B saeasPDFFie..

Figure 89: Creating a New Port
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1-1-3.
1-1-4.
1-1-5.
1-1-6.

1-1-7.

The Create Port dialog box opens.

Enter the name of the port in the Port name field (1).

Select the port direction as input, output, or inout/bidirectional (2).
Select the type to be according to the table below (3).

Ensure that the Create vector option is selected and if this port is more than one
signal wide, select the Create vector option and indicate the range of the vector (4).

Create Port x

Create port and connect it to selected pins and ports
, Pu |
Port name: [ Name of the port (1)
Direction: (’lml.v

e () T e
| Create Vector:] from
! 7
.............

2 ﬂ‘ cancel

Figure 90: Creating a Port

Click OK (5).

Making a Pin or Interface External

There are several mechanisms for making a pin or interface external. The easiest
way is described here.

1-1. Make your ports and/or interfaces external to the block design.
1-1-1.  Locate the IP block containing the pin or interface you want to make external.
Right-click the pin or interface, making sure that just the pin of interest is highlighted.
1-1-2.  Select Make External.
Right-click @ e
—1 :_' B copy
Figure 91: Making a Port or Interface External
A port is created, and a net is generated to connect it to the pin or interface that you
specified.
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Running Connection Automation

1-1. Use Connection Automation to make connections to the desired piece of
IP.
1-1-1.  Click Run Connection Automation in the Design tab information bar.
Diagram » Address Editor X
@ e X W 9 Q S + & FFE HC g T
/ Designer Assistance available.@un Connection .ﬂ.utomatioD
Figure 92: Running Connection Automation
This opens a Run Connection Automation dialog box listing all the IP blocks currently in
the design that can have Designer Assistance run on it. IPs are listed in a hierarchy on
the left where each child node of an IP node represents an interface that is eligible for
automation. Any options associated with an automation will be shown on the right
whenever an interface node is selected on the left.
1-1-2.  Click the Expand All icon (3) above the list of IPs in the left-hand panel so that you
have a full view of all the IP available for connection automation.
1-1-3.  Check your interface ports, on which Connection Automation will be run.
Notice how options appear on the right after the interface node is selected. In some
cases, you want to leave all automation options at their defaults but, in other cases, it
can be useful to customize the options here. For example, several automations allow
you to select which clock or AXI master will be automatically connected to the IP.
Run Connection Automation x
| fg;?lr;j:‘;lau“'}\ ?Da:gncsosrr‘w;:gtigsh\: your design by checking the boxes of the interfaces to connect. Select an interface on the left to display its ‘
Q = =
o~ }al\ Automation | | out of selected)
7 “ Cancel
Figure 93: Generic Run Connection Automation Wizard
1-1-4.  Click OK to run the selected automation.
Connection Automation is fully capable of performing multiple connections—here a
single connection was illustrated to show the basics of the capability.
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Running Block Automation

1-1. Use Block Automation to automate the configuration of recently
instantiated IP.
1-1-1.  Click Run Block Automation from the Designer Assistance information bar.
Diagram x Address Editor X
@ @ 3 m o Q + % E X C U
7/ Designer Assistance a\failable
Figure 94: Designer Assistance - Block Automation (Run Connection Automation
May be Absent)
This opens a Run Block Automation dialog box listing all the IP currently in the design
eligible for block automation. IPs are listed in a hierarchy on the left and any options
associated with a particular automation will be shown in the right pane whenever an IP
instance is selected in the left pane.
1-1-2.  Click the Expand All icon (¥) to ensure that the list of available automations is fully
visible (1).
1-1-3.  Select either the top-level All Automation check box or individual blocks as listed
below.
Unless otherwise indicated within the block list, maintain default automation options for
all blocks.
o Blocks: the desired piece of IP
1-1-4. Deselect Apply Board Preset when using Zynq devices, as this will undo any work
that you have done in the processor's Re-customization Wizard (2).
Run Block Automation x
?Sﬁi.nq‘jrt;i‘.‘: gﬁ}f.fn(sug:i:.g.m;h? your design by checking the boxes of the blocks to connect. Select a block on the left to display its
a = < Description
| "|“ ‘“l““m:;::;”‘;l z“:t:;:::'m“” This aption sets the board presst an th frocessing System, Allcurrent properties
| — S L
Apply Board Preset: [ [
Cross Trigger In: Disable v
Cross Irigger out: Disable ~
| 0
Figure 95: Run Block Automation Dialog Box
1-1-5.  Click OK to run the selected automation (3).
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Locating Objects in the Board Design

Some designs can become quite large and complex. When "Regenerate Layout"
is run, how can you find various IP blocks, nets, or ports/interfaces? This
instruction reviews the use of the design hierarchy in locating objects.

1-1. Locate the object.
1-1-1.  Locate the Design tab next to the Sources tab.

This is where all the elements in a design are located. Elements are organized into
external interfaces, interface connections, ports, nets, hierarchical blocks, and IP.

BLOCK DESIGH - blkDsgn *

Sources Design % Signals Board ?_008
a = 4 &
#

> Ports
5 Llate

IP Modules

> AF
> AF
s A
> 4
>

Figure 96: Locating the Design Hierarchy View

1-1-2.  Expand the branch corresponding to the type of element you are looking for (hierarchy
block, port, etc.)
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If you are looking for a specific port or interface on an IP block, you can expand that IP
block. Hierarchy blocks contain their own hierarchy of elements.

BLOCK DESIGN -

sources Design X Signals Board ? 00

Q = 4 1

% blkDsgn -

~ External Interfaces

¥ E
> @

« = Interface Connecti Expand fields to access
= specific elements in the IP
= block

> Nets Expand fields to access

> ¥ objects of these types

» ¥

»

»

y

IE| dok v

Figure 97: Expanding Branches in the Design Hierarchy Tree

1-1-3.  Click the specific element or elements that you want to locate.
The Schematic view will highlight (select) that item.
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Mapping Peripheral Addresses

Ensuring that each peripheral has its own memory location is a key aspect of
getting the hardware and software to work together.

1-1.

1-1-1.
1-1-2.
1-1-3.

1-2-1.
1-2-2.

1-2-3.

Ensure that all peripherals have an address assigned to them.
Select the Address Editor tab (1).

Click the Expand icon (5) to expand all the entries in the window (2).

Search for any field containing the text "Unmapped Slaves" (3).

D 2 »(Address Editoryu v
a 3 [4] Assigned (0) ) Unassigned (1) ) Excluded (0)

Name A1 |nterface Slave Segment Master Base Address  Range Master High Address
~ 2 Network 0

Figure 98: Verifying Peripheral Addresses

This field will appear only once for each AXl tree.

If there are unmapped devices, continue with the next instruction; otherwise, skip the
next instruction.

Assign addresses for any peripheral that do not yet have an address
assigned to them.

Expand the tree until you see the unmapped devices (1).

Right-click the peripheral that you want to assign an address to or select Unassigned
to assign addresses to all unassigned elements (2).

Select Assign Address to assign addresses peripheral by peripheral.
—-OR --

Select Assign All to assign addresses to all peripherals that do not have an address
assigned to them (3).

Diagram  x Address Editor
z = v assigned (0) | Unassigned (1)

Name A1 interfac
- = MNetwork 0

1 Assign All o

Expart to file Py

o_mdl

Figure 99: Opening the Dialog Box for Assigning an Address
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Generating Output Products

Once a block design is complete, its output products can be generated. The
synthesis task automatically runs this phase; however, other operations require
the output products, such as exporting a block design.

1-1.

1-1-1.

1-1-2.

1-1-3.

Generate the output products for <list_of output_products>.
Select <list_of_output_products> to generate the output products.

It may be necessary to expand the hierarchy in the Sources window to locate the
object(s) of interest.

Right-click the items and select Generate Output Products from the context menu.

Sources  x Desig Signals | Board ? 00

Q|z|e|+ Right-Click the °

- / Item(s) You

v @ Want to
v &E Generate
v@ Output
1 Products For

Y Canstrainte

Source Node Properties.

@ OpenFile

Create HDL Wrapper... sompile Order

View Instantiation Template

Generate Qutput Products..

Reset Output Products..

Figure 100: Selecting the Items to Generate Output Products For

The Generate Output Products dialog box opens, listing which output products will be
generated.

How the design will be synthesized is up to the user. Global means that all the IP in the
design (along with the user code) is synthesized as a whole. Out of context per IP will
synthesize and generate a netlist for each piece of IP. Out of context per Block Design
will synthesize only the contents of the selected block design.

Select the Global synthesis option so that the complete design—the block design, its
IP, and the user code (including the wrapper)—will be generated as a single module
(1).

If you are changing the settings from out of context to global, click Apply.

Note: Out of context is helpful when developing large designs with many blocks. Since
each block is synthesized independently, if that block is not changed, then it is not
resynthesized, which can offer significant time savings. Contrast this with the Global
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synthesis option in which all aspects of the design will be resynthesized if any changes
are detected.

Generate Output Products x
t  The following output products will be generated. |
P |
Preview
Q = =
blkdsgn.bd iy
Synthesis
Simulation

Implementation
Hw Handnff i

I Synthesis Optiop |
Qut of conte® per [P |
: Out of context per Block Design [

Run Settings
®) On ocal host: Number of jobs: | 8 v
On remote hosts
Launch rung on Cluster

Generate scripts only

Do not launch

=

| Cancel |

Figure 101: Managing the Output Products

The Run Settings specify the number of processors on your development machine that
you would like to run the task on. Generally, this is set to the maximum number of
processors.

1-1-4. Click Generate to start the generation process (2).

When generation completes, a success dialog box opens.

Generate Output Products X

o Generation of output products completed successfully.

Figure 102: Successful Output Products Generation

1-1-5.  Click OK to close the Generate Output Products dialog box.

Note: If the Generate Output Products dialog box does not appear, you can check the
"Ready" status at the top-right of the tool once the process is complete.
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Creating a Hierarchical Block in a Block Design

Hierarchy blocks are useful for grouping similar logic together to simplify cluttered
block designs.

1-1.

1-1-1.
1-1-2.

1-1-3.

1-1-4.

Create and name a hierarchy block.

There are two processes involved in creating a hierarchy block. One is the
creation of a hierarchy block; the other is the addition of IP to the block.

These two tasks can be performed in either order:

o Select the IP to be included in the hierarchy block and create a
hierarchy block around that IP

« Create an empty hierarchy block and add IP to it.

These processes are not mutually exclusive because once a hierarchy
block is created, additional IP can be added to it regardless of how the
hierarchy block was initially created.

The following describes how to create an empty hierarchy block.
Right-click in the block diagram.

Select Create Hierarchy from the context menu.

The Create Hierarchy dialog box allows you to specify the name for the hierarchy.

Enter the name of your hierarchy in the Cell name field.
Create Hierarchy x

Please specify name of hierarchical
cell to create in blkDsgn. You can also l

move selected blocks to new hierarchy.

cell name: | As per instruction |

\? “ Cancel |
Figure 103: Creating a Hierarchy

Click OK to create an empty hierarchy.

Note that if you were to select the IP from the canvas and/or the Design view, then
follow the above tasks—you will create the hierarchy block with the IP already included
in it.
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Adding IP to a Hierarchy Block

IP can be added to a hierarchy block before or after the hierarchy block is
created.

1-1. Add your IP modules IP blocks to the hierarchal block.
1-1-1.  Select your IP modules IP blocks.

This can be done graphically by using <Ctrl + click> to select each piece of IP from
the canvas as well as selecting the IP from the Design tab.

Note that when you select the IP blocks in the block diagram, they will also be
highlighted in the Design window and vice versa.

1-1-2. Drag-and-drop the selected IP into the name of your hierarchy.

This is performed by pressing the <Ctrl> key and clicking (but not releasing) one of the
IP blocks. Drag the selected item into the name of your hierarchy by moving the cursor
of the hierarchy block and then releasing the mouse button.

When moving the IP, you will notice the "plus-sign-in-a-diamond" appear in the IP's
outline. This indicates that it will be added to the hierarchy block that it is being
dragged over.

Hierarchical Block

Figure 104: Example of Dragging IP into a Hierarchical Block

Alternatively, before creating the hierarchical block, you can select the IP from the
canvas or from the Design tab and then right-click the canvas to open the context
menu and select Create Hierarchy. The hierarchical block will be created with the
selected IPs added to it.
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Expanding the Contents of a Hierarchical Block

Sometimes it is easier to understand the diagram when the contents are
displayed in another tab, but sometimes you want to see the context of how the
contents of a hierarchical block interact with the current level of hierarchy.

1-1. Expand the name of your hierarchy.
1-1-1. Locate the name of your hierarchy.

This can be done by visually searching through the canvas, or using the alphabetical
list of items in the Design tab.

1-1-2.  Click the '+' sign in the upper-left corner of the hierarchy block.

Figure 105: Expanding a Hierarchy Block

Note: The hierarchy block can be collapsed by clicking the '-' button in the upper-left
corner.
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Opening a Hierarchical Block in a New Tab

Once a hierarchy exists, there are times when you might want to see what is
happening inside the block. Here's how to access the contents of a hierarchy

block.
1-1. Open the name of your hierarchy in a new tab.
As with many other features of the tool, there are several ways to gain
entry into the hierarchy block. First, you must identify which block you
want to enter.
1-1-1.  ldentify the block that you want to enter.
This can be done in one of two ways:
o Right-click the hierarchy block and select Open in new tab or press <F4>,
4
“r . ¢
Sub-block Properties...
— ¥ Delete
' ... B copy
IS :’
N Q,  Search...
.: Wr  SelectAl
5 +  AddiP.
. Add Module...
hd “‘ Crientation
". IP Settings..
. .‘.‘ [ wvalidate Design
- .."Q.!',—I Open in new tab ?
Figure 106: Opening the Hierarchy Block in a New Tab
o Alternatively, you can use the hierarchy browser, which is part of the Sources tab.
When the block design is expanded, the individual pieces of IP are shown.
Similarly, the Design tab divides the canvas into ports, nets, IP, and hierarchies.
Each hierarchy is further sub-divided into ports, nets, IP, and other hierarchies.
1-1-2.  From the Design tab (next to the Sources tab), double-click the match_antimatch
entry to both expand the ports, nets, and IP within this hierarchy as well as open a new
tab with only the contents of the hierarchy present.
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1-1-3.  Select the name of your hierarchy from the list of hierarchies to open the hierarchy in
a new tab.

Note: If the block design hierarchy list is not as shown in the figure, click the Settings
symbol in the extreme top-right corner. Go to the General section and select the Show
Hierarchy option to enable this capability. The hierarchy can be opened from this
location as well as the Design tab.

Diagram
a = & 9 Q
2, hIszgn.Q

>

113
+

]
*

A S B e it
Figure 107: Accessing the Hierarchical Blocks in a Block Diagram

A new tab with the name Diagram - the name of your hierarchy opens.

Regenerating the Layout

The canvas can be some disorganized after manual edits. The IP integrator tool
can automatically reconfigure the layout to be aesthetically pleasing.

1-1. Regenerate the layout.
1-1-1.  Right-click anywhere on the canvas and select Regenerate Layout.

Alternatively, you can click the Regenerate Layout icon.

Diagram * Address Editor X

@ e X ® o Q T E»‘©g

Figure 108: Regenerating the Layout
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Running a Design Rule Check/Design Validation

Each time an IP is connected, a suite of partial design rule checks automatically
runs. Design validation is a more comprehensive (but not exhaustive) block
design-wide verification and must be run manually.

1-1. Run a manual design validation.

1-1-1.  Select Tools > Validate Design or press <F6>.

& ui-PlanAhead

cdit Flo

Repgrts Window Layout View Help

¥ \validate Design I

Create and Package New IP... b

~lnterface Deff™™en, -

Figure 109: Validating the Design

When design validation is complete, results are reported via the Messages tab at the
bottom of the Vivado IDE.

Because many messages may be displayed, you have the option of filtering what to
view.

If no issues are found, then a dialog box will appear that reports that validation
succeeded.

1-1-2.  Click OK to close the dialog box.
If issues were located:
1-1-3.  Select the Messages tab to view the items discovered by the validation process.

1-1-4.  Filter the results by selecting or deselecting the types of messages you want to see:
Error, Info, or Status messages.

The display is automatically updated.

Hyperlinks are provided to help you quickly locate the issue.

Tcl Console Messages x Log Reports Design Runs

Q = = ¥, B 1@ Y@ Emr@) @ ino G4 [/ @ Status (43)

> Vivado Commands (3 inf
*~ e Block Design (2 errors, 21in

> launch_runs impl_1 -jobs 4 (9 infos, 10 status messages

bd undo (1 info

> create_bd_cell -type ip -vinv xilinx.com:ip:fifo_generator.13.1 fifo_generator_0 (1 info

~ e |Iaunch_runs synth_1 -jobs 4 (3 errors, 10 infos, 10 status messages]{
> (D Wrote : <C:ftraining/IPI_driverlab/PIdriver. sresisources_1/bdiblkDsgn/blkDsgn.bd= (9 more like this
> @ [BD 41-1029] Generation completed for the IP Integrator block pattern (2 more like this

@ [BD 41-758] The following clock pins are not connagtedio ayalid clock source:
fite_3gpp_mimo_decoder_0/aclk

Hyperlink to problem source

l

Figure 110: Viewing the Results of the Design Validation

1-1-5.  Correct any issues and rerun validation until no more issues are found.
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Validating the Block Design

1-1.

1-1-1.

1-1-2.

Validate the design to catch any connection and address map errors.

Select Tools > Validate Design or press <F6>.
Any issues are displayed in the Console window.

Click OK to close the window.

Saving the Block Design

1-1.

1-1-1.

Save the block design.
Select File > Save Block Design to save the block design.
Alternatively, you can press <Ctrl + S>.

File Edit Flow Tools Reports

Project
I Add Sources...

[ Save Block Design l

Save Block Design As...
Close Block Design

Checkpoint

Figure 111: Saving the Block Design
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Generating a Wrapper for a Block Design

While a block design can be directly converted into a structural netlist, block
designs are most frequently used as structural modules within a larger design.

Typically, once the design is complete, an HDL wrapper is created that
instantiates the design and provides a platform for adding other logic. This
wrapper can be automatically generated (and optionally terminated) by the tools,
or it can be added manually by the user.

1-1. Create a wrapper for the block design.

1-1-1.  Ensure that the Sources tab is selected; if it is not, select it to open the Sources view
(1)
While the block diagram can be found under any of the tabs found at the bottom of the

pane (Hierarchy, IP Sources, Libraries, or Compile Order), it is shown here from the
Hierarchy tab as this is a common practice.

1-1-2.  Using the Sources > Hierarchy tab, right-click the block design under the Design
Sources node (2).

Notice the icon (u"h) which indicates that this entry is a block design.
This will open a pop-up window to actions that can be taken for this entry.
1-1-3.  Select Create HDL Wrapper to begin the wrapper creation process (3).
BLOCK DESIGN
sl T £ + £~

~ Design Sources (1

l_’_' Source Mode Properties...
> Constraints

[ OpenFile

-
~ Simulation Sou.rces [ o with
en Wi
> 1 ’n... P 3
> Utilit rces HCreate HDL Wrapper...

- View Instantiation Template

Generate Output Products...
Sources

Figure 112: Creating an HDL Wrapper

Reset Output Products...

The Create HDL Wrapper dialog box opens, showing a list of options relating to how
the wrapper should be handled once generated.

Two choices are presented:

o Generate a wrapper that you can manually edit, which is useful when you have
additional logic to add to the top-level wrapper, or

o Generate a wrapper that is managed by the Vivado Design Suite, which is ideal for
designs that are fully described by one or more block designs.
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1-1-4.  Select the option which best matches your needs (typically this is the default option of
letting the Vivado Design Suite manage the wrapper).

Create HDL Wrapper X
Generate a wrapper around & BD. Select how the wrapper will be managed, if the
wrapper will be the top of the design and optionally choose the desired language. 1

Options

Copy generated wrapper to allow user edits

[ ®) Let Vivado manage wrapper and auto-update ]

) Generated wrapper will be used as Top Module

The wrapper may include global clocking buffers, 10 buffers, and tie offs intended to be
placed at the top of the design hierarchy. Deselect this option if the wrapper is
intended to be placed deeper in the design hierarchy.

@ Mote: For block design wrappers used as top, this will default to language defined in
the project settings

Change target language

P
&) Cancel

Figure 113: Generating the Wrapper and Copying the Generated File into the
Project

This will produce a wrapper file in the target language. You can double-click it to open it

in a new editor window. The project hierarchy will automatically be adjusted to reflect
the addition of this new file.

1-1-5.  Click OK to create the wrapper.

Vivado Elaborated Design Operations

In This Section

Opening the Elaborated DeSIGN ........oooiiiiiiiiiiiie e e e e e eeeaees 82
Creating a Schematic on an Elaborated Design..............uuiiiiiiiiiiiiiiiiii e 83
Running UltraFast DRC Checks on the Elaborated Design .............cccooiiiiiiiiiiiiiiiieee 83
Running DRC Checks on the Elaborated Design ... 83
Closing the Elaborated DESIGN.........cceuuuiiiiiiiie e e e e e et e e e e e e aeees 83

Opening the Elaborated Design

1-1. Open the elaborated design.

1-1-1.  Click Open Elaborated Design under RTL ANALYSIS in the Flow Navigator to
elaborate the design.

The elaborated RTL design enables various analysis views, including RTL Netlist,
Schematic, and Graphical Hierarchy. These views have a cross-selection feature that
allows you to debug and optimize the RTL.

The Elaborate Design dialog box opens.

1-1-2.  Click OK in the dialog box to open the elaborated design.
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Creating a Schematic on an Elaborated Design

1-1.

1-1-1.

Create a Schematic on an Elaborated Design.
In the Flow Navigator, under RTL Analysis > Elaborated Design, click Schematic.

The RTL Schematic opens in the main workspace area.

Running UltraFast DRC Checks on the Elaborated Design

1-1.

1-1-1.

1-1-2.

Run UltraFast™ design methodology DRC checks on the elaborated
design.

Click Report Methodology under RTL ANALYSIS > Open Elaborated Design in the
Flow Navigator.

The Report Methodology dialog box opens.

Click OK to run the design methodology checks and find errors or problems in the
current design.

Running DRC Checks on the Elaborated Design

1-1. Run DRC checks on the elaborated design.

1-1-1.  Click Report DRC under RTL Analysis > Open Elaborated Design in the Flow
Navigator.
The Report DRC dialog box opens.

1-1-2.  Select default in the Vivado Rule Decks section.

1-1-3. Observe the categories in the Rules section.

1-1-4.  Click OK to generate the DRC report.
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Closing the Elaborated Design

1-1. Close the elaborated design.
1-1-1.  Select File > Close Elaborated Design to close the elaborated design.

The Confirm Close dialog box opens.

Confirm Close X

o OK to close 'Elaborated Design'?

[J pon't show this dialog again
[ o

Figure 114: Confirm Close Dialog Box

1-1-2.  Click OK.

Vivado Simulation Operations

In This Section

Running Behavioral Simulation .............ooii e 84
Running Timing SIMUIGtION ..o e e 85
Accessing SIMuUIation SEINGS .....couuuiiiii e 85
Closing Vivado SImMUIGtION ..........uueieie e e e e e et e e e e e eeees 85

Running Behavioral Simulation

1-1. Run behavioral simulation using the Vivado simulator.
1-1-1.  Select Simulation > Run Simulation > Run Behavioral Simulation under Simulation
from the Flow Navigator.

The simulation window opens, and the simulation runs for the length of time specified
in the Simulation Settings (1 us default).

You can alternatively start the Vivado simulator by entering 1aunch_simulationin
the Tcl command line.
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Running Timing Simulation

1-1. Run behavioral simulation using the Vivado simulator.

1-1-1.  Select Run Simulation > Run Post-Implementation Timing Simulation from the
Flow Navigator, under Simulation.

The simulation window opens, and the simulation runs for the length of time specified
in the Simulation Settings (1 us default).

Accessing Simulation Settings

1-1. Open the simulation settings.
1-1-1.  Select Settings in the Flow Navigator, under Project Manager and go to Simulation.

The simulation settings open. There are five sub-tabs: Compilation, Elaboration,
Simulation, Netlist, and Advanced.

¢ Settings {&J
Simulation
Project Settings Specify various setiings associated to Simulation 4
General
Simulation Target simulator: Vivado S8imulator A4
Elaboration
Synihesi Simulator language Verilog 4
ynthesis
Implementation Simulation set: i sim_1 v
Bitstream
s Simulation top module name: EI
Tool Setti ¥ Clean up simulation files
ool Settings
Project
IP Defaults ' Compilati Elaborati Simulation i Advance: ’
Source File
Disp! xsim.simulate.tcl.post
isplay
WebTalk xsim.simulate runtime [ 50us
Help xsim.simulate.log_all_signals
> Text Editor xsim.simulate custom_tel
30 Party Simulators xsim.simulate wdb
> Colors xsim.simulate saif_scope
Selection Rules xsim.simulate saif
Shorteuts xsim simulate saif_all_signals
Strategies xsim.simulate xsim.more_options
> Window Behavior
xsim.simulate.runtime
Specify simulation run time
(2 | oK | ‘ Cancel ‘ | Apply | ‘ Restore

Figure 115: Vivado Simulator Settings

Closing Vivado Simulation

1-1. Close the simulation.
1-1-1.  Select Simulation in the Flow Navigator, then right-click and select Close Simulation.

1-1-2.  Click OK to close the simulation.
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Vivado Synthesis Operations

In This Section

RUNNING SYNNESIS ... e e e e e e e e ean s 86
Opening the Synthesized DeSIGN ........cooiiiiiiiii et eeeeeeeees 88
Generating a Utilization RePOIt........coooiiii e 88
Generating a Clocks Networks RepOrt .........oouuiiiiiii e 88
Running a DRC Report on the Synthesized Design ..............uuiiiiiiiiiiiiiii 88
Opening the Timing Constraints Window after Synthesis ..............cccccoiiiiiiiiiiiiii e, 89
Generating a Timing Summary Report on the Synthesized Design..............cccovvviiiiiiiiineeeee. 89
Running Simultaneous Switching Noise (SSN) ANalySis ..........cc.oiviiiiiiiiiiiiii e, 90
Generating a Clock Interaction Report on the Synthesized Design ..........ccccoeeviiiiiiiiincn. 90
Closing the Synthesized DeSIgN..........cuuii i e e eees 90
Running Synthesis
1-1. Run synthesis.
1-1-1.  Expand Synthesis in the Flow Navigator (1).
1-1-2.  Click Run Synthesis (2).
¥ Settings

() SYNTHESIS

Figure 116: Running Synthesis

Alternatively, you can also press <F11>.

The Launch Runs dialog box opens.
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1-1-3.  Ensure that the Launch runs on local host option is selected (1).
1-1-4.  Select the largest values from the Number of jobs drop-down list (2).

This allocates the number of processor cores recruited to run synthesis. Generally, the
more cores, the faster synthesis completes.

Launch Runs X

Launch the selected synthesis or implementation runs.
[

Launch directory: |« <Default Launch Directory=

(1 )ers e
Tl Launch runs on local host: I Number of jobs:| Par Instruction

()} Launch runs on remote hosts

() Launch runs on Cluster

Generate scripts only

|_) Don't show this dialog again
"’/' cancel

Figure 117: Setting the Launch Run Configuration

1-1-5.  Click OK to launch the runs (3).
1-1-6. Click Save if you are asked to save your files.

Once synthesis completes, you are asked what task you want to perform next: run
implementation, open the synthesized design, view reports, or none of the above.

1-1-7. Select whatever process you want to perform next or Cancel to exit the dialog
box (1).

1-1-8.  [Optional] If you are familiar with accessing these various capabilities, you can disable
this dialog box from appearing again by selecting Don't show this dialog again (2).

Synthesis Completed X

o Synthesis successfully completed.

Next

(®) Run Implementation

() open Synthesized Design

() View Reports

[_) Don't show this dialog again

Cancel

Figure 118: Selecting Post-Synthesis Options

1-1-9.  Click OK to take the action you just selected (3) or click Cancel to simply close the
dialog box.
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Opening the Synthesized Design

1-1. Open the synthesized design.
1-1-1.  Click Open Synthesized Design under Synthesis in the Flow Navigator.

Alternatively, you can select Flow > Open Synthesized Design.

v  SYNTHESIS
P Run Synthesis

( > Open Synthesized Design j

Figure 119: Opening the Synthesized Design

Generating a Utilization Report

1-1. Generate a Utilization report.
1-1-1.  Click Report Utilization under Synthesized Design in the Flow Navigator.

Alternatively, you can select Reports > Report Utilization.

Generating a Clocks Networks Report

1-1. Generate a Clocks Networks report.

1-1-1.  Click Report Clock Networks in the Flow Navigator under Synthesized Design.
Alternatively, you can select Reports > Timing > Report Clock Networks.
The Report Clock Networks dialog box opens.

1-1-2.  Click OK.

Running a DRC Report on the Synthesized Design

1-1. Run a DRC report on the synthesized design to check for any violations.

1-1-1.  Click Report DRC under Synthesis > Synthesized Design in the Flow Navigator.
The Report DRC dialog box opens.

1-1-2.  Select default in the Rule Decks section of the Report DRC dialog box.

1-1-3.  Click OK to start the default DRC checks on the synthesized design.
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Opening the Timing Constraints Window after Synthesis

1-1. Open the Timing Constraints window.
1-1-1.  Select Window > Timing Constraints.

This window can also be opened by clicking Edit Timing Constraints under
Synthesized Design in the Flow Navigator.

The Timing Constraints window opens in the main workspace area.

Generating a Timing Summary Report on the Synthesized Design

The timing summary command is accessible in the Vivado Design Suite GUI
once the synthesized design is opened in the Vivado IDE. If the synthesized
design is not opened in the GUI and you do not remember how to open the
design, refer to the "Opening the Synthesized Design" section in the Lab
Reference Guide.

1-1. Generate a Timing Summary report.

1-1-1.  Click Report Timing Summary under Synthesis > Open Synthesized Design in the
Flow Navigator.

The Report Timing Summary dialog box opens.

Report Timing Summary ES

Generate a timing summary to understand if the design met timing.
Pa
Results name: |timmg_1\ I
Options
Report
Path delay type: | min_max
¥l Report unconstrained paths
Report datasheet
Path Limits
Maximum number of paths per clock or path group: 10 2
Maximum number of worst paths per endpoint: 13
Path Display
Display paths with slack less than: ] Use default (1e+30)
Significant digits: 33
Command: report_timing_summary -delay type min_max -report_unconstrained -check_timing_verbose -max_paths 10 -nput_pins -routable_nets -name timing_1
&) Open in a new tab
Open in Timing Analysis layout
® o |

Figure 120: Report Timing Summary Dialog Box

1-1-2.  Click OK to generate the Timing Summary report using the default settings.

The Design Timing Summary window opens at the bottom in the Timing tab.
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Running Simultaneous Switching Noise (SSN) Analysis

Simultaneous switching noise (SSN) analysis can be performed to help identify
potential signal integrity issues.

1-1. Run SSN on the design.
1-1-1.  From the Flow Navigator, click Report Noise under Synthesis > Synthesized Design.
1-1-2.  Click OK in the Report Noise dialog box.

The Noise Report window opens at the bottom in the Noise tab.

Generating a Clock Interaction Report on the Synthesized Design

The clock interaction command is accessible in the Vivado Design Suite GUI
once the synthesized design is opened in the Vivado IDE. If the synthesized
design is not opened in the GUI and you do not remember how to open the
synthesized design, refer to the "Opening the Synthesized Design" section in the
Lab Reference Guide.

1-1. Generate a Clock Interaction Report.

1-1-1.  In the Flow Navigator, under Synthesis > Synthesized Design, select Report Clock
Interaction.

Alternatively, you can select Tools > Timing > Report Clock Interaction.
The Report Clock Interaction dialog box opens.

1-1-2.  Click OK with the default settings.
The Clock Interaction Report opens in GUI mode.
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Closing the Synthesized Design

1-1. Close the synthesized design.
1-1-1.  Select File > Close Synthesized Design.

The Confirm Close dialog box may open.

Confirm Close x

o OK to close 'Synthesized Design'?

[] boen't show this dialog again

B

Figure 121: Confirm Close Dialog Box

1-1-2.  Click OK to close the synthesized design if the Confirm Close dialog box opens.

Alternatively, you can also close the synthesized design by clicking the X in the
Synthesized Design status bar at the top or entering the Tcl command close design
in the Tcl Console.

Vivado Implementation Operations

In This Section

IMPIEMENtING @ DESIGN ... .t 9
Generating a Utilization Report on the Implemented Design............ccoouuiiiiiiiiiiiiiiiiiiie 93
Opening the Implemented DESIgN.........cooeiiiiiiiiii e e e e e eeeeees 94
Generating a Clock Interaction Report on the Implemented Design ..., 94
Closing the Implemented DESIQN .......coiiniiii e 94
Generating CloCK NEtWOIKS ........oooiiii e 95
Generating the BItStream . ... ..o 95
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Implementing a Design

1-1.
1-1-1.

1-1-2.

1-1-3.
1-1-4.

Implement the design.

From the Flow Navigator, under Implementation, click Run Implementation to run all
operations necessary to generate the bitstream.

This includes synthesis if the netlist has not already been generated and the
implementation processes if not already performed.

Tl FEIEEOLFETL LA Flow Navigator &7

PROJECT MANAGER

Project Manager

~

Settings PoB

v

IP Integrator IP INTEGRATOR

Create Block Design

v

Open Block Design » SIMULATION

Run Simulation ¥

~

RTL AMALYSIS
Open Static Simulation...

Open Elaborated Design

~

SYNTHESIS
Mew Elaborated Design... C

<

P Run Synthesis IMPLEMENTATION

Open Synthesized Design P Run Implementation

Mew Synthesized Design... > Open Implemented Design

»  Run|mplementation ]

v PROGRAM AND DEBUG

Open Hardware Magager Mecenerate Bitstream

-

Figure 122: Two Ways to Run Implementation

The Launch Runs dialog box opens. Here is where you can specify where the
synthesis or implementation activity will occur and how many resources are assigned
to the task.

Select whatever process you wish to perform next or cancel to exit the dialog (1).

For the Launch runs on local host option, the number of jobs represents the number of
processing cores that can be assigned to this task, which is platform specific.

Launch Runs X

Launch the selected synthesis or implementation runs.
il

Launch directory: | a <Default Launch Directory= ~

Options

[ ® Launch runs on local host: umber of jobs: v
| Lsunch runs on remote ho!

Launch runs on Cluster ]

Generate scripts only

Don't show this dialog again e

Figure 123: Selecting Run Options and Launching the Task

Click OK to begin the implementation process (2).
Click OK if any critical warning messages dialog boxes appear.

You will need to determine if the critical warnings need to be addressed immediately or
if they can be ignored.
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When implementation is complete, the Implementation Complete dialog box opens.

When the design finishes the implementation, the Implementation Completed dialog
box opens. You can view reports to review what was created or open the hardware
manager to program the device or view the information from the Vivado analyzer tool.
You can also simply cancel to perform neither of these tasks. These tasks, and others,
are still available through the Flow Navigator.

1-1-5.  From the dialog box, select to your desired settings (1).

Implementation Completed (=]

o Implementation successfully completed.

Next

Open Implemented Design
Generate Bitstream
View Reports

Don't show this dialog again

O

Figure 124: Selecting which Activity to Perform after Implementation

1-1-6.  Click OK to open the selected item or Cancel to perform none of the listed tasks (2, 3).

Generating a Utilization Report on the Implemented Design

1-1. Generate a Utilization report on the implemented design.
1-1-1.  Click Report Utilization under Open Implemented Design in the Flow Navigator.
Alternatively, you can select Reports > Report Utilization.

The Report Utilization dialog box opens.
Report Utilization *

Report resource utilization.

Results name: utilization_1

Export to file:

| Open in a new tab

® EEE (e

Figure 125: Report Utilization Dialog Box

1-1-2.  Click OK using the default settings.
The Design Utilization Summary window opens at the bottom in the Utilization tab.

Note that the device resources are listed in a hierarchical format for each RTL design
module.
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Opening the Implemented Design

1-1. Open the implemented design.
1-1-1.  Click Open Implemented Design under Implementation in the Flow Navigator.

Alternatively, you can select Flow > Open Implemented Design.

~ IMPLEMENTATION
P Run Implementation

> Open Implemented Design

Figure 126: Opening the Implemented Design

Note that the Timing Summary report is automatically generated in read only mode
when the implemented design is opened.

Generating a Clock Interaction Report on the Implemented Design

The clock interaction command is accessible in the Vivado Design Suite GUI
once the implemented design is opened in the Vivado IDE. If the implemented
design is not opened in the GUI and you do not remember how to open the
implemented design, refer to "Opening the Implemented Design" section in the
Lab Reference Guide.

1-1. Generate a Clock Interaction Report.

1-1-1.  In the Flow Navigator, under Implementation > Implemented Design, select Report
Clock Interaction.

Alternatively, you select Tools > Timing > Report Clock Interaction.
The Report Clock Interaction dialog box opens

1-1-2.  Click OK with the default settings.
The Clock Interaction Report opens in GUI mode.
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Closing the Implemented Design

1-1. Close the implemented design.
1-1-1.  Select File > Close Implemented Design to close the implemented design.

The Confirm Close dialog box opens.

Confirm Close x

o OK to close Implemented Design'?

D Dont show this dialog again

Figure 127: Confirm Close Dialog Box

1-1-2.  Click OK to close the implemented design.

Alternatively, you can also close the implemented design by selecting Flow > Close
Implemented Design or clicking the X in the Implemented Design status bar at the
top.

Generating Clock Networks

1-1. Generate a Clocks Networks report.
1-1-1.  In the Flow Navigator, under Implemented Design, click Report Clock Networks.

Alternatively, you can select Tools > Report > Report Clock Networks.

Generating the Bitstream

For users that have a few hours, it is time to generate the bitstream. If you are
running in class or on CloudShare, only review this and the next step.

Note: Do not perform this step as generating the bitstream will take approximately 3-4 hours
depending on your system configuration. The instructions below are provided for review on
what the necessary actions are.

For CloudShare users, if you are going to perform this step, you should do so in your local
environment, not in CloudShare. This is because the memory available in CloudShare is 12
GB, and 16 GB is the minimum requirement. Generating the bitstream will still take
approximately 3-4 hours.

AMDZD1 www.amd.com
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1-1.

1-1-1.

1-1-2.

1-1-3.

1-1-4.

1-1-6.

Generate the bitstream.

Locate the Generate Bitstream entry under Program and Debug in the Flow
Navigator.

~ PROGRAM AND DEBUG

( ¥ Generate Bitstream )

» OpenHardware Manager

Figure 128: Generate Bitstream in the Flow Navigator

Click Generate Bitstream to start the bitstream generation.

If neither synthesis nor implementation has been run, you will see a "No
Implementation Results available" message.

Click Yes to continue the process as both synthesis and implementation will be run
during the generation of the bitstream.

When the Launch Runs window opens, ensure that the Launch runs on local host
option is selected.

Set the number of jobs to the highest number available.
This specifies how many CPU cores are allocated to this task.
Click OK to begin the bitstream generation process.

Track the progress using the status indicator in the upper-right corner of the workspace
as well as in the design runs console. Successful completion of the bitstream is
indicated with a message in the Console tab.

Errors are reported through pop-up messages.
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Vivado Tcl Operations

In This Section

Running a Tcl Script from within the Vivado Design Suite ... 97
Clearing the TCl CONSOIE .........oouiiiiiie e et e e e e e eeeaens 98
Generating a Timing Summary Report with the Tcl Interface............cccoooviiiiiii s 99
Using the llength Command to Obtain the Number of Paths Between Two Domains............ 100
Using the join Command to Join All Timing Paths Between Two Domains..................cc....... 101
Building a Custom Timing Report with the Tcl Interface .............ccooiiiiiiiiii . 101

Running a Tcl Script from within the Vivado Design Suite

The Vivado Design Suite offers both GUI and scripted control. Tcl provides
scripted control. These Tcl commands can be entered directly into the tool one at
a time (or block copied), or an entire Tcl script can be loaded and executed
(sourced).

1-1. Run a Tcl script.
1-1-1.  Select the Tcl Console tab to view the console.

Hint: If the Tcl Console is minimized, clicking the tab will partially expand the view.
1-1-2. Locate the Tcl command line entry.

The command line entry can be found either on the Welcome page before a project is
opened, or once a project has been opened.

From the Welcome screen:

Figure 129: Accessing the Tcl Console from the Getting Started Page

You can always click the Tcl tab to maximize/restore it.
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1-1-3.

1-1-4.

1-1-5.

From the Tcl Console tab in an open project:

er
aborated Design
v SYNTHESIS
P Run Synthesis
> Enter the Tcl Commands here ]
~ IMPLEMENTATION
P Run Imy plementation
. . = :

Figure 130: Entering Commands into the Tcl Console from an Open Project

Initially, the directory location begins within the tool installation directory.

Enter the following command to change the current working directory to where the Tcl
script is located:

cd $::env(TRAINING PATH) /<the topic cluster name>/support

Note: The Tcl proc env reaches out to the operating system and returns the value of
the environment variable given by TRAINING PATH. The $ indicates that the value of
that variable should be returned and the two colons (::) indicate from which namespace
the information should be pulled. Because there is nothing in front of the ::, the global
or base layer of the namespace is to be used.

Verify that you are now where you want to be by entering the following into the Tcl
command line:

pwd

This should show that you are in the support directory under the <the topic
cluster name> directory in the training directory.

Note that the training directory can be anywhere in the system. What is essential is
that you are currently working from the support directory under <the topic
cluster name>.

Run the following Tcl command to run the helper Tcl script for this lab:
source your Tcl script.tecl

The Tcl script is run as though you typed each command included in the Tcl script into
the Tcl command line. You can follow the execution of the script and monitor for any
errors or warnings in the Tcl Console.
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Clearing the Tcl Console

1-1. Clear the Tcl Console window.
This helps to make it clear how each command behaves.

1-1-1.  From the Tcl Console, click the Trash Can icon in the Tcl Console toolbar.

Tel Console 1
Qa = 2 I B T 4

Figure 131: Clearing the Tcl Console

A dialog box opens, asking you to confirm the clearing of the Tcl console.
1-1-2.  Click Yes to clear the Tcl Console.

Generating a Timing Summary Report with the Tcl Interface

The timing summary command is accessible in the Vivado Design Suite GUI
once the synthesized design or implemented design is opened in the Vivado IDE.
If the synthesized/implemented design is not opened in the GUI and you do not
remember how to open the design, refer to the "Opening the Synthesized
Design" or "Opening the Implemented Design" section in the Lab Reference
Guide.

1-1.  Generate a timing report with the Tcl interface.

1-1-1.  In the Tcl Console at the bottom of the GUI, enter the following command:

report timing summary -delay type max -report unconstrained -
check timing verbose -max paths 10 -input pins

This displays the 10 worst paths per clock or per group and reports the unconstrained
paths as well.

1-1-2.  If you want to save the timing results to a text file, enter the following command:

report timing summary -delay type max -report unconstrained -
check timing verbose -max paths 10 -input pins -file
C:/<file location>/<file name>.txt

AMDZ www.amd.com 99
together we advance_ © Copyright 2026 Advanced Micro Devices, Inc.



Lab Reference Guide

1-1-3.  If you want to see the timing results in the GUI use the —name option:

report timing summary -delay type max -report unconstrained -
check timing verbose -max paths 10 -input pins -name timing 1 -
file C:/<file location>/<file name>.txt -name timing 1

O

-delay type - Values are min, max and min_max (sets the type of analysis to
be run. For synthesized designs, only max delay analysis).

-report unconstrained — Reports the unconstrained paths in the report.
-check timing verbose - Reports the missing timing constraints in the report.
-max_paths — Number of worst paths to be displayed in the timing report.
-input_ pins — Shows the inputs pins the timing report.

-file — Writes the output timing results to a file to the specified location.

-name — 10 see the results in GUI mode.

Using the llength Command to Obtain the Number of Paths Between
Two Domains

The 11ength Tcl command can be used to return the length of the list
(elements).

For example:
set Vivado [list 1 2 3] -->returnsthe 123

length $Vivado -->returns 3

1-1. Use the 11ength command to obtain the number of paths that exists
between two domains.

1-1-1.  In the Tcl Console, generate the list of timing paths that exist between two domains
with get timing paths:

get timing paths -from [get clocks <clock name>] -to [get clocks
<clock name>] -max paths 100

This command will display the timing paths that exist between the two clock domains.

1-1-2. Usethe 11ength command to return the number of paths that exist between the two
clock domains:

llength [get timing paths -from [get clocks <clock name>] -to
[get clocks <clock name>] -max paths 100]

100
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Using the join Command to Join All Timing Paths Between Two
Domains

The join Tcl command can be used to join two strings or characters with a new
line or another character.

For example:
set Vivado [1 2 3]
returns --=>12 3

join $Vivado \n

returns -> 1
2
3
1-1. Use the join command to join the timing paths between two domains

with a new line.

1-1-1.  In the Tcl Console, generate the list of timing paths that exist between two domains
with get timing paths:

get timing paths -from [get clocks <clock name>] -to [get clocks
<clock name>] -max paths 100

This command will display the timing paths that exist between the two clock domains.

1-1-2.  Join the timing paths with a new line.

join [get timing paths -from [get clocks <clock name>] -to
[get clocks <clock name>] -max paths 100] \n

Note that \n adds a new line for each timing path.
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Building a Custom Timing Report with the Tcl Interface

The report timing command is accessible in the Vivado Design Suite GUI
once the synthesized design or implemented design is opened in the Vivado IDE.
If the synthesized/implemented design is not opened in the GUI and you do not
remember how to open the design, refer to the "Opening the Synthesized
Design" or "Opening the Implemented Design" section in the Lab Reference

Guide.

The report timing command displays specific timing paths only.

1-1. Generate a custom timing report with Tcl interface.

1-1-1.  In the Tcl Console at the bottom of the GUI, enter the following command:

report timing -from [startup points] -to [end points] -
delay type min max -max paths 10 -sort by group -input pins -
name timing 1

O

O

O

O

O

- from — Startup points such as sequential components, F/F pins, etc.
-to — End points such as data inputs of sequential components, etc.

-delay type - Values are min, max and min_max (sets the type of analysis to
be run. For synthesized designs, only max delay analysis).

-report unconstrained — Reports the unconstrained paths in the report.
-check timing verbose - Reports the missing timing constraints in the report.
-max_paths — Number of worst paths to be displayed in the timing report.

-input pins — Shows the inputs pins the timing report.

-file — Writes the output timing results to a file to the specified location.

-name — To see the results in GUI mode.

For more information about the options that can be used with report timing, type
report timing -help inthe Tcl Console.
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Vivado Hardware Session Operations

In This Section

Implementing a Design and Generating a Bitstream ... 103
Opening the Hardware Manager...........ooueeiiuiiiiiie et eeeeeeees 105
Launching and Configuring the Terminal Emulator................cccoooiiiiiiiiii e, 108

Implementing a Design and Generating a Bitstream

1-1. Generate the implemented design and bitstream.

The Vivado Design Suite runs the equivalent of a "make" file that
understands dependencies. If synthesis or implementation has not been
run, and bitstream generation is requested, then the tools are smart
enough to synthesize whatever modules need to be synthesized and
implement the design before generating the bitstream.

1-1-1.  Click Generate Bitstream from the Flow Navigator under Program and Debug to run
all operations necessary to generate the bitstream.

Flow Navigator = 8 2 _
> PROJECT MANAGER
’
> IPINTEGRATOR
FEile Edit( Flow ,Iools Window Layoi

> SIMULATION " % ProjectManager

-

: Settings
> RTLAMNALYSIS * PROJE =

- IP lgte: r
> SYNTHESIS

OR N
- uene:at \
-
* IMPLEMENTATION > Open P Open Hardware Manager
TCTF Generate Bitstream )
~ PROGRAM AND DEBUG
ii Generate Bitstream
» OQpen Hardware Manager 1
Figure 132: Launching the Generate Bitstream Process
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1-1-2.  If you are presented with a warning that there aren't any implementation results
available, click Yes.
Launch the selected synthesis or implementation runs. '
Launch directory: | » =Default Launch Directory= ~
Options
®) Launch runs on local host: Number of jobs: ~
Launch runs on remote hosts
Launch runs on Cluster
Generate scripts only
Don't show this dialog again
Figure 133: Launch Runs Dialog Box
The default settings are sufficient for this run.
1-1-3.  Click OK to proceed with synthesis, implementation, and bitstream generation.
1-1-4. Address any critical warning messages dialog boxes that appear and continue the
bitstream generation operation.
You will need to determine if the critical warnings need to be addressed immediately or
if they can be ignored.
When implementation is complete, the Implementation Complete dialog box opens.
The status indicator in the upper-right corner of the workspace will indicate when
bitstream generation is complete as well as in the Design Runs tab in the bottom panel.
When generation is complete, the Bitstream Generation Completed dialog box opens.
( Bitstream Generation Completed &J‘
o Bitstream Generation successfully completed.
Next
@ Open Implemented Design
View Reports
Open Hardware Manager
Generate Memory Configuration File
Don't show this dialog again
Figure 134: Bitstream Generation Completed Dialog Box
You can view reports to review what was created or open the hardware manager to
program the device or view the information from the Vivado analyzer tool.
You can also simply cancel to perform neither of these tasks. These tasks, and others,
are still available through the Flow Navigator.
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1-1-5.

Click Cancel to perform none of these tasks and end the bitstream generation process.
OR

If you would like to quickly jump to one of these frequently used next steps, select the
option of your choice and click OK.

Opening the Hardware Manager

The hardware manager is the portion of the Vivado Design Suite that enables the
monitoring of cores that were added to a design.

1-1.

1-1-1.

1-2.

1-2-1.

1-2-2.

Open the hardware manager.

Click Open Hardware Manager in the Bitstream Generation Completed dialog box and
click OK.

The Hardware Manager window opens.

The hardware needs to be connected and the information bar invites you to open an
existing or a new target.

HARDVWARE MANAGER - unconnected

0 o hardware target is npe

Figure 135: Opening a Hardware Target

Connect the target through the New Target Wizard to guide you through
the process.

Click Open target > Open New Target.

Open Hardware Target
AMDA

. This wizare will guide you through coni

Vivado

ML Edition To connect t mote hardware target, provide the host name and IP port of the remote
f a Vivado Hardware Server is running.

necting to a hardware target

oare
machine on which the instance o

®

Figure 136: Open Hardware Target Dialog Box

Click Next to set the hardware server settings.
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1-2-3.

1-2-4.
1-2-5.

Enter a name for the server.

Typically, this is left at its default value.

Open New Hardware Target x |

Hardware Server Settings
Select local or remote hardware server, then configure the host name and port
settings. Use Local server if the target is attached to the local machine; otherwise,

Connect to: | Local server (target is on local machine “

Click Next to launch andfor connect to the hw_server (port 3121) application on the local
machine.

=

Figure 137: Setting the Server Name for the New Hardware Target

Click Next to select the hardware target.
Verify the hardware target.
This becomes important when there are multiple targets connected to the PC.

You can change the frequency of the JTAG cable if you are experiencing
communications problems.

[Linux users]: If you receive an error saying that no active target is found, check the
USB connections by selecting Devices > USB in the VirtualBox toolbar at the top.

Virtual Machine Container

o

. - Virtual
= ) e Machine

> Contents

" Pwred Dgboard 3

% Oragand Drop »

Insent Guest Adations CD image

Figure 138: Selecting the Hardware Target
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1-2-6.

1-2-7.

1-2-8.

Leave the frequency at its default value.

Open New Hardware Target X

Select Hardware Target
Select & hardware target from the list of available targets, then set the appropriate
JTAG clock (TCK) frequency. If you do not see the expected devices, decrease the

Hardware Targets

Type Name |TAG Clock Frequency
=2 -

Add Xilink Virtual Cable (XvC)

Hardware Devices (for unknown devices, specify the Instruction Register (IR)
length)

Hardware server: localhost:3121

=

Figure 139: Selecting the Hardware Target

Click Next to view the hardware target summary.

A summary of the connection is displayed.

Open New Hardware Target x

AM Da Open Hardware Target Summary
VivadD @ Hardware Server Settings:
ML Edition o Server: localhost:3121
@ Target Settings:
o Target:
o Frequency:
To connect to the hardware described above, click Finish
®

Figure 140: Summary of the Open Hardware Target Settings

Click Finish to connect to the new hardware target.
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Launching and Configuring the Terminal Emulator

Maintaining consistency in the instructions is an important aspect of the lab experience. The
labs will use general and vague commands such as "Open the terminal emulator". Depending
on the system that you are using, you must know which terminal emulator to configure and
launch. Here are the instructions for opening a terminal emulator for both the Linux and
Windows environments.

Generally, the software labs will use the serial terminal built into the Vitis platform; however,
there are some labs that will require you to communicate with the board without using the Vitis
environment. These situations require the use of a third-party serial port emulator.

We have tested Tera Term for the Windows environment and GTKTerm for Linux. The
GTKTerm tool is pre-installed with the Customer Training VM. Both terminal emulators listed
here run independently of the tools. If you have another terminal emulator that you prefer, you
can certainly use it; however, you are responsible for figuring out how to configure it.

Linux

GTKTerm is a simple GTK+ terminal used to communicate with the serial port. Other terminal
emulators may be used; however, the installation and configuration instruction provided here
are for GTKTerm.

GTKTerm is already installed in the VM provided by the Customer Training team; however
native Linux users may need to install GTKTerm.

[Native Linux users] Acquire and install the GTKTerm software from the command line.

I. Press <Ctrl + Alt + T> to open a new terminal.
2. Download and install GTKTerm:
[host] $ sudo apt install gtkterm

3. When prompted for the password, enter the super user password.
The tools will install in about a minute or less.
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GTK Term is an interface that only supports serial port/UART communications.
The more general Terminal tab supports other formats, such as SSH and Telnet.

Since serial port communications occur over the USB, which is an enumerated
interface, the board must be powered on with the cable connected for the port to
be recognized.

If you are using the VM, ensure that the proper USB port is allowed to cross the
host/VM threshold by selecting Devices > USB > Xilinx <board selection>

[0800] in the VirtualBox Manager for Zynq UltraScale+ MPSoC/Versal adaptive
SoC boards or selecting Devices > USB > Digilent Adept USB Device [0700].

1-1. Launch GTKTerm and set the port configuration.

1-1-1.  Click the GTKTerm icon (@) from the quick launch toolbar.

Alternatively, GTKTerm can be launched from a Linux terminal window (<Ctrl + Alt +
T>) and entering:

[host] $ sudo gtkterm

Note: While the application will run as a regular user, you must be a super user to
access the ports.

When the GTKTerm window opens, perform the following.
1-1-2.  Select Configuration > Port to open the Configuration dialog box.

1-1-3.  Identify the port associated with your board and set the port as /dev/ttyUSBx (where x
could be 0, 1, 2, 3, etc.)

1-1-4.  Set the baud rate to 115200.
1-1-5. Leave the rest of the settings at their default.

Note: You can open multiple instances of /dev/USBx if you are unable to determine
which port your UART is connected to.

DS E GtkTerm - /dev/|
training@xilinxs$ sud | File Edit Log Configuration Controlsign:

[sudo] password for
Control signals read output error Port
Main window

Local echo
CRLF auto

Baud Rate: Parity: Macros

Load configuration
Save configuration
Bits: Stopbits: Flow control: Delete configuration

I Per instructions I v I Per instructions Iv none

8 = K > | | none

P Advanced Configuration Options

Jdev/ DTR RTS CTS CD DSR

Figure 141: Opening GtkTerm and Selecting the Port Configuration

[Optional]: You can save these settings so that you do not have to reconfigure
GKTTerm each time you open it by selecting Configuration > Save configuration.
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If you save the configuration as "default", this configuration will open when GTKTerm
starts. Otherwise, you can save the configuration with another name; however, you will
then need to load the configuration each time you start GTKTerm.

1-1-6.  Click OK to save the settings and leave the terminal open.

1-2. Enable auto CR/LF mode.

GTKTerm is a terminal emulator that supports automatic translation of CR
(carriage return) characters to LF (line feed) characters and vice versa.

1-2-1.  Select Configuration > CR LF auto to enable auto CR/LF mode.

GTKTerm - /dev/ttyUSB1 115200-8-N-1

File Edit 2 Configuration Controlsignals View Help
Port
Main window
Local echo
Timestamp
Macros

Load configuration

Save configuration

Delete configuration

Figure 142: Enabling CR/LF Auto in GTKTerm

Note: This step is optional, but it will ensure that the serial messages appear aligned
on the terminal.

Windows

Tera Term is a popular public domain terminal emulation program. It is capable of operating as
a serial port terminal or as a telnet client.

Download and install Tera Term.

I. Acquire and install the Tera Term software from any legitimate site. Recommended sites:
e ttssh2.0sdn.jp/index.html.en (Tera Term home page with documentation)
e osdn.net/projects/ttssh2
e en.sourceforge.jp/projects/ttssh2
e logmett.com
2. Install per instructions.

There are two types of downloads: a traditional zip install, and a self-installing version, which
is recommended.

[Optional] Certain drivers like installing their com port numbers using high numbered serial
ports. Tera Term does not accept these port numbers by default, so you will need to override
the Tera Term settings:

I. Open TERATERM.INI (found in the install path for Tera Term) with an ASCII text editor.

110 www.amd.com AMDZU
© Copyright 2026 Advanced Micro Devices, Inc. together we advance_



Lab Reference Guide

2. Setto MaxComPort=256.
3. Save and close the INI file.
4. Use the Setup > Save Setup option to save the setup.

Launch the Tera Term terminal program.

Double-click the Tera Term icon on the Windows desktop to launch Tera Term.
Alternatively, you can select Start > All Programs > Tera Term > Tera Term.

Select Serial as the connection (1).

Click the Port drop-down list to view the available COM ports (2).

Note: If your port is not listed, exit Tera Term, power cycle your board and restart this step.

Select the COM # (3).

Hint: MPSoC and RFSoC devices display three COM ports. Their specific numbers may
vary based on the USB enumeration process; however, the first two COM ports connect to

the UARTS in the PS and the third connects to PL pins.

] I]I_
| File Action View Help 3
e | T HE =

Ll Jamenn e .’-"‘-kj

[ Network adapters
E Portable Devices

v i Ports (COM &LLPT

ﬁ Standard Serial over Bluetooth link (COME)

ﬁ Standard Serial over Bluetooth |j

) USB Serial Port (COM |

f USE Serial Port (COM | =" }
9 USB Serial Port (COM |
= Print queues Connects with P
=1 Printerc

Figure 143: Locating and Identifying COM Ports from the Windows Device Manager

w | Tera Term: New connection

OTCPIP myhost.example.com ~
History
22
Telnet
SSH SSH2

Other

AUTO

Figure 144: Selecting the COM Port

Note: The COM port setting is specific to the computer being used and may need to be
different than shown. Use the COM port # that was discovered in the previous step.

5. Click OK (4).
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The terminal console window opens.
6. Select Setup > Serial Port.

‘T COM4 - Tera Term VT

i Control Window Help

Terminal...

Window...

Font ?
Keyboard...

Proww

Figure 145: Opening the Tera Term Serial Port Setup Window

The Tera Term Serial Port Setup dialog box opens.
7. Confirm that the proper serial port has been selected (1).
8. Set the baud rate to 115200 (2).

Tera Term: Serial port setup and connection x

: coM4 3 3
Port New setting q
Speed: ( : 1115200 v

Data: 8 bit v R
Parity: none ~

Stop bits: 1 bit v Help
Flow control: none v

Transmit delay

0 msecichar 0 mseciline

Device Friendly Name: USB Serial Port (COM4)

Device Instance ID: FTDIBUS\VID_0403+PID_6011+36693B\0000
Device Manufacturer: FTDI

Provider Name: FTDI

Driver Date: B-16-2017

Driver Version: 2.12.28.0

Figure 146: Setting the Parameters for the Serial Port

Note: The COM port setting is specific to the computer being used and may need to be
different than shown. Use the COM port # that was discovered in the previous step.
9. Click OK (3).

Tera Term is now configured to receive and transmit serial information to/from the evaluation
board.
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Vivado Analyzer Operations

This sub-section covers many of the common activities associated with configuring IP cores and
collecting data.

In This Section

INformMative INfOMMIATION ... .. e e 113
a1 (U o3 Lo o TR 115

Informative Information

The following information is for background understanding of the materials discussed in the
Instructions section.

Overview of the Vivado Analyzer Hardware Session

The following is a quick review of the Hardware Session screen usage.

File Edit Flow Toolsgdindow Layout View Help
g3 @ S{A)> > B ® %| T (@ [Eoeftlayout v w|® wrne,hnstrumc@
Flow Navigator « i t i D\ B
QT & Harduare Z 02 X ||®hwila_data_Lwchg® x e R
i = [H P
4 Project Manager
§ Frojectseng | ||Nme staus
3 nits BB locahost (1 Connectec ~
@i Add Sources =@l xin_tcffunknonn/2102033270534 () Open < [ [ o
LF 1P Catalog m = - =
4 1P Integrator Debug Probe Properties _ouwe x
#; create BlockD) 2| &
5% Open Block De g M5 i (3:0]

&y Generate Blod| =

Mame 2] 3:0]
4 Smuiation Source:  NETLIST
Probe type: ILA

43 simulation Seti =
(@, Ren Simaton General | Progssie = m velm b m f
4 RIL Analysis Debug Probes e =5t
 Open Elaborat| §| =z
¥ Open Elabora QA Name | Compare Value | Trigger Cond  TriggerPos  Data Dep
e > I——  E——
5 Synthesis Sett = e
> RunSynthesis il
<
[2% Open Synthesi [
b =
4 Implementation TLA Cores | VIO Cores ara
L] Implementatir [ Td Console | (> Messages:, o Debug Probes

Figure 147: Vivado Analyzer - Hardware Session Screen Usage
o A: Name of the active function (hardware session) and its TCF connection —
This shows that you have successfully opened the hardware session.

o B: Debug Probes — This section lists each ILA and VIO and the various
probes within each.

o C: Debug Probe Properties — Provides relevant information about the selected
probe (the type of device it is attached to, its width, etc.)

o D: Waveform Window — Each tab supports a different ILA or VIO.

o E: Exit Hardware Session — Click the 'X' to exit the hardware session and
access other Vivado Design Suite capabilities.
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Understanding Trigger Conditions

Trigger conditions describe the desired state of various trigger-capable signals.
When these settings are found, the ILA will trigger and capture data.

The Vivado analyzer recognizes five different signal conditions: Rising, Falling, 1,
0, and X (don't care). These signals conditions can be logically joined to describe
more complex situations.

First, consider a single probe example:

Captured when pasition = 0 Captured when position < buffer size

)
7
6
5
4
Probe ‘A’ 7
3 B
2 Il I j—l—l—lj
|- I . .IJ
1 | ;'l ||II rlll ‘_llf | | | | ‘ ‘ ‘ |
0 I : l,l- |- J_—‘ ‘ ‘ ‘ | |
I I_|"I -
I [ Il
. b / J
sampieposiion P AAAEEEEEEEEEEEEEELS
.JI- I,-'II ,lll.II |
7 | R *'jxi ;."'I fl :%
&l o i -
S S
501 /) | 5
/f , =
Compare | 4|0
Value 3 |1 K
2 | X
1| X
0| x

Figure 148: An Individual Probe's Compare Value
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Each position or signal within a given probe corresponds to one of five possible
match conditions (R,F,0,1,X) as specified in the Compare Value setting. The first
time each signal matches its specified "compare value", the combination
becomes "true". When all of the signals simultaneously match all of the "compare
values", the probe condition becomes true. If there is only one probe, then the
trigger conditions are met and data is captured.

If there are multiple probes within the ILA/VIO, then the results of the probes can
be ANDed or ORed together to cause a trigger. For example, if it does not matter
which probe triggers in order to capture data, you would set the ILA trigger
condition to "OR". If both probes must be simultaneously "true", then set the
trigger condition to "AND", which will then cause the trigger.

Instructions
The following sections contain only the detailed instructions for the specified task.

In This Section

Opening the Vivado Analyzer Hardware Manager ............ccoooeiiiiuiiiiiiini e 115
Adding Probes (Signals) to the Waveform Viewer.............c.ooiiiiiiiiiiii e 118
Removing Probes (Signals) from the Waveform Viewer ... 119
Arming the Vivado ANAlYZEr COrE ..........iiiiiiieeiiiiiie e e 120
Triggering the ILA IMmediately .........ccoouniiii e 121
AMD1 www.amd.com 115
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Opening the Vivado Analyzer Hardware Manager

The Vivado logic analyzer requires a connection to the target hardware board.
The actual connection is typically made using a USB-to-JTAG intelligent cable.
Many of our evaluation boards provide support for the intelligent cable as a
module component on the board.

When you open a hardware session, a cable server program is launched that
identifies the cable type and JTAG components on the board. A TCP/IP port is
opened for a connection that may be to a logic analyzer or other application.

1-1.  Open the hardware manager.
1-1-1. Expand PROGRAM AND DEBUG from the Flow Navigator.
1-1-2. Double-click Open Hardware Manager.
Flow Navigator = @& ? _
~ PROJECT MANAGER
£ settings
Add Sources
> Open Implemented Design
PROGRAM AND DEBUG
¥ Generate Bitstream
-[ ~ Open Hardware Manager ]
Open Target
Figure 149: Opening the Hardware Manager from an Open Project
1-1-3.  Click Open target > Open New Target from the Hardware Session window to open a
wizard that will facilitate making a connection to the USB platform JTAG download
cable.
HARDWARE MANAGER - unconnected
ﬁ Mo hardware targetis ope
£ Auto Connect
Hardware
Recent Targets 3
g
Open Mew Target...
Figure 150: Selecting Open New Hardware Target
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1-1-4.  Click Next to bypass the Welcome dialog box.

Open New Hardware Target X
AM Da Open Hardware Target

This wizard will guide you through connecting to a hardware target.

Vivado

ML Edition To connect to a remote hardware target, provide the host name and IP port
of the remote machine on which the instance of a Vivado Hardware Server
is running.

=

Figure 151: Opening a New Hardware Target
1-1-5. Use the default local server name since your board is connected to the machine that
you are running the Vivado Design Suite on (1).

If this is not the case, you will need to select the connection to the machine that is
attached to the board.

Open New Hardware Target x
Select local or remote hardware server, then configure the host name and port settings. Use Local -|
server if the target is attached to the local machine; otherwise, use Remote server. [

Connect to: Per Instruction ( 1 )

Click Next to launch and/or connect to the hw_server (port 3121) application on the local machine.

('_7' < Back Mext =-. 1 | Cancel

Figure 152: Using the Default Server Name

1-1-6.  Click Next to scan the JTAG chain and view the nodes within the chain (2).
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You should now see the xilinx_tcf hardware target and the hardware devices present in

the JTAG chain. The JTAG clock speed is also shown.

Open New Hardware Target x
Select Hardware Target

Select a hardware target from the list of available targets, then set the appropriate JTAG clock (TCK) frequency. If you do not
see the ewpected devices, decrease the frequency or select a different target.

Hardware Targets

Type Name JTAG Clock Frequency
B wilin_tef  Xilinw/36693A 15000000 v
S Y " PR P Y Y _,/ L

Add Xilinx Virtual Cable (XvC)

Hardware Devices (for unknown devices, specify the Instruction Register (IR) length)
Name ID Code IR Length
@ xezu?_0 14730093 12

@ arm_dap_1 5BA00477 4

Hardware server: localhost:3121

Figure 153: Viewing the Hardware Target and Devices

1-1-7.  Click Next to advance to the summary.

Open New Hardware Target x
AM Da Open Hardware Target Summary
VivadD @ Hardware Server Settings:
ML Edition o Server: localhost: 3121

@ Target Settings:
a Target: wlinx_tefXilin/36693A
© Frequency: 15000000

e Y PSR Y P gt P » o N W S

To connect to the hardware described above, click Finish

Figure 154: Summary Dialog Box

1-1-8.  Click Finish to connect to the target.
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Adding Probes (Signals) to the Waveform Viewer

When the hardware session opens, one or more probes (inputs into an ILA or
VIO) are present.

1-1. Add a probe.

1-1-1.  [Optional] Select one or more probes to add to the waveform in the Design Probes
window.

1-1-2.  Right-click the probe to add to the waveform from the Design Probes window.
o Select Add Probes to Waveform to add the selected probes to the waveform or
o Select Add All Probes to Waveform to add all the probes

Debug Probes

a MName Compare Value
5 -
z 4 = Debug Probe Properties... Ctrl+E
g dESIgn_l_prl’DEES Bl Run Trigger
Stop Trigger
EE;I [l Run Trigger Immediate

T i Add Probes to Waveform s 0 R
ores ores
- Add All Probes to Wawvefor %
5 Td Console | () Messages

Export to Spreadsheet...

Figure 155: Adding Selected (or All) Probes to the Waveform

The probes will be added after any existing probes in the waveform.

Note that any given probe may be added more than once. This may be desirable as
each probe entry in the waveform can have a different radix or color.
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Removing Probes (Signals) from the Waveform Viewer

When the hardware session opens, one or more probes (inputs into an ILA or
VIO) are present.

1-1. Remove one or more probes that you no longer want.
1-1-1.  Select one or more probes from the Waveform window.

1-1-2.  Press the Del key or right-click and select Delete.

Qo010

0010

Figure 156: Deleting a Probe from the Waveform Viewer
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Arming the Vivado Analyzer Core

The Vivado analyzer cores are individually armed. Arming a core simply means
that the core is made ready to collect incoming signals.

There are two basic modes of arming: Run Trigger and Run Trigger Immediate.
Run Trigger Immediate ignores the trigger conditions and simply captures data
from the time that you click Run Trigger Immediate until the core's memory fills.
Run Trigger immediately captures data when the specified trigger condition is
met.

Cores must be armed one at a time; therefore, it is good design methodology to
use the Trigger In and Trigger Out ports of the ILA and arm the cores from the
last core backwards to the first core. In this fashion, the sequence cannot be
completed until the first ILA is armed. This prevents "earlier" ILAs from arming
and having their trigger conditions met before you can arm the subsequent ILAs.

ILA_O ILA_1 ILA_n
Trigger Out P Trigger In Trigger Out |=p= — Trigger In
Trigger Out ACK |« Trigger In ACK  Trigger Out ACK = Trigger In ACK
= Probe 0 = Probe 0 = Probe 0
o000
= Probe 1 = Probe 1 = Probe 1
. . .
. . .
= Probe N = Probe N = Probe N
< Arming Order
|

Figure 157: Connections and Arming Order for Multiple ILAs

1-1. Arm the ILA core.
1-1-1.  Click the Run Trigger icon (L“‘]).

Triggering the ILA Immediately

Sometimes it is beneficial to see the activity on an ILA or VIO without having to
set or modify the trigger conditions.

If trigger conditions have not yet been set (all comparisons are set to 'X' - don't
care), this is equivalent to Run Trigger Immediate.

1-1. Capture whatever data is currently presented to the specified analyzer
core (trigger the ILA/VIO immediately).

1-1-1.  Click the Run Trigger Immediate icon (??).

After a (typically) short delay, depending on the sample rate and size of the capture
buffer, data will be uploaded from the device and displayed in the Waveform viewer.
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Vitis Model Composer Operations

This section contains instructions for commonly performed tasks using Vitis Model Composer.

In This Section

Launching Vitis Model Composer [SHARED] [LRG].....cccovuuuiiiiiiiiieeeee e 122
Simulating a Model in the Simulink SOftware ... 122

Launching Vitis Model Composer [SHARED] [LRG]

1-1. Launch Vitis Model Composer.
1-1-1.  Press <Ctrl + Alt + T> to open a new terminal window.

1-1-2.  Enter the following command to source Vitis Model Composer:
[host]$ source /opt/amd/2025.2/Model Composer/settings64.sh

Note: The installation path (/opt/amd) is valid for the Customer Training VM and
CloudShare environments. Modify the path as necessary for your environment.

1-1-3.  Enter the following command to set the installed MATLAB software path:
[host]$ export PATH=$PATH:<Path to_your Matlab installation>/bin

For the Customer Training VM and CloudShare environments, the MATLAB software is
installed in the /home /amd/matlab path. Enter the following command:

[host]$ export PATH=$PATH:/home/amd/matlab/bin

1-1-4.  Enter the following command to launch Vitis Model Composer:

[host]$ model composer

Simulating a Model in the Simulink Software

1-1. Simulate the model.

1-1-1.  Click the Run icon :‘ in the toolbar from the SIMULATION tab in the Simulink
software.
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Vitis Unified IDE Operations

Instructions

In This Section

Launching the Vitis Unified IDE and Setting a Workspace............cooovvviiiiiiiiiiiiiiiciiieeeeein 123
Opening a Vitis Unified IDE Workspace from the Welcome Window...............ccccceeeeiiviees 125
Launching the Python Command Line Interface ... 125
Creating an Application Component from Example Templates ..........cccoooeeiiiiiiiiiiiinneennnn. 126
Creating a Platform CompPONENt...........cooiiiiiiiiii e e e 128
Creating a Bare-Metal Application Component for an Embedded Flow ................cccccoenn. 132
Importing Sources to an ApPlCAtioN...........cooiiiiiii i 134
Opening a Source File in the EditOr............ouuu e 135
Finding Text in @ SOUICE File ..........oooiinii e 136
Setting Compiler Optimization OPLiONS ...........uii i e 137
Adding Symbols to Application Settings ..........coooiiiii i 139
Building the COMPONENES........cooiiiiii e 140
Running with a Default Configuration ..............coooiiii e 141
Running an Application on HardwWare .................oiiiiiiiiiiiii e 142
Launching QEMU for the Embedded Software FIOW ...............cooiiiiiiiiiiiiii e 143
Launching QEMU Using a Script in the Vitis Unified IDE..............cccooiiiiiiiiie 145
Creating and Running the Default Debug Configuration ... 145
Switching Views from the ToOoIDar............oovii e 150
Known Issue - ZCU104 - XParameters ........coooiiiiiiiiiie e 150
1972 o1 T T 11 T P 151
CloSiNG the VItIS IDE........coouiiiiieiie et e e e e e e e e e e e e e e e s e e e e eraaaeaaes 154

Launching the Vitis Unified IDE and Setting a Workspace

1-1. Launch the Vitis Unified IDE.

1-1-1.  Click the Vitis icon (d ) from the taskbar or desktop to launch the tool.

Figure 158: Launching the Vitis Unified IDE from the Taskbar

Alternatively, from a Linux terminal window (<Ctrl + Alt + T>), enter the following:
[host] $ source /opt/amd/2025.2/Vitis/settings64.sh; wvitis
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1-1-2.

1-2.

1-2-1.

1-2-2.

1-2-3.

1-2-4.

Note: This installation path is valid for the CloudShare and CustEd VM environments.
Use the proper path for your environment.

It is important to note that not all tools included in the Vitis suite of tools are supported
under Windows.

If not already maximized, click the Maximize icon in the upper-right corner of the tool
window to see all the views.

Set the workspace.

Best practices recommend setting a workspace regardless of the flow you
are following as it makes it easier to find the tool-generated logs and
scripts.

Alternatively, you can immediately jump into one of the development
flows, where you will eventually be asked to specify a workspace. This
causes the log and script files to be placed in two different directories.

From the Vitis Components window, click the Set Workspace link.

l-.' File Edit Selection View Go

O VITIS EXPLORER: NO FOLDER OPENED f

You have not yet opened a
workspace.

Set Workspace (

You can clone a repository locally,

Clone Repository

Jﬂh‘uu-.—-m“’.-4l'“"‘«

Figure 159: Setting the Workspace in the Vitis Unified IDE

Browse to the following location:

a workspace

Click Open to open the new workspace.

The tool relaunches using the new workspace.
Close the Welcome tab if it appears.

This tab opens various types of components, enables access to documentation and
examples, quickly switches workspaces, etc. If you want to reopen the Welcome tab,
select Help > Welcome.
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Opening a Vitis Unified IDE Workspace from the Welcome Window

1-1. Set the workspace.

Best practices recommend setting a workspace regardless of the flow you
are following as it makes it easier to find the tool-generated logs and
scripts.

Alternatively, you can immediately jump into one of the development
flows, where you will eventually be asked to specify a workspace. This
causes the log and script files to be placed in two different directories.

1-1-1.  From the Vitis Components window, click the Set Workspace link.

l-.' File Edit Selection View Go

O VITIS EXPLORER: NO FOLDER OPENED f

You have not yet opened a
workspace.

Set Workspace (

You can clone a repository locally,

Clone Repository

PV

Figure 160: Setting the Workspace in the Vitis Unified IDE

1-1-2. Browse to the following location:

a workspace
1-1-3.  Click Open to open the new workspace.

The tool relaunches using the new workspace.
1-1-4. Close the Welcome tab if it appears.

This tab opens various types of components, enables access to documentation and
examples, quickly switches workspaces, etc. If you want to reopen the Welcome tab,
select Help > Welcome.
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Launching the Python Command Line Interface

The Vitis Unified IDE supports the use of a Python command line interface that
allows scripting to automate complex or repetitive processes, reducing human
error and/or tedium.

The Vitis Unified Software Platform Documentation: Embedded Software
Development User Guide (UG1400), "Vitis Python CLI" chapter describes the
available commands and provides more examples.

Access the Python CLI in the Vitis Unified IDE via a terminal window to enter
Python commands directly into the environment, allowing you to configure Vitis
tool projects without the use of the GUI.

1-1. Open a terminal and set up the CLI.

1-1-1.  Select Terminal > New Terminal from the Vitis Unified IDE menu bar to launch a new
instance of the Vitis terminal.

1-1-2.  Enter the following command to launch the Python CLI in interactive mode:
[host]$ vitis -i

Creating an Application Component from Example Templates

Once the platform component is built, the next step is to create an application.

The Create Application Component Wizard provides a quick way to create an
application via the example templates available in the Vitis Unified IDE. Based on
the template that is selected, appropriate options are populated, and you choose
the right options to create the application component.

1-1. Create an application component.
1-1-1.  Navigate to the toolbar and click File (1).

1-1-2.  Select New Example from the options (2).

File; t Selection WView Go Terminal Vitls g

+,  NEWw Component >
* 3

New Example G

1

New Flle... Ctri+Alt+N

New Folder...
Open File... Ctrl+0

Add Folder to Workspace...
Save Workspace As...

W o g o W P

Figure 161: Creating an Application Component from Examples

-

p

I
+

The Examples window becomes visible.
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1-1-3.  Search for the application template example from the Examples window (1).

1-1-4. Select application template from System Design Examples > Vitis Accel Examples
Repository > Installed Examples Repository (2).

1-1-5.  Click Create Application from Template to create the application component (3).

k&:mpust 1 |) P v A - I welkome * F simple vector Addition
T Al Engines ples

3, System Design Examples Simple Vector Addltl?l_'l.y( Create Application from Te| np\ate( 3
. = A

. o
» Vitis Accel Examples Repository This is asimpl&m!r?’\;\e of vector addition. The purpose of this code is to introduce the user to application development in the Vitis tools.
.
:-v Installed Examples Repository _...--"
Al Engine System Design Examp\gs, ot * D vadd
.t
Simple Vector Addition * .
Hierarchical name installed_examples/vadd
Is Accelerated Libraries Repository
& Empty Accelerated Application Location fsamples/vadd/descriptionjson

~ Embedded Software Examples

_ Show Details
& DOR self refresh

& Dhrystone

& Empty Application

Figure 162: Selecting the Example Template and Creating an Application
Component

The Create System Project dialog box appears.
1-1-6. Enter your system project name in the system project name field (1).
1-1-7.  Click Browse in the System project location field to set the appropriate location (2).
1-1-8. Browse to the following directory:

STRAINING PATH/<the topic cluster name>/lab

1-1-9. Click OK.

Create System Project X

> Hardware >

Name and Location

Choose a name for your system project and specify a directory where sys! ata files will be stored
System project name I As per instructions
System project location I As per instructions 2 v Browse

System project will be created at

Figure 163: Creating the System Project and Selecting the Location

1-1-10. Click Next (3).
1-1-11. Select your platform project name from the list.
1-1-12. Click Next.
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1-1-13. Select the following paths (1):

o Kernel image:
the path to the kernel image

o Root FS:
the path to the file system root

o Sysroot path:
the path to the root of the system

1-1-14. Select the Update Workspace Preference option (2).

Create System Project

Name and Location > Hardware > Embedded ent Paths > Summary

Embedded Component Paths

Specify paths for embedded components. The tool will automatically populate these paths using nfcrmau@v Preferences -> Embedded Component Paths.

Kernel Image I As per instructions Browse
Root S I As per instructions I Browse
Sysroot I As per instructions I Browse
( Update Workspace Preference)':
N S N e P N ‘_F/ F o W * _./”"“" e SRPPTIE R P W~ T P NS w |

Cancel | Back ) &

Figure 164: Selecting the Embedded Components Paths

1-1-15. Click Next (3).

1-1-16. Review all the options and click Finish.
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Creating a Platform Component

A platform component contains a thorough description of a hardware design,
including:

o Which processors are available
o The PL-based peripherals and the enabled PS peripherals
o A full system memory map

Based on this description, software, such as the board support package (BSP),
and applications can be tailored to the hardware.

Normally, you would use your hardware description file, which is typically
generated by the Vivado Design Suite; however, there are situations when you
just want to quickly test your code using the standard peripheral set for the
supported device. Choose from the provided collection of predefined hardware
templates for various boards.

The following instructions illustrate how to include custom hardware.

1-1. Create a platform component.
1-1-1.  Navigate to the toolbar and click File (1).
1-1-2.  Hover over or click New Component to open its context menu (2).

1-1-3.  Select Platform from the options (3).

.._ File | Edit Selection View Go Terminal Help 2

Q New File Ctri+N
MNew Folder e

ew Component g
HLS

Open File... Al Engine

Open Workspace . Application

Systas Proj

Figure 165: Opening the Create Platform Component Wizard

The Create Platform Component dialog box appears.
Note: There are other ways to access this wizard; however, this is the easiest.
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1-1-4. Enter your platform project name in the Component name field (1).
Hint: Make certain that there aren't any spaces in this field.

This sets the name of the platform component. The associated directories and files are
populated within the current workspace.

Note: The Component location field is automatically set to the workspace location. The
location can be changed if you want to place this component somewhere else.

> Flow > >

Name and Location
Choose a name for your component and specify a directory where companent data files will be stored
Compot | Use the platform component name as per instructions Q

Component location 1 This will automatically fill according to the workspace location | Browse

Component will be created at

- -

Figure 166: Entering the Platform Component Name and Location

1-1-5.  Click Next to advance to the next page of the wizard (2).

1-1-6.  Select the Hardware Design option so that you can import an embedded design from
one of the supplied boards or one of your own (1).

1-1-7.  Click Browse next to the Hardware Design (XSA) For Implementation field (2).
1-1-8. Browse to the following directory:

the location of the files to be exported from the Vivado Design
Suite

1-1-9. Double-click the hardware platform description name.xsa file.

Remember that the Vitis Unified IDE does not automatically expand the environment
variables. You must type out or navigate to the path. For more details about
environment variables, refer to the Introduction section of this lab.

Create Platform Component

Name and Location > » Osand Processor >

Select Platform Creation Flow

Create a platform component by selecting the hardware design and add software demains.

(@ Hardware Desigi Existing Platform

Hardware Design (XS4) - " e
For Implementation | As per instructions |

> Emulation

> Advanced Options

Figure 167: Specifying the XSA File

1-1-10. Click Next to select the operating system and processor (3).
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1-1-11.

1-1-12.

1-1-13.
1-1-14.

1-1-15.
1-1-16.

If not already selected, select the operating system from the Operating system drop-
down list (1).

If not automatically populated, select your processor from the Processor drop-down
list (2).

Depending on the processor selection, additional options may appear, enabling you to
select the processor's instruction set architecture or provide options for boot artifacts.
Unless there is a specific reason to do so, leave this at its default setting.

Note: Zynq UltraScale+ MPSoC-based boards will allow you to select the architecture,
whereas this option is not available for Versal devices.

If not automatically populated, select 64-bit from the Architecture drop-down list (3).
Click the down arrow to select the appropriate boot components as follows (4):

Note: The following platforms are listed here for completeness. Follow the guidance for
the board or device you selected.

[Versal users]: This field is not available for this target—continue with the next task.

[MPSoC users]: Select Generate PMU Firmware, which generates the firmware for
the PMU present in Zynq UltraScale+ MPSoCs (5).

Select Target processor to create FSBL, which generates an FSBL that runs on the
specified processor. Under most circumstances, it doesn't matter which processor is
chosen (6).

[Zynq 7000 users]: Select Generate boot artifacts. Since there is only one type of
processor in this device's PS, the choice to select a processor type is unavailable.

Note: The boot process is handled differently in Versal devices; hence the absence of
this field when devices are selected.

Per Instructions

| Per Instructions

1
{2
Per Instructions @

. (6
Per Instruction

-

Figure 168: Specifying the OS and Target Processor for the Platform

Click Next to proceed to the Summary section (7).
Verify the information for the platform component and then click Finish.

Note: It takes a few minutes to process. The status is usually indicated in the bottom-
left corner, and progress messages appear in the Output window.

Along with the platform component, the wizard creates a domain within the platform
component based on the selected operating system and processor.

AMDA
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Creating a Bare-Metal Application Component for an Embedded Flow

Using the Create Application Component Wizard is a quick way to create an
application after a platform component is created.

Based on the dialog box choices, the appropriate toolchain is selected for pre-
processing, compiling, assembling, and linking.

1-1. Create an application component.
1-1-1.  Navigate to the toolbar and click File (1).
1-1-2.  Select New Example from the options (2).
Flle; 1 it Selectlon View Go Terminal Vitls
., Componem > ,3
' New Example ; g
New Flle... Ctrli+Alt+N i
MNew Folder...
Open Flle... Ctrl+O L]
Add Folder to Workspace... f*
save Workspace As... i
-+
W o o o W I R
Figure 169: Creating an Application Component from Examples
The Examples window becomes visible.
1-1-3.  Select application template under Embedded Software Examples (1).
1-1-4. Click Create Application Component from Template to create the application
component (2).
Alternatively, you can click the '+' symbol that appears when hovering over the
template name (3).
EXAMPLES oV A - 8
~ Al Engine Examples
> Installed Al Engine Examples I Create Application Component from Template 2
& Empty Al Engine Component
~ Acceleration Examples
Vitls Accel Examples Repository D
Vitls Accelerated Librarles Repository ) )
> Installed Examples Repository Hierarchical name
& Empty Accelerated Application Hide Details )
IV Embedded Software Examples I Supported 05 List
& DODR self refresh if‘mmlnm
& Dhrystone 1 freertos
&| As Per Instructions O Supported Processor List:
& FreeRTOS Hello World psu_cortexas3
& FreeRTOS IwIP Echo Server psu_cortexrs
& FreeRTOS IwIP TCP Perf Client psv_cortexa72
& FreeRTOS IwIP TCP Perf Server psy_cortexrs ,
Figure 170: Selecting an Example Template
The Create Application Component - application template dialog box appears.
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1-1-5. Enter your application project name in the Component name field (1).
Hint: Make certain that there aren't any spaces in this field.

This sets the name of the application component. While the "app" suffix is not required,
using it simplifies identifying the component type.

Create Applicatlon Component -

Name and Location > Hardware > > >

Name and Location

Choose a name for your compenent and specify a directory where component data files will be stored

Component name I As per Instructions Q

Component location v Browse

Component will be created at

I Cancel ) ﬁ

Figure 171: Naming the Application

1-1-6.  Click Next to continue with the process (2).
You will now associate the application with a platform and domain.
1-1-7.  Select your platform project name from the list (1).

Note: The platform information view will be populated with values from the selected

platform.
Create Application Component - X
Name and Location > Hardware > Domain >

Select Platform
Platforms supporting the selected example from your repositories. To create a new platform, use "File -> New Component -> Platform"

o

Y t

NAME BOARD FLOW VENDOR PATH
A _plat (1) _plat
‘ Embedded xilinx.com -_plat.xpfm
D7 oo P -ttt I P . ooy oo P Y W e S T T

Figure 172: Selecting the Platform Component

1-1-8.  Click Next to continue to the domain selection (2).

You can now associate this application with an existing domain or create a new
domain.
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1-1-9.

1-1-10.
1-1-11.

If not already selected, select your domain name to link to the application component

(1).

Create Application Component - |

Name and Location > Hardware > Domain > Summary

Select Domain

Choose a domain from the available domains In the platform

Name

|
1
+ create new...

Detalls

Name
Display Name
0s

Processor

- P adP™ g

( Cancel )

Figure 173: Associating the Application with a Domain

Click Next to continue to view the summary (2).

Click Finish to build the application component.

Note: This assembles all the pieces but does not compile the application.

a0 B
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Importing Sources to an Application

Next, add source files (your files) to the application component.

1-1. Import the sources.

1-1-1.  If not already done, expand your application project name > Sources so that the src
folder is visible in the Vitis Components window (1).

1-1-2.  Right-click the src directory as this is where you want to place the resource files (2).

The tools require certain files to be in specific locations. The tools look in the src
directory for source files and linker scripts. Other types of files can be imported into
other directories.

1-1-3. Hover over Import and select Files to select the necessary files (3).

VITIS COMPONENTS

~ LAB

> plat [Platform]

) app [Application]
> Settings

> Includes

~ [ src ]
e ] New Flle
New Folder

Copy
Paste

C
k
C
b Copy Path
P Copy Relative Path

Rename
» Output

Delete

Folders...

Figure 174: Importing Sources

1-1-4. Browse to the following directory:

the directory where your files are located
1-1-5.  Press <Ctrl> and click your files to select the file(s).

1-1-6.  Click Open to add all the files to the src directory.
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Opening a Source File in the Editor

1-1.

1-1-1.

1-1-2.

Open the desired source file in the editor.
Locate the desired source file in the Vitis Components window.

Note: Source files are typically located in the application's src folder and can be found
under your application project name > Sources > src (1).

Click the desired source file to open it in the editor window (2).

VITIS COMPONENTS

c > € _app.c

app [Application]

> Settings

> Includes

& Iscript.ld

© README.txt

Figure 175: Opening a Source File

Finding Text in a Source File

1-1. Find the text that you are looking for.
1-1-1.  Select View > Search or press <Ctrl + F>.
The Search view or Find/Replace dialog box opens based on how it was invoked.
When invoked from a view window or from selecting View from the toolbar, the Search
view is opened.
Note: The Search view can also be invoked by clicking the magnifying glass icon in a
view window.
SEARCH
h A an x o
Replat
Figure 176: Search View
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When the keyboard shortcut is used, the Find/Replace dialog box appears on the top-
right side in the editor.

Find Aa ab, ¥ | Mo results = X

Replace AB

Figure 177: Search/Replace Dialog Box

Note: To view the Replace field, click the arrow to the left side of the Search or Find
field to expand the view or dialog box.

1-1-2.  Enter the text that you are looking for in the Search or Find field.

1-1-3.  Press <Enter> to find the next occurrence of the text that you are looking for.

1-1-4.  Continue pressing <Enter> or clicking the down arrow until you locate the specific
instance that you are looking for.
If you are looking for text within a specific region of the code, you would first highlight
the region to perform the search in and then launch the find/replace function using the
keyboard shortcut as described in this set of instructions.

1-1-5.  Click the X icon to close the Find/Replace dialog box.
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Setting Compiler Optimization Options

Compiler options communicate the designer's intentions to the compiler. These
options directly affect how the object file is constructed.

1-1.

1-1-1.

1-1-2.

1-1-3.
1-1-4.
1-1-5.

Set the baseline application's optimization to your desired level of
optimization.

The Optimization settings enable you to select the level of optimization
needed to meet your timing requirements for this application. Note that
the optimization should be set to zero (-O0) for debugging; otherwise, the
one-to-one correspondence between the source code and the executing
code is lost.

Remember that the levels of optimization listed are collections of specific
optimization flags. Refer to the GNU Compiler Manual for a listing of
which flags are enabled for each optimization level.

If the predefined optimization settings do not suit your needs, you can
add your optimization flags to the Other optimization flags text field.
Remember that optimizations can change the way your code operates.

Expand your application project name > Settings in the Vitis Components window
(1).

Double-click UserConfig.cmake to open the compiler settings for this application
component (2).

Click Optimization under Compiler Settings (3).
Click the drop-down list in the Optimization level setting (4).

If the optimization is not already set to your desired level of optimization, then select
your desired level of optimization from the Optimization level drop-down list (5).

If you need to add any additional flags, place them in the Other optimization flags field

(6).

Optimization level
Optimizat

_app [Applicat =
Cgcy,,,. Compiler Settings Optimization
vitis-comp. jsor
A t D
1 cmal )

stion lev {None] . -O1 [Optimize] , -O2 [Optimize Mg— -O3 [Optimize Most] or -Os [Optimize Size
[ As Per Instructions @ @

Figure 178: Updating the Application Component Compiler Settings
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Adding Symbols to Application Settings

Adding a symbol to an application is equivalent to adding a #DEFINE
SYMBOL_NAME statement that is visible to the entire project. It is common
practice to use symbols to conditionally compile code by guarding code with
conditional pre-processor statements (e.g., #ifdef SYMBOL_NAME ... #endif).

Remember that #ifdef only tests to see if a preprocessor symbol has been
defined or not, and #if can test against specific values (assigning a value to a
symbol can be done like this: NEW_SYMBOL=123).

1-1.  Add symbol(s) to the compiler settings.

1-1-1. Expand your application project name > Settings in the Vitis Components window
(1).

1-1-2.  Click UserConfig.cmake to open the compiler settings for this application (2).

1-1-3.  Click Add Item under Defined Symbols (-D) to add the first symbol (3).

VITIS COMPONENTS. * A UserConfigemake *

Compiler Settings
Symbols

Defined Symbols (-D)
Add any compiler definitions, they will be added as extra definitions. Example ,

efine any previously specified compiler definitions, either bullt In or provid
BOL to the compller

Figure 179: Accessing the UserConfig Settings for the Application

1-1-4.  Enter the symbol name in the field that opened after the previous task (1).

Note: Symbols can only be added one at a time.

Compiler Settings
Symbols

Defined Symbols (-D) i
Add any compller definitions, they will be added as extra definitions. Examplg

| As Per Instructions Cancel -
— (1) (2 ¢
e il - . F » -

Figure 180: Defining a New Compiler Symbol

1-1-5. Click OK to add each new symbol individually (2).

Note: Follow tasks 3 through 5 to add the symbol(s) in this list: application project
symbol names as required.

1-1-6.  Once all the symbol(s) are added, close the UserConfig.cmake tab.
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Building the Components

1-1.

1-1-1.

1-1-3.

1-1-4.

1-1-5.

Confirm the build setting and build the components.
From the Flow window, click the arrow for the Component drop-down list (1).

Hint: You may need to click the ">' symbol next to Flow to expand the Flow window.

f
F

{% FLOW

Figure 181: Expanding the Flow Window

Select your application project name (2).

~ FLOW ¥ A

Component L1 _app

Component 0

: &7 Bulld
[ Runi E > f
3
4
i’

& Debug

__ 4] Create Boot Image
f-u—.m_m

Figure 182: Building the Application Component

Click Build (3).
This will build all components with the settings specified in the build configuration (if
any).

If prompted by the Application - Platform Build Dependency dialog box, select Always
build platform with application (1).

Application - Platform Build Dependency

| Changes in Platform BSP won't automatically trigger a rebuild.
! Please choose how you want to handle pla@ulds when building your application:

[@ Always build platform with application

Only build application (manually build platform if needed)

Save in Workspace Preference

Figure 183: Selecting the Platform Build Dependency

Click Save in User Preference (2).
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Note: Click OK if prompted with the Platform Build message.
Any issues are shown in the Problems or Output tabs.

Note: Monitor the progress of the build via the percentage values displayed in the
Output tab.

Vitis Server _app: X

[ 14%]

[ 28%]

[ 42%]

[ 57%3
-
[ 7197 progress

[ 85%]

& A o ™t
Figure 184: Build Progress Indicator

When the compilation completes successfully, a size summary of the build is displayed.

OUTPUT x PROBLEMS x

Vitis Server _app: X

|Build Finished successfully|

Figure 185: Successful Build Console Message
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Running with a Default Configuration

Configurations are a powerful ally in setting up a run for specific sets of criteria.
The default configuration settings are adequate for most basic programs and do
not require clicking through multiple dialog boxes just to run the program.

1-1. Run your application project name with the default configuration settings.

1-1-1.  Select your application project name from the Component drop-down list from the
Flow view (1).

1-1-2.  Click Run to begin running the application on the hardware (2).
Component ] _app v, TE
7% Bulld @ o

Debug
.| Create Boot Image

Figure 186: Launching the Application on Hardware Using the Default
Configuration Settings

Running an Application on Hardware

1-1. Run the application on the board.
1-1-1.  Switch back to the Vitis Unified IDE.

1-1-2. Click Run from the Flow view.

Figure 187: Running the Application on Hardware

Note: This will take a few seconds. During this time, the tool runs several commands to
initialize the hardware. First, the hardware is reset. Once reset is successful, the device
is programmed with the application.
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Launching QEMU for the Embedded Software Flow

Note: The current version of the Vitis Unified IDE does not have direct support for QEMU in
the embedded software development flow; hence, as a workaround, you will run QEMU
externally to validate the application. Here you will copy the necessary files into the project
and run several commands to set up QEMU.

1-1.
1-1-1.

1-1-4.

Launch a terminal and copy the files needed to launch and run QEMU.

From the Vitis Unified IDE menu bar, select Terminal > New Terminal to launch the
built-in terminal.

Select the Terminal tab to enter commands and view the status of executed
commands.

Enter the following command to confirm that the terminal is pointing to
STRAINING PATH/<the topic cluster name>/lab:

[host] $ pwd

Copy the QEMU-related files using the following commands:

[host] $ cp STRAINING PATH/CustEdIP/makefile .

[host] $ cp STRAINING PATH/CustEdIP/xsct_script.tcl .

Note: The dot at the end of the command means "copy to the current directory" and
MUST be included in these commands.

[MPSoC users]: Also enter the following command:
[host] $ cp STRAINING PATH/CustEdIP/pmu _rom gemu sha3.elf .

This set of commands copies one makefile, one QEMU ELF file, and one Tcl file into
the Vitis tool workspace. The makefile sources the Tcl file procs and builds the files to
support QEMU and the application executable.

Note: This is a patch. Ideally, the Vitis Unified IDE will open QEMU natively; however,
for 2024.1, this minor workaround must be performed.

You will now run the makefile that you just copied to build all the QEMU DTS and
scripts necessary to run QEMU from the terminal. Once these files are
generated, you will then build and run the application on QEMU and observe the
results in the console.

1-2.

1-2-1.

Run the makefile to generate the QEMU scripts and then run the
application.

Run the build gemu dts command to generate the necessary device tree files:
[host] $ make build gemu dts

With the device tree files generated, the application now needs the executables to be
created based on the processor type and design.
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1-2-2.

1-2-3.

1-2-4.

1-2-5.
1-2-6.

1-2-7.

Generate the application executables:

[host] $ make generate apps APP=your application project name
PROC=<processor name> XSA=<xsa file name>

where:
[MPSoC users]: PROC = psu_cortexa53 0
[Versal users]: PROC = versal cips 0 pspmc 0 psv_cortexa72 0

<xsa file name>: If the XSA file that was used to create this project is in the lab
directory, then only the file name is required, not the full path. If not, the full path of the
file must be provided.

Once the application executables are generated, view the contents of the a72. txt or
a53. txt file to make sure it contains the right path for the application ELF file.

Open the a53.txt ora72. txt file:
[MPSoC users]:

[host] $ gedit a53.txt
[Versal users]:

[host] $ gedit a72.txt

Verify that the content of the text file is as follows:

-device loader,file=your application project name/build/your
application project name.elf,
cpu—-num=0

Note: If the content of the text file is not the same as the above, replace the text with
the above line and save and close the file.

Close the editor by clicking the 'X' in the upper-left corner of the tool.
Generate the QEMU scripts:

[host] $ make generate gemu scripts XSA=<xsa file name>

The generated scripts will run the application in the QEMU instance.
A message in the terminal shows that the scripts are generated and are ready to run:

77777777777777777777777

INFO: [Hsi 5522033] elapsed time for zepositazy (fopt/amd/vitis/st
fo: machine-path sec WONE)cu;

Info: No applicagions found for rs

Info: No applications found fox x5 @ @ @ o ommand to test the amm on OFF

Figure 188: Terminal Message When Generating the QEMU Scripts

Run the run _gemu command to ensure that QEMU is ready and to run the application:

[host] $ make run gemu
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Launching QEMU Using a Script in the Vitis Unified IDE

Note: The current version of the Vitis Unified IDE does not have direct support for QEMU in
the embedded software development flow; hence, as a workaround, you will run QEMU by
using a script to validate the application.

1-1. Execute the application from a Linux terminal.

1-1-1.  From the Vitis Unified IDE menu bar, select Terminal > New Terminal to launch the
built-in terminal.

1-1-2. Select the Terminal tab to enter commands and view the status of executed
commands.

1-1-3.  Enter the following command to navigate to the support directory:
[host] $ cd STRAINING PATH/<the topic cluster name>/support
1-1-4.  Run the script that launches QEMU with the necessary command line arguments:
[host] $ ./<the topic cluster name> QemuRun.sh your processor

It will take a few moments to get QEMU configured and running. The output will appear
in the terminal window.

Note: If the script fails to run, you may need to set its permissions. Enter chmod 777
<the topic cluster name> QemuRun.sh and then rerun the script.
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Creating and Running the Default Debug Configuration

There are many options as to how to set up a Debug configuration. Often, the
default options are enough when you just want to quickly run your application in
debug mode.

1-1. Launch the XSDB console and determine the TCF port number.
1-1-1.  Select Vitis > XSDB Console to launch the XSDB console.
1-1-2.  After the console launches, enter the following command to set up a TCF channel:

Note: You may have to press <Enter> in order to type in the XSDB console.
xsdb% gdbremote connect localhost:9000

Note: If connection refused messages appear after running the above command,
replace 9000 with 9001 and try again.

TERMINAL 2 = TASK: XSDB CONSOLE TERMINAL 4 = 0 ~ x

*##%x#% System Debugger (XSDB)
#*¥% Build date : .
*#* Copyright 1986-2822 Xilinx, Inc. ALL Rights Reserved.
** Copyright 2822-2024 Advanced Micro Devices, Inc. AlLL Rights Reserved.

XSDB Server URL: TCP:localhost:4@539
xsdb% XSDB Server Chammel: tcfchan#@
XSDB Started

xsdb%

xsdb% gdbremote connect localhost:9800

attempting to launch xrt_server

xsdb% Info: Cortex-A72 #0 (target 3) Stopped at @x20a@ (Suspended)
xsdb% Info: Cortex-A72 #1 (target 4) Stopped at @x@ (Suspended)
xsdb% Info: Cortex-R5 #@ (target 6) Stopped at @x@ (Suspended)
xsdb% Info: Cortex-R5 #1 (target 7) Stopped at @x@ (Suspended)
xsdb% B

Figure 189: Setting Up a TCF Connection

1-1-3.  Enter the following command to display the currently running TCF channel:

xsdb% conn -list

xsdb% conn -list

*tcfchan#1l tcp;lz?.e.e.1D
xsdb% |

Figure 190: List of Running TCF Connections

Note down the port number—it will be needed for the instructions that follow.
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1-2. Create a new target connection for the Hardware Server.
1-2-1.  Select Vitis > Target Connections to create a new target connection.

1-2-2.  Click the + icon for a new target connection.

Target Connections

~ Hardware Server

Local (Default)
~ Linux TCF Agent

Linux Agent (Default)

— —— /- _f ba e . ___/ b, e
Figure 191: Creating a New Target Connection

The Target Connection Details dialog box opens.
1-2-3. Enter gemu_debug in the Name field (1).
1-2-4. Ensure that Hardware Server is selected as the type (2).
1-2-5. Enter 127.0.0.1 as the host IP (3).

1-2-6.  For the port number, enter the value that you noted down in the previous instructions

(4).

Target Connection Details

MNew Target Connection

Name As per instructions (1 )

Set as default target

Type Hardware Server ( 2 ' VQ
3

Host As per instructions

Port Value obtained from previous instructions

Test Cionre-::ti-:nQ Cancel _} o]

Figure 192: Configuring the Target Connection

| Use Symbol Server

> Advanced

1-2-7. Click Test Connection to verify whether the connection is established (5).
1-2-8. Click OK twice to exit the Target Connection Details dialog box (6).

1-2-9. Close the Target Connections window.
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1-3. Create a new launch configuration.
1-3-1.  Right-click in the empty space of the Explorer pane.

Note: The Explorer pane can be opened by selecting View > Explorer.
1-3-2. Select Edit Launch Configurations.
1-3-3. Click New Launch Configuration to launch the Create Launch Configuration Wizard

(1).
1-3-4. Select Embedded Standalone Application as the design type (2).
1-3-5. Select Attach to Running Target as the debug option (3).

launch.json =
ide > launch.json
522 o> o -
+ New Launch Configuration ngine Graph

Figure 193: Creating a New Launch Configuration
1-3-6.  Click Submit to close the Create Launch Configuration dialog box (4).

A launch configuration with default settings is generated.
1-3-7.  Ensure that the Target Connection field points to the target connection created in the

previous instructions (5).
1-3-8.  Click the Debug icon to begin a debugging session (6).

;de ‘.\\\::\ “Am“d”&‘\”

Figure 194: Newly Generated Launch Configuration
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1-4.

1-4-1.

1-4-2.
1-4-3.

1-4-4.
1-4-5.
1-4-6.

1-4-7.
1-4-8.
1-4-9.

Add a symbol file.

The debugger has launched, but for it to proceed, a symbol file needs to
be added. A symbol file is the application ELF file created by the tool.

Expand the Debug window (1).

The Debug window lists the processors available in the target board you are emulating.
Right-click your processor (2).

Select Manage Symbol Files (3).

o GdbClient (localhost:9000)

~ p1

Cortex-A  #0 )
e |b> Continue

ortex-A  #1 Step Over

v p2 ¥ Step Into

Cortex-R5 #0 T Step Out
Cortex-R5 #1 3
IManage Symbaol Files...

TCF Debug Virtual Terminal

Figure 195: Adding a Symbol File to the Debugger

Click the '+' symbol.
Click Browse when the Add Symbol Files window appears.

Navigate to the following directory:
location of the ELF file

Double-click name of the ELF file.

Click OK to close the Symbol Files dialog box.
In the XSDB console, enter the following command to download the ELF file into it:
xsdb% dow location of the ELF file/name of the ELF file

Note: STRAINING PATH may need to be expanded.

The debugger is now configured and launched in the main source file. The following
message appears on the XSDB console:

. -.0n, Jata: Oa. ...2%954 - vxwvd02S . L
section, .sbss: @x00029080 - 0x0002907f
section, .tdata: 0x00029080 - 0x0002907f
section, .tbss: Ox00029080 - 9x0002907f
section, .bss: O0x00029080 - 0x000290bf
section, .heap: 0x000290c@ - 0x0002bobf
section, .stack: ©Ox0002b0Bc@ - OxBLRB2eObf

100% eMB 5.9MB/s ©0:00

Satting DL to brogran Start Address 0x00000000

Successfully downloadec‘ .elf g
Xsdb%® L]

Figure 196: Successful Download Message
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Switching Views from the Toolbar

1-1.  The Vitis toolbar on the left of the IDE is a collection of views that assist
you with a specific task. There are several predefined views, including the
Vitis Components view for developing applications and a Debug view for
debugging.

1-1-1.  Locate the icon for the view that you would like to switch to in the toolbar on the left
side of the IDE.

@| Vitis Components |
D|v Search

Dl Source Control
Dl Debug

|
|
|
D| Examples |
|
|

Dl Libraries
Dl Analysis

Figure 197: Different Views in the Toolbar

1-1-2. Click the desired icon.

Known Issue - ZCU104 - xparameters

Known issue: For applications using the serialPort_helper.c file as part of the source
files (observed in labs using ZCU104):

Sometimes, because of the way the xparameters.h file is generated, the block of code that
contains the definitions of UART base addresses may not be pointing to the right constant
definitions in the xparameters file. This can be observed when you're unable to give keyboard
inputs in the Terminal.

If this happens, you will need to:
- Manually locate the xparameters.h file located in the following location:

STRAINING PATH/<the topic cluster name>/lab/your platform project
name/psu_cortexab53 0/
standalone psu cortexa53 0/bsp/include

- Search for /* Definitions for peripheral UARTO */ (1).
- Locate the constant definition that holds the base address ending with BASEADDR (2).
- Copy the definition.
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- Replace the current value of UART _BASE_ADDRESS with the correct base address
definition you just identified.

Figure 198: Known Issue — serialPort_helper Definitions

Debugging

In This Section

(D= o1 e [ 7o) 1 (o] 3PP 151
Running the Debugger on HardWare ............cooouuiiiiiiiii e 152
T T= 1 oo ] 7P 152

Debug Controls

The Debug toolbar icons provide easy access to the various debugger features.
Take a moment to familiarize yourself with the toolbar location, icons, and their
functions. Note that some of the more popular icons have function keys
associated with them.

DEBUG

2PP... =]
E=ulalaYalsle

Figure 199: Debug view options

o Start Debugger: Launches the debugging process (1).

o Continue: Allows program execution to continue from a current breakpoint or
paused state (2).

o Pause: Enables pausing the execution of the program—usually to inspect
variables or to stop the program from running further (3).

o Step Over: Executes the current line of code and moves to the next line but
does not enter into function calls (4).
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o Step Into: Moves the debugger to the next line of code, entering function calls
to debug them step by step (5).

o Step Out: Allows the debugger to execute until it exits the current function,
then stops at the line immediately after the function call (6).

o Restart: Restarts the debugger by placing it in the beginning of the
application (7).

o Stop: Stops the debugging process and disconnects the debugger from the
target (8).

o Debugger settings: Opens the debugger configuration settings (9).

Running the Debugger on Hardware

There are many options as to how to set up a Debug configuration. Often, the
default options are enough when you just want to quickly run your application in
debug mode.

1-1.

1-1-1.

Run the debugger from the Flow view.

Select your application project name from the Component drop-down list from the
Flow view (1).

Ensure that the application has been built by verifying that there is a green check mark
next to Build.

~ FLOW z =

Component

Build 0

> Run 9

4] Create Boot Image

Figure 200: Running the Debugger

1-1-2. Click Debug (2).

The Vitis Unified IDE will start programming the board.

This might take a few minutes to finish. The Debug view will automatically open.
152 www.amd.com AMDZA
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Breakpoints

In This Section

Opening the Breakpoints View
Running to a Breakpoint

Opening the Breakpoints View

1-1.
1-1-1.

Open the Breakpoints view.

Select the BREAKPOINTS view in the Debug window to see all of the automatically

generated breakpoints as well as any breakpoints that you have created.

Tip: You can reopen the view by selecting Debug.

DEBUG t’
> Lo | E8s p=
I 20 T o 0O

> DEBUG
» CALLSTACK

» VARIABLES

> i
E= > WATCH (
~» BREAKPOINTS + o &
A main
A _exit

Figure 201: Locating the Breakpoints View

Running to a Breakpoint

1-1. Run to the next breakpoint.

1-1-1.  Click the Continue icon (/) to continue operation.
The application will run until an unconditional breakpoint is met or a conditional
breakpoint whose condition is satisfied is met.
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Closing the Vitis IDE

1-1. Close the Vitis Unified IDE.

1-1-1.  Select File > Close Window to close the tool.

Vitis Unified IDE HLS Component Operations

This section contains instructions for commonly performed tasks using the Vitis High-Level
Synthesis (HLS) tool.

In This Section

Creating an HLS COMPONENL....... .ttt e e e ee et e e e e eeeenene 154
Simulating an HLS COmMPONENL..........cooiiii e 158
Synthesizing an HLS COMPONENL ........ccooiiiiiiiie e 159
Implementing an HLS COMPONENL .........ooiiiii e 160
Running C/RTL Cosimulation with Trace Level.............coooiiiiiiii e 162
Setting the Trace Level for C/RTL Cosimulation ..............coveiiiiiiiiiiiiie e 164
Running C/RTL CoSIMUIALION ......coiiiiiiii et 165
= To3 =T | o TN I = T | P 167

Creating an HLS Component

1-1. Create the HLS component for your HLS project name.
1-1-1.  Navigate to the toolbar and click File (1).

1-1-2. Hover over New Component (2).

| File | Edit Selection View Go Terminal Help Vitis

New File Ctrl+N

New Folder
New Component > HLS
Al Engine
pen File... Ctrl+0 e g
Application
Open Workspace ... Ctri+Alt+W Platform
Open Recent Workspace... Ctri+Alt+R

System Project

Open Waveform... From Examples

£ 2nan Cirl+ g
Figure 202: Creating a New HLS Component

1-1-3.  Select HLS from the options to create the HLS component (3).
The Create HLS Component dialog box appears.
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1-1-4.

1-1-5.
1-1-6.

1-1-7.

Enter your HLS project name in the Component name field (1).

This sets the name of the HLS component, and the associated directories and files are
then populated within the current workspace.

Note that the Component location field is automatically set to the workspace location

().

Create HLS Component - Empty HLS Component

MName and Location > Configuration File > > > >

Name and Location

Choose a name for your component and specify a directory where component data files will be stored

1
Browse
2

I T S T T

Component name | As per Instructions

Component |ocation | Automatically populated as per the workspace

Ccomponent will be created at

B

NV e |

s’

¥

I SR SN

| Cancel )

Figure 203: Choosing the Component Name and Location

Click Next to advance to the Configuration File page (3).
Select Empty File (1).
The remaining fields can be left at their default settings.

Note that the new configuration name will be set to hils_config.

Create HLS Component - Empty HLS Component

Name and Location > Configuration File > Source Files > > >

Configuration File

A configuration file stores component settings like source files, compiler settings, etc. How would you like to set up your configuration file?

@ Empty File o

Existing File

Generate from Vitis HLS Project

Create a new, empty configuration file

New configuration file name hls_config

Compenent configuration file will be created at

r/ M amrininsn gt

b T

(" cancel ) (" Back )

Figure 204: Selecting the Configuration File

Click Next to advance to the Source Files page (2).
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1-2.  Add the source and testbench files to the HLS component.
1-2-1.  Click the Add Files icon in the Design Files section (1).
1-2-2. Browse to the following directory:
the directory where your files are located
1-2-3. Select your HLS source files and click Open.
1-2-4. Click Browse next to the Top Function field (2).
1-2-5. Select the name of the top function kernel function (3) and click OK (4).
1-2-6.  Click the Add Files icon in the Test Bench Files section (5).
1-2-7. Browse to the following directory:
the directory where your files are located
1-2-8. Select your HLS testbench files and click Open.
Create HLS Component - Empty HLS Component
Name and Location > Configuration File > > Hardware > >
Add Source Files
Specify design, test bench files and flags for your component. You can also skip this step now and add sources later
DESIGN FILES
FILE(S) CFLAGS CSIMFLAGS 0
P
As perinstructions
TEST BENCH FILES o i
B - <
P Y W SN N r - VP S » gy
Figure 205: Adding the Source and Test Bench Files
1-2-9. Click Next to advance to the Part selection page (6).
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1-3.
1-3-1.
1-3-2.

1-3-3.
1-3-4.
1-3-5.

1-3-6.

1-3-7.

Specify the part number and settings for the HLS component.
Ensure that the Part option is selected (1).

Select the part number from the list of parts (2).

Create HLS Component - Empty HLS Component

Name and Location > Configuration File > Source Files > > >

Part

Specify a board, device, or platform you are compiling your compenent for

Platform Hardware Design
. - » > " T S W > Y
I As perinstructions @
PART FAM PACKAGE SPEED LuT FF DSP BRAM
— o - / - e " A - -
o _y™ r P S — ——————— Py, S —— ey |

- R . ! » 4 ‘
\ Cancel ,‘ ‘ Back lﬂ

Figure 206: Adding the Part Number to the HLS Component

Click Next to advance to the Settings page (3).
Enter your clock period for the clock setting (1).
Select Vivado IP Flow Target from the flow_target drop-down list (2).

Note: By default, the package.output.format option is selected as Generate Vivado IP
and .zip archive.

Create HLS Compenent - Empty HLS Component

Name and Location > Configuration File > Source Files > Hardware > > Summary
Edit Settings
Specify initial HLS settings.

clock
Specify the clock period in ns, ps, hz, MHz, or GHz (ns is default). If no period is specified a default period of 10ns is used.

| As per the instructions

clock_uncertainty
Specify how much of the clock period is used as a margin by HLS. Default units is ns but % or MHz can also be used.

Examples: 27%, 2ns, 20MHz

flow_target
Spedify target for interface and tool defaults

[\-’wsdc IP Flow Target VO

package.output.format
specified the packaged format.

Generate Vivado IP and zip archive ~

( cancel ) (_ Back ﬁ

Figure 207: Specifying the HLS Settings

Click Next to advance to the Summary page (3).
Review the HLS component summary and click Finish.
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Simulating an HLS Component

1-1.  Simulate the design.
1-1-1.  Go to the Flow view (1).

The Flow view displays C Simulation, C Synthesis, C/RTL Cosimulation, Package, and
Implementation as the primary steps of the HLS component workflow.

1-1-2.  Select the active HLS component to simulate from the Component drop-down list (2).

Note: You can have multiple components in a system project. These components will
be displayed here.

&
»

FLOW

mponent v ]| £

~ CSIMULATION

(R
e.é Debug
> REPORTS
» CSYNTHESIS
» C/RTL COSIMULATION

> PACKAGE
» IMPLEMENTATION

Figure 208: Running C Simulation

1-1-3.  Click Run under C Simulation (3).

The Run C SIMULATION Basic Settings pop-up window appears, displaying the
available settings under C Simulation.

Run C SIMULATION Basic Settings

o

csim.clean
csim.setup
csim.code_analyzer

| csim.argv

Do not show this dialog again

|

Lg "I Y
Run { Cancel )

. | y

Figure 209: Run C SIMULATION Basic Settings

1-1-4. Keep the default settings and click Run.
This will initiate C simulation using the default configuration.

You can view the simulation log in the Output tab.
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Synthesizing an HLS Component

1-1.  Synthesize the design.
1-1-1.  Go to the Flow view (1).

The Flow view displays C Simulation, C Synthesis, C/RTL Cosimulation, Package, and
Implementation as the primary steps of the HLS component workflow.

1-1-2.  Select the active HLS component to synthesize from the Component drop-down list
(2).

Note: You can have multiple components in a system project. These components will
be displayed here.

Trow { 1) v A

Component ~ €23
~ CSIMULATION
> Run &

5 Debug
> REPORTS

~ C SYNTHESIS
>
~ C/RTL COSIMULATION
> Run
>
~ PACKAGE
> Run
>
“~ |IMPLEMENTATION
> Run
>

Figure 210: Running C Synthesis

1-1-3.  Click Run under C synthesis (3).
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The Run C SYNTHESIS Basic Settings pop-up window appears, displaying the

available configuration options for the synthesis process.

Run C SYNTHESIS Basic Settings

part

Browse

clock

clock_uncertainty

flow_target

vivado ~

/| package.output.syn

Do not show this dialog again

r D
Run [ Cancel )
[ " |

Figure 211: Run C SYNTHESIS Basic Settings

1-1-4. Keep the default values and make sure package.output.syn remains checked.
1-1-5.  Click Run.
This will initiate C Synthesis using the current configuration.
You can view the synthesis log in the Output tab.
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Implementing an HLS Component

1-1. Implement the design.
1-1-1.  Go to the Flow view (1).

The Flow view displays C Simulation, C Synthesis, C/RTL Cosimulation, Package, and
Implementation as the primary steps of the HLS component workflow.

1-1-2.  Select the active HLS component to simulate from the Component drop-down list (2).

Note: You can have multiple components in a system project. These components will
be displayed here.

FLOW
rnponcnt
> CSIMULATION
» CSYNTHESIS
2 C/RTL COSIMULATION

> PACKAGE
~ IMPLEMENTATION

> REPORTS
Figure 212: Running Implementation

1-1-3.  Click Run under Implementation (3).

The Run IMPLEMENTATION Basic Settings pop-up window appears, displaying
configuration options for the implementation process.

L
Figure 213: Run IMPLEMENTATION Basic Settings
1-1-4. Keep the default values and click Run.

This will initiate the implementation process using the current configuration.
You can view the implementation log in the Output tab.
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Running C/RTL Cosimulation with Trace Level

1-1.

1-1-1.
1-1-2.
1-1-3.
1-1-4.
1-1-5.
1-1-6.

Set the trace level for C/RTL cosimulation.

Expand your HLS project name > Settings in the Vitis Components window (1).
Click hls_config.cfg to open the configuration settings.

Scroll down and click C/RTL Cosimulation (2).

Scroll on the right side and locate cosim.trace_level.

Click the down arrow to open the list of trace levels.

Select all from the list of trace levels (3).

O VITIS COMPONENTS vitis-compjson <[5 “ 2 nisconfigerg

~ LAB

[HLS]
 Settings
vitis-comp.json
O

> Includes

All Settings

cosim.teo
v Sources General Option ta select the HDL simulator to be used to co-simulate the RTL with the C testbench
4 C Synthesis sources
xsim -
> Test Bench Testbench sources

~ Output Blackbox sources

B config.cmdline ~ Simulation &
> esim C Simulation

hls_data.json e C/RTL Cosimulation

C synthesis

cosim.trace_level

Betermines te level of waveform tracing during C/RTL cosimulation.

all v

none default

port 4
Companent v & Compile 1

AP A At I bl IO R A g I NGl ottt P g g R B g e T

> = impl
Array Partition

v FLow Array Stencil

Figure 214: Configuration Settings for C-RTL Cosimulation

The trace_level option specifies the level of trace file output written to the sim/Verilog or
sim/VHDL directory of the current solution when the simulation executes.
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1-2. Run C/RTL cosimulation for your HLS project name.

1-2-1.  Go to the Flow view (1).

The Flow view displays C Simulation, C Synthesis, C/RTL Cosimulation, Package, and

Implementation as the primary steps of the HLS component workflow.

1-2-2. Select the active HLS component to simulate from the Component drop-down list (2).

Note: You can have multiple components in a system project. These components will
be displayed here.

o Component

v | &
» CSIMULATION 2

» CSYNTHESIS
v C/RTL COSIMULATION

3 [> Run

» REPORTS

v PACKAGE
[> Run

Y REPORT®

~  IMPLEMENTATION

[> Run

Y e NP e S

Figure 215: Running C/RTL Cosimulation

1-2-3.  Click Run under C/RTL Cosimulation (3).
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The Run C/RTL COSIMULATION Basic Settings pop-up window appears, displaying
configuration options for the cosimulation process.

Run C/RTL COSIMULATION Basic Settings

o

cosim.argv

cosim.compiled_library_dir

Browse
cosim.disable_deadlock_detection
cosim.enable_dataflow_profiling
cosim.enable_fifo_sizing
cosim.random_stall

cosim.rtl

verilog ~ |
cosim.setup

cosim.tool

xsim ~

| cosim.trace_level

all ~

cosim.wave_debug

Do not show this dialog again

Figure 216: Run C/RTL COSIMULATION Basic Settings

1-2-4. Keep the default settings and click Run.
This will initiate C/RTL cosimulation using the current configuration.
You can view the simulation log in the Output tab.
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Setting the Trace Level for C/RTL Cosimulation

1-1.  Set the trace level for C/RTL cosimulation.
1-1-1. Expand your HLS project name > Settings in the Vitis Components window (1).
1-1-2.  Click hls_config.cfg to open the configuration settings.
1-1-3.  Scroll down and click C/RTL Cosimulation (2).
1-1-4.  Scroll on the right side and locate cosim.trace_level.
1-1-5.  Click the down arrow to open the list of trace levels.
1-1-6.  Select all from the list of trace levels (3).
O VITIS COMPONENTS vitis-compjson <[5 “ 2 nisconfigerg
« o
: [HLS] B o &
~ Settings
o‘ All Settings
> Includes
~ Sources General ‘(:)D:t::—l‘w.ll::ﬂeclthe HDL simulator to be used to co-simulate the RTL with the C testbench
4 C Synthesis sources
> Test Bench Testbench sources = v
~ Output Blackbox sources
B config.cmdline ~ Simulation )
N esim C simulation Betermines the level of waveform tracing during C/RTL cosimulation.
hls_data.json - all v
> impl e C synthesis none default
-
Component N Compile = b
- pw.%{%w'w “p“-“l" iyt e NG el vt g ¢ g M Hmmt_ -—o"""”
Figure 217: Configuration Settings for C-RTL Cosimulation
The trace_level option specifies the level of trace file output written to the sim/Verilog or
sim/VHDL directory of the current solution when the simulation executes.
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Running C/RTL Cosimulation

1-1. Run C/RTL cosimulation for your HLS project name.
1-1-1.  Go to the Flow view (1).

The Flow view displays C Simulation, C Synthesis, C/RTL Cosimulation, Package, and
Implementation as the primary steps of the HLS component workflow.

1-1-2.  Select the active HLS component to simulate from the Component drop-down list (2).

Note: You can have multiple components in a system project. These components will
be displayed here.

Component v {5}
> CSIMULATION 2

> CSYNTHESIS

v C/RTL COSIMULATION

3 [> Run
» REPORTS

v PACKAGE
[> Run

~ IMPLEMENTATION

Figure 218: Running C/RTL Cosimulation

1-1-3.  Click Run under C/RTL Cosimulation (3).
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The Run C/RTL COSIMULATION Basic Settings pop-up window appears, displaying

configuration options for the cosimulation process.

Run C/RTL COSIMULATION Basic Settings

o

cosim.argv

cosim.compiled library_dir

cosim.disahle_deadlock_detection

cosim.enable_dataflow_profiling
cosim.enable_fifo_sizing
cosim.random_stall

cosim.rtl

verilog
cosim.setup

cosim.tool

xsim

| cosim.trace_level

none

cosim.wave_debug

Do not show this dialog again

n
()

Figure 219: Run C/RTL COSIMULATION Basic Settings

Browse

{ Cancel ) |

1-1-4. Keep the default settings and click Run.

This will initiate C/RTL cosimulation using the current configuration.

You can view the simulation log in the Output tab.
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Packaging RTL as IP

1-1.

1-1-1.

1-1-3.

1-1-4.

Package the RTL as an IP core.
Go to the Flow view (1).

The Flow view displays C Simulation, C Synthesis, C/RTL Cosimulation, Package, and
Implementation as the primary steps of the HLS component workflow.

Select the active HLS component to package from the Component drop-down list (2).

Note: You can have multiple components in a system project. These components will
be displayed here.

O ®
» CSIMULATION e
» CSYNTHESIS
v C/RTL COSIMULATION
v PACKAGE
(3)etur]
> REPORTS

v IMPLEMENTATION
[> Run

Click Run under Package (3).

The Run PACKAGE Basic Settings pop-up window appears, displaying configuration
options for packaging settings.

output file

output.format
ip_catalog ~
ip.description

ip.display_name

ip.library

| ipxde_file

ip.xde_ooc file

Do not show this dialog again

Figure 220: Run PACKAGE Basic Settings

Keep the default values and click Run.
This will initiate the packaging process using the current configuration.

You can view the log in the Output tab.

168

www.amd.com AMDA1
© Copyright 2026 Advanced Micro Devices, Inc. together we advance_



Lab Reference Guide

QEMU Operations

In This Section

Terminating QEMU in the Embedded Software FIOW .............ccoooiiiiiiiiiiiii e, 169

Terminating QEMU in the Embedded Software Flow

1-1. Terminate the program.

1-1-1.  Press <Ctrl + A> followed by <X> to terminate the current QEMU session.

PetaLinux Operations

In This Section

Creating a New PetaLinux Project (Using Any BSP with Project Name)................cocevieeees 169
Creating @ New ApPPlICAtION .........u e e e e eeees 170
Creating a New Application (ENable APP).......uuiii i 170
Creating a New Application (Enable App) Using Any BSP.........coiiiiiiiiiiiiieeieeeeeees 171
Selecting the New Application to be Included in the Build Process ..........c.ccooovvviiiiiiiiineens 172
Building the LiNUX IMage ........uniiiiii e e e e e e e eeann s 173
Booting the Linux Image on the Board (Running Netboot).............cooooiiiiiiiiii, 174
Running the Application in QEMU .............oiiiiiii e 175
Configuring Network SettiNgS ........uuuii e 175
Adding Ethernet OPlioNS ......ooeni e 179

Creating a New PetaLinux Project (Using Any BSP with Project Name)

1-1. Use the petalinux-create command to create a new embedded Linux
for the chosen platform.

1-1-1.  Change to the lab directory:
[host] $ cd STRAINING PATH/<the topic cluster name>/lab

This is done so that when the petalinux-create command is run, the project is
created at this location.
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1-1-2.

1-1-3.

Create a new PetaLinux project:

[host] $ petalinux-create -t project -s your BSP name -n your
project name

Note: After the command is executed, information about the created project will be
displayed.

Note: The PetaLinux project directory is in the following location and is where all work
for this project must be performed:

STRAINING PATH/<the topic cluster name>/lab/your project name

Change the directory to the Petalinux project:

[host] $ cd your project name

Creating a New Application

1-1. Create a new application.
The PetaLinux tools allow you to create user applications using
predefined C, C++, and autoconf templates. The autoconf template is used
for GNU autoconfig.
These templates include application source code and makefiles so that
you can easily configure and compile applications for the target and
install them into the root file system.

1-1-1.  Change the directory to the PetaLinux project:
[host] $ cd $TRAINING PATH/<the topic cluster name>/lab/your
project name

1-1-2.  Enter the following command to create a new user application inside the PetaLinux
project:
[host] $ petalinux-create -t apps --name your application
--template c
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Creating a New Application (Enable App)

1-1.

1-1-1.

1-1-2.

Create a new application and enable it in the root file system.

The PetaLinux tools allow you to create user applications using
predefined C, C++, and autoconf templates. The autoconf template is used
for GNU autoconfig.

These templates include application source code and makefiles so that
you can easily configure and compile applications for the target and
install them into the root file system.

Make sure that you are in the PetaLinux project directory as follows:

STRAINING PATH/<the topic cluster name>/lab/the name of the
Petalinux project

Enter the following command to create a new user application inside a PetaLinux
project:

[host] $ petalinux-create -t apps --name your application --
enable

The --enable option automatically enables it in the project's root file system. To
create a C++ application template, pass the ——template c++ option.

Creating a New Application (Enable App) Using Any BSP

1-1.

1-1-1.

Create a new application and enable it in the root file system.

The PetaLinux tools support multiple predefined templates, enabling you
to more easily create a project tailored to your needs. Here you will create
a user application from the default C template.

Other templates exist to facilitate other types of projects. For more details,
refer to UG1144: PetalLinux Tools Documentation: Reference Guide. All
templates include application source code and makefiles for easy
configuration and compilation.

Make sure that you are in the PetaLinux project directory as follows:

STRAINING PATH/<the topic cluster name>/lab/the name of the
Petalinux project
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1-1-2.

Enter the following command to create a new user application inside a PetaLinux
project:

[host] $ petalinux-create -t apps --name the desired source file
--enable

Note: After execution the following information will be printed.
INFO: Create apps: the desired source file

INFO: New apps successfully created in $STRAINING PATH/<the topic
cluster name>/lab/your project name/project-spec/meta-
user/recipes—-apps/your application project name

INFO: Enabling created component...

INFO: Sourcing build environment

INFO: Silentconfig rootfs

INFO: your application project name has been enabled

Note: The new application that you have created can be found in the <project-
root>/project-spec/meta-user/recipes-apps/your application
project name directory, where <project-root>is STRAINING PATH/<the
topic cluster name>/lab/your project name.

The —--enable option automatically enables the just created application in the project's
root file system. To create a C++ application template, pass --template c++ as
another parameter to the just entered command.

Selecting the New Application to be Included in the Build Process

1-1. Select the new application to be included in the build process. The
application is not enabled by defaulit.

1-1-1.  Ensure that your current working directory (project directory) is the following:
STRAINING PATH/<the topic cluster name>/lab/your project name

1-1-2.  Enter the following command to launch the rootfs configuration menu:
[host] $ petalinux-config -c rootfs
Note: Make sure that the terminal window is at least 80 columns wide. If your terminal
is not at least 80 columns wide, you will see "Error: Failed is config linux/rootfs! Your
display is too small to run menuconfig."
The Linux/rootfs configuration menu opens.
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1-1-3.

1-1-4.

1-1-5.

1-1-6.

Press the Down Arrow key (l) to scroll down the menu to user packages.

Configuration
Arrow keys navigate the menu. <Enter> selects submenus ---> (or empty
submenus ----). Highlighted letters are hotkeys. Pressing <Y>
includes, <N> excludes, <M> modularizes features. Press <Esc><Esc> to
exit, <?> for Help, </> for Search. Legend: [*] built-in [ ]

Filesystem Packages -
Petalinux Package Groups --->
Inage Features --->

user packages

PetaLinux RootFS Settings --->

< Exit > < Help > < save > < Load >

Figure 221: Linux/rootfs Configuration Menu

Press <Enter> to go into the user packages submenu.

The new application your application is listed in the menu.

Press the <Space Bar> to select the application your application.
Selecting the application will be included in the build process.

Select Exit and save the configuration.

Building the Linux Image

1-1. Build the Linux image.
This process is time consuming, typically taking 60 minutes or more
depending on your system configuration. If you have time, you can build
the image yourself with the process provided here, or you can skip this
instruction and proceed with the next step in the lab.
Extremely important! Before running the petalinux-build command,
make sure that you are connected to the internet.
1-1-1. Make sure that you are in the root of the PetalLinux project directory:
[host] $ pwd
If you are not at the proper location, you can navigate there by entering:
cd STRAINING PATH/<the topic cluster name>/lab/your project name
1-1-2.  Enter the following command to build the image:
[host] $ petalinux-build
Running petalinux-build in the project directory will build the system image,
including the selected user application your project name.
The full compilation log (build.log) is stored in the build subdirectory of the
PetaLinux project. The Linux software images and the device tree are generated in the
<plnx project root>/images/linux subdirectory of the PetaLinux project.
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Booting the Linux Image on the Board (Running Netboot)

1-1.

1-1-1.

1-1-2.

1-1-3.

1-1-5.

Boot the new Linux image on the board.

Press any key to stop auto-boot when you see messages similar to the following in the
GtkTerm window:

GtkTerm - /dev/ttyUSB1 115200-8-N-1

og Configuration Controlsignals Vi Help

Fi St

¢, interface rgmii-id

tiation to ¢

ev, -8-N-
dev/ttyUSB1 115200-8-N-1 DTR RTS

Figure 222: Stopping the Autoboot (ZedBoard)

If the system has booted, reset the board (BTN7) again and stop auto-boot.

Note: If you have finished setting the IP address and server IP address and saved
once, you can directly run the command run netboot.

Set the IP address for the target board so that it can communicate to the host and load
the new image:

Zyng> setenv ipaddr 192.168.1.10
Set the TFTP server IP to the host IP:

Zyng> setenv serverip 192.168.1.1
Save the environment to the SPI Flash:

Zynqg> saveenv

Download and boot the new image using TFTP:
Zyng> run netboot

This command will download the image.ub file from /tftpboot on the host to the
main memory of the ARM Cortex MPCore system and boot the system with the image.
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Running the Application in QEMU

1-1.  Run the application in QEMU.
1-1-1.  Enter the following command to boot the newly built PetalLinux image through QEMU:

# petalinux-boot --gemu —--kernel

1-1-2.  After the system boots, log into the system by entering root as the both the login
name and password.

Configuring Network Settings

1-1. Launch VirtualBox.

1-1-1.  Select Start Menu > All Programs > Oracle VM VirtualBox > Oracle VM VirtualBox
to start the VirtualBox Manager program.

1-1-2.  Select the name of the virtual machine virtual machine titled from the left pane (1).

1-1-3.  Double-click the virtual machine (1) or click the green right arrow icon to launch the
selected virtual machine (2).

@ Oracle VM VirtualBox Mal

File Machine Help

,,u; Details | @ Snapshots

= General = preview

Name: Ubuntu_ -
Operating System: Ubuntu (64-bit)

A| system

Base Memory: 4096 MB
Boot Order: Floppy, Optical, Hard Disk
Acceleration:  VT-%/AMD-V, Nested Paging, KVM Paravirtualization

Ubuntu_ & &a

“WJ"JMJWF"’J’I"Mu
Figure 223: VirtualBox Manager Window

The name of the virtual machine virtual machine will now launch in a new window.

1-1-4.  Click the Maximize (=l) icon in the window title bar to make it full screen if the virtual
machine window is not maximized.
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1-2. Disable the static IP settings.
1-2-1.  Press <Ctrl + Alt + T> to open a new terminal window.
1-2-2.  Enter the following command to open the interface file:
gedit /etc/network/interfaces
1-2-3. Comment all the lines in the interfaces file except the two lines as shown below:
#interfaces(5) file used by ifup(8) and ifdown (8)
auto lo
iface lo inet loopback
#auto eth0
#iface ethO inet static
#address 192.168.1.1
#netmask 255.255.255.0
#broadcast 192.168.1.255
#gateway 192.168.1.
1-2-4. Press <Ctrl + S> to save the changes.
1-2-5.  Click <X> in the upper-left corner of the gedit window to exit the editor.
1-2-6.  Enter the following command in the terminal to shut down the OS:

sudo poweroff

1-2-7. Enter xilinx as password when asked to enter a password.

1-3. Change the VirtualBox network settings.

1-3-1.  Select Network as shown in the figure below.

¥¥ Oracle VM VirtualBex Manager = | B i

File Machine Help

o J L
s
E'-;:} I{::} g - (& snapshots

Mew Settings Discard Start

- “SATAFPort0: MPSoC_Ubuntu.vdi (Normal, 75.00 GE) -
M B Audio

Host Driver:  Windows DirectSound
Controller:  ICH AC97

:
(¥ usB

USE Controller:  OHCI, EHCI
Devigr.Filters: 0 (0 activpl

Figure 224: Selecting the Network Tab
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1-3-2.  Select the Enable Network Adapter option to enable the network adapter.

r ™y
£53 MPSoC_Ubuntu - Settings [ [
E General Network
System Adepter 1 | Adapter 2 | Adapter 3 | Adapter 4
Display @ Enable MNetwork Adapter)
Storage Attached to: |Bridged Adapter =
. Mame: |Intel(R) Dual Band Wireless-AC 8260 -
I# Audio
B Advanced
@ MNetwork
@ Senial Ports
ﬁ USE
|j Shared Folders
E User Interface
[ OK, J ’ Cancel
" A

Figure 225: Enabling the Network Adapter

1-3-3.  Select the appropriate name option from the drop-down list.

This will vary from system to system. The figures shown here are for illustration
purposes only.

i ™
£7) MPSoC_Ubuntu - Settings [

JE‘I General Network
System Adapter 1 | Adapter 2 I Adapter 3 I Adapter 4
Display Enable Metwork Adapter
Storage Attached to
A Name: [Intel{R) Dual Band Wireless-AC 8250 =
udio

Intel{R) Ethernet Connection {2) 1219-1M
UL Lol 1rtI(R) Dual Biand \ireless-AC 5250
Metwork Microsoft Virtual WiFi Miniport Adapter
Microsoft Virtual WiFi Miniport Adapter #2

Serial Ports

USB

Shared Folders

User Interface

AP avyeERE

[ OK J [ Cancel

w o

Figure 226: Selecting the Appropriate Network Connection
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This example shows that Intel(R) Dual Band Wireless-AC 8260 (or the wired network
Intel(R) Ethernet Connection (2) 1219-LM) is selected because it is the name of our
network connection on the Windows machine running at the backend as shown below.

( = @ é
@le £’ » Control Panel » Network and Internet » Network Connections » - ‘#, ’ [ Search Network Connections pe) [
Organize v Connect To Disable this network device Diagnose this connection Rename this connection » . £ (2}
:. Wireless Network Connection ‘ ‘ No preview
> o xlnxxilinx.com available.

dﬂm Intel{R) Dual Band Wireless-AC 82...

&

Figure 227: Network Connection on Windows Machine

You will have to check the network connection of your Windows machine and then
select the appropriate name in the VirtualBox.

1-3-4.  Select the Advanced option in the Adapter tab in the VirtualBox to show the extra
configuration parameters.

1-3-5.  Edit the configuration as shown below.

£3 MPSoC_Ubuntu - Settings -2 [
E General Network
[ system Adapter 1 | Adapter 2 | Adapter3 | Adapter4 |
Display [¥] Enable Netwark Adapter
@ stoge —
. MName: lInteI[R} Dual Band Wireless-AC 8260 *]
Ip Audio
W Advanced
@ Network Adapter Type: Intel PRO/1000 MT Desktop (82540EM) -]
@ Senial Ports Promiscuous Mode: l.l'-\llow All *]
@ USE MAC Address: 08002725882 &)
Cable Connected
|j Shared Folders
Port Forwarding
E User Interface
OK, ] [ Cancel

"

Figure 228: Configuring Advanced Options

Note: The network connection name may be different in your environment.
1-3-6.  Click OK to bring the changes into effect.
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Adding Ethernet Options

1-1. Add the Ethernet information in the device tree.

1-1-1. Change to the device tree folder:

[host] $ cd <project-root>/project-spec/meta-user/recipes-
bsp/device-tree/files

Note: <project-root> here is the $<the topic cluster name>/lab/your
project name directory.

1-1-2. Open the system-user.dtsi file:
[host] $ gedit system-user.dtsi
1-1-3.  Add the following lines at the end of the file:

Note: You will find the completed system-user.dtsi inthe $<the topic
cluster name>/support directory.

&gem3 {
status = "okay";
local-mac—-address = [00 O0a 35 00 02 907];

phy-mode = "rgmii-id";

phy-handle = <&phy0>;

phy0: phy@c {
reg = <0xc>;
ti, rx-internal-delay = <0x8>;
ti,tx-internal-delay = <0xa>;
ti,fifo-depth = <0x1>;

i

i

&gspi |
status = "okay";
flash@0 {
compatible = "m25p80"; /* 32MB */
#address-cells = <1>;
fsize-cells = <1>;
reg = <0x0>;
spi-tx-bus-width = <1>;
spi-rx-bus-width <4>; /* FIXME also DUAL
configuration possible */
spi-max-frequency = <108000000>; /* Based on DCl spec

*/

partition@gspi-fsbl-uboot { /* for testing purpose */
label = "gspi-fsbl-uboot";
reg = <0x0 0x100000>;

by

partition@gspi-linux { /* for testing purpose */
label = "gspi-linux";
reg = <0x100000 0x40000>;

i

partition@gspi-device-tree { /* for testing purpose */
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label = "gspi-device-tree";
reg = <0x00140000 0x2000000>;

by

partition@gspi-rootfs { /* for testing purpose */
label = "gspi-rootfs";
reg = <0x02140000 0x80000>;

b

by
b7

1-1-4. Save and close the file.

Board, OS, COM, and IP Address Tasks
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Configuring the Terminal

The Terminal tab is used with a serial source (UART), SSH, or Telnet session.

The following instructions will show you how to configure this tab to work with a
serial UART.
1-1. Open the Terminal tab.
1-1-1. If the Terminal tab is not visible, select Windows > Show View > Other > Terminal >
Terminal to open it or create a new Terminal tab.
This will open a Terminal tab in one of the panels. The tab can be moved to any other
panel by click-dragging it to the new panel.
Note: More than one terminal can be enabled at a time.
1-1-2.  Select the Terminal tab to access the terminal icons (1).
1-1-3.  Click the Settings icon () (2).
_[;"'_ Problems | 45| Tasks | B Console | 2 Pw Terminal 1 23 =
5 iz BB &~ & -
Mo Connection Selected @ @@
Figure 229: Accessing the Terminal Settings
Alternatively, you can also click the Connect icon (N ) to open the Terminal Settings
dialog box. If the terminal was previously configured, this action will not open the
Terminal Settings dialog box, rather it will attempt to open the communication channel
with the previously selected settings.
Changing the settings requires that you close the channel and use the Settings icon.
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1-2.
1-2-1.
1-2-2.

1-2-3.

1-2-4.

Configure the settings as shown in the following figure.

Select the connection type as Serial.
Select the proper port for the COM #.

Your board must be on and connected; otherwise, the USB bridge is not enumerated,
and your COM port will not appear.

Set the baud rate to 115200.

~* Terminal Settings ﬁ

View Settings:
View Title: Terminal 1

Encoding: 150-8839-1

4

Connection Type:

@_erial

Settings:

Port: CoM v
Baud Rate: 115200 v

Data Bits:

Stop Bits:

Parity:

= | [feo
4 4

Flow Control:

Timeout (sec): 5

</

[ OK l [ Cancel

|

Figure 230: Configuring the Terminal Settings

Click OK.

The terminal session will be connected to the associated COM port on the PC.
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Setting Up the ZCU104 Board

1-1. Bring up the ZCU104 board.

The figure below of the ZCU104 evaluation board enumerates some of its
more popular features. Take a moment to familiarize yourself with the PCB
location of these features. Before the board can be used, there are cables
and switch settings that need to be in place and set (or just verified) to
ensure proper board operation.

The steps that follow will reference items at the numbered PCB locations.
Additional information can be found in the ZCU104 Evaluation Board User

Guide (UG1267).

ad R d
FIRMSSET SW6 - MPSoC
Boot Mode

User Buttons VN IA S Switches
and LEDs S XILINX. £ A 0

I Button SW20: [REH
|_PL CPU Reset B

: Mg N i S Button SW5: PL
s [ L ' \\ SIS S Configuration Clear
uSD Card . B User Switches § - 1 S
),

for MPSoC > ik
Device Boot -\ Button SW3:
System Reset S

Figure 231: ZCU104 Overview

1-1-1.  Ensure that the board is powered off by verifying that the power slide switch is in the
position furthest from the power connector (1).
The figure above shows the switch in the "ON" position.

1-1-2.  Ensure that the power connector is plugged in (2).

1-1-3.  Connect the micro-USB JTAG/UART cable between the board and the host (3).
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This USB cable from the host connects to a four-channel USB-to-UART bridge chip on
the board:

o Channel 1: JTAG serial device pins, recognized by the AMD JTAG driver.

o Channel 2: PS UARTO, recognized by host software as COM port COMx and is the
most frequently used port.

o Channel 3: PS UART1, recognized by host software as COM port COMx+1.
o Channel 4: PL device pins, recognized by host software as COM port COMx+2.
= TXD: Pin A20
= RXD: Pin C19
= RTS:Pin C18
= CTS:Pin A19

1-1-4. If the boot mode is an SD card, insert the microSD card containing the Zynq
UltraScale+ MPSoC device boot image (e.g., BOOT.bin) into the uSD card slot on the
top side of the board (4).

1-1-5. Locate SW6 on the board (5).

This switch configures the MPSoC device's boot mode, which should be set to SD
card.

1-1-6. Set SW6 as shown below to ensure that the board is configured to boot from SD card.

Note: Settings are also shown below to illustrate different boot mode settings. Make
sure you select SD card.

Boot Mode Mode Pins [3:0] Mode SW6 [4:1]
JTAG 0000/0%0 ON,ON,QON,ON
QSPI32 0o10/0x2l ON,ON,OFF,ON
s01 1110/0%E OFF,OFF, OFF,ON

Figure 232: ZCU104 Boot Mode Switch Settings Table

[ % s o | T
UltraSCALEw* & |2 UltraSCALEN* &

MODES 0 B MODE3 “™

1".OFF

Fr
’
R

(SD1 Card)

Figure 233: ZCU104 Boot Mode Switch Settings

1-1-7.  Slide the power switch to the "ON" position to power on the board.

You are now ready to configure the board.
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Setting Up the ZC702 Board

1-1.  Bring up the ZC702 board.
The figure below of the ZC702 evaluation board enumerates some of its
more popular features. Take a moment to familiarize yourself with the PCB
location of these features. Before the board can be used, there are cables
and switch and jumper settings that need to be in place and set (or just
verified) to ensure proper board operation.
The steps that follow will reference items at the numbered PCB locations.
Additional information can be found in the ZC702 Evaluation Board for the
Zynq 7000 XC7020 SoC User Guide (UG850).
SD Card for
Zynq 7000 B .
Device Boot
N UserLEDs XIUNX satery
2 : T ZYNu w ; .i :
22, 420 .l.!-‘;(tt‘l. £ ] """ﬁ‘ "-‘
Zynq 7000 Boot I e 3 .
Mode Jumpers 18119118
:—~ & 7) 1&* i e
;_'J ~: ‘ h
=
Micro-USB usB
@
Figure 234: ZC702 Overview
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1-1-1.

1-1-2.
1-1-3.

1-1-4.

1-1-5.

1-1-6.

1-1-7.

1-1-8.
1-1-9.

Ensure that the board is powered off by verifying that the power slide switch is in the
position furthest from the power connector (1).

The figure above shows the switch in the "ON" position.
Ensure that the power connector is plugged in (2).
Connect the micro-USB JTAG cable between the board and the host (3).

This connection implements JTAG communication to boot, download software object
code, and configure the PL of the Zynq 7000 SoC.

Connect the mini-USB UART cable between the board and the host (4).

This connection uses a USB to UART bridge chip to implement host COMXx port
communication to PS UART1 in the Zynq 7000 SoC.

If the boot mode is an SD card, insert the SD card containing the Zynq 7000 SoC
device boot image (e.g., BOOT.bin) into the SD card slot located on the top side of the
board (5).

Locate the two-position dip switch, SW10 (6).

SW10 selects the Zyng 7000 SoC device JTAG source, which, for this lab, will be the
onboard USB to JTAG daughter card that the micro USB cable is plugged into (other
connector sources exist).

Ensure that SW10.1 is OFF and SW10.2 is ON (6).

{ SW10- JTAG
% Source Connector

S
-

Figure 235: ZC702 SW10 JTAG Source Settings

Note: Earlier ZC702 boards with a letter REV designation use shunt jumpers to
configure the boot mode. Later versions with a number REV designation replace five of
the configuration shunts with a dip switch. Both REV configurations are shown below.

Locate and note the board REV, either letter or number (7).
Locate the board configuration jumpers (8).
If the REV is a letter, then the boot configuration uses jumper shunts.

These jumpers (REV <l/etter>) or switches (REV <number>) configure the Zynq 7000
SoC device's boot mode, which should be set to the desired boot mode.
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1-1-10. Set the shunt jumpers as shown below to ensure that the board is configured to boot
from the desired boot mode.

Note: Settings are also shown below to illustrate different boot mode settings. Make
sure you select the desired boot mode.

ZCT702 REV <letter> Jumpers J26 J25 J22 J20 J21
ZCT02 REV 1.<x> Switch SW16 SW16.5 | SWi6.4 | SW16.3 | SW16.2 |] SW16.1
ITAG modell) ] 0 Q 0 0
Independent JITAG mode 1 0 0 0 0
Quad SPI mode 0 0 0 1 0
SD mode 0 0 1 1 0

MIO configuration pin MIO2 y MIO4 MIOS MIOG
These two jumpers/switches
set the boot mode

Figure 236: ZC702 - Boot Mode Settings Table

Jumpers J27, J28, J21, J20, and J26 (shown in yellow) are in the same position for all
of the boot configurations.

Jumpers J27 and J28 are selected to enable SW1 and SW2 buttons to respectively
initiate PS power on and system reset operations. Jumpers J21, J20, and J26
determine the QSPI memory configuration.

Jumpers J22 and J25 (shown in red) select the configuration mode: JTAG (cable),
QSPI (on-board SPI memory) or SD card (using the PS SDO controller).

(16U
nq Res u(:-‘v J6

B, I

Zynq Rcscw’_:iié ___7‘1

=74 Z '7 g

Figure 237: ZC702 Boot Mode Jumper Settings
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If the ZC702 board REV is a number, then boot configuration uses a five-position dip
switch designated SW16.

Jumpers J27 and J28 (shown in yellow) are in the same position for all of the boot
configurations.

Jumpers J21, J20, J22, J25, and J26 are not populated as they are implemented via
SW16.

1-1-11. Set SW16 as shown below to ensure that the board is configured to boot from the
desired boot mode.

SW16.1, SW16.2, and SW16.5 (shown in green) replace jumpers J21, J20, and J26
and are set in the same position, '0', for all boot configuration modes.

SW16.3 and SW16.4 replace jumpers J22 and J25 and set the boot source mode.

1-1-12. Slide the power switch to the "ON" position to power on the board.
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Setting Up the VCK190 Board

1-1.

Bring up the VCK190 board.

The figure below of the VCK190 evaluation board enumerates some of its
more popular features. Take a moment to familiarize yourself with the PCB
location of these features. Before the board can be used, there are cables
and switch settings that need to be in place and set (or just verified) to
ensure proper board operation. The steps that follow will reference items
at the numbered PCB locations.

The VCK190 is more complex than most other boards as it incorporates a
platform system controller using a Zynq UltraScale+ MPSoC along with
Versal adaptive SoC technology. Additional information can be found in
the VCK190 Evaluation Board User Guide (UG1366).

Button SW12:
System Controller
Power on Reset

o SW11 - System -
#9 Controller Boot |ty
(R Mode Switches J8

uSD Card for

System Controller
MUST BE
PRESENT

(on solder side)

uSD Card E g Chain Routing
for Versal = Switches

=4

Figure 239: VCK190 Overview
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1-1-1.  Ensure that the board is powered off by verifying that the power slide switch is in the
position closest to the power connector (1).

The figure above shows the switch in the "ON" position.

1-1-2.  Ensure that the power connector is plugged in (2).

uSD Card for -
System Controller

MUST BE
PRESENT

(on solder side)

uSD Card for
Versal Device

()

—
mmus JTAG/UART
@ USB Type-C

Cable to Host ;

Figure 240: VCK190 uSD Cards and USB C Connector Locations

1-1-3.  If not already present, insert the programmed system controller microSD card into the
microSD card slot on the bottom side of the board (3).

Note: This is NOT the SD card that is used to boot the Versal device—instead, it boots
an UltraScale+ device that is used for overall board management.

1-1-4.  If the boot mode is an SD card, insert the microSD card containing the Versal device
boot image (e.g., BOOT.pdi) into the uSD card slot on the top side of the board (4).

1-1-5. Connect the USB-C JTAG/UART cable between the board and the host (5).

This USB cable from the host connects to a four-channel USB-to-UART bridge chip on
the board:

o Channel 1: JTAG serial device pins, recognized by the AMD JTAG driver.

o Channel 2: PS UARTO, recognized by host software as COM port COMx and is the
most frequently used port.

o Channel 3: Versal PL device pins, recognized by host software as COM port
COMx+1.

= TXD: Pin K33
= RXD: Pin L33

o Channel 4: System Controller PS UARTO, recognized by host software as COM
port COMx+2.

Caution: SW11 (located in the 11 o'clock position relative to the Versal device in the figure
below) controls the mode settings for the system controller. The switch settings MUST NOT
be changed from the SD card boot setting (1=ON; 2,3,4=0FF); otherwise, the system
controller will not boot, blocking the Versal device from booting.
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SW11 - System Controller
Boot Mode Switches

FsYsCTL IniT
SIREER SW3 - JTAG Chain
: Routing Switch

[ N3
ITAR MIIY s,"L

~

) '..‘,."“ us o —

Figure 241: VCK190 SW11 and SW3 Settings

1-1-6.  Verify that SW11 (which controls the boot mode for the system controller) is set as
shown (6).
1-1-7.  Verify that SW3 (which controls how the JTAG chain is routed) is set so that the switch
marked "1" is off, and the switch marked "2" is on, as shown (7).
1-1-8. Locate SW1 on the board.
This switch configures the Versal device's boot mode, which should be set to the
desired boot mode.
Set SW1 as shown below to ensure that the board is configured to boot from the
desired boot mode.
Note: Settings are also shown below to illustrate different boot mode settings. Make
sure you select the desired boot mode.
Boot Mode Mode Pins [3:0] Mode SW1 [4:1]
JTAG 0000/ 0x0 ON,ON,ON,ON
QSPI32 0010/ 0x2 ON,ON,OFF,ON
SD1 1110 / OXE OFF,OFF,OFF,ON
SD1 Card
Figure 242: Boot Mode Switch Settings
1-1-9. Slide the power switch to the "ON" position to power on the board.
You are now ready to configure the board.
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Setting Up the VEK280 Board

1-1. Bring up the VEK280 board.

The figure below of the VEK280 evaluation board enumerates some of its
more popular features. Take a moment to familiarize yourself with the PCB
location of these features. Before the board can be used, there are cables
and switch settings that need to be in place and set (or just verified) to
ensure proper board operation. The steps that follow will reference items
at the numbered PCB locations.

The VEK280 is more complex than most other boards as it incorporates a
platform system controller using a Zynq UltraScale+ MPSoC along with
Versal adaptive SoC technology. Additional information can be found in
the VEK280 Evaluation Board User Guide (UG1612).

T T T TR T OTTR T T T

@ »—c
8

Figure 243: VEK280 Overview

1-1-1.  Ensure that the board is powered off by verifying that the power slide switch is in the
position closest to the power connector (1).
The figure above shows the switch in the "ON" position.

1-1-2.  Ensure that the power connector is plugged in (2).

1-1-3.  If the boot mode is an SD card, insert the microSD card containing the Versal device
boot image (e.g., BOOT.pdi) into the uSD card slot on the top side of the board (3).

1-1-4. Connect the USB-C JTAG/UART cable between the board and the host (4).
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This USB cable from the host connects to a four-channel USB-to-UART bridge chip on
the board:

o Channel 1: JTAG serial device pins, recognized by the AMD JTAG driver.

o Channel 2: PS UARTO, recognized by host software as COM port COMx and is the
most frequently used port.

o Channel 3: Versal PL device pins, recognized by host software as COM port
COMx+1.

= TXD: Pin K33
= RXD: Pin L33

o Channel 4: System Controller PS UARTO, recognized by host software as COM
port COMx+2.

1-1-5. [Optional] Connect one end of the HDMI cable to the board’s HDMI TX connector and
the other end to the HDMI monitor (5).
1-1-6. Locate SW1 on the board (6).
This switch configures the Versal device's boot mode, which should be set to SD card.
1-1-7. Set SW1 as shown below to ensure that the board is configured to boot from SD card.
Note: Settings are also shown below to illustrate different boot mode settings. Make
sure you select SD card.
Boot Mode Mode Pins [3:0] Mode SW1 [4:1]
JTAG 0000/ 0x0 ON,ON,ON,ON
QSPI32 0010/ 0x2 ON,ON,OFF,ON
SD1 1110 / OXE OFF,OFF,OFF,ON
SD1 Card
Figure 244: Boot Mode Switch Settings
1-1-8.  Slide the power switch to the "ON" position to power on the board.
You are now ready to configure the board.
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Setting Up the ZedBoard

1-1.

1-1-1.

1-1-2.

Bring up the ZedBoard.

The figure below of the ZedBoard enumerates some of its more popular
features. Take a moment to familiarize yourself with the PCB location of
these features. Before the board can be used, there are cables and switch
and jumper settings that need to be in place and set (or just verified) to
ensure proper board operation.

The steps that follow will reference items at the numbered PCB locations.
Additional information can be found in the ZedBoard HW User Guide
available from the Digilent website (the board manufacturer).

JP9, JP10 38 3
=8 Zynq 7000 Boot s
=8l Mode Jumpers ‘

(=

T |

SD Card for

@
Ay AVNE RALER(

- Device Boot
ZedBoard User Buttons (solder side)
wuy. zédboard. org \

| User Switches
i "

7 =)
on| i -
| |

Configuration Clear

Button BTN7:
PS CPU Reset

Figure 245: ZedBoard Overview

Ensure that the board is powered off by verifying that the power slide switch is in the
position furthest from the board edge (1).

The figure above shows the switch in the "ON" position.

Ensure that the power connector is plugged in (2).
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1-1-3.  Connect the micro-USB JTAG cable between the board and the host (3).
This connection implements JTAG communication to boot, download software object
code, and configure the PL of the Zynq 7000 SoC.
1-1-4. Connect the micro-USB UART cable between the board and the host (4).
This connection uses a USB-to-UART bridge chip to implement host COMx port
communication to PS UART1 in the Zyng 7000 SoC.
1-1-5.  If the boot mode is an SD card, insert the SD card containing the Zynq 7000 SoC
device boot image (e.g., BOOT.bin) into the SD card slot located on the bottom (solder)
side of the board (5).
1-1-6. Locate the board configuration jumpers (6).
These jumpers configure the Zyng 7000 SoC device's boot mode, which should be set
to the desired boot mode.
1-1-7.  Set the shunt jumpers as shown below to ensure that the board is configured to boot
from the desired boot mode.
Note: Settings are also shown below to illustrate different boot mode settings. Make
sure you select the desired boot mode.
Jumpers JP11, JP8, and JP7 (shown in yellow) are in the same position for all of the
boot configurations. Jumper JP11 enables the PS internal PLL. Jumpers JP8 and JP7
determine the QSPI memory configuration.
Jumpers JP10 and JP9 (shown in red) select the configuration mode: JTAG (cable),
QSPI (on-board SPI memory), or SD card (using the PS SDO controller).
Lgﬁﬁxgémﬁf ZedBoard Configuration Mode Jumpers
MIO[6] MIO[5] MIO[4] MIO3([] MIO[2]
AMD TRM | Boot_Mode[4] [iBoot_Mode[0] | Boot_Mode[2] | Boot_Mode[1] | Boot_Mode[3]
Jumper JP11 JP10 JP8 JP7
JTAG 0 0 0
Quad SPI 0 0 0
SD Card 0 0 0
Figure 247: ZedBoard Boot Mode Jumper Settings
1-1-8.  Slide the power switch to the "ON" position to power on the board.
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Determining the COM Port Assigned by the USB Driver

A serial UART terminal emulator program provides a simple and straightforward
way to collect and transmit serial information using the RS-232 protocols. Most
modern PCs lack the traditional DB-9 connectors for RS-232 communication and
instead use USB ports.

From the PC's perspective there is still a COMx port being used; however, the
actual COM port number is not known until USB enumeration. The PC is capable
of supporting multiple COM ports, so it is important to know which connection is
the one to use when communicating with the development board.

When using a PC COM port with communications software (terminal emulator)
on the PC such as the Vitis Serial Terminal tab, Tera Term, or other software, it
is necessary to identify the COM port number associated with serial connection
to the evaluation board. This is done by identifying the USB COM port driver and
which COM port is being assigned.

The MPSoC boards support three USB ports. Two are connected to the UARTs
in the PS and one is available to the PL, assuming that there is a UART
implemented in the PL.

1-1. Determine which COM port is connected to the USB serial port from the
board.

1-1-1. Make sure that the development board is powered on and the serial UART device USB
cable is in place.

This ensures that the USB-to-serial bridge will be enumerated by the PC host.

The Device Manager in Windows lists all of the hardware items in the system. While
there are a number of routes to opening the device manager, the easiest is as follows.

1-1-2.  Click Start (1).

1-1-3.  Enter the following into the search bar (2):

device manager

= e
4

>

All Programs

Figure 248: Accessing the Windows Application Search

Note: You may be asked to confirm opening the Device Manager. If so, click Yes.
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1-1-4. Expand Ports (COM & LPT) so that you can see all of the enumerated ports.
Various boards use different USB bridge chips. The name of the driver varies
correspondingly.

o 2ZCU102/4 users: Locate Silicon Labs Quad CP210x USB to UART Bridge:

Interface 0 (COM#).

» Note that there will be a group of (at least) four COM ports listed. This is
because this board has a quad USB to UART bridge. Interface 0 and 1 are
attached to stdout 0 and 1, respectively. Also note the COM port number
assigned to Silicon Labs Quad CP210x USB to UART Bridge: Interface 0
(COM#)"as this is the COM port number you will need when establishing
communications with the board, specifically the output from the PMU.

Note: The # indicates the port number for this serial connection.
Example:
.'-"-T Device Manager EE
File Action View Help
&= | mHE =
] ‘.'E LN it L
b % Batteries
b ﬂa Bluetooth Radios
b M Computer
o rW‘ *
“F
» - |7y wther devices
b -E1] PCMCIA adapters
o BB Portable Devices
? Ports (COM & LPT)
‘? Communications Port (COMI)
4 ? Silicon Labs CP210x USE to UART Bridge (COM]
.> D SUTS
} j Smart card readers
5 l"@”"da’"‘” and E.arntrnllﬁﬁ — o -
Figure 249: Locating the Silicon Labs Com Port Driver

1-1-5. Note the COM# corresponding to the USB bridge chip.

This is the port number you will use when connecting a terminal to the board.

1-1-6. Close the Device Manager by clicking the red X" in the upper-right corner of the panel.
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Linux Operations

Opening a Terminal — Linux Ubuntu

Sometimes it is easier to enter operating system commands via a Linux terminal
rather than a GUI. A terminal can completely configure and control a Linux
system without the need for a graphical desktop.

Even when there is a graphical desktop available for use, it may sometimes be
necessary or more convenient to use the terminal window to launch programs
and configure settings.

1-1. Open a Linux terminal window.

1-1-1.  Click the Linux terminal window icon in the taskbar.

Figure 250: Opening the Linux Terminal Window from the Taskbar

Alternatively, you can press <Ctrl + Alt + T>.

The terminal window will open, leaving you in your home directory.
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Shutting Down Ubuntu Linux

1-1.
1-1-1.
1-1-2.

1-1-3.

[Windows users]: Shut down Ubuntu Linux.

Click the System Settings icon in the upper-right corner of the Ubuntu desktop (1).
Select Shut Down (2).

The Shut Down dialog box opens.

Click Shut Down (3).

f B = <) 1nasam {3
About This Computer
Ubuntu Help
System Settings...
Lock
2 Guest sessior
* 2 petalinur

Log Out .

Susperd e
n

Figure 251: Shutting Down

Running a Virtual Machine Using VirtualBox

For CloudShare users, you can skip the launching VirtualBox instructions below
and proceed with the launching the Vivado Design Suite instructions.

1-1. Launch the VirtualBox Manager application.
Running Linux under Windows is easily achieved using a virtual machine
that forms an isolated container for another OS. The Oracle VirtualBox
application was selected as the framework for hosting virtual machines as
it works well and is available without the hassles of licensing. The
Customer Training team provides a VM that is properly configured to run
the labs and demos.

1-1-1.  Select Start Menu > Oracle VM VirtualBox > Oracle VM VirtualBox to launch the
VirtualBox Manager program.
Alternatively, if a desktop or taskbar icon is available, you can simply click it.
When the VirtualBox Manager opens, the left-hand pane will show all of the available
virtual machines.
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1-1-2.  Double-click the virtual machine (1).

Alternatively, you can single-click the virtual machine of choice, then click the green
right arrow icon to launch the selected virtual machine (2).

% Oracle VM VirtualBox Mai b@ﬁ

File Machine Help

o
3 ~
L IR EE &8 Srapshots

New Settings Discard
~

= General = Preview

Name: Ubuntu
Operating System: Ubuntu (64-bit)

] system Ubuntu_ S 4ss & s

Base Memory: 4096 MB et
Boot Order: Floppy, Optical, Hard Disk
Acceleration:  VT-x/AMD-V, Nested Paging, KVM Paravirtualization

Figure 252: VirtualBox Manager Window

The virtual machine will now launch in a new window. It takes a few moments to boot. If
any warning messages appears, such as anything regarding the mouse or keyboard,
click the "x" on the line with the error and continue.

1-1-3.  Click the Maximize ([=l) icon in the window title bar to expand the screen to its full size,
if not already maximized.

Cleaning Up the VirtualBox File System

Some systems (particularly VMs) may be memory constrained. Removing the
workspace frees a portion of the disk space, allowing other labs to be performed.

You can delete the directory containing the lab you just ran by using the
graphical interface or the command-line interface. You can choose either
mechanism. Both processes will recursively delete all the files in the
STRAINING PATH/<the topic cluster name> directory.

1-1. [Optional] [Only for local VMs—not for CloudShare] Clean up the file
system.

Using the GUI:
1-1-1.  Navigate to STRAINING PATH/<the topic cluster name>.
1-1-2. Select <the topic cluster name>.
1-1-3.  Press <Delete>.
—-OR --
[Linux users]: Using the command line:
1-1-4. Press <Ctrl + Alt + T> to open a terminal window.

1-1-5.  Enter the following command to delete the contents of the workspace:
[host] $ rm -rf $TRAINING PATH/<the topic cluster name>
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Setting the Static Host IP Address Using Windows 10

These instructions illustrate how to change to or set up a static IP address on the
host computer. Follow the reverse of these instructions to change back to a
DHCP-received address.

For labs that require an Ethernet connection between the host computer, the
hardwired Ethernet settings on your host machine must be set up properly to
work with the hardware evaluation board.

Typically, the PC's Ethernet port is set to automatically request an IP address
from the network DHCP client server. Because the hardwire Ethernet connection
will attach directly to the hardware evaluation board, there will not be a DHCP
server to supply the needed IP address for the host computer.

It is therefore necessary to reconfigure the TCP/IP client (host computer) with its
own static IP address. After you are finished with this lab, you can revert this step
and set TCP/IP properties to obtain an IP address automatically.

Most of our software applications use an IP address of 192.168.1.11. The host
computer is required to have an IP address of 192.168.1.num, where num is any
number between 2 and 255 except 11 (which is reserved for the hardware).

These instructions describe how to perform this task on a Windows 10 machine.

1-1. Set the static host IP address.

1-1-1.  If wireless is on, it is suggested that you turn if off with the switch on your computer or
disable in settings.

How to perform this will vary with different PC wireless hardware.

While this step should not be necessary, there has been reports that the wired Ethernet
port does not work with static address (192.168.1.num) using the same base subnet
address of the wireless adapter.

1-1-2.  Right-click the networking icon on the bottom-right corner of the taskbar (1).
1-1-3.  Select Open Network and Sharing Center (2).

Troubleshoot problems

Open Network and Sharing Center

14:48
L]

06-Aug-19

Figure 253: Selecting Open Network and Sharing Center
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1-1-4.  From the Network and Sharing Center left pane, select Change Adapter Settings.
== g

- v :‘,: ¥ Control Panel » ontrol Panel lkerns » Network an aring Center - |+ wearch Control Panel
IR [of | Panel » All C | Panel I N k and Sh o + Search Ci i Panel p|
File Edit ‘“iew Tools Help
Contrel Panel Home . . . . . ®
View your basic network information and set up connections
Manage wireless networks Ay = See full map
E»E b 0
XSJLANCER30 linksys_SES_G6467 Internet
(This computer)
settings View your active networks Connect or disconnect
linksys. SES_6467 Access type: Internet
Public network Connections: Wireless Network Connection
(linksys_SES_6467)
Change your networking settings

il Set up 2 new connection or network

=" Setup awireless, broadband, dial-up, ad hac, or VPN connection; or set up a router or access point,

ﬁ‘ Cennect to a network

Connect or reconnect to a wireless, wired, dial-up, or VPN network connection.
@, Choosehomegroup and sharing cptions
Access files and printers lacated on other network computers, or change sharing settings.

Seealso
e [S Troubleshoot problems
A Diagnose and repair netwark problems, or get troubleshaoting information.
Windows Firewall

Figure 254: Control Panel Networt and Sharing Center

1-1-5.  Select the Ethernet adapter to be used.
1-1-6.  Right-click and select Properties.

@O:J@ > el P > Wit e 5 M Careedems 5 v [ 3 || Search tetwonk Connections )
File Edit Wiew Tools Advanced Help .’l."L'.-L'_'!_. S
Organize v Disable this network device Diagnose this connection Renamgh\s connection Ch settings of this connection i~ 0 @
L"' Bluetaath Metwork Connection L"’ Local Area Connection L"' Local Area Canm.’(ion 2 - '-
| = R« - .
I = Mot connected . *  Metwork cable unplugged o Enabled “ =" Disconnected
K g Bluetooth Dewice (Personal Area ... W3R T Iel(® T TLM Gogyabit MgBunoeh - Yoote [§5 WAN Miniport (PPTR)
) S— ! Disable
L-" Wireless Metwork Connection Miiireless Network Connection
| = ‘ | Status
il — 0 £ > o Mot connected
il e . st b X Ml icrosoft virusl wiki Miniport &, Diagnose i
Bridge Connections I.
.
Create Shortcut .’
Delete ’o
Sl' Rename k,.
I@' Properties ’

Figure 255: Network Connections

1-1-7.  Click Yes to make changes (if necessary).
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1-1-8. Deselect Internet Protocol Version 6 (TCP/IPv6) (1).
1-1-9. Select Internet Protocol Version 4 (TCP/IPv4) (2).
1-1-10. Click Properties (2).

U Local Area Connection Properties @

Nehwarking | Sharing

Connect using.

KF bl B5TTLM Gagalih Netwosk Connection

This connection uses the fallowing items:

& Client for Microsoft Networks
8 Deterministic Metwork Enhancer

AN B 0165 Facket Scheduler
E File and Printer Sharing for Microzoft Network s 2 )
D) @ A,
=
qlnte: o C 1
=& Ll Mapper | /0 Driver

wd Link-Layer Topology Discovery Responder

- Yy
Inistall... Uriirztall lj

Description

Transmigsion Control Protocal/nternet Protocal. The default
wide area network. protocal that provides communication
across diverse interconnected networks.

Figure 256: Local Area Connection Properties

1-1-11. Select Use the following IP address (1).
1-1-12. Enter 192.168.1.10 in the IP address field (2).

This value is fairly arbitrary, but it cannot be the same as the IP address designated for

the board.

The Subnet mask field should fill in with 255.255.255.0 automatically after leaving the

IP address field (3).

' et TP P o)
Internet Protocol Version 4 (TCP/IPv4) Properties

General

‘You can get IP settings assigned automatically if your network supports
this capability. Otherwise, you need to ask your network administrator
for the appropriate IP settings.

() Obtain an IP address au
@ Use the following IP addres! 2

1P address: 192 . 163 . 1 . 10
Subnet mask: 255,255,255 . O
Default gateway: . . . e

Obtain DNS server address automatically

@ 1se the following DNS server addresses::
Preferred DNS server:

Alternate DNS server:

[ validate settings upon exit

Figure 257: Set TCP-IPv4 Properties for Static Address

1-1-13. Click OK.

1-1-14. Click Close to close the Control Panel.
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1-2. To return to a DHCP-obtained address, follow the same steps to revert the
settings.

1-2-1.  Select the Internet Protocol Version 6 (TCP/IPv6) option.
1-2-2. Select Internet Protocol Version 4 (TCP/IPv4)
1-2-3.  Click Properties.

1-2-4. Select Obtain an IP address automatically.

Internet Protocel Version 4 (TCP/IPvd) Properties l % —r S

General | Alkernate Configuration |

¥ou can get IP settings assigned autamatically if wour network supparks
this capability, Ctherwise, vou need to ask your network, administrator
for the appropriate IP settings.

' @ Obtain an IP address aubomatically ,

~ Use the Fallowing IF address:

) Obtain DS server address automnatically
@ Use the Following DS server addresses:

Preferred DS server:

Alternate DMS server:

["]validate settings upon exik advanced. .

[ Ok H Cancel J

Figure 258: Set TCP-IPv4 Properties for DHCP Obtained Address

1-2-5. Click OK.
1-2-6. Click Close.
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Setting the Static Host IP Address Using Linux

These instructions illustrate how to change to or set up a static IP address on the
host computer. Follow the reverse of these instructions to change back to a
DHCP-received address.

For labs that require an Ethernet connection between the laptop host computer,
the hardwired Ethernet settings on your host machine must be set up properly to
work with the hardware evaluation board. Typically, the PC's Ethernet port is set
to automatically request an IP address from the network DHCP client server.
Because the hardwire Ethernet connection will attach directly to the hardware
evaluation board, there will not be a DHCP server to supply the needed IP
address for the host computer. It is therefore necessary to reconfigure the
TCP/IP client (laptop) with its own static IP address. After you are finished with
this lab, you can revert this step and set TCP/IP properties to obtain an IP
address automatically.

Most AMD software applications use an IP address of 192.168.1.11. The host
computer is required to have an IP address of 192.168.1.num, where num is any
number between 2 and 255 except 11 (which is reserved for the AMD hardware).

These instructions describe how to perform this task on a Linux machine.

1-1.  Set the static host IP address.

1-1-1.  Press <Ctrl + Alt + T> to open a new terminal.

1-1-2.  Enter the following command to set the static IP:
[host] $ ifconfig ethO 192.168.1.10

This value is fairly arbitrary, but it cannot be the same as the |P address designated for
the board.

1-1-3.  Exit the terminal:
[host] $ exit

1-2. To return to a DHCP-obtained address, follow the same steps to revert the
settings.

1-2-1. Reboot the Linux machine or VM to revert the static IP settings that you set in the
previous step.
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Verifying Board Jumper/Switch Settings Configured to Boot from the
SD Card

The board evaluation hardware platform has jumpers (or switches) to select the
boot mode for the processor.

1-1.

1-1-1.
1-1-2.

1-1-3.
1-1-4.

Verify that the board hardware platform is properly connected and the
jumpers (or switches) are configured to boot from the SD card.

Confirm that the power to the evaluation board is OFF.

Ensure that the connections between the host PC and the hardware evaluation board
are correct (ask for assistance from the instructor if necessary).

The connections include power, serial bridge USB, Ethernet, and USB Platform
download cables.

Make sure that the SD card with a Linux image is inserted into the board card slot.
Verify the jumper settings on the board are set up to boot from the SD card.

Refer to the "Jumper/Switch Settings board - Boot from SD Card " topic under the
Hardware Requirements - <Name of Board> Hardware Setup section in the Lab
Reference Guide or ask your instructor for assistance.

Powering Up the Hardware Platform

1-1. Apply power to (turn on) the board hardware platform.
1-1-1.  Make sure that AC power is connected to the power brick.
1-1-2.  Ensure that the power brick is connected to the board.
1-1-3.  Confirm the serial port USB connection between the board and the PC.
1-1-4.  Confirm the USB-JTAG connection between the board and the PC.
1-1-5.  Slide the power switch to the on position.
Some LEDs on the board will iluminate when the board is powered.
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Preparing an SD Card

Prepare an SD card.

Insert an SD card into the PC's SD card slot.

2. [Linux users]: Make sure that you copy the SD card files from Linux to the C:\training
directory by entering the following command:
[host] $ cp -rf <path to_sd card files> /media/sf training

3. Browse to the SD card drive using Windows Explorer.
Optional: You may want to erase or reformat the SD card at this time, which may prevent
any unwanted interaction with other files that may be on the card.

4. Open a second Windows Explorer window to browse to the location of the files you want to
copy to the SD card, which will be copied to the SD card.
Be aware that many SD card images are delivered as compressed files. You will need to
ensure that these files are properly decompressed unless otherwise indicated.

5. Drag-and-drop all the files from the source directory to the SD card directory.
This will automatically copy the files onto the SD card.
Note: The files should go into the root of the SD card unless there are specific instructions to
the contrary.

6. Close both Windows Explorer windows.

7. Remove the SD card from the PC card slot.

8. Turn off power to the hardware platform.
Note: The boot selection switches or jumpers must be properly set to boot from the SD card.
See the appropriate section in the Lab Setup Guide.

9. Insert the SD card into its slot on the hardware platform.
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Booting Linux

You must have an SD card with a properly constructed Linux boot image. This
can be open-source Linux, Petalinux, or a third-party image.

1-1. Set the jumpers/switches on your board to boot from the SD card.

If you do not recall how to perform this task, refer to the "Setting the Jumpers on
the <Name of Board> Board" section under Board, OS, COM, and IP Address
Tasks in the Lab Reference Guide.

1-2. Insert an SD card with a properly constructed Linux boot image.

1-3.  Apply power to the board.
1-3-1.  Open a terminal window if you want to observe the Linux boot process.

This process typically takes several minutes to complete. The reason for applying
power prior to setting up a terminal window is that the PC must first "see" the UART
(via USB). This can only happen when the board is powered up. If you want to see all
of the Linux boot-up messages, you will need to recycle power on the board.

Launching and Configuring the Terminal Emulator

Maintaining consistency in the instructions is an important aspect of the lab experience. The
labs will use general and vague commands such as "Open the terminal emulator". Depending
on the system that you are using, you must know which terminal emulator to configure and
launch. Here are the instructions for opening a terminal emulator for both the Linux and
Windows environments.

Generally, the software labs will use the serial terminal built into the Vitis platform; however,
there are some labs that will require you to communicate with the board without using the Vitis
environment. These situations require the use of a third-party serial port emulator.

We have tested Tera Term for the Windows environment and GTKTerm for Linux. The
GTKTerm tool is pre-installed with the Customer Training VM. Both terminal emulators listed
here run independently of the tools. If you have another terminal emulator that you prefer, you
can certainly use it; however, you are responsible for figuring out how to configure it.
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Linux

GTKTerm is a simple GTK+ terminal used to communicate with the serial port. Other terminal
emulators may be used; however, the installation and configuration instruction provided here
are for GTKTerm.

GTKTerm is already installed in the VM provided by the Customer Training team; however
native Linux users may need to install GTKTerm.

[Native Linux users] Acquire and install the GTKTerm software from the command line.

I. Press <Ctrl + Alt + T> to open a new terminal.
2. Download and install GTKTerm:
[host] $ sudo apt install gtkterm

3. When prompted for the password, enter the super user password.
The tools will install in about a minute or less.

GTK Term is an interface that only supports serial port/UART communications.
The more general Terminal tab supports other formats, such as SSH and Telnet.

Since serial port communications occur over the USB, which is an enumerated
interface, the board must be powered on with the cable connected for the port to
be recognized.

If you are using the VM, ensure that the proper USB port is allowed to cross the
host/VM threshold by selecting Devices > USB > Xilinx <board selection>

[0800] in the VirtualBox Manager for Zynq UltraScale+ MPSoC/Versal adaptive
SoC boards or selecting Devices > USB > Digilent Adept USB Device [0700].

1-1. Launch GTKTerm and set the port configuration.

1-1-1.  Click the GTKTerm icon (E=3) from the quick launch toolbar.

Alternatively, GTKTerm can be launched from a Linux terminal window (<Ctrl + Alt +
T>) and entering:

[host] $ sudo gtkterm

Note: While the application will run as a regular user, you must be a super user to
access the ports.

When the GTKTerm window opens, perform the following.
1-1-2.  Select Configuration > Port to open the Configuration dialog box.

1-1-3.  Identify the port associated with your board and set the port as /dev/ttyUSBx (where x
could be 0, 1, 2, 3, etc.)

1-1-4. Set the baud rate to 115200.

1-1-5. Leave the rest of the settings at their default.
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Note: You can open multiple instances of /dev/USBx if you are unable to determine
which port your UART is connected to.

@S E GtkTerm - /devy|
training@xilinxs sudo | File Edit Log Configuration Controlsignals
[sudo] password for—eilinms
Control signals read: put/output error

Port

Main window
Local echo
CRLF auto
Macros

Serial port
Port: Baud Rate: Parity:

Load configuration
Save configuration
Bits: Stopbits: Flow control: Delete configuration

I Per instructions I v I Per instructions Iv none

8 = | > | |none

» Advanced Configuration Options

Cancel

Jdev/ DTR RTS CTS CD DSR
Figure 259: Opening GtkTerm and Selecting the Port Configuration
[Optional]: You can save these settings so that you do not have to reconfigure
GKTTerm each time you open it by selecting Configuration > Save configuration.

If you save the configuration as "default", this configuration will open when GTKTerm
starts. Otherwise, you can save the configuration with another name; however, you will
then need to load the configuration each time you start GTKTerm.

1-1-6.  Click OK to save the settings and leave the terminal open.

1-2. Enable auto CR/LF mode.

GTKTerm is a terminal emulator that supports automatic translation of CR
(carriage return) characters to LF (line feed) characters and vice versa.

1-2-1.  Select Configuration > CR LF auto to enable auto CR/LF mode.

GTKTerm - /dev/ttyUSB1 115200-8-N-1

File Edit M Configuration | Controlsignals View Help

Port

Main window

Local echo

v CRLFauto

Timestamp

Macros
Load configuration

Save configuration

Delete configuration

Figure 260: Enabling CR/LF Auto in GTKTerm

Note: This step is optional, but it will ensure that the serial messages appear aligned
on the terminal.
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Windows

Tera Term is a popular public domain terminal emulation program. It is capable of operating as
a serial port terminal or as a telnet client.

Download and install Tera Term.

I. Acquire and install the Tera Term software from any legitimate site. Recommended sites:
ttssh2.o0sdn.jp/index.html.en (Tera Term home page with documentation)
osdn.net/projects/ttssh2

e en.sourceforge.jp/projects/ttssh2

¢ logmett.com
2. Install per instructions.

There are two types of downloads: a traditional zip install, and a self-installing version, which
is recommended.

[Optional] Certain drivers like installing their com port numbers using high numbered serial
ports. Tera Term does not accept these port numbers by default, so you will need to override
the Tera Term settings:

Open TERATERM.INI (found in the install path for Tera Term) with an ASCII text editor.

l.
2. Setto MaxComPort=256.
3. Save and close the INI file.
4. Use the Setup > Save Setup option to save the setup.
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Launch the Tera Term terminal program.
|. Double-click the Tera Term icon on the Windows desktop to launch Tera Term.
Alternatively, you can select Start > All Programs > Tera Term > Tera Term.
. Select Serial as the connection (1).
3. Click the Port drop-down list to view the available COM ports (2).
Note: If your port is not listed, exit Tera Term, power cycle your board and restart this step.

4. Select the COM # (3).

Hint: MPSoC and RFSoC devices display three COM ports. Their specific numbers may
vary based on the USB enumeration process; however, the first two COM ports connect to
the UARTSs in the PS and the third connects to PL pins.

&
 File Action View Help 3
e @ HEIE

I Network adapters
E Portable Devices

v i/ Ii.orts(COM&LPT PR " ~ ARTO
 Standard Serial over Bluetooth link (COME) gl =~ - ’
ﬁ Standard Serial over Bluetooth |j
5 USB Serial Port (COM | e (ONNECHS W 3 AR

& USE Serial Port (COM | =" }

E USB Serial Port (COM |
= Print queues Connects with P
== Printers

Figure 261: Locating and Identifying COM Ports from the Windows Device Manager

wi| | Tera Term: New connection

OTCPIP myhost.example.com A
History
22
Telnet
SSH SSH2
Other
AUTO

Figure 262: Selecting the COM Port

Note: The COM port setting is specific to the computer being used and may need to be
different than shown. Use the COM port # that was discovered in the previous step.

5. Click OK (4).
The terminal console window opens.
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6. Select Setup > Serial Port.

. COM4 - Tera Term VT
Setup |Control Window Help

Terminal..
Window...
Font »
Keyboard...

Proww

Figure 263: Opening the Tera Term Serial Port Setup Window

The Tera Term Serial Port Setup dialog box opens.
7. Confirm that the proper serial port has been selected (1).
8. Set the baud rate to 115200 (2).

Tera Term: Serial port setup and connection x

: coM4 C 3
Port New setting q
Speed; ' : ”1 15200 v

Data: 8 bit v

Cancel
Parity: none v
Stop bits: 1 bit v Help
Flow control: none v

Transmit delay

0 msecichar 0 mseciline

Device Friendly Name: USB Serial Port (COM4)

Device Instance ID: FTDIBUS\VID_0403+PID_6011+36693B\0000
Device Manufacturer: FTDI

Provider Name: FTDI

Driver Date: B-16-2017

Driver Version: 2.12.28.0

Figure 264: Setting the Parameters for the Serial Port

Note: The COM port setting is specific to the computer being used and may need to be
different than shown. Use the COM port # that was discovered in the previous step.

9. Click OK (3).

Tera Term is now configured to receive and transmit serial information to/from the evaluation
board.
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Setting the Jumpers on the ZC702 Board

The jumpers connected to the Zynqg device are read by the Stage 0 bootloader
and are used to determine where the Zyng PS boots from.

1-1. Set the jumpers on the ZC702 board based on your booting requirements.
o Boot from SD card
e JTAG communications with PC (no boot)
« Boot from QSPI
The three following topics cover these cases.

Jumper/Switch Settings ZC702 - Boot from SD Card

SD Card Boot:

J27 J28 J21 J20 J22 J25 J26

Pr— >

Figure 265: SD Card Boot Settings (ZC702 Board)
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Jumper/Switch Settings ZC702 - Boot from JTAG

JTAG Mode:

s |

gz 11" mery (m—
’

g s
Figure 266: JTAG Boot Settings (ZC702 Board)

It is worth noting that if the SD card settings are used, but no SD card is present in the socket,
then the boot mode will fall back to JTAG.

The ZC702 board has two JTAG cable options (most ATPs use option 1):

I. Digilent on-board platform cable USB interface using USB A-mini B cable: Set SW10 (i.e.
JTAG Select dip switches) on Zynq board to "01"

2. Platform USB: Set SW10 ( i.e. JTAG Select dip switches) on Zynqg board to "10".
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Jumper/Switch Settings ZC702 - Boot from QSPI

Flash Boot:

Setting the Jumpers on the ZC706 Board

1-1. Set the jumpers on the ZC706 board based on your booting requirements.
o Boot from SD card
e JTAG communications with PC (no boot)
« Boot from QSPI
The three following topics cover these cases.
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Jumper/Switch Settings ZC706 - Boot from SD Card

SD Card Boot:

Figure 268: SD Card Boot Settings (ZC706 Board)
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Jumper/Switch Settings ZC706 - Boot from JTAG

JTAG Mode:

It is worth noting that if the SD card settings are used, but no SD card is present in the socket,
then the boot mode will fall back to JTAG.

The ZC706 board has a Digilent interface option, and you can use a USB A-mini B cable.

To use this cable instead of Platform USB, make sure that the jumper settings are in JTAG
mode as mentioned above.

o Set SW4 (i.e., the JTAG select dip switches) on the board to "01", which is to select the
Digilent interface. To select Platform USB, SW4 should be "10".
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Jumper/Switch Settings ZC706 - Boot from QSPI

Flash Boot:

Figure 270: Flash Boot Settings (ZC706 Board)
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Setting the Jumpers on the ZCU102 Board

1-1.  Set the jumpers on the ZCU102 board based on your booting
requirements.

e« Boot from SD card
e JTAG communications with PC (no boot)

The following topics cover these cases.

Jumper/Switch Settings ZCU102 - Boot from SD Card

SD Card Mode:

Up

Figure 271: SD Card Boot Settings (ZCU102 Board)
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Jumper/Switch Settings ZCU102 - Boot from JTAG
JTAG Mode:

.

Down

SW6.1 SW6.2 SW6.3 SW6.4

Figure 272: JTAG Boot Settings (ZCU102 Board)

Setting the Jumpers on the ZCU104 Board

1-1. Set the jumpers on the ZCU104 board based on your booting
requirements.

o Boot from SD card
e JTAG communications with PC (no boot)
The following topics cover these cases.
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Jumper/Switch Settings ZCU104 - Boot from SD Card

SD Card Mode:

Up

Down

Jumper/Switch Settings ZCU104 - Boot from JTAG

oated

5 11{'1‘.1

JTAG Mode:
Up
Down
SW6.1 SW6.2 SW6.3 SW6.4
N NS
PmEas
ONC&K SDAOH
Figure 274: JTAG Boot Settings
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Jumper/Switch Settings ZCU104 - Boot from QSPI
Flash Boot:

Up

Down

Setting the Jumpers on the ZedBoard

1-1. Set the jumpers on the ZedBoard based on your booting requirements.
o Boot from SD card
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Jumper Settings ZedBoard - Boot from SD Card

SD Card Boot:

JP5/JP8 - JP4/JP7 -
Mode 1 Mode 0

JP6/JP9 -
Mode 2

JP8/JP11 -
Mode 4

JP7/JP10 -
Mode 3

ON/3.3V
Off/Gnd
Jumper - JP6 (shortened)
VADJ SELECT - 3V3
: o <
Figure 276: SD Card Boot Settings (ZedBoard)
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Setting Up the Hardware - KC705

Set up and connect the hardware evaluation board or verify that this has properly
been done before turning on the power.

1-1. Connect the board to your machine as shown below.

1-1-1. Connect a USB cable from a USB port on your computer to the USB UART connector
on the evaluation board.

1-1-2.  Similarly, connect the USB cable to the Digilent USB JTAG interface.
1-1-3.  Ensure that the power cord is plugged in and turn on the evaluation board.
1-1-4. Make sure that the board settings are proper.

1-1-5. Ensure that all DIP switches (SW11) are in the off position.

FMC (HPC) FMC (LPC)

User LEDs

USB UART Power Switch

Interface

& XILINX. * CW T
KNTEX” e o % n

Power Cable

USB JTAG
Interface

User DIP Switch
CPU Reset

User Push
Buttons

Kintex-7 XC7K325T-2FFG900C
FPGA (located under the fan)

Figure 277: KC705 Evaluation Board

You may be prompted to install drivers when the board is first connected. Do not allow
the driver installation to search the Web but allow it to search for the drivers on your
computer.
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Default Switch Settings

1-1. Default DIP switch for SW11 user GPIO settings.
1-1-1.  Set all the switch positions to the default settings.

ON Position = 1

o

123
GPIODIP SW N\
OFF Position = 0

SW11 Default Switch Settings

SW1A

Position Function Default
1 GPIO_DIP_SW3 Off
2 GPIO_DIP_SW2 Off
3 GPIO_DIP_SW1 Off
4 GPIO_DIP_SWO Off

Figure 278: KC705: SW11 Default Switch Settings

1-2. Default DIP switch SW 13 mode and Flash address settings.
1-2-1.  Set the switch positions to the default settings.

ON Position = 1

s
.
3

33
l
2

®
G
\OFF Position = 0
SW13 Default Switch Settings
Position Function Default
1 FLASH_A25 A25 Off
2 FLASH_A24 A24 Off
3 FPGA_M2 MO Off
4 FPGA_M1 M1 On
5 FPCA_MO M3 Off

Figure 279: KC705: SW13 Default Switch Settings
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Setting Up the Hardware - KCU105

Set up and connect the hardware evaluation board or verify that this has been
done properly before turning on the power.

1-1. Connect the board to your machine as shown below.
1-1-1. Connect a USB cable from a USB port on your computer to the USB UART connector
on the evaluation board.
1-1-2.  Similarly, connect the USB cable to the USB JTAG connector on the evaluation board.
1-1-3.  Ensure that the power cord is plugged in and turn on the evaluation board.
1-1-4. Make sure that the board settings are correct.
HDMI Dual Quad-SPI FMC1 | | FMC2
Video Output{| Flash Memory || (HPC, 8x GTHs) (LPC, 1x GTH)
[USB-UART Connector}
IUserGPIO
?IJD‘/E:OOHDDD MB/s Tri-Speed Ethernet)] §
XCVR SMAS
2x SFP + Cages
! |GTH ::;f::esnlcn:i s(:wckl PCle 2;;2 {SE:ectm JTAG Header | IXCKU040-2FFVA1155EI |(4X1E;D:F4 64-bit |
Figure 280: KCU105 Evaluation Board
AMD1 www.amd.com 227

together we advance_ © Copyright 2026 Advanced Micro Devices, Inc.



AMDA

together we advance_



	Introduction
	Understanding the Lab Environment
	Vivado Design Suite Operations
	Vivado Analyzer Operations
	Vitis Model Composer Operations
	Vitis Unified IDE Operations
	Vitis Unified IDE HLS Component Operations
	QEMU Operations
	PetaLinux Operations
	Board, OS, COM, and IP Address Tasks

